# Table of Contents

**Introduction**

**Chapter One: The Fundamentals**
- Lesson 1-1: Introduction to Databases
- Lesson 1-3: Starting Access and Opening a Database
- Lesson 1-4: Understanding the Access Program Screen
- Lesson 1-5: Using Menus
- Lesson 1-6: Using, Hiding, Displaying, and Moving Toolbars
- Lesson 1-7: Filling Out Dialog Boxes
- Lesson 1-8: Keystroke and Right Mouse Button Shortcuts
- Lesson 1-9: Opening and Modifying Database Objects
- Lesson 1-10: Working with Multiple Windows
- Lesson 1-11: Tour of a Table
- Lesson 1-12: Adding, Editing, and Deleting Records
- Lesson 1-13: Tour of a Form
- Lesson 1-14: Tour of a Query
- Lesson 1-15: Tour of a Report
- Lesson 1-16: Previewing and Printing a Database Object
- Lesson 1-17: Selecting Data
- Lesson 1-18: Cutting, Copying, and Pasting Data
- Lesson 1-19: Using Undo
- Lesson 1-20: Checking Your Spelling
- Lesson 1-21: Getting Help from the Office Assistant
- Lesson 1-22: Changing the Office Assistant and Using the “What’s This” Button
- Lesson 1-23: Using the Zoom Box
- Lesson 1-24: Closing a Database and Exiting Access

**Chapter One Review**

**Chapter Two: Creating and Working with a Database**
- Lesson 2-1: Planning a Database
- Lesson 2-2: Creating a Database Using the Database Wizard
- Lesson 2-3: Creating a Blank Database
- Lesson 2-4: Creating a Table Using the Table Wizard
- Lesson 2-5: Modifying a Table and Understanding Data Types
- Lesson 2-6: Creating a New Table from Scratch
- Lesson 2-7: Creating a Query in Design View
- Lesson 2-8: Modifying a Query
- Lesson 2-9: Sorting a Query using Multiple Fields
- Lesson 2-10: Developing AND and OR Operators
- Lesson 2-11: Creating a Form with the Form Wizard
- Lesson 2-12: Creating a Report with the Report Wizard
Lesson 2-13: Creating Mailing Labels with the Label Wizard ........................................88
Lesson 2-14: Database Object Management ................................................................90
Lesson 2-15: File Management ....................................................................................92
Lesson 2-16: Compacting and Repairing a Database ....................................................94
Lesson 2-17: Converting an Access 97 Database ........................................................95
Chapter Two Review .................................................................................................96

Chapter Three: Finding, Filtering, and Formatting Data ........................................ 103
Lesson 3-1: Finding and Replacing Information .........................................................104
Lesson 3-2: Sorting Records .......................................................................................106
Lesson 3-3: Filtering by Selection ................................................................................108
Lesson 3-4: Filtering by Form ......................................................................................110
Lesson 3-5: Creating an Advanced Filter ...................................................................112
Lesson 3-6: Adjusting Row Height and Column Width .............................................114
Lesson 3-7: Rearranging Columns ..............................................................................116
Lesson 3-8: Changing Gridline and Cell Effects .......................................................117
Lesson 3-9: Freezing a Field ......................................................................................118
Lesson 3-10: Hiding a Column ..................................................................................119
Lesson 3-11: Changing the Datasheet Font ...............................................................120
Chapter Three Review ..............................................................................................122

Chapter Four: Working with Tables and Fields .........................................................127
Lesson 4-1: Understanding Field Properties .............................................................128
Lesson 4-2: Indexing a Field .....................................................................................130
Lesson 4-3: Adding a Primary Key to a Table .........................................................132
Lesson 4-4: Inserting, Deleting, and Reordering Fields ..........................................134
Lesson 4-5: Changing a Field’s Data Type ...............................................................136
Lesson 4-6: Using Field Descriptions ......................................................................138
Lesson 4-7: Adding a Caption .................................................................................139
Lesson 4-8: Changing the Field Size .......................................................................140
Lesson 4-9: Formatting Number, Currency, and Date/Time Fields ......................142
Lesson 4-10: Formatting Number, Currency, and Date/Time Fields by Hand ....144
Lesson 4-11: Formatting Text Fields .........................................................................146
Lesson 4-12: Setting a Default Value .......................................................................148
Lesson 4-13: Requiring Data Entry .........................................................................149
Lesson 4-14: Validating Data ....................................................................................150
Lesson 4-15: Creating an Input Mask .......................................................................152
Lesson 4-16: Creating a Lookup Field .....................................................................154
Lesson 4-17: Creating a Value List ..........................................................................156
Lesson 4-18: Modifying a Lookup List ....................................................................158
Chapter Four Review ...............................................................................................160

Chapter Five: Creating Relational Databases ..........................................................165
Lesson 5-1: Understanding Table Relationships ......................................................166
Lesson 5-2: Creating Relationships between Tables .................................................168
Lesson 5-3: Enforcing Referential Integrity ..............................................................170
Lesson 5-4: Testing Referential Integrity and Printing and Deleting Table Relationships 172
Lesson 5-5: Understanding Relationship Types .......................................................174
Chapter Five Review ...............................................................................................176

Chapter Six: Working with Queries ..........................................................................179
Lesson 6-1: A Quick Review ....................................................................................180
Lesson 6-2: Understanding the Different Types of Queries .....................................181
Lesson 6-3: Creating a Multiple Table Query ........................................................182
Lesson 6-4: Creating a Calculated Field ................................................................184
Lesson 6-5: Working with Expressions and the Expression Builder .....................186
Lesson 6-6: Using an IIF Function ...........................................................................188
Introduction

Welcome to CustomGuide: Microsoft Access 2000. CustomGuide courseware allows instructors to create and print manuals that contain the specific lessons that best meet their students’ needs. In other words, this book was designed and printed just for you.

Unlike most other computer-training courseware, each CustomGuide manual is uniquely designed to be three books in one:

- Step-by-step instructions make this manual great for use in an instructor-led class or as a self-paced tutorial.
- Detailed descriptions, illustrated diagrams, informative tables, and an index make this manual suitable as a reference guide when you want to learn more about a topic or process.
- The handy Quick Reference box, found on the last page of each lesson, is great for when you need to know how to do something quickly.

CustomGuide manuals are designed both for users who want to learn the basics of the software and those who want to learn more advanced features.

Here’s how a CustomGuide manual is organized:

**Chapters**
Each manual is divided into several chapters. Aren’t sure if you’re ready for a chapter? Look at the prerequisites that appear at the beginning of each chapter. They will tell you what you should know before you start the chapter.

**Lessons**
Each chapter contains several lessons on related topics. Each lesson explains a new skill or topic and contains a step-by-step exercise to give you hands-on-experience.

**Chapter Reviews**
A review is included at the end of each chapter to help you absorb and retain all that you have learned. This review contains a brief recap of everything covered in the chapter’s lessons, a quiz to assess how much you’ve learned (and which lessons you might want to look over again), and a homework assignment where you can put your new skills into practice. If you’re having problems with a homework exercise, you can always refer back to the lessons in the chapter to get help.
How to Use the Lessons

Every topic is presented on two facing pages, so that you can concentrate on the lesson without having to worry about turning the page. Since this is a hands-on course, each lesson contains an exercise with step-by-step instructions for you to follow.

To make learning easier, every exercise follows certain conventions:

- Anything you’re supposed to click, drag, or press appears like this.
- Anything you’re supposed to type appears like this.
- This book never assumes you know where (or what) something is. The first time you’re told to click something, a picture of what you’re supposed to click appears either in the margin next to the step or in the illustrations at the beginning of the lesson.

Illustrations show what your screen should look like as you follow the lesson. They also describe controls, dialog boxes, and processes.

An easy-to-understand introduction explains the task or topic covered in the lesson and what you’ll be doing in the exercise.

Tips and traps appear in the margin.

Icons and pictures appear in the margin, showing you what to click or look for.

Clear step-by-step instructions guide you through the exercise. Anything you need to click appears like this.
When you see a keyboard instruction like “press <Ctrl> + <B>,” you should press and hold the first key (<Ctrl> in this example) while you press the second key (<B> in this example). Then, after you’ve pressed both keys, you can release them.

There is usually more than one way to do something in Access. The exercise explains the most common method of doing something, while the alternate methods appear in the margin. Use whatever approach feels most comfortable for you.

Important terms appear in italics the first time they’re presented.

Whenever something is especially difficult or can easily go wrong, you’ll see a:

**NOTE:** immediately after the step, warning you of pitfalls that you could encounter if you’re not careful.

Our exclusive Quick Reference box appears at the end of every lesson. You can use it to review the skills you’ve learned in the lesson and as a handy reference—when you need to know how to do something fast and don’t need to step through the sample exercises.

### Formatting a Worksheet

2. Click cell A4 and type Annual Sales.
   
   The numbers in this column should be formatted as currency.

3. Press <Enter> to confirm your entry and overwrite the existing information.

4. Select the cell range G5:G17 and click the Currency Style button on the Formatting toolbar.
   
   A dollar sign and two decimal places are added to the values in the selected cell range.

5. Select the cell range F5:F17 and click the Percent Style button on the Formatting toolbar.
   
   Excel applies percentage style number formatting to the information in the Tax column.

6. With the Tax cell range still selected, click the Increase Decimal button on the Formatting toolbar.
   
   Excel adds one decimal place to the information in the tax rate column.

7. With the Date cell range still selected, select Format → Cells from the menu, select 4-Mar-97 from the Type list box and click OK.

That’s all there is to formatting values—not as difficult as you thought it would be, was it? The following table lists the five buttons on the Formatting toolbar you can use to apply number formatting to the values in your worksheets.

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency</td>
<td>$1,000.00</td>
<td>Adds a dollar sign, comma, and two decimal places.</td>
</tr>
<tr>
<td>Percent</td>
<td>100%</td>
<td>Displays the value as a percentage with no decimal places.</td>
</tr>
<tr>
<td>Comma</td>
<td>1,000</td>
<td>Separates thousands with a comma.</td>
</tr>
<tr>
<td>Increase Decimal</td>
<td>1000.00</td>
<td>Increases the number of digits after the decimal point by one</td>
</tr>
<tr>
<td>Decrease Decimal</td>
<td>1000.0</td>
<td>Decreases the number of digits after the decimal point by one</td>
</tr>
</tbody>
</table>

### Quick Reference

- **To Apply Currency Formatting:**
  1. Type the dollar sign ($) before you enter a number.

### Tables

Tables provide summaries of the terms, toolbar buttons, or shortcuts covered in the lesson.

### Important Terms

- **Important terms** appear in italics the first time they’re presented.

### Formatting During Data Entry

- **Formatting during data entry** is the process of applying number formatting to a value before you enter it into a cell. This can be useful when you want to ensure that a value is formatted correctly before you enter it into a cell.

### Formatting after Data Entry

- **Formatting after data entry** is the process of applying number formatting to a value after it has been entered into a cell. This can be useful when you want to change the formatting of a value after it has been entered into a cell.

### Formatting Rules

- **Formatting rules** are the rules that determine how values are formatted in a cell. These rules can be based on the type of data in the cell, the context of the cell, or other factors.

### Formatting Options

- **Formatting options** are the options that determine how values are formatted in a cell. These options can include the number of decimal places, the number of digits, the currency symbol, or other factors.

### Formatting Buttons

- **Formatting buttons** are the buttons that allow you to apply number formatting to a value in a cell. These buttons are typically found on the Formatting toolbar.

### Formatting Functions

- **Formatting functions** are the functions that apply number formatting to a value in a cell. These functions can be based on the type of data in the cell, the context of the cell, or other factors.

### Formatting Techniques

- **Formatting techniques** are the techniques that can be used to apply number formatting to a value in a cell. These techniques can include the use of formatting functions, the use of formatting buttons, or other methods.

### Formatting Styles

- **Formatting styles** are the styles that determine how values are formatted in a cell. These styles can be based on the type of data in the cell, the context of the cell, or other factors.

### Formatting Tips

- **Formatting tips** are the tips that can be used to apply number formatting to a value in a cell. These tips can include the use of formatting functions, the use of formatting buttons, or other methods.
Welcome to your first lesson on Microsoft Access! Microsoft Access is a powerful database program you can use to store all kinds of information—from a simple list of recipes to an inventory catalog with tens of thousands of products. Once information is stored in a Microsoft Access database, it’s easy to find, analyze, and print.

Of all the programs in the Microsoft Office suite, Microsoft Access is the one that most intimidates people. “Mastering Microsoft Excel or Word was hard enough,” they think. “How can I ever understand a complicated program like Access?” While it’s true that Microsoft Access has many advanced features (there are computer consultants whose only job is programming Access databases) creating and working with a Microsoft Access database is probably a whole lot easier than you think.

With that in mind, this chapter is your introduction to Microsoft Access and the world of databases. In this chapter you will learn more about exactly what a database is, what it is used for, and how to perform simple database tasks, such as adding and deleting records. This chapter also takes you on a basic tour of various parts of a Microsoft Access database: Tables, Forms, Reports, and Queries. If you have worked with one of the other Microsoft Office applications, such as Microsoft Excel or Word, you will find that you already know a lot about the concepts covered in this chapter.

And so, without further ado, turn the page and take your first step into the world of databases.
In its simplest form, a database is a collection of information that is organized into a list. Whenever you make a list of information, such as names, addresses, products, or invoices, you are, in fact, creating a database. Technically speaking, you don’t even have to use a database program to create a database. You can make a list of information in all kinds of programs, such as Microsoft Excel, Word—even the meek and lowly Notepad program! A database program, however, is much more powerful than a simple list you keep on paper or in a Microsoft Word document. A database program lets you:

- **Store Information**
  A database stores lists of information that are related to a particular subject or purpose. A database stores personal information, such as a list of Aunt Mildred’s recipes, or business information, such as a list of hundreds of thousands of customers. A database also makes it easy to add, update, organize, and delete information.

- **Find Information**
  You can easily and instantly locate information stored in a database. For example, you can find all the customers with the last name “Johnson” or all customers who live in the 55417 zip code and are older than 65.

- **Analyze and Print Information**
  You can perform calculations on information in a database. For example, you could calculate what percent of your total sales comes from the state of Texas. You can also present information in a professional-looking printed report.

- **Manage Information**
  Databases make it easy to work with and manage huge amounts of information. For example, with a few keystrokes you can change the area code for hundreds of customers in the (612) area code to a new (817) area code.
- **Share Information**
  Most database programs (including Microsoft Access) allow more than one user to view and work with the same information at once. Such databases are called *multi-user databases*.

Databases usually consist of several parts. A Microsoft Access database may contain up to seven different database object types. The table on this page identifies the database objects you can use when creating a Microsoft Access database. Some objects you will use all the time (such as Tables), others you will hardly use (such as Modules).

<table>
<thead>
<tr>
<th>Table 1-1: Database Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Tables</td>
</tr>
<tr>
<td>Queries</td>
</tr>
<tr>
<td>Forms</td>
</tr>
<tr>
<td>Reports</td>
</tr>
<tr>
<td>Pages</td>
</tr>
<tr>
<td>Macros</td>
</tr>
<tr>
<td>Modules</td>
</tr>
</tbody>
</table>

**Quick Reference**

Databases are Used To:
- Store, Find, Analyze, Print, Manage, and Share Information.

A Microsoft Access Database can contain these Database Object Types:
1. Tables
2. Queries
3. Forms
4. Reports
5. Macros
6. Modules

If you're upgrading from Access 97 to Access 2000 you're in luck—in many respects Access 2000 looks and works *almost* the same as your trusty version of Access 97. Here's what's new:

### Table 1-1: What's New

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New Database File Format</strong></td>
<td>We may as well start off with the biggest downside of Access 2000. Unlike the other applications in the Microsoft Office 2000 suite, Access 2000 uses a new database file format. You can still read and write Access 97 databases, but it requires an extra step. For this reason, migrating from Access 97 to 2000 can be quite an undertaking for larger organizations.</td>
</tr>
<tr>
<td><strong>Personalized Menus</strong></td>
<td>Office 2000 displays only the commands that you use most often on new personalized menus and toolbars. A menu's more advanced commands are hidden from view, although you can easily expand a menu to reveal all of it's commands. After you click a command, it appears on your personalized menu.</td>
</tr>
<tr>
<td><strong>Multiple Cut, Copy, and Paste Clipboard</strong></td>
<td>Office 2000 programs share a multiple clipboard which can hold 12 copied or cut objects instead of just one. The only problem with the new clipboard is only Office 2000 programs can access all 12 copied or cut objects.</td>
</tr>
<tr>
<td><strong>See What You Have Open</strong></td>
<td>Use the Windows taskbar to switch between open Office documents—each document appears as an icon on the taskbar.</td>
</tr>
<tr>
<td><strong>Improved Office Assistant</strong></td>
<td>The Assistant uses less space on your screen, while still providing you with all the help you need. If the Office Assistant can't answer your question, it can take you to the Web for more information.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Improved User Interface</td>
<td>The Access 2000 database window makes it easier to work with components of your databases. Use the vertical Objects bar to switch between forms, tables, and reports. Organize database objects into groups, and create shortcuts to frequently used items.</td>
</tr>
<tr>
<td>Data Access Pages</td>
<td>Data Access Pages are forms and reports designed for the Web. They enable any employee to easily open, view, and update live data from the Internet or an intranet. These pages are stored as HTML files outside the Access database file, so that users who do not have Access installed can share them.</td>
</tr>
<tr>
<td>Subdatasheets</td>
<td>Allows you to see information from tables that are related to the table you are currently viewing. With subdatasheets, you can browse hierarchical data in Datasheet View.</td>
</tr>
<tr>
<td>Name AutoCorrect</td>
<td>Rename a field and the Name AutoCorrect feature changes it in all queries and forms. You can keep working without interruption.</td>
</tr>
<tr>
<td>Conditional Formatting</td>
<td>Changed the format of a field based on the value in the data in a form or report. For example, if the date in a “Due Date” field is equal to or less than the current date, you might display the date in a large red font.</td>
</tr>
<tr>
<td>Form Enhancements</td>
<td>Allow you to simply select a field on a form and change its background color, size, or border. See the changes right away without switching to Design View.</td>
</tr>
<tr>
<td>Euro Currency Symbol</td>
<td>Additional number formats are available with the Euro currency symbol.</td>
</tr>
<tr>
<td>Seamless Integration with SQL Server</td>
<td>Microsoft Access 2000 includes built-in Microsoft SQL Server™ integration that brings the power of high-end database management to the familiar Access environment.</td>
</tr>
<tr>
<td>Detect and Repair</td>
<td>If you find that your Access program is getting buggy, instead of reinstalling the entire program, you can use Office 2000’s new Detect and Repair feature to diagnose and fix the problem.</td>
</tr>
<tr>
<td>AutoCompact</td>
<td>Automatically compresses and repairs a database when the file is closed.</td>
</tr>
</tbody>
</table>
Lesson 1-3: Starting Access and Opening a Database

You start Access 2000 the same as any other Windows program—with the Start button. Because every computer is set up differently (some people like to rearrange and reorder their Program menu) the procedure for starting Access on your computer may be slightly different from the one listed here.

1. Make sure that your computer is on and the Windows desktop appears on the screen.
2. **Use your mouse to point to and click the Start Button, located at the bottom-left corner of the screen.**
   The Windows Start menu pops up.

3. **Use the mouse to move the pointer over the word Programs.**
   A menu pops up to the right of Programs. The programs and menus you see depends on the programs installed on your computer.

4. **On the Programs menu, point to and click Microsoft Access.**
   Once you click the Microsoft Access program your computer’s hard drive will whir for a moment while it loads Access. The Access program appears and displays a dialog box where you can open a database or create a new database, as shown in Figure 1-5. We don’t need to use this dialog box for now so…

5. **Click Cancel to close the Microsoft Access dialog box.**
   The Microsoft Access dialog box closes and you are left looking at an empty and somewhat intimidating screen. Most Microsoft Office applications, such as Word and Excel, start out by giving you a blank document that you can work with right away. Here Microsoft Access is very different than its Microsoft Office cousins because you really can’t do anything in Microsoft Access unless you open an existing database or create a new database. Most of the time you will open an existing database, and here’s how to accomplish this simple task.

6. **Click the Open button on the toolbar.**
   The Open dialog box appears, as shown in Figure 1-4. Now you have to tell Access where the database you want to open is located.

7. **Navigate to the folder where your practice files are located.**
   Ask your instructor if you don’t know where your practice folder is located.

8. **Find and double-click the Lesson 1 file.**
   Access opens the Lesson 1 database and displays it in the database window.

### Table 1-2: Special Folders in the Open and Save As Dialog Boxes

<table>
<thead>
<tr>
<th><strong>Heading</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="History" /></td>
<td>Displays a list of files that you’ve recently worked on.</td>
</tr>
<tr>
<td><img src="image" alt="My Documents" /></td>
<td>Displays all the files in the My Document folder—the default location where Microsoft Office programs save their files.</td>
</tr>
<tr>
<td><img src="image" alt="Desktop" /></td>
<td>Temporarily minimizes or hides all your programs so that you can see the Windows desktop.</td>
</tr>
<tr>
<td><img src="image" alt="Favorites" /></td>
<td>Displays a list of your “Favorite” folders, although these are often used to organize your favorite Web pages.</td>
</tr>
<tr>
<td><img src="image" alt="Web Folders" /></td>
<td>Displays all the files in any Web Folders—special locations to save Web pages.</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Start Microsoft Access:**
1. Click the Windows Start button.
2. Select **Programs** → **Microsoft Access**.

**To Open a Database:**
- Click the ![Open button](image) on the toolbar.
- Select **File** → **Open** from the menu.
- Press `<Ctrl>` + `<O>`. 
Lesson 1-4: Understanding the Access Program Screen

Figure 1-6
The Microsoft Access Screen.

You might find the Access 2000 program screen a bit confusing and overwhelming the first time you see it. What are all those buttons, icons, menus, and arrows for? This lesson will help you become familiar with the Access program screen. There are no step-by-step instructions in this lesson—all you have to do is look at Figure 1-6 then refer to Table 1-3: The Access Program Screen to see what everything you’re looking at means. And, most of all, relax! This lesson is only meant to help you get acquainted with the Access screen—you don’t have to memorize anything.
Table 1-3: The Access Program Screen

<table>
<thead>
<tr>
<th>Element</th>
<th>What it’s Used For</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>Displays the name of the program you are currently using (in this case, Microsoft Access) and the name of the database you are working on. The title bar appears at the top of all Windows programs.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Displays a list of menus you use to give commands to Access. Clicking a menu name displays a list of commands—for example, clicking the Format menu name would display different formatting commands.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Toolbars are shortcuts—they contain buttons for the most commonly used commands (instead of having to wade through several menus). The toolbars in Access change depending on what you are working on. The database toolbar (the toolbar currently displayed) contains buttons for the Access commands that you will use the most often, such as opening and printing databases.</td>
</tr>
<tr>
<td>Database window</td>
<td>The command center for a database, the Database window allows you to view, create, edit, and modify database objects.</td>
</tr>
<tr>
<td>Object Bar</td>
<td>The Object bar categorizes the different types of database objects. Each type of database object has its own icon. To view a type of object, click its icon on the Object bar.</td>
</tr>
<tr>
<td>Database Objects</td>
<td>Database objects are the basic components that make up a database. Database objects include tables, queries, forms, reports, macros, pages and modules.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Displays messages and feedback. The Status bar is especially important in Access, since it can give you meaningful information and messages when you are entering information into a database.</td>
</tr>
</tbody>
</table>

Don’t worry if you find some of these objects confusing at first—they will make more sense after you’ve actually used them.

One more important note about the Access program screen: We have been examining the Database window in this lesson but it is by no means the only screen that you will in encounter in Access. Just as there are several different types of database objects in Microsoft Access, there are also dozens of different program screens—something that makes Access quite different from its Microsoft Office cousins Word and Excel. You will see some of these screens as we continue this chapter’s tour of Microsoft Access.
Lesson 1-5: Using Menus

This lesson explains the one way to give commands to Access—by using the menus. Menus for all Windows programs can be found at the top of a window, just beneath the program’s title bar. In Figure 1-7 notice the words File, Edit, View, Insert, Tools, Window, and Help. The next steps will show you why they’re there.

1. **Click the word File on the menu bar.**
   A menu drops down from the word File, as shown in Figure 1-7. The File menu contains a list of file-related commands, such as New, which creates a new file, Open, which opens or loads a saved file, Save, which saves the currently opened file, and Close, which closes the currently opened file. Move on to the next step to try selecting a command from the File menu.

2. **Click the word Open in the File menu.**
   The Open dialog box appears. You don’t need to open a database quite yet, so…

3. **Click the Cancel button to close the Open dialog box.**
   Notice each of the words in the menu has an underlined letter somewhere in them. For example, the F in the File menu is underlined. Holding down the <Alt> key and pressing the underlined letter in a menu does the same thing as clicking the menu title. For example, pressing the <Alt> key and then the <F> key would open the File menu. Move on to the next step and try it for yourself.

4. **Press the <Alt> key then press the <F> key.**
   The File menu appears. Once you open a menu you can navigate through the different menus, using either the mouse or the <Alt> key and the letter that is underlined in the menu name.

   If you open a menu and then change your mind, it is easy to close it without selecting any commands. Click anywhere outside the menu or press the <Esc> key.

5. **Click anywhere outside the menu to close the menu without issuing any commands.**
   The menus in Access 2000 work quite a bit differently than in other Windows programs—even than previous versions of Access! Microsoft Access 2000 displays its menu commands on the screen in three different ways:
   - By displaying every command possible, just like most Windows programs, including earlier versions of Access, do.
• By hiding the commands you don’t use as frequently (the more advanced commands) from view.
• By displaying the hidden commands by clicking the downward-pointing arrows (/navigation) at the bottom of the menu or after waiting a couple seconds.

6. **Click the word Tools in the menu.**

The most common menu commands appear in the Tools menu. Some people feel intimidated by being confronted with so many menu options, so the menus in Office 2000 don’t display the more advanced commands at first. To display a menu’s advanced commands either click the downward-pointing (navigation) at the bottom of the menu or keep the menu open a few seconds.

7. **Click the downward-pointing arrow (navigation) at the bottom of the Tools menu.**

The more advanced commands appear shaded on the Tools menu.

If you’re accustomed to working with earlier versions of Microsoft Office you may find that hiding the more advanced commands is disconcerting. If so, you can easily change how the menus work. Here’s how:

8. **Select View → Toolbars → Customize from the menu.**

The Customize dialog box appears, as shown in Figure 1-8. This is where you can change how Access’s menus work. There are two check boxes here that are important:

• **Menus Show Recently Used Commands First:** Clear this check box if you want to show all the commands on the menus, instead of hiding the advanced commands.

• **Show Full Menus After a Short Delay:** If checked, this option waits a few seconds before displaying the more advanced commands on a menu.

9. **Click Close.**

---

**Table 1-4: Menus found in Microsoft Access**

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>File-related commands to open, close, print, and create new files.</td>
</tr>
<tr>
<td>Edit</td>
<td>Commands to copy, cut, paste, find, and replace text.</td>
</tr>
<tr>
<td>View</td>
<td>Commands to change how the screen is displayed.</td>
</tr>
<tr>
<td>Insert</td>
<td>Lists items that you can insert into a database, such as graphics and charts.</td>
</tr>
<tr>
<td>Format</td>
<td>Commands to format fonts, cell alignment, and borders.</td>
</tr>
<tr>
<td>Tools</td>
<td>Lists tools such as the spell checker and macros. You can also change the default for Microsoft Access options here.</td>
</tr>
<tr>
<td>Records</td>
<td>Commands to add, delete, sort, and filter information.</td>
</tr>
<tr>
<td>Window</td>
<td>Commands to display and arrange multiple windows (if you have more than one file open).</td>
</tr>
<tr>
<td>Help</td>
<td>Get help on using the program.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Open a Menu:**

• Click the menu name with the mouse.

Or...

• Press **<Alt>** and then the underlined letter in menu.

**To Display a Menu’s Hidden Commands:**

• Click the downward-pointing arrow (navigation) at the bottom of the menu.

Or...

• Open the menu and wait a few seconds.

**To Change How Menus Work:**

1. Select **View → Toolbars → Customize** from the menu.

2. Check or clear either the **Menus Show Recently Used Commands First** and/or **Show Full Menus After a Short Delay** options, then click **Close.**
Lesson 1-6: Using, Hiding, Displaying, and Moving Toolbars

In this lesson we move on to another very common way of giving commands to Access—using toolbars. Toolbars are shortcuts—they contain buttons for the most commonly used commands. Instead of wading through several menus to access a command, you can click a single button on a toolbar. Access displays different toolbars, depending on what you are working on. For example, when you view the Database window, Access displays the Database toolbar, which contains database object-related commands.

This lesson explains how to use toolbars and also how to hide, display, and move toolbars.

1. Position the mouse pointer over the **New button** on the toolbar (but don't click the mouse yet!).
   A Screen Tip appears over the button briefly identifying what the button is, in this case “New.” If you don’t know what a button on a toolbar does, simply move the pointer over it, wait a second, and a ScreenTip will appear over the button, telling you what it does.

2. Click the **New button** on the toolbar.
   The New dialog box appears.
3. **Click Cancel** to close the New dialog box.
When you first start Access, one toolbar—the Database toolbar—appears by default. As you work with Access, you may want to display other toolbars, such as the Web toolbar or the Formatting toolbar to help you accomplish your tasks. This lesson explains how to move Access toolbars to different positions on the screen, or how to remove them all together.

4. **Select** View → **Toolbars** from the menu.
A list of available toolbars appears, as shown in Figure 1-10. Notice that check marks appear next to the Database toolbar. This indicates the toolbar is already selected and appears on the Access screen.

5. **Select** Web from the toolbar menu.
The Web toolbar appears. Toolbars don’t have to be at the top the screen—you can move a toolbar anywhere you want.

6. **Move the pointer to the move handle [ ] at the far left side of the Web toolbar. Click and drag the toolbar to the middle of the screen, then release the mouse button.**
The Web toolbar is torn from the top of the screen and floats in the middle of the window. Notice a title bar appears above the Drawing toolbar. You can move a floating toolbar by clicking its title bar and dragging it to a new position. If you drag a floating toolbar to the edge of the program window, it becomes a docked toolbar.

7. **Click the Web toolbar's title bar and drag the toolbar up until it docks at the top of the screen.**
The Web toolbar is reattached to the top of the Access screen.

8. **Right-click any of the toolbars and select Web from the Toolbar shortcut menu.**
The Web toolbar disappears.

---

**Quick Reference**

**To Display a Toolbar Button's Description:**
- Position the pointer over the toolbar button and wait a second. A ScreenTip will appear and tell you what the button does.

**To View or Hide a Toolbar:**
- Select View → **Toolbars** from the menu and select the toolbar you want to display or hide.
- Or...
  - Right-click any toolbar or menu and select the toolbar you want to display or hide from the shortcut menu.

**To Move a Toolbar to a New Location Onscreen:**
- Drag the toolbar by its move handle (if the toolbar is docked) or title bar (if the toolbar is floating) to the desired location.
Lesson 1-7: Filling Out Dialog Boxes

Some commands are more complicated than others are. Opening a database is a simple process—you only need to select File → Open from the menu or click the Open button on the Database toolbar. Other commands are more complex, such as changing the default options for Access. Whenever you want to do something relatively complicated, you must fill out a dialog box. Filling out a dialog box is usually quite easy. If you have worked at all with Windows, you have undoubtedly filled out hundreds of dialog boxes. Dialog boxes usually contain several types of controls, including:

- Text boxes
- List boxes
- Check boxes
- Combo boxes (also called drop-down lists)

It is important that you know the names of these controls, because this book will refer to them in many lessons throughout this guide. This lesson will give you a tour of a dialog box, and explain each of these controls to you, so that you will know what they are and know how to use them.

1. **Click the word Tools from the menu.**
   The Tools menu appears. Notice the Options menu in the Tools menu is followed by ellipses (...). The ellipses indicate there is a dialog box behind the Options menu.

2. **Select Options from the Tools menu.**
   The Options dialog box appears, as shown in Figure 1-12. Some dialog boxes have so many options that they are organized and grouped on separate sheets. Such dialog boxes have several sheet tabs near the top of the dialog box. To view a sheet simply click its sheet tab.
3. **Click the Tables/Queries Tab.**
   The Tables/Queries tab appears in front of the dialog box, as shown in Figure 1-12.
   This is a more complex sheet in the dialog box and contains several different types of components that you can fill out.
   Remember: the purpose of this lesson is to learn about dialog boxes—not how to change the default options for Access (we’ll get to that later). The next destination on our dialog box tour is the text box.

   Look at the text box, located in the Default Field Sizes section of the dialog box. Text boxes are the most common dialog box components and are nothing more than the fill-in-the-blank you’re familiar with if you’ve filled out any type of paper form. To use a text box, you first select the text box by clicking it or pressing the <Tab> key until the insertion point appears in the text box, and then simply enter in the text you want into the text box.

4. **Click the Text box located under Default field sizes and replace the 50 with 70.**
   You’ve just filled out the text box—nothing to it. The next stop in our dialog box tour is the *combo box*. There’s a combo box located directly below the text box you just typed in. A combo lists several (or many) options in a small box. You must first click a combo box’s downward pointing arrow in order to display its options. Sometimes a combo box will contain so many options that they can’t all be displayed at once, and you must use the combo box’s *scroll bar* to move up or down the list.

5. **Click the Number combo box down arrow.**
   A list of numbering options appears below the combo box.

6. **Select Byte from the combo box.**
   Sometimes you need to select more than one item from a dialog box—in such cases you use the *check box* control when you’re presented with multiple choices.

7. **In the Query design section click the Output All Fields check box.**
   The last destination on our dialog box tour is the *button*. Buttons are found in every dialog box and are used to execute or cancel commands. The two buttons you’ll see the most are:
   - **OK**: Applies and saves any changes you have made and then closes this dialog box. Pressing the <Enter> key usually does the same thing as clicking the OK button.
   - **Cancel**: Closes the dialog box without applying and saving any changes. Pressing the <Esc> key usually does the same thing as clicking the Cancel button.

8. **Click the Cancel button to cancel the changes you made and close the Options dialog box.**
Lesson 1-8: Keystroke and Right Mouse Button Shortcuts

You are probably starting to realize that there are several methods to do the same thing in Access. For example, to open a database, you can use the menu (select File → Open) or the toolbar (click the Open button). This lesson introduces you to two more methods of executing commands: Right-mouse button shortcut menus and keystroke shortcuts.

You know that the left-mouse button is the primary mouse button, used for clicking and double-clicking, and it’s the mouse button that you will use over ninety-five percent of the time. So what’s the right-mouse button for? Whenever you right-click something, it brings up a shortcut menu that lists everything you can do to the object. Whenever you’re unsure or curious about what you can do with an object, right-click it. A shortcut menu will appear with a list of commands related to the object or area you right-clicked.

Right mouse button shortcut menus are an especially effective way to give commands in Access, because you don’t have to wade through several levels of unfamiliar menus when you want to do something. For this lesson, assume you want to modify the Employees form.

1. **Make sure the Forms button is selected underneath the Objects bar and position the pointer over the Employees form. Click the right mouse button.**
   A shortcut menu appears where you clicked the mouse, as shown in Figure 1-13. Notice one of the items listed on the shortcut menu is Print. This is the same Print command that you can select from the menu by clicking File → Print. Using the right mouse button shortcut method is slightly faster and usually easier to remember than using the menus in Access. If you open a shortcut menu and then change your mind, you can close it without selecting anything. Here’s how:

2. **Move the mouse anywhere outside the shortcut menu and click the left-mouse button to close the shortcut menu.**
   Remember that the options listed in the shortcut menu will be different, depending on what or where you right-clicked.
3. Position the pointer over the Database toolbar and click the right-mouse button.
   A shortcut menu listing all the toolbars you can view appears.

4. Move the mouse button anywhere outside the shortcut menu and click the left-mouse button to close the shortcut menu.
   On to keystroke shortcuts. Without a doubt, keystroke shortcuts are the fastest way to give commands to Access, even if they are a little hard to remember. They’re great time-savers for issuing frequently-used commands. To issue a keystroke-shortcut press and hold down the <Ctrl> key, press the shortcut key, and release both buttons.

5. Press <Ctrl> + <O> (the Ctrl and O keys at the same time).
   This is the keystroke shortcut to open a database and thus pressing <Ctrl> + <O> causes the Open dialog box to appear. Since you already have a database open you can close the dialog box without opening a new file.

6. Click Cancel to close the Open dialog box.
   The Open dialog box closes.

NOTE: Although we won’t discuss it in this lesson, you can change or re-map the default keystroke shortcuts for Access and assign them to execute other commands.

Table 1-5: Common Keystroke Shortcuts lists the shortcut keystrokes you’re likely to use the most in Access.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
<td>Open a database</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;W&gt;</td>
<td>Close a database</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;P&gt;</td>
<td>Print current view</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Z&gt;</td>
<td>Undo</td>
</tr>
<tr>
<td>&lt;F7&gt;</td>
<td>Check spelling</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;+&gt;</td>
<td>New Record</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;-&gt;</td>
<td>Delete record</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;C&gt;</td>
<td>Copies the selected text or object to the Windows clipboard.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;X&gt;</td>
<td>Cuts the selected text or object from its current location to the Windows clipboard.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;V&gt;</td>
<td>Pastes any copied or cut text or object in the Windows clipboard to the current location.</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;F&gt;</td>
<td>Find</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;H&gt;</td>
<td>Find and replace</td>
</tr>
<tr>
<td>&lt;Page Down&gt;</td>
<td>Next Screen</td>
</tr>
<tr>
<td>&lt;Page Up&gt;</td>
<td>Previous Screen</td>
</tr>
</tbody>
</table>

Quick Reference

To Open a Context-Sensitive Shortcut Menu:
• Right-click the object.

To Use a Keystroke Shortcut:
• Press <Ctrl> + the letter of the keystroke shortcut you want to execute.
Lesson 1-9: Opening and Modifying Database Objects

Think of the Database window as the mission control center for an Access database. You use the Database window to open, modify, and manage all the different types of objects in a database. The Database window contains tabs for each type of database object described in Table 1-6: Database Objects. To display a type of object click the appropriate tab.
1. **Click the Forms icon on the Objects bar.**
Access displays all the forms in the database. To open a database object either select the object and click the Database window’s Open button or double-click the object.

2. **Double-click the Employees form.**
The Employees form appears in its own window. We’ll take a closer look at forms later on, so go to the next step and close the form window.

3. **Close the Employee form by clicking its Close button.**
You can modify any database object by opening it in Design View. Design View displays the structure of a database object and allows you to make changes to it. You don’t have to know how to make changes to a database object yet, but knowing how to open an object in Design View is useful. Here’s how to open an object in Design View:

4. **Click the Employees form to select it and then click the Design button.**
The employee form opens in Design View. Now you can see the structure of the employee form object and even make changes to the form (don’t worry—we won’t be covering that topic for quite a while!).

5. **Close the Employee form by clicking its Close button.**
When you work with database objects you may find that you need to change how you view information on the screen. You can display database objects using one of four view modes: Large Icons, Small Icons, List, or Details. Figure 1-16 illustrates each of these four views. List view is the default view—and it’s usually the best way to view database objects—but there are times when you may want to change views. For example you might want to use Details view to see when an object was created.

6. **Click the View buttons on the toolbar of the smaller window to display each of the four views shown in Figure 1-16, then return to List View.**

Here—once more for your viewing pleasure—are the types of database objects.

### Table 1-6: Database Objects

<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Tables Icon]</td>
<td>Tables store a database’s data in rows (records) and columns (fields). For example, one table could store a list of customers and their addresses while another table could store the customers’ orders. A database must always contain at least one table where it can store information—all the other database objects are optional.</td>
</tr>
<tr>
<td>![Queries Icon]</td>
<td>Queries ask a question of data stored in a table. For example, a query might only display customers who are from Texas.</td>
</tr>
<tr>
<td>![Forms Icon]</td>
<td>Forms are custom screens that provide an easy way to enter and view data in a table or query.</td>
</tr>
<tr>
<td>![Reports Icon]</td>
<td>Reports present data in a table or query in a printed format.</td>
</tr>
<tr>
<td>![Pages Icon]</td>
<td>A special type of Web page designed for viewing and working with Microsoft Access data from an intranet or over the Internet.</td>
</tr>
<tr>
<td>![Macros Icon]</td>
<td>Macros help you perform routine tasks by automating them into a single command. For example, you could create a macro that automatically opens and prints a report.</td>
</tr>
<tr>
<td>![Modules Icon]</td>
<td>Like macros, Modules automate tasks, but by using a built-in programming language called Visual Basic or VB. Modules are much more powerful and complex than macros.</td>
</tr>
</tbody>
</table>
Lesson 1-10: Working with Multiple Windows

One of the many benefits of working with Windows is that you can open and work with several windows at once. Working with multiple windows is particularly important in Access, because each database object you open appears in its own window, and you will often have to switch between those windows. The Database window always remains open—closing the Database window closes the current database.

This lesson explains how to open and work with more than one window. You will also learn some tricks for changing the size of a window, moving a window, and arranging a window.

1. **Click the Tables icon on the Objects bar to display the tables in the current database.**
   Access displays all the tables in the current database.

2. **Open the Employees Table.**
   Remember to open any database object you can select the object and click the Open button in the Database window or else just double-click the database object.
   The Employees table appears in its own window. The Database window is still open too, although you may not be able to see it because it’s behind the Employees table window.
   One of the big changes in Access 2000 is that each open window appears as an icon in the Windows taskbar, as shown in Figure 1-18. To switch to a different document click its icon on the taskbar.

3. **Click the Lesson 1: Database icon on the Windows taskbar.**
   The Database window appears. The Employees table window is still open, but you can’t see all of it because it is located behind the Database window.
   Sometimes it can be helpful to view two or more windows on screen at the same time. When you want to do this you use the Window command to select a tile option. Move on to the next step to try this for yourself.
4. Select **Window → Tile Horizontally** from the menu.
Both windows—the Database window and the Employees: Table window—can be viewed on top of one another, as shown in Figure 1-18 (Your screen may show the windows in reverse order). Sometimes it’s useful to look at more than one window at a time. Notice how the Title Bar for the Employees: Table window is a different color than the Database window? That’s because the Database window is **active**, meaning it’s the window or document you’re currently working on. The other window, Employees: Table, is inactive.

5. Click anywhere in the **Employees: Table window**.
The Employees: Table window becomes active and the Database window becomes inactive.
To make working with several windows at once easier, you can change the size of the windows. You can **maximize** or enlarge a window so it takes up the document window.

6. Click the **Maximize button** in the Employees: Table window title bar.
The Employees: Table window maximizes and fills the entire screen. You can change a maximized window back to its original size by clicking the Restore button, which replaces the Maximize button whenever a window is maximized.

7. Click the **Restore button** in the Employees: Table window title bar to restore the Employees: Table window to its previous size.
Make sure you click the lower Restore button—the Restore button for Employees: Table window, and not the Restore button for the Access program. The window returns to its previous size.
You can also manually fine-tune a window’s size to meet your own specific needs. A window must not be in a maximized state if you want to manually size it.

8. Position the mouse pointer over the bottom edge of the Employees: Table window, until it changes to a ↓.
The two arrows point in the directions, indicating that you can drag the window’s border up or down.
**NOTE:** The mouse is very picky about where you place the pointer, and sometimes it can be a little tricky finding the exact spot where the pointer changes.

9. While the ↓ pointer is still over the bottom edge of the window, click and drag the mouse up a half-inch to move the window border, and release the mouse button.
Notice the window border follows as you drag the mouse. When the window is the size you want, you can release the mouse button. You just resized the window by adjusting the bottom edge of a window, but you can also adjust the left, right, and top edges of a window.
Sometimes when you have more than one window open at once, you may find that one window covers another window or other items on your screen. When this happens, you can simply move the window to a new location on the screen—just like you would move a report or folder to a new location on your desk.

10. Click and drag the **title bar** of the Employees: Table window to a new location on the screen. Release the mouse button to drop the window.
Remember that the title bar is at the top of the window or program, and displays the name of the program or window. An outline of the window follows your mouse as you drag the window, showing you where you are moving it.

11. Close the Employees: Table window.
Lesson 1-11: Tour of a Table

Tables are the heart and soul of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, and macros—are merely tools to analyze and manipulate the information stored in a table. Any of these other database objects are optional—but without tables a database wouldn’t be a database. Each table in a database stores related information. Most databases have more than one table: each table is used to store a different type of information. For example, one table might contain a list of customers and their addresses, while another table might contain any orders placed by the customers, while yet another table might contain a list of products.

Tables are made up of groups of fields. A field is a specific type of information, such as a person’s last name, address, or phone number. Together, the related fields for each individual person, place, or thing make up a single record. If your company has ten employees, your employee table would have ten records—one for each employee.

Here’s how to open and view a table:

1. Click the Tables icon in the Database window Object bar.

Access lists all the tables in the current database.
2. Click the Employees table to select it and then click the Open button in the database window.

   The Employee table opens in its own window, as shown in Figure 1-19. If you are working on a table you will usually want to maximize the window so that you can see as much information as possible.

3. Click the window’s Maximize button.

   The table window expands to fill the entire screen. Table information is displayed, entered, and modified in a datasheet. A datasheet is a grid that contains all the records in a table. Records are stored in rows and field names are stored in columns, as shown in Figure 1-19.

   Let’s take a closer look at the current table. First notice the that appears to the left of the first record in the table. This is the record selector and it shows the record that you are currently working on.

   Next, take a look at the Record Navigation buttons near the bottom of the screen, as shown in Figure 1-20. The record navigation buttons display the number of records in the current database and allow you to move between these records.

4. Click the Next Record button on the Record Navigation bar.

   Access moves to the next record in the table. Notice that the record selector moves to the next record and that the Record Navigation area indicates that you are currently viewing record 2.

5. Click the Last Record button on the Record Navigation bar.

   Tables will often contain too much information to display on the screen at once and you will have to use the vertical scroll bar (see Figure 1-21) to move up or down and/or the horizontal scroll bar to move left or right. Since the current database only contains 9 records, Access can display all of them on the screen at once, however you will still need to use the horizontal scroll bar in order to see all of the table’s fields.

6. Click the Scroll Right button on the horizontal scroll bar at the bottom of the screen to view to scroll to the right.

   The screen scrolls to the right, displaying previously hidden fields.

This ends the first half of our table tour. In the next lesson you’ll learn how to add, edit, and delete a table’s records.

### Table 1-7: Table Navigation

<table>
<thead>
<tr>
<th>To Move To:</th>
<th>Navigation Buttons</th>
<th>Keyboard</th>
<th>Mouse</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Next Record</td>
<td>Click the Record Navigation button</td>
<td>Press the ↓ (down arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>The Previous Record</td>
<td>Click the Record Navigation button</td>
<td>Press the ↑ (up arrow) key.</td>
<td>Click the record you want to select (if displayed).</td>
</tr>
<tr>
<td>The Last Record in the Table</td>
<td>Click the Record Navigation button</td>
<td>Press &lt;Ctrl&gt; + &lt;Page Down&gt;.</td>
<td>N/A</td>
</tr>
<tr>
<td>The First Record in the Table</td>
<td>Click the Record Navigation button</td>
<td>Press &lt;Ctrl&gt; + &lt;Page Up&gt;.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

---

### Quick Reference

- **To Open a Table:**
  - Click the Tables icon in the Object bar and double-click the table or select the table and click Open.

- **To Move to the Next Record:**
  - Click the Next Record Navigation button, or press the ↓ key, or click the record you want to select.

- **To Move to the Previous Record:**
  - Click the Previous Record Navigation button, or press the ↑ key, or click the record you want to select.

- **To Move to the Last Record in a Table:**
  - Click the Last Record Navigation button or press <Ctrl> + <Page Down>.

- **To Move to the First Record in a Table:**
  - Click the First Record Navigation button or press <Ctrl> + <Page Up>.
Lesson 1-12: Adding, Editing, and Deleting Records

You can easily add, change, or delete the records in your table. For example, you might want to add a record to store information about a new employee, change an existing record when an employee’s address changes, or delete a record for an employee who no longer works for the company. This lesson explains how to do all three of these tasks.

First, here’s how to add a record to a table:

1. **Click the New Record button on the Record Navigation bar.**
   The record indicator jumps to the blank row at the end of the table and the blinking insertion point ( | ) appears in the first LastName field.

2. **Enter your last name in the LastName field.**
   If you make a mistake you can press the Backspace key to correct it.
   Once you have finished entering data into a field you can press <Tab> or <Enter> to move to the next field or <Shift> + <Tab> to move to the previous field.

3. **Press <Tab> to move to the next field and enter your first name.**
   Getting the hang of this data entry stuff? Move on to the next step and finish entering the new record.

4. **Complete the record by entering your own information into each respective field (enter today’s date for the hire date). Remember to press <Tab> to move to the next field.**
   Finish entering all that information? Super! When you enter data, you don’t have to click a Save button to save the information—Access automatically saves the information as you enter it. Neat, huh?
You can also make changes to the records in a table at any time. To edit a record, simply click the field you want to edit and make the changes. Let’s try it!

5. **Position the mouse over the left edge of the Title cell (the pointer changes to a ✴️) and then click to select the cell.**
   When a cell has been selected, anything you type will replace the original contents.

6. **Type Inside Sales Coordinator.**
   The text “Inside Sales Coordinator” replaces the original contents of the Title field.
   You might want to glance at Table 1-8: Helpful Editing Keys, which lists several keys that are very important for editing and changing the contents of a field.

7. **When you have finished making the changes press <Tab>.**
   You can permanently delete records that you no longer need from a table. Here’s how:

8. **Place the insertion point anywhere in the record you just added and click the Delete Record button on the toolbar.**
   The record disappears and a warning dialog box appears, asking you to confirm the deletion.

9. **Click Yes to confirm the deletion and then close the table.**
   Congratulations! While it may not seem like you have gone over very much, you have just learned the ins and outs of data entry with Access—the most important (and boring) database task of all!

### Table 1-8: Helpful Editing Keys

<table>
<thead>
<tr>
<th>Key(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Tab&gt; or &lt;Enter&gt;</td>
<td>Moves to the next field in the table. If you’re at the last field or cell in a table pressing &lt;Tab&gt; or &lt;Enter&gt; will save your changes and move to the first field in the next record.</td>
</tr>
<tr>
<td>&lt;Esc&gt;</td>
<td>The &lt;Esc&gt; or Escape key is the “Wait, I’ve changed my mind” key. Press &lt;Esc&gt; to cancel any changes you’ve made to a record.</td>
</tr>
<tr>
<td>Up, Down, Left, Right keys</td>
<td>Use the arrow keys to move between fields and records. If you are editing a field, pressing the left and right arrow keys will move the insertion point one character to the left or right.</td>
</tr>
<tr>
<td>&lt;Delete&gt;</td>
<td>Nothing surprising here. The &lt;Delete&gt; key deletes or erases whatever is selected—text, cell contents—even entire records. If you’re working with text, the &lt;Delete&gt; key erases characters to the right of the insertion point.</td>
</tr>
<tr>
<td>&lt;Backspace&gt;</td>
<td>Use the &lt;Backspace&gt; key to fix your typing mistakes—it erases characters to the left of the insertion point.</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Add a New Record:**
1. Click the 📌 New Record navigation button.
   Or...
   Click the 📌 New Record button on the toolbar.
   Or...
   Press <Ctrl> + <>.  
2. Enter the record information for the field, pressing <Tab> to move to the next field and <Shift> + <Tab> to move to the previous field.

**To Edit a Record:**
- Click the field you want to edit and make the changes.

**To Delete a Record:**
- Place the insertion point anywhere in the record and click the 🗑️ Delete Record button on the toolbar.
Adding, viewing, and modifying information in a database should be straightforward and easy. Yet information in a table is often difficult to understand and manage. Access solves this problem by using forms to display table and query information. The forms in Access are actually quite similar to the ordinary paper form you fill out with a pen or pencil. Access forms have several major advantages over the traditional paper forms, however—they save you time, effort, and paper. Not to mention not having to worry about trying to read poor penmanship!

Forms can include fill-in-the-blank fields, checkboxes, lists of options—even information and prompts to help users complete the form. Forms can also contain buttons that allow you to perform other actions, such as running macros to print reports or labels. Forms can even validate data entry by automatically checking your entries for errors.

This lesson will give you a brief overview of the ins and outs of working with forms.

1. **Click the Forms icon in the Objects bar in the Lesson 1: Database window.**
   Access lists all the forms in the current database.

2. **Double-click the Employees form.**
   The Employee form opens in its own window, as shown in Figure 1-23. You should already be familiar with some of the items on the form, such as the Record Navigation buttons located at the bottom of the screen. As with tables, the Record Navigation buttons are used to move between records.
3. **Click the Next Record Navigation button.**
   Access moves to the next record. The Employees form displays information from the Employees table, one record at a time.

4. **Practice using the form Navigation buttons to move through the various records in the Employees table.**
   You can usually add new records to a form’s underlying table. The procedure for adding a new record with a form is virtually the same as adding a new record to a table.

5. **Click the New Record button on the Record Navigation bar.**
   A blank form appears, ready to accept your information.

6. **Enter your last name in the LastName field.**
   Just as with tables, once you have finished entering data into a form’s field you can press <Tab> or <Enter> to move to the next field or <Shift> + <Tab> to move to the previous field.

7. **Press <Tab> to move to the next field and enter your first name.**

8. **Complete the record by entering your own information into each respective field (enter today’s date for the hire date). Remember to press <Tab> to move to the next field.**
   When you enter data you don’t have to click a Save button to save the information—Access automatically saves the information as you enter it. When you have finished entering the record you can close the form, click the New Record button to enter another record, or use the Record Navigation buttons to view another record.

**NOTE:** The simple form used in this exercise contains only fill-in-the-blank style text fields. Some forms are more complex and may contain lists, combo boxes, check boxes—even sub-forms! If you are unfamiliar with these controls you might want to review the Dialog box lesson, presented earlier in this chapter.

You can also delete records using a form. The procedure for deleting records in a form is no different than deleting them from a table.

9. **Make sure the record you just added appears in the form and click the Delete Record button on the toolbar.**
   The record disappears and a warning dialog box appears, asking you to confirm the deletion.

10. **Click Yes to confirm the deletion.**
    Access deletes the record from the Employees table.

11. **Close the Employees form window.**
Lesson 1-14: Tour of a Query

Webster’s definition of a query is:

**Que-ry**
1. A question; an inquiry.
2. A doubt in the mind; a mental reservation.
3. A notation, usually a question mark, calling attention to an item in order to question its validity or accuracy.

In its simplest form, a query in Access is no different than this definition—well, the first one, anyway. Queries ask a question of the information in a table and then retrieve and display the results. For example, if you wanted to know which employees had worked for the company for more than five years, you could create a query to examine the contents of the HireDate field to find all the records in which the hire date is more than five years old. Access would retrieve the information that meets your criteria and displays it in a datasheet.
Here’s how to open and run a query:

1. **Click the Queries icon in the Objects bar.**
   Access lists all the queries in the current database.

2. **Double-click the USA Employees query.**
   The USA Employees query opens in its own window, as shown in Figure 1-25. This query asks the Employee table “Which employees are from the USA?” and then displays the results in a datasheet. The information displayed in the USA Employees query isn’t a duplication of the data in the Employees table—just another way of looking at it.

   You have probably already noticed that the layout of the USA Employees query doesn’t look any different than a table—records appear in rows, fields appear in columns, and the Record Navigation buttons appear at bottom of the window. Some queries even allow you to add, edit, and delete records to and from the underlying tables (as is the case with this query).

   So how do queries work their magic? Let’s take a “behind-the-scenes” look at the USA Employees query in **Design View**.

3. **Click the View button on the toolbar.**
   Access displays the USA Employees query in Design View, as shown in Figure 1-26. In Design View you can see a query’s underlying tables, which fields are included in the query, and the criteria used to specify which records to display.

   Here you can see that the underlying table for this query is the Employees table, which appears in the upper portion of the Design View window. You can also see that three field names—LastName, FirstName, and Country—appear in the design grid below. These are the fields that are included in the query. Notice "USA" appears in the Criteria row below the Country field. The query displays only the records that meet the criteria entered in this row. This query filters only those employees whose Country field equals "USA".

   Let’s try changing this query’s criteria and see what happens…

4. **Select the "USA" text in the criteria box and replace it with "UK".**
   Now the query will display only employees from the UK. Let’s return to **Datasheet View** and see the new query results. To switch back to Datasheet View simply click the View button on the toolbar.

5. **Click the View button on the toolbar.**
   Access displays the results of the query in Datasheet View. This time instead of displaying employees from the USA the query uses the new criteria and displays employees from the UK.

6. **Close the USA Employees window.**
   Because you made changes to the USA Employees query a dialog box appears asking if you want to save your changes.

7. **Click No.**
   The USA Employees query used in this exercise is about as simple as queries can get. Queries can ask much more detailed and complex questions of tables, such as “What were the totals of last month’s sales, by region?” or “Which sales representatives had higher than average sales?” or “Which customers have purchased our meteorite protection coverage option for their car insurance?” For now though, you have a good understanding of what queries are and what they can do for you.
Lesson 1-15: Tour of a Report

Managers like paper. Don’t try explaining anything to them—they’ll want to see it in printed hardcopy first. Fortunately, with a Report you can print database information from tables and queries and satisfy the demands of even the most paper-hungry supervisor. Although you can print table and query information directly from their datasheets, reports give you many more formatting and display options. Reports can be a simple list of records in a table, or complex presentations that include calculations, graphics—even charts!

Reports are the most static of all the database objects. Unlike tables and forms, which allow user interaction, reports just sit there, waiting to be printed.

This lesson is your report primer. You won’t get a chance to actually create a report in this lesson, but you will get a chance to look at an existing report. Here’s how to open a report:

1. **Click the Reports icon in the Objects bar.**
   Access lists all the reports in the current database.

2. **Double-click the Employee List report.**
   The Employee List report opens in its own window, as shown in Figure 1-27. Reports open in Print Preview mode by default so that you can see how they will look when printed.
   You can enlarge the report by clicking the area you want to magnify with the pointer.

3. **Move the pointer over an area of the report that contains data and click the mouse button.**
   Access magnifies the selected area. Once you have seen an enlarged area, you can zoom back out to see the overall page.
4. Move the \( \text{ } \) pointer over any area of the report and click the mouse button.

The report returns to the previous preview size.

If a report contains more than one page you can use the vertical scroll bar or \(<\text{Page Up}>\) and \(<\text{Page Down}>\) keys to scroll through the pages of the report.

Reports wouldn’t be very valuable if they couldn’t be printed. To print a report simply click the Print button on the toolbar. We’ll skip printing the report for now, unless you want to see for yourself that the report will print when you click the Print button.

5. Click the Close button to close the report.
Lesson 1-16: Previewing and Printing a Database Object

Most database objects—tables, forms, queries, and reports—and the information they contain can be printed. Sometimes it’s a good idea to preview a database object on screen to see if something needs to be changed before sending it to the printer. You can preview a database object by clicking the Print Preview button on the toolbar.

1. **Click the Tables Icon in the Objects bar.**
   Access lists all the tables in the database.
2. **Double-click the Employees table.**
   The Employee table appears in its own window.

3. **Click the Print Preview button on the toolbar.**
   The datasheet is previewed on the screen, as shown in Figure 1-29. You can enlarge the datasheet by clicking the area of the datasheet you want to magnify with the \( \mathbin{\mathbb{Q}} \) pointer.

4. **Move the \( \mathbin{\mathbb{Q}} \) pointer over an area of the datasheet that contains data and click the mouse button.**
   Access magnifies the selected area. Once you have seen an enlarged area, you can zoom back out to see the overall page again.

5. **Move the \( \mathbin{\mathbb{Q}} \) pointer over any area of the datasheet and click the mouse button.**
   The datasheet returns to the previous size.

6. **Select File → Print from the menu.**
   The Print Dialog box appears, as shown in Figure 1-30. The Print Dialog box allows you to specify printing options such as which pages to print and the number of copies you want printed. Table 1-9: Print Dialog Box Options describes the options listed in the Print dialog box.
   Normally you would click the dialog box’s Print button to print, however we are going to save the paper and close the Print dialog box without printing.

7. **Click Cancel.**
   Access closes the Print dialog box without printing anything.
   
   **NOTE:** You can also print by clicking the Print button on the toolbar or by pressing \(<\text{Ctrl}> + <\text{P}>.\) (Actually, this is the method you’ll usually use to print something.)

8. **Click Close to close the Print Preview window.**

<table>
<thead>
<tr>
<th><strong>Table 1-9: Print Dialog Box Options</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Print option</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Properties</td>
</tr>
</tbody>
</table>
| Page range | Allows you to specify which pages you want printed. There are several options: 
- **All:** Prints the entire document. 
- **Selection:** Prints only the text you have selected (before using the print command). 
- **Pages:** Prints only the pages of the file you specify. Select a range of pages with a hyphen (like 5-8) and separate single pages with a comma (like 3,7). |
| Number of copies | Specify the number of copies you want to print. |
Lesson 1-17: Selecting Data

Figure 1-31
How to select text using the mouse.

Figure 1-32
To select multiple records, position the pointer over the area to the left of the first record you want to select, then click and drag down until all the records you want to select are highlighted.

Often, before you can do anything in Access, you must select the data that you want to work with. Many common tasks, such as editing, formatting, copying, cutting, and pasting all require you to know how to select information in Access. The procedure for selecting text in Access is no different than selecting text in any other Microsoft Office program, so hopefully this lesson will be an easy review for you.

1. If it isn't already open, open the Employees table.

2. In the Janet Leverling record, find and click the Address field, then click and drag the mouse across the words Moss Bay Blvd. as shown in Figure 1-31. When you’re finished, release the left-mouse button.

The words “Moss Bay Blvd.” should be highlighted in black, as shown in Figure 1-31. Selecting text with the mouse can be a little tricky for some people, especially if you don’t have much experience using the mouse. While text is selected, anything you type replaces the existing selected text.

3. Type East River Road.

The phrase “East River Road” replaces the selected text “Moss Bay Blvd”.

You can also select an entire record or even groups of records in a table. Here’s how:
4. **Click the record selector for the Janet Leverling record** (will change to ➡) to select the record.
   
   To select multiple records, position the pointer to the left of the first record and then drag the ➡ mouse pointer down until you have highlighted all the records you want to select.

5. **Position the pointer over the record selector for the Janet Leverling record** (will change to ➡), then click and drag the ➡ pointer down to the Andrew Fuller record selector.
   
   You have highlighted the first few records in the table.
   
   The procedure for selecting a field or column is almost the same as selecting a row—just click the field name that you wish to select.

6. **Position the mouse over the FirstName field name** (changes to ↓) and click to select the column.
   
   The FirstName field is selected.

7. **Click anywhere in the datasheet to de-select the text.**
   
   The FirstName field no longer selected.

That’s all there is to selecting data in Access. The importance of knowing how to select text and records can’t be stressed enough. Knowing how to select text will make you more proficient and skillful at editing and formatting data.

Table 1-10: Data selection shortcuts describes several shortcut techniques you can use to select data in Microsoft Access.

<table>
<thead>
<tr>
<th>To select</th>
<th>Do this</th>
<th>Visual Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>A word</td>
<td>Double-click anywhere in the word.</td>
<td></td>
</tr>
<tr>
<td>A cell</td>
<td>Position the mouse over left edge of the cell you want to select (changes to ➡) and click to select the cell.</td>
<td></td>
</tr>
<tr>
<td>A record or row</td>
<td>Position the mouse over the record selector (changes to ➡) and click to select the record.</td>
<td></td>
</tr>
<tr>
<td>A field or column</td>
<td>Position the mouse over the name of the field you want to select (changes to ↓) and click to select the field.</td>
<td></td>
</tr>
<tr>
<td>The entire table</td>
<td>Click the empty box (□) to the left of the field names.</td>
<td></td>
</tr>
</tbody>
</table>

You can also select text using the keyboard by pressing and holding the <Shift> key while using the arrow keys to select the text you want.

To de-select text, point the mouse and click anywhere in the document.

### Quick Reference

**To Select Text:**

1. Move the insertion point to the beginning or end of the text you want to select.
2. Click and hold the left mouse button and drag the insertion point across the text then release the mouse button once the text is selected.

**To Replace Text:**

- Replace text by first selecting it and then typing the new text you want.

**To Select Cells, Records, Fields, and Tables:**

- Refer to Table 1-10: Data selection shortcuts.
Lesson 1-18: Cutting, Copying, and Pasting Data

You already know how to select database data. Once you have selected some text, a cell, a record—just about any database object—you can cut it, removing it from its original location, and then paste it in another location. Copying is similar to cutting, except the information is duplicated instead of removed. Whenever you cut or copy something, it is placed in a temporary storage area called the Clipboard. The Clipboard is available to any Windows program, so you can cut and paste between different programs.

In Microsoft Access you can cut, copy, and paste any of the following items:

- Text
- Records
- Database objects (such as tables, queries, forms, and reports)
- Controls (such as text boxes and labels on forms and reports)

This lesson will give you some practice copying and pasting text and objects in Access.
1. If it isn’t already open, open the **Employees table**.

First you have to select the information you want to cut or copy.

2. **Find and select the Title field for the Steve Buchanan record (it should contain Sales Manager)**.

You want to copy the text “Sales Manager” to the clipboard so you can paste it to a different record. There are several different ways to copy something—we’ll look at all of them. Try out each method and then use the method you like best.

3. **Click the Copy button on the toolbar**.

Nothing appears to have happened, but Access has just copied the selected “Sales Manager” text to the Windows clipboard. Now you must move the cell pointer to the destination where you want to paste the copied text.

4. **Find and select the Title field for the Janet Leverling record (it should contain Sales Representative)**.

This is where you want to paste the copied text. There are several ways to paste information from the Windows clipboard. Here’s one of them:

5. **Click the Paste button on the toolbar**.

The copied text is pasted into the selected Title field, replacing its original contents. Access still keeps the copied information in the Clipboard so you can paste it again in other locations. Try pasting the copied information in another record.

6. **Find and select the Title field for the Michael Suyama record (it should contain Sales Representative)**. **Click the Paste button on the toolbar**.

The copied information is pasted in the selected field.

Now that you’re familiar with copying, let’s try cutting some text.

7. **Find and select the HireDate field for the Robert King record (it should contain 1/2/1994)**.

This time we’ll cut or remove the information from this cell instead of copying it.

8. **Click the Cut button on the toolbar**.

This time the contents of the cell disappear as they are removed or “cut” from their original location into the Windows clipboard.

**NOTE:** Select only the text in the cell, not the entire cell or the Cut button will be unavailable to you.

9. **Find and select the HireDate field for the Anne Dodsworth record (it should contain 11/15/1994)**. **Click the Paste button on the toolbar**.

Access pastes the copied Hire Date in the selected field.

You can also copy, cut, and paste text between two different Windows programs—for example, you could copy information from an Excel worksheet and paste it in an Access table. The toolbar buttons, menus, and/or keyboard shortcuts for the cut, copy, and paste commands you learned in Access will work with most Windows applications.

If you are entering a lot of records that are nearly identical, you can also copy and paste entire records to create existing records quickly. After copying and pasting, you can edit the new record quickly to make a few changes. To copy a record select the record’s row selector, copy the record, select an empty row for the new record and then paste the copied record.
Lesson 1-19: Using Undo

You may not want to admit this, but you’re going to make mistakes when you use Access. You might accidentally delete a record you didn’t mean to delete, or paste something you didn’t mean to paste. Fortunately, Access has a wonderful feature called undo that does just that. It undoes your mistakes and actions, making it seem as though they never happened. This lesson explains how you can undo both single and multiple mistakes, and how to redo your actions in case you change your mind.

It’s important to note that the Undo feature in Access isn’t nearly as powerful as it is in other Microsoft Office programs. In Microsoft Access 2000, Undo will only reverse the last action or command you made. If you make a mistake and don’t catch it right away, chances are you won’t be able to use Undo to correct it. If that weren’t bad enough, Access can’t even undo many actions! For example if you delete a record and then decide you want to use Undo to retrieve the record, you’re out of luck. (To its credit Access does warn you whenever you delete a record that you will not be able to use Undo to bring it back.) Hopefully Microsoft will fix these problems in the next version of Access.

Here’s how to use Undo:
1. If it isn't already open, open the Employees table.
   First we need to make a “mistake” that we can undo…

2. Find the Robert King record. Change Robert's LastName from King to Queen.
   Don’t remember how to edit a record? Click the left edge of Robert King’s LastName cell to select it and type “Queen.” Press <Tab> when you’re finished.
   The Robert King is now Robert Queen. Whoops! Somebody’s played a joke on you—better change Robert’s last name back to “King” before he sees it. Here’s how you can undo your “mistake.”

3. Click the Undo button on the toolbar.
   Poof! The LastName field changes back to the original “King.” That’s all there is to using Undo in Access.

Quick Reference
To Undo Your Last Action:
- Click the Undo button on the toolbar.
- Select Edit → Undo from the menu.
- Press <Ctrl> + <Z>.
Lesson 1-20: Checking Your Spelling

Spell check used to be a feature only available in word processing programs—but no more! You can use the spell checker in Access to find and correct any spelling errors that you might have made in your tables and forms. The spell checker in Access is shared and used by the other programs in the Microsoft Office suite, so any words you add to the custom spelling dictionary in one Microsoft Office program will be available to the other Microsoft Office programs.

Unfortunately, spell check in Access is not nearly as useful as it is in a word processor. Most databases contain names, addresses, and information the spell checker may not recognize. When this happens click either Ignore to ignore the word, or Add to add the word to the custom spelling dictionary.

1. **If it isn't already open, open the Employees table.**
   Access will start checking the spelling of the words in a table where the cursor is located and will stop whenever it encounters a word that is not found in its dictionary. Before we start spell check, let’s move to the very beginning of the table.

2. **Press <Ctrl> + <Home> to move to the very beginning of the table.**
   Access selects the first field in the first record of the table. Here’s how to use spell check:

3. **Click the Spelling button on the toolbar.**
   The Spelling dialog box appears, as shown in Figure 1-35. Because it can’t find the word “Leveling” in its dictionary, Access flags it as possible spelling error. Obviously Access is going to have problems checking the spelling of the LastName field. Instead of having to click “Ignore” for each and every last name Access doesn’t recognize, you can tell Access to ignore the entire last name field.

---

**Figure 1-35**
The Spelling dialog box.

**Figure 1-36**
The spell check complete dialog box.
4. **Click Ignore ‘LastName’ Field** to ignore all text in the LastName field.
   Access ignores the LastName field and continues looking for words that aren't in its spelling dictionary. The next word Access flags, “Concordia,” is the correctly spelled name of a school, so you can tell Access to ignore this word.

5. **Click Ignore All to ignore all occurrences of the word “Concordia” in the table.**
   Access continues looking for words that aren't in its spelling dictionary. The next word Access flags, “Edgeham” is the correctly spelled name of a street.

6. **Click Ignore All to ignore all occurrences of the word “Edgeham” in the table.**
   Access ignores the “error” and continues looking for words that aren’t in its spelling dictionary.
   The spell checker moves on and selects the word “Londan” as the next misspelled word in the table. Finally a legitimate misspelling! Access lists a possible suggestion for the correct spelling of the word.

7. **Click London in the Suggestions list and click Change.**
   Access makes the spelling correction for you.
   The remainder of the of the words in the Employee table are spelled correctly, so you can safely ignore them.

8. **Continue with the spell check, ignoring the remainder of the flagged words.**
   When the spell checker can’t find any more incorrectly spelled words, Access will indicate the spelling check is complete by displaying the dialog box shown in Figure 1-36.

9. **Click OK.**
10. **Close the Employees table.**
    After the following exercise you're probably wondering if you should even bother using spell check at all. That depends largely on what type of information is in your table. Spell check can be very useful for identifying and correcting errors in certain types of fields, memos, and notes. Spell check is nearly useless for last name fields, address fields, and other similar types of information.

---

**Quick Reference**

To Check Your Spelling:
- Click the Spelling button on the toolbar.
- Select Tools → Spelling from the menu.
- Press <F7>.
Lesson 1-21: Getting Help from the Office Assistant

When you don’t know how to do something in Windows or a Windows based program, don’t panic—ask the Office Assistant for help. The Office Assistant is a cute animated character (a paperclip by default) that can answer your questions, offer tips, and provide help for all of Access’s features. Many Access users don’t use the Office Assistant because they think that it’s nothing more than an amusing distraction—something to keep them entertained when they pound out boring budget numbers. This is unfortunate, because the Office Assistant knows more about Access than most Access books do!

Whenever you use Access, you can make the Office Assistant appear by pressing the <F1> key. Then all you have to do is ask the Office Assistant your question in normal English. This lesson will show you how you can get help by asking the Office Assistant a question.
1. **Press the <F1> key.**
   The Office Assistant appears and asks what you would like to do.

2. **Type** *How do I create a table?* **in the Office Assistant’s speech balloon, as shown in Figure 1-37.**
   You can ask the Office Assistant questions about Access in regular English, just as if you were asking a person instead of a computer. No, the Office Assistant doesn’t really understand the English language—computers have a way to go before they can do that. The Office Assistant actually looks for key words and phrases in your questions like “create” and “table”.

3. **Click Search.**
   The Office Assistant presents you with a list of topics it thinks may be relevant for your question, as shown in Figure 1-38. You have to select the help topic that you’re looking for.

4. **Click the Create a table topic in the Office Assistant’s speech balloon, as shown in Figure 1-38.**
   Access displays several help topics about creating a table, as shown in Figure 1-39.

5. **Click the Find out more about what tables are and how they work topic as shown in Figure 1-39.**
   Access displays the help topic about what tables are and what they are used for.

6. **Click the Help window’s Close button (🗙) to close the help window.**
   The Help window closes, however Office Assistant remains on-screen and will remain there, distracting and annoying you with its animated antics unless you close it, as well.

7. **Right-click on the Office Assistant and choose Hide from the shortcut menu.**
   The helpful but oh-so-annoying Office Assistant disappears from the screen and stands by ready to assist you the next time you press the <F1> help key.

### Table 1-11: Help Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Shows or hides a list of all available Help topics.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Moves back to the previous help topic.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Moves forward to the next help topic.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Prints the current help topic.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Displays a list of help options and commands.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Get Help from the Office Assistant:

1. Press the <F1> key.
2. Type your question in the Office Assistant’s speech balloon and click Search or press <Enter>.
3. Click the help topic that best matches what you’re looking for (repeat as this step as necessary).
Lesson 1-22: Changing the Office Assistant and Using the “What’s This” Button

If you find that Clippit’s (the cartoon paperclip) antics are getting old, you can choose a different Office Assistant at anytime. People have different tastes and personalities, and that’s why Microsoft allows you to select from eight different Office Assistants (see Table 1-12: Office Assistants1) to guide you through Access. Of course, if you really hate the Office Assistant, you can always completely shut it off too.

The other topic covered in this lesson is how to use the “What’s This” button. During your journey with Access you will undoubtedly come across a dialog box or two with a number of confusing controls and options. To help you find out what the various controls and options in a dialog box are there for, many dialog boxes contain a “Help” (Help) button that explains the purpose of each of the dialog box’s controls. This lesson will show you how to use the “What’s This” button, but first, let’s start taming the Office Assistant.

1. If necessary, select Help → Show the Office Assistant from the menu.
   The Office Assistant appears.
2. Right-click the Office Assistant and select Choose Assistant from the shortcut menu.
   The Office Assistant dialog box appears.
3. **Click the Back or Next button to see the available Office Assistants.**
   The Office Assistant you select is completely up to you. They all work the same—they just look and act different.

4. **Click OK when you find an Office Assistant you like.**
   If you find the Office Assistant annoying (a lot of people do) and want to get rid of it altogether here’s how:

5. **Right-click the Office Assistant**
   A shortcut menu appears.

6. **Select Hide from the shortcut menu.**
   You can always bring the Office Assistant back whenever you require it’s help by pressing the <F1> key. Now let’s move on to how to use the “What’s This” button to discover the purpose of confusing dialog box controls.

7. **Select Tools → Options from the menu and click the View tab.**
   The Options dialog box appears. Notice the “What’s This” button located in the dialog box’s title bar just to the left of the dialog box’s close button.

8. **Click the “What’s This” button (§).**
   The mouse pointer changes to a ??, indicating you can point to anything on the dialog box to find out what it does. The Windows in Taskbar check box is rather confusing isn’t it? Move on to the next step and we’ll find out what it’s there for.

9. **Click the Windows in Taskbar check box with the ?? pointer.**
   A brief description of the Windows in Taskbar check box appears.

10. **Close the Options dialog box.**

### Table 1-12: Office Assistants

<table>
<thead>
<tr>
<th>Office Assistant</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Clippit" /></td>
<td>Though nothing more than a thin metal wire, Clippit will help you find what you need and keep it together. Clippit is the default Office Assistant.</td>
</tr>
<tr>
<td><img src="image" alt="The Dot" /></td>
<td>Need a guide on the electronic frontier? Able to transform into any shape, the Dot will always point you in the right direction.</td>
</tr>
<tr>
<td><img src="image" alt="F1" /></td>
<td>F1 is the first of the 300/M series, built to serve. This robot is fully optimized for Office use.</td>
</tr>
<tr>
<td><img src="image" alt="The Genius" /></td>
<td>The mind of the Genius works at the speed of light. Harness his power of thought to save yourself time and energy.</td>
</tr>
<tr>
<td><img src="image" alt="Office Logo" /></td>
<td>The Office Logo gives you help accompanied by a simple spin of its colored pieces. It won’t distract you as you’re taking care of business.</td>
</tr>
<tr>
<td><img src="image" alt="Mother Nature" /></td>
<td>Transforming into images from nature, such as the dove, the volcano, and the flower, Mother Nature provides gentle help and guidance.</td>
</tr>
<tr>
<td><img src="image" alt="Links" /></td>
<td>If you’re on the prowl for answers in Windows, Links can chase them down for you.</td>
</tr>
<tr>
<td><img src="image" alt="Rocky" /></td>
<td>If you fall into a ravine, call Lassie. If you need help in Office, call Rocky.</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Change Office Assistants:

1. If necessary, select Help → Show the Office Assistant from the menu.
2. Right-click the Office Assistant and select Choose Assistant from the shortcut menu.
3. Click the Next or Back buttons until you find an Office Assistant you like, then click OK.

To Hide the Office Assistant:

- Right-click the Office Assistant and select Hide from the shortcut menu.

To See what a Control in a Dialog Box Does:

1. Click the Dialog box “What’s This” button (located right next to the close button).
2. Click the control you want more information on with the ?? pointer.

---

Lesson 1-23: Using the Zoom Box

When you are viewing and working with data sometimes a column will not be wide enough to display all the text in a cell or field. This is especially true for notes and memo fields, which may contain several paragraphs of text. Don’t worry—you can summon the Zoom Box to make the contents of any cell easier to view and edit.

1. If it isn’t already open, open the Employees table.
   Most of the information in this table fits nicely into its designated column. Move on to the next step and take a look at the Notes field, however.

2. Scroll to the right using the horizontal scroll bar until you can see the Notes field.
   The Notes field is not wide or tall enough to display all its information. Move to the next step to see how the Zoom box can display the contents of a Notes cell.

3. Click the Notes field for any record, then zoom into that cell by pressing <Shift> + <F2>.
   The Zoom box appears and displays the contents of the selected cell, as shown in Figure 1-45. You can edit the cell information in the Zoom box. When you’re finished viewing or editing the cell simply click OK to close the Zoom box. The cell will display any changes you made to the data.

4. Click OK to close the Zoom box and then close the Employees: Table window.
Lesson 1-24: Closing a Database and Exiting Access

Because the tasks covered in this lesson are so simple—closing an open database and exiting the Access program—you’re at what is undoubtedly the easiest lesson in the guide.

Whenever you close the Database window you close the current database.

1. **Click the Database window’s Close button.**
   If any of your Access windows are maximized you may see two close buttons on your screen, as shown in Figure 1-47. Make sure you click the lower close button to close the database window. The close button located in the far upper-right hand corner of the screen closes the Microsoft Access program. The current database closes but the Access program does not. You can close a database when you’re finished working on it but may still want to remain in the Access program—perhaps to open and work on another database. You have finished both this lesson and this chapter, so you want to exit, or close the Access program.

2. **Click the Close button on the Microsoft Access Title Bar.**
   The Access program window closes and you return back to the Windows desktop.

That’s it! You’ve just completed your first chapter and are well on your way towards mastering Microsoft Access. You’ve already learned some very important things: how to start Access; enter records, open and work with tables, forms, queries and reports and print a database object. You will use these skills all the time in your long and illustrious relationship with Microsoft Access.
Chapter One Review

Lesson Summary

Starting Access and Opening a Database

- **To Start Microsoft Access**: Click the Windows **Start button** and select **Programs → Microsoft Access**.
- **To Open a Database**: Click the **Open button** on the toolbar, or select **File → Open** from the menu, or press `<Ctrl>` + `<O>`.

Understanding the Access Screen

- Be able to identify the main components of the Access program screen.

Using Menus and Toolbars

- **Menus**: Either click the menu name with the mouse pointer or press the `<Alt>` key and the letter that is underlined in the menu name.
- **Toolbars**: Simply click the toolbar button you want to use. Leave the pointer over the button to display a screen tip of what the buttons does.
- **To Display a Toolbar Button's Description**: Position the pointer over the toolbar button and wait a second. A ScreenTip will appear above the button.

Filling Out Dialog Boxes

- Be able to identify and use text boxes, list boxes, combo boxes, check boxes, and sheet tabs.

Keystroke and Right-Mouse Button Shortcuts

- **Keystroke shortcuts**: Press `<Ctrl>` and the letter that corresponds to the shortcut command at the same time.
- **Right-mouse Button shortcut menus**: Whenever you’re unsure or curious about what you can do with an object, click it with the right-mouse button to display a list of commands related to the object.

Opening and Modifying Database Objects

- **To View Different Types of Database Objects**: From the Database window, click the appropriate **icon** in the Objects bar.
- **To Open a Database Object**: Double-click the object or click the database object and click the **Open button** on the Database window.
- **To Open a Database Object in Design View**: Click the database object and click the **Design button** on the Database window.
• **To Change How Database Objects are Displayed:** Click the appropriate **View button** on the toolbar or Select **View** from the menu and select the desired view.

**Working with Multiple Windows**

• **To Switch between Multiple Windows:** Click the corresponding icon on the Windows taskbar or select **Window** and select the name of the window you want to view.

• **To View Multiple Windows at the Same Time:** Select **Window** from the menu and select **Tile Horizontally**, **Tile Vertically**, or **Cascade** from the menu.

• **To Maximize a Window:** Click the window’s **Maximize button**.

• **To Restore a Window:** Click the Window’s **Restore button**.

• **To Manually Resize a Window:** Position the mouse pointer over the edge of the window, hold down the mouse button and drag the mouse to resize the window then release the mouse button.

• **Using the keyboard:** Move the cell pointer by pressing the keyboard arrow key that corresponds to the direction you want to move.

• **To Move a Window:** Drag the window’s title bar to the location where you want to position the window.

**Tour of a Table**

• **To Move to the Next Record:** Click the **Next Record Navigation button**, or press the `<↓>` key, or click the record you want to select.

• **To Move to the Previous Record:** Click the **Previous Record Navigation button**, or press the `<↑>` key, or click the record you want to select.

• **To Move to the Last Record in a Table:** Click the **Last Record Navigation button** or press <Ctrl>+<Page Down>.

• **To Move to the First Record in a Table:** Click the **First Record Navigation button** or press <Ctrl>+<Page Up>.

**Adding, Editing, and Deleting Records**

• **To Add a New Record:** Do any of the following:
  - Click the **New Record navigation button**
  - Click the **New Record button** on the toolbar
  - Press <Ctrl>+<+>
  …then enter the record information for the field, pressing <Tab> to move to the next field and <Shift>+<Tab> to move to the previous field.

• **To Edit a Record:** Click the field you want to edit and make the changes.

• **To Delete a Record:** Place the insertion point anywhere in the record and click the **Delete Record button** on the toolbar.

**Tour of a Form**

• **To Move between Records:** Use the **Record Navigation buttons** near the bottom of the screen.
• To Add a New Record: Do any of the following:
  - Click the New Record navigation button
  - Click the New Record button on the toolbar
  - Press <Ctrl>+<->
  ...then enter the record information for the field, pressing <Tab> to move to the next field and <Shift>+<Tab> to move to the previous field.

• To Delete a Record: Place the insertion point anywhere in the record and click the Delete Record button on the toolbar.

Tour of a Query

• To Display a Query in Design View: Open the query and click the View button on the toolbar. You can also select the query and click Design.

Tour of a Report

• To Zoom in Print Preview: Click the area you want to zoom (either in or out) with the pointer.

• To Print a Report: Click the Print button on the toolbar, or select File → Print from the menu, or press <Ctrl>+<P>.

Previewing and Printing a Database Object

• To Preview: Click the Print Preview button on the toolbar or select File → Print Preview from the menu.

• To Print: Do any of the following:
  - Click the Print button on the toolbar
  - Select File → Print from the menu.
  - Press <Ctrl>+<P>.

• For Advanced Printing Options: Select File → Print from the menu and select your printing options from the Print dialog box.

Selecting Data

• To Select:
  A word       Double-click anywhere in the word.
  A cell       Click the left edge of the cell you want to select.
  A record     Click the record selector for the record you want to select.
  The entire table Click the empty box ( ) to the left of the field of the field names.

• To Select Text: Move the insertion point to the beginning or end of the text you want to select, click and hold the left mouse button and drag the insertion point across the text then release the mouse button once the text is selected.

• To Replace Text: Replace text by first selecting it then typing the new text you want.

• To Select a Cell: Position the mouse over left edge of the cell you want to select ( changes to ) and click to select the cell.

• To Select a Record: Position the mouse over the record selector ( changes to ) and click to select the record.

• To Select a Field or Column: Position the mouse over the name of the field you want to select ( changes to ) and click to select the field.
To Select the Entire Table: Click the empty box (□) to the left of the field of the field names.

Cutting, Copying, and Pasting Data

- **To Cut:** Cut text or objects by selecting the text or object and using one of four methods to cut:
  1) Click the **Cut button** on the toolbar.
  2) Select **Edit → Cut** from the menu.
  3) Press `<Ctrl> + <X>`. 
  4) Right-click and select **Cut** from the shortcut menu.

- **To Copy:** Copy text or objects by selecting the text or object and using one of four methods to copy:
  1) Click the **Copy button** on the toolbar.
  2) Select **Edit → Copy** from the menu.
  3) Press `<Ctrl> + <C>`. 
  4) Right-click and select **Copy** from the shortcut menu.

- **To Paste:** Paste text or objects by selecting the text or object and using one of four methods to paste the data:
  1) Click the **Paste button** on the toolbar.
  2) Select **Edit → Paste** from the menu.
  3) Press `<Ctrl> + <V>`. 
  4) Right-click and select **Paste** from the shortcut menu.

Using Undo

- **To Undo Your Last Action:** Click the **Undo button** on the toolbar, or select **Edit → Undo** from the menu, or press `<Ctrl> + <Z>`.

Checking Your Spelling

- **To Check Your Spelling:** Click the **Spelling button** on the toolbar, or select **Tools → Spelling** from the menu, or Press `<F7>`.

Using the Zoom Box

- **To Zoom into a Cell:** Select the cell you want to zoom and press `<Shift> + <F2>`.

Closing a Database and Exiting Access

- **To Close a Database:** Click the Database window **close button** or select **File → Close** from the menu.

- **To Exit Microsoft Access:** Click the Access Program **close button** or select **File → Exit** from the menu.

Quiz

1. **What are the columns in a Microsoft Access table called?**
   A. Rows.
   B. Records.
   C. Fields.
   D. Cells.
2. **Right-clicking something in Access:**
   A. Deletes the object.
   B. Opens a shortcut menu listing everything you can do to the object.
   C. Selects the object.
   D. Nothing—the right mouse button is there for left-handed people.

3. **Which of the following is NOT a type of Microsoft Access database object?**
   A. Tables.
   B. Queries.
   C. Forms.
   D. Workbooks.

4. **Which of the following database objects asks a question of information in a database and then displays the results?**
   A. Tables.
   B. Queries.
   C. Forms.
   D. Reports.

5. **Which of the following database objects makes it easy to view, edit, and enter database information?**
   A. Tables.
   B. Queries.
   C. Forms.
   D. Reports.

6. **Design View lets you view and modify the structure of any database object.** (True or False?)

7. **You can display a database object in Design View by:** (Select all that apply.)
   A. Selecting the database object and press <Ctrl> + <V>.
   B. Selecting the database object and clicking the Design button on the Database window.
   C. Opening the database object and selecting Tools → Design View.
   D. Opening the database object and clicking the View button on the toolbar.

8. **Click the Save button on the toolbar to save record.** (True or False?)

9. **The □ that appears to the left of every record is:**
   A. The *New Record Pointer*, which indicates the records that have not yet been saved.
   B. The *Record Delete Button*, which is used to delete records.
   C. The *Record Selector*, which is used to select records.
   D. The *Record Edit Indicator*, which indicates the record is being edited.

10. **Which of the following statements is NOT true?** (Select all that apply.)
    A. You can display any database field in a Zoom Box by pressing the <F2> key.
    B. Microsoft Access is a spelling genius and even recognizes the names of people, places, and products.
    C. In Microsoft Access, the <Tab> key moves to the next field and <Shift> + <Tab> moves to the previous field.
    D. You can add and edit information in tables, forms, and some queries.
11. Which of the following is NOT a selection technique?
   A. To select a word, double-click the word.
   B. To select a row, click the record selector box.
   C. To select a column, double-click anywhere in the column.
   D. To select an entire table, click the empty box to the left of the field names.

12. How can you print three copies of a table?
   A. Select File → Print from the menu and type 3 in the Number of copies text box.
   B. Press <Ctrl> + <P> + <3>.
   C. Select File → Properties from the menu and type 3 in the Copies to print text box.
   D. Click the Print button on the Standard toolbar to print the document then take it to Kinko’s and have 2 more copies made.

**Homework**

1. Start Microsoft Access and open the Homework database.
2. Open the Science Test Answers table.
3. Without counting by hand, how many records are currently in the Science Test Answers table?
4. Use the Record Navigation buttons to navigate between the records in the Science Test Answers table.
5. Add a new record to the table: Click the New button on either the Table Navigation button area or on the toolbar.
6. Enter the following information into the new record:
<table>
<thead>
<tr>
<th>Grade</th>
<th>Score</th>
<th>Class</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>5th</td>
<td>C-</td>
<td>Science</td>
<td>Liter: A nest of young puppies.</td>
</tr>
</tbody>
</table>
7. Change the score of the previous record from a C- to a D+.
8. Select the previous record by clicking its Record Selector, then delete the record by pressing the <Delete> key.
9. Click the Undo button to undo the deletion.
11. Click the Forms icon in the Objects bar and open the Test Answer form.
12. Enter the following information into the new record:

<table>
<thead>
<tr>
<th>Grade</th>
<th>Score</th>
<th>Class</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>8th</td>
<td>D</td>
<td>Biology</td>
<td>Germinate: To become a naturalized German.</td>
</tr>
</tbody>
</table>

13. Close the Test Answer form.
14. Click the Queries icon in the Objects bar and open the Sort by Grades query.
15. Click the View button on the toolbar to display the Grades query in Design View.

**Quiz Answers**

1. C. The columns in a Microsoft Access table are its fields.
2. B. Right-clicking an object displays a shortcut menu for the object.
3. C. You’ll find worksheets in Microsoft Excel but not in Microsoft Access.
4. B. Queries ask a question of information in a table and display the results.
5. C. Forms display table and query information in an organized format, making it easy to view, add, and edit records.
7. B and D. Either of these procedures will display a database object in Design View.
8. False. Microsoft Access automatically saves database records—you don’t have to click the Save button on the toolbar.
9. C. This is the Record Indicator and is used to select records.
10. A and B. You need to press the <Shift> key along with <F2> to zoom and Spell Checker is usually not suitable for checking the spelling of typical table information.
11. C. You only need to click a column once to select it in Access.
12. A. Taking it to Kinko’s?!
Chapter Two: Creating and Working with a Database

Chapter Objectives:

- Create a database from scratch and use the Database Wizard
- Create a table from scratch and use the Table Wizard
- Understand field data types
- Create and modify a query
- Create queries that sort and filter database information
- Create a form using the Form Wizard
- Create reports and mailing labels using the Report Wizard

Stop typing lists of information in Microsoft Word or Excel! In this chapter, you will learn how to create databases that can store names, addresses, and any other type of information that you can think of. You will be pleasantly surprised to find that creating a database isn’t all that difficult. Microsoft Access even comes with a Database Wizard that takes you step-by-step through the process of creating a database.

Because there are so many components that constitute a database, this chapter will cover a lot of ground—but thankfully not in great detail. In this chapter you will learn to create and modify the major database objects: tables, forms, queries, and reports. You will even learn some basic database management tasks, such as how to delete and rename database objects and how to repair and compress a database.

If all you need is a simple, easy-to-use database, look no farther than this chapter—more than likely, everything you need to know about creating databases is here.
Lesson 2-1: Planning a Database

Although you can always make changes to a database, a little planning ahead before you create a database can save you lots of time and headaches later on.

Consider Figure 2-1: In the first table you can only sort by the name or address field. If you sort the name field the sort is performed by the first name and then the last name. If you sort the address field the sort is performed by the street—you cannot sort by city, state, or zip code. Furthermore, the information stored in the first table is inflexible. You couldn’t create a query or filter that only displays people from a particular state because the states are not stored in their own field.

Now take a look at the second table in Figure 2-1. Here you can sort records by first name, last name, address, city, state, and zip code. You can also query and filter records using any of these fields.
Here are some guidelines for creating a well-designed database:

- **Determine the Purpose of the Database**
  The best way to do this is to write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but if you think about it, these reports are really the reason you’re creating the database. Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the tables and fields to include in your database.

- **Determine the Fields You Need**
  This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists. Think about the data type for each type of your fields—Will the field store text information? Numbers? Dates? Write down the data type next to each field.

- **Determine the Tables You Need**
  Each table in the Database should be based on only one subject. By breaking each subject into its own table you avoid redundant information and make the database more organized. The second database in Figure 2-2 is broken down into two tables, Customers and Invoices, so there isn’t any duplicated data. When you brainstorm try to break down your information as much as possible. If your tables contain fields like Item 1, Item 2, Item 3, Item 4, and so on you should probably break the information up into its own table.

- **Determine the Primary Key**
  Each record in a table should have a primary key that uniquely identifies it. When you think about a primary key field think unique—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of fields that could be used as a table’s primary key.

- **Determine the Relationship between Tables**
  In Figure 2-2 the ID field links the Customers and Invoices tables together. One of the linked fields should be the table’s primary key.

- **Sketch a Diagram of Your Database**
  Create a diagram of your database. Draw a box for each of your tables and write the table’s field names inside that box. Draw a line between the related fields in the tables. For example, in Figure 2-2 each record in the Customers table is related to one or more records in the Invoices table.

### Table 2-1: Guidelines for Good Database Design

<table>
<thead>
<tr>
<th>Guideline</th>
<th>Why?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Each field or column should contain the same type of information.</td>
<td>This makes the table more meaningful, organized, and easier to understand.</td>
</tr>
<tr>
<td>Try to break up information as much as possible.</td>
<td>This gives you more power to sort, filter and manipulate the list. See Figure 2-1 for an example.</td>
</tr>
<tr>
<td>Use multiple tables so that you don’t duplicate information in the same table.</td>
<td>Organize your information into several tables—each one containing fields related to a specific subject—rather than one large table containing fields for a wide range of topics. See Figure 2-2 for an example.</td>
</tr>
<tr>
<td>Don’t use duplicate field names.</td>
<td>Duplicate field names can cause problems when entering and sorting information.</td>
</tr>
</tbody>
</table>
Lesson 2-2: Creating a Database Using the Database Wizard

The easiest way to create a database is with the Database Wizard. The Database Wizard saves you time and effort by walking you step-by-step through the process of creating a database and provides you with ready read-to-use tables, forms, queries, and reports. The Database Wizard can create databases for contact management, keeping track of inventory, and taking orders. You can also modify a database created by the Database Wizard to better suit your needs.

This lesson explains how to use the Database Wizard to create a database.

1. **Start Microsoft Access by clicking the Windows Start button and selecting Programs → Microsoft Access from the Start menu.**

   The Microsoft Access program appears with the Microsoft Access dialog box displayed, as shown in Figure 2-3. The Microsoft Access dialog box gives you quick access to any database you have worked on recently and allows you to create a new database.

2. **Click the Access database wizards option, click OK, and click the Databases tab if necessary.**

   The New dialog box appears with the Database tab selected. Here you need to select the type of database you want to create. For this exercise we’ll create a Contact Management database.
3. Double-click the **Contact Management** icon.
   Access prompts you to type in a file name for your new database.

4. Type **My Contacts** and click **Create**.
   The first screen of the Database Wizard appears and describes the database it will create for you.

5. Click **Next** to continue.
   The next screen of the Database Wizard appears as shown in Figure 2-4. This dialog box displays the standard tables and fields that the Database Wizard is building for you. Click a table on the left side of the dialog box to view its fields on the right side. If you want, you can remove the fields from the database by unchecking them. For this exercise we will leave the standard fields as they are.

6. Click **Next** to accept the Database Wizard's standard tables and fields.
   Next you have to decide what your new database should look like. Access provides you with several aesthetic styles to choose from. Click a style to see a sample of what it looks like.

7. Browse the various styles by clicking each of them, then select the style you like best and click **Next**.
   Another screen and more aesthetic decisions to make. Here, you need to select the font you want to use in your reports. You can preview each of the font styles by clicking them.

8. Select the font style that you like best and click **Next**.
   You’re just about done. The next step in the Database Wizard is entering the title of your new database. This title will appear on the heading of all the reports in your database. You can even add a graphic or logo to your reports by checking the “Yes, I’d like to include a picture” box, clicking the Picture button and selecting the picture or graphic file.

9. Type **ACME Client List** and click **Next**.
   That’s it—you’ve finished giving the Database Wizard all the information it needs to create the database.

10. Click **Finish** to create the new database.
    Access chugs along and creates the new database for you. When it’s finished it will create a handy switchboard screen that makes it easy to access the database’s tables, forms, and reports.

11. Explore the tables, forms, and reports in the new database by clicking the various buttons on the switchboard form.
    Move on to the next step when you have seen enough of the new database.

12. Close the new database by selecting **File → Close** from the menu.
    That’s it! You’ve created your first database using the Database Wizard. The database created by the Database Wizard may not be exactly what you’re looking for, but you can always modify its tables, forms, and reports to better suit your needs. A lot of people create databases using the Database Wizard to serve as the foundation for a more customized database.

---

**Quick Reference**

To Create a Database using the Database Wizard:

1. Click the **New** button on the toolbar.
   Or...
   Select **File → New** from the menu.

2. Click the **Databases** tab and double-click the **Access database wizards, pages, and projects** option.

3. Double-click the type of database you want to create.

Lesson 2-3: Creating a Blank Database

Can’t find a suitable database in the Database Wizard? Then you’ll have to create a blank database and start from scratch. The advantage of creating a blank database is that it gives you the most flexibility and control over your database design. The disadvantage of creating a blank database is that you have to create every table, form, report, and query yourself.

Here’s how to create a blank database.

1. **Click the New button on the toolbar.**
   The New dialog box appears, as shown in Figure 2-5. The New dialog box has two tabs:
   - **General**: Blank databases that you create from scratch.

![New dialog box](image)
- **Databases**: An assortment of databases which you can create using the Database Wizard.

2. **Select the Database template on the Databases tab and click OK.**
   The File New Database dialog box appears. Before you can put anything into your new database you must first give it a file name and save it.

3. **Navigate to the drive and folder where you want to save the new database, then type** *My First Database* **in the File Name box and click Create.**
   Access creates a new database and saves it with the “My First Database” file name. The Database window appears when it’s finished. If you click the various database object tabs you will notice that there aren’t any database objects in this database yet. You will have to create the whole database yourself—something we will be doing in the next several lessons.

---

**Quick Reference**
To Create a New Blank Database:

1. Click the ![New](new.png) button on the toolbar.
   Or…
   Select **File → New** from the menu.
   Or…
   Press `<Ctrl>` + `<N>`.

2. Select the Blank Database icon and click **OK**.

3. Navigate to the drive and folder where you want to save the new database, then type a name for your new database in the **File Name** box and click **Create**.
Lesson 2-4: Creating a Table Using the Table Wizard

If you're new to Access, the easiest way to add a table to an existing database is with the Table Wizard. The Table Wizard asks you a series of questions about which fields you want to appear in your table, and does the dirty work of creating a new table for you. The Table Wizard can create a variety of different tables to store mailing lists, inventory, catalogs and more.

1. Make sure that you have a blank database open.
   If you don't have a blank database open you can create one by clicking the New button on the toolbar, double-clicking the database template, entering a name for your database, and clicking OK.

2. Click the Tables icon in the Objects bar if it is not already selected.
   Access lists all the tables in the current database.

3. Double-click the Create table by using wizard icon.
   The Table Wizard dialog box appears, as shown in Figure 2-7. This is definitely one of the more confusing dialog boxes in Access. The list to the far left of the dialog box contains the sample tables from which to choose. You start the Table Wizard by selecting the sample table you want to use.

4. Click the Contacts sample table from the Sample Table list.
   The Table Wizard displays the ready-made fields that you can incorporate into your table in the Sample Fields list. To add a field to your table double-click the field or select the field and click the button. Click the button to add all the sample fields to your table.

5. Double-click the Contact ID field in the Sample Fields list.
   The Contact ID field appears in the “Fields in my new table” list. If you accidentally add a field to the “Fields in my new table” list you can remove it by double-clicking it or by selecting it and clicking the button.
6. **Add the following fields to your table by double-clicking them:**
   - **FirstName, LastName, Address, City, StateOrProvince,** and
   - **PostalCode.**

   You can easily change the field names in your new table if you don’t like the default
   names given to them by the Table Wizard. Here’s how to rename a field:

7. **Select the **StateOrProvince** field from the “Fields in my new table” list and click **Rename Field**.**

   The Rename Field dialog box appears. From here, renaming a field is pretty much self-
   explanatory.

8. **Replace the **StateOrProvince** text with **State** and click **OK.**

   Once you have finished adding the fields to your table you can move on to the next
   step in the Table Wizard.

9. **Click **Next.**

   The Table Wizard asks you to give your table a name and if you want to have Access
   set a primary key for you. You will learn more about primary keys later on, so for now
   let’s accept the Table Wizard’s default settings and create the table.

   **NOTE:** If other tables exist in your database, another screen will appear, asking you
   how this table relates to the other tables in your database.

10. **Click **Finish** to create the new table.**

    The Table Wizard builds the table using the fields you selected and then opens the new
    table—ready for your data input.

11. **Close the Contacts table.**

### Table 2-2: Useful Sample Tables from the Table Wizard

<table>
<thead>
<tr>
<th>Sample Table</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Employees</strong></td>
<td>Tracks employee data such as addresses and phone numbers.</td>
</tr>
<tr>
<td><strong>Orders</strong></td>
<td>Tracks customer orders.</td>
</tr>
<tr>
<td><strong>Contacts</strong></td>
<td>A generic table that stores details about your customers and prospects.</td>
</tr>
<tr>
<td><strong>Customers</strong></td>
<td>Stores all your customer or client information.</td>
</tr>
<tr>
<td><strong>Products</strong></td>
<td>Maintains a list of products that your company sells.</td>
</tr>
<tr>
<td><strong>Order Details</strong></td>
<td>Used with the Orders table—tracks what was purchased in each order.</td>
</tr>
<tr>
<td><strong>Time Billed</strong></td>
<td>Used to keep track of how much time to bill a client.</td>
</tr>
<tr>
<td><strong>Expenses</strong></td>
<td>Tracks expenses—useful for reimbursements or for billing customers.</td>
</tr>
<tr>
<td><strong>Tasks</strong></td>
<td>Tracks to-do items.</td>
</tr>
</tbody>
</table>

### Quick Reference

To Create a New Table using the Table Wizard:

1. **From the database window click the **Tables icon** in the Objects bar and then double-click the**
   - **Create table using wizard** icon.

2. **Select the type of table you want to create.**

3. **Follow the on-screen instructions and specify what you want to appear in your database.**
Lesson 2-5: Modifying a Table and Understanding Data Types

Once you have created a table, you can modify it later in Design View. Design View allows you to change the structure of a table by adding, deleting, and modifying its fields.

Because there are so many different types of data, Access offers several different types of fields. A field’s data type determines the type of information that can be stored in a field. Table 2-3: Data Types lists the various data types available in Access. A field’s data type restricts what type of information you can enter in a field. For example, you cannot enter text into a number data type field.

In this lesson you will modify a table by adding a new field and then determining the field’s data type.

1. Select the Contacts table and click the Database window’s Design button.
   The Contacts table appears in Design View, which allows you to add, delete, or modify the table’s structure and fields.
   Here’s how to change a field name in Design View:

2. Scroll down, if necessary, select the PostalCode Field Name box and replace the text “PostalCode” with ZipCode.
   That’s how easy it is to change a field name. Next try adding a new field to the table.

3. Press <Tab> three times.
   The cursor should be located in the blank Field Name box below the ZipCode field name. To add a field in Design View simply type a new field name in the first blank Field Name box you find.
4. **Type Birthday and press <Tab>.**

   New fields are text data type fields by default. Here’s how to change a field’s data type:

5. **Click the Data Type area next to the Birthday field.**

   A down arrow appears on the right side of the Birthday’s Data Type box.

6. **Click the Data Type arrow and select Date/Time from the list.**

   The new Birthday field will now only accept date and time information. The new Date/Time data type also makes your database more flexible and powerful because now you can sort birthdays by date or use them in a calculation—for example to determine a person’s age.

   Once you have finished modifying a table you have to save your changes.

7. **Click the Save button on the toolbar to save your changes.**

   You’ve finished modifying the table, so…

8. **Close the Contacts table.**

---

### Table 2-3: Data Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Legal Name: John Doe</td>
<td>Stores text, numbers, or a combination of both, up to 255 characters long. Text fields are the most common of all data types.</td>
</tr>
<tr>
<td>Memo</td>
<td>Notes: Sally displays a high amount of…</td>
<td>Stores long text entries—up to 64,000 characters long (equivalent to 18 pages of text!). Use memo fields to store notes or anything else that requires lots of space.</td>
</tr>
<tr>
<td>Number</td>
<td>Age: 31</td>
<td>Stores numbers that can be used in calculations.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Birthday: April 7, 1969</td>
<td>Stores dates, times, or both.</td>
</tr>
<tr>
<td>Currency</td>
<td>Price: $84.95</td>
<td>Stores numbers and symbols that represent money.</td>
</tr>
<tr>
<td>AutoNumber</td>
<td>Invoice Number: 187001</td>
<td>Automatically fills in a unique number for each record. Many tables often contain an AutoNumber field that is also used as their primary key.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Smoker?: Yes</td>
<td>Stores only one of two values, such as Yes or No, True or False, etc.</td>
</tr>
<tr>
<td>OLE Object</td>
<td>Photo:</td>
<td>Stores objects created in other programs such as a graphic, an Excel spreadsheet, or a Word document.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Web Site: <a href="http://www.amazon.com">www.amazon.com</a></td>
<td>Stores clickable links to files on your computer or on the network or to Web pages on the Internet.</td>
</tr>
<tr>
<td>Lookup Wizard</td>
<td><strong>Purpose of Trip:</strong> Business, Leisure, Trip</td>
<td>A wizard that helps you create a field whose values are selected from a table, query or a preset list of values.</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Display a Table in Design View:**

- Select **File → Save** from the menu.
- Press <Ctrl> + <S>.

**To Change the Data Type for a Field:**

1. Display the table in Design View.
2. Click the field’s Data Type box, click the Data Type list arrow and select the data type.

**To Save Changes to a Database Object:**

- Click the Save button on the toolbar.
- Select **File → Save** from the menu.
- Press <Ctrl> + <S>. 
Lesson 2-6: Creating a New Table from Scratch

1. Click the Tables icon in the Objects bar if it already isn’t selected, then double-click the Create Table in Design view icon.

   The new blank table appears in Design View. Now all you have to do is add the fields you want included in the table. The table you will create in this exercise will track telephone calls made to customers. Let’s add the first field.

2. Type Date in the first blank Field Name box.

   Since this field will store the date the call was made, you need to change the data type of the field to Date/Time.

3. Click the Data Type area next to the Date field.

   A down arrow appears on the right side of the Date Data Type box.

The Table Wizard is helpful if you’re new at building tables, but the more you start using Access, the less you will probably want to use the Table Wizard. That’s because you will know exactly what type of tables and fields your database needs and how to create them.

This lesson explains how to build your own tables from scratch. The most straight-forward way to build a table is in Design View, where adding fields to a table and specifying their data types is not much more than basic data entry.
4. **Click the Data Type arrow** and select **Date/Time** from the list.
   The Date field will now only accept date and time information. Let’s add the next field to the table...

5. **Press <Tab> two times and type Contact ID.**
   In case you were wondering, the Description box you just tabbed past is used to provide users with online prompts and instructions. Anything you enter in a field’s Description box will appear in the Status bar whenever a user selects that field. We’ll discuss the Description box in greater depth later on.

   The Contact ID field will indicate the contact that was called. Since the Contact ID field will always be a number, you need to change its data type to numeric. A faster way of changing a field’s data type is to type the first letter of the data type in the Data Type box. For example typing a ‘D’ would change the data type to Date. Table 2-4: Data Type Shortcuts lists these keyboard shortcuts.

6. **Click the Data Type area next to the Contact ID field.**
   Try typing in the data type this time.

7. **Type N in the Data Type box.**
   “Number” appears in the Data Type box.

8. **Complete the table by entering the following field names and data types:**
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone</td>
<td>Text</td>
</tr>
<tr>
<td>Comments</td>
<td>Memo</td>
</tr>
<tr>
<td>FollowUp</td>
<td>Yes/No</td>
</tr>
</tbody>
</table>

   Make sure that you press <Tab> after each field. If you make a mistake you can either click the field you want to edit or press <Shift> + <Tab> to move back to the previous field.

   Once you have finished modifying a table you have to save your changes.

9. **Click the Save button on the toolbar to save your changes.**
   Access asks you to give your new homemade table a name.

10. **Type Phone Calls and click OK, then close the current database.**

    **NOTE:** You may see a pop-up window after saving your table asking whether you want to define a primary key. We’ll learn about that later, so click “No” for now.

---

### Table 2-4: Data Type Shortcuts

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Shortcut</th>
<th>Data Type</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>T</td>
<td>Yes/No</td>
<td>Y</td>
</tr>
<tr>
<td>Memo</td>
<td>M</td>
<td>OLE Object</td>
<td>O</td>
</tr>
<tr>
<td>Number</td>
<td>N</td>
<td>AutoNumber</td>
<td>A</td>
</tr>
<tr>
<td>Date/Time</td>
<td>D</td>
<td>Lookup Wizard</td>
<td>L</td>
</tr>
<tr>
<td>Currency</td>
<td>C</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Lesson 2-7: Creating a Query in Design View

Most of the time the fastest and easiest way to create a query is in Design View.

1. **Open the Lesson 2 database.**
   Here’s how to create a simple query:

2. **Click the Queries icon in the Database window Objects bar and double-click the Create query in Design view icon.**
   The Show Table dialog box appears, as shown in Figure 2-11. You have to select the table or query you want to use.
3. **Click the Employees table and click Add.**  
When you have finished adding the tables and/or queries to your new query you can close the Show Tables dialog box.

4. **Click Close.**  
The Query window appears in Design View, as shown in Figure 2-12. Notice that the window is split. The top half contains a box labeled Employees, which displays all the fields in the Employees table. The bottom half of the screen contains a design grid, which is where the information goes.

You add the fields you want to appear in your query to the design grid in two ways:
- By double-clicking the field on the field list, or
- By clicking and dragging the field down to the design grid yourself.

5. **Double-click the LastName field and FirstName field in the field list.**  
Access adds the LastName and FirstName fields to the design grid.

Often you will have to use the field list’s scroll bar to scroll up or down the list in order to find a field.

6. **Scroll down Employees Field list and double-click the City field.**  
Next you need to specify any criteria for the query. You type the criteria in the design grid’s Criteria row. For this exercise you want to see only the records whose City fields contain London—move on to the next step to add this criteria to the query.

7. **Click the City column’s Criteria row and type London.**  
If you want to use a field in the query but you don’t want it to be displayed in the query results uncheck the Show box for that field.

8. **Uncheck the Show box for the City field.**  
The query will still use the criteria you specified for the City field but it won’t display the City field in query results. You’ve created a simple query. Here’s how to save it:

9. **Click the Save button on the toolbar, type London Query and click OK.**  
OK—let’s run our new query!

10. **Click the Run button on the toolbar.**  
Access displays the results of the query. Notice that though the City field is part of the query, it is not displayed because you unchecked its Show box back in Step 10.

Here is a smattering of criteria operators and examples to get you started:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>&quot;MN&quot;</td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>&lt;&gt;&quot;MN&quot;</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt;10</td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>&lt;=10</td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td>&gt;</td>
<td>&gt;10</td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>&gt;=10 AND &lt; &gt;5</td>
<td>Finds records greater than or equal to 10 and not equal to five.</td>
</tr>
<tr>
<td>LIKE</td>
<td>LIKE &quot;S&quot;</td>
<td>Finds text beginning with the letter S. You can use LIKE with wildcards such as &quot;.&quot;</td>
</tr>
</tbody>
</table>
Lesson 2-8: Modifying a Query

As with any database object, you can modify any existing query. This lesson explains how to add and remove a field from a query and how to rearrange the fields in a query.

1. Make sure you have the London Query you created in the previous lesson open in Design View.

   First, here’s how to remove a field from a query:

2. Position the mouse over the top of the City field (_changes to_) and click to select the field.

   Once you have selected a field you can delete it.

3. Press <Delete> to delete the selected City field from the query.

   Next add a new field to the query

4. Double-click the Region field in the field list.

   Access adds the Region field to the design grid. Now add some criteria to the new field so that only employees from Washington are displayed.

5. Click the Region column’s Criteria row and type WA.

   You can also rearrange the order of field names in a query. Here’s how:

6. Select the FirstName field, then click and drag the selected field in front of the LastName field, as shown in Figure 2-15.

   Let’s see the results of the modified query.

7. Click the Run button on the toolbar to view the results of the query. Save your changes and close the query.
Lesson 2-9: Sorting a Query using Multiple Fields

1. From the Database window create a new query in Design View that uses the Employees table as the underlying data source.
   Notice an asterisk (*) appears at the top of the Employee field list. Selecting a table’s asterisk (*) in a query is the same as selecting all its fields.

2. Double-click the asterisk (*) in the Employees field list.
   Access adds the asterisk to the design grid. Next you have to add the fields you want to use to sort the query.

3. Double-click the LastName field and the FirstName field to add them to the design grid.
   You are going to use the LastName and FirstName fields to sort the query. To sort a query click the Sort row for the field you want to use to sort the query and select either Ascending or Descending.

4. Click the LastName field’s Sort Row and select Ascending. Do the same for the FirstName field.
   The LastName and FirstName fields will already be displayed with all the other fields in the table because you added the asterisk (*) to the design grid. Because you don’t want the LastName and FirstName fields to appear twice you can uncheck the LastName and FirstName fields Show boxes.

5. Uncheck the Show box for the LastName and FirstName fields.
   The query will still use the LastName and FirstName fields for sorting purposes but it won’t display these field names in the query results.

6. Save your query as AZ Query and then click the Run button on the toolbar to view the results. Close the query when you’ve finished.
Lesson 2-10: Developing AND and OR Operators

The longer you work with Access, the more you will want to analyze your data. Before long you will want to create queries that match two or more conditions, such as “Which people have bought our cigarettes AND have contracted lung cancer?” You will also, at some time, want to create a query that matches only one of several conditions, such as “Which people have bought our cigarettes OR have bought our chewing tobacco?”

Towards that goal this lesson introduces AND and OR operators. Here’s the run-down on the two:

- **AND** narrows your query, making it more restrictive. For example you could filter for employees from Washington AND who had been with the company for more than 5 years. To create an AND query enter the criteria for the fields on the same Criteria row of the Design grid.

- **OR** relaxes your query, so that more records match. For example you could filter for employees from California OR Minnesota. To create an OR query enter the criteria for the fields on different Criteria rows of the Design grid.

The terms AND and OR operators may sound like they belong to the frighteningly technical world of programming, but if you already have a basic understanding of queries they are remarkably easy to use.
Chapter Two: Creating and Working with a Database

1. **Open the Customers List query in Design View.**
   Remember: To open any database object in Design View simply select the object and click the Database window’s Design button.

   The Customers List query appears in Design View. For this exercise you want to find which of your customers are from France AND own their own business. You will need to create an AND query because the ContactTitle field must equal Owner and the Country field must equal France. To create an AND query simply list each criteria on the same line, as shown in Figure 2-17.

2. **Click the ContactTitle column’s Criteria row and type Owner.**
   This will retrieve records whose ContactTitle equals Owner. Next you have to enter the country criteria.

3. **Click the Country column’s Criteria row and type France.**
   Because you entered the Country criteria in the same Criteria row as the ContactTitle criteria Access will treat it as an AND statement. (Which of my customers is an Owner AND is from France?)

   Move on to the next step to view the results of your first AND query.

4. **Click the View button on the toolbar.**
   Access displays the results of the query, as shown in Figure 2-19. Notice that the results match your queries AND criteria—all the records have Owner in the ContactTitle field and France in the Country field.

   Next we’ll modify the query and create an OR statement.

5. **Switch to Design View by clicking the View button on the toolbar.**
   You’re back in Design View. First let’s remove the Owner criteria from the query.

6. **Delete the “Owner” criteria from the ContactTitle column Criteria row.**
   This time you want to find which of your customers are from France OR are from Mexico. You will need to create an OR query to find these records. To create an OR query, simply list each criteria on its own line, as shown in Figure 2-18.

7. **Click the second Criteria row for the Country column and type Mexico.**
   Because you entered each criteria in a different row Access will treat is as an OR statement. (Which customers are from France OR are from Mexico?)

   Move on to the next step to view the results of your OR query.

8. **Click the View button on the toolbar.**
   Access displays the results of the query, as shown in Figure 2-20. Notice the results match your queries OR criteria—all the records are from either France OR Mexico.

9. **Click the Save button on the toolbar to save your work and close the query window.**

---

**Quick Reference**

To Create AND/OR Criteria:

1. Open/display the query in Design View.
2. Enter your criteria in the appropriate field’s first Criteria box.
3. Enter additional criteria as follows:
   - **AND:** Enter additional criteria for one or more fields in the appropriate field Criteria box in the same row.
   - **OR:** Enter additional criteria for one or more fields in the appropriate field Criteria box, using a different row for each OR criteria.
Lesson 2-11: Creating a Form with the Form Wizard

You will usually want to use the Form Wizard to create your forms. It’s almost always easier to create and modify a form created by the Form Wizard than it is to create one from scratch. This lesson will show you how to use the Form Wizard to create a form.

1. Click the **Forms icon** in the Objects bar if it isn’t already selected, then double-click the **Create form by using wizard** icon.

   The Form Wizard appears, as shown in Figure 2-21. Anytime you create a form you have to tell Access which table or query you want to use for your form.

2. Click the **Tables/Queries list and select Table: Employees.**

   Now that you have specified the table, you tell the Wizard which fields you want to display on the form. To add a field, double-click the field or select the field and click the **button. Click the button to add all the fields to your form.

3. **Double-click the LastName field in the Available Fields list.**

   The LastName field appears in the Selected Fields list. If you accidentally add a field to the Selected Fields list you can remove it by double-clicking it or by selecting it and clicking the **button.

4. **Add the following fields to your table by double-clicking them:** **FirstName, Title, Address, City, Region, PostalCode and Country.**

   Compare your Form Wizard dialog box to the one in Figure 2-21 when you’re finished.
5. **Click Next.**

If you had selected fields from more than one table, the Form Wizard would ask how you would like to organize the data on your form. The Form Wizard doesn’t ask this question, however, since you are creating a form based on a single table.

Next the Form Wizard asks how you want to display the data on the form, as shown in Figure 2-22. You have four layout choices:

- **Columnar:** Displays one record at a time in an easy-to-read format.
- **Tabular:** Displays many records at a time.
- **Datasheet:** Displays many records at a time and looks exactly like a table in Datasheet View.
- **Justified:** Displays one record at a time in a format similar to a tax return—interesting, but usually creates complicated forms that are difficult to work with.

The Form Wizard will select the layout options it thinks is best for your data. Keep in mind—the Form Wizard isn’t very bright.

For this exercise we will use the default Columnar option.

6. **Click Next.**

Next the Form Wizard offers some interesting color styles you can use in your form, as shown in Figure 2-23. Simply click a style to preview it.

**NOTE:** Some of the color styles can slow down the performance of your forms. Try to stick with either the Standard, Colorful, or Stone styles.

7. **Click and preview each of the styles. When you’re finished click the Standard style and click Next.**

The final window of the Form Wizard appears—you have to give your form a name.

8. **Type Employees Form in the text box and click Finish.**

After a few moments your new form appears on-screen, as shown in Figure 2-24. You don’t have to worry about saving your new form—the Form Wizard does this for you automatically as part of the form creation process.

9. **Use the form’s Record Navigation buttons to browse through the records in the underlying Employees table. Close the form when you’re finished.**

---

**Quick Reference**

To Create a Form using the Form Wizard:

1. From the database window click the Forms icon in the Objects bar and then double-click the Create form using wizard icon.
2. Select the table or query you want to use to create your form and select the fields that you want to appear on the form. Click Next when you’re finished.
3. Select the type of form you want to create and click Next.
4. Select a format for your form and click Next.
5. Give your form a name and click Finish.
Lesson 2-12: Creating a Report with the Report Wizard

Even more so than the Form Wizard, the fastest and easiest way to create a report is with the Report Wizard. It’s almost always easier to create and modify a report created by the Report Wizard than it is to create one from scratch.

1. **Click the Reports icon** in the Objects bar and double-click the Create report by using wizard icon.

   The Report Wizard appears, as shown in Figure 2-25. Anytime you create a report you have to tell Access which table or query you want to use for your report.

2. **Click the Tables/Queries list and select Table: Customers.**

   Now that you have specified the table, you tell the Wizard which fields you want to display on the report. To add a field, double-click the field or select the field and click the button. Click the button to add all the fields to your report.

3. **Double-click the CompanyName field in the Available Fields list.**

   The CompanyName field appears in the Selected Fields list. If you accidentally add a field to the Selected Fields list you can remove it by double-clicking it or by selecting it and clicking the button.
4. **Add the following fields to your table by double-clicking them:** ContactName, Address, City, and Country.
   Compare your Report Wizard dialog box to the one in Figure 2-25 when you’re finished.

5. **Click Next.**
   The Report Wizard asks you if and how you want to group the data in your report, as shown in Figure 2-26. For example, you can group all the customers from the same country together in your report. Grouping can help organize and summarize the information in your report. To use a specific field to group data, double-click the field you want to use. For this exercise we’ll group our report data using the Country field.

6. **Double-click the Country field from the list.**
   The Country field appears on top of the sample report to show how Access will group the data in the report. If you change your mind, simply double-click the grouping field at the top of the sample report to remove it.

7. **Click Next.**
   Next the Report Wizard asks if you want to sort the records in your report. Simply select the field you want to use to sort the records. You can click the button to toggle between ascending and descending sort orders. You can also perform calculations in your report by clicking the Summary Options button.

8. **Select CompanyName from the list and click Next.**
   Next the Report Wizard asks how you want to display the data on the report. Click a layout option to see it previewed on-screen. You also specify the page orientation here.

   **NOTE:** If you’re trying to get a lot of fields onto your report, consider using Landscape orientation, which lays the page along its longest side.

9. **Select the Align Left 1 option and click Next.**
   Next the Report Wizard offers some interesting styles you can use in your report. Simply click a style to preview it on-screen. We’ll use the default style.

10. **Click Next.**
    You need to give your new report a name.

11. **Type Customers by Country in the text box and click Finish.**
    After a few moments your new report appears on-screen, as shown in Figure 2-24. You don’t have to worry about saving your new report—the Report Wizard does this for you automatically as part of the report creation process.

12. **Close the report.**

---

**Quick Reference**

To Create a Report using the Report Wizard:

1. From the database window click the Reports icon in the Objects bar and then double-click the Create reports using wizard icon.

2. Select the table or query you want to use to create your report and select the fields that you want to appear on the report. Click Next when you’re finished.

3. Specify the field(s) you want to use to sort the report and click Next (optional).

4. Select a field by which to group the report and click Next (optional).

5. Select a format for the report and click Next.

6. Give your report a name and click Finish.
Lesson 2-13: Creating Mailing Labels with the Label Wizard

For bulk mailings, nothing beats a good stack of mailing labels. The Access Label Wizard helps you quickly create labels for any number of uses: mailing labels, name tags—even labels for your floppy disks! The Label Wizard supports a huge variety of label sizes and brands (as long as they’re from Avery).

In this lesson you will use the Label Wizard to create a set of mailing labels.

1. **Click the Reports icon in the Objects bar.**
   Access lists all the reports in the current database.

2. **Click the Database Window’s New button.**
   The New Report dialog box appears, as shown in Figure 2-29.

3. **Select Label Wizard from the list but DON’T CLICK OK YET.**
   Anytime you create a report you have to tell Access which table or query contains the fields you want to use in your report.
4. **Select Customers from the Table or Query drop-down list and click OK.**
   The first screen of the Label Wizard appears, as shown in Figure 2-30. You can choose from templates set up for various types of labels under the “Filter by manufacturer” arrow. If you can’t find your labels there, you’ll have to click the Customize button and tell the Label Wizard how to set up your non-standard labels.

   **NOTE:** Make sure that the English option is selected under Unit of Measure.

5. **Select 5161 from the list and click Next.**
   The next window of the Label Wizard lets you change the font used in your label. You can format the font type, size, weight and color. If you’re satisfied with the default font (Arial 8 point) you can simply click Next.

6. **Click Next to accept the default font.**
   It’s time to tell the Form Wizard which fields you want to use, as shown in Figure 2-31. You’ve done this before: Double-click a field to add it or select the field and click the button.

7. **Double-click the ContactName field in the Available Fields list.**
   The ContactName field appears in the Prototype label. OK there’s a slight twist to the Label Wizard. The Label Wizard creates labels exactly how you tell it to. So if you want to place fields on separate rows you need to press <Enter> to move to the next row.
   Use the backspace key to delete a field from the Prototype label if you make a mistake.

8. **Press <Enter>, Double-click the CompanyName field in the Available Fields list, press <Enter>, double-click the Address field and press <Enter>.**
   If you want a character or text to appear on your labels you’ll need to type that in too. For example, in the next step you will have to type in the comma and space between the City field and the Region field.

9. **Double-click the City field, type a , (comma) followed by a <Spacebar>, double-click the Region field, press <Spacebar> and double-click the PostalCode field.**
   When you’re finished compare your prototype label to the one in Figure 2-31, then move on to the next step.

10. **Click Next.**
    The next window lets you sort your labels by any field. Simply double-click the field you want to use to sort the labels.

11. **Double-click the PostalCode field and click Next.**
    The final window of the Label Wizard appears. All you have to do now is give your new report a name.

12. **Type Customers Labels in the text box and click Finish.**
    **NOTE:** Depending on your computer’s printer setup, Access may warn you that some data may not be displayed. Go ahead and click OK.
    After a few moments your labels appear on-screen, as shown in Figure 2-32. You don’t have to worry about saving your new labels—the Label Wizard does this for you automatically as part of the report creation process.

13. **Close the labels.**
Lesson 2-14: Database Object Management

Not only can you view, open, and modify database objects (tables, queries, forms, etc.) from the Database window, you can also use it to cut, copy, paste, delete, and rename database objects.

1. **Ensure that you’re at the Database window in Lesson 2 and click the Tables icon in the Objects bar.**
   
   One reason to copy a database object is that it’s often easier to copy and use the design of an existing database object than it is to create a new object from scratch. For example, you might copy an Employees table so that you could create a new table using its structure.
   
   You can use standard cut, copy, and paste procedures on any Microsoft Access database object in the Database window. That’s right—the same cut and paste stuff you already know how to do with text, works with tables, queries, forms, and reports too!

2. **Select the Employees table and click the Copy button on the toolbar.**
   
   On the surface nothing appears to happen—but Microsoft Access has copied the Employees table to the Windows clipboard. Move on to the next step and paste the copied Employees table.

3. **Click the Paste button on the toolbar.**
   
   The Paste Table As dialog box appears, as shown in Figure 2-33. First you have to specify a name for the new table.

4. **Type Fired Employees in the Table Name box.**
   
   You have several options when you paste a table object—you can paste the:
   
   - **Structure Only**: Pastes only the structure or design of the table.
   - **Structure and Data**: Pastes the structure of the table and its data.

---

**Naming Conventions**

Intermediate and Advanced Access users use a standard naming convention to make it easy to identify database objects. You are strongly encouraged to use the following naming convention as well, as it makes it easier to refer to database objects in expressions, macros, and VB procedures.

<table>
<thead>
<tr>
<th>Object</th>
<th>Prefix</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table</td>
<td>tbl</td>
<td>tblSales</td>
</tr>
<tr>
<td>Query</td>
<td>qry</td>
<td>qrySales</td>
</tr>
<tr>
<td>Form</td>
<td>frm</td>
<td>frmSales</td>
</tr>
<tr>
<td>Report</td>
<td>rpt</td>
<td>rptSales</td>
</tr>
<tr>
<td>Page</td>
<td>dap</td>
<td>dapSales</td>
</tr>
<tr>
<td>Macro</td>
<td>mcr</td>
<td>mcrSales</td>
</tr>
<tr>
<td>Module</td>
<td>bas</td>
<td>basSales</td>
</tr>
</tbody>
</table>
Chapter Two: Creating and Working with a Database

- **Append Data to an Existing Table**: Adds the copied records to an existing table in the database.

  For this exercise we just need to paste the structure of the Employee table.

  5. **Select the Structure Only option and click OK.**
     Access pastes the copied Employees table as a new Fired Employees table.

     **NOTE**: You can also copy objects from one database to another using simple copy and paste commands. Copy the database object, start another session of Microsoft Access by clicking the Start menu and selecting Programs → Microsoft Access, and open the destination database. Click the Paste button to paste the copied object into the other database.

  6. **Double-click the Fired Employees table.**
     Notice that there aren’t any records in the Fired Employees table because you specified that you only wanted to copy the structure of the Employees table.

  7. **Close the Fired Employees table.**
     You can also rename a database object from the Database window. Here’s how:

  8. **Right-click the Fired Employees table, select Rename from the shortcut menu, type Previous Employees and press <Enter>.**
     The Fired Employees table is now named Previous Employees. Finally, here’s how to delete any database object.

  9. **Select the Previous Employees table and press the <Delete> key.**
     Confirm the deletion by clicking Yes.

Whenever you’re unsure or curious about what you can do with a database object, try right-clicking it. A shortcut menu will appear with a list of commands related to the database object. The following table contains some of the commands you’ll see on the database object shortcut menu.

<table>
<thead>
<tr>
<th>Commands</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens the selected object.</td>
</tr>
<tr>
<td>Design</td>
<td>Opens the selected object in Design View so that it can be modified.</td>
</tr>
<tr>
<td>Print</td>
<td>Sends the selected object to the default printer.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Displays how the selected object will appear when it is printed.</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts/moves the selected object to the Windows clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies/moves the selected object to the Windows clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes any cut or copied database object.</td>
</tr>
<tr>
<td>Save As/Export</td>
<td>Saves the selected object to a new object within the current database or exports it to another Access database or to a different file format.</td>
</tr>
<tr>
<td>Create Shortcut</td>
<td>Creates a shortcut on the Windows desktop to the selected object.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected object.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the selected object.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays the properties and settings for the selected object.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Cut/Copy and Paste a Database Object:

1. Select the database object.
2. Click the **Cut** button on the toolbar. Or…
   Click the **Copy** button on the toolbar.
3. Click the **Paste button** on the toolbar, enter a name for the new object and click OK.

To Rename an Object:

- Right-click the object, select **Rename** from the shortcut menu and enter a new name for the object.

To Delete an Object:

- Select the object and press the <Delete> key.
Lesson 2-15: File Management

File management includes moving, copying, deleting, and renaming the files you’ve created. Although it’s a little easier to work with and organize your files using Windows Explorer or My Computer, you can also perform a surprising number of file management chores from inside Microsoft Access 2000—especially with its new and improved Open and Save dialog boxes.

1. Click the **Open button** on the toolbar.
   The Open dialog box appears. The Open dialog box is normally used to open files, but you can also use it to perform several file management functions. There are two different ways to access file management commands from inside the Open or Save As dialog boxes:
   - Select a file and then select the command you want from the dialog box’s Tools menu.
   - Right-click a file and select the command you want from a shortcut menu.

2. **Right-click the Rename Me file.**
   A shortcut menu appears with a list of available file management commands for the selected file.

3. **Select Rename from the shortcut menu, type Home Budget and press <Enter>.**
   You have just changed the name of the selected file from “Rename Me” to “Home Budget.” Instead of right-clicking the file, you could have selected it and then selected Rename from the Tools menu. Move on to the next step to learn how to delete a file.

4. **Click the Home Budget file to select it and press the <Delete> key.**
   A dialog box appears, asking you to confirm the deletion of the Home Budget file.
5. **Click Yes.**

The Home Budget file is deleted. If you work with and create numerous files, you may find it difficult to remember what you named a file. To find the file(s) you’re looking for, it can help to preview your files without opening them.

6. **Click the View button arrow as shown in Figure 2-35 and select Details.**

The Open dialog changes the display of Access files in the Practice folder from List View to Details View. Change back to List view to display as many files in the window as possible.

7. **Click the View button arrow, select List to display the files in list view, then close the dialog box by clicking Cancel.**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Open</strong></td>
<td>Opens the selected file.</td>
</tr>
<tr>
<td><strong>Open Read-Only</strong></td>
<td>Opens the selected file so that it can be read but not changed.</td>
</tr>
<tr>
<td><strong>Open as Copy</strong></td>
<td>Creates a copy of the selected file with the name “Copy of” and the name of the original file, and then opens the new, copied file.</td>
</tr>
<tr>
<td><strong>Print</strong></td>
<td>Sends the selected file to the default printer.</td>
</tr>
<tr>
<td><strong>Quick View</strong></td>
<td>Displays the contents of the selected file without opening the file.</td>
</tr>
<tr>
<td><strong>Send To</strong></td>
<td>Depending on how your computer is set up, it lets you send the selected file to a printer, to an email recipient, to a fax, or to a floppy drive.</td>
</tr>
<tr>
<td><strong>Cut</strong></td>
<td>Used in conjunction with the Paste command to move files. Cuts, or removes, the selected file from its current folder or location.</td>
</tr>
<tr>
<td><strong>Copy</strong></td>
<td>Used in conjunction with the Paste command to copy files. Copies the selected file.</td>
</tr>
<tr>
<td><strong>Paste</strong></td>
<td>Pastes a cut or copied file or files.</td>
</tr>
<tr>
<td><strong>Create Shortcut</strong></td>
<td>Creates a shortcut—a quick way to a file or folder without having to go to its permanent location.</td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td>Deletes the selected file or files.</td>
</tr>
<tr>
<td><strong>Rename</strong></td>
<td>Renames the selected files.</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Displays the properties of the selected file, such as when the file was created or last modified, or how large the file is.</td>
</tr>
</tbody>
</table>
Lesson 2-16: Compacting and Repairing a Database

Cars require maintenance to keep them running at their peak performance. Databases are no different. Your Access database requires some routine maintenance to prevent and/or correct problems and to keep it running in top performance. This lesson covers the two database utility commands:

- **Compact Database**: When you delete a database object or record, it leaves behind an empty hole that the object previously occupied. This isn’t a big deal unless, over time, you have deleted lots of database objects and records. Compacting a database rearranges how the database is stored and reduces its file size.

- **Repair Database**: Over time, normal wear and tear causes errors to appear in your database, affecting its performance. Usually these errors are very minor and can easily be fixed by repairing the database.

Microsoft has combined compact and repair into a single command in Access 2000. When should you use the compact and repair command? If you have been busy adding, editing, and deleting records for a while, or if your database seems buggy, sluggish, or is generating error messages, it’s a good idea to run the Compact and Repair Database command. Here’s how to compact and repair a database:

1. **Select Tools → Database Utilities → Compact and Repair Database from the menu.**

   Your computer’s hard disk will make some noise as Access compacts and repairs the database, and repairs any errors it finds. The amount of time it takes to repair or compact a database depends on how large your database is, how long it’s been since you’ve last compacted and repaired it, and how fast your computer is.

   That’s all there is to compacting and repairing a database!

   Congratulations! You’ve gotten through the lesson, learned some difficult concepts, and know the essentials of creating a simple database!
Lesson 2-17: Converting an Access 97 Database

Unlike other programs in the Microsoft Office 2000 suite, Access 2000 saves its files in a different format than previous Access 97 databases. Thus you need to convert older Access 97 to the new Access 2000 format. This lesson explains how to do just that.

1. **Make a backup copy of the Access database you're going to convert.**
   Ninety-nine percent of the time you won’t encounter any problems when you convert a database, but it doesn’t hurt to play it safe. Remember Murphy’s Law: Anything that can go wrong usually does. Once you feel comfortable working with the converted Access 2000 database you can erase the backup.
   Once you’ve made your backup, move on to the next step.

2. **Close the Microsoft Access database you're going to convert.**
   Okay, you’re ready to convert the database!

3. **Select Tools → Database Utilities → Convert Database → To Current Access Database Version** from the menu.
   The Database To Convert From dialog box appears. Here you need to browse to and select the Microsoft Access 97 database file you want to convert.

4. **Browse to and double-click the Microsoft Access 97 database file you want to convert.**
   Next you need to type a new name for the newly converted Microsoft Access 2000 database file.
   **NOTE:** You cannot convert an Access database into a file with the same name and location as the original database.

5. **Type a name for the new Microsoft Access database file and click Save.**
   Microsoft Access converts the database to Access 2000 format.

6. **Close the Microsoft Access program.**

---

Quick Reference

To Convert an Access 97 Database to Access 2000:

1. Close any open databases and select **Tools → Database Utilities → Convert Database → To Current Access Database Version** from the menu.

2. Browse to and double-click the Microsoft Access 97 database file.

3. Type a name for the Access database file and click **Save**.

To Convert an Access 2000 Database to Access 97:

1. Open the database you want to convert and select **Tools → Database Utilities → Convert Database → To Prior Access Database Version** from the menu.

2. Type a name for the Access 97 database file and click **Save**.
Chapter Two Review

Lesson Summary

Planning a Database

- Know how to plan a good database design.

Creating a Database Using the Database Wizard

- To Create a Database using the Database Wizard: Click the New button on the toolbar or select File → New from the menu. Click the Database tab and double-click the Access database wizards, pages, and projects option. Double-click the type of database you want to create.

Creating a Blank Database

- To Create a New Blank Database: Click the New button on the toolbar, or select File → New from the menu, or press <Ctrl> + <N>. Then Select the Database template and click OK. Navigate to the drive and folder where you want to save the new database, then type a name for your new database in the File Name box and click Create.

Creating a Table Using the Table Wizard

- To Create a New Table using the Table Wizard: From the database window click the Tables icon in the Objects bar and then double-click the Create table using wizard icon then select the type of table you want to create. Follow the on-screen instructions and specify what you want to appear in your database.

Modifying a Table and Understanding Data Types

- To Display a Table in Design View: Open the table and click the View button on the toolbar or from the database window click the Tables icon in the Objects bar, select the table and click the Design button.

- To Change the Data Type for a Field: Display the table in Design View, click the field’s Data Type box, click the Data Type list arrow and select the data type.

- To Save Changes to a Database Object: Click the Save button on the toolbar, or Select File → Save from the menu, or Press <Ctrl> + <S>.

Creating a New Table from Scratch

- To Create a Table from Scratch: From the database window click the Tables icon in the Objects bar and then double-click the Create table in Design View icon. Type a field name in the Field name column, press <Tab> click the Data Type list arrow and select a data type for the field. Repeat the preceding steps as necessary to add additional fields. When you’re finished close the table window, click Yes to save the table, enter a table name, and then click OK.
Creating a Query in Design View

- **To Create a Query in Design View:** From the database window click the Queries icon in the Objects bar and then double-click the Create query in Design View icon. Select the table you want to add to the query and click Add—repeat as necessary to add additional tables or queries. When you’re finished click Close. Double-click each field you want to include from the field list. In the design grid, enter any desired search criteria for the field in the Criteria box and click the Sort box list arrow for the field and select a sort order. Close the query window and click Yes to save the query, enter a query name, and then click OK.

Modifying a Query

- **To Add a Field to a Query:** Click the Show Tables button on the toolbar, select the table you want to display and click Add. Repeat for any additional tables and click Close when you’re finished. Double-click each field you want to include from the field list, or drag the field from the field list onto the design grid.

- **To Delete a Query Field:** Click the top of the field you want to delete (changes to Delete) and press <Delete>.

- **To Rearrange Fields:** Position the pointer over the field (changes to ) and then click and drag the field to a new location.

Sorting a Query using Multiple Fields

- **To Sort a Query using Multiple Fields:** Open/display the query in Design View, click the Sort box list arrow for the first field you want to use to sort the query and select a sort order. Repeat for each additional field you want to use to sort the query, bearing in mind that the fields will be sorted from left to right.

Developing AND and OR Operators

- **To Create AND/OR Criteria:** Open/display the query in Design View, enter your criteria in the appropriate field’s first Criteria box, enter additional criteria as necessary. Enter additional criteria as follows:
  - **AND:** Enter additional criteria for one or more fields in the appropriate field Criteria box in the same row.
  - **OR:** Enter additional criteria for one or more fields in the appropriate field Criteria box, using a different row for each OR criteria.

Creating a Form with the Form Wizard

- **To Create a Form using the Form Wizard:** From the database window click the Forms icon in the Objects bar and then double-click the Create form using wizard icon. Select the table or query you want to use to create your form, select the fields that you want to appear on the form and click Next when you’re finished. Select the type of form you want to create and click Next, select a format for your form and click Next, give your form a name and click Finish.

Creating a Report with the Report Wizard

- **To Create a Report using the Report Wizard:** From the database window click the Reports icon in the Objects bar and then double-click the Create reports using wizard icon. Select the table or query you want to use to create your report and select the fields that you want to appear on the form. Click Next when you’re finished. Specify the field(s) you want to use to sort the report and click Next (optional) or select a field to group the report by and click Next (also optional). Select a format for the report and click Next, and give your report a name and click Finish.
Creating Mailing Labels with the Label Wizard

- **To Create Labels:** From the database window click the Reports icon in the Objects bar, click **New**, select the Label Wizard from the list and click **OK**. Select the table or query you want to use to create your labels, click **Next**, select the product manufacturer and number for your labels click **Next**, select the fields that you want to appear on the form and enter any text, click **Next** when you're finished. Give your labels a name and click **Finish**.

Database Object Management

- **To Cut/Copy and Paste a Database Object:** Select the database object, click the **Cut button** or **Copy button** on the toolbar, click the **Paste button** on the toolbar, enter a name for the new object and click **OK**.
- **To Rename an Object:** Right-click the object, select **Rename** from the shortcut menu and enter a new name for the object.
- **To Delete an Object:** Select the object and press the <Delete> key.

File Management

- **Basic File Management in the Open Dialog box:** Open the Open File dialog box by clicking the **Open button** on the toolbar or selecting **File → Open**, right-click the file and select the desired command.

Compacting and Repairing a Database

- **To Compact and Repair a Database:** Select **Tools → Database Utilities → Compact and Repair Database** from the menu.

Converting an Access 97 Database

- **To Convert an Access 97 Database to Access 2000:** Close any open databases and select **Tools → Database Utilities → Convert Database → To Current Access Database Version** from the menu. Browse to and double-click the Microsoft Access 97 database file. Type a name for the Access database file and click **Save**.
- **To Convert an Access 2000 Database to Access 97:** Open the database you want to convert and select **Tools → Database Utilities → Convert Database → To Prior Access Database Version** from the menu. Type a name for the Access 97 database file and click **Save**.

**Quiz**

1. **Which of the following is NOT a step in planning a database?**
   
   A. Determine the fields you’ll need and their data type.
   B. Determine the tables you’ll need.
   C. Use the Database Planning Wizard to help determine the structure of your database.
   D. Determine the purpose of the database: the information you want to put into it and the reports you want to come out of it.
2. **Which of the following statements is NOT true?**
   A. The Database Wizard steps you through the process of creating a database and provides you with ready-to-use tables, forms, queries, and reports.
   B. Datasheet View lets you view and modify the structure of any database object.
   C. The Table Wizard asks you a series of questions about what you want to appear in a table and then creates the table for you.
   D. You can add criteria to a query to determine which records are displayed.

3. **Which of the following is NOT a data type?**
   A. Text.
   B. Number.
   C. Picture/Graphic.
   D. Date/Time.

4. **You can add a field to a query without displaying it in the query results.** (True or False?)

5. **Which of the following statements is NOT true? (Select all that apply)**
   A. To add a field to a query, double-click the field from the field list.
   B. Selecting the asterisk (*) in a query is the same as selecting all of a table’s fields.
   C. You can only specify one set of criteria for each query—for example to display customers from Texas AND from Minnesota you would have to create two separate queries.
   D. You can sort a query’s records by clicking the Sort box list arrow for the field you want to use to sort the query, and selecting a sort order.

6. **The fastest and easiest way to create a form or report is with the Form Wizard or the Report Wizard.** (True or False?)

7. **Microsoft Word is required in order to print mailing labels with Microsoft Access.** (True or False?)

8. **Which of the following two statements is NOT true? (Select all that apply.)**
   A. Just as you can with files, you can cut, copy, paste, rename, and delete Microsoft Access database objects.
   B. Whenever you don’t know how to do something to a database object, right-click the object. A shortcut menu listing everything you can do to the object will appear.
   C. When entered in the criteria row of a query design grid, the expression <>“MN” would display only those records equal to “MN”.
   D. Avery labels are a non-standard product and should never be used for mailing labels.

9. **What is the maximum length a text field can be?**
   A. 512 characters.
   B. There is no limit to how long a text field can be.
   C. 50 characters.
   D. 255 characters.
10. **What is the memo data type field used for?**
   - A. To add an electronic Post-It® Note reminder to any record.
   - B. For long text entries of one or more sentences.
   - C. For short text entries of no more than 255 characters.
   - D. To store objects created in other programs such as a graphic or Microsoft Word document.

11. **Which of the following criterion would find records whose Personality field does not equal “Nice”?**
   - A. <> Nice.
   - B. NOT Nice.
   - C. IS NOT Nice.
   - D. <>"Nice".

12. **What happens when you add the asterisk (*) from any Field List to a query?**
   - A. The query uses the records from the table without displaying them.
   - B. The query sorts the table’s records in the order you specify.
   - C. The query will include every field from the table.
   - D. The table will not include any fields from the table.

13. **You want to sort a query by a table’s LastName field. In order to do this, the LastName field MUST appear in the displayed results of the query.** (True or False?)

14. **Where do reports and forms get their information from? (Select all that apply.)**
   - A. Tables.
   - B. Queries.
   - C. Forms.
   - D. Modules.

15. **What is the first step in creating a form or report with the Form Wizard or Report Wizard?**
   - A. Selecting how the form or report should be formatted.
   - B. Selecting the underlying table or query on which you want to base the form or report.
   - C. Reading several screens of mostly useless information and clicking Next.
   - D. Selecting the fields that you want to appear in the form or report.

---

**Homework**

1. Start Microsoft Access.
2. Create a new blank database named Homework 2.
3. Create a new table in Design View that contains the following fields:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last</td>
<td>Text</td>
</tr>
<tr>
<td>First</td>
<td>Text</td>
</tr>
<tr>
<td>Phone</td>
<td>Text</td>
</tr>
</tbody>
</table>
4. Save the table as Phone Numbers.
5. Use the Forms Wizard to create and save a columnar form named Phone Log, using the Phone Numbers table as the data source.
6. Use the Reports Wizard to create and save a tabular report named Phone Log, using the Phone Numbers table as the data source.

Quiz Answers

1. C. Since there isn’t a Database Planning Wizard you can’t use it to help determine the structure of a database.
2. B. Design View lets you view and modify the structure of any database object. Datasheet View lets you view the records in a table, query, or form in a grid format.
3. C. There isn’t a Picture/Graphic field in Microsoft Access, although OLE fields can store pictures and graphics, in addition to other files created with external programs.
4. True. You can include a field in a query without displaying it in the query results by unchecking its Show box.
5. C. You can specify additional AND / OR criteria to a query by entering it in the appropriate AND / OR criteria rows.
6. True. Once you create a form or report using the Form Wizard or the Report Wizard you can modify it to better suit your needs.
7. False. The Mailing Label Wizard, including with Microsoft Access, makes creating mailing labels a snap.
8. C and D. The expression <>"MN" would display only those records that are not equal to “MN” and Avery is the standard of the label industry.
9. D. A text field can have a maximum length of 255 characters.
10. B. The memo data field type is used long text entries of one or more sentences.
11. D.
12. C. Adding the asterisk (*) from a Field List is the same as adding every field from the table.
13. False. You can sort the results of a query without displaying the field you used to sort the query.
14. A and B. Reports and forms get their information from tables and queries.
15. B. The first step in creating a form or report with the Form Wizard or Report Wizard is to select the underlying table or query for the form or report.
Chapter Three:
Finding, Filtering, and Formatting Data

Chapter Objectives:

- Find and replace database information
- Sort table information in ascending or descending order
- Filter information by selection
- Filter information by form
- Create an advanced filter
- Adjust the row height and column width in a datasheet
- Freeze and hide a datasheet's columns
- Change the appearance of a datasheet

Chapter Task: Filter and sort information in a table and change the appearance of a datasheet

As databases grow larger and larger, finding a specific record or group of records becomes harder and harder. Fortunately, Microsoft Access is equipped with an arsenal of Find, Sort, and Filter commands that can track down and organize a table’s information in record time.

In this chapter you will learn how to use these commands. First, you’ll learn how to use the Find command to lookup a specific record. Next, you’ll learn how to sort information in a table—in ascending or descending order. Then, you’ll learn all about filters: How they can find and display only records that meet your criteria, such as customers from the state of Texas.

Once you’ve learned how to organize and sort all that information, you’ll learn how to make it look more professional. This chapter explains how to format a datasheet to change its font and appearance. You will also learn how to freeze and hide columns in a datasheet—an important task if you need to view large amounts of information.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.
Lesson 3-1: Finding and Replacing Information

Finding specific records or information in a large database would be like finding a needle in a haystack if it weren’t for the Find feature. Find allows you to quickly search tables, queries, and forms for specified text—a critical database task.

Select a field to search through that field in all records. This is usually quicker, especially if the field is indexed. Or, select the datasheet or form to search through all fields in all records.

The Find and Replace feature is very useful. Imagine you are working on a huge database that tracks the feeding patterns of squirrels. You’re almost finished when you realize that you’ve mistakenly referred to one of the species of squirrels you’re tracking—flying squirrels—not by their proper scientific name “Sciuridae Glaucomys” but by the scientific name for the common gray squirrel “Sciuridae Sciurus.” Yikes! It will take hours to go back and find every instance of “Sciuridae Sciurus” in your database and replace it with “Sciuridae Glaucomys.” Or it could take you less than a minute if you use Access’s find and replace function.

1. Start Microsoft Access, open the Lesson 3 database and then find and open the Employees table.
   First you need to put the cursor in the field that contains the data you want to look for. For this exercise we’ll search the City field.

2. Click anywhere in the City field.
   Here’s how to open the Find dialog box.

3. Click the Find button on the toolbar.
   The Find dialog box appears, as shown in Figure 3-1. You tell Access what you’re looking for in the Find What box.

---

**Figure 3-1**
The Find dialog box.

**Figure 3-2**
The Find and Replace dialog box.
Chapter Three: Finding, Filtering, and Formatting Data

4. In the **Find what box** type *Redmond.*

Also important is the Match combo box, which has the following options:

- **Match combo box:** See Table 3-1: Using the Match List Options for a description of the Match combo box and its options.
- **Match Case check box:** Finds only text that has the same pattern of uppercase and lowercase characters as the text you specified.
- **Search Fields As Formatted check box:** Check to find data based on its display format, not its value (slower).

**NOTE:** You may have to click the More button to see all these options.

5. **Click the Find Next button.**

Access jumps to the first (and only) occurrence of the word “Redmond” it finds in the table.

6. **Click Cancel.**

The Find dialog box closes. You can also replace information in a datasheet.

7. **Click anywhere in the Title field and select Edit → Replace from the menu.**

The Replace dialog box appears, as shown in Figure 3-2.

8. **In the Find what text box type *Sales Representative.***

You want to replace every occurrence of the phrase “Sales Representative” with the phrase “Sales Associate”.

9. **Select the Replace with text box by clicking it or by pressing the <Tab> key and type *Sales Associate.***

10. **Click Replace All.**

A pop-up window appears reminding you that you can’t Undo this operation and asking you if you’re sure you want to continue. Click Yes.

Access finds all the occurrences of the phrase “Sales Representative” in the table and replaces them with the words “Sales Associate.”

**NOTE:** Think before you use the Replace All button—you might not want it to replace every instance of a label or value! You can find and replace each individual occurrence of a label or value by clicking Find Next and then Replace.

11. **Click Cancel.**

The Replace dialog box disappears and you’re back to your datasheet. Notice how all the occurrences of the phrase “Sales Representative” have been replaced by the phrase “Sales Associate”.

### Table 3-1: Using the Match List Options

<table>
<thead>
<tr>
<th>Match</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole Field</td>
<td>Finds only data that is exactly the same.</td>
</tr>
<tr>
<td>Example:</td>
<td>John finds John, but not Johnson, or Sue and John.</td>
</tr>
<tr>
<td>Any Part of Field</td>
<td>Finds data anywhere in the field.</td>
</tr>
<tr>
<td>Example:</td>
<td>John finds John, Johnson, and Sue and John.</td>
</tr>
<tr>
<td>Start of Field</td>
<td>Finds data only at the beginning of the field.</td>
</tr>
<tr>
<td>Example:</td>
<td>John finds John, and Johnson, but not Sue and John.</td>
</tr>
</tbody>
</table>

### Other Ways to Find and Replace Information:

- Press <Ctrl> + <H>.

### Quick Reference

**To Find Information:**

1. Click the **Find button** on the toolbar.
   Or...
   Press <Ctrl> + <F>.
   Or...
   Select **Edit → Find** from the menu.

2. Enter the text you want to search for in the **Find What** box.

3. **Click the Find Next button.**

4. Repeat Step 3 until you find the text you’re looking for.

**To Find and Replace Information:**

1. Select **Edit → Replace** from the menu.
   Or...
   Press <Ctrl> + <H>.

2. Enter the text you want to search for in the **Find What** box.

3. Enter the text you want to replace the word with in the **Replace With** box.

4. **Click the Find Next button.**

5. **Click the Replace button to replace the text.**

6. Repeat Steps 4 and 5 if there is more than one occurrence that you want to replace.

Or...

Click **Replace All** to search and replace every occurrence of text in the table.
Lesson 3-2: Sorting Records

When you enter new records into a table they are added at the end of the table in the order you enter them. Working with information in such a jumbled order can be difficult if not impossible. Fortunately you can sort, or change the order of records in a table. You can sort records alphabetically, numerically, or chronically (by date.) Additionally, you can sort information in ascending (A to Z) or descending (Z to A) order. This lesson will show you several techniques you can use to sort information in your tables, queries, pages and forms.

NOTE: If you frequently sort a table the same way you should consider creating and using a query that automatically sorts the table data for you. For example, a query that sorts a table alphabetically by name.

1. If it isn’t already open, find and open the Employees table.
   First you need to put the cursor in the field you want to use to sort the table. You want to sort the list by the last name, so you would select the Last Name field.

2. Click anywhere in the Last Name field.
   Here’s how to sort a table:
3. **Click the Sort Ascending button on the toolbar.**
   Access sorts the table, ordering the records in ascending (A-Z) order by last name, as shown in Figure 3-4. You can also sort a list in descending (Z-A) order.

4. **Click the Sort Descending button on the toolbar.**
   The list is sorted in descending (Z-A) order by the Last Name field.
   Let’s try sorting the table using a different field.

5. **Click anywhere in the BirthDate field and click the Sort Ascending button on the toolbar.**
   Access sorts the table by the BirthDate field and we instantly discover that poor Margaret Peacock is the oldest employee in the company.

<table>
<thead>
<tr>
<th>Table 3-2: Sort Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>Ascending</td>
</tr>
<tr>
<td>Descending</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Sort Records by One Field:
1. Click in the column you want to use to sort the list.
2. Click either the **Sort Ascending button** or **Sort Descending button** on the toolbar.
Lesson 3-3: Filtering by Selection

Sometimes you may want to see only certain records in your table. By filtering a table, you display only the records that meet your criteria and hide the records that do not. For example, you could filter a client list to display only clients who live in California.

There are several filter methods:

- **Filter by Selection:** The fastest and easiest of the three filter commands. Simply find and select the value you want to use as the filter criteria, and then use Filter By Selection to find all records with the selected value.

- **Filter by Form:** Here you type your filter criteria into a blank form that contains all the field names in the table. Works well if you have more than one criteria.

- **Advanced Filter/Sort:** The most powerful and complicated filter method. Creating an advanced filter is really not any different from creating a query.

In this lesson, you will learn the fastest and easiest way to filter a list with the nifty Filter by Selection feature.
If it isn’t already open, find and open the Employees table in Lesson 3. The first step is finding a record and field that matches your criterion. For example, to find all the addresses from Minnesota you would put the cursor in any State field that contained MN.

2. Find the Region field and then right-click any WA value.
A shortcut menu with the Filter by Selection command appears, as shown in Figure 3-5. Notice that the shortcut menu actually contains four filter-related commands: you can read more about these other commands in Table 3-3: Filter Shortcut Menu Commands.

3. Select Filter By Selection from the shortcut menu.
Access filters the table so that only records that contain WA in the Region field are displayed, as shown in Figure 3-6. Notice the bottom of the table window tells you the number of records that match your filter criteria. Also the message (Filtered) indicates that the table is currently being filtered.

Here’s how to remove a filter:

4. Click the Remove Filter button on the toolbar.
All the records in the table are displayed.

The opposite of Filter by Selection is Filter Excluding Selection, which filters all records that don’t contain the criteria value. For example, to find all the addresses that aren’t from Minnesota you would put the cursor in any State field that contained MN.

5. Find the City field and then right-click any London value. Select Filter Excluding Selection from the shortcut menu.
This time Access displays all the records that do not contain London in the City field.

6. Click the Remove Filter button on the toolbar.
All the records in the table are displayed.

The following table describes the filter commands that appear in the table shortcut menu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter by Selection</td>
<td>Finds and displays all records with the selected value.</td>
</tr>
<tr>
<td>Filter Excluding Selection</td>
<td>Finds and displays all records that don’t contain the selected value.</td>
</tr>
<tr>
<td>Filter For</td>
<td>Finds and displays all records that match the text you enter.</td>
</tr>
<tr>
<td>Remove Filter/Sort</td>
<td>Removes the applied filter from the table.</td>
</tr>
</tbody>
</table>
Lesson 3-4: Filtering by Form

Filtering by Form makes it easy to create a filter that uses more than one criterion. The Filter by Form window enables you to enter your filter criterion by picking values that you want the filtered records to have.

If you look at Figure 3-7 you’ll notice that several tabs appear at the bottom of the Filter by Form window. If you specify more than one criterion on the same Filter by Form tab, Access treats it as an AND criteria statement, meaning that a record must match all the criterion in order to be displayed. For example you could filter for employees from Washington AND who had been with the company for more than 5 years.

If you specify filter criterion on different tabs Access treats it as an OR criteria statement, meaning a record has to match the criterion on one tab or the other to be displayed. For example you could filter for employees from California OR Minnesota.

1. If it isn’t already open, find and open the Employees table.
   First you need to display the Filter by Form window.

2. Click the Filter by Form button on the toolbar.
   The Filter by Form window, which looks like an empty replica of your table, appears as shown in Figure 3-7.
   The Filter by Form window may already contain a value from a previous filter. If that’s not a field that you want to use in your filter you can press <Delete> to clear the old criteria.

3. Press <Delete> to delete any old filter criteria.
   Next you have to select the field and value you want to use as your criteria.

4. Click the City field.
   A down arrow appears in the field that the cursor is in. Click this down arrow to see a list of values used in that field.
Chapter Three: Finding, Filtering, and Formatting Data

5. Click the ✉️ City arrow and select London from the list.
   This will display only records whose City field contains London.
   You can create an AND criteria statement by specifying more than one criterion on the same Filter by Form tab. For example you could filter for employees from London AND who have been employed before 1994.

6. Click the Title field, click the ✉️ Title arrow and select Sales Manager from the list.
   This will display only records from London and whose Title is Sales Manager.

7. Click the Apply Filter button on the toolbar.
   Access applies the filter and displays only those records whose City Field equals “London” AND whose Title field equals “Sales Manager.” Only one record meets the filter criteria. Let’s try modifying the query and adding an OR criteria statement.

8. Click the Filter by Form button on the toolbar.
   If you have another set of criteria or rules to filter records by, click the Or tab at the bottom of the Filter by Form window.

9. Click the Or tab at the bottom of the Filter by Form window.
   Access displays another blank Filter by Form window. Access will search for any criterion you enter on this tab in addition to your original criterion. You decide to filter for records whose City Field equals “London” AND whose Title field equals “Sales Manager” OR whose title is “Vice President, Sales”.

10. Click the Title field and select Vice President, Sales from the list.
    Notice a new Or tab appears at the bottom of the Filter by Form window. You can use as many “Or” statements as you need to define all your filter criteria.

11. Click the Apply Filter button on the toolbar.
    Access applies the filter and displays records whose City Field equals “London” AND whose Title field equals “Sales Manager” OR whose title is “Vice President, Sales”.

12. Click the Remove Filter button on the toolbar.
    Access once more displays all the records in the table.

Here are some criteria operators and examples you can use in your filters.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>=&quot;MN&quot;</td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>&lt;&gt;&quot;MN&quot;</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt;10</td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>&lt;=10</td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td>&gt;</td>
<td>&gt;10</td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>&gt;=10 AND &lt;&gt;5</td>
<td>Finds records greater than or equal to 10 and not equal to 5.</td>
</tr>
</tbody>
</table>
| LIKE     | LIKE "S*"             | Finds text beginning with the letter S. You can use LIKE with wildcards such as *.

Quick Reference

To Filter by Form:
1. Click the ✉️ Filter by Form button on the toolbar.
2. Click the empty text box below the field you want to filter, click the drop-down arrow and select the value you want to use to filter the records.
3. Repeat Step 2 for each additional field you want to specify additional filter criteria.
4. If you want to use Or criteria, click the Or tab at the bottom of the screen to specify the additional filter criteria.
5. Click the ✉️ Apply Filter button on the toolbar.
Lesson 3-5: Creating an Advanced Filter

The most powerful filter is the Advanced Filter. The Advanced Filter is so powerful that you can think of it as a baby query. In fact, the procedure for creating an Advanced Filter is virtually the same as it is for creating a simple query. The problem with Advanced Filters is that they can be difficult to set up the first few times—especially if you’re new to Access.

Advanced Filters have many advantages. They have the ability to:

- **Sort by multiple fields**: You can sort records using several fields. For example, you could sort a table alphabetically by last name and then by first name.
- **Use complex filter criteria and expressions**: You can use advanced expressions and operators to search for data. For example you could filter for dates that fall *Between* 1/1/95 and 12/31/99.
- **Use multiple AND/OR statements**: You can use more than one criteria to sift through records. For example you could filter for employees from Washington *AND* who had been with the company for more than five years.

This lesson explains how to get your own Advanced Filters up and running.

1. **If it isn’t already open, find and open the Employees table.**
   Here’s how to create an Advanced Filter/Sort:

2. **Select Records → Filter → Advanced Filter/Sort from the menu.**
   The Filter window appears, as shown in Figure 3-8. The Advanced Filter will probably contain criteria from a previous filter that will have to be removed.
3. Click the **Clear Grid button** from the toolbar to clear the grid of any preexisting criteria.

   You’re ready to create your Advanced Filter. Notice in Figure 3-8 that the window is split. The top half contains a box labeled Employees, which displays all the fields in the current table. The bottom half of the screen contains a design grid, which is where the filter information goes.

   The first thing you need to do is select the fields that you want to use in your filter. You can add fields to the design grid in two ways:
   - By double-clicking the field on the field list, or
   - By clicking and dragging the field down to the design grid yourself.

   Because the field list doesn’t have a lot of room you will usually need to use the field list’s scroll bar to scroll up or down the list.

4. **Double-click the Last Name field in the field list.**

   Access adds the LastName field to the design grid.

5. **Add the FirstName, City, Hire Date, and Region fields to the design grid.**

   You can use any field on the design grid to sort or filter the table. To sort by a field click the Sort row in the column that contains the field that you want to sort and select Ascending or Descending from the list.

6. **Click the LastName column’s Sort row and select Ascending.**

   This will sort the table by the LastName field in Ascending order. You can also sort by more than one field. For example, you could sort by LastName and then by FirstName.

   When you use several fields to sort a table Access performs the sort in the order the fields appear in the design grid.

7. **Click the FirstName column’s Sort row and select Ascending.**

   Next you need to specify the criteria for the Advanced Filter. You type the criteria in the design grid’s Criteria row.

8. **Click the City column’s Criteria row and type London.**

   If you specify more than one criterion in the same Criteria row, Access treats it as an AND criteria statement, meaning a record must match all the criterion, in order to be displayed. For example you could filter for employees from Washington AND those hired after January 1, 1993.

9. **Click the HireDate column’s Criteria row and type >1/1/93.**

   This criteria will display only records whose HireDate is greater than (or after) 1/1/93.

   Because it’s on the same Criteria row as the City field’s London criteria, the filter will display other those records whose City field equals London and whose Hire Date is after 1/1/93.

   If you specify filter criterion on different Criteria rows, Access treats it as an OR criteria statement, meaning a record has to match the criterion on one tab or the other to be displayed. For example you could filter for employees from California OR Minnesota.

10. **Click the Region column’s Second Criteria row and type WA.**

    Your completed design grid should look similar to the one shown in Figure 3-9. You’re ready to try the Advanced Filter.

11. **Click the Apply Filter button on the toolbar to apply the filter.**

    The Advanced Filter window closes and Access applies the filter and displays the records that meet your criterion.

12. **Click the Remove Filter button to remove the filter.**
Lesson 3-6: Adjusting Row Height and Column Width

Figure 3-10
Adjusting the width of a column.

Figure 3-11
The resized column.

Figure 3-12
Adjusting the height of a row.

Figure 3-13
The resized row.

Access is usually pretty smart about how wide to make the columns of a table or query so hopefully you won’t have to do much resizing. Sometimes, however, you will discover that some of the columns or rows are not large enough to display the information they contain. This lesson explains how to change the width of a column and the height of a row.

1. **If it isn’t already open, find and open the Employees table.**
   Most of the columns in this table are wide enough to display all their information. The Title column however, needs to be slightly wider.

2. **Carefully position the pointer over the right edge of the Title field, until it changes to a ‡.**
   Once the pointer is positioned over the column line and appears as a ‡, you can adjust the column width to make it smaller or wider.

3. **Click and hold the mouse button and drag the line to the right until about a half-inch, as shown in Figure 3-10, then release the mouse button.**
   Access resizes the width of the Title column.
You can also have Access automatically adjust the width of a field or column so that it can hold the widest entry. This neat feature is called *AutoFit*. To use AutoFit simply double-click the right edge of the column or field you wish to adjust.

4. **Scroll to the right until the Address field is displayed. Double-click the right edge of the Address field name to automatically adjust its width.**
   
   AutoFit automatically adjusts the width of the Address field so that it is wide enough to display its longest entry.
   
   Unless you are working with a table that contains several memo fields with lots of text you will probably want to stick with the default row height. The procedure for adjusting the height of a row is almost the same as adjusting the width of a column—simply click and drag the bottom of any record’s row heading.

5. **Move the pointer to the record selection area and carefully position the pointer between any two records, until it changes to a †.**
   
   Once the pointer appears as a † you can adjust the row height to make it smaller or wider.

6. **Click and hold the mouse button and drag the line down until the row height doubles, as shown in Figure 3-12, then release the mouse button.**
   
   The height of all the rows in the table is doubled.

Splendid! In just one lesson you’ve learned how to adjust the width of columns and the height of rows in a datasheet.

---

### Quick Reference

**To Adjust the Width of a Column:**
- Drag the column header’s right border to the left or right.

Or...
- Right-click the column header(s), select **Column Width** from the shortcut menu, and enter the column width.

Or...
- Select the column header(s), select **Format → Column Width** from the menu and enter the column width.

**To Adjust the Height of a Row:**
- Drag the row header’s bottom border up or down.

Or...
- Right-click the row header(s), select **Row Height** from the shortcut menu, and enter the row height.

Or...
- Select the row header(s), select **Format → Row Height** from menu and enter the row height.

**To Automatically Adjust the Width of a Column or Row:**
- Double-click the right border of the column or bottom border of a row.
Lesson 3-7: Rearranging Columns

Hopefully when you first created a table you thought about its field order, so that most of the time your data will appear in the order you want. Sometimes, however, you may want to temporarily change the column order of a table.

This lesson explains how to move a field to a different location on the datasheet.

1. If it isn’t already open, open the Employees table.
   For this exercise imagine, you have to call all the people listed in the Employees table. The only problem is that you can’t view both the employee name fields and Home Phone fields at the same time. To fix this problem you decide to move the Home Phone field next to the employee name fields.
   Here then, is how to move a field or column.

2. Scroll to the right until you find the Home Phone field. Click the Home Phone field name to highlight the column. Click again and hold the mouse button down until the arrow pointer appears.
   Now you have to drag the column to its new destination. If the destination is too far to the left or right to appear on the screen, drag the column to the left or right of the window—the datasheet will scroll in that direction.

3. Drag the Home Phone column to the far left of the window to scroll the datasheet to the left.
   Make sure you keep holding down the mouse button! As you move the column, a bar moves between the columns, showing where the column will go when you release the mouse button, as shown in Figure 3-14.

4. Drag the column to the right of the Region field and release the mouse button to drop the column.
   The Home Phone column and all its data moves next to the Region field.
Lesson 3-8: Changing Gridline and Cell Effects

Unless you are the type of person who likes to frequently change their Windows desktop wallpaper or rearrange your bedroom furniture on a monthly basis, you can safely skip this lesson. Changing the appearance of cells in a table is purely cosmetic and is probably one of the least important things to know about Access.

Are you still there? Okay, here’s how to give a table a three-dimensional look.

1. **If it isn't already open, open the Employees table.**

2. **Select Format → Datasheet from the menu.**

   The Datasheet Formatting dialog box appears, as shown in Figure 3-15. You can select one of the 3-D effects from the Cell Effect area. See Figure 3-16 for an illustration of each of these cell effects.

   You can also change the color of a table’s gridlines (the lines that separate the rows and columns) and background. Unless you have a compelling reason for doing so, you should normally leave these color settings as they are.

   If you don’t want gridlines at all, set the Cell Effect to Flat and uncheck both of the Gridlines Shown boxes.

3. **Select the Cell Effects options you want.**

   The Sample area of the dialog box displays how the Cell Effects settings will appear.

4. **Click OK when you’re finished making the Cell Effect settings.**

   The datasheet changes according to your settings.

---

**Figure 3-15**

The Cell Effects dialog box.

**Figure 3-16**

Examples of the three cell effect options: Flat, Raised, and Sunken.

---

**Quick Reference**

To Change a Datasheet's Gridline Effects:

1. Select Format → Datasheet from the menu.
2. Select the effects option you want and click OK.
Lesson 3-9: Freezing a Field

Figure 3-17
Freeze a field by right-clicking the Field Name and selecting Freeze Columns from the shortcut menu.

Figure 3-18
Information in the frozen field remains on the screen as you scroll and move through the table.

Most tables have so much information that it won’t all fit on the same screen. When this happens, you have to scroll through the datasheet to add, delete, modify, and view information. The problem with scrolling and viewing information in a large table is that it can be confusing when you can’t see such important information as names or product numbers.

To overcome this problem, you can freeze a field so it stays in the same place while you scroll around the rest of the table.

1. **If it isn’t already open, open the Employees table.**
   
   Here’s how to freeze a field.

2. **Right-click the LastName field name and select Freeze Columns from the shortcut menu.**
   
   The LastName field is now frozen and will always remain visible as you move through the rest of the table. Try scrolling the table window to see for yourself.

3. **Scroll the table to the right to view all its data.**
   
   Notice how the frozen LastName field stays on the screen as you scroll the table, allowing you to always be able to see the last name for each record. Now you’re ready to unfreeze the LastName field.

4. **Select Format → Unfreeze All Columns from the menu.**
   
   All the fields in the table are now unfrozen.

Quick Reference

To Freeze a Column:
- Right-click the column field name you want to freeze and select **Freeze Columns** from the shortcut menu.

To Unfreeze a Column:
- Select **Format → Unfreeze All Columns** from the menu.
Lesson 3-10: Hiding a Column

A hidden column or field is still in your table—you just can’t see it. You can temporarily hide a column when you want to reduce the amount of information that is displayed on the screen. The procedure for hiding and unhiding a column is almost the same as freezing a column. Here it is:

1. **If it isn't already open, open the Employees table.**
   Here's how to hide a field.

2. **Right-click the LastName field name and select Hide Columns from the shortcut menu.**
   The LastName field is temporarily hidden from view.
   You can select and hide several columns at once by clicking the first field name and then dragging to the last field name but you will have to select Format → Hide Columns from the menu because you cannot right-click the columns to display the shortcut menu without de-selecting the columns.
   When you want to make your hidden columns reappear try this:

3. **Select Format → Unhide Columns from the menu.**
   The Unhide Dialog box appears, as shown in Figure 3-19. To re-display a column, simply click the check box next to the field you want to see again.

4. **Click the LastName check box and click Close.**
   Poof! The LastName field is re-displayed.

---

**Figure 3-19**
Hide a field by right-clicking the Field Name and selecting Hide Columns from the shortcut menu.

**Figure 3-20**
The Unhide Columns dialog box lets you check and uncheck the columns you wish to hide or display.

---

**Quick Reference**

To Hide a Column:
- Right-click the column field name you want to hide and select Hide Columns from the shortcut menu.

To Unhide a Column:
- Select Format → Unhide Columns from the menu.
Lesson 3-11: Changing the Datasheet Font

Being a practical business program, Access displays its tables in a no-nonsense, easy-to-read font. You can change the font used to display table data. You can make the text darker and heavier (bold), slanted (italics), larger, appear in a different typeface or color. Most people are satisfied with the default font used in tables, and if you’re one of them, you may want to skip this lesson.

One very important note about changing a table’s font: The font settings you make apply to the entire table, not just a particular cell, column, or row.

Here’s how to change the font used in a table.

1. **If it isn’t already open, open the Employees table.**
   Once you have the table in Datasheet View you can change its font.

2. **Select Format → Font from the menu.**
   The Font dialog box makes its entrance, as shown in Figure 3-21. To select a new font simply find and click it from the Font list.

3. **Scroll down the Font list until you find Times New Roman. Click the Times New Roman font.**
   The table data will now be displayed using the Times New Roman font.

   **NOTE:** When selecting fonts always try to use a TrueType font. TrueType fonts are the universal font standard used by Windows and they look great when printed. TrueType fonts have a double-T icon next to them.

   Next try changing the font size. Font sizes are measured in points (pt.) which are 1/72 of an inch. The larger the number of points, the larger the font. Here’s how to change font size:
4. **Select 11 from the Size list.**
   Notice the Sample area of the Font dialog box displays what your new font setting will look like.
   You’ve finished making changes to the font settings so move on to the next step.

5. **Click OK to save your font change settings and close the Font dialog box.**
   The Font dialog box closes and Access displays the table with the new font settings.
   Don’t like your new font settings? Don’t worry—you can always close a table without saving your layout changes.

6. **Close the Employees table without saving any of your layout changes.**
   There are several other font formatting options available in the Font Dialog box. The purpose of this lesson isn’t to go through all the font options, but to explain how to use the Font Dialog box. You can experiment with the different font formatting options to see what they do. Table 3-5: Font Formatting Options explains the different options in the Font dialog box.

### Table 3-5: Font Formatting Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Font</strong></td>
<td>Displays and allows you to change the font to any font installed on your computer.</td>
</tr>
<tr>
<td><strong>Font style</strong></td>
<td>Formats the style of the font: Regular (no emphasis), Italic, Bold, and Bold Italic.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Displays and allows you to increase or decrease the size of the font.</td>
</tr>
<tr>
<td><strong>Color</strong></td>
<td>Displays and allows you to change the font color.</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Allows you to add underlining to your fonts.</td>
</tr>
<tr>
<td><strong>Script</strong></td>
<td>If supported by the selected font, allows you to display foreign characters used in other languages, such as ñ and à.</td>
</tr>
</tbody>
</table>

Quick Reference

To Open the Font Dialog Box:

- Select **Format → Font** from the menu.
Chapter Three Review

Lesson Summary

Finding and Replacing Information

- **To Find Information**: Click the **Find button** on the toolbar, or press `<Ctrl> + <F>`, or select `Edit → Find` from the menu. Enter the text you want to search for in the **Find What** text box, and then click the **Find Next** button until you find what you are looking for.

- **To Find and Replace Information**: Select `Edit → Replace` from the menu, or press `<Ctrl> + <H>`. Enter the text you want to search for in the **Find What** text box, enter the text you want to replace the word with in the **Replace With** box. Click the **Find Next** button to move the first occurrence of the text and click the **Replace** button to replace the text or click the **Find Next** button to move the next occurrence of the text. Repeat if there is more than one occurrence that you want to replace or click **Replace All** to search and replace every occurrence of text in the table.

Sorting Records

- **To Sort Records by One Field**: Click anywhere in the column you want to use to sort the list, and click either the **Sort Ascending button** or **Sort Descending button** on the toolbar.

Filtering by Selection

- **To Filter by Selection**: Find the field value on which you want to base the filter, right-click the field value and select **Filter by Selection** from the shortcut menu, or click the field value then click the **Filter by Selection button** on the toolbar.

- **To Filter Excluding the Selection**: Right-click the field value you want to exclude and select **Filter Excluding Selection** from the shortcut menu.

- **To Remove a Filter**: Right-click the filtered table and select **Remove Filter/Sort** from the shortcut menu, or Click the **Remove Filter button** on the toolbar.

Filtering by Form

- **To Filter by Form**: Click the **Filter by Form button** on the toolbar, click the text box for the field you want to filter, click the drop-down arrow and select the value you want to use to filter the records. Repeat this step each additional field you want to use to specify additional filter criteria—if you want to use Or criteria, click the **Or** tab at the bottom of the screen to specify the additional filter criteria. Click the **Apply Filter button** on the toolbar.

Creating an Advanced Filter

- **To Create an Advanced Filter**: Select `Records → Filter → Advanced Filter/Sort` from the menu, double-click each field you want to include from the field list or drag the field from the field list onto the design grid. In the design grid, enter any desired search criteria for the field in the **Criteria row**. Click the **Apply Filter button** on the toolbar.
Adjusting Row Height and Column Width

- **To Adjust the Width of a Column:** Drag the column header’s right border to the left or right. You can also right-click the column header(s), select **Column Width** from the shortcut menu and enter the column width or select the column header(s), select **Format → Column Width** from the menu and enter the column width.
- **To Adjust the Height of a Row:** Drag the row header’s bottom border up or down. You can also right-click the row header(s), select **Row Height** from the shortcut menu, and enter the row height or select the row header(s), select **Format → Row Height** from menu and enter the row height.
- **To Automatically Adjust the Width of a Column or Row:** Double-click the right border of the column or bottom border of a row.

Rearranging Columns

- **To Move a Column:** Click the field name of the column you want to move, then drag the selected column to its new location.

Changing Gridline and Cell Effects

- **To Change a Datasheet’s Gridline Effects:** Select **Format → Datasheet** from the menu, and then select the effect option you want, and click **OK**.

Freezing a Field

- **To Freeze a Column:** Right-click the column field name you want to freeze and select **Freeze Columns** from the shortcut menu.
- **To Unfreeze a Column:** Select **Format → Unfreeze All Columns** from the menu.

Hiding a Column

- **To Hide a Column:** Right-click the column field name you want to hide and select **Hide Columns** from the shortcut menu.
- **To Unhide a Column:** Select **Format → Unhide Columns** from the menu.

Changing the Datasheet Font

- **To Open the Font Dialog Box:** Select **Format → Font** from the menu.

Quiz

1. Which of the following is NOT a command to find specific words or phrases in a database?
   A. Click the Find button on the toolbar.
   B. Select **Edit → Find** from the menu.
   C. Click the Find button on the Record Navigation button area.
   D. Press <Ctrl> + <F>.
2. The only way to find and replace information in Microsoft Access is with an Update Query. (True or False?)

3. Which of the following is NOT true? (Select all that apply.)
   A. Filter by Selection finds all records that match a selected value.
   B. Filter excluding Selection finds all records that do not match a selected value.
   C. Filter by Form lets you enter your filter criteria in a blank form and works well so long as you do not need to use multiple AND/OR criteria.
   D. An Advanced Filter is similar to creating a simple select query.

4. The criteria BETWEEN 1/1/99 AND 12/31/99 would:
   A. Display records between the dates 1/2/99 and 1/1/00.
   B. Display records whose dates equaled 1/1/99 or 12/31/99.
   C. Display records between the dates 1/1/99 and 12/31/99.
   D. Do nothing – this criteria has not been entered using the proper syntax.

5. In an Advanced Filter, which of the following are ways you can add fields to the design grid? (Select all that apply.)
   A. Select the field from the Add Field List on the toolbar.
   B. Double-click the field from the Field List.
   C. Select Edit → Add Field from the menu, select the field from the list, and then click OK.
   D. Drag and drop the field from the Field List to the design grid.

6. The only way you can rearrange the order of fields in a datasheet is by reordering the fields in table Design View. (True or False?)

7. Which of the following statements is NOT true?
   A. Bill Gates has more money than I do.
   B. When you freeze a field it stays in the same place while you scroll around the rest of the datasheet.
   C. You can temporarily hide a field or column when you want to reduce the amount of information that is displayed on the screen.
   D. To hide a field select the field and click the Hide Column button on the toolbar.

8. How do you freeze a column or field in Microsoft Access?
   A. Click anywhere in the column and click the Freeze button on the toolbar.
   B. Place an ice cube on the column.
   C. Right-click the column and select Freeze Columns from the shortcut menu.
   D. Click anywhere in the column and select Edit → Freeze Column from the menu.

9. How do you filter by selection?
   A. Find and double-click the value on which you want to base the filter.
   B. Find the value on which you want to base the filter, right-click the field value and select Filter by Selection from the shortcut menu.
   C. Find and select the value on which you want to base the filter and select Tools → Filter by Selection from the menu.
   D. This feature is found in Microsoft Excel, not Access.
10. **What is a fast way to adjust the width of a column?**
   
   A. Double-click the left side of the column heading.
   B. Double-click the right side of the column heading.
   C. Right-click the left side of the column heading.
   D. Select **Tools** → **Adjust Column Width** from the menu.

**Homework**

1. Start Microsoft Access and open the Homework database.
2. Open the Customers table in Datasheet View.
3. Click anywhere in the LastName field and find any customers with the last name “Eller”.
4. With the cursor still in the LastName field use the Find and Replace command to replace every instance of the first name “John” with the first name “Jack”.
5. Use the Sort command to sort the Customers table by the LastName field, in ascending order.
6. Use the Filter by Selection command to display only records from the state of Texas (TX).
   **Hint:** Right-click any TX value in the State field and select Filter by Selection from the shortcut menu.
7. Remove the filter.
8. Use the Filter by Form command to display only those records from “TX” or “MN”.
9. Create an Advanced Filter to display records for customers from “TX” or “MN” and who were born before 1/1/1950.
   
   **Hint:** Use the following illustration as an example of how the Advanced Filter should look:

![Advanced Filter Illustration]


**Quiz Answers**

1. C. There are buttons to add and navigate records in the Record Navigation area, however there isn’t a Find button.
2. False. An Update Query can find and replace information in Microsoft Access (more about that later) but so can the Find and Replace command, which you can use by selecting Edit → Replace or pressing <Ctrl> + <H>.

3. C. Filter by Form is great for using multiple AND/OR criteria.

4. C. Displays records between the dates 1/1/99 and 12/31/99.

5. B and D. Both of these are ways to add fields to the design grid in an Advanced Filter.

6. False. You can rearrange the order of fields in a datasheet by simply selecting them and then dragging and dropping them to the new desired location.

7. D. To hide a field, simply right-click the column and select Hide Columns from the shortcut menu.

8. C. You can freeze a column by right-clicking the column and selecting Freeze Columns from the shortcut menu.

9. B. You can filter a selection by finding the value on which you want to base the filter, right-clicking the field value and selecting Filter by Selection from the shortcut menu.

10. B. Double-clicking the right side of a column automatically adjusts its width.
Chapter Four:
Working with Tables and Fields

Chapter Objectives:
- Understand and modify a table’s field properties
- Index a field and add a primary key to a table
- Change a field’s data type
- Format how information is displayed in a field
- Specify data validation options for a field
- Create a lookup field that lets you pick a field’s entry from a list of values

Chapter Task: Modify a table’s fields and join two related tables

Tables are by far the most important part of any database. Tables are where a database stores all of its information. All the other database objects—queries, forms, reports, and macros—are merely tools to analyze, manipulate, and display the information stored in a table. Any of these other database objects are optional—but without tables, a database wouldn’t be a database.

If you are interested in creating your own databases this may be the one of the most important chapters in the entire book. Why? Because, at their heart, the most useful and efficient databases use well-structured tables to store their information.

This chapter explains just about everything you will ever need to know about tables and fields: How to link two or more related tables, how to create indexes for faster performance, and how to create a primary key field, which uniquely identifies each record in a table. This chapter also explains how to change all the properties and settings for your tables’ fields, such as how they are formatted and what kind of information they can store.

☑️ Prerequisites
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.
Lesson 4-1: Understanding Field Properties

A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, a car’s properties would include its color, make and model, and shape. A property for a numeric field might be the number of decimal places displayed or the maximum number of characters a field can hold.

Just about every object in Access—every heading on a report, every label on a form, every field in a table—has its own set of properties that you can view and change. This property concept might seem a little confusing at first but it’s something you have to learn if you want to become proficient at using Microsoft Access. Because you can almost always change object properties, you can also sometimes think of an object’s properties as its settings.

Over half of this chapter is devoted to working with a table’s Field Properties so consider this your introduction to Field Properties and to properties in general.

1. **Open the Lesson 4 database.**

   To view and modify the Field Properties for a table you need to open the table in Design view.

---

© 2000 CustomGuide.com
2. **Select the tblCustomers table and click the Database window’s **Design button**.

As you can see in Figure 4-2 the table design window is broken into two sections. The top section contains the table’s field names and the bottom section displays the properties for the selected field. Simply click the field name whose field properties you want to view.

3. **Click the LastName field name.**

The lower Field Properties section of the window displays the properties for the LastName field. To change a field property, simply click the property box you want to change and enter the new settings—simple.

Table 4-1: Field Properties describes all the field properties. Don’t worry if some of them seem confusing—you will get a lot of practice adjusting each and every one of these properties in this chapter. It’s important to note that certain types of fields have their own sets of properties. For example, number fields have a Decimal Places property while text fields do not.

<table>
<thead>
<tr>
<th>Field Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| Field Size      | **Text fields**: The maximum number of characters (up to 255) that can be entered in the field. The default setting is 50.  
**Number / Currency fields**: Stores the number as a Byte, Integer, Long Integer, Single, Double, or Replication ID. The default setting is Long Integer. |
| Format          | How the data in the field will be displayed on the screen. |
| Input Mask      | Creates a format or pattern in which data must be entered. |
| Decimal Places  | The number of decimal places in number and currency fields. |
| Caption         | A label for the field that will appear on forms. If you don’t enter a caption, Access will use the field name as the caption. |
| Default Value   | A value that Access enters automatically in the field for new records. |
| Validation Rule | An expression that limits the values that can be entered in the field. |
| Validation Text | The error message that appears when an incorrect or restricted value is entered in a field with a validation rule. |
| Required        | Specify if a value must be entered in the field. The default is No. |
| Allow Zero Length | Specify if the field allows zero-length text strings (a string containing no characters). Zero-length text strings are useful if you must enter data in a field but no data exists. For example, if a Social Security field requires data but you don't know the social security number, you enter a zero-length text string in the field. To enter a zero-length text string type ‘” in the cell. The cell will appear empty. The default is No. |
| Indexed         | Specify if you want to index the field to speed up searches and sorts performed on the field. The default is No. |
| Unicode Compression | Access 2000 supports multilingual or foreign characters in its fields. As a result text and memo fields require more space than in previous versions of Access. You can offset this increased storage space by compressing the field by setting the Unicode Compression property to Yes. |
Lesson 4-2: Indexing a Field

Just like an index in a book, when you index a field, it helps Access find and sort information quickly, especially in large tables. You can index any field in a table to dramatically speed up queries and sorts. When you sort or query a large table using an indexed field, Access finds or sorts the information by consulting the index instead of sifting through the entire table.

Here are some more important notes about indexes:

- Since indexes speed up searching and sorting, you should index the fields you frequently use to search or sort. For example, if you often search for specific last names, you should create an index for the LastName field.
- Don’t index too many of a table’s fields. The more fields you index, the slower your searches and sorts will be—defeating the entire purpose of indexes. Only index the fields you use to search and sort data.
- Any field can be indexed except memo, OLE, and hyperlink fields.
- Primary key fields are indexed automatically (we’ll discuss primary keys more in future lessons).
- If you choose, indexes can prevent duplicate entries into your table; for example, if you don’t want to allow two customers to have the same social security number.

This lesson will give you some practice adding indexes to your tables.

1. **Make sure you have the tblCustomers table open in Design view.**

   Indexing a field is a simple one or two step operation. First you need to click the name of the field you want to index. The LastName field is a great index candidate because it is frequently used to find and sort information.

2. **Click the LastName field name.**

   The blinking cursor should appear in the LastName field name. Here’s how to index the selected field.
3. **Click the Indexed drop-down list in the Field Properties section, as shown in Figure 4-3.**

The Indexed list gives you three choices:
- **No**: The field is not indexed. This is the default setting.
- **Yes (Duplicates OK)**: The field is indexed and Access will allow records in this field to have the same value.
- **Yes (No Duplicates)**: The field is indexed and Access won’t allow records in this field to have the same value. For example, if you don’t want to allow two customers to have the same social security number.

Most of the time you will want to choose the Yes (Duplicates OK) option. Since people may have the same last name the Yes (Duplicates OK) option is what you’ll want to use here.

4. **Select the Yes (Duplicates OK) option from the Indexed list.**

Most of the time Access creates the index in a matter of seconds. If you have a huge table with thousands of records it will take longer to create the index.

Let’s try indexing another field. Since you do a lot of sorting by Zip Codes you decide to index the Zip Code field as well.

5. **Click the ZipCode field name and then click the Indexed drop-down list.**

Since people can (and do) live in the same Zip Code you want to select the Yes (Duplicates OK) option.

6. **Select the Yes (Duplicates OK) option from the Indexed list.**

You don’t need to index any of the other fields in this table, since you don’t use them as frequently in your sorts and queries. You do need to save the changes you’ve made to your table, however.

7. **Click the Save button on the toolbar to save the changes you’ve made to the table.**

If you need to remove an index from a field, select the field, click the Indexed drop-down list and select the No option. Access will delete the field’s index.

---

### Quick Reference

**To Index a Field:**

1. Display the table in Design view, and click a field you want as an index.
2. Click the Indexed box.
3. Click the drop-down arrow and select one of the following:
   - Yes (Duplicates OK) if you want to allow multiple records to have the same data in this field.
   - Yes (No Duplicates) if you want to ensure that no two records have the same data in this field.
Lesson 4-3: Adding a Primary Key to a Table

A primary key is a special kind of indexed field that uniquely identifies each record in a table. When you think about primary key fields think *unique*—each primary key value must be the only one of its kind in a table. A customer ID or invoice number would be two good examples of fields that could be used as a table’s primary key.

Here are some things you need to know about primary keys:

- A table can only have one primary key.
- The values in the primary key fields must be unique. For this reason many people use an AutoNumber field as their primary key. AutoNumber fields automatically add a new, unique number to each record in a table.
- Every table you create should have a primary key because it helps keep your data organized and easy to work with. In fact, if you create a table without a primary key, Access will ask if you want to add one. If you answer Yes, Access will create an AutoNumber field at the beginning of the table and set it as the primary key.
- The primary key field is automatically indexed.
- Yes/No, OLE, and hyperlink fields can’t be used as the primary key.
- The primary key is normally a single field, but two or more fields can act together as the primary key, so long as their combined values are unique. Such multifield keys are usually difficult and confusing to work with, however.
- Primary keys are especially important in creating relationships between tables.

So what makes a good primary key field? The most important consideration for a primary key is its *uniqueness*. A primary key field must always be different in every record, so you might be able use a Customer ID, Invoice Number, or Social Security Number as your table’s primary key.
If a table doesn’t have a unique field, suitable as the primary key (most tables don’t) you can add an AutoNumber field to your table. The AutoNumber field will automatically add a new, unique number to each of the records in a table.

This lesson explains how to add a primary key to a table.

1. **Make sure the tblCustomers table is open in Design view.**
   First you need to click the name of the field you want to use as your primary key. If your table doesn’t have a natural primary key field, you will need to add one. AutoNumber fields make great primary keys.
   For this exercise we’ll use the CustomerID AutoNumber field as the table’s primary key.

2. **Click the CustomerID field name.**
   Now you can set the CustomerID field as the table’s primary key.

3. **Click the Primary Key button on the toolbar.**
   A key symbol (キー) appears next to the CustomerID field, indicating that it is the table’s primary key. Notice that Access also sets the Indexed field to “Yes (No Duplicates).” Access automatically indexes the CustomerID field so that sorts and queries using the field will be faster and so that you cannot enter duplicate values in the field.

4. **Click the Save button on the toolbar to save the changes you’ve made to the table.**

---

Quick Reference

To Add a Primary Key to a Table:

1. Display the table in Design view, and click the field that you want to set as the primary key. If such a field doesn’t exist you will have to create it.
   **Note:** AutoNumber fields make great primary keys.

2. Click the **Primary Key button** on the toolbar.
   Or…
   Right-click the field you want to use as the primary key and **Primary Key** from the shortcut menu.

---
Lesson 4-4: Inserting, Deleting, and Reordering Fields

You can insert, delete, and reorder fields in your tables in Design view. Remember that in Design view for tables, each row corresponds to a field. You add a field by inserting a new row and delete a field by deleting its corresponding row.

1. Open the tblCustomers table in Design view.
   To insert a new field, you must first click the row selector for the field that will appear below the new field you want to insert.

2. Click the row selector for the Phone field. Press <Insert> to add a blank field.
   Now all you have to do is give the new row a name and specify its data type.

3. Click the Field Name box for the new row and type MI.
   You’ve added a new field. Now let’s see how to rearrange the order of fields in a table.

4. Click the MI row selector to select the MI field.
   Now you can move the selected MI row.

5. Click and drag the MI row selector down before the City row, as shown in Figure 4-5.
   Finally here’s how to delete a field:

6. With the MI field still selected, press <Delete> to delete the selected field.
   Access deletes the MI field from the tblCustomers table.
Great! In a very short lesson you’ve learned three new tables skills.

Quick Reference

To Insert a Row:
1. Click the row selector for the field that will be below the new field you want to insert.
2. Press <Insert>.

To Change the Order of Fields in a Table:
1. Click the row selector for the field you want to move.
2. Click and drag the row selector to the desired location.

To Delete a Field from a Table:
- Click the row selector for the field and press the <Delete>.
Lesson 4-5: Changing a Field's Data Type

Because there are so many different types of data, Access offers several different types of fields. A field’s data type determines the type of information that can be stored in a field. Table 4-2: Data Types lists the various data types available in Access. A field’s data type helps prevent data entry errors because it restricts what type of information you can enter in a field. For example, you can not enter text into a number data type field.

If you’ve been working with Access for a while, you are probably already know some of this stuff. Just consider this lesson a quick review.

1. **Make sure the tblCustomers table is open in Design view.**
   First you need to select the field whose data type you want to change.

2. **Click the DOB field name.**
   The blinking cursor should appear in the DOB field name. Since the DOB field stores the employee’s date of birth it should be a Date/Time field instead of a text field.
   Here’s how to change a field’s data type:

3. **Click the Data Type area next to the DOB field.**
   A down arrow appears on the right side of the DOB Data Type box.
4. Click the \( \square \) DOB Data Type arrow and select Date/Time from the list.
The DOB field will now only accept date and time information. The new Date/Time data type also makes your database more flexible and powerful because now you can sort birthdays by date or use a person’s birthday in a calculation—for example to determine a person’s age.

Once you have finished modifying a table you have to save your changes.

5. Click the Save button on the toolbar to save your changes.

Table 4-2: Data Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Legal Name: John Doe</td>
<td>Stores text, numbers, or both, up to 255 characters long. Text fields are the most common of all data types.</td>
</tr>
<tr>
<td>Memo</td>
<td>Notes: Sally displays a high amount of...</td>
<td>Stores long text entries—up to 64,000 characters long (equivalent to 18 pages of text!). Use memo fields to store notes or anything else that requires lots of space.</td>
</tr>
<tr>
<td>Number</td>
<td>Age: 31</td>
<td>Stores numbers that can be used in calculations.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Birthday: April 7, 1969</td>
<td>Stores dates, times, or both.</td>
</tr>
<tr>
<td>Currency</td>
<td>Price: $84.95</td>
<td>Stores numbers and symbols that represent money.</td>
</tr>
<tr>
<td>AutoNumber</td>
<td>Invoice Number: 187001</td>
<td>Automatically fills in a unique number for each record. Many tables often contain an AutoNumber field that is also used as their primary key.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Smoker?: Yes</td>
<td>Stores only one of two values, such as Yes or No, True or False, etc.</td>
</tr>
<tr>
<td>OLE Object</td>
<td>Photo:</td>
<td>Stores objects created in other programs such as a graphic, Excel spreadsheet, or Word document.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Web Site: <a href="http://www.amazon.com">www.amazon.com</a></td>
<td>Stores clickable links to files on your computer or on the network or to web pages on the Internet.</td>
</tr>
<tr>
<td>Lookup Wizard</td>
<td>Purpose of Trip:</td>
<td>A wizard that helps you create a field whose values are selected from another table or query or from a list of values.</td>
</tr>
</tbody>
</table>

Quick Reference

To Change the Data Type for a Field:
1. Display the table in Design View.
2. Click the field’s Data Type box, click the Data Type list arrow and select the data type.
Lesson 4-6: Using Field Descriptions

Figure 4-7
A field's description lets you provide your database users with on-screen prompts and instructions.

Figure 4-8
A field’s description appears in the Status bar whenever you select the field.

Quick Reference
To add a Description to a Field:
- Display the table in Design View, click the field’s Description box and type the description.

1. Make sure the tblCustomers table is open in Design view.
   First you need to select the field where you want to add a description.
2. Click Description box for the LastName field.
   Now you can add description to the LastName field that will appear in the Status bar whenever the LastName field is selected.
3. Type Enter the Customer’s Last Name.
   Let’s add a description to the FirstName field as well.
4. Click Description box for the FirstName field name and type Enter the Customer’s First Name.
   Let’s see how the new captions look.
5. Click the Save button on the toolbar to save your changes, then click the View button to display the table in Datasheet view.
6. Click anywhere in the LastName field.
   The Status bar displays the field’s description, as shown in Figure 4-8.

Descriptions make your database fields easier to fill out and use by providing users with online instructions and help. Whenever a user selects a field, anything you type in that field’s Description box will appear in the Status bar. There really isn’t anything to adding a description to a field—just type the text you want to appear in the field’s Description box.
Lesson 4-7: Adding a Caption

Think of the Caption property as a field’s pseudonym or stage name. When you create forms and reports, Access uses the field’s Field Name as the field’s heading. When you add a caption to a field, however, it appears as the heading for the field instead of the field name. Captions are useful when you want to provide more detailed headings for your field names. For example, instead of displaying the rather unclear DOB field name you could add more meaningful “Date of Birth” caption to the DOB field to make your forms and reports easier to read and understand. The original DOB field name is not affected in any way.

This lesson explains how to add a Caption to a field.

1. **Make sure the tblCustomers table is open in Design view.**
   The tblCustomers table contains two unclearly labeled fields that could use captions: the DOB (date of birth) and SSN (social security number) fields. You probably already know the first step by now—click the name of the field where you want to add the caption.

2. **Click the DOB field.**
   Now you can add a more meaningful caption to the DOB field that will appear as the field’s heading.

3. **Click the Caption box in the Field Properties section and type Date of Birth.**
   Next add a caption to the SSN field.

4. **Click the SSN field name, click the Caption box in the Field Properties section and type Social Security No.**
   Let’s see how the new captions look.

5. **Click the Save button on the toolbar to save your changes, then click the View button to display the table in Datasheet view.**
   You will need to scroll to the right to see the captions.
Lesson 4-8: Changing the Field Size

The Field Size property determines the maximum size of information that can be stored in a text or number field. For example, if you set the size of a text field to 2, you could enter “MN” but not “Minnesota.” There are several reasons why you would want to change the size of a field:

- Changing the field size reduces data entry errors.
- Access can process smaller field sizes more quickly.
- Smaller field sizes require less hard drive storage space.

Field Size works a little differently for text and number fields. In text fields, the Field Size determines the maximum number of characters the field can accept. In number fields, the Field Size determines what type of number the field will accept, as shown in Figure 4-11.

In this lesson you will change the size of a table’s fields.

1. **Make sure the tblCustomers table is open in Design view.**
   You probably already know the first step by now—click the name of the field whose property you want to change.

2. **Click the State field name.**
   Now change the State Field Size.

3. **Click the Field Size box in the Field Properties section and replace the existing number 50 with 2.**
   The State field can now only accept a maximum of two characters so that users will have to enter standard two digit state abbreviations.

   Let’s try changing the size of another field.
4. **Click the ZipCode field name.**
   Notice the Zip Code’s Field Size set at 50. We probably won’t have 50 digit zip codes for at least a few more years, so you can safely change the field size to a smaller number.

5. **Click the Field Size box in the Field Properties section and replace 50 with 11.**
   The Zip Code field will now accept no more than 11 digits.

   **NOTE:** Be very careful when you’re changing the Field Size of a field that already contains data. Access will truncate or delete data that is larger than the new field size.

6. **Click the Save button on the toolbar to save your changes.**

   **NOTE:** Access may display get a dialog box warning you that some data may be lost if you change the Field Size. We’ve planned for this so go ahead and click “OK” or “Yes.”

If you are working with a number field, the Field Size property determines the type and size of the number that a field will accept, as shown in the following table.

### Table 4-3: Available Number Field Sizes

<table>
<thead>
<tr>
<th>Heading</th>
<th>Number Range</th>
<th>Decimal Places</th>
<th>Storage Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Byte</td>
<td>0 to 255</td>
<td>None</td>
<td>1 byte</td>
</tr>
<tr>
<td>Integer</td>
<td>-32,768 to 32,767</td>
<td>None</td>
<td>2 bytes</td>
</tr>
<tr>
<td>Long Integer</td>
<td>-2.1×10(^{38}) to 2.1×10(^{38})</td>
<td>None</td>
<td>4 bytes</td>
</tr>
<tr>
<td>Single</td>
<td>-3.4×10(^{38}) to 3.4×10(^{38})</td>
<td>7</td>
<td>4 bytes</td>
</tr>
<tr>
<td>Double</td>
<td>-1.8×10(^{308}) to 1.8×10(^{308})</td>
<td>15</td>
<td>8 bytes</td>
</tr>
<tr>
<td>Replication ID</td>
<td>N/A to N/A</td>
<td>N/A</td>
<td>16 bytes</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Change the Field Size:**

1. Display the table in **Design view** and click the field in the field list.
2. Click the **Field Size box** in the Field Properties section.
3. **For Text Fields:** Type the Field Size value.
   **For Number Fields:** Choose the value from the drop-down list.
Lesson 4-9: Formatting Number, Currency, and Date/Time Fields

A field’s Format property changes how information appears in the field. The Format property only changes how data is displayed on-screen, not how the data is actually stored in the field. For example, a date field could be formatted to display the same value as 6/10/00; or Saturday, June 10, 2000; or 10-Jun-00. Each field type has its own set of formats. For example, number fields have a different set of formats than date/time or text fields.

This lesson explains how to format number, currency, and date/time fields. There are two ways to format a number, currency and date/time field:

- By selecting a ready-made format from the Format drop-down list (the easy way).
- By typing a series of formatting characters in the Format box (the hard way).

Hopefully the ready-made formats listed in Table 4-4: Number, Currency, and Date/Time Formats will be all you will ever need to format your fields. This lesson explains how to format Number, currency, and date/time fields by selecting a ready-made format.

1. **Open the tblCustomerTours table.**
   Let’s take a look at how the numbers and date fields in this table are currently formatted. Notice the Cost currency field has two decimal places and that Date field displays its dates in 1/1/2000 format.

   **NOTE:** If you haven’t installed any Year 2000 updates, such as the Microsoft Office 97 Service Pack 2, your dates may be displayed in 1/1/00 format. If this is the case you should visit the Microsoft Office Update web site, located at www.officeupdate.com and download Microsoft Office 97 Service Pack 2.

2. **Switch to Design View by clicking the View button on the toolbar.**
   Now you can change the formats of the fields in the tblCustomerTours table.
3. **Click the Date field name and click the Format box in the Field Properties section.**

   A downward pointing arrow appears in the Date Format box. You can format this field the easy way by clicking the arrow to select from one of the ready-made number formats shown in Table 4-4: Number, Currency, and Date/Time Formats.

4. **Click the Format drop-down list and select Medium Date.**

   The Date field will now display its dates in 1-Jan-00 format instead of the 1/1/2000 format.

   You can also specify how many decimal places you want numbers in a field to display. To change the number of decimal places in a number field you enter the number of decimal places you want displayed in the Decimal Places box.

5. **Click the Cost field, click the Decimal Places drop-down list and select 0.**

   The Cost field will not display any decimal places. Access will round any decimals equal to or greater than five to the next number.

   **NOTE:** The Decimal Places property setting has no effect if the Format property is blank or is set to General Number.

   **NOTE:** The Decimal Places property affects only the number of decimal places that are displayed, not how many decimal places are stored.

   You’ll need to save the table before you can view your new Format settings.

6. **Click the Save button on the toolbar to save your changes.**

   Now let’s see how the fields look with their new formats.

7. **Switch to Datasheet View by clicking the View button on the toolbar.**

   Notice the Date field now displays dates in a 1-Jan-00 format and the Cost field no longer has any decimal places.

Okay, here’s a list of ready-made Number, Currency, and Date/Time formats you can choose from. These standard formats should be all that you’ll ever need—if not, take a look at the lesson on Formatting Number, Currency, and Date/Time fields by hand.

---

**Table 4-4: Number, Currency, and Date/Time Formats**

<table>
<thead>
<tr>
<th>Number Format</th>
<th>Example</th>
<th>Date/Time Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Number</td>
<td>1234.567</td>
<td>General Date</td>
<td>6/10/00 6:35:21 PM</td>
</tr>
<tr>
<td>Currency</td>
<td>$1,234.57</td>
<td>Long Date</td>
<td>Saturday, June 10, 2000</td>
</tr>
<tr>
<td>Fixed</td>
<td>1234.57</td>
<td>Medium Date</td>
<td>10-Jun-00</td>
</tr>
<tr>
<td>Standard</td>
<td>1,234.57</td>
<td>Short Date</td>
<td>6/10/00</td>
</tr>
<tr>
<td>Percent</td>
<td>123456.70%</td>
<td>Long Time</td>
<td>6:35:21 PM</td>
</tr>
<tr>
<td>Scientific</td>
<td>1.23E+03</td>
<td>Medium Time</td>
<td>6:35 PM</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Short Time</td>
<td>18:35</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Format Number and Currency Fields:**

1. Display the table in **Design view** and click the field in the field list.

2. Click the **Format box** in the Field Properties section.

3. Click the **Format drop-down arrow** and select a number format.

**To Change the Number of Decimal Places:**

1. Display the table in **Design view** and click the field in the field list.

2. Click the **Decimal Places box** in the Field Properties section.

3. Click the **Decimal Places drop-down arrow** and select the number of decimal places you want to display.
If none of the ready-made Number, Currency, or Date formats meets your needs, you can format your Number, currency, and date/time fields the old-fashioned way—by hand. Formatting fields by hand is a laborious and confusing process—you tell Access how you want the field to be formatted by typing the formatting characters listed in Table 4-5: Number, Currency, and Date/Time Formatting Characters in the Format box. On the other hand, manually formatting a Number, Currency, or Date/Time field gives you complete flexibility on how the field displays its information.

In this lesson you will learn how to format Number, currency, and date/time fields by hand.

1. **Make sure the tblCustomerTours table is open in Design view.**
   First you have to click the name of the field you want to format.

2. **Click the Date field name.**
   This time we will specify our own date/time format instead of using one of the Format Property box’s ready made data formats. Formatting Number, currency, and date/time fields by hand isn’t exactly a difficult process, but you will probably need to use the reference on the next page to know which formatting characters to enter.

3. **Click the Format box in the Field Properties section and replace the text Medium Date with dddd mmm d.**
   This will display the date in Sun Mar 8 format. Look at Table 4-5: Number, Currency, and Date/Time Formatting Characters for a description of the characters you just entered.

4. **Click the Save button on the toolbar to save your changes then switch to Datasheet View by clicking the View button on the toolbar.**
   Notice the Date field now displays its days using the Date format you specified.
5. Close the tblCustomerTours table.

Use the following characters when you want to format Number, Currency, or Date/Time characters by hand. You can mix and match any of the following characters. For example you could add mmmm (full name of month) to yy (last two digits of the year) to get January 00.

<table>
<thead>
<tr>
<th>Date/Time Formatting Characters</th>
<th>Description</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>:)</td>
<td>Time separator</td>
<td>h:nn</td>
<td>8:45</td>
</tr>
<tr>
<td>/</td>
<td>Date separator</td>
<td>m/d/yy</td>
<td>10/8/00</td>
</tr>
<tr>
<td>-</td>
<td>Date separator</td>
<td>m-d-yy</td>
<td>10-8-00</td>
</tr>
<tr>
<td>d</td>
<td>Day in one or two numeric digits.</td>
<td>m/d/yy</td>
<td>10/8/00</td>
</tr>
<tr>
<td>dd</td>
<td>Day in two numeric digits.</td>
<td>m/dd/yy</td>
<td>10/08/00</td>
</tr>
<tr>
<td>ddd</td>
<td>First three letters of the weekday.</td>
<td>ddd, m/d/yy</td>
<td>Sun, 3/8/00</td>
</tr>
<tr>
<td>dddd</td>
<td>Full name of the weekday.</td>
<td>dddd, m/d/yy</td>
<td>Sunday, 3/8/00</td>
</tr>
<tr>
<td>m</td>
<td>Month in one or two digits.</td>
<td>m/d/yy</td>
<td>3/15/00</td>
</tr>
<tr>
<td>mm</td>
<td>Month in two digits.</td>
<td>mm/dd/yy</td>
<td>03/15/00</td>
</tr>
<tr>
<td>mmm</td>
<td>First three letters of the month.</td>
<td>mmm-d-yy</td>
<td>Mar-15-00</td>
</tr>
<tr>
<td>mmmm</td>
<td>Full name of the month.</td>
<td>Mmmm d, yyyy</td>
<td>March 15, 2000</td>
</tr>
<tr>
<td>yy</td>
<td>Last two digits of the year.</td>
<td>m/d/yy</td>
<td>3/15/00</td>
</tr>
<tr>
<td>yyyy</td>
<td>Full year</td>
<td>Mmmm d, yyyy</td>
<td>March 15, 2000</td>
</tr>
<tr>
<td>h</td>
<td>Hour in one or two digits.</td>
<td>h:n</td>
<td>8:45</td>
</tr>
<tr>
<td>hh</td>
<td>Hour in two digits.</td>
<td>hh:nn</td>
<td>08:45</td>
</tr>
<tr>
<td>nn</td>
<td>Minute in two digits.</td>
<td>hh:nn</td>
<td>13:09</td>
</tr>
<tr>
<td>ss</td>
<td>Second in two digits.</td>
<td>hh:nn</td>
<td>10:45:07</td>
</tr>
<tr>
<td>AM/PM</td>
<td>Twelve-hour clock (uppercase)</td>
<td>hh:nn AM/PM</td>
<td>08:45 AM</td>
</tr>
<tr>
<td>am/pm</td>
<td>Twelve-hour clock (lowercase)</td>
<td>hh:nn am/pm</td>
<td>08:45 am</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Number Formatting Symbols</th>
<th>Description</th>
<th>Data</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Display a digit or nothing.</td>
<td>50</td>
<td>#</td>
<td>50</td>
</tr>
<tr>
<td>0</td>
<td>Display a digit or 0.</td>
<td>50</td>
<td>#.00</td>
<td>50.00</td>
</tr>
<tr>
<td>.</td>
<td>Display a decimal separator.</td>
<td>50</td>
<td>.</td>
<td>50.00</td>
</tr>
<tr>
<td>,</td>
<td>Display thousands separator.</td>
<td>5000</td>
<td>###</td>
<td>5,000</td>
</tr>
<tr>
<td>$</td>
<td>Display the $ currency symbol.</td>
<td>50</td>
<td>$#.00</td>
<td>$50.00</td>
</tr>
<tr>
<td>%</td>
<td>Multiply the value by 100 and add a percent sign.</td>
<td>0.5</td>
<td>#%</td>
<td>50%</td>
</tr>
<tr>
<td>E+, e+, e</td>
<td>Scientific notation.</td>
<td>500000</td>
<td>#.00E+00</td>
<td>5.00E+05</td>
</tr>
</tbody>
</table>

Quick Reference

To Manually Format a Number, Date, or Currency Field:

1. Display the table in Design view and click the field in the field list.
2. Click the Format box in the Field Properties section.
3. Enter the appropriate formatting codes for how you want the date or number to be formatted.
Lesson 4-11: Formatting Text Fields

Just like number, currency, and date/time fields, a text field’s Format Property changes how information appears in the field. The Format property only changes how data is displayed on-screen, not how the data is actually stored in the field.

Unfortunately, unlike number fields, text fields don’t have any ready-made settings built into them and must be formatted manually. Luckily text fields don’t have nearly as many formatting options as number, currency, and date/time fields. The most common of these text formatting characters are the greater than symbol (>) which makes all text in the field appear in uppercase and the less than symbol (<) which makes all text in the field appear in lowercase, regardless of how it was entered. In both cases Access actually stores the data exactly as it was typed.

This lesson will give you some practice formatting text fields.

1. **Open the tblCustomers table in Datasheet view.**
   First enter a sample record.

2. **Add a new record to the Customer table by clicking the New Record button on the Record Navigation bar. Enter your own personal information. When you reach the **State field** enter the state abbreviation in **lowercase letters**.**
   Move on to the next step when you have finished entering your record into the table.

3. **Click the View button on the toolbar to display the table in Design view.**
   Access displays the tblCustomers table in Design view. First you have to click the name of the field you want to format.

4. **Click the **State field name**.**
   You can make sure that the contents of the State field are always capitalized by adding a greater than symbol (>) to the Format box.
5. Click the **Format** box in the Field Properties section and type a **greater than symbol** (>).
Access will display the contents of the State field in uppercase, even if it was entered in lowercase.

**NOTE:** Remember that the Format property only changes how data is displayed on-screen, not how the data is actually stored in the field.

6. **Click the Save button on the toolbar to save your changes.**
Now let’s see how the State field looks with its new format.

7. **Switch to Datasheet View by clicking the View button on the toolbar.**
Notice that the lowercase state abbreviation you entered back in Step 2 now appears in uppercase.

OK, here’s the ready-made Number, Currency, and Date/Time formats you can choose from. These standard formats should be all that you’ll ever need—if not, take a look at the lesson on Formatting Number, Currency, and Date/Time field by hand.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Text</th>
<th>Format</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Aligns text from the right.</td>
<td>Hello</td>
<td>!</td>
<td>Hello</td>
</tr>
<tr>
<td>&lt;</td>
<td>Lowercase</td>
<td>Hello</td>
<td>&lt;</td>
<td>hello</td>
</tr>
<tr>
<td>&gt;</td>
<td>Uppercase</td>
<td>Hello</td>
<td>&gt;</td>
<td>HELLO</td>
</tr>
<tr>
<td>&quot;ABC&quot;</td>
<td>Always displays quoted text.</td>
<td>4</td>
<td>&amp;&quot; oz.&quot;</td>
<td>4 oz.</td>
</tr>
<tr>
<td>@</td>
<td>Character is required.</td>
<td>5558000</td>
<td>@@@-@@@</td>
<td>555-8000</td>
</tr>
<tr>
<td>*</td>
<td>Fill available space with next character.</td>
<td>Alert</td>
<td>&amp;!*</td>
<td>Alert!!!!!!!!!</td>
</tr>
</tbody>
</table>
Lesson 4-12: Setting a Default Value

A field’s default value is automatically entered in the field whenever you add a new record.

The default value for the State field automatically appears in a new record.

You can enter a Default Value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX”. When a user adds a record to the table, they can either accept the TX default value for the State field or enter their own value.

1. Make sure the tblCustomers table is open in Design view.

Since the majority of your customers are from Minnesota, you decide to add MN as the default value for the State field.

2. Click the State field name.

Now you can add a default value to the State field.

3. Click the Default Value box and type MN, as shown in Figure 4-15.

Let’s see how the new default value works.

4. Click the Save button on the toolbar to save your changes, and then click the View button to display the table in Datasheet view.

You will need to add a new record in order to see any default values.

5. Click the New Record button on the Record Navigation bar.

Access adds a new blank record to the table. Notice the State field already contains the MN default value. If the customer is from another state, you can simply replace the default value with your own data.
Lesson 4-13: Requiring Data Entry

In most tables there are usually at least a few fields that absolutely must contain data in order for the record to be meaningful. For example, at the absolute minimum a customer record needs to have the customer’s first and last name—otherwise why bother entering it? You can specify that a field must contain data to prevent users from leaving out important information when they are entering data.

This lesson explains how you can make sure that a field has a value for each record.

1. **Make sure the tblCustomers table is open in Design view.**
   You decide to specify that the LastName field must contain data for each record.

2. **Click the LastName field name.**
   Here’s how to prevent a user from leaving out a data in a field.

3. **Click the Required field property and select Yes from the drop-down list.**
   Let’s see how the new default value works.

4. **Click the Save button on the toolbar to save your changes, and then click the View button to display the table in Datasheet view.**
   You will need to add a new record in order to see any default values.

   **NOTE:** Access displays a dialog box asking if you want the existing data testing with the new rules. Click Yes.

5. **Click the New Record button on the Record Navigation bar.**
   Access adds a new blank record to the table.

6. **Enter a new record with your own information. Leave the LastName field blank, however.**
   Let’s see what happens…

7. **When you have finished entering the record, click in any other record or press <Ctrl> + <Enter> to save the record.**
   Access displays a dialog that states that the LastName field cannot contain a null value.

8. **Click OK and press <Esc> to cancel the new record.**
Lesson 4-14: Validating Data

Without a doubt, data validation is the most powerful tool you can use to prevent data entry errors. With data validation, Access actually tests data to make sure that it conforms to what you want to appear in the table. If the incoming data doesn’t meet your requirements, Access kicks it out and displays an error message.

Data validation works best in number, currency, and date/time fields. You can create a validation rule for text entries, but doing so can be complicated—especially if you want to test a lot of text variables.

There are actually two boxes that relate to data validation. They are the:

- **Validation Rule box**: Use to specify the requirements for data entered into the field.
- **Validation Text box**: When data is entered that violates the validation rule you can use the Validation Text box to specify the message to be displayed to the user.

Creating data validation rules can be a little tricky—you create a data validation using the same hard-to-remember operators that you use in filters and queries. Table 4-7: Data Validation Examples contain some data validations that you can modify and use in your tables.

1. **Make sure the tblCustomers table is open in Design view.**
   You decide to specify that the DOB field can not be later than today’s date. (We can’t have any people with birthdays in the future can we?)

2. **Click the DOB field name.**
   Before we get started you need to make sure that the DOB is a Date/Time field—you should have changed this in a previous lesson.
3. **Verify that the DOB field’s Data Type is set to Date/Time.**
   First you need to enter a validation rule.

4. **Click the Validation Rule box and type `<Date()`**.
   The validation rule you just entered will prevent users from entering dates later than today’s date in the DOB field. Next you have to specify the error message that Access will display if someone tries to break your validation rule by entering a future date.

5. **Click the Validation Text box and type `Date must not be later than today’s date`.**
   Let’s test our new data validation rule.

6. **Click the Save button on the toolbar to save your changes, and then click the View button to display the table in Datasheet view.**
   Data validation rules apply to both new and existing records. Move on to the next step and try modifying a record so that it breaks our data validation rule.

   **NOTE:** Access will display a dialog box asking if you want the existing data to be tested with the new rules. Click Yes.

7. **Click the DOB field for any record. Try changing the date to a future date that falls after today.**
   When you try to violate the validation rule, Access displays the Validation Text you entered back in Step 4, as shown in Figure 4-19.

8. **Click OK and press <Esc> to cancel the new record.**
   You’re finished with this lesson, so…

9. **Close the tblCustomers table.**
   
   Consider the following table your data validation “cheat sheet.” It contains samples of the most common types of validation rules. Feel free to copy, modify, or mix and match these examples to create your own validation rules.

### Table 4-7: Data Validation Examples

<table>
<thead>
<tr>
<th>Validation Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;100</code></td>
<td>Must be less than 100.</td>
</tr>
<tr>
<td><code>&lt;=100</code></td>
<td>Must be equal to or less than 100.</td>
</tr>
<tr>
<td>Between 1 and 10</td>
<td>Must be between 1 and 10.</td>
</tr>
<tr>
<td><code>&lt;&gt;0</code></td>
<td>Must not equal 0.</td>
</tr>
<tr>
<td><code>&lt;1/1/95</code></td>
<td>Must be a date before 1/1/95.</td>
</tr>
<tr>
<td><code>&gt;= Date( )</code></td>
<td>Must be today’s date or later.</td>
</tr>
<tr>
<td><code>&lt; Date( )</code></td>
<td>Must be today’s date or earlier.</td>
</tr>
<tr>
<td>&quot;Business&quot; Or &quot;Pleasure&quot; Or &quot;Other&quot;</td>
<td>Must be Business or Pleasure or Other.</td>
</tr>
<tr>
<td>Like &quot;??&quot;</td>
<td>Must have 2 characters.</td>
</tr>
<tr>
<td>Like &quot;####&quot;</td>
<td>Must have 4 numbers.</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Validate Field Data:**

1. Display the table in **Design view** and click the field in the field list.
2. Click the **Validation Rule box** in the Field Properties section.
3. Enter an expression you want to use to validate the field’s data (see Table 4-7: Data Validation Examples).
4. Click the **Validation Text box** in the Field Properties section.
5. Type the text that Access will display when the user tries to enter incorrect data for the field.
Lesson 4-15: Creating an Input Mask

An Input Mask limits the amount and type of information that can be entered in a field. You have probably already seen an example of an input mask on an ordinary paper form—the type of form that assumes you’re too dim-witted to know how to write down your phone number or social security number and thus provides you with a guide like (___) ___ - _____ or ____-___-_______. Look familiar? That’s an input mask, pure and simple.

There are two ways to create an input mask:

- Click the Build button and have the Input Mask Wizard create the input mask for you (the fast and easy way). The only problem with the Input Mask Wizard is that it can only help you create input masks for phone numbers, Social Security numbers, zip codes, and date and time fields.
- Create the input mask yourself by typing a series of characters in the Input Mask box (the hard way). If you want to use this brutal method refer to Table 4-8: Input Mask Characters to see what you have to enter to create an input mask.

In this lesson you will learn how to use the Input Mask Wizard to add an input mask to a field.

1. **Make sure the tblCustomers table is open in Design view.**
   You decide to create an input mask for the Phone field to reduce data entry errors and to remind users to enter the area code.

2. **Click the Phone field name.**
   A button appears next to the Input Mask box—click this button to start the Input Mask Wizard.
   Now let’s look at the Input mask property…

3. **Click the Input Mask box.**
   A button appears next to the Input Mask box—click this button to start the Input Mask Wizard.

4. **Click Build button to start the Input Mask Wizard.**
   The first step of the Input Mask Wizard appears, as shown in Figure 4-20. All you need to do here is select the input mask you want to choose.
If you want to try an input mask to see how it works, click the input mask you want to use and then type some sample text in the Try It box.

5. **Click the Phone Number input mask and then try typing a phone number in the Try It box. Click Next when you're finished.**

The next step of the Input Wizard appears. If you want, you can select a different placeholder to use than the default underscore (__) character.

6. **Click Next.**

The next step of the Input Wizard is quite important—you have to specify how Access should store your data. You have two choices:

- **With the Symbols in the Mask**
  This will store only the text you type in the field and the input mask symbols. For example, if you enter 5555555555 in a Phone field, Access will save the input mask symbols with the text you enter, so (555) 555-5555 would be saved.

- **Without the Symbols in the Mask**
  This will store only the text you type in the field. For example, if you enter 5555555555 in a Phone field, Access will display (555) 555-5555 but only store the numbers you typed (5555555555).

This may not seem like much of an issue, and it’s not unless you want to export your table. Then you will have to work with the results of the decision you made here: the phone numbers will be in either 5555555555 or (555) 555-5555 format.

7. **Select the With the Symbols in the Mask option and click Next.**

That’s it! You’re ready to create your input mask!

8. **Click Finish to create the input mask.**

The Input Mask Wizard creates an input mask for the field.

Creating an input mask by hand is difficult, but it can be done. You need to create the input mask by entering the characters shown in the following table in the Input Mask box.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Numbers 0 to 9 required; plus and minus signs not allowed.</td>
<td>&amp;</td>
<td>Character or space required.</td>
</tr>
<tr>
<td>9</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>C</td>
<td>Character or space optional.</td>
</tr>
<tr>
<td>#</td>
<td>Number or space optional; plus and minus signs not allowed.</td>
<td>&lt;</td>
<td>Converts the following characters to lowercase.</td>
</tr>
<tr>
<td>. , ; : ; /</td>
<td>Decimal point, thousands, date, and time separators.</td>
<td>&gt;</td>
<td>Converts the following characters to uppercase.</td>
</tr>
<tr>
<td>A</td>
<td>Letter or number required.</td>
<td>!</td>
<td>Displays characters from right to left, rather than left to right.</td>
</tr>
<tr>
<td>a</td>
<td>Letter or number optional.</td>
<td>\</td>
<td>Displays the following input mask character. For example, \ would display *.</td>
</tr>
<tr>
<td>L</td>
<td>Letters A to Z required.</td>
<td>Password</td>
<td>Displays an asterisk (*) for each character you type.</td>
</tr>
<tr>
<td>?</td>
<td>Letter or number optional.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Lesson 4-16: Creating a Lookup Field

Lookup fields are definitely one of the coolest and most powerful features in Access. A lookup field lets you pick a field’s entry from a list of values. There are two ways that a lookup field can get its list of values:

- From a list of values or options that you enter yourself. For example you could add the values FedEx, UPS, and AirBorne to a Shipping field.
- From a list of values in a table or query. For example, instead of entering a CustomerID number you could select the CustomerID from a list of names.

Tip: You can also select an option from a lookup field by typing the first few letters of the entry.
You can see an example of a lookup field in Figure 4-22. Instead of having to type a hard-to-remember CustomerID number, the lookup shows you more meaningful information, such as the customer’s name, yet still stores the CustomerID number in the field. Lookup fields make more sense once you have actually worked with them, so let’s jump right into this lesson’s exercise.

1. **Open the tblCustomerTours table in Design view.**
   You decide to use a lookup field to make the CustomerID easier to view and add data to. Here’s how to create a lookup field.

2. **Click the Data Type area next to the CustomerID field, click the down arrow and select Lookup Wizard, as shown in Figure 4-23.**
   The Lookup Wizard dialog box appears and asks if you want your lookup field to get its values from another table or query or if you want to type a list of options yourself, as shown in Figure 4-24. Since you want your lookup field to get its values from the tblCustomers table you will select the first option.

3. **Click Next.**
   The next step in the Lookup Wizard is to select the table or query that contains the values for your lookup field. You want to look up customer names, so you would select the tblCustomers table.

4. **Select the tblCustomers table and click Next.**
   Next you have to select the fields that contain the values you want to display in your lookup field. The Lookup Wizard displays the field names in the tblCustomers table that you can add to your lookup field. To add a field to your lookup field double-click the field or select the field and click the button.
   This step can be a little confusing at first. You will need to add the field that contains the value you want to enter—the CustomerID field—but you also want to add some fields to display some more meaningful information in the value list, such as the LastName and FirstName fields.

5. **Double-click the CustomerID, LastName, and FirstName fields to add them to the lookup field. Click Next when you’re finished.**
   The next step in the Lookup Wizard dialog box is to specify which fields you want to actually display in the lookup list. The first field, CustomerID, is the key field, or the value that will actually be stored in the field. Any primary key fields will be hidden by default to make the lookup field less confusing.

   **NOTE:** Because you can use queries to sort and filter information, consider using them as the source for your lookup fields.

6. **Click Next. Complete the Lookup Wizard by clicking Finish.**
   Access displays a dialog box asking if you want to save the table now. Click Yes. You’ve finished creating the lookup field! Let’s test it out….

7. **Click the View button to display the table in Datasheet view.**
   The CustomerID field still contains CustomerID numbers, but now it looks up and displays the customer’s LastName field—much easier to understand.

8. **Click the CustomerID field for any record. Click the down arrow that appears in the field.**
   Out pops a list of all the customers in the tblCustomers table—neat, huh? All you have to do is click a customer’s name to add their CustomerID number to the CustomerID field.

9. **Press <Esc> to close the list without selecting any options.**

---

Quick Reference

To Create a Lookup Field:
1. Display the table in Design View.
2. Click the field’s Data Type box, click the Data Type list arrow and select Lookup Wizard.
3. Click the I Want The Lookup Column To Look Up The Values In A Table Or Query option and click Next.
4. Select the table or query you want to use for the lookup list and click Next.
5. Resize the column width and indicate whether or not to include the primary key in the column. If the table or query doesn’t have a primary key, you will be promoted for the column that will act as the bound column.
6. Click Next.
7. Enter a label for the Lookup column and click Finish.
Lesson 4-17: Creating a Value List

Similar to its cousin the lookup list, a value list displays list of values in a drop-down list. Unlike a lookup list, which displays data in a table or query, a value list displays a list of options that you manually enter. A value list is useful if you enter the same data in a field again and again. For example, if you ship a product using three different courier services, you could create a value list that displays the three courier services, such as AirBorne, FedEx, and UPS.

Although it’s possible to change the options displayed in a value list, doing so is a rather cumbersome process, and for that reason you should only use value lists for values that will not change very often. If you want to display a lot of options, such as a list of state abbreviations, or values that may change frequently, you should create a table to store those values and then display them with a lookup list instead. It’s a lot easier to change values in a table than it is to change options in a value list.

This lesson will show you how to create a value list that contains several static options.

1. **Make sure the tblCustomerTours table is open in Design view.**

You decide to create a value list to make it easier to enter data into the Ship Via field.
2. Click the **Data Type** box next to the **Ship Via** field, click the down arrow and select **Lookup Wizard**, as shown in Figure 4-29.

   The Lookup Wizard dialog box appears and asks if you want your value list to get its values from another table or query or if you want to type a list of options yourself. Since you want to enter the options that appear in the value list you will want to select the second option.

3. **Click the I will type in the values that I want** option and click **Next**.

   The next step of the Lookup Wizard appears, as shown in Figure 4-31. This step is pretty easy—you simply enter the options you want to be displayed in the value list.

4. **Click in the Col1 box type Airborne, press <Tab>, type FedEx, press <Tab>, and press UPS.**

   The value list will display these three values.

   **NOTE:** If you want to add a lot of options (ten or more) to your value list or if the values in the list will change, consider creating a table to store the values and display them with a lookup list instead. Adding the initial options to a value list is easy, but adding, changing, or deleting these values is a non-intuitive process.

5. **Click Next.**

   You’ve finished creating the value list!

6. **Complete the Lookup Wizard by clicking Finish.**

   Let’s see how our new value list works.

7. **Click the Save button on the toolbar to save your changes and then click the View button to display the table in Datasheet view.**

   To display the value list for the Ship Via field, simply click the Ship Via field and click the down arrow or press the <↓> (down arrow) key.

8. **Click the **Ship Via** field for any record. Click the down arrow that appears in the field.**

   Out pops the value list with the three couriers you entered in Step 4.

9. **Select FedEx from the value list.**

---

### Quick Reference

**To Create a Value List:**

1. Display the table in **Design View**.
2. Click the field’s **Data Type** box, click the down Data Type list arrow and select **Lookup Wizard**.
3. Click the I Will Type in The Values That I Want option and click **Next**.
4. Specify the number of columns you want to appear in the Value list.
5. Enter the values in the list. Resize the column widths if necessary. Click **Next** when you’re finished.
6. Choose which column will act as the bound column and click **Next**.
7. Enter a label for the value list and click **Finish**.
Lesson 4-18: Modifying a Lookup List

Modifying an existing lookup field isn’t nearly as straightforward as creating one. You can display and modify the properties for a lookup field by clicking on the Lookup tab in the Field Properties section. There are several reasons why you would want to modify a lookup field:

- To sort the records in a lookup list. For example, to sort the records in a lookup list alphabetically by last name.
- To add, change, or delete the static options in a value list. For example, you could add “U.S. Postal Service” to a Ship Via value list.

In this lesson you will learn how to view and modify an existing lookup field.

1. Make sure the **tblCustomerTours** table is open in **Design view**.

   The CustomerID lookup field we created in an earlier lesson is neat, but its list of names aren’t displayed in alphabetical order. Not a problem—we can change this by modifying the lookup field. You can display and change the properties for a lookup field by clicking the Lookup tab in the Field Properties section.
2. Click the CustomerID field name, then click the Lookup tab in the Field Properties section.

   The properties for the CustomerID lookup field are displayed, as shown in Figure 4-32. You can learn more about these properties in Table 4-9: Lookup Field Properties.

3. Click the Row Source box.

   That technical SELECT DISTINCTROW [Customers].[CustomerID] stuff in the Row Source box is a SQL statement. SQL (Structured Query Language) is a language most database programs use to create queries—and it tells lookup fields where to get their values. Fortunately you don’t have to know how to write SQL to modify a lookup field—you can use the familiar Query grid to create the SQL statement for you.

4. Click the Row Source button to display the SQL Statement: Query Builder window.

   The SQL Statement: Query Builder window appears as shown in Figure 4-33. Yep—it’s the same query grid that you’re already familiar with.

5. Click the LastName field’s Sort Rows and select Ascending, as shown in Figure 4-33.

   This will sort the CustomerID lookup field by the LastName field.

6. Close the SQL Statement: Query Builder window and click Yes when you are prompted to save your changes.

   Access updates the SQL statement for the CustomerID lookup field. You can also view, change, or delete options from a value list using the Lookup tab.

7. Click the Ship Via field name.

   The Row Source box contains the value list options.

8. Click the Row Source box.

   The Row Source box contains the text "Airborne","FedEx","UPS". You can add options to the value list by typing them into the Row Source box—just make sure that the options are enclosed by quotation marks (" ) and separated by a semi colon (;).

9. Type ; "US Mail" so that the Row Source reads "Airborne","FedEx","UPS","US Mail".

   That’s it—you’ve finished modifying the lookup fields in the tblCustomers table.

10. Save your changes and close the tblCustomers table.

---

**Table 4-9: Lookup Field Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Control</td>
<td>Determines whether the lookup field is a text box, combo box, or list box.</td>
</tr>
<tr>
<td>Row Source Type</td>
<td>Determines how Access provides data to the lookup field: from a table or query, from a list of values specified in the Row Source box, or a list of field names in a table or query.</td>
</tr>
<tr>
<td>Row Source</td>
<td>Determines what is displayed in the lookup field. The Row Source property setting depends on the Row Source Type property setting.</td>
</tr>
<tr>
<td>Bound Column</td>
<td>The column in the lookup list that contains the value that is actually stored in the field. The bound column is the first column (1) by default.</td>
</tr>
<tr>
<td>Column Count</td>
<td>The number of columns that are displayed in the lookup field list.</td>
</tr>
<tr>
<td>Column Widths</td>
<td>The width of each column that is displayed in the lookup field list. Setting a column width to 0 hides the column.</td>
</tr>
<tr>
<td>Limit to List</td>
<td>Determines whether a field can accept a value that is not in the lookup list.</td>
</tr>
</tbody>
</table>
Chapter Four Review

Lesson Summary

Understanding Field Properties

• To Display a Table in Design View: Open the table and click the View button on the toolbar, or from the Database window click the Tables icon in the Objects bar, select the table and click the Design button.

Indexing a Field

• To Index a Field: Display the table in Design view. Click the field you want as an index, click the Indexed box, click the drop-down arrow and select Yes (Duplicates OK) if you want to allow multiple records to have the same data in this field, or select Yes (No Duplicates) if you want to ensure that no two records have the same data in this field.

Adding a Primary Key to a Table

• To Add a Primary Key to a Table: Display the table in Design view and click the field that you want to set as the primary key. If such a field doesn’t exist you will have to create it. Click the Primary Key button on the toolbar, and then right-click the field you want to use as the primary key and Primary Key from the shortcut menu.

Inserting, Deleting, and Reordering Fields

• To Insert a Row: Click the row selector for the field that will be below the new field you want to insert and press <Insert>.

• To Change the Order of Fields in a Table: Click the row selector for the field you want to move and click and drag the row selector to the desired location.

• To Delete a Field from a Table: Click the row selector for the field and press the <Delete>.

Changing a Field’s Data Type

• To Change the Data Type for a Field: Display the table in Design View, Click the field’s Data Type box, click the Data Type list arrow and select the data type.

Using Field Descriptions

• To add a Description to a Field: Display the table in Design View, click the field’s Description box and type the description you want to appear in the Status bar whenever a user selects that field.

Adding a Caption

• To Add a Caption to a Field: Display the table in Design view, click the field in the field list and click the Caption box in the Field Properties section and type the caption.
Change the Field Size

- **To Change the Field Size:** Display the table in **Design view**, click the field in the field list and click the **Field Size box** in the Field Properties section and either type the Field Size value (for text fields) or choose the value from the drop-down list (for number fields).

Formatting Number, Currency, and Date/Time Fields

- **To Format Number and Currency Fields:** Display the table in **Design view**, click the field in the field list, click the **Format box** in the Field Properties section, click the **Format drop-down arrow** and select a number format.

- **To Change the Number of Decimal Places:** Display the table in **Design view**, click the field in the field list, click the **Decimal Places box** in the Field Properties section, click the **Decimal Places drop-down arrow** and select the number of decimal places you want to display.

Formatting Number, Currency, and Date/Time Fields by Hand

- **To Manually Format a Number, Date, or Currency Field:** Display the table in **Design view**, click the field in the field list, click the **Format box** in the Field Properties section, and enter the appropriate text formatting symbols.

Formatting Text Fields

- **To Manually Format a Text Field:** Display the table in **Design view** and click the field in the field list, click the **Format box** in the Field Properties section, enter the appropriate text formatting symbols.

Setting a Default Value

- **To Enter a Default Value for a Field:** Display the table in **Design view**, click the field in the field list, click the **Default Value box** in the Field Properties section, and enter the default value you want to appear in the field for new records.

Requiring Data Entry

- **To Require Data Entry for a Field:** Display the table in **Design view**, click the field in the field list, click the **Required box** in the Field Properties section, click the **Required drop-down arrow** and select Yes.

Validating Data

- **To Validate Field Data:** Display the table in **Design view** and click the field in the field list, click the **Validation Rule box** in the Field Properties section, enter an expression you want to use to validate the field’s data, click the **Validation Text box** in the Field Properties section, and then type the text that Access will display when the user tries to enter incorrect data for the field.

Creating an Input Mask

- **To Create an Input Mask for a Field:** Display the table in **Design view** and click the field in the field list, click the **Input Mask box** in the Field Properties section, and click the **Build button** that appears to start the Input Wizard and select an input mask from the predefined list.
Creating a Lookup Field

- **To Create a Lookup Field**: Display the table in Design View, click the field's Data Type box, click the Data Type list arrow and select Lookup Wizard. Click the I Want The Lookup Column To Look Up The Values In A Table Or Query option, click Next, select the table or query you want to use for the look up list and click Next. Resize the column width and indicate whether or not to include the primary key in the column. If the table or query doesn’t have a primary key, you will be promoted for the column that will act as the bound column, click Next, enter a label for the Lookup column and click Finish.

Creating a Value List

- **To Create a Value List**: Display the table in Design View, click the field's Data Type box, click the Data Type list arrow and select Lookup Wizard, click the I Will Type in The Values That I Want option and click Next. Specify the number of columns you want to appear in the Value list, Enter the values in the list, Resize the column widths if necessary and click Next when you're finished. Choose which column will act as the bound column, click Next, enter a label for the Lookup column and click Finish.

Modifying a Lookup List

- **To Modify a Lookup List**: Display the table in Design View, click the Lookup field name box then click the Lookup tab in the Field Properties section, click the Row Source button to display the SQL Statement: Query Builder window, make the desired changes and then close the SQL Statement Builder window.

Quiz

1. **Which of the following is NOT a field property?**
   A. Field Size.
   B. Format.
   C. Color.
   D. Indexed.

2. **Indexing a field dramatically speeds up queries and sorts performed on the field, therefore you should always index every field in a table.** (True or False?)

3. **Which of the following statements is NOT true?**
   A. The Index Property has three settings: No, Yes (Duplicates OK), and Yes (No Duplicates).
   B. Primary key fields are automatically indexed.
   C. The Yes (No Duplicates) index option prevents duplicate entries in your table.
   D. You can index any type of field: text, date/time, AutoNumber, number, currency, yes/no, memo, OLE object, and hyperlink fields.

4. **Which of the following fields would NOT make a suitable primary key?**
   A. An AutoNumber field.
   B. A customer’s social security number.
   C. An invoice number.
   D. A date field.
5. Text entered in the field Description box will appear in a pop-up window whenever a user selected that field. (True or False?)

6. The Field Size property works differently, depending on whether the field is a text or number field. (True or False?)

7. Which of the following Format properties would display the full name of the month?
   A. MONTH.
   B. FULLMONTH.
   C. mm.
   D. mmmm.

8. Which of the following statements is NOT true?
   A. The Default Value property is automatically entered in a field when a new record is created.
   B. The Required property determines if a user must enter a value in a field or not.
   C. A lookup field lets you pick a field’s entry from a list of values, which often comes from another table or query.
   D. (___) ___ - _____ is a example of a Required property.

9. What does adding a > into the Format box of a text field do?
   A. Requires all characters entered in the field be in uppercase.
   B. Displays the characters in the field in uppercase.
   C. Requires all characters entered in the field be numbers.
   D. Displays the characters in the field in a larger font.

10. Which of the following statements is NOT true?
    A. The Default Value box lets you specify a value that is automatically entered in a field when a new record is created.
    B. The Required box lets you specify if data entry is required for a field.
    C. The maximum length of a memo field is 255 characters.
    D. The Validation Rule box lets you test data to make sure that it conforms to what you want to appear in the table. For example, entering <100 would require that a number must be less than 100.

11. You want to create a field that lets you add a customer's name by picking it from a drop-down list. Which of the following fields would let you do this?
    A. A memo field.
    B. A lookup field.
    C. An OLE field.
    D. A hyperlink field.

12. What is the corresponding text for the <#1/1/95# Validation Rule Setting?
    A. Enter a date before 1995.
    B. Enter a value less than 1,195.
    C. Enter a value greater than 1,195.
    D. Value must be less than 95 characters.

13. You can set a field as the primary key by selecting the field and clicking the Primary Key button on the toolbar. (True or False?)
Homework

1. Open the Homework database.
2. Open the Customers table in Design View.
3. Limit the Field Size of the LastName and FirstName fields to 15 characters.
4. Specify a format for the State field that will display all entries in uppercase.
5. Create an Input Mask for the SSN field so that users must enter information in a
   ___-__-___ format and make the SSN field a required field.
6. Index both the LastName and FirstName fields (duplicates OK).
7. Make the SSN field the table’s primary key.
8. Save your changes to the Customers table and close the Homework database.

Quiz Answers

1. C. There are Color properties for other database objects, but not for fields in a table.
2. False. Only index those fields that you frequently use to filter or sort information.
   Indexing too many fields in a table slows down filters and sorts, defeating the whole
   idea behind the index property.
3. D. This was a tricky question—you can’t index memo, OLE object, or hyperlink
   fields.
4. D. Because the date isn’t usually a unique value (the same date might appear more
   than once in the same table), it wouldn’t normally make a good candidate for a
   table’s primary key.
5. False. Text in the field Description box will appear in the Status bar when a user
   selects that field.
6. True. Text fields and Number/Currency fields have a different set of Field Size
   properties.
7. D. Another difficult question. mmmm would display the full name of the month.
8. D. (___) ___ - _____ is a example of an Input Mask property, not a Required
   property.
9. B. Adding a > to a text field’s Format box displays all characters in uppercase.
10. C. Memo fields have a maximum length of 64,000 characters.
11. B. A lookup field lets you select a value from a drop-down list.
12. A.
13. True. This is the procedure for setting a field as a table’s primary key.
Chapter Five: Creating Relational Databases

Chapter Objectives:

- Understand table relationships
- Create a relationship between two tables
- Understand referential integrity

Chapter Task: Join two related tables

This chapter covers what many people agree is one of the most difficult database concepts—how to create and work with relational databases. A relational database contains two or more tables that are related to each other in some way. For example, a database might contain a Customers table and an Invoices table that contains the customer’s orders.

In this chapter you will learn how to link tables in an existing database together in a one-to-many relationship to create a relational database. You will also learn how to enforce referential integrity between those tables to keep records in related fields valid and accurate.

Relational databases can be confusing at first, so we’ll take things slowly and explain everything in great detail as we go. Let’s get started!

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.
Lesson 5-1: Understanding Table Relationships

Figure 5-1
This database tracks customers and their orders in two separate but related tables.

Figure 5-2
Sketch out a diagram of your table, including its tables and how they relate to each other.

There are two basic types of databases:

- **Flat File**: Think of a Rolodex when you think of a flat file database. A flat file database stores all of its information—names, addresses, etc.—in the same place, just like addresses are stored on a Rolodex card. Flat file databases are incredibly simple to create and use, but they’re not very powerful or well-suited for many business tasks.

- **Relational**: A relational database contains multiple tables that are related through matching fields. Figure 5-1 illustrates the design of a relational database. The database in Figure 5-1 has two tables—one that stores customer names and addresses, and another that stores customer orders. The two tables are related or linked by a common field. Relational databases are very powerful, but developing one takes a lot of skill, practice, and a strong understanding of tables and fields.
Microsoft Access can create either type of database—flat file or relational—however most Access databases tend to be the relational flavor.

Still fuzzy about how relational databases work? To see an example of a relational database look at the diagram illustrated in Figure 5-1. This database tracks customers and their orders. To store this information, the database uses two tables: Customers and Orders. Each table contains fields that store similar information. The Customers table contains only information about customers and their addresses. The Orders table contains only information about any orders that were placed—it doesn’t contain any information about the customers. The two tables both have an ID field and it’s this ID field that relates or links the two tables.

Relational databases save storage space by cutting down on duplicate data. For example, the relational database shown in Figure 5-1 stores information in two related tables and eliminates the need to re-enter a customer’s name and address each time they place a new order.

Relational databases require lots of planning ahead. Before you attempt to create your database you should sit down with a trusty pencil and a pad of paper and walk through the following steps:

• **Determine the Purpose of the Database**
  Write down a list of the reports and lists that you want to come out of the database. This may seem a little backward at first, but these reports are the reason you’re creating the database. Make a list of the reports and lists you want to see and then sketch some samples of these reports and lists—be as detailed as possible. This will help determine the tables and fields to include in your database.

• **Write Down the Fields You Need**
  This should be an easy step once you have determined the purpose of your database and have sketched some sample reports and lists.

• **Organize and Group Related Fields into Separate Tables**
  Each Table in the Database should be based on only one subject. By breaking each subject into its own table you avoid redundant information and make the database more organized. The database in Figure 5-1 is broken down into two tables, Customers and Orders, so there isn’t any duplicated data. When you brainstorm try to break down your information as much as possible. If your table contains fields like Item 1, Item 2, Item 3, and so on you should probably break each item up into its own table.

• **Identify and Add the Fields Common to Each Table**
  In Figure 5-1 the Customer table’s ID field links to the Orders Table’s ID field. One of the linked fields should be the table’s primary key. See the Adding a Primary Key to a Table lesson for more information about primary keys.

• **Sketch a Diagram of Your Database**
  Create a diagram of your database similar to the one shown in Figure 5-2. Draw a box for each of your tables and write the table’s field names inside that box. Draw a line between the related fields. Most table relationships are a one to many relationship. This means that a record in one table may be related to one or more records in another table. For example, in Figure 5-1 each record in the tblCustomers table is related to one or more records in the Orders table. This makes sense, since hopefully most customers will place more than one order. You should indicate the one side of the relationship by drawing a 1 on the one side of relationship line and a ∞ (infinity symbol) on the many side of the relationship line.

All this writing and planning may seem like a lot of work, but it’s a critical step in creating a sound database. A carpenter wouldn’t start building a house without their blueprints would she? No—and it’s no different if you’re going to create a good relational database.
Lesson 5-2: Creating Relationships between Tables

Figure 5-3
The Show Table dialog box.

Figure 5-4
The Relationships dialog box.

Figure 5-5
Click and drag the primary key field from one table to the matching field in the related table.

Figure 5-6
The Relationships window.

Once you begin to understand the difficult concept of relational databases, the process of actually linking the tables in a database is rather simple. You link related tables by connecting the table’s common fields in Access’s Relationship window, shown in Figure 5-6. The Relationship window lets you view, create, and modify relationships among tables in a database.

Keep the following rules in mind when you link two tables together:

- **Linked fields should be (almost) identical**
  Related fields must have the same data type and field size, and they must contain the same kind of information. Related fields don’t have to have the same field name—but they should so that things don’t get confusing. The most common problem people have when they are trying to link two tables is caused by fields with different data types and/or sizes.
Chapter Five: Creating Relational Database

Quick Reference

To Define Table Relationships:
1. In the Database window, click the Relationships button on the toolbar.
Or...
Right-click any blank area in the Database window and select Relationships.

Relationship button

Other Ways to Define Table Relationships:
- Right-click any blank area in the Database window and select Relationships.

Show Table button

1. Open the Lesson 5 database.
   To view and create relationships between tables you need to display the Relationships window.

2. Click the Relationships button on the toolbar.
The Relationships window appears.

3. If the Show table dialog box doesn’t appear when you open the Relationships window click the Show Table button on the toolbar.
First you have to add the tables that you want to relate using the Show Table dialog box, as shown in Figure 5-3. In this exercise you want to relate the Customers, Tours, and tblCustomerTours tables, so you will need to add these tables to the Relationships window.

4. Click the tblCustomers table and click Add.
The tblCustomers table appears in the Relationships window.

5. Add the tblTours and tblCustomerTours tables to the Relationships window.
You can close the Show Table window when you have finished adding all the tables that you want to relate to one another.

6. Click Close to close the Show Table dialog box.
You’re ready to start relating the tables you added. Relating tables may sound difficult but it’s really nothing more than dragging and dropping the field you want to use to link one table to the other. Before you can drag and drop the matching field from one table to the other you have to make sure that the linking fields in both tables are visible.

7. Drag the CustomerID field from the tblCustomers table to the CustomerID field in the tblCustomerTours table, as shown in Figure 5-5.
Dragging a field from one table to another in the Relationships window links the two tables using the selected field.

NOTE: Access is very picky about where you point, click, drag, and drop. You need be very accurate and drag the pointer right next to the field you’re linking to.
The Relationships dialog box appears as shown in Figure 5-4. What’s especially important here is the “Enforce Referential Integrity” check box. Referential integrity helps you avoid “orphan” records and maintains database accuracy. For example, checking the Referential Integrity box would ensure that you could not enter an invoice for a customer in an Invoice table unless that same customer existed in a tblCustomers table. We’ll discuss referential integrity more later in the chapter.

8. Check the Enforce Referential Integrity, Cascade Update Related Fields, and Cascade Delete Related Fields boxes and click Create.
The Relationships dialog box closes and a line appears between the two tables’ CustomerID fields, indicating that the tables are linked, as shown in Figure 5-6.

Congratulations! You’ve just linked two related tables together!

- The primary key in one table is usually linked with a matching field in the other table
Notice in Figure 5-6 that the tblCustomers table’s primary key CustomerID links to the CustomerID field in the Customer tblTours table.

- Fields related to an AutoNumber primary key field must be Number fields with the Long Integer Field Size.
Now you’re ready to create a relationship between the tables in your database. Here’s how to do it:

1. Open the Lesson 5 database.
   To view and create relationships between tables you need to display the Relationships window.

2. Click the Relationships button on the toolbar.
The Relationships window appears.

3. If the Show table dialog box doesn’t appear when you open the Relationships window click the Show Table button on the toolbar.
First you have to add the tables that you want to relate using the Show Table dialog box, as shown in Figure 5-3. In this exercise you want to relate the Customers, Tours, and tblCustomerTours tables, so you will need to add these tables to the Relationships window.

4. Click the tblCustomers table and click Add.
The tblCustomers table appears in the Relationships window.

5. Add the tblTours and tblCustomerTours tables to the Relationships window.
You can close the Show Table window when you have finished adding all the tables that you want to relate to one another.

6. Click Close to close the Show Table dialog box.
You’re ready to start relating the tables you added. Relating tables may sound difficult but it’s really nothing more than dragging and dropping the field you want to use to link one table to the other. Before you can drag and drop the matching field from one table to the other you have to make sure that the linking fields in both tables are visible.

7. Drag the CustomerID field from the tblCustomers table to the CustomerID field in the tblCustomerTours table, as shown in Figure 5-5.
Dragging a field from one table to another in the Relationships window links the two tables using the selected field.

NOTE: Access is very picky about where you point, click, drag, and drop. You need be very accurate and drag the pointer right next to the field you’re linking to.
The Relationships dialog box appears as shown in Figure 5-4. What’s especially important here is the “Enforce Referential Integrity” check box. Referential integrity helps you avoid “orphan” records and maintains database accuracy. For example, checking the Referential Integrity box would ensure that you could not enter an invoice for a customer in an Invoice table unless that same customer existed in a tblCustomers table. We’ll discuss referential integrity more later in the chapter.

8. Check the Enforce Referential Integrity, Cascade Update Related Fields, and Cascade Delete Related Fields boxes and click Create.
The Relationships dialog box closes and a line appears between the two tables’ CustomerID fields, indicating that the tables are linked, as shown in Figure 5-6.

Congratulations! You’ve just linked two related tables together!
Lesson 5-3: Enforcing Referential Integrity

When you create a relationship between two tables, it is usually a good idea to enforce referential integrity. So what does this technical-sounding phrase mean? Referential integrity keeps records in related fields valid and accurate. Referential integrity ensures that you don’t accidentally change or delete related data in one table but not in the other. For example, say you were using two related Social Security fields to link two tables. If you changed the Social Security number in one record, referential integrity would automatically change the Social Security number in the other related records.

Access is very picky about when you can set referential integrity. You can only use referential integrity when all of the following conditions are met:

- One of the linked fields is a primary key
- The related fields are the same data type and size. (If you are using an AutoNumber field you can relate it to a Number field with a Long Integer Field size.)
- Both tables are in the same Access database.
- You can’t have a record in a related table unless a matching record already exists in the primary table. Orphan data in a related table is the most common problem people encounter when attempting to establish referential integrity.

Once you have established referential integrity, the following rules are set:

- You can’t add a record to a related table unless a matching record already exists in the primary table.
Quick Reference

To Enforce Referential Integrity:

1. In the Database window, click the Relationships button on the toolbar.
   Or...
   Right-click any blank area in the Database window and select Relationships.
2. Double-click the join line for the relationship you want to work with.
3. Check the Enforce Referential Integrity box.
   This will enforce referential integrity between the tables. If you get an error message it’s because your tables and fields don’t meet all the required conditions listed on the previous page.

There are two other very important boxes in the Relationships dialog box. They are:

- **Cascade Update Related Fields**
  When you change data in the main field of one table, Access will automatically update the matching data in the related table.

- **Cascade Delete Related Records**
  When you delete a record in the main table, Access will automatically delete any matching records in the related table.

These are both very powerful options—think twice before using them.

In the next lesson you will get to test the results of your new referential integrity settings.

Chapter Five: Creating Relational Database

- You can’t change the value of a primary key in the primary table if matching records exist in the related table (unless you select the Cascade Update Related Fields option).
- You can’t delete a record from a primary table if matching records exist in a related table (unless you select the Cascade Delete Related Fields option).

In this lesson you will learn how to enforce referential integrity.

Make sure you’re in Lesson 5, the relationship window is open and the tblTours and tblCustomerTours tables are shown.

First, establish a relationship between the tblTours table and the tblCustomerTours table…

1. **Drag the TourID field from the tblTours table to the TourID field in the tblCustomerTours table.**
   The Relationships dialog box appears. We want to enforce referential integrity so that you can’t enter a TourID in the tblCustomerTours table unless that TourID number already exists in the tblTours table.

2. **Check the Enforce Referential Integrity box.**
   This will enforce referential integrity between the tables. If you get an error message it’s because your tables and fields don’t meet all the required conditions listed on the previous page.

   There are two other very important boxes in the Relationships dialog box. They are:

   - **Cascade Update Related Fields**
     When you change data in the main field of one table, Access will automatically update the matching data in the related table.

   - **Cascade Delete Related Records**
     When you delete a record in the main table, Access will automatically delete any matching records in the related table.

   These are both very powerful options—think twice before using them.

3. **Check both the Cascade Update Related Fields and Cascade Delete Related Records boxes.**
   Go ahead and create the relationship.

4. **Click Create to create the relationship between the tblCustomers and tblCustomerTours tables.**
   Access creates the relationship between the two tables and enforces referential integrity between them. Notice that the join line between the tblCustomers table and the tblCustomerTours table looks a little different. This relationship indicates that referential integrity is being enforced between the two tables and that the tables have a one-to-many relationship (more about that later).

5. **Close the Relationships window and click Yes to save the changes you made.**

   In the next lesson you will get to test the results of your new referential integrity settings.
Lesson 5-4: Testing Referential Integrity and Printing and Deleting Table Relationships

In this lesson you will get to test the referential integrity rules you established in the previous lesson. You just went over it, but since this referential integrity stuff is a little tricky and confusing at first let’s review...

Once you have established referential integrity, the following rules are set:

- You can’t add a record to a related table unless a matching record already exists in the primary table.
- You can’t change the value of a primary key in the primary table if matching records exist in the related table (unless you select the Cascade Update Related Fields option.)
- You can’t delete a record from a primary table if matching records existing in a related table (unless you select the Cascade Delete Related Records option.)

Think you have a better understanding referential integrity yet? No? This lesson will give you a chance to work with some related tables where referential integrity has been set. You will also learn how to delete a relationship between two tables.

1. **Open the tblCustomers table in Datasheet view.**
   First let’s try deleting a new record to the tblCustomerTours table.

2. **Click on the record selector for the record with the CustomerID 1 (Antonio Rommero) and click the Delete Record button on the toolbar.**
   Because you enable both referential integrity and cascaded deletes in the previous lesson, Access displays the dialog box shown in Figure 5-9. Access wants you to confirm your deletion, as deleting the customer record will delete any related data for the customer in the tblCustomerTours table.

3. **Click Yes.**
   Access deletes the record from the Customer table and any related tours for the customer in the tblCustomerTours table. If you hadn’t enforced referential integrity between these tables you would be left with one or more “orphan” records for Antonio Rommero in the tblCustomerTours table.
4. Close the tblCustomers table and open the tblCustomerTours table in Datasheet view.

Yikes! The tblCustomerTours table contains a lot of ID number fields, such as CustomerID and TourID. Unless you have a printed list of these ID numbers (or have a super-human memory) you won’t know which CustomerID to enter. (By the way, this is why you will want to use a lot of forms and queries in relational database—to hide all the technical inner-working of a database from your hapless users.)

Anyway let’s try adding a new record to the tblCustomerTours table.

5. Click the New Record button on the Record Navigation bar.

Access adds a new blank record to the table.

6. Enter a new record using the following information:

<table>
<thead>
<tr>
<th>CustomerID</th>
<th>TourID</th>
<th>EmployeeID</th>
<th>Date</th>
<th>Number of Tickets</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>4</td>
<td>4/2/00</td>
<td>1</td>
</tr>
<tr>
<td>Ship Via</td>
<td>Smoker</td>
<td>First Class</td>
<td>Cost</td>
<td></td>
</tr>
<tr>
<td>FedEx</td>
<td>No</td>
<td>No</td>
<td>$450</td>
<td></td>
</tr>
</tbody>
</table>

Before you finish adding the record, it’s very important that you remember that you deleted the CustomerID 1 record back in Steps 2 and 3. Since you enforced referential integrity between the two related CustomerID fields watch what happens when you try to add the record…

7. Finish adding the record by pressing <Ctrl> + <Enter> or clicking in any other record when you have finished entering the records information.

Because a CustomerID 1 doesn’t exist in the tblCustomers table, a dialog box appears informing you that Access can’t add the record because doing so would violate referential integrity.

8. Click OK to close the dialog box.

You can cancel the addition of the new record.

9. Press <Esc> to cancel the new record, then close the tblCustomerTours table.

Now that you have a better feel for how referential integrity works let’s go back to the Relationships window to quickly cover this lesson’s other two topics—printing and deleting table relationships.

10. Click the Relationships button on the toolbar.

Sometimes you may want a printed hardcopy of the Relationship window.

11. Select File → Print Relationships from the menu.

The Print dialog box appears. You don’t actually need to print anything for now, so…

12. Click Cancel.

Sometimes you may want to delete the relationship between two tables. Access is very restrictive about letting you modify a related table, and often you must temporarily delete the relationship between two tables, modify one of the tables, and then re-connect them. Here’s how to delete a table relationship.

13. Click the join line between the tblTours table and the tblCustomerTours table to select it and press <Delete>.

NOTE: Clicking a tiny join line between two tables requires a lot of mouse dexterity—you probably will have to try several times before you get it.

Access asks you to confirm the deletion. Let’s leave the table relationship be for now.

14. Click No and close the Relationships window.
Lesson 5-5: Understanding Relationship Types

When you link two tables together, they form one of three possible relationships. This information is rather technical, but it’s good to know if you’re working with related or linked tables. There isn’t a step-by-step exercise in this lesson—all you have to do is look over Table 5-10: Types of Relationships to get a better understanding of table relationships.

Table 5-10: Types of Relationships

<table>
<thead>
<tr>
<th>Relationship</th>
<th>Description</th>
</tr>
</thead>
</table>
| One to One   | Each record in a table relates to one record in another table. This is the simplest type of relationship, but they don’t occur very often because it’s usually easier to store such information in one table instead of two.  
**Example:** Each customer has one credit report. |
| One to Many  | Each record in a table relates to one or more records in another table. **This is the most common type of relationship.**  
**Example:** Each customer has one or more invoices. |
| Many to Many | One or more records in a table relates to one or more records in another table. Many to many relationships are very confusing and thus they aren’t used very often. To create a Many to Many relationship you usually need a third intermediate table that contains the primary keys from each of the two tables in the relationship. Such an intermediate table is called a **junction table**.  
**Example:** Each sales representative sells several products and each product is sold by several sales representatives. |
Chapter Five Review

Lesson Summary

Understanding Table Relationships
- Make sure that you have a good understanding of table relationships.

Creating Relationships between Tables
- To Define Table Relationships: In the Database window, click the Relationships button on the toolbar or right-click any blank area in the Database window and select Relationships. If necessary, click the Show Table button on the toolbar, click the table you want, and click Add. Repeat for each for table you want to use in the relationship and click Close when you’re finished. Click the related field in the first table and drag it to the related field in the second table, specify any referential integrity and/or join type options (optional). Click Create to create the relationship.

Enforcing Referential Integrity
- To Enforce Referential Integrity: In the Database window, click the Relationships button on the toolbar or right-click any blank area in the Database window and select Relationships. Double-click the join line for the relationship you want to work with and check the Enforce Referential Integrity box. If you want changes to the primary field of the primary table copied to the related field in the related table, check the Cascade Update Related Fields box, or if you want Access to automatically delete orphan records in the related table, check the Cascade Delete Related Records box. Then click OK.

Testing Referential Integrity and Printing and Deleting Table Relationships
- To Print the Relationships Window: In the Database window, click the Relationships button on the toolbar or right-click any blank area in the Database window and select Relationships. Select File → Print Relationships from the menu.
- To Delete a Table Relationship: Open the Relationships window, and click the join line that connects the tables and press <Delete>.
Chapter Five: Creating Relational Database

Quiz

1. You can use fields with different data types to link two tables. (True or False?)

2. Which of the following statements is NOT true?
   A. Click the Relationships button on the toolbar to display the table relationships in a database.
   B. Once you have added the required tables to the Relationships window, you can relate the tables by clicking the related field in the first table and dragging it to the related field in the second table.
   C. Referential integrity keeps records in related fields valid and accurate.
   D. For most people, table relationships are an easy to understand, straight-forward concept.

3. You have created a relationship between a Customers table and a related Customer Orders table and have established referential integrity in this relationship without the cascade delete related records option. Can you delete a record in the Customer table if it has related records in the Customer Orders table? (Yes or No?)

4. If the Cascade Delete Related Records referential integrity option is selected, when you delete a record in the main table, Access will automatically delete any matching records in the related table. (True or False?)

5. How can you display the relationships in a database?
   A. Select View → Relationships from the menu.
   B. Click the Relationships button in the Database window.
   C. Click the Relationships button on the toolbar.
   D. Select Edit → Relationships from the menu.

6. How can you add a table to the Relationships window?
   A. Select Edit → Add Table from the menu.
   B. Click the Show Table button on the toolbar.
   C. Select the table from the Table list on the toolbar.
   D. Select Tools → Add Table from the menu.

Homework

1. Open the Homework database.
2. Open the Customers table in Design View. Set the SSN field as the table’s primary key (if it isn’t already). Save your changes and close the Customers table.
3. Using the Relationship window, establish a relationship between the Customers table and the Claims table, using the SSN field to join the two tables.
4. Enforce referential integrity for the Customers/Claims relationship.
5. Enable Cascade Update Related Fields and Cascade Delete Related Records for the Customers/Claims relationship and click Create.


7. Close the Homework database.

**Quiz Answers**

1. False. With the exception of AutoNumber and Number fields, related fields must always have the same data type in order to be used to join two tables.

2. D. If only this were true! The truth is, understanding how to create and work with table relationships is a concept that most users struggle with initially.

3. No. Referential Integrity would prevent you from deleting a record in a primary table if it has records in a related table (unless the Delete Cascade Related Records option is selected.)

4. True. The Delete Cascade Related Records option automatically deletes records in any related tables.

5. C. Click the Relationships button on the toolbar to display the relationships in a database.

6. B. You can add a table to the Relationships window by clicking the Show Table button on the toolbar.
Chapter Six: Working with Queries

Chapter Objectives:
- Understand the various types of queries and their purposes
- Create queries based on more than one table
- Create queries that calculate and summarize information
- Use the Expression Builder to create expressions
- Create parameter queries which prompt the user for information
- Create queries that find duplicate and unmatched records
- Create Action queries that delete, update, append, and export information

Chapter Task: Create a variety of queries that analyze and manipulate database information

Queries are the stars of Microsoft Access. Queries make sense out of all thousands of jumbled records and display exactly what you need to know. Queries discover things like what the average price of tea in China is or which customers bought the most parakeet food from your company. Queries can even make widespread changes to the records in your database without wearing out your mouse and keyboard! For example, a delete query can automatically delete a whole bunch of records that meet your criteria.

In this chapter you will learn how to harness the power of queries. First you will learn about all the different types of queries: simple select queries, parameter queries that prompt you for more information, crosstab queries that summarize records in an easy understand format, action queries that actually modify the records in your database.

All this power comes with a price tag: many people find that queries are one of the more difficult database objects, and learning how to fully utilize queries isn’t something you can learn in an afternoon. By the time you finish this chapter, however, you will have a good start towards understanding and mastering queries.

Prerequisites
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- A basic understanding of queries: how to specify criteria and sort information.
Lesson 6-1: A Quick Review

Figure 6-1
The Query window in Design view.

Figure 6-2
A close-up of the Design grid.

Quick Reference
To Create a Query in Design View:
1. Click the Queries icon in the Objects bar then double-click the Create query in design view icon.
2. Select the table or query you want to use and click OK.
3. Repeat Step 2 as necessary for additional tables or queries. Click Close when you're finished.
4. Double-click each field you want to include from the field list.
   Or…
   Drag the field from the field list onto the design grid.
5. In the design grid, enter any desired search criteria for the field in the Criteria box.
6. Click the Sort box list arrow for the field and select a sort order.
7. Close the query window.
8. Click Yes to save the query, enter a query name, and then click OK.

Before we start tackling the functions and types of queries, let's take a step back and review. This lesson is more of a “cheat sheet” than an exercise. Hopefully it will help you remember what you already know about queries.

Table 6-1: Common Criteria Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>&quot;MN&quot;</td>
<td>Finds records equal to MN.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>&quot;MN&quot;</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt;10</td>
<td>Finds records less than 10.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>&lt;=10</td>
<td>Finds records less than or equal to 10.</td>
</tr>
<tr>
<td>&gt;</td>
<td>&gt;10</td>
<td>Finds records greater than 10.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>&gt;=10</td>
<td>Finds records greater than or equal to 10.</td>
</tr>
<tr>
<td>LIKE</td>
<td>LIKE &quot;S*&quot;</td>
<td>Finds text beginning with the letter S. You can use LIKE with wildcards such as &quot;.&quot;</td>
</tr>
<tr>
<td>NOT</td>
<td>NOT &quot;MN&quot;</td>
<td>Finds records not equal to MN.</td>
</tr>
<tr>
<td>IS NULL</td>
<td>IS NULL</td>
<td>Finds records whose fields are empty.</td>
</tr>
<tr>
<td>IS NOT NULL</td>
<td>IS NOT NULL</td>
<td>Finds records whose fields contain values.</td>
</tr>
</tbody>
</table>
Lesson 6-2: Understanding the Different Types of Queries

Figure 6-3

Each type of query has its own icon so that you can identify it. Table 6-2: Types of Queries describes the different types of queries.

Up until now, when you thought of a query you were actually probably thinking of a Select query—a particular type of query. Select queries are by far the most common and useful type of query in Access, however there are other types of queries that are also important. We will cover most of these query types in this chapter, so here’s a quick “overview” of the different types of queries you’ll find in Microsoft Access.

Table 6-2: Types of Queries

<table>
<thead>
<tr>
<th>Query Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Query</strong></td>
<td>The most basic and common type of query, select queries find and display the data you want from one or more tables or queries.</td>
</tr>
<tr>
<td><strong>Parameter Query</strong></td>
<td>Prompts the user for specific information every time the query is run.</td>
</tr>
<tr>
<td><strong>Crosstab Query</strong></td>
<td>Summarizes data in a table format that makes it easy to read and compare information.</td>
</tr>
<tr>
<td><strong>Make-Table Query</strong></td>
<td>Creates a new table from all or part of the data in one or more tables. Useful for backing up and exporting information.</td>
</tr>
<tr>
<td><strong>Append Query</strong></td>
<td>Appends or adds selected records from one table to another table. Useful for importing information into a table.</td>
</tr>
<tr>
<td><strong>Delete Query</strong></td>
<td>Deletes selected records from one or more tables.</td>
</tr>
<tr>
<td><strong>Update Query</strong></td>
<td>Updates selected information in a table. For example, you could raise the prices on all trips to Europe by 15%.</td>
</tr>
<tr>
<td><strong>Union Query</strong></td>
<td>Union queries combine fields from two or more tables or queries into one field. Union Queries are written directly in SQL.</td>
</tr>
</tbody>
</table>

Quick Reference

- Refer to Table 6-2: Types of Queries to be able to identify the various types of Microsoft Access queries and what each of them do.
Lesson 6-3: Creating a Multiple Table Query

In Access you will often need to look at and analyze information that comes from not one but several different tables. Since Access is a relational database it’s easy to establish a relationship between two or more tables and look at the information that goes together.

Just like it sounds, a multiple-table query blends together information from two or more related tables. Working with a multiple-table query usually isn’t much different than a single-table query. You tell Access which tables you want to use in your query and specify the fields and criteria you want to see. The main difference between a multiple-table query and a single-table query is that with multiple-table queries, Access creates a link between related tables. In query design view, this link (called a join) appears as a line that connects two more tables.

When you create a multiple-table query Access will usually link or join the tables automatically. Sometimes however, you will have to manually join two tables in the Query design window. You manually join two tables by dragging one field from a list to the other matching field in the field list for the other table. If the tables don’t have any fields in common, you must add another table to act as a bridge between them. This lesson will give you some experience creating a multiple-table query.

1. **Open the** Lesson 6 **database.**

   You should know how to create a query by now…
2. Click the Queries icon in the Objects bar then double-click the Create query in design view icon.
   The Query design window and Show Tables dialog box both appear. You have to select the tables and/or queries you want to use.

3. Click the tblEmployees table and click Add.
   A field list for the tblEmployees table appears in the top half of the Query design window. You also want to add the tblCustomerTours table and the tblTours table to the query.

4. Add the tblCustomerTours table and tblTours table to the query.
   When you have finished adding the tables and/or queries to your query you can close the Show Tables dialog box.

5. Click Close.
   If the two tables are related, Access will automatically connect their common fields with a join line. For example, Access automatically joins the tblTours table and tblCustomerTours tables because they are already related. If the tables aren’t related you will have to manually join the tables by dragging from one field list to the other matching field in the field list from the other table.

   You need to connect the tblEmployees table with the tblCustomerTours table.

6. Click on EmployeeID in the tblEmployees field list and drag and drop it onto Employee in the tblCustomerTours field list.
   NOTE: You can remove a join from a query by clicking the join line (careful—there’s not much there to click!) and pressing <Delete>.

   Next you need to specify the fields you want to appear in the query results. You can add fields to the query design grid in two ways:
   - By double-clicking the field on the field list.
   - By clicking and dragging the field down to the design grid yourself.

   Because field lists don’t have much room to display their contents you may have to scroll up or down the list in order to find the field you want.

7. Double-click the LastName and FirstName fields in the tblEmployee field list.
   Access adds the LastName and FirstName fields from the tblEmployees table to the design grid. Next add the fields for the Tour and tblCustomerTours tables.

8. Double-click the TourName field in the tblTour field list and the Date and Cost fields in the tblCustomerTours field list.
   Next you need to specify any criteria for the query. For this exercise you want to see tours from the first quarter of the year.

9. Click the Date column’s Criteria row and type Between 1/1/00 and 3/31/00.
   You want to sort your query by date, so…

10. Click the Date field’s Sort Row and select Ascending.
    That’s it! You’ve just created a multiple-table query.

11. Save the Query as qryFirstQuarterTours.
    Okay, let’s run our new query!

12. Click the Run button on the toolbar.
    Access displays the results of the query. The results show the names of the employees who sold tours and the names, dates, and costs of the tours.

13. Close the Query.
Lesson 6-4: Creating a Calculated Field

Normally when you create a database, you should only have to enter the information you need and not worry about data or values that Access calculate based on information already in the database. A calculated field performs some type of arithmetic on one or more fields in a database to come up with a completely new field. For example, if your database has an Order Total field and a Tax Rate field, Access can calculate these two fields to find out the Sales Tax for each order: \[ \text{Order Total} \times \text{Tax Rate} = \text{Sales Tax} \].

You must create an expression (or formula) to perform a calculation. To enter fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!). Then type the field name in brackets ([Order Total]).

**Figure 6-6**

Creating a calculated field.

**Figure 6-7**

To enter fields in an expression type the field name in brackets ([Order Total]).

**Figure 6-8**

If a field name exists in more than one table you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!). Then type the field name in brackets ([Order Total]).

**Bonus:** \[ \text{[Cost]} \times \text{[Commission]} \]

Name of the field that will display the results of the calculation followed by a colon (:).

**Figure 6-7**

**Bonus:** \[ \text{[tblCustomerTours]}!\text{[Cost]} \times \text{[tblEmployees]}!\text{[Commission]} \]

Name of the field that will display the results of the calculation followed by a colon (:).

Table Names must be enclosed in brackets [ ].

Existing field names used in the calculation must be enclosed by brackets [ ].
typing the table name ([Orders]), an exclamation mark (!), and then the field name ([Date]) or [Orders]![Date]. Yes, calculated fields can be a little confusing at first…

This lesson will show you how to add a calculated field to a query.

1. Click the **Queries tab**, if necessary, click the **qryEmployeeSales** query, then click **Design**.
   Instead of creating a query from scratch, you can modify an existing query and save it with a different name.

2. **Click the blank field cell of the fourth column and type**
   **Bonus:[Cost]*[Commission]**.
   The expression you entered will create a new calculated field to the query named Bonus that will display the results of the Cost field in the tblCustomerTours table multiplied by the Commission field in the tblEmployees table.

   Let’s see the results of our calculated field.

3. **Click the **Run button** on the toolbar.**
   Access displays the results of the query. The Bonus calculated field multiplies the Cost field by the Commission field in each record and displays the results.

   Save your changes in new query with a different name. Here’s how:

   4. **Select File → Save As from the menu.**
      The Save As dialog box appears.

5. **Type** **qryEmployeeBonus** **in the New Name box and click OK.**
   Access saves your changes in a new query named qryEmployeeBonus.

6. **Close the query.**

You’re already familiar with some of the arithmetic operators used in expressions: They include math symbols such as the plus sign (+) to perform addition between values and the minus sign (-) to perform subtraction.

### Table 6-3: Arithmetic Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
</tr>
</tbody>
</table>

You can also use the **Expression Builder** to help you create your calculated fields. Click the **Builder button** on the toolbar, double-click the field you want to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other fields or values you want to use.

---

**Quick Reference**

To Create an Expression or Calculation in a Query:

1. Display the query in **Design View**.

2. Click the **Field Row** of a blank column in the design grid.

3. Enter the field name for the calculated field followed by a : (colon).

4. Enter the expression you want Access to calculate, using the proper syntax.
   Or…
   Click the **Build button** on the toolbar, double-click the field you want to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other fields or values you want to use when you’re finished. Click **OK**.

5. Click the **View or Run button** on the toolbar to see the results.
Lesson 6-5: Working with Expressions and the Expression Builder

You can add calculations to queries, forms, and reports by typing an expression or formula that tells Access exactly what to calculate. An expression can be any combination of values, identifiers (such as the value in a field), and operators that result in a value. Here’s an example of an expression that calculates profit from two fields called Income and Expenses:

Profit: [Income] – [Expenses]

You can also use constants in an expression, such as:

Commission: [Sales] * .15

Number fields aren’t the only types of fields that you can use in expressions—you can also perform calculations with dates, times, and text data.

The problem with creating expressions is you have to enter a formula so that Access understands it (and believe me, Access isn’t very bright). For example, when you create an expression, some types of information must be enclosed between special characters so that Access knows what type of information it is—table names and field names must be enclosed in [brackets], text strings in "quotation marks" and so on. Table 6-4: How Types of Data Should Look in an Expression has more information about how to use various elements in an expression.

If you know what you want an expression to do, but not how to write it, you can try using the Expression builder. The Expression builder lets you pick the fields, mathematical symbols, and functions you can use to create an expression.

This lesson will give you some more experience writing expressions—both on your own and using the Expression builder.

1. **Open the qrySales query in Design view.**
   First you need to insert a blank column at the beginning of the design grid. Here’s how:
Position the mouse over the top of the **Tour Name** field (changess to §) and click to select the field. Press **Insert** to add a new column.

A column is inserted at the beginning of the design grid. In the next step, you will learn how to create one of the most common database functions: how to combine the tblEmployee table’s FirstName and LastName fields to display the full name.

**Type Agent:** [FirstName] & " " & [LastName] in the new blank Field row.

The ampersand (&) symbol is used to combine or “concatenate” two or more text fields. The " " adds a space between the [FirstName] and [LastName] fields.

Next you need to enter an expression that calculates the cost of the tour by multiplying the Number of Tickets field by the Normal Price field. You will use the Expression Builder to help you write this expression.

**Click the first blank Field row and click the Build button on the toolbar.**

The Expression Builder appears, as shown in Figure 6-9. The Expression Builder contains an area where you can build the expression, buttons you can use to build the expression, and the fields and controls in the current query, report, or form.

**Double-click Normal Price, click the Multiplication button, and double-click Number of Tickets.**

The completed expression appears in the Expression list box, as shown in Figure 6-9. You’re finished writing the expression so you can close the Expression Builder.

**Click OK.**

The Expression Builder closes. Add a meaningful label to the new calculated field.

**In the new calculated field, replace the Expr1: label with Total:**

The edited expression should read Total:[Normal Price]*[Number of Tickets]. Let’s see the results of the new query.

**Click the Run button on the toolbar.**

The query combines the FirstName and LastName fields in the new Name field and displays the total sales price in the New Total Field.

**Click the Save button on the menu to save your changes and then close the query.**

Microsoft Access is very strict about how you write your expressions. If your expressions aren’t written in the correct syntax, they won’t work. Use the following table as a guideline for adding fields, text, and constants to your expressions.

<table>
<thead>
<tr>
<th>Type of Data</th>
<th>How It Should Look</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>&quot;Minneapolis&quot;</td>
</tr>
<tr>
<td>Date/Time</td>
<td>&quot;#20-Mar-99#&quot; (Access will add the # symbols.)</td>
</tr>
<tr>
<td>Field Name</td>
<td>[Price]</td>
</tr>
<tr>
<td>Field Name in a Specific Table</td>
<td>[Products]<img src="Price" alt="" /></td>
</tr>
<tr>
<td>Concatenated (Combined) Text and Fields</td>
<td>[Last] &amp; &quot; &quot; &amp; [First]</td>
</tr>
<tr>
<td>Calculated Field (Using Two Fields)</td>
<td>[SalePrice]-[Cost]</td>
</tr>
<tr>
<td>Calculated Field (Using a Field and a Constant)</td>
<td>[SalePrice]*0.1</td>
</tr>
</tbody>
</table>

**Quick Reference**

**To Create an Expression with the Expression Builder:**

1. Display the query in **Design View**.
2. Click the **Field Row** of a blank column in the design grid.
3. Click the **Build button** on the toolbar, double-click the field you want to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other fields or values you want to use.
4. Click **OK**.
Lesson 6-6: Using an IIF Function

Figure 6-10
The syntax for the IIF function.

Figure 6-11
Here the IIF function evaluates the value in the First Class field and returns 50 if the First Class field is True and 25 if the First Class field is false.

Functions are used to create more complicated calculations or expressions than operators can. For example, the SUM function adds several values together and the IPmt function calculates the loan payments based on an interest rate, the length of the loan, and the principal amount of the loan.

There are several hundred functions in Access, but all of them are used in a similar way. The name of the function is followed by the arguments in parenthesis. An “argument” in Access is the value a function uses to perform its calculation—it’s not the disagreement you have over political views. For example, the argument in the formula $\pi r^2$ would be $r$ or the radius, used to find the area of a circle.

This lesson introduces a very useful database function, the IIF function. The IIF function is a “conditional function” or “logical function” because it evaluates a condition and return one value if the condition is true and another value if the condition is false. For example, you could use the IIF function in an invoice to create a formula that would subtract a 5% discount from the invoice if the total were more than $500.00—otherwise the IIF Function wouldn’t subtract anything.

The IIF function contains 3 arguments, as shown in Figure 6-10. Since you can use the Expression Builder to help you create IIF function formulas you really don’t need to memorize the syntax of the function.

In this lesson you will use the IIF function to create a field that gives passengers a $50 rebate if they fly first class and a $25 rebate if they fly coach.

1. Open the qryRebate query in Design view.

You need to create a calculated field that will determine how much of a rebate passengers should receive. Create this field in the first blank field row.

2. Click the blank field row in the fifth column and click the Build button on the toolbar.

The Expression Builder appears.
The bottom-left window of the Expression Builder displays several folders that contain lots of information. For example, the Tables folder contains a list of all the tables in the current database. These folders are displayed in a hierarchical view. A plus symbol (+) or a minus symbol (-) on a folder means a folder contains several subfolders. Normally these subfolders are hidden. You can display the hidden folders within a folder by double-clicking the folder. To see the contents of a folder simply select the folder—its contents will appear in the middle and left windows.

To use one of the built-in functions, double-click the Functions folder in the bottom-left window.

3. **Double-click the **Functions folder in the bottom-left window.

The Function folder expands and displays its contents. The Built-In Functions folder contains several hundred functions that are included in Access.

4. **Click the **Built-In Functions folder.

When you select the Built-In Functions folder in the left window, the middle window displays the function categories you can use, and the right window displays the functions in the selected category. If you know the category of the function you want to use you can select it in the middle window to narrow down your choices in the right window.

5. **Scroll down the bottom-middle window and find and select the Program Flow function category.**

The right window displays the Program Flow functions.

6. **Double-click the **IIf function in the right window.

Access adds IIf («expr», «truepart», «falsepart») to the expression box. Now that you know the proper syntax of the IIf function, you need to replace the argument names with the data values. You can double-click to select any argument name so that you can replace it with your own value.

7. **Double-click the «expr» argument to highlight it.**

You need to specify the logical test—if the passenger flew first class or not.

8. **Click the qryRebate folder in the right window and then double-click the First Class field in the middle window.**

The Expression Builder adds the First Class field to the expression. Finish the rest of the logical test.

9. **Type =True.**

Your expression should read IIf ([First Class]=True, «truepart», «falsepart»). Now you have to replace the «truepart» and «falsepart» arguments with the values you want to use if the IIf statement is true or false.

10. **Double-click the «truepart» argument and type 50, then double-click the «falsepart» argument and type 25.**

11. **Click OK.**

The Expression Builder closes. We need to give the new calculated control a more meaningful name...

12. **In the new calculated field, replace the Expr1: label with Rebate:**

Let’s see the results of the new query.

13. **Click the Run button on the toolbar.**

The IIf expression in the new Rebate field evaluates the First Class field and returns a $50 rebate if the customer flew First Class and a $25 rebate if they didn’t.

Save your changes.

14. **Save your changes and close the query.**
Lesson 6-7: Summarizing Groups of Records

When you work with queries, you will often be less interested in the individual records and more interested in summarized information about groups of records. A query can calculate information about a group of records in one or more tables. For example, you could create a query that finds the total amount of tea your company sold to China in 1998 or how much all that tea cost. The Total row lets you group and summarize information in a query. The Total row normally is tucked away from view in the query design window—you can make the Total row appear by clicking the Total button on the toolbar or by selecting View → Totals from the menu. Once the Totals row is displayed you can tell Access how you want to summarize the fields.

1. **Open the qryTourSales query in Design view.**
   First you need to add the field that you want to group data by onto the design grid. You want to calculate the total sales and number of tickets sold for each tour package, so you will group the query by the TourName field.

2. **Double-click the TourName field in the tblTours field list.**
   The TourName field appears as the first field in the design grid. Next you need to add the fields you want to summarize.

3. **Double-click the Number of Tickets and Cost fields in the tblCustomerTours field list.**
   To summarize your query you must summon the Total row. To summon the Total row click on the Totals button on the toolbar or select View → Totals from the menu.

4. **Click the Totals button on the toolbar.**
   The Totals row appears in the design grid. Next you need to select the fields you want to summarize and the calculation you want to perform on them.

---

**Figure 6-12**

Using a query to find the total number of tickets and sales, grouped by the TourName field.

<table>
<thead>
<tr>
<th>TourName</th>
<th>SumOfCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>African Safari</td>
<td>$15,960.00</td>
</tr>
<tr>
<td>British Isles</td>
<td>$33,100.00</td>
</tr>
<tr>
<td>China</td>
<td>$177,270.00</td>
</tr>
<tr>
<td>Europe 10 Days</td>
<td>$18,500.00</td>
</tr>
<tr>
<td>Europe 15 Days</td>
<td>$78,835.00</td>
</tr>
</tbody>
</table>

A Datasheet calculated with a SUM function.
Chapter Six: Working with Queries

5. **Click the Number of Tickets column's Total row and click the arrow that appears.**
   A list of calculations appears. You simply select the calculation you want to perform on the field. Table 6-5: Total Options describes the available calculations.

6. **Select Sum from the list.**
   This will total the values in the Number of Tickets field.

7. **Click the Cost column's Total row, click the arrow and select Sum from the list.**
   You can specify criteria to limit the records you want to be calculated—simply enter the criteria in the Criteria row of any grouped or calculated fields. If the field you want to use for the criteria isn’t one of the grouped or calculated field you must use the Where option in the field’s Total row. The Where option limits the records used in the calculation without being included in the query results.

8. **Double-click the Date field in the tblCustomerTours field list.**
   Here’s how to add criteria to the Date field.

9. **Click the Date column's Total row, click the arrow and select Where from the list.**
   The Where option is used only to limit records—its results cannot be displayed in the results of the query. Access knows this and automatically turns off the Show checkbox.

10. **Click the Date column's Criteria row and type Between 4/1/00 and 6/30/00.**
    You’re ready to see the results of the new query.

11. **Click the Run button on the toolbar.**
    Access displays the results of the query, which calculates the total sales and number of tickets sold for each tour package.

12. **Save the query as qryTourTotals and then close the query.**

### Table 6-5: Total Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group By</td>
<td>Groups the values in the field so that you can perform calculations on the groups.</td>
</tr>
<tr>
<td>Sum</td>
<td>Calculates the total (sum) of values in a field.</td>
</tr>
<tr>
<td>Avg</td>
<td>Calculates the average of values in a field.</td>
</tr>
<tr>
<td>Min</td>
<td>Finds the lowest value in a field.</td>
</tr>
<tr>
<td>Max</td>
<td>Finds the highest value in a field.</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of entries in a field, not including blank (Null) records.</td>
</tr>
<tr>
<td>StDev</td>
<td>Calculates the standard deviation of values in a field.</td>
</tr>
<tr>
<td>Var</td>
<td>Calculates the variance of values in a field.</td>
</tr>
<tr>
<td>First</td>
<td>Finds the values from the first record in a field.</td>
</tr>
<tr>
<td>Last</td>
<td>Finds the values from the last record in a field.</td>
</tr>
<tr>
<td>Expression</td>
<td>Tells Access that you want to create your own expression to calculate a field.</td>
</tr>
<tr>
<td>Where</td>
<td>Specifies criteria for a field to limit the records included in a calculation.</td>
</tr>
</tbody>
</table>
Lesson 6-8: Display Top or Bottom Values

If all you care about is the highest or lowest values produced by a query you can use the Top Values list in the Query Design toolbar to display only these records. For example, you could use the top Values list to display the ten largest or smallest orders in the Invoices table.

This lesson explains how you can use the Top Values list to display the top or bottom values in a query.

1. **Open the qryTourSales query in Design view.**
   Move to the next step and add the fields you want to see in your query.

2. **Double-click the TourName field in the tblTours field list, and the Cost and Smoker fields in the tblCustomerTours field list.**
   You want to create a query that retrieves the five most expensive non-smoking tours. First you need to add the non-smoking criteria to the query.

3. **Click the Smoker column's Criteria row and type False.**
   Next you have to sort the field that you want to display the top or bottom values. The Sort row works a little differently when you're using top or bottom values:
   - **Ascending:** Displays bottom values
   - **Descending:** Displays top values
   You want the query to display the top values in the Cost field, so…

If all you care about is the highest or lowest values produced by a query you can use the Top Values list in the Query Design toolbar to display only these records. For example, you could use the top Values list to display the ten largest or smallest orders in the Invoices table.

This lesson explains how you can use the Top Values list to display the top or bottom values in a query.

1. **Open the qryTourSales query in Design view.**
   Move to the next step and add the fields you want to see in your query.

2. **Double-click the TourName field in the tblTours field list, and the Cost and Smoker fields in the tblCustomerTours field list.**
   You want to create a query that retrieves the five most expensive non-smoking tours. First you need to add the non-smoking criteria to the query.

3. **Click the Smoker column's Criteria row and type False.**
   Next you have to sort the field that you want to display the top or bottom values. The Sort row works a little differently when you're using top or bottom values:
   - **Ascending:** Displays bottom values
   - **Descending:** Displays top values
   You want the query to display the top values in the Cost field, so…
4. **Click the Cost field’s Sort Row and select Descending.**
Next you have to use the Top Values list to specify the number of top values you want to be displayed in your query results.

5. **Click the Top Values list arrow on the toolbar and select 5.**
This will display the five most expensive tickets. You’re ready to run the query.

6. **Click the Run button on the toolbar.**
Access displays the results of the query, as shown in Figure 6-14.

7. **Click the View button on the toolbar to display the query in Design view.**
You can also use the Top Values feature to display the top or bottom values from a calculation. Let’s modify the query so that it calculates the total sales of non-smoking tour sales.

8. **Click the Totals button on the toolbar if necessary.**
The Totals row appears. You need to specify which field you want to use to group the query, which field(s) you want to be calculated, and which fields are used to limit the number of record displayed in the query.
You want to group records using the TourName field, and since its Total row already displays Group By you can leave it as it is. You will need to tweak the Total row for both the Cost and Smoker fields, however.

9. **Click the Cost column’s Total row, click the arrow and select Sum from the list.**
This will total the Cost field. The Smoker field is used as criteria to limit the records displayed to only non-smokers—it shouldn’t be included in the query results. Move on to the next step to tell Access this.

10. **Click the Smokers column’s Total row, click the arrow and select Where from the list.**
One more change before we run the query—this time instead of displaying the top values for the Cost field we want to display its bottom values.

11. **Click the Cost field’s Sort Row and select Ascending.**
This will summarize the five tours with the lowest sales (for non-smokers). Let’s see the results...

12. **Click the Run button on the toolbar.**
Access displays the results of the query, as shown in Figure 6-15.

13. **Save the query as qryBottomTours and then close the Query.**
This table explains what each of the options in the Top Values list does.

### Table 6-6: The Top Values List

<table>
<thead>
<tr>
<th>Do This…</th>
<th>…to Display This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click 5, 25, or 100 from the Top Values List.</td>
<td>The top 5, 25, or 100 records.</td>
</tr>
<tr>
<td>Type a number, such as 15 in the Top Values box.</td>
<td>The top 15 (or specified number of) records.</td>
</tr>
<tr>
<td>Type a percentage, such as 20%, in the Top Values box.</td>
<td>The top 20 percent (or specified percent) of records.</td>
</tr>
<tr>
<td>Click All from the Top Values list.</td>
<td>All of the records.</td>
</tr>
</tbody>
</table>

---

Quick Reference

To View Top or Bottom Values:
1. Display the query in **Design View**.
2. Click the first **Sort field** and select either:
   - **Ascending**: Displays bottom values.
   - **Descending**: Displays top values.
3. Select an option from the **Top Values list** on the toolbar.
Lesson 6-9: Parameter Queries

Getting tired of modifying a query every time you want to use a new criterion? A parameter query is your answer. A parameter query prompts the user for the query’s criteria. For example, you could create a Regional Sales query that would ask for the name of the state that you want filter by.

Creating a parameter query is easy. All you have to do is click the Criteria row for the field that you want to use a parameter query with and type a message, enclosed in [brackets] that you want Access to display when you run the query.

1. **Open the qryTourSales query in Design view.**
   As always, you need to add the field that you want to group data by onto the design grid. This time we want to create a query that summarizes total employee sales. Here are the fields that we will use in the query:

   2. **In the tblEmployees field list double-click the FirstName, LastName, and State fields and in the tblCustomerTours field list double-click the Cost and Date fields.**

   Next you need to tell the query that you want to group and summarize the query.

   3. **Click the Totals button on the toolbar.**

   The Totals row appears. You need to specify which field(s) you want to use to group the query, which field(s) you want to be calculated, and which fields are used to limit the number of record displayed in the query.
You want to group records using the FirstName, LastName, and State fields and find the total of the Cost field.

4. **Click the Cost column's Total row, click the \( \rightarrow \) arrow and select Sum from the list.**
   This will total the Cost field. We will use the Date field as criteria to limit the records to those that fall between two dates. Instead of entering a criteria expression with two fixed date values, such as Between 1/1/00 and 3/31/00, we will create two parameters that will prompt the user to enter the two date values each time they run the query.

5. **Click the Date column's Criteria row and type Between [Enter start date] and [Enter end date].**
   You’ve just created two parameters—the [Enter start date] parameter and the [Enter end date] parameter.
   Since the Date field is only being used as a criteria field you need to select the Where option from its Total row.

6. **Click the Date column's Total row, click the \( \rightarrow \) arrow and select Where from the list.**
   The Show box automatically turns off, indicating that the Date field will not appear in the query results.
   Let’s add one more parameter—one that prompts the user to enter the state where the tour was sold.

7. **Click the State column's Criteria row and type [Enter the state].**
   This will prompt the user to enter the name of the state.
   Since the State field is only being used as a criteria field you need to select the Where option from its Total row.

8. **Click the State column's Total row, click the \( \rightarrow \) arrow and select Where from the list.**
   Let’s test our parameter query.

9. **Click the Run button on the toolbar.**
   Access prompts you to enter the first parameters, as shown in Figure 6-17. You want to summarize records from Washington.

10. **Type WA and click OK.**
    Access prompts you for the next parameter—the start date.

11. **Type 1/1/00 and click OK.**
    Access prompts you for the last parameter—the end date.

12. **Type 6/30/00 and click OK.**
    Access displays the results of the parameter query, as shown in Figure 6-18.

13. **Save the query as qryParameter and then close the query.**

Some advanced Access developers use custom-made forms to provide parameter queries with their information. By binding a parameter to the controls on a form (such as [frmCustomers]![Name]) users can fill out one dialog box instead of having to fill out five or six pop-up dialog boxes.
Lesson 6-10: Finding Duplicate Records

The Find Duplicates Query Wizard helps you find records that have the same value in one or more fields. So when would you need to use a Find Duplicates Query? Here are a few scenarios:

- To search for duplicate values in an Orders table to find out which customers have placed more than one order.
- To search for duplicate values in several fields to search for data-entry errors. For example, if you and another user both accidentally entered the same customers into a table you could search for duplicate values in the LastName and FirstName fields to find and delete the duplicated records.

Access provides a wizard to make creating a query that finds duplicate information in a snap.

"Arrr-rrgh!" you shout as you realize that you and another co-worker have just entered the same customers into a database. Fortunately, you can find the duplicated records by using the Find Duplicates Query Wizard.

1. From the Database window, click the Queries icon in the Objects bar and click the New button.
   The New Query dialog box appears.
2. **Select the Find Duplicates Query Wizard and click OK.**
   The first step of the Find Duplicates Query Wizard appears, as shown in Figure 6-19. You need to choose the table or query that you want to sift through for duplicate records.

3. **Select the tblCustomers table and click Next.**
   Step two of the Find Duplicates Query Wizard appears, as shown in Figure 6-20. Here you tell Access which field or fields might contain the duplicate information. Since you are trying to find duplicate customers you decide to search the FirstName and LastName fields for duplicate values.

4. **Double-click the LastName and FirstName fields.**
   The LastName and FirstName fields appear in the selected fields list.

5. **Click Next.**
   The next step of the Duplicates Query Wizard appears. You can select any field (other than the ones you specified in Step 4) that you want to be displayed in the query. You decide to display the Address and City fields so that you can verify that the records are duplicates.

6. **Double-click the City and State fields. Click Next when you’re finished.**
   You’re finished! Well, almost. You have to give your query a name, or you can accept the default name Access gives the query.

7. **Click Finish.**
   Access saves the query with the name “Find duplicates for tblCustomers” and displays the results of the query, as shown in Figure 6-21.

8. **Close the query.**

**Quick Reference**

To Use the Find Duplicate Wizard:

1. From the Database window, click the Queries icon in the Objects bar and click the New button.

2. Select the Find Duplicates Query Wizard and click OK.

3. Double-click the field(s) that may contain the duplicate values and click Next.

4. Double-click any additional fields that you want to appear in the query results and click Next.

5. Click Finish.
Lesson 6-11: Finding Unmatched Records

The Find Unmatched Records Query Wizard helps you find the records in one table that do not have matching records in another table. Some scenarios when you might need to create such a query include:

- To find customers who have never placed an order.
- To find products that have never been purchased.
- To find “orphan” records. If you haven’t enforced referential integrity in your related tables, deleting a record in one table could leave one or more orphan records in a related table. For example, if you delete a customer record from a Customer table you may leave several unmatched records for that customer in an Order table.

In this lesson you will use the Find Unmatched Records Query Wizard to create a query to find customers who have never booked a tour.

1. **From the Database window, click the Queries icon in the Objects bar and click the New button.**
   
   The New Query dialog box appears.
2. **Select the Find Unmatched Records Query Wizard and click OK.**
   The first step of the Find Unmatched Records Query Wizard appears, as shown in Figure 6-22. You need to choose the table or query whose values you want to display in the query. Since you want to find customers without any tour packages, you would select the tblCustomers table.

3. **Select the tblCustomers table and click Next.**
   Step two of the Find Unmatched Records Query Wizard appears. Here you have to tell Access which table contains the related records.

4. **Select the tblCustomerTours table and click Next.**
   The third step of the Find Unmatched Records Query Wizard appears, as shown in Figure 6-23. Here you have to specify the related field to join the records in the first table to the records in the second table. Once you have selected the matching record in both tables, click the button to join the two tables.

5. **Verify that the CustomerID field is selected in both tables and click the button.**
   The Matching Field area displays the fields used to join the tables (CustomerID <=> CustomerID).

6. **Click Next.**
   Almost there! Now you have to specify which fields you want to see in the query.

7. **Double-click the LastName, FirstName, City, and State fields.**
   The LastName, FirstName, City, and State fields should all appear in the Select Fields list.

8. **Click Next.**
   You have to give your query a name—or you can accept the default name access gives the query.

9. **Click Finish.**
   Access saves the query with the name “Customers Without Matching Customer Tours” and displays the results of the query, as shown in Figure 6-24.

10. **Close the query.**

---

**Quick Reference**

**To Use the Find Unmatched Wizard:**

1. From the Database window, click the Queries icon in the Objects bar and click the New button.

2. Select the Find Unmatched Query Wizard and click OK.

3. Select the table whose values you want to display and click Next.

4. Select the table that contains the related records and click Next.

5. Specify the related fields that join the two tables then click the button to join the two tables and click Next.

6. Double-click any additional fields that you want to appear in the query results and click Next.

7. Click Finish.
Lesson 6-12: Crosstab Queries

There are many ways that queries can help you summarize and analyze all that information in your database. A crosstab query displays summarized information in a table format that makes it easy to analyze and compare data. Look at the information displayed in Figure 6-25—difficult to see the bottom line, isn’t it? Now look what happens when the same information is placed in a crosstab query, as shown in Figure 6-26. Which do you think is easier to understand?

You can create a crosstab query in Design view or by using the Crosstab Query Wizard. The Crosstab Query Wizard is usually much easier, but it does have some limitations:

- If you need to use more than one table or query in the crosstab query, you will first need to create a separate query that has the tables you want to use.
- You can’t specify any limiting criteria when using the Crosstab Query Wizard (of course you can always modify the crosstab query in Design view and add the criteria yourself).
In this lesson you will use the Crosstab Query Wizard to create a query that summarizes monthly ticket sales by tours.

1. **From the Database window, click the Queries icon in the Objects bar and click the New button.**
   The New Query dialog box appears.

2. **Select the Crosstab Query Wizard and click OK.**
   The first step of the Crosstab Query Wizard appears. You need to select the table or query that contains the values you want. For this exercise you will use the Tours by Query as the source for the crosstab query.

3. **Click the Queries option in the View section to display the queries in the database, select the qryToursByNames query and click Next.**
   The second step of the Crosstab Query Wizard is which field you want to use as the row headings for the crosstab. You want to use the TourName field as row headings.

4. **Double-click the TourName field and click Next.**
   The next step is determining which field you want to use as your column headings. You want to use the Date field as the column heading.

5. **Double-click the Date field.**
   Because you selected a date field using the Crosstab Query Wizard asks by which interval you want to group the dates: By date, month, quarter, or year. For this exercise you want the date column to group dates by months.

6. **Double-click the Month option.**
   Probably the most important step in the Crosstab Query Wizard is determining which field you want to calculate where columns and rows intersect and the type of calculation you want to use to summarize the fields.

7. **Select the Number of Tickets field from the Field list and the Sum option from the Functions list, as shown in Figure 6-27.**
   This will calculate the total number of tickets sold for each tour, grouped by month.

8. **Click Next.**
   You have to give your crosstab query a name.

9. **Type qryTicketsByDate and click Finish.**
   Access saves the query with the name “qryTicketsByDate” and displays the results of the query, as shown in Figure 6-26. Let’s modify the crosstab query and add some limiting criteria.

10. **Click the View button to display the crosstab query in Design view.**
    The crosstab query appears in Design view as shown in Figure 6-28. Notice the Crosstab row, which you use to determine if a field should be a column heading, row heading, or value.

11. **Double-click the First Class field in the qryToursByNames field list.**
    You only want to see tours for passengers without first class tickets.

12. **Click the First Class column’s Total row, click the arrow and select Where from the list. Click the First Class column’s Criteria row and type False.**

13. **Click the Run button on the toolbar.**
    Access displays the crosstab query, which only includes non-first class tickets.

14. **Close the query without saving your changes.**

### Quick Reference

**To Create a Crosstab Query:**

1. From the Database window, click the Queries icon in the Objects bar, and click the New button.
2. Select the Crosstab Query Wizard, and click OK.
3. Select the table or query you want to use and click OK.
4. Double-click the TourName field and click Next.
5. Double-click the Date field.
6. Select the field you want to use as the row heading and click Next.
7. Select the field you want to use as the column heading.
8. Double-click the Month option.
9. Click Next.
10. Type qryTicketsByDate and click Finish.
Lesson 6-13: Delete Queries

The most dangerous of all queries is a delete query, a query that deletes a whole bunch of records at a time. Once you have deleted records using a delete query, you cannot undo the results—the records are gone forever! Creating a Delete query is no different than creating a Select query—with one very important difference: While a Select query displays the records that match your criteria, a Delete query deletes those records. For this reason you should always preview the results of a Delete query in Datasheet view to see which records will be deleted.

If you want to delete records from multiple tables—for example a customer and all their orders—you need to do a few things first:

- Define relationships between the tables.
- Establish Referential Integrity for the join(s) between the tables and turn on the Cascade Delete Related Records option.

LeAnne Chang, one of North Shore Travel’s managers, decides to open her own competing travel agency across the street, and being the vindictive person she is, takes all her customers with her. In this lesson you will create a Delete query to delete all the tours sold by LeAnne Chang.

1. From the Database window, click the Queries icon in the Objects bar and click the New button.
   The New Query dialog box appears.

2. Select Design View and click OK.
   The Query design window and Show Tables dialog box both appear. You have to select the tables and/or queries you want to use in the Delete query.

3. Click the tblEmployees table and click Add.
   A field list for the tblEmployees table appears in the top half of the Query design window.
4. **Add the tblCustomerTours table and tblTours table to the query.**
   When you have finished adding the tables and/or queries you can close the Show Tables dialog box.

5. **Click Close.**
   If the tables are related, Access automatically connects their common fields with a join line. If the tables aren’t related, you will have to manually join them by dragging from one field list to the other matching field in the field list from the other table.
   You need to connect the tblEmployees table with the tblCustomerTours table.

6. **Click on EmployeeID field in the tblEmployees field list and drag and drop it onto the Employee field in the tblCustomerTours field list.**
   Next, you need to tell Access that this is a Delete query.

7. **Click the Query Type button arrow on the toolbar and select Delete Query from the list.**
   Access converts the Select query to a Delete query and displays the Delete row in the query design grid. Now you have to tell Access what you want to delete.

8. **Drag the asterisk (*) from the top of the tblCustomerTours field list into the design grid.**
   Notice that From appears in the Delete cell for the asterisk field, indicating that the records will be deleted from the tblCustomerTours table. Unless you want the Delete query to delete each and every record in the tblCustomerTours table, you will need to add some limiting criteria. You decide to use the last name Chang as the limiting criteria.

9. **Drag the LastName field from the top of the tblEmployees field list into the design grid.**
   This time Where appears in the Delete cell for the LastName field, indicating that the LastName field will be used as the criteria to select which records will be deleted from the tblCustomerTours table.

10. **Click the LastName column’s Criteria row and type Chang.**
    Access will add the “quotation marks” around the text string Chang for you. That’s all there is to creating a Delete query. Before you run a delete query you should always preview the results in Datasheet View.

   **NOTE:** Before you run a Delete query, you should always preview the results in Datasheet view first. Click the **View button** on the toolbar to display the Delete query in Datasheet View.

11. **Click the View button on the toolbar to preview the results of the Delete query in Datasheet view.**
    The Delete query displays the records belonging to LeAnne Chang that will be deleted upon your command. Switch back to Design view.

12. **Click the View button on the toolbar to return to Design view.**
    Okay, let’s run the Delete query and delete the selected records.

13. **Click the Run button on the toolbar.**
    Ever cautious Access asks if you really want the Delete query to delete the records.

14. **Click Yes.**
    Access silently deletes all 75 tour records for LeAnne Chang.

15. **Close the query without saving your changes and open the qryToursByName query.**
    Notice that all the tours for LeAnne Chang are gone.

16. **Close the qryToursByName query.**
Lesson 6-14: Append Queries

An append query takes a group of records from one or more tables or queries in your database and adds them to another existing table. Append queries are especially useful for importing information into a table. For example, you could use an Append query to import several dozen customer records from an Excel spreadsheet into an existing table. Of course you would have to know how to import the Excel spreadsheet first—and that’s another lesson in and of itself.

There are several rules that you must follow when using an Append query.

- The appended data must meet the data validation and referential integrity rules of the table it is being added to.
- The appended data must have its own unique primary key values. If the primary key field in the table to which the data is being added is an AutoNumber field, do not append that field—Access will generate new numbers for the new records.
- The type of data in the records you’re adding must match the type of data in the table to which you’re adding them.

In this lesson you will create an Append query to add a new group of tours to the tblCustomerTours table.

1. **From the Database window, click the Queries icon in the Objects bar and click the New button.**

The New Query dialog box appears.
Chapter Six: Working with Queries

2. Select **Design View** and click **OK**.
The Query design window and Show Tables dialog box both appear. You have to select the tables and/or queries you want to use in the Append query.

3. Click the **tblCaribbeanTours** table, click **Add** and then click **Close**.
Now you need to convert the Select query to an Append query. Here’s how:

4. **Select Query → Append Query from the menu.**
The Append dialog box appears, as shown in Figure 6-31. You have to tell the Append query where you want the results of the query to be added.

5. Select **tblCustomerTours** from the Table Name list and click **OK**.
The Append query will add the results of its query to the tblCustomerTours table. Notice an Append To row appears in the design grid. Now you have to specify the fields you want to append.

6. Double-click the **CustomerID**, **Employee**, and **TourID** fields in the **tblCaribbeanTours** field list.
Since the field names are the same in both tables, Access automatically fills in the Append To row with the names of the fields you’re appending records to. If some of the fields you’re appending have a different field name you will have to specify to which field they should be added from the Append To row.

7. Double-click the **No Tickets** field in the **tblCaribbeanTours** field list.
Since there isn’t a field named No Tickets in the tblCustomerTours table, Access doesn’t automatically fill in the Append To row. You will have to select the name of the field you want to append to.

8. **Click the No Tickets field’s Append To row and select Number of Tickets.**
This will append the fields from the No Tickets field in the tblCaribbeanTours table to the Number of Tickets field in the tblCustomerTours table. Move on to the next step and finish adding the remaining fields that you want to append.

9. Double-click the **Date**, **FirstClass**, **Smoker**, **Ship Via**, and **Cost** fields in the **tblCaribbeanTours** field list.

**NOTE:** As with any Action query you should always preview the results in Datasheet view first. Click the **View button** on the toolbar to display the results of the Append query in Datasheet view.

10. **Click the View button on the toolbar to preview the results of the Append query in Datasheet view.**
The Append query displays the records it will add or append to the tblCustomerTours table.

11. **Click the View button on the toolbar to return to Design view and click the Run button on the toolbar.**
Access asks you to confirm the addition of the records to the tblCustomerTours table.

12. **Click Yes.**
Access adds the records from the tblCaribbeanTours table to the tblCustomerTours table.

13. **Close the query without saving your changes and open the qryToursByName query.**
Notice the new tblCaribbeanTours records that have been added by the Append query.

14. **Close the Tours by Name query.**

---

**Quick Reference**

To Create an Append Query:

1. In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria.

2. Click the **Query Type button list** on the toolbar and select **Append Query**.

Or...

Select **Query → Append Query** from the menu.

---

**Other Ways to Create an Append Query:**

- Select **Query → Append Query** from the menu.
Lesson 6-15: Make-Table Queries

Like all queries, a make-table query asks a question of the information in one or more tables and then retrieves results. Instead of displaying the results however, a make-table query creates a new table with the results of the query. Make-table queries are useful for:

- Exporting a table to another database or application
- Creating a backup copy of a table
- Creating an archive table that stores old records
- Creating a table that includes information or fields from more than one table
Chapter Six: Working with Queries

In this lesson you will create a make-table query to create a table with information about all China tour records.

1. **Open the qryTourSales query in Design view.**
   First you need to add the fields that you want to include in your new table.

2. **Double-click the TourName field in the tblTours field list, the Number of Tickets, Date, and Cost fields in the tblCustomerTours field list, and the LastName and FirstName fields in the tblEmployees field list.**
   The make-table query will create a table with these fields. Next you need to specify any limiting criteria.

3. **Click the TourName column’s Criteria row and type China.**
   Access will add the “quotation marks” around the text string China for you. The make-table query will only include China tours when it creates the new table. Here’s how to change the query type to a Make-Table query:

4. **Click the Query Type button arrow and select Make Table Query from the list.**
   Access displays the Make Table dialog box, as shown in Figure 6-33. Here you need to tell Access the name of the new table.

5. **Type tblChinaTours in the Table Name box and click OK.**
   You’re ready to have the make-table query create the new table. Preview the results of the query first.

   **NOTE:** As with any Action query you should always preview the results in Datasheet view first. Click the View button on the toolbar to display the results of the make-table query in Datasheet view.

6. **Click the View button on the toolbar to preview the results of the make-table query in Datasheet view.**
   The Append query displays the records it will use to create the new tblChinaTours table.

7. **Click the View button on the toolbar to return to Design view and click the Run button on the toolbar.**
   Access asks you to confirm the creation of the tblChinaTours table.

8. **Click Yes.**
   Access creates the new tblChinaTours table based on the results of the make-table query.

9. **Close the query without saving your changes and open the tblChina table.**
   Verify the results of the make-table query, then…

10. **Close the tblChinaTours table.**

**Quick Reference**

**To Create a Make-Table Query:**
1. In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria.

2. **Click the Query Type button list on the toolbar and select Make Table Query from the menu.**

   **Or…**
   Select **Query → Make Table Query from the menu.**

3. **Click the OK button on the dropdown list and select a table from the list if you want to replace the existing one.**

4. **Click one of the following options:**
   - **Current Database:** If the table is in the currently open database.
   - **Another Database:** And type the name of the other database (including the path, if necessary).

5. **Click OK.**

6. **Click the View button on the toolbar to view the results of the query or the Run button on the toolbar to create the new table.**
**Lesson 6-16: Update Queries**

You can use an update query to change a pile of records at the same time. For example, you could create an update query to lower prices by 8% or to change the sales representative for all your clients in Oregon from Mr. Potter to George Bailey. Just like other action queries, you create an update query by first creating a select query and then converting the select query to an update query.

In this lesson you will create an update query to raise the prices of all trips to Europe by 10%.

1. **From the Database window, click the Queries icon in the Objects bar and click the New button.**
   
   The New Query dialog box appears.

2. **Select Design View and click OK.**
   
   The Query Design window and Show Tables dialog box both appear. You have to select the tables and/or queries you want to use in the update query.

3. **Double-click the tblTours table and click Close.**
   
   Now you need to convert the Select query to an Update query. Here’s how:

   ![Figure 6-36: An Update Query.](image)

   ![Figure 6-37: Access asks you to confirm the record update.](image)

   ![Figure 6-38: The Update query has updated the selected records and raised their price fields by 10%.](image)

You can use an update query to change a pile of records at the same time. For example, you could create an update query to lower prices by 8% or to change the sales representative for all your clients in Oregon from Mr. Potter to George Bailey. Just like other action queries, you create an update query by first creating a select query and then converting the select query to an update query.

In this lesson you will create an update query to raise the prices of all trips to Europe by 10%.
4. Click the **Query Type button arrow** and select **Update Query** from the list.

Access converts the Select query to an Update query. Notice an Update To row appears in the design grid. Now you have to specify the fields you want to update.

5. **Double-click the TourID, Normal Price, and First Class Price fields in the tblTours field list.**

The next step is a little bit tricky—you have to tell Access what fields to update and how to update them. You want to raise the price of both the Normal Price and First Class Price fields by 10%—you will have to write an expression (or formula) in the Update To rows of both fields to make this little bit of magic happen.

6. Click the **Normal Price column’s Update To row** and type **[Normal Price]+([Normal Price]*.1).**

So what does the confusing expression you entered actually mean? Let’s assume the Normal Price for a record is $100. The expression would then look something like this: $100 + ($100 * .1).

Access first calculates anything it sees in parenthesis, so it multiples $100 × 0.1 (or 10%) and comes up with $10. Access then adds this $10 to the Normal Price $10 + $10 and comes up with $110. Make a little more sense? Hope so—because you have to do the same thing to the First Class Price field.

7. Click the **First Class Price column’s Update To row** and type **[First Class Price]+([First Class Price]*.1).**

Next you need to specify any limiting criteria. You want to raise prices for only tours that are in Europe. Unfortunately, the only way to determine this is by looking at the values in the tblTours table. Here are all the European TourIDs: 1, 2, 3, and 9. You will have to create an OR statement in your query to make sure you get all of them.

8. Click the **TourID field’s Criteria row** and type **1.**

This will select the record whose TourID is 1, but what about the rest?

9. Press the **<↓>** (down arrow key) to select the **TourID field’s or Criteria row and type 2.**

This will select the records whose TourID is 2. Go to the next step and finish adding the rest of the OR criteria.

10. Press the **<↓>** (down arrow key) to select the **TourID field’s second or Criteria row, type 3, press the **<↓>** (down arrow key) to select the **TourID field’s second or Criteria row and type 9.**

Compare your query to the one in Figure 6-36. Look the same? Let’s run the update query.

11. **Click the Run button on the toolbar.**

Access asks about the updating the selected records, as shown in Figure 6-37.

12. **Click Yes.**

Access updates the selected records by raising both their Normal Price and First Class Price fields by 10%.

13. **Close the query without saving your changes and open the tblTours table.**

Notice the prices of four European tours have been increased by ten percent.

14. **Close the tblTours table.**
Chapter Six Review

Lesson Summary

A Quick Review

- **To Create a Query in Design View:** From the database window, click the Queries tab, click New, select Design View from the list and click OK. Select the table or query you want to use and click OK. Repeat as necessary for additional tables or queries you want to add to the query and click Close when you’re finished. Double-click the fields that you want to appear in the query or click and drag the fields onto the design grid. In the design grid, enter any desired search criteria for the field in the Criteria box and/or click the Sort box list arrow for the field and select a sort order. Click the Save button on the toolbar and give a name to the query.

Understanding the Different Types of Queries

- **The Types of Queries Are:**
  - Select Queries
  - Parameter Queries
  - Crosstab Queries
  - Make-Table Queries
  - Append Queries
  - Delete Queries
  - Update Queries
  - Union Queries

Creating a Multiple Table Query

- **To Create a Query in Design View:** From the database window, click the Queries tab, click New, select Design View from the list and click OK. Select the table or query you want to use and click OK. Repeat as necessary for additional tables or queries that you want to add to the query and click Close when you’re finished. If Access doesn’t automatically join the tables click the designated field in the first table and drag it to the related field in the second table. Repeat as necessary to connect all the tables. Double-click the fields that you want to appear in the query or click and drag the fields onto the design grid. In the design grid, enter any desired search criteria for the field in the Criteria box and/or click the Sort box list arrow for the field and select a sort order. Click the Save button on the toolbar and give a name to the query.

Creating a Calculated Field

- **To Create an Expression or Calculation in a Query:** Display the query in Design View. Click the Field Row of a blank column in the design grid, enter the field name for the calculated field followed by a : (colon) followed by the expression you want Access to calculate, using the proper syntax (you can use the Expression Builder to help you create this expression).
Working with Expressions and the Expression Builder

- **To Create an Expression with the Expression Builder:** Display the query in **Design View**. Click the Field Row of a blank column in the design grid, click the Build button on the toolbar, double-click the field you want to use in the calculation, click the button that corresponds to the calculation you want, and then click or type any other fields or values you want to use. Click **OK** when you're finished.

Using an IIf Function

- **To Create an IIf (IF...THEN) Function:** Display the query in **Design View**. Click the Field Row of a blank column in the design grid, enter the field name followed by a : (colon) and type the expression using the syntax `IIf(«expr», «truepart», «falsepart»)` (You can also use the Expression Builder to help you create the IIf expression.).

Summarizing Groups of Records

- **To Calculate or Summarize a Group of Records:** Display the query in **Design View** and, if necessary, click the Totals button on the toolbar. Move the field that you want to group data by onto the design grid and make sure Group By appears in that field's Total Row. Move the field that you want to perform calculations onto the design grid. Choose the type of calculation that you want for each field from the drop-down list in the Total row.

Display Top or Bottom Values

- **To View Top or Bottom Values:** Display the query in **Design View**, click the first Sort field and select either Ascending (displays bottom values) or Descending (displays top values). Select an option from the Top Values list on the toolbar.

Parameter Queries

- **To Create a Parameter Query:** Display the query in **Design View**, click the Criteria row for the field you want to use for your parameter criteria and enter the text of the prompt surrounded by square brackets [ ].

Finding Duplicate Records

- **To Use the Find Duplicate Wizard:** From the Database window, click the Queries icon in the Objects bar and click the New button. Select the Find Duplicates Query Wizard and click **OK**, select the field(s) that may contain the duplicate values and click Next. Double-click any additional fields that you want to appear in the query results, click Next and then click Finish.

Finding Unmatched Records

- **To Use the Find Unmatched Wizard:** From the Database window, click the Queries icon in the Objects bar and click the New button. Select the Find Duplicates Query Wizard and click **OK**, select the table whose values you want to display and click Next. Select the table that contains the related records, click Next, specify the related fields that join the two tables then click the button to join the two tables and click Next. Double-click any additional fields that you want to appear in the query results, click Next, and then click Finish.
Crosstab Queries

- **To Create a Crosstab Query** From the Database window, click the **Queries** icon in the Objects bar and click the **New** button, then select the **Crosstab Query Wizard** and click **OK**. Select the table or query you want to use in the crosstab query and click **OK**. Select the field you want to use as the column headings, click **Next**, select the field you want to use as the row headings and click **Next**. Select the field you want to use as the row heading, click **Next**, type a name for the crosstab query and click **Finish**.

Delete Queries

- **To Create a Delete Query:** In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria. Click the **Query Type** button list on the toolbar and select **Delete Query** or select **Query → Delete Query** from the menu. Click the **View** button to view the results of the delete query. If you're satisfied that the appropriate records will be deleted, click the **Run** button on the toolbar to delete the records.

Append Queries

- **To Create an Append Query:** In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria. Click the **Query Type** button list on the toolbar and select **Append Query** or select **Query → Append Query** from the menu. Select the table to which you want to add the records from the drop-down list and select one of the following options: Current Database (if the table is in the currently open database) or Another Database, and type the name of the other database (including the path, if necessary). Click **OK** and click the **View** button on the toolbar to view the results of the query or the **Run** button on the toolbar to append the records.

Make-Table Queries

- **To Create a Make-Table Query:** In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria. Click the **Query Type** button list on the toolbar and select **Make-Table Query** or select **Query → Make Table Query** from the menu. Type the name of the table you want to create, or click the drop-down list and select a table from the list if you want to replace the existing one. Click one of the following options: Current Database (if the table is in the currently open database) or Another Database, and type the name of the other database (including the path, if necessary). Click **OK**. Click the **View** button on the toolbar to view the results of the query or the **Run** button on the toolbar to create the new table.

Update Queries

- **To Create an Update Query:** In **Query Design View** create a select query, including any tables, fields, calculated fields, and criteria. Click the **Query Type** button list on the toolbar and select **Append Query** or select **Query → Update Query** from the menu. Enter an expression to update the selected field and enter any criteria, if needed, to select which records should be updated. Click the **View** button to view the results of the update query. If you're satisfied that the appropriate records will be updated, click the **Run** button on the toolbar to update the records.
Chapter Six: Working with Queries

Quiz

1. Which of the following criterion is NOT written using the proper syntax?
   A. "Harris"
   B. Between 1/1/2000 and 12/31/2000
   C. NO VALUE
   D. <500

2. Which of the following types of queries are action queries? (Select all that apply.)
   A. Parameter queries.
   B. Append queries.
   C. Update queries.
   D. Crosstab queries.

3. Which of the following expressions is NOT written in the correct syntax?
   A. [Order Total]*[Tax Rate]
   B. "Order Total"*0.1
   C. [tblCustomerTours]![Cost]*[tblEmployees]![Commission]
   D. 100+10

4. If you are having trouble remembering how to write expressions using the correct syntax, you can use the Expression Builder to help you create the expression. (True or False?)

5. Rebate: IIf([Age]>65,"Senior","Adult") This expression is an example of:
   A. Something I learned back in high school algebra and thought I would never see again.
   B. A financial expression.
   C. Something that belongs in a Microsoft Excel book.
   D. A conditional expression.

6. A query prompts a user for a date and then displays only records that contain the specified date. Which type of query is this?
   A. A parameter query.
   B. A crosstab query.
   C. An action query.
   D. An update query.

7. You must create a report if you want to calculate totals for a group of records, as queries can’t perform this task. (True or False?)

8. A query summarizes information in a grid, organized by regions and months. Which type of query is this?
   A. A parameter query.
   B. A crosstab query.
   C. An action query.
   D. An update query.
9. Your company finally agreed to buy you a nifty 3COM Palm palmtop. Now you want to extract your clients from the company’s database and put them into a separate table that you can export to your Palm. Which type of query could help you accomplish this task?
   A. A parameter query.
   B. A crosstab query.
   C. An update query.
   D. A make-table query.

10. If you are creating a crosstab query, what must the table you are querying contain?
   A. At least one text field.
   B. At least one number field.
   C. More than 100 records.
   D. Lots of confusing information.

11. How can you add a table to the Query Design window?
   A. Select Edit → Add Table from the menu.
   B. Click the Show Table button on the toolbar.
   C. Select the table from the Table list on the toolbar.
   D. Select Tools → Add Table from the menu.

12. You want a query to calculate the total sales for your employees. How can you do this from the Query Design window?
   A. Click the Totals button on the toolbar. In the Total row select “Group By” under the Employee field and “Sum” under the Sales field.
   B. Click in the Sales field and click the AutoSum button on the toolbar.
   C. You need to export this information to Microsoft Excel and calculate it there.
   D. Click in the Sales field and select Tools → AutoSum from the menu.

### Homework

1. Open the Homework database.
2. Using the Customers and Insurance Claims tables, create a multi-table query that counts the total number of claims, grouped by the State field. **Hint:** Use the Count function on any field in the Insurance Claims table.
3. Sort the results of the query by date.
4. Add criteria to the query that excludes records from the state of Wisconsin (WI).
5. Change the Select query to a Delete query and delete all records from the state of Wisconsin (WI).
6. Change the Delete query back into a Select query. Remove the current criteria and add parameter criteria that asks for the beginning and ending date.
7. Create a calculated field that combines the FirstName and LastName fields.
8. Save the query as “Homework Query”.
Quiz Answers

1. C.
2. B and C. Append queries and Update queries are both action queries.
3. B. Fields should be enclosed in [ ] brackets, not "" quotation marks.
4. True. The Expression Builder helps you create expressions in your queries (and in forms, reports, and macros too!).
5. D. The IIf function is a conditional expression that evaluates a field for a specified condition and returns one value if the condition is true and another value if the condition is false.
6. A. A parameter query prompts the user for information.
7. False. Queries can calculate groups of records—just click the Totals button on the toolbar and choose the type of calculation that you want for each field from the drop-down list in the Total row.
8. B. A query that summarizes information in a grid, organized by columns and rows sounds an awful lot like a crosstab query.
9. D. Since a Make-Table query creates a new table with the results of the query, this would be your best bet.
10. B. A crosstab query must contain at least one number field.
11. B. You can add a table to the Query Design window by clicking the Show Table button on the toolbar.
12. A.
Chapter Seven: Working with Forms

Chapter Objectives:

- Create and modify a form
- Add, delete, move, and size controls
- Change a form’s tab order
- Work with control properties and settings
- Work with form properties and settings
- Use the Control Wizard to create interactive forms
- Create subforms to display information from a one-to-many relationship

Chapter Task: Create and work with several types of forms

A form created in Access is similar to the ordinary paper forms that you fill out with a pen or pencil—only you don’t have to worry about trying to read poor penmanship. In Access, forms provide an easy way to enter and view data in a table. Here are just a few examples of how forms make working with data easier:

- **Easier to View and Use:** Instead of scrolling back and forth in a table’s Datasheet, a form lets you focus on one record at a time.
- **See Data any Way You Want:** You can design forms to present information any way you like.
- **Combine Data from Linked Tables:** One form can display data from several related tables or queries—and your users will never know that they are working with two sources!

And that’s just for starters. No doubt about it—forms make your database easier to use. Just like a Windows dialog box (which is really what a form is), Access forms can include fill-in-the-blank fields, check boxes, drop-down lists, and more.

This chapter explains everything you have ever wanted to know about forms—and maybe a few things you didn’t want to know.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.
Lesson 7-1: Creating a Form with AutoForm

The fastest and easiest way to create a form in Access is with one of the AutoForm Wizards. The AutoForm Wizard automatically creates a form by arranging all the fields from a table or query.

The AutoForm Wizards are fast and easy to use but limited: There are only three AutoForm Wizards and each can only create one type of form, as shown in Table 7-1: Available Form Layouts. Of course, you can always modify a form created by an AutoForm Wizard.

In this lesson you will learn how to create a form using an AutoForm Wizard.

1. **Open the Lesson 7 database.**

   First you need to go to the Forms tab in the Database window.
2. Click the **Forms icon** in the Objects bar then click the **New button**.

The New Form dialog box appears, as shown in Figure 7-1. You create a form with the AutoForm Wizard by selecting one of the three AutoForm Wizards…

3. **Select AutoForm: Columnar from the list.**

… and the table or query you want to use in your form.

4. Click the **Choose the table or query where the object’s data comes from:** arrow and select *qryCustomers* from the list.

That's all the information the AutoForm Wizard needs to create your form.

5. **Click OK to create the columnar form.**

Access takes all the fields in the *qryCustomers* query, arranges them, and creates a report similar to the one shown in Figure 7-2.

6. **Close the form without saving your changes.**

AutoForm Wizards forms aren't really very pretty to look at but they can give you a good start at creating the form you really want since it's a lot easier to modify an existing form than it is to create one from scratch.

---

**Table 7-1: Available Form Layouts**

<table>
<thead>
<tr>
<th>Form Layout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Columnar</strong></td>
<td>Only one record is displayed at a time. Data for each record is displayed vertically. Technically speaking, Columnar form's Default View property is set to Single.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Tabular</strong></td>
<td>Several records are displayed at once. Data for the records is displayed horizontally. Technically speaking, Columnar form's Default View property is set to Continuous.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Datasheet</strong></td>
<td>Displays the records in Datasheet view (several records at the same time). Technically speaking, Columnar form's Default View property is set to Datasheet.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Create a Form with AutoForm:

1. From the Database window, click the **Forms icon** in the Objects bar and click the **New button**.
2. Select one of the following: **AutoForm: Columnar**
3. **AutoForm: Tabular**
4. **AutoForm: Datasheet**.
5. Click the **table or query** you want to use for the form from the **drop-down list**.
6. Click **OK**.
Lesson 7-2: Modifying a Form

After you create a form, you may decide to modify it to add additional features or make it easier to use. For example, you might want to add or delete a field, or change the location of a field on the form. You modify a form in Design View, which you can get to in two different ways:

- **From the database window**: Click the Forms tab to list the forms in the database. Click on the form you want to modify and click the Design button.

- **From a form window**: Click the View button on the toolbar or select View → Form Design from the menu.

This lesson will introduce you to Form Design View.

1. **From the Database window**, click the **Forms icon** in the Objects bar if it isn’t already selected, then select the **frmCustomers form** and click the **Design button**.

   The frmCustomers form appears in Design View, as shown in Figure 7-3.

Don’t let Design View scare you. It looks more complicated than it really is. In some ways, Form Design View is similar to many Paint programs. Think of the form as your canvas and the Toolbox and Field List as the paint brushes you use to add fields, text boxes, and buttons to the form.

Any graphic object that appears on forms and reports are called controls. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls. You add controls to a form by clicking the control you want to use and then dragging it on the form.
Table 7-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Objects</td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle around all controls you want to select.</td>
</tr>
<tr>
<td>Control Wizard</td>
<td>Click to use Control Wizards when you add controls to your form.</td>
</tr>
<tr>
<td>Label</td>
<td>Creates a static text label that is the same for every record, such as a heading. Most controls already have a text label attached.</td>
</tr>
<tr>
<td>Text Box</td>
<td>Creates a text box that displays information from a table and query. You can also use text boxes to enter text.</td>
</tr>
<tr>
<td>Option Group</td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box.</td>
</tr>
<tr>
<td>Toggle Button</td>
<td>Creates a toggled button that allows you to display and enter data from a Yes/No field.</td>
</tr>
<tr>
<td>Option Button</td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with a Group Box control.</td>
</tr>
<tr>
<td>Check Box</td>
<td>Creates a box that is checked or unchecked. Use to enter data from a Yes/No field.</td>
</tr>
<tr>
<td>Combo Box</td>
<td>Creates a drop-down box that lets the user enter text or select an item from a list of options.</td>
</tr>
<tr>
<td>List Box</td>
<td>Creates a box that lets the user select an item from a list of options.</td>
</tr>
<tr>
<td>Command Button</td>
<td>Creates a button that runs a macro or Visual Basic function.</td>
</tr>
<tr>
<td>Image</td>
<td>Displays a picture or graphic file that you specify.</td>
</tr>
<tr>
<td>Unbound Object Frame</td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td>Bound Object Frame</td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database. Normally used with OLE Object fields.</td>
</tr>
<tr>
<td>Page Break</td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td>Tab Control</td>
<td>Enables you to create tabs (like the ones found in some dialog boxes) to include more than one page of controls on the form.</td>
</tr>
<tr>
<td>Subform/Subreport</td>
<td>Inserts another form within the main form. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td>Line</td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td>More Controls</td>
<td>Click to display other OLE objects.</td>
</tr>
</tbody>
</table>

Quick Reference

To Modify a Form:
1. From the Database window, click the Forms icon in the Objects bar.
2. Click the form you want to modify and click Design. Or...
   Open the form and click the View button on the toolbar.
Lesson 7-3: Adding and Deleting Fields

Once you have created a form, you can delete unnecessary fields or add more fields to display additional information. You add fields to a form by dragging the fields from the Field List onto the form. The Field List lists all the fields from the table or query you used to create the form.

In this lesson you will modify an existing form by adding and deleting fields.

1. Make sure you have the frmCustomers form open in Design View.
   First you click the control you want to delete.
2. **Click the DOB text box to select it.**
   Handles (■) appear around the control, indicating that it is selected.

   **NOTE:** Selecting a label will select only the label. Selecting a text box will select both the text box and the corresponding label.

3. **Press the `<Delete>` key to delete the DOB text box.**
   Poo? The DOB text box disappears without any fuss.

   So much for deleting fields. Here’s how to add a field:

4. **If the Field List isn’t displayed, click the Field List button on the toolbar.**
   The Field List displays all the fields from the table or query you used to create the form—although you will usually have to scroll down the Field List to find the field that you want. Once the Field List is displayed you can click and drag the field you want to add to the location that you want the field to appear on your form.

   Move on to the next step and add the DOB field you had previously deleted from the form.

5. **Scroll down the Field List until you find the DOB field. Click and drag the DOB field just above the Phone field, as shown in Figure 7-5, then release the mouse button.**
   The DOB field appears above the Phone field, as shown in Figure 7-6. Don’t worry if the DOB field isn’t positioned perfectly—you’ll learn how to move controls in the next lesson.

   See how your form looks in Form view.

6. **Click the View button on the toolbar to display the form in Form view.**
   Compare your form with the one in Figure 7-6.

7. **Select Save As from the File menu and save the form as frmFirstForm.**

---

**Quick Reference**

**To Add a Field to a Form:**
1. Display the form in *Design view* and click the Field List button on the toolbar if necessary.
2. Find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the form.

**To Delete a Field or Control:**
1. Click the field or control to select it.
2. Press `<Delete>`. 

**Field List button**

Other Ways to Display the Field List:
- Select View → Field List from the menu.
Lesson 7-4: Moving and Sizing Controls

It's easy to change the location and size of a control on a form. Moving a control allows you to change the order that information appears on the form. When you size a control, you increase or decrease the amount of information the control can display. Once you have selected a control on a form, sizing handles appear around the edges of the control. Now you can drag the form's sizing handles to adjust the size of the control or move the control to a new location on the form.

This lesson will give you some experience moving and sizing the controls on the form you created in the previous lesson.

1. **Make sure that you have the frmFirstForm form open in Design View.**
   You need to select a control before you can move or size it.

2. **Click the Phone text box to select it.**
   Most controls have a corresponding label.

3. **Position the pointer on any border of the Phone text box (but not over a sizing handle) until it changes to a .**
   Click and drag the border of a control to move both the control and its label.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a control. Move the pointer very slowly and wait until it turns into a control before you try to move the control.

   It's easy to change the location and size of a control on a form. Moving a control allows you to change the order that information appears on the form. When you size a control, you increase or decrease the amount of information the control can display. Once you have selected a control on a form, sizing handles appear around the edges of the control. Now you can drag the form's sizing handles to adjust the size of the control or move the control to a new location on the form.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a control. Move the pointer very slowly and wait until it turns into a control before you try to move the control.
4. Click and hold down the mouse button while the pointer is still over the border of the Phone text box. Drag the field directly to the left of the FirstName text box and directly above the SSN text box, as shown in Figure 7-7, then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a form or report—any shapes, lines, pictures, or text boxes. Sometimes, you may want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. To move the control, simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

5. With the Phone field still selected, hold down the <Ctrl> + ← (left arrow) key.

The Phone field moves to the left a smidgen. Go to the next step and try moving the DOB field.

6. Follow the procedure you learned in Step 5 and move the DOB text box directly to the left of the LastName text box and directly above the Phone text box.

Don’t worry if the DOB field isn’t the same size or aligned with the other controls—we’ll fix that in a minute.

Notice that the DOB text box moves with its label control. You can move labels and control, independently of one another by dragging it by their upper-left sizing handle.

7. Position the pointer over the upper-left sizing handle of the DOB label until it changes to a .

When the mouse pointer changes to a , it means that you can drag and drop the text box or label independently of one another.

NOTE: Most controls have a corresponding label, as shown in Figure 7-8. Make sure that you position the mouse over the DOB label and not the DOB text box.

8. Click and hold down the mouse button while the pointer is still over the upper-left sizing handle of the DOB label. Drag the DOB label so that the DOB label is left-aligned with the Phone label below it.

Enough about moving controls—here’s how to change their size.

When you select a control sizing handles appear around its edge. You can use these sizing handles to change the size and proportions of the selected control. Move on to the next step to see how we can reduce the size of the selected DOB label.

9. With the control still selected, position the pointer over the middle-right sizing handle until it changes to a . Click and hold down the mouse button and drag down and to the right until the label is the same width as the other labels on the form, then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it.

10. Click the DOB text box. Follow the procedure you learned in Step 10 and resize the DOB text box so that it is the same width as the other text boxes in the form.

That’s all there is to moving and sizing controls on a form.

11. Click the Save button on the Form Design toolbar to save your changes.

Quick Reference

To Resize a Control:
1. Click the control to select it.
2. Click one of the control’s sizing handles and drag until the control reaches the desired size.

To Move a Control:
- Click and drag the control to the desired location. Release the mouse button to drop the control.

To Move a Text Box or Text Label Independently of Each Other:
- Position the pointer over the upper-left sizing handle of the control until it changes to a , then click and drag the control.
Lesson 7-5: Changing the Tab Order

If you add, remove, or move fields on a form, you’ll want to change the form’s tab order. A form’s tab order determines the order in which you advance from one field to the next when you press <Tab>. The order of the fields when a form is first created determines the initial tab order. Even when you reposition the fields on a form the form’s tab order remains the same. For example, the Tab order shown in Figure 7-9 is from when the form was originally created. Because you have rearranged several controls, the tab order no longer reflects the order in which the fields appear on the form, as shown in Figure 7-10. This isn’t really a big problem, since it’s easy to change the tab order.

To change the tab order for a form select View → Tab Order from the menu. The Tab Order dialog box will appear, as shown in Figure 7-9. From here all you have to do is click and drag the field in the order you want. Or you can click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

1. **Make sure that you have the frmFirstForm form open.**
   First let’s see the current tab order of the frmFirst form.
2. **Switch to Form view by clicking the View button on the Form Design toolbar.**
   Go to the next step and see what happens when you try tabbing through the fields on the form.

3. **Press the <Tab> key several times.**
   When you press the <Tab> key the cursor jumps from the CustomerID field to the LastName field to the… Phone field? The tab order for the frmFirstForm form was determined when the form was created. You may have moved the Phone name field in the previous lesson, but its position in the tab order hasn’t changed.

   You can view and change the tab order by opening the Tab Order dialog box. First you need to be in Design View.

4. **Click the View button on the Form Design toolbar to switch to Design View.**
   Here’s how to display the Tab Order dialog box.

5. **Select View → Tab Order from the menu.**
   The Tab Order dialog box appears, as shown in Figure 7-9. The order of the fields in the list is the order in which you will advance from one field to the next when you press the <Tab> key. There are a couple of ways to change the tab order. The fast and easy way is to click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

   **NOTE:** The initial tab order of a form and the Auto Order option both create a tab order from left-to-right, top-to-bottom.

6. **Click the Auto Order button.**
   Access looks at the order in which fields appear on the form and adjusts the tab order accordingly.

   Sometimes the tab order may not be intuitive for data entry and you may want to manually change it. For example, you may want to modify the tab order so that the address, city, state, and zip code fields are together. Here’s how to manually change a field’s position in the tab order.

7. **Click the City row selector in the Custom Order list.**
   Now that you have selected the City row you can change its order by dragging it to a new location in the list.

8. **Drag the City row until it is below the Address row, then release the mouse button, as shown in Figure 7-11.**
   Move on to the next step and finish arranging the fields in the tab order.

9. **Drag the State row below the Address row and drag the ZipCode row below the State row.**
   You’re finished changing the tab order for the frmFirstForm form.

10. **Click OK to close the Tab Order dialog box.**
    Let’s test the new tab order.

11. **Switch to Form view by clicking the View button on the Form Design toolbar.** Press the <Tab> key several times and notice the order in which the cursor moves from field to field.
    You’ve finished this lesson so…

12. **Save your changes and then close the frmFirstForm form.**
Lesson 7-6: Working with Control Properties

Every control on a form—every text box, every label, and every check box—has a set of properties that you can modify. A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, the properties of a house would be its color, square footage, and shape. A property for a field on a form might be the number of decimal places displayed and the default value for the field. Because you can almost always change an object’s properties, you can think of them as the object’s settings.

Different types of controls have different properties. For example, label controls have a Caption property that determines the text that is displayed in the label, while text box controls have a Control Source property that determines which field is displayed in the control. Most controls have several dozen different properties or settings. Fortunately, Access organizes these properties into different categories, as shown in Table 7-3: Tabs in the Properties Dialog Box.

There are several ways to view the properties for any object:

- Right-click the control and select Properties from the shortcut menu.
- Select the control and click the Properties button on the toolbar.
- Select the control and select View → Properties from the menu.

This lesson explains how to view and change a control’s properties.

1. **Open the frmCustomers form in Design View.**

Here’s one way to view the properties for a control:
2. Select the **LastName text box control** and display its properties by clicking the **Properties button** on the Form Design toolbar.

   The Properties dialog box appears and displays the properties for the LastName text box control, as shown in Figure 7-12. To change a property simply find and click the appropriate property box and make the changes. Some properties boxes will display one of the following buttons when clicked:
   - ![ ] Click to display a list of options to change the settings for selected property.
   - ![ ] Click to invoke a Wizard or display a dialog box that you use to change the settings for selected property.

   Move on to the next step and we’ll try changing one of the LastName text box control’s properties.

3. **Click the Format tab** if necessary, then find and click in the **Back Style box**, click its **Down Arrow** and select **Transparent**.
   The back of the LastName text box control becomes transparent and displays the gray background of the underlying form.

   **NOTE:** Most controls have dozens and dozens of properties. You will often have to click the appropriate tab and then do some scrolling to find the property box that you’re looking for.

   The transparent Back Style property of the LastName text box control looks out of place, so let’s change it back.

4. **Change the Back Style property of the LastName text box control back to Normal.**
   Once the Properties dialog box is open you can simply click any control to display its properties.

5. **Click the LastName label (NOT the LastName text box.)**
   The Properties dialog box now displays the properties for the LastName label. You can tell which control’s properties are being displayed by looking at the Title bar of the Properties dialog box.

6. **Close the Properties dialog box.**

---

### Table 7-3: Tabs in the Properties Dialog Box

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Properties that determine the object’s appearance, such as color, text formatting, line and border color/thickness, and special effects. The purpose of many Formatting properties should be pretty obvious. For example, Font Size determines the font size of the control.</td>
</tr>
<tr>
<td>Data</td>
<td>Properties that determine where a control get its data, its default value (if any), and data validation rules for the control.</td>
</tr>
<tr>
<td>Event</td>
<td>Actions to which you can assign a macro or Visual Basic procedure. For example, clicking a button or entering information in a particular field could trigger a macro to run.</td>
</tr>
<tr>
<td>Other</td>
<td>Miscellaneous but important properties, such as the name of the control, if tabbing to the control is allowed, and if a message should appear in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>All</td>
<td>Displays all the properties for the control.</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Display the Properties for any Control:**
1. Display the form in **Design View**.
2. Select the control and click the **Properties button** on the toolbar.
   Or...
   Right-click the control and select **Properties** from the shortcut menu.
   Or...
   Select the control and select **View → Properties** from the menu.
Lesson 7-7: Control Property Reference

Every control on a form or report has dozens of different control properties or settings—so how do you keep them all straight? Here’s how—this lesson is really a cheat sheet that you can use whenever you’re not sure what exactly a particular control property is or does. The more important properties are marked with a ★.

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption for a form or text label.</td>
</tr>
<tr>
<td>Format ★</td>
<td>Format</td>
<td>Customizes the way numbers, dates, times, and text are displayed and printed.</td>
</tr>
<tr>
<td>Decimal Places ★</td>
<td>Format</td>
<td>Determines the number of decimal places displayed.</td>
</tr>
<tr>
<td>Visible ★</td>
<td>Format</td>
<td>Used to show or hide a control. Useful if you want to use information on the form without it being visible. For example, you could use the value in a hidden control as the criteria for a query.</td>
</tr>
<tr>
<td>Display When</td>
<td>Format</td>
<td>Specify if you want a section or control to appear always, or only when it is displayed on-screen or printed.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Format</td>
<td>Determines whether scroll bars appear in the control.</td>
</tr>
<tr>
<td>Left ★</td>
<td>Format</td>
<td>The horizontal position of the control.</td>
</tr>
<tr>
<td>Top ★</td>
<td>Format</td>
<td>The vertical position of the control.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>The width of a control.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>The height of a control.</td>
</tr>
<tr>
<td>Back Style</td>
<td>Format</td>
<td>Determines whether a control is or is not transparent.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Format</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Format</td>
<td>Applies a 3-D effect to a control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Format</td>
<td>Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Format</td>
<td>Determines the color of a control’s border. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Format</td>
<td>Determines the width of a control’s border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Format</td>
<td>Determines the color of text in a control or the fill color of an object. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Format</td>
<td>Determines the font used in a control (such as Arial or Times New Roman.)</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Format</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td>Property</td>
<td>Tab</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Format</td>
<td>Specify if you want the text in a control to appear in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Format</td>
<td>Specify if you want the text in a control to be underlined.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Format</td>
<td>Specify how text should be aligned in a control.</td>
</tr>
<tr>
<td>Control Source</td>
<td>Data</td>
<td>Specify the data that appears in the control.</td>
</tr>
<tr>
<td>Input Mask</td>
<td>Data</td>
<td>Limits the amount and type of information that can be entered in a field, such as (<em><strong>)</strong></em>-______ for a phone number. Click the button to create an input mask using the Input Mask Wizard.</td>
</tr>
<tr>
<td>Default Value</td>
<td>Data</td>
<td>A value that is automatically entered in this field for new records.</td>
</tr>
<tr>
<td>Validation Rule</td>
<td>Data</td>
<td>Enter an expression that is evaluated when data in the field is added or changed.</td>
</tr>
<tr>
<td>Validation Text</td>
<td>Data</td>
<td>Enter a message that is displayed when data doesn't meet the Validation Rule property.</td>
</tr>
<tr>
<td>Locked</td>
<td>Data</td>
<td>Specify whether changes can be made to a field’s data.</td>
</tr>
<tr>
<td>Events Tab</td>
<td>Events</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Name</td>
<td>Other</td>
<td>The name of the control that identifies it in expressions, macros, and Visual Basic procedures.</td>
</tr>
<tr>
<td>Status Bar Text</td>
<td>Other</td>
<td>Specify a message to display in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Specify if you want users to be able to tab to the control.</td>
</tr>
<tr>
<td>Enter Key Behavior</td>
<td>Other</td>
<td>Determines if pressing the &lt;Enter&gt; key adds a new line of text in a control or if it moves to the next field.</td>
</tr>
<tr>
<td>Allow AutoCorrect</td>
<td>Other</td>
<td>Determines if AutoCorrect (i.e. teh → the) is used in a control.</td>
</tr>
<tr>
<td>AutoTab</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field occurs when the last character permitted by a text box control’s input mask is entered.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field.</td>
</tr>
<tr>
<td>Tab Index</td>
<td>Other</td>
<td>Determines the tab order.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specify a user-created shortcut menu that appears when the control is right-clicked.</td>
</tr>
<tr>
<td>ControlTip Message</td>
<td>Other</td>
<td>Specify a brief message that appears when a user points at the control for a couple of seconds.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specify an identifier number for a user-created help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Extra, user-defined information that is stored in the object.</td>
</tr>
</tbody>
</table>
Lesson 7-8: Working with Form Properties

In the previous few lessons, you’ve been learning how to view and change the properties for form controls. In this lesson you will learn how to view and change the properties and settings of the form itself. That’s right—just like controls, forms also have their own set of properties that you can view and manipulate. So why would you want to change a form’s properties? Modifying a form’s properties can be especially important if you are creating a database that will be used by novice users. For example, by modifying a form’s properties you can:

• Allow users to edit existing records in a table or query—but not add any additional records.
• Display one record at a time on each form, or display many records at once.
• Determine the size and location of the form.

To view the properties for a form or report, simply double-click the Form Selector, as shown in Figure 7-13. In this lesson you will learn how to work with a form’s properties.

1. **Open the frmCustomers form in Form View.**
   In its current state, the frmCustomers form displays one record at a time and has a rather confusing caption in the title bar: frmCustomers. These are form properties that you can change. You must be in Design View in order to view and change a form’s properties.

2. **Click the View button on the toolbar to switch to Design View.**
   To view the properties for a form, double-click the Form Selector, as shown in Figure 7-13. Move on to the next step and try it!

3. **Double-click the Form Selector.**
   Microsoft Access displays the properties for the form. First, let’s give the frmCustomers title bar a more descriptive name.

---

**Figure 7-13**

The Form Selector is the key to selecting a form and displaying its properties.

[Image of Form Selector]
Chapter Seven: Working with Forms

4. **Click the Format tab if necessary, click in the Caption box and replace its text with Customers.**

   One of the most important form properties is the Default View property, which determines how many records a form can display at once. Let’s take a closer look at this property…

5. **Click the Format tab, click the Default View box and click the Down Arrow.**

   You have three options. They are:
   - **Single Form:** Displays one record at a time on a form.
   - **Continuous Form:** Displays multiple records on a form. The main difference between a Datasheet and a Continuous Form is Continuous Forms can be customized.
   - **Datasheet:** Displays multiple records in a table, using one line per record. Tables and queries display information inDatasheets.
   - **PivotTable:** Dynamically analyzes information and summarizes it into a datasheet-like table.

6. **Select Datasheet from the list.**

   That’s enough changes for now.

7. **Close the Properties dialog box.**

   Let’s see how the form looks with its new properties.

8. **Click the View button Down Arrow on the toolbar and select Form View from the list to display the form in Form View.**

   Access displays the frmCustomers form in Form View. Notice that the form now appears as a Datasheet and has a new caption in the title bar.

9. **Close the frmCustomers form without saving any changes.**

   You’re probably wondering how you are going to get a handle on all these form properties. Don’t worry—you will probably never touch ninety-five percent of them. And when you actually do have to roll up your sleeves and tackle form properties, you’ll find the cheat sheet in the next lesson invaluable.

---

**Quick Reference**

To View and Change Form Properties:

1. Display the form in Design View.
2. Double-click the Form or Report Selector.
3. Click the appropriate property tab and property box and make the desired changes.
Lesson 7-9: Form and Report Property Reference

If you thought controls had lots of properties, wait until you see how many properties forms and reports have! Here’s another “cheat sheet” that lists the various form properties. Some of the more important properties are marked with a ★.

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption in the form’s title bar.</td>
</tr>
</tbody>
</table>
| Default View ★            | Format | Specify the view the form is in when opened.  
**Single Form**: Displays one record at a time.  
**Continuous Forms**: Displays multiple records in a form.  
**Datasheet**: Displays multiple records in a Datasheet. |
<p>| Views Allowed             | Format | Determines the view users can switch to: Form, Datasheet, or Both. |
| Scroll Bars ★             | Format | Determines whether scroll bars appear on the form. |
| Record Selectors ★        | Format | Specify whether a form contains a record selector. |
| Navigation Buttons ★      | Format | Determines whether a form has navigation buttons. |
| Dividing Lines            | Format | Determines if lines appear between records in continuous forms. |
| Auto Resize               | Format | Resizes the form automatically to display a complete record. |
| Border Style ★            | Format | Determines the type of window the form appears in: None, Thin, Sizable, or Dialog. |
| Control Box               | Format | Determines if a control menu appears in the form. |
| Min Max Buttons           | Format | Determines if minimize and/or maximize buttons appear in the form. |
| Close Button              | Format | Determines if a close button appears on the form. |
| Width ★                   | Format | Determines the width of the form. |
| Height ★                  | Format | Determines the height of the form. |
| Picture                   | Format | Adds a graphic or picture for the form or report background. Click the Build button to browse for the folder and file. |
| Picture Type              | Format | Determines if the picture is embedded or linked. |
| Picture Size Mode         | Format | Determines how the contents of a picture frame are displayed: Clip, Stretch, or Zoom. |
| Picture Alignment         | Format | Determines the alignment of a picture within a frame. |
| Picture Tiling            | Format | Determines whether a picture is tiled within a frame. |
| Grid X                    | Format | Determines the number of subdivisions (horizontal) in a grid. |
| Grid Y                    | Format | Determines the number of subdivisions (vertical) in a grid. |</p>
<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout for Print</td>
<td>Format</td>
<td>Determines whether the form uses printer fonts.</td>
</tr>
<tr>
<td>Palette Source</td>
<td>Format</td>
<td>Specify the path and file name for the graphic file used as a palette.</td>
</tr>
<tr>
<td>Record Source ⚫️</td>
<td>Data</td>
<td>Specify the table or query whose data you want to use in the form.</td>
</tr>
<tr>
<td>Filter</td>
<td>Data</td>
<td>Specify a filter that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Order By</td>
<td>Data</td>
<td>Specify a sort order that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Allow Filters</td>
<td>Data</td>
<td>Determines whether filters may be applied to the form.</td>
</tr>
<tr>
<td>Allow Edits ⚫️</td>
<td>Data</td>
<td>Specify whether records can be modified in the form.</td>
</tr>
<tr>
<td>Allow Deletions ⚫️</td>
<td>Data</td>
<td>Specify whether records can be deleted in the form.</td>
</tr>
<tr>
<td>Allow Additions ⚫️</td>
<td>Data</td>
<td>Specify whether records can be added in the form.</td>
</tr>
<tr>
<td>Data Entry ⚫️</td>
<td>Data</td>
<td>Select Yes if you only want to use the form for to add new records.</td>
</tr>
<tr>
<td>Events Tab</td>
<td>Events</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Pop Up</td>
<td>Other</td>
<td>Specify if the form appears in a pop up window that remains on top of all other windows.</td>
</tr>
<tr>
<td>Modal</td>
<td>Other</td>
<td>Specify if the form keeps the focus (you can’t switch to any other windows or forms) until it is closed.</td>
</tr>
<tr>
<td>Cycle</td>
<td></td>
<td>Determines how the tab key should cycle.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Other</td>
<td>Select a custom Menu Bar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Other</td>
<td>Select a custom Toolbar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>Other</td>
<td>Determines if right-mouse button shortcut menus are permitted in the form.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specify a user-created shortcut menu that appears when a user clicks the right-mouse button.</td>
</tr>
<tr>
<td>Fast Laser Printing</td>
<td>Other</td>
<td>Print the form using optimized laser printer formatting.</td>
</tr>
<tr>
<td>Help File</td>
<td>Other</td>
<td>Specify the name of the custom help file for the form.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specify an identifier number for a user-created help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Extra, user-defined information that is stored in the form.</td>
</tr>
<tr>
<td>Has Module</td>
<td>Other</td>
<td>Specify if the form has Visual Basic code behind it.</td>
</tr>
</tbody>
</table>
Lesson 7-10: Working with Multiple Controls

The advantage of selecting multiple controls in a form or report is that you can edit, delete, move, format, or resize a whole bunch of controls at once, instead of having to edit each control individually. In this lesson you will learn how to select multiple controls on a form.

1. **Open the frmCustomers form in Design View.**
   To delete a control you have to select it and press the <Delete> key. Sometimes you will want to delete several controls; instead of selecting and deleting each individual control you can select and delete several controls at the same time. There are several ways to select more than one control:
   - Press and hold down the <Shift> key as you click each control that you want to select.
   - If necessary, click the Select Object button on the Toolbox toolbar. Then use the arrow pointer (✔️) to draw a box around the controls that you want to select, as shown in Figure 7-15. The disadvantage of this method is it’s not as selective as using the <Shift> + click method.
   - If the controls you want to select are aligned along a horizontal line, click to the left of the objects in the vertical ruler to select every control to the right of the ruler.

2. **Hold down the <Shift> key as you click the Smoker and First Class text boxes as shown in Figure 7-14.**
   Handles (🔺) appear around the controls, indicating that they are selected.

3. **Press the <Delete> key to delete the selected controls.**
   The Smoker and First Class text box controls are both deleted.
Lesson 7-11: Adding, Cutting, Copying, and Pasting Controls

In this lesson you will learn how to add controls by clicking and dragging and by copying and pasting.

1. **Click the Check Box button on the Toolbox.**
   
   **NOTE:** If the Toolbox isn’t displayed, click the Toolbox button on the Form Design toolbar.
   
   The mouse pointer changes to a , indicating that you can click and drag a check box control on the form.

2. **Place the pointer below the SSN text box. Click and drag the pointer down and to the right, and release the mouse button, as shown in Figure 7-16.**
   
   Congratulations! You’ve just added a check box control to your form.
   
   If your form already has a control that’s similar to the one you want to add, it’s often easier to add the new control by copying and pasting the similar control than it is to add a control using the Toolbox. Once you have pasted the control, you can easily modify its properties, such as its text label data source. Here’s how to copy a control.

3. **Select the check box control you just added and click the Copy button on the Form Design toolbar.**
   
   Access copies the selected check box control to the Windows clipboard. You can also cut controls on a form by selecting them and clicking the Cut button on the Form Design toolbar or by pressing <Ctrl> + <X>. Now let’s paste the copied control.

4. **Click the Paste button on the Form Design toolbar.**
   
   Access pastes the copied check box onto the form as a new check box with its own name and label. We’ll modify the two new check box controls in the next lesson.
Lesson 7-12: Changing a Control’s Data Source

There are three types of controls that you can add to your forms, as illustrated in Figure 7-17. They are:

- **Bound Controls**: Bound controls are bound or connected to an underlying field in a table or query. You use bound controls to display, enter, and update field values in your database. The fields that you can add to a form using the Field List are all examples of bound controls.

- **Unbound Controls**: Unbound controls are not bound or connected to an underlying field in a table or query. You use unbound controls to display information. Labels, text boxes, and buttons can all be inserted on a form as unbound controls. The two check boxes you added to the form in the previous lessons are both examples of unbound controls, because they aren’t connected to an underlying field in a table or query.

- **Calculated Controls**: Calculated controls are based on an expression and are used to calculate values in a form, such as arithmetic problems. Technically speaking, calculated controls are unbound controls because they do not update any table fields.
Chapter Seven: Working with Forms

A control’s Control Source property determines what is displayed in a control – here’s how:

- A bound control’s Control Source property contains the name of the underlying database field to which it is bound.
- An unbound control’s Control Source property does not contain the name of an underlying database field.
- A calculated control’s Control Source property contains an expression that calculates the values displayed in the control.

This lesson explains how you can change a control’s Control Source property.

1. Select the first check box control you added in the previous lesson, and display its properties by clicking the Properties button on the Form Design toolbar.
   The Properties dialog box appears. You can find the Control Source property on the Data Tab.

2. Click the Data Tab.
   The Data Tab appears, as shown in Figure 7-18. You can determine what is displayed in the control by setting the Control Source property. You can select bind the control to a field in the form’s underlying query or table by clicking the button, or you can type text or an expression directly into the Control Source box. We want to bind the selected check box to the Smoker field.

3. Click in the Control Source box, click the button and select Smoker from the list.
   The check box is now bound to the Smoker field in the tblCustomers table. Next let’s bind the other check box control you added to the First Class field.

4. With the properties dialog box still open, click the second check box control you added in the previous lesson.
   The Properties dialog box is updated and displays the settings for the selected check box control.

5. Click in the Control Source box, click the button and select First Class from the list.
   You’re done specifying the data sources for the two check boxes, so you can close the Properties dialog box.

6. Close the Properties dialog box.
   Before we’re finished, we have to give the two check boxes more meaningful text labels. Here’s how:

7. Click the first check box control to select it.
   Once you have selected a control you can change its text label.

8. Position the pointer over the check box text label, until it changes into a , and then click inside the text label.
   Now you can edit the check box text label.

9. Replace the text label text with Smoker.
   Now move on to the next step and change the text label for the second check box.

10. Following the same procedures as steps 7-9, rename the second check box text label First Class.
    That’s it! You’re done binding the check boxes to two underlying database fields.

11. Save your changes and close the frmCustomer form.
Lesson 7-13: Creating a Calculated Control

A calculated control is an unbound control that displays totals and other arithmetic computations on a form. You create calculated controls by entering an expression (or formula) to perform the calculation in the control’s Control Source property.

In forms, expressions start with the equal sign (=), which tells Access that you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Expressions can contain explicit values, such as the numbers 4 or 5 or can reference the values contained in database fields. For example, the formula = [Cost] * [Commission] would multiply the values in the Cost and Commissions fields. To enter fields in an expression, type the field name in brackets ([Order Total]). If a field name exists in more than one table you will need to enter the name of the table that contains the field in brackets ([Customer Tours]) followed by an exclamation mark (!).

To Create a Calculated Control:

1. Open the frmTours form in Design View.
   You want the Totals text box to be a calculated control that finds the total cost of each tour by multiplying the Number of Tickets field by the Cost field.

2. Select the Total text box, click the Properties button on the Form Design toolbar and click the Data Tab.
   You need to enter the expression in the Control Source box.

3. Click in the Control Source box and type the expression = [Number of Tickets] * [Cost] as shown in Figure 7-22.
   Let’s see how our new calculated control works.

4. Close the Properties dialog box and click the View button on the Form Design toolbar to switch to Form View.
   The Totals field displays the results of the expression you entered in Step 3.

5. Save your changes and close the frmTours form.

Although you worked on a form in this lesson, you can also use expressions to create calculated controls and fields in queries and reports.
Lesson 7-14: Changing a Control's Default Value

You can enter a Default Value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to "TX". When a user adds a record using a form, they can either accept the TX default value for the State field or enter their own value.

1. **Open the frmCustomers form in Design View.**
   Since the majority of your customers are from Minnesota you decide to add MN as the default value for the State field.

2. **Click the State field, display its properties by clicking the Properties button on the Form Design toolbar and click the Data tab.**
   Now you can add a default value to the State field.

3. **Click the Default Value box and type MN, as shown in Figure 7-23.**
   Let’s see how the new default value property works.

4. **Close the properties dialog box and click the View button on the Form Design toolbar to switch to Form View.**
   You will need to add a new record in order to see any default values.

5. **Click the New Record button on the Record Navigation bar.**
   Access adds a new blank record to the form. Notice the State field already contains the MN default value. If the customer is from another state you can simply replace the default value with your own data.

6. **Save your changes and close the frmCustomers form.**

One more important note about form control properties: Control properties in a form are inherited, or passed down from the original properties in the underlying table or query. So, for example, if you set the Default Value property for a table’s State field to TX, the TX Default Value property will be passed on to a related State control on a form by default.
Lesson 7-15: Using the Control Wizard

The Control Wizard (no relation to Merlin) helps you add powerful, interactive controls on your form. Some examples include:

- List and combo box controls that can look up values in a table and then display the corresponding record on a form.
- Buttons that can open, print, or close tables, forms, queries, and reports.
- Subforms, subreports, and charts that display related data from different tables.

When you add a control using the Control Wizard, you are asked a series of questions about what you want the control to do. The Control Wizard then creates the control, making the appropriate property settings and even adding several lines of Visual Basic code to the control for you.

1. Open the frmCustomers form in Design View.

To use the Control Wizard, simply make sure that the Control Wizards button on the Toolbox is pressed in, and then add the control. The Control Wizard will appear anytime you try to create a list box, combo box, option group, button, chart, subreport, or subform.
2. Make sure the **Control Wizard button** on the Toolbox is pressed in.
The Control Wizard is so incredibly cool and useful that you are strongly recommended to always keep it on.

**NOTE:** If the Toolbox isn’t displayed, click the **Toolbox button** on the Form Design toolbar.

3. Click the **Combo Box button** on the Toolbox.

The mouse pointer changes to a ▼, indicating that you can click and drag a combo box control on the form.

4. Place the ▼ pointer in the form header, about one inch to the right of the Customer label. Click and drag the ▼ pointer to the right about an inch and release the mouse button.

Because the Control Wizard is on, the Combo Box Wizard dialog box appears, as shown in Figure 7-26. Each type of control will have its own Control Wizard and its own set of options. For this exercise you want to select the third option.

5. Select the **Find a record on my form based on the value I selected from my combo box option** and click **Next**.

Next the Control Wizard asks which values you want to add to the combo box control.

6. Click the ▼ button three times to add the CustomerID, LastName and FirstName fields to the combo box and click **Next**.

Next the Control Wizard asks how wide you want the columns in your combo box control and if you want to hide the key column. Everything looks okay here, so…

7. Click **Next**.

Finally you are asked to give your combo box a name. You can accept the default name provided by the Control Wizard or you can provide your own name.

8. Type **Lookup Name** and click **Finish**.

Poof! The Control Wizard adds the combo box. Next let’s add a command button that will print the current record when clicked. You may want to put some finishing touches on the button such as resizing or repositioning.

9. Click the **Command Button button** on the Toolbox and add a button to the right of the CustomerID text box by clicking and dragging.

Because the Control Wizard is on, the Command Button Wizard appears. Command Buttons have lots of options that you can choose from, broken down by categories.

10. Select **Record Operations** from the Categories list and select **Print Record** from the Actions list.

This will make the command button print the current record when clicked.

11. Click **Next**.

Here you can specify the text or picture that will appear in the button.

12. Click **Finish**.

Access adds the command button to the form. You may want to put some finishing touches on the button such as resizing or repositioning.

13. Click the **View button** on the Form Design toolbar.

Let’s see how our new controls work.

14. Select a name from the new **Lookup Name combo box**.

Access finds and displays the record that you select from the combo box.

15. Save your changes and close the **frmCustomers form**.

Try experimenting and adding controls to your forms using the Control Wizard. You’ll be amazed at how much you can accomplish without knowing any programming!
Lesson 7-16: Creating a Subform

A subform is a form within a form. The primary form is called the main form, and the form within the form is called the subform. Subforms are especially useful when you want to show data from tables or queries with a one-to-many relationship. For example, a Customer form might have a subform that displays each customer’s orders. Subforms are a great way to display information from a one-to-many table relationship.

The main form and subform are linked so that the subform displays only records that are related to the current record in the main form. For example, when the main form displays a particular customer, the subform displays only orders for that customer.

1. **Open the frmEmployees form in Design View.**
   Usually you will want to have the Control Wizard assist you when you add a subform.

2. **Make sure the Control Wizard button on the Toolbox is pressed in.**
   The Control Wizard is on whenever its button is depressed.

   **NOTE:** If the Toolbox isn’t displayed, click the Toolbox button on the Form Design toolbar.

   Before you add a subform, make sure that you have enough room for it on the main form.

3. **Resize the main form window as needed, so that you have enough room to add the subform.**
   You’re ready to add the subform! Here’s how:
Chapter Seven: Working with Forms

4. **Click the Subform/Subreport button on the Toolbox.**
   The mouse pointer changes to a †, indicating that you can click and drag the subform onto the main form.

5. **Place the † pointer just below the DOB field. Click and drag the † pointer down and to the right, until the subform covers most of the bottom half of the main form.**
   The Subform/Subreport Wizard appears and asks if you want to use an existing form for your subform, or if you want to build a new form using tables or queries. In this exercise we will have the Wizard build us a new form using tables and queries to use as our subform.

6. **Click Next.**
   The next step of the Wizard appears. Here you have to select the table or query and fields that you want to display in your subform. We want our subform to display the tours that each employee has sold, so we will select the qryTours query as the source for our subform.

7. **Select Query: qryCustomerTours query from the Tables and Queries combo box.**
   Now you need to select the fields you want to appear in the subform. You **must** select the related field used to join the main form and subform. This related field must appear on both the main form (where it is called the parent field) and on the subform (where it is called the child field). In this exercise we will use the EmployeeID that will be used to link the two forms.
   **NOTE:** It’s very important that the underlying tables or queries of the main form and subform have a related field, and that the related field appears somewhere on both forms. See the “Understanding Table Relationships” in the “Working with Tables and Fields” chapter if you’re having trouble understanding this concept.

8. **Select the EmployeeID field and click the ‡ button to add the field to the Selected fields list.**
   Now that you’ve added the most important field that will link the two forms, you can add the remaining fields that you want to appear on the subform.

9. **Add the Date, TourID, CustomerID, and Number of Tickets fields to the Selected fields list.**
   If you’re this far you should be a pro at adding and removing fields using the Wizard. Just make sure that you add the fields in the order specified above.

10. **Click Next.**
    The next step in the Wizard is to define the fields that link the main form and the subform. The Subform Wizard is often smart enough to recognize the field and use it to link the two forms—as it is in this exercise. If not, you will have to click the Define my own option and select the two related fields.

11. **Click Finish.**
    Access creates the subform and adds it to the main form.

12. **Save your changes and to the frmEmployees form and display it in Form View.**
    The frmEmployees form displays information on each employee and the new subform displays the tours that employee booked.

Subforms created with the Subform/Subreport wizard are usually a little rough around the edges and will require a little clean-up work on your part. We’ll learn how to modify and work with a subform in the next lesson.

---

**Quick Reference**

To Create a Subform:
1. Display the form in **Design View.**
2. Click the Toolbox button on the toolbar if necessary.
3. Make sure the Control Wizard button on the Toolbox is selected.
4. Resize the form if necessary.
5. Click the Subform/Subreport button on the Toolbox.
6. In the form window, click and drag where you want the subform to appear.
7. Click Next.
8. Specify the table or query you want to use for the subform and select the fields you want to appear in the subform.
9. Click Next.
10. If necessary, specify the parent and child fields that link the main form and subform.
11. Click Finish.
Lesson 7-17: Modifying and Working with Subforms

Subforms rarely come out the way you want them to the first time: They may be too small or too large, and must be resized so that the main form and subform fit together nicely. If you’re using an existing form as a subform you may need to change the subform layout. Subforms can be displayed using one of three different formats:

- **Datasheet**: Displays multiple records in a table, using one line per record. Tables and queries display their data in Datasheet layout.
- **Single Form**: Displays one record at time on a form.
- **Continuous Form**: Displays multiple records on a form. The main difference between Datasheets and continuous forms is that you can design and customize continuous forms.

1. **Make sure that you have the frmEmployees form you modified in the previous lesson open in Form view.**
   When you add records on a main form or subform Access stores the appropriate data in each table. Usually you won’t even realize that you are working with several tables!

   The subform you added in the previous lesson has enlarged the main form so that it is large enough to display the subform contents. You will need to resize the form window to display the form properly.

2. **Select Window → Size to Fit Form from the menu.**
   Access resizes the window to fit the form. Let’s see how the new subform works.

3. **Click the Next Record Navigation button on the main form.**
   Notice that the subform displays tours booked by the current employee.

   Notice that the main form and subform each have their own set of navigation buttons that you can use to add and move between records. Try adding a new record to the subform.
4. **Click the New record button on the subform record navigation bar.**
   The record indicator jumps to the blank row at the end of the subform datasheet and the blinking insertion point (|) appears in the EmployeeID field. Notice that Access has automatically filled in the EmployeeID field with the main form’s EmployeeID.
   
   **NOTE:** If you have set referential integrity between two or more related fields in a subform’s underlying table or query you will have to obey those referential integrity rules in order to add or edit a record in the subform. For example, you can’t enter a number in the TourID field unless that number exists in the Tours table.

5. **Enter a new record in the subform using the following information:**

<table>
<thead>
<tr>
<th>EmployeeID</th>
<th>Date</th>
<th>TourID</th>
<th>CustomerID</th>
<th>Number of Tickets</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Current)</td>
<td>9/2/01</td>
<td>China</td>
<td>Ali Chien</td>
<td>2</td>
</tr>
</tbody>
</table>

It’s easy to switch between the main form and subform: simply click a field or control in the form you want to move to or press <Ctrl> + <Shift> + <Tab>.

6. **Click any field in the main form to move to the main form.**

Here’s how to modify a subform:

7. **Switch to Design View.**

   First get rid of that annoying subform label.

8. **Select the label for the subform and press <Delete>.**

   In Access 2000 you can directly modify subforms from the main form (previously you had to work with subforms in a separate window.)

9. **In the subform, resize the text fields and corresponding text labels for the TourID, CustomerID, and Number of Tickets fields. Then move the resized text fields and corresponding text labels closer together.**

   Compare your subform to the one in Figure 7-31. Now let’s resize the subform.

10. **Resize the subform window as needed, then click and drag the right edge of the subform to the left to eliminate the wasted, empty space.**

    Here’s how to change the layout of a subform:

11. **Double-click the subform’s form selector in the upper-left corner of the subform.**

    The Properties dialog box appears.

12. **Click the Format tab, click in the Default View box, click the button and select Datasheet. Close the Properties dialog box.**

    Now you need to resize the subform control and the main form.

13. **Resize the subform control so that it fits nicely in the main form, and then drag the right edge of the main form to resize it as well.**

    Let’s see how our form looks.

14. **Display the frmEmployees form in Form View.**

    The subform is displayed in continuous form layout instead of Datasheet layout.

15. **Save your changes to the form and exit Microsoft Access.**

   Whew! We just covered a lot of ground in this chapter. Try moving on to the Chapter Review to see how much you remember.
Chapter Seven Review

Lesson Summary

Creating a Form with AutoForm

- To Create a Form with AutoForm: From the Database window, click the Forms icon in the Objects bar and click the New button. Select the type of form you want to create: Columnar, Tabular, or Datasheet. Click the table or query you want to use for the form from the drop-down list and click OK.

Modifying a Form

- To Modify a Form: From the Database window, click the Forms icon in the Objects bar, click the form you want to modify and click Design or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- To Add a Field to a Form: Display the form in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the form.

- To Delete a Field or Control: Click the field or control to select it and then press <Delete>.

Moving and Sizing Controls

- To Resize an Object: Click the object to select it, grab one of its sizing handles, and drag. Release the mouse button when the object reaches the desired size. Hold down the <Shift> key while dragging to maintain the object’s proportions while resizing it.

- To Move a Control: Click the control and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.

- To Move a Text Box or Text Label Independently of Each Other: Position the pointer over the upper-left sizing handle of the control until it changes to a », then click and drag the control.

Changing the Tab Order

- To Change a Form’s Tab Order: Display the form in Design View and select View → Tab Order from the menu. Click the row selector for the control you want to move and click and drag the row selector to the desired location. Repeat as needed to change the tab order of additional controls.

- To Automatically Change the Tab Order: Display the form in Design View and select View → Tab Order from the menu. Click the Auto Order button to automatically reorder the form controls, based on their position in the form.
Working with Control Properties

- **To Display the Properties for any Control**: Display the form in Design View and do any of the following:
  - Select the control and click the Properties button on the toolbar.
  - Right-click the control and select Properties from the shortcut menu.
  - Select the control and select View → Properties from the menu.

Working with Form Properties

- **To View and Change Form Properties**: Display the form in Design View and double-click the Form or Report Selector. Click the appropriate property tab and property box and make the desired changes.

Working with Multiple Controls

- **To Select Multiple Controls**: Do any of following:
  - Press and hold down the <Shift> key as you click each object that you want to select.
  - User the arrow pointer (↑) to draw a box around the object that you want to select.
  - If controls are aligned along horizontal or vertical lines, click the corresponding ruler above or to the left of the controls.

Adding, Cutting, Copying, and Pasting Controls

- **To Add a Control**: Click the Toolbox button on the toolbar if necessary, click the button on the Toolbox for the type of control you want to add. In the Form window, click and drag the pointer where you want the control to appear.

- **To Cut a Control**: Select the control and:
  - Click the Cut button on the toolbar or…
  - Press <Ctrl> + <X> or…
  - Select Edit → Cut from the menu.

- **To Copy a Control**: Select the control and:
  - Click the Copy button on the toolbar or…
  - Press <Ctrl> + <C> or…
  - Select Edit → Copy from the menu.

- **To Paste a Control**: Select the control and:
  - Click the Paste button on the toolbar or…
  - Press <Ctrl> + <V> or…
  - Select Edit → Paste from the menu.

Changing a Control’s Data Source

- **To Change a Control’s Data Source**: Display the Form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab, click the Control Source box, click the arrow and select the field that you want to bind the control to or enter an expression. Close the Properties dialog box when you’re finished.

Creating Calculated Controls

- **To Create a Calculated Control**: Display the form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab and click in the Control Source box, type the expression and then close the Properties dialog box.
Changing a Control's Default Value

- **To Set a Control's Default Value:** Display the form in **Design View**, display the properties for the desired control and click the **Data tab**. Click the **Default Value box** and type the default value you want to appear for new records. Close the Properties dialog box when you're finished.

Using the Control Wizard

- **To Create a List Box or Combo Box:** Display the form in **Design View**, click the **Toolbox button** on the toolbar if necessary and make sure the **Control Wizard button** on the Toolbox is selected. Click the **Combo box or List box button** on the Toolbox. In the form window, click and drag where you want the control to appear. Specify whether you want the control to get its values from a table or query, or if you want the control to find a record on the form. Select the table that contains the fields you want to include in the list, click **Next**, select the fields you want to appear in your list and click **Next**. Adjust the column widths if necessary, click **Next**. If necessary, specify which column contains the value that will be stored and click **Next**. Specify whether Access should merely display the value or display it in a field. Enter a label and click **Finish**.

Creating a Subform

- **To Create a Subform:** Display the form in **Design View**, click the **Toolbox button** on the toolbar if necessary and make sure the **Control Wizard button** on the Toolbox is selected. Resize the form if necessary, then click the **Subform/ Subreport button** on the Toolbox and click and drag where you want the subform to appear in the form. Click **Next** and specify the table or query you want to use for the subform and select the fields you want to appear in the subform. Click **Next**, specify the parent and child fields that link the main form and subform if necessary and click **Finish**.

Modifying and Working with Subforms

- **To Modify a Subform:** Display the main form in **Design View** and double-click the subform. Edit the subform as needed. When you're finished close the subform and save your changes.

Quiz

1. Which of the following statements about the AutoForm Wizard is NOT true?
   A. The AutoForm Wizard is the fastest and easiest way to create a form in Microsoft Access.
   B. The AutoForm Wizard can only create three types of forms: Datasheet, Columnar, or Tabular.
   C. Forms created with the AutoForm Wizard usually come out looking sharp and professional and don’t require any further clean-up work.
   D. The AutoForm Wizard can only create forms based on a single table or query.

2. Which of the following statements is NOT true?
   A. The Field List displays all the fields from a form’s underlying table or query.
   B. Click the Field List button on the Toolbar to display the Field List.
   C. You can add fields to a form by dragging them from the Field List onto the form.
   D. The Field List displays all the fields from every table in a database.
3. Controls and their corresponding text labels cannot be moved independently of one another. (True or False?)

4. If you move a control on a form, the Tab Order, in which you advance from one field to the next when you press the <Tab> key, is automatically updated. (True or False?)

5. A form that has a Datasheet Default View property would display one record at a time in the form. (True or False?)

6. A calculated field… (Select all that apply.)
   A. …is a bound control.
   B. …is a control that contains an expression.
   C. …can perform calculations on fields values, such as =[Cost]*[Commission].
   D. …can perform calculations on explicit values, such as =2+4.

7. Which of the following set of tables would benefit from a subform? (Select all that apply.)
   A. A Customer table and the Customer Orders table.
   B. A Customer table and the Products table.
   C. A Customer table and the Foreign Currency table.
   D. A Customer table and the Customer Contacts table.

8. When you add a subform to a main form, Access always recognizes how the two forms are related (True or False?)

Homework

1. Open the Homework database.
2. Use AutoForm to create and save a columnar form named Customers, using the Customers table as the underlying data source.
3. Add a text box control with today’s date in the bottom-right corner of the Customers form. Hint: You will need to change the text box control’s data source to the expression =Today().
4. Rearrange the control fields on the form, so that the LastName and FirstName fields appear before the SSN field.
5. Change the Customer form’s tab order to reflect the new field order.
6. Delete the DOB field control from the form.
7. Resize the Customers form as necessary, then use the SubForm Wizard to create a subform based on the Claims table.
8. Modify the Claims subform so that its Default View property is displayed in Datasheet View.
Quiz Answers

1. C. The AutoForm Wizard can create forms in record time, but they aren’t usually well-organized or professional looking.

2. D. The Field List only displays fields from a form or a form’s underlying table or query.

3. False. You can click and drag the upper-left sizing handle to move a label or control independently.

4. False. If you add or move a control on a form, you have to change the form’s tab order yourself—Microsoft Access won’t do it for you.

5. False. A form whose Default View property was set to Datasheet would display multiple records. A form whose Default View property was set to Single Form would display one record on the form at a time.

6. B, C, and D. All of these statements are true.

7. A and D. Because subforms are great at displaying information from one-to-many relationships, both of these tables would benefit from being displayed in a subform.

8. False. If you include the field that links the two tables, Access will automatically recognize it. If the tables aren’t related you may have to manually join the tables by connecting their related fields.
Chapter Eight: Working with Reports

Chapter Objectives:

- Create and modify a report
- Add, delete, move, and size controls
- Adjust page margins and orientation
- Add page numbers and dates
- Work with report sections
- Use reports to group and sort records
- Create and work with report sections
- Add a chart to a report

Chapter Task: Create and modify a variety of reports

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.

It’s easy to print a simple list of records in a table or query—just click the Print button on the toolbar. But if you want your printed hardcopies to look professional, include calculations, graphics, or a customized header or footer, you’ll need to create a report. Reports present information in tables and queries in a format that looks great when printed.

Reports can also summarize and analyze the information in your database. For example, a report might tell you which of your employees had used the most sick days for the past year. Here are just a few examples of how reports work well for presenting information:

- **Attractive Formatting Options:** You can change the type, size, and color of the fonts used in a report to make it easier to read. You can also add lines, boxes, and graphics to your reports.

- **Sorting and Grouping Options:** Reports are great for summarizing and organizing information. For example, you could create a report to total sales by day, week, or month.

- **Combine Data from Linked Tables:** One report can display data from several related tables or queries.

This chapter explains all the ins and outs of creating and working with reports.
Lesson 8-1: Creating a Report with AutoReport

The fastest and easiest way to create a simple report in Access is with the AutoReport Wizard. The AutoReport Wizard can automatically create a report by arranging all the fields from a table or query into a neatly formatted report.

The AutoReport Wizard is easy to use but limited—it only works with one table or query and there are only two types of reports that it can create, as shown in Figure 8-1. Of course you can always modify a report created by using the AutoReport Wizard.

In this lesson you will learn how to create a report using an AutoReport Wizard.

1. **Open the Lesson 8 database.**
   First, you need to go to the Reports tab in the Database window.
2. **Click the Reports icon in the Objects bar, then click the New button.**
   The New Report dialog box appears, as shown in Figure 8-1. You create a report with the AutoReport Wizard by selecting one of the two AutoReport Wizards…

3. **Select AutoReport: Tabular from the list.**
   … and the table or query you want to use for your report.

4. **Click the Choose the table or query where the object's data comes from: arrow and select qryCustomers from the list.**
   That’s all the information the AutoReport Wizard needs to create your report.

5. **Click OK to create the tabular report.**
   Access takes and arranges all the fields in the qryCustomers query and creates a report similar to the one shown in Figure 8-2. Yuck! Ugly-looking report, isn’t it?

6. **Close the report without saving your changes.**
   The reports created by the AutoForm Wizards aren’t very pretty to look at, but they’re fast and easy to create. If you want to have more control over what appears on your report use the Report Wizard. Either way, you will probably want to do some clean-up work, such as renaming the report’s column headings and moving/resizing its controls.

---

**Table 8-1: Available AutoReport Layouts**

<table>
<thead>
<tr>
<th>Report Layout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columnar</td>
<td>Displays each record’s data vertically. Each field of each record appears on a single line by itself.</td>
</tr>
<tr>
<td>Tabular</td>
<td>Displays each record’s data horizontally. Each field appears in a column.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Create a Report with AutoReport:

1. From the Database window, click the Forms icon in the Objects bar and click the New button.
2. Select one of the following:
   - AutoReport: Columnar
   - AutoReport: Tabular
3. Click the table or query you want to use for the report from the dropdown list.
4. Click OK.
Lesson 8-2: Modifying a Report

After you create a report from scratch, using the Report Wizard or using the AutoReport Wizard, you may decide to modify it make it easier to read and understand. For example, you might want to add or delete a field, change a column heading, or change the locations of the fields in the report. To modify a report, go to Design view, which you can get to from:

- **The database window**: Click the Reports tab to list the reports in the database. Click on the report you want to modify and click the Design button.

- **Any report window**: Click the View button on the toolbar or select View → Report Design from the menu.

This lesson will introduce you to Report Design view.

1. **From the Database window**, click the Reports icon in the Objects bar if it isn’t already selected, then select the rptCustomers form and click the Design button.

   The rptCustomers form appears in Design view, as shown in Figure 8-3.

   If you have already worked with forms in Design view you should be in familiar territory—Design view is remarkably similar for both forms and reports. Just as it is with forms, Report Design view is similar to many Paint programs: Think of the report as your canvas and the Toolbox and Field List as the paint brushes you use to add fields, headings, and lines to the report.

   Any object that appears on a report is called a control. A text box used to display record information (usually fields from a table or query) or a column heading are both examples of controls. You add controls to a report by clicking the control you want to use, and by clicking and dragging them on the report to draw the control.

---

**Figure 8-3**
A report in Design view.

<table>
<thead>
<tr>
<th>Report Selector</th>
<th>Click to select the entire report. Double-click to display the report’s properties.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field List button</td>
<td>Click to display/hide the Field List.</td>
</tr>
<tr>
<td>Toolbox button</td>
<td>Click to display/hide the Toolbox.</td>
</tr>
<tr>
<td>Properties button</td>
<td>Click to display properties for the selected object.</td>
</tr>
</tbody>
</table>

- **Toolbox**: Drag and drop to place fields on the report.
- **Field List**: Appears at the top (first page) of the report.
- **Page Header**: Drag down to create a page header.
- **Report Footer divider**: Drag down to create a footer that will appear at the very end (last page) of the report.
- **Details**: Appears for each record.
- **Page Footer**: Appears at the bottom of each page.

© 2000 CustomGuide.com
### Quick Reference

**To Modify a Report:**

1. From the Database window, click the **Forms icon** in the Objects bar.
2. Click the report you want to modify and click **Design**.

Or...

Open the report and click the **View button** on the toolbar.

---

#### Table 8-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Select Objects]</td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the <code>&lt;Shift&gt;</code> key as you click each control, or drag a rectangle shape around all the controls you want to select.</td>
</tr>
<tr>
<td>![Control Wizard]</td>
<td>Click to use Control Wizards when you add controls to your report.</td>
</tr>
<tr>
<td>![Label]</td>
<td>Creates a text label that is the same for every record, such as a heading. Most controls already include a text label.</td>
</tr>
<tr>
<td>![Text Box]</td>
<td>Creates a text box that displays information from tables and queries in a report.</td>
</tr>
<tr>
<td>![Option Group]</td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Toggle Button]</td>
<td>Creates a toggle button. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Option Button]</td>
<td>Creates an option button (or radio button) that displays data from two or more options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Check Box]</td>
<td>Creates a box that is empty or contains a checkmark. Use to display data from a Yes/No field.</td>
</tr>
<tr>
<td>![Combo Box]</td>
<td>Creates a combo box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![List Box]</td>
<td>Creates a list box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Command Button]</td>
<td>Creates a button that runs a macro or Visual Basic function. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Displays a picture by using a graphic file that you specify.</td>
</tr>
<tr>
<td>![Unbound Object Frame]</td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td>![Bound Object Frame]</td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td>![Page Break]</td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td>![Tab Control]</td>
<td>Creates a tab control. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>![Subform/Subreport]</td>
<td>Inserts another report within the main report. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td>![Line]</td>
<td>Enables you to draw a line in the report.</td>
</tr>
<tr>
<td>![Rectangle]</td>
<td>Enables you to draw a rectangle in the report.</td>
</tr>
<tr>
<td>![More Controls]</td>
<td>Click to display other toolboxes and OLE objects.</td>
</tr>
</tbody>
</table>
Lesson 8-3: Adding and Deleting Fields

Once you have created a report, you can delete a field that you don’t need or make a report more comprehensive by adding more fields to display additional information.

In this lesson you will modify an existing report by adding and deleting fields.
1. Make sure you have the *rptCustomers* report open in **Design view**. Maximize the report window.

First, click the control you want to delete.

2. **Click the DOB text box to select it.**

Handles (■) appear around the control, indicating that the control is selected.

3. **Press the <Delete> key to delete the DOB text box.**

The DOB text box disappears from the report screen.

Unfortunately, adding fields to a report isn’t quite as easy…

4. **If the Field List isn’t displayed, click the Field List button on the toolbar.**

The Field List displays all the fields from the table or query you used to create the report. You will often have to scroll down the Field List to find the field you want. Once the Field List is displayed you can click and drag the field you want to add from the Field List onto the report.

5. **Scroll down the Field List until you find the ZipCode field. Click and drag the ZipCode field to the right of the Phone field, as shown in Figure 8-4, then release the mouse button.**

The ZipCode field appears on the report with less than desirable results, as shown in Figure 8-5. An annoyance with adding controls to a report is that you almost always have to do some clean-up work afterwards. For example, the ZipCode field has an unneeded text label, it isn’t positioned correctly, and it has enlarged the Detail section of the report. Don’t worry about the positioning for now—you’ll learn how to move controls in the next lesson. We can fix some of the other problems, however, starting with getting rid of the text label.

6. **Click the ZipCode text label (NOT the actual ZipCode field or text box!) and press <Delete>.**

Before we’re finished, we have to give the ZipCode field a more meaningful text heading. Here’s how:

7. **Click the DOB text label to select it.**

8. **Position the pointer over the check box DOB text label, until it changes into a ✂, and then click inside the text label.**

Now you can edit the check box text label.

9. **Replace the text label text with Zip Code.**

Let’s see how the modified report looks.

10. **Click the View button on the toolbar to display the report in Print Preview.**

Compare your report with the one in Figure 8-7.

11. **Switch back to Design View using the View Button and save your changes by clicking the Save button on the toolbar.**

---

**Quick Reference**

**To Add a Field to a Form:**

1. Display the report in **Design View** and click the **Field List button** on the toolbar if necessary.
2. Find the field you want to add to the form in the **Field List**, then click and drag the field to the desired location on the report.

**To Delete a Field or Control:**

1. Click the field or control to select it.
2. Press <Delete>. 

---

**Field List button**

Other Ways to Display the Field List:

- Select View → Field List from the menu.
Lesson 8-4: Moving and Sizing Controls

It’s easy to change the location and size of a control on a report—and it’s something you will usually have to do whenever you add a control, since Access rarely places things exactly right in the first place. When you size a control, you increase or decrease the amount of information the control can display. When you select a control on a report, sizing handles appear around the edges of the control. Once you have selected a control you can drag its sizing handles to adjust the size of the control or move the control to a new location on the report.

This lesson will give you some experience moving and sizing the controls on the report you created in the previous lesson.

1. Make sure that you have the rptCustomers report open.
   You need to be in Design view to modify a report.

2. If you’re not in Design view, click the View button on the toolbar.
   You need to select a control before you can move or size it.

3. Click the ZipCode text box to select it.
   Sizing handles appear around the selected phone field. Here’s how to move a control:

4. Position the pointer on any border of the ZipCode text box (but not over a sizing handle) until it changes to a ⬇️.
   When the mouse pointer changes to a ⬇️ it means that you can drag and drop the control to a location.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a field. Move the pointer very slowly and wait until you see it turn into a ⬇️ before you try to move the control.
5. Click and hold down the mouse button while the pointer is still over the border of the ZipCode text box. Drag the field directly to the left of the State text box, as shown in Figure 8-8 then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a report—any shapes, lines, pictures, or text boxes.

Sometimes, after moving an object, you’ll find you want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. Simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

6. With the ZipCode field still selected, hold down the <Ctrl> key and press the ← (left arrow) key.

The ZipCode field moves to the left a smidgen.

7. Make sure the ZipCode text box is still selected. Position the pointer over the middle-right sizing handle until it changes to a ←. Click and hold down the mouse button and drag to the left until the label is about two-thirds of its original size then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it. That’s all there is to moving and sizing controls on a report.

8. Click the Save button on the toolbar to save your changes.

Quick Reference

To Resize an Object:
• Click the object to select it; grab one of its sizing handles; and dragging and releasing the mouse button when the object reaches the desired size.
• Hold down the <Shift> key while dragging to maintain the object’s proportions while resizing it.

To Move an Object:
• Click the object and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.

To Copy an Object using Drop and Drag:
• Follow the same procedures as moving an object, only hold down the <Ctrl> key while you drag the object.
Lesson 8-5: Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. The default margins for a report are 1 inch at the top, bottom, left, and right. There are many reasons to change a report’s margins: To make room for more data, to add some extra space if you’re binding a document, or to leave a blank space to write in notes. If you don’t already know how to adjust a page’s margins, you will after this lesson.

This lesson also explains how to change the page orientation. Everything you print uses one of two different types of paper orientations: Portrait and Landscape. In Portrait orientation, the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape.

1. **Make sure that you have the **rptCustomers** report open in Design view.**

Here’s how to modify the page setup for a report:

The default margins are 1-inch at the top, bottom, left, and right.
2. Click File → Page Setup from the menu and click the Margins tab if it is not already in front.

The Margins tab of the Page Setup dialog box appears, as shown in Figure 8-9. Here you can view and adjust the margin sizes for the current worksheet. Notice there are margins settings in the Top, Left, Right, header, and footer boxes.

3. Click the Top Margin box and type .5.

This will change the size of the top margin from 1.0” to 0.5”.

4. Repeat Step 2 and change the Bottom, Left, and Right margins to 0.5 inches.

Do you think you have a handle on changing a report’s margins? Good, because without further ado, we’ll move on to page orientation.

5. Click the Page tab.

The Page tab appears, as shown in Figure 8-11.

6. In the Orientation area, click the Landscape option button.

This will change the worksheet’s orientation to Landscape when it is printed.

7. Click OK.

The Page setup dialog box closes, and the report’s margins and page orientation settings are changed.

When you change a report’s margins you will usually want to resize the report itself—here’s how:

8. If necessary, scroll to the right edge of the report. Click and drag the right edge of the report to the right to the 7.5 inch mark on the ruler.

Let’s see how the newly formatted report looks.

9. Click the View button on the Form Design toolbar.

The report is previewed on the screen. You can reduce or enlarge the display by clicking the report you want to magnify with the pointer.

10. Move the pointer over an area of the report and click the mouse button.

Access displays the entire report—and it’s easy to see the new landscape orientation.

11. Switch back to Design View and save the changes you’ve made to the report.

Quick Reference

To Adjust Margins:
1. Select File → Page Setup from the menu and click the Margins tab.
2. Adjust the appropriate margins.

To Change a Page’s Orientation:
1. Select File → Page Setup from the menu, and click the Page tab.
2. In the Orientation section, select either the Portrait or Landscape option.
Lesson 8-6: Adding Page Numbers and Dates

Reports that are several pages long often have information such as the page number or the date located at the top (header) or bottom (footer) of every page. In this fast and easy lesson you will learn how to use the Page Number command and Date and Time command to add page numbers and/or the current date to your report.

1. Make sure that you have the rptCustomers report open in Design view.

   Here's how to add page numbering to a report:

   2. Select Insert → Page Numbers from the menu.

      The Page Numbers dialog box appears, as shown in Figure 8-13. The Page Numbers dialog box gives you several choices for how you want the page numbers to be formatted:

         • **Page N**: Prints only the page number, for example, page 5.
• **Page N of M**: Prints the page number and the total number of pages, for example page 5 of 15.

3. **Select the Page N of M option.**
   Next you need to specify where on the page you want the page number to appear—at the top or bottom of the page—and how you want the page numbers aligned.

4. **Select the Bottom of Page option and select Right from the Alignment list.**
   That’s all there is to adding page numbers to a report.

5. **Click OK to close the Page Numbers dialog box.**
   The Page Numbers dialog box closes and Access adds a text box with a page number expression (="Page " & [Page] & " of " & [Pages]) to the Page Footer.
   Here’s how to add the date and time to your reports:

6. **Select Insert → Date and Time from the menu.**
   The Date and Time dialog box appears, as shown in Figure 8-14. You can add the date, time, or both to your reports. For this exercise you only want the current date to appear on your report.

7. **Click the Include Time check box to remove its checkmark.**
   Just like the Page Number dialog box, the Date and Time dialog box gives you several choices for how you want the date and/or time to be formatted. The currently selected date format (the first option) will work fine here so you can close the Date and Time dialog box.

8. **Click OK to close the Date and Time dialog box.**
   The Date and Time dialog box closes and Access adds a text box with a date number expression (=Format(Date(),"Long Date") to the Report Header.
   Microsoft Access isn’t particularly bright and may place the date, time, or page numbers on top of an existing control, as has happened here. To correct the problem you will have to move the new control to a different location on the report.

9. **Click and drag the Date control [=(Date())] to the far right side of the report header.**
   Let’s see how our modified report looks.

10. **Click the View button on the Form Design toolbar.**
    The report is previewed on the screen and you can see the date and, if you scroll down, the page numbering.

11. **Switch back to Design View and save the changes you’ve made to the rptCustomers report.**

---

**Quick Reference**

**To Add Page Numbers:**
1. Display the report in **Design View**.
2. Select **Insert → Page Number** from the menu.
3. Select the page format, position, and alignment options.
4. Click **OK**.

**To Insert the Date and/or Time:**
1. Display the report in **Design View**.
2. Select **Insert → Date and Time** from the menu.
3. Check or uncheck the **Date box** and select a formatting option.
4. Check or uncheck the **Time box** and select a formatting option.
5. Click **OK**.
Lesson 8-7: Understanding Report Sections

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 8-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word processing program to create a report for school or work you’re familiar with section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. Double-click the rptAnnualSales report to open it in Print Preview.

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 8-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word processing program to create a report for school or work you’re familiar with section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. Double-click the rptAnnualSales report to open it in Print Preview.

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 8-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word processing program to create a report for school or work you’re familiar with section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 8-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word processing program to create a report for school or work you’re familiar with section concept—you can add headers and footers to your documents that contain such information as the report name or page number.
Chapter Eight: Working with Reports

267

Quick Reference

To Resize a Report Section:
1. Display the report in Design View.
2. Click and drag the Section line up or down.

Understanding Report Sections:
• Be familiar with the various report sections described in Table 8-3: Report Sections.

Table 8-3: Report Sections

<table>
<thead>
<tr>
<th>Section Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Header</td>
<td>Contains text that appears at the top of the first page of a report, such as the name of the report.</td>
</tr>
<tr>
<td>Page Header</td>
<td>Contains text that appears at the top of each page of a report, such as the report's column headings.</td>
</tr>
<tr>
<td>Group Header</td>
<td>Used to place text, such as a group name, at the beginning of each group of records.</td>
</tr>
<tr>
<td>Detail</td>
<td>Contains text and the actual fields that are displayed for each record. This would be equivalent to the main body in a word processing document.</td>
</tr>
<tr>
<td>Group Footer</td>
<td>Used to place text and numeric summaries, such as totals or averages, at the end of each group of records.</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Contains text that appears at the bottom of each page of a report, such as page numbers.</td>
</tr>
<tr>
<td>Report Footer</td>
<td>Contains text that appears at the end of the last page of a report. Often also contains numeric summaries for the report, such as a grand total.</td>
</tr>
</tbody>
</table>
Lesson 8-8: Grouping and Sorting Records

Organizing records into logical groups often makes them easier to read and understand. For example, the second report in Figure 8-17 is grouped by the date field, so that you can quickly see how many sales occurred in a particular month. If you create a report using the Report Wizard (the preferred method), you specify which fields you want to use to group and/or sort your report by. If you’re modifying an existing report or creating a report from scratch you can use the Sorting and Grouping dialog box to create your groups. More importantly, if you use a Wizard to create a report for you, you can use the Sorting and Grouping dialog box to change the grouping and sorting options for the report.

1. **Open the rptEmployeeSales report in Design View.**
   In its current state the rptEmployeeSales report has Report Header, Page Header, Page Footer, and Report Footer sections, but it doesn’t have any grouping sections. To add a Grouping Section to a report you need to summon the Sorting and Grouping dialog box.

2. **Click the Sorting and Grouping button on the Report Design toolbar.**
   Access displays the Sorting and Grouping dialog box, which displays any fields that are currently being used for sorting or grouping your report, as shown in Figure 8-18. To add a section to group and/or sort by, select a blank row and select a field from the Field/Expression drop-down list. In this exercise you will use the Employee field to group and sort the report.
3. Click inside the first blank row and select Employee from the Field/Expression drop-down list.

You can also specify the order in which Access sorts the records by selecting the order you want to sort by (Ascending or Descending) from the Sort Order list. Since you want to sort the Employees field in Ascending order you can leave the Sort Order alone.

To make a Group Header or Group Footer, use the Group Properties settings at the bottom of the dialog box. You want to add a Group Header for the Employees field—here’s how to add one:

4. With the Employee Field/Expression still selected, click the Group Header list near the bottom of the dialog box and select Yes from the drop-down list.

Access adds an Employee Group Header to the report.

The order of the fields in the Sorting and Grouping dialog box is very important. The field in the first row is the first sorting/grouping level, the second row is the second sorting/grouping level, and so on. You want to group and sort your report by the Employee field then by the Date field, so you will have to rearrange the field order.

5. Click the Employee row selector, drag it above the Date row and release the mouse button.

Now that you have created the Group Header you need to specify what you want to appear in it—usually the field the Group Header is based on. In this report you will want to move the Employee text box control field from the Details section to the Employee Header Group section.

6. Close the Sorting and Grouping dialog box.

7. Cut the Employee field from the Detail section and paste it in the Employee Header section.

Let’s see how the modified report looks.

8. Click the View button to switch to Print Preview.

Access groups and sorts the report by the Employee field.

Table 8-4: Sorting and Grouping Properties

<table>
<thead>
<tr>
<th>Group Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Header</td>
<td>Specify whether you want the report to contain a header section for this group.</td>
</tr>
<tr>
<td>Group Footer</td>
<td>Specify whether you want the report to contain a footer section for this group.</td>
</tr>
<tr>
<td>Group On</td>
<td>Allows you to choose the size of the group. For example, if you’re using a date field to group a section, you can group each value by day, week, month, or year.</td>
</tr>
<tr>
<td>Group Interval</td>
<td>Allows you to choose the size of the interval from a drop-down list. You must have chosen an option other than Each Value from the Group On list.</td>
</tr>
<tr>
<td>Keep Together</td>
<td>No: Prints the group without keeping the group header, detail section, and group footer on the same page. Whole Page: Prints the group header, detail section, and group footer on the same page. With First Detail: Prints the group header on a page only if it can also print the first detail record.</td>
</tr>
</tbody>
</table>
Lesson 8-9: Creating Calculated Controls

Footers are most often used to summarize report information. For example, a Group Footer could total the number of harassing phone calls each telemarketer made and the Report Footer could calculate the number of harassing phone calls made by all telemarketers.

If you create a report using the Report Wizard (the preferred method), you specify which fields you want to summarize and the calculation you want to use to summarize them. Of course, you can always add your calculated control or calculated field to summarize information on an existing report. A calculated control displays totals and other arithmetic computations on a form or report. Table 8-5: Common Summary Functions describes the functions you will use most often to summarize your reports.

1. Make sure you have the modified rptEmployeeSales report you worked on in the previous lesson open in Design View.

   The section footer in which you place a calculated control is very important, as each footer section calculates/summarizes records differently:
   - **Group Footer:** Calculates all the records in a group.
   - **Page Footer:** Calculates all the records on the page.
   - **Report Footer:** Calculates all the records in the report.

   You want to add a calculated control to the Report Footer that will calculate the total sales for all records. First though, you will need to resize the Report Footer so that there is enough room to add such a control. Here’s how to change the size of a section.

2. **Click and drag the Report Footer section divider down a half-inch.**

   Now that you have enough room in the Report Footer you can add the calculated control. There are two ways that you can add a calculated control to a form or report:
   - Click the **Text Box** control on the Toolbox and click and drag where you want to add the control.
   - Copy an existing text box control, select the desired location and paste the copied text box control.
You can use either method, but the copy and paste method is a little faster and easier.

3. **Select the Total text box control in the Detail section** and click the copy button on the toolbar. **Click the Report Footer section divider and click the Paste button on the toolbar.**

Access pastes the copied control. Next you have to add an expression to the control.

4. **With the new Totals text box in the Report Footer still selected, click the Properties button on the toolbar.**

The Properties dialog box appears. You need to enter the expression in the Control Source property, which you can find on the Data tab.

5. **Click the Data tab, click in the Control Source box, type =SUM([Total]) and close the Properties dialog box.**

You're finished adding a calculated control that will total the total fields on the report.

Next you want to add another footer and calculated control that will total the total sales by employee. First you need to add an Employee Group Footer section to your report.

6. **Click the Grouping and Sorting button on the toolbar.**

The Grouping and Sorting dialog box appears.

7. **Click in the Employee Field/Expression box, click the Group Footer box, select Yes and then close the Sorting and Grouping dialog box.**

Because the Totals text box control you created in Steps 3-5 already contains the SUM expression you need you can simply copy and paste the control in the Group Footer.

8. **Copy the Total text box control in the Report Footer section, click the Employee Footer section divider and paste the control.**

You need to add some meaningful labels to your report. Often, it’s useful to add a calculated control that mixes some text with the current value of a field to produce an informative notice for the report.

9. **Copy the Total text box control in the Employee Footer section and paste it in same section. Change the Data Control Source property of the pasted control to ="Total for " & [Employee] and close the Properties dialog box.**

This expression will display the text “Total for” and the employee’s name. Let’s finish tidying up the report.

10. **Add a Totals: text label to the Report Footer section, then click and drag the three new calculated fields and text labels so that your report looks like the one in Figure 8-20.**

Let’s see how our report looks.

11. **Click the View button to switch to Print Preview. Scroll through the report and notice the calculated controls. When you’re finished save your changes and close the report.**

### Table 8-5: Common Summary Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Totals all the values listed in a field.</td>
<td>Sum([InvoiceTotal])</td>
</tr>
<tr>
<td>Maximum</td>
<td>Finds and displays the largest value listed in a field.</td>
<td>Max([InvoiceTotal])</td>
</tr>
<tr>
<td>Minimum</td>
<td>Finds and displays the smallest value listed in a field.</td>
<td>Min([InvoiceTotal])</td>
</tr>
<tr>
<td>Average</td>
<td>Calculates the average of all the values listed in a field.</td>
<td>Avg([InvoiceTotal])</td>
</tr>
<tr>
<td>Count</td>
<td>Counts how many values are listed in a field.</td>
<td>Count([InvoiceTotal])</td>
</tr>
</tbody>
</table>
Lesson 8-10: Working with Section Properties

When you want to fine-tune how a group or section works there are two different places to go:

- **The Sorting and Grouping dialog box**: Contains important sorting and grouping settings, such as if you want your report to display any Group Headers and/or Footers. To display the Group Properties dialog box click the Sorting and Grouping button on the toolbar.

- **The Section Properties dialog box**: Contains miscellaneous properties for each report section, such as the section’s background color. To display the properties or settings for a report section click the section divider line and then the Properties button on the toolbar, or right-click the section divider line and select Properties from the shortcut menu, or double-click the section divider line.

Some of the settings you might want to adjust might be the Group Interval property (especially for sections grouped by date fields) and the Force New Page property which tells Access to start a new page before or after each report section.

In this lesson you will learn how to tweak your report section settings.

1. **Double-click the rptSalesByMonth report to open it in Print Preview.**
   In this report Access uses the Date field to group records—Access creates a Date group for each Date value, or day. The report would be meaningful if Access grouped dates by month. Before we can change the report we need to switch to Design View.

2. **Click the View button on the toolbar to switch to Design View.**
   You can change the grouping interval to specify how records are grouped in a report in the Sorting and Grouping dialog box.

3. **Click the Sorting and Grouping button on the toolbar.**
   The Sorting and Grouping dialog box appears, as shown in Figure 8-21. The Group On property lets you specify how you want to group records. For example, you can use the Group On property to group a Date field by year.
   Let’s change the Date Group interval so that the report groups sales on a monthly basis.

4. **Click in the Date Field/Expression box, click in the Group On box and select Month from the list and then close the dialog box.**
   You won’t be able to see any of the grouping changes until you display the report in Print Preview—and we’ll do that in a minute.
Every report section has its own set of properties or settings that you can view and change. You can view the properties for a report section by double-clicking the section’s divider line.

5. **Double-click the Date Header section divider line.**
   
   Access displays the properties for the Date Header section, as shown in Figure 8-22.
   
   Table 8-6: Important Section Properties describes these options in more detail.

6. **Click the Format tab.**
   
   We want to change the background color of the section. Here’s how to do it.

7. **Click the Back Color box, click the **button, select a gray color** and then close the dialog box.**
   
   Let’s see how the modified report looks.

8. **Click the View button on the toolbar to display the report in Print Preview. Scroll through the report's pages and notice how the Date Section is now grouped by month.**

9. **Save your changes and close the report.**

<table>
<thead>
<tr>
<th>Table 8-6: Important Section Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Property</strong></td>
</tr>
<tr>
<td>Force New Page</td>
</tr>
<tr>
<td>New Row Or Col</td>
</tr>
<tr>
<td>Keep Together</td>
</tr>
<tr>
<td>Visible</td>
</tr>
<tr>
<td>Can Grow</td>
</tr>
<tr>
<td>Can Shrink</td>
</tr>
<tr>
<td>Repeat Section</td>
</tr>
<tr>
<td>Height</td>
</tr>
<tr>
<td>Back Color</td>
</tr>
<tr>
<td>Special Effect</td>
</tr>
</tbody>
</table>

Quick Reference

To Modify a Report's Section and Grouping Options:
1. Display the report in **Design View**.
2. Click the **Sorting and Grouping button** on the Report Design toolbar.

To Modify a Section's Properties:
1. Display the report in **Design View**.
2. Double-click the **Section line** for the section whose properties you want to view/modify.
Lesson 8-11: Creating Charts with the Chart Wizard

You already know what a chart is—charts illustrate data, relationships, or trends graphically. Like the saying “a picture is worth a thousand words” charts are often better at presenting information than hard-to-read numbers in a datasheet. Microsoft Access comes with a great built-in program for creating charts called Microsoft Graph. You can insert charts and graphs on forms and reports, and this lesson will show you how.

1. Click the Reports tab in the Database window and click the New button. The New Report dialog box appears.
2. Select Chart Wizard from the list and select qryCustomerTours from the Table or Query drop-down list and click OK. The first screen of the Chart Wizard appears. Here you have to tell the Wizard which fields you want to display on the chart.
3. Double-click the Tour Name field in the Available Fields list. The Tour Name field appears in the Selected Fields list.
4. Click Next. The Chart Wizard asks what type of chart you want to use to display your data, as shown in Figure 8-23. Table 8-7: Types of Charts and Graphs shows the more common charts and gives an explanation on how and when they are used.
5. Select the **Pie Chart** as shown in Figure 8-23 and click **Next**.
   Next the Chart Wizard asks how you want to lay out the data in your chart. You do this by dragging and dropping the data fields to the appropriate areas on the chart. Since we chose a simple pie chart everything is already correctly laid out for us.

6. **Click Next**.
   You can specify a chart title if you’re not thrilled with Microsoft Access’ imaginative suggestions. You can also specify if you want to include a legend with your chart.

7. **Click in the What title would you like for your chart? box and type Total Tours. Click Finish to create the pie chart.**
   Access creates the pie chart, shown in Figure 8-24.

8. **Exit Microsoft Access without saving any changes.**

### Table 8-7: Types of Charts and Graphs

<table>
<thead>
<tr>
<th>Chart or Graph Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Column charts are used when you want to compare different values vertically side-by-side. Each value is represented in the chart by a vertical bar. If there are several values in an item, each value is represented by a different color.</td>
</tr>
<tr>
<td>Bar</td>
<td>Bar charts are just like column charts, except they display information in horizontal bars rather than vertical columns.</td>
</tr>
<tr>
<td>Line</td>
<td>Line charts are used to illustrate trends. Each value is plotted as a point on the chart and is connected to other values by a line. Multiple items are plotted using different lines.</td>
</tr>
<tr>
<td>Area</td>
<td>Area charts are the same as line charts, except the area beneath the lines is filled with color.</td>
</tr>
<tr>
<td>Pie</td>
<td>Pie charts are useful for showing values as a percentage of a whole. The values for each item are represented by different colors.</td>
</tr>
<tr>
<td>Scatter</td>
<td>Scatter charts are used to plot clusters of values using single points. Multiple items can be plotted by using different colored points or different point symbols.</td>
</tr>
<tr>
<td>Combination</td>
<td>Combination charts combine two different types of charts together, for example, a combination chart might contain both a column chart and a line chart.</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Insert a Chart to a Form or Report:**

1. Display the report in **Design View**.
2. Select **Insert → Chart** from the menu.
3. Select **Chart Wizard** from the list and select the table or query you want to chart from the Table or Query drop-down list. Click **OK** to continue.
4. Double-click each field you want to add to the chart. Click **Next** to continue.
5. Click the chart type you want and click **Next** to continue.
6. Make any layout modifications to the chart. Click **Next** to continue.
7. If you want the chart to change from record to record, select the fields that link the document and the chart. Click **Next** to continue.
8. Enter a chart name and click **Finish**.
Chapter Eight Review

Lesson Summary

Creating a Report with AutoReport

- To Create a Report with AutoReport: From the Database window, click the Forms icon in the Objects bar, click the New button and select one of the either AutoForm: Columnar or AutoForm: Tabular. Click the table or query you want to use for the report from the drop-down list and Click OK.

Modifying a Report

- To Modify a Report: From the Database window, click the Report icon in the Objects bar, click the report you want to modify and click Design or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- To Add a Field to a Form: Display the report in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the report.
- To Delete a Field or Control: Click the field or control to select it, then press <Delete>.

Moving and Sizing Controls

- To Resize a Control: Click the control to select it, grab one of its sizing handles, and drag and release the mouse button when the control reaches the desired size. Hold down the <Shift> key while dragging to maintain the control’s proportions while resizing it.
- To Move a Control: Click the control and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.
- To Move a Text Box or Text Label Independently of Each Other: Position the pointer over the upper-left sizing handle of the control until it changes to a , then click and drag the control.

Adjusting Page Margins and Orientation

- To Adjust Margins: Select File → Page Setup from the menu, click the Margins tab, and adjust the appropriate margins.
- To Change a Page’s Orientation: Select File → Page Setup from the menu, and click the Page tab. In the Orientation section, select either the Portrait or Landscape option.

Adding Page Numbers and Dates

- To Add Page Numbers: Display the report in Design View, select Insert → Page Number from the menu, select the page format, position, and alignment options, and click OK.
• To Insert the Date and/or Time: Display the report in *Design View*, select *Insert → Date and Time* from the menu, check or uncheck the Date box and select a formatting option. Check or uncheck the Time box, select a formatting option, and click OK.

Understanding Report Sections

• To Resize a Report Section: Display the report in *Design View* and click and drag the Section line up or down.

Grouping and Sorting Records

• To Group Records: Display the report in *Design View*, Click the Sorting and Grouping button on the Report Design toolbar. Click the Field/ Expression box, click the drop-down list and select a field for grouping records. Click the corresponding Sort Order box, click the drop-down list, select the desired sort order and select any Group Properties you want to use in the Group Properties area. Repeat these steps for each Field/Expression you want to use to group and sort your data. Close the Sorting and Grouping dialog box when you’re finished.

Creating Calculated Controls

• To Create a Calculated Control: Display the form in *Design View*, select the control and click the Properties button on the toolbar. Click the Data tab and click in the Control Source box, type the expression and then close the Properties dialog box.

Working with Section Properties

• To Modify a Report’s Section and Grouping Options: Display the report in *Design View*, and then click the Sorting and Grouping button on the Report Design toolbar.

• To Modify a Section’s Properties: Display the report in *Design View* and double-click the Section line for the section whose properties you want to view/modify.

Creating Charts with the Chart Wizard

• To Insert a Chart to a Form or Report: Display the report in *Design View*, select *Insert → Chart* from the menu. Select Chart Wizard from the list and select the table or query you want to chart from the Table or Query drop-down list. Click OK to continue. Double-click each field you want to add to the chart. Click Next to continue, click the chart type you want and click Next to continue. Make any necessary layout modifications to the chart, and click Next to continue. If you want the chart to change from record to record, select the fields that link the document and the chart. Click Next to continue, enter a chart name, and click Finish.

Quiz

1. Which of the following statements about the AutoReport Wizard is NOT true?
   A. The AutoReport Wizard is the fastest and easiest way to create a report in Microsoft Access.
   B. The AutoReport Wizard can only create two types of reports: Columnar and Tabular.
   C. Reports created with the AutoReport Wizard usually come out looking sharp and professional and don’t require further clean-up work.
   D. The AutoReport Wizard can only create reports based on a single table or query.
2. Which of the following statements is NOT true?
   A. The Field List displays all the fields from a report’s underlying table or query.
   B. Click the Field List button on the Toolbar to display the Field List.
   C. You can add fields to a report by dragging them from the Field List onto the report.
   D. The Field List displays all the fields from every table in a database.

3. Controls and their corresponding text labels cannot be moved independently of one another. (True or False?)

4. Which of the following statements is NOT true?
   A. You can move a control to a different location on a report by clicking, dragging, and dropping the control.
   B. To add a page number to a report, select View \(\rightarrow\) Header/Footer from the menu and click the Page Number button on the Header/Footer toolbar.
   C. You can resize a report by clicking and dragging the right edge of the report.
   D. You can resize a control by clicking the control to select it, grabbing one of its sizing handles, and dragging and releasing the mouse button when the control reaches the desired size.

5. You want a report to group and total sales by month. Where would you place a calculated control containing the following expression
   \[ \text{=SUM([Sales])} \] to calculate the totals for each month?
   A. In the Month Group Footer section.
   B. In the Page Footer section.
   C. In the Report Footer section.
   D. In the Summary section.

6. Which of the following is NOT a report section?
   A. Report Header section.
   B. Page Header section.
   C. Summary section.
   D. Details section.

7. The only way to sort a report’s records is to base the report on a query, which actually does the work of sorting the records. (True or False?)

8. Which of the following expressions is incorrect?
   A. \[ \text{=Total for: [Employee]} \]
   B. \[ \text{=[InvoiceDate]+30} \]
   C. \[ \text{=[LastName]}&" \&"[FirstName] \]
   D. \[ \text{=[Units]}*[UnitPrice] \]

9. You want to track the progress of the stock market on a daily basis. Which type of chart should you use?
   A. Line chart.
   B. Column chart.
   C. Row chart.
   D. Pie chart.
Chapter Eight: Working with Reports

10. How do you adjust a page’s margins?
   A. Click and drag the edge of the page to where you want the margin set.
   B. Select Format → Page Setup from the menu, click the Margins tab and adjust the margins.
   C. Select File → Page Setup from the menu, click the Margins tab, and adjust the margins.
   D. Click the Margins button on the Formatting toolbar.

11. How can you view a report’s sorting and grouping options?
   A. Select Format → Sorting and Grouping from the menu.
   B. Double-click the Report Selector box in the upper-left corner of the report.
   C. Select File → Page Setup from the menu and click the Sorting and Grouping tab.
   D. Click the Sorting and Grouping button on the toolbar.

12. What is the procedure for selecting multiple controls on a report?
   A. Press and hold down the <Shift> key as you click each object that you want to select.
   B. Use the arrow pointer (↑) to draw a box around the object that you want to select.
   C. If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.
   D. All of these.

Homework

1. Open the Homework database.
2. Use AutoReport to create and save a tabular report named Customers, using the Customers table as the underlying data source.
3. Delete the DOB field from the report.
4. Change all of the report’s margins to a half-inch.
5. Sort the information on the report by DOB.
6. Save your changes and close the Homework database.

Quiz Answers

1. C. The AutoReport Wizard can create reports in record time, but they aren’t usually well-organized or professional looking.
2. D. The Field List only displays fields from a form or report’s underlying table or query.
3. False. You can click and drag the upper-left sizing handle to move a label or control independently of one another.
4. B. This procedure will let you add page numbers in Microsoft Word, but not in Microsoft Access.
5. A. You would want the calculated control in the Month Group Footer section to total monthly sales.
6. C. Although you can summarize information in a report section, there isn’t actually a section called a Summary section.
7. False. Although you can sort a report using a query, you can also simply click the Sorting and Grouping button on the toolbar and specify the field you want to use to sort the report.

8. A. This expression is missing the quotation marks (") and the ampersand (&) symbol. The corrected expression would be ="Total for: ",&[Employee].

9. A. Line charts are used to illustrate trends. If you used the other three chart types to track the stock market, there would be too many data points.

10. C. You adjust a page’s margins by selecting File → Page Setup from the menu, clicking the Margins tab, and adjusting the margins.

11. D. Click the Sorting and Grouping button on the toolbar to view a report’s sorting and grouping options.

12. D. All of these are procedures for selecting multiple controls on a report.
Chapter Nine: Formatting Forms and Reports

Chapter Objectives:

- Format fonts using the Formatting toolbar
- Change text alignment
- Use AutoFormat to quickly format forms and reports
- Change the color of text, objects, and borders
- Apply 3-D effects to the controls on forms and reports
- Use the Format Painter to copy control formatting options
- Add pictures and lines to forms and reports
- Align controls with one another
- Format a control by changing its Formatting Properties

Chapter Task: Apply formatting options to existing forms and reports

Forms and reports created with a Microsoft Access Wizard are informative and functional, but they are rarely designed well. Some of the forms and reports set up by the Form Wizard or Report Wizard are even downright ugly. Don’t worry—this chapter will help you fix the design of your forms and reports.

This chapter guides you through the process of creating sharp-looking forms and reports that have colorful fonts, neat-looking borders, even controls with 3-D effects. This chapter explains how to format your form and reports to make them more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a control. This chapter also describes how you can add pictures and graphics to your forms and reports.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify forms and reports in Design View.
Lesson 9-1: Formatting Fonts with the Formatting Toolbar

You can emphasize text on a form or report by making the text darker and heavier (bold), slanted (italics), larger, or in a different typeface (or font). The Formatting toolbar makes it easy to apply character formatting. The Formatting toolbar includes buttons for applying the most common formatting options.

1. Start Microsoft Access, open the Lesson 9 database, click the Reports icon in the Objects bar and double-click the rptTourSales report.

   Access displays the rptTourSales report in Print Preview. A quick look at this report is all you need to realize that the Report Wizard could use a few remedial graphical design classes. Fortunately, a little moving, resizing, and formatting will fix all of the report’s design problems.

2. Click the View button on the Report Design toolbar to switch to Design View.

   In order to format a control you must first select it. The Tour Name text box in the TourName Header needs to stand out a little more from the rest of the report.

3. Click the TourName text box control in the TourName Header to select it.

   Handles (■) appear around the text box control, indicating that the control is selected. Once you have selected a control you can format it.

4. Click the Font list arrow (▼) on the Formatting toolbar, then scroll to and select Arial from the list of fonts.

   The text in the Text Name text box control appears in Arial font. Arial and Times New Roman are two of the most commonly used fonts in Windows.
You can also use the Formatting toolbar to change the size of a font. Font sizes are measured in points (pt.), which are 1/72 of an inch. The larger the number of points, the larger the font.

5. **With the Tour Name text box still selected, click the Font Size list arrow ( ▮ ) on the Formatting toolbar and select 14, as shown in Figure 9-2.**

   The Text Name text box appears in a larger font size (14 point type instead of the previous 11 point type.) Wow! That font formatting really makes the title stand out from the rest of the report, doesn’t it?

   **NOTE:** When you change a control’s font size you will often have to resize the control so that it can properly display its contents.

   All the column heading labels in the Page Header section need to be emphasized as well. You could select and format each label individually, but it’s much faster to select and format all of them at the same time. If the controls you want to format are arranged along a horizontal line, you can click to the left of the controls, in the vertical ruler, to select all of them.

6. **Select all the labels in the Page Header section by clicking in the Vertical Ruler to the left of the TourName label.**

   Access selects everything to the right of where you clicked the mouse. Let’s apply boldface formatting to the selected text labels.

7. **Click the Bold button on the Formatting toolbar.**

   The selected controls appear in bold.

8. **Click the Save button to save your changes to the report.**

   **Table 9-1: Examples of Common Font Types and Sizes**

<table>
<thead>
<tr>
<th>Common Font Types</th>
<th>Common Font Sizes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
<td>Arial 8 point</td>
</tr>
<tr>
<td>Comic Sans MS</td>
<td>Arial 10 point</td>
</tr>
<tr>
<td>Courier New</td>
<td>Arial 12 point</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Arial 14 point</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Change Font Size:**
- Select the control and select the pt. size from the **Font Size list** on the Formatting toolbar.

**To Change Font Type:**
- Select the control and select the font from the **Font Style list** on the Formatting toolbar.

**To Format Text with Bold, Italics, or Underlining:**
- Select the control and click the **Bold**, **Italics**, or **Underline button** on the Formatting toolbar.
Lesson 9-2: Changing Text Alignment

This lesson explains how to align a control’s text to the left, center, or right. Figure 9-3 gives a better idea of what the various alignments look like. Alignment only affects what’s inside of a control: If you apply center formatting to a text box, Access will center the text inside the text box—it won’t center the text box control on the form or report. If you want to align a control to the left, center, or right of a form or report, you’ll have to do it the old-fashioned way—by clicking and dragging the control.

1. Make sure that the rptTourSales report is open in Design View. Again, you first need to select the control you want to format.

2. Select the Date text label in the Page Header and click the Center button on the Formatting toolbar.

Access centers the text inside the Date text label. Easy isn’t it? Let’s try aligning one more control.

3. Click the TourName text label in the Page Header and click the Align Right button on the Formatting toolbar.

Access right-aligns the text inside the Tour text label.

4. Click the Save button to save your changes to the report.

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Left</td>
<td>Left</td>
<td>Aligns text to the left side of the control.</td>
</tr>
<tr>
<td>Center</td>
<td>Center</td>
<td>Centers text in a control.</td>
</tr>
<tr>
<td>Align Right</td>
<td>Right</td>
<td>Aligns text to the right side of the control.</td>
</tr>
</tbody>
</table>
Lesson 9-3: Using AutoFormat

You’ve just finished creating a report using the Report Wizard when you suddenly realize that you hate how it looks! Don’t worry—you can apply a new design to your forms and templates at any time with the AutoFormat command. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to form or report. AutoFormat is a great feature if you want your forms and reports to look sharp and professional but don’t have the time to format them yourself.

1. **Make sure that the rptTourSales report is open in Design View.**
   Here’s how to format a report using AutoFormat:

2. **Click the AutoFormat button on the Formatting toolbar.**
   The AutoFormat dialog box appears, as shown in Figure 9-5. The present formats are listed in the AutoFormat list. Yep, they’re the same choices as you get in the Report or Form Wizard. You can see what a format looks like by selecting it and looking at the sample area in the dialog box.

3. **Click the Options button.**
   The AutoFormat dialog box expands to show three check boxes. You can control the type of formatting that is applied by checking or unchecking any of the boxes. If you want AutoFormat to skip one of the formatting categories, simply uncheck the appropriate box.

4. **Select the Corporate option from the AutoFormat list and click OK.**
   The dialog box closes and the report is formatted with the Corporate formatting options.

5. **Click the Save button to save your changes and then close the rptTourSales report.**
Lesson 9-4: Changing Colors

In this day of color, laser, and inkjet printers; and high-resolution 21-inch monitors, choosing an appropriate color for your report or form is an important formatting decision. When used tastefully, colors can make your forms and reports look more visually attractive. You can add color to lines, text, rectangles—even to the background of your headers and footers!

In this lesson, you will learn how to use the color buttons on the Formatting toolbar to apply color to your reports and forms.

1. **Click the Forms tab and open the frmCustomers form in Design view.**
   
   There are three color buttons on the Formatting toolbar—each color button applies color to a different element. It can be a little confusing knowing which color button to use at first, so you’ll want to refer to Table 9-3: Color Buttons on the Formatting Toolbar until you get the hang of it.

2. **Click the Customers text label in the Form Header, click the Font/Fore Color button arrow on the Formatting toolbar and select a yellow color.**
   
   You can also apply color to the sections of a report or form.

3. **Click the Form Header section divider, click the Fill/Back Color button arrow on the Formatting toolbar and select a dark blue color.**

<table>
<thead>
<tr>
<th>Color Button</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Fill/Back Color" /></td>
<td>Date: 5/1/1992</td>
<td>Applies color to the background of the selected control(s).</td>
</tr>
<tr>
<td><img src="image" alt="Font/Fore Color" /></td>
<td>Date: 5/1/1992</td>
<td>Applies color to the text in the selected control(s).</td>
</tr>
<tr>
<td><img src="image" alt="Line/Border Color" /></td>
<td>Date: 5/1/1992</td>
<td>Applies a color or makes transparent the line or border of the selected control(s).</td>
</tr>
</tbody>
</table>
Lesson 9-5: Applying Special Effects

You can apply special effect formatting to the controls in your forms and reports to give them a polished, high-tech appearance. For example, you can give a form a three-dimensional look by applying a sunken or raised effect to its controls. Applying special effect formatting is pretty straightforward: Simply select the controls you want to format and then select one of the six special effect options listed in Table 9-4: Available Special Effect Options from the Special Effect button list.

1. **Make sure that the frmCustomers form is open in Design view.**
   Normally you will want to apply special effect formatting to both a control and its corresponding text label, so you will have to select both controls using one of the multiple selection techniques you’ve (hopefully) learned.

2. **Click the CustomerID text box control to select it, then hold down the <Shift> key as you click the CustomerID text label.**
   You’re ready to apply a special effect to both controls.

3. **Click the Special Effect button arrow on the Formatting toolbar and select the Raised effect.**

Table 9-4: Available Special Effect Options

<table>
<thead>
<tr>
<th>Special Effect</th>
<th>Example</th>
<th>Special Effect</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flat</td>
<td>Date: 5/1/1992</td>
<td>Raised</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Sunken</td>
<td>Date: 5/1/1992</td>
<td>Etched</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Shadowed</td>
<td>Date: 5/1/1992</td>
<td>Chiseled</td>
<td>Date: 5/1/1992</td>
</tr>
</tbody>
</table>
Lesson 9-6: Using the Format Painter

If you find yourself applying exactly the same formatting to several controls repeatedly, the Format Painter is the tool for you. The Format Painter allows you to copy the formatting attributes from one control and then apply them to another. Sound confusing? It won’t once you have finished this lesson.

1. Make sure that the frmCustomers form is open in Design view.
   First you need to select the control whose formatting attributes you want to copy, or else format a control so that you can copy its formatting—and that’s what we’ll do in the next steps.

Figure 9-8
Use the Format Painter to copy formatting from one control to another.

1. Select the control whose formatting you want to copy and click or double-click the Format Painter button.
2. Click the control where you want to paste the copied formatting attributes.

The copied formatting is applied to the destination control.
2. Click the LastName text box control to select it.
   We want to format this control so that we can copy its formatting attributes and paste them to other controls on the form.

3. Click the Font/Fore Color button arrow on the Formatting toolbar and select a red color, then click the Bold button on Formatting toolbar, and finally click the Special Effect button arrow on the Formatting toolbar and select the Raised effect.
   The control is now formatted with red text and a raised effect.
   It took some work to apply that formatting, didn’t it? Now imagine you want to format all the controls on the form with the same formatting options. Instead of doing all that formatting, you can use the Format Painter tool to copy the formatting from LastName text box control, then paste or apply the copied formatting to the other controls on the form. First, you need to select the control with the formatting you want to copy and then do one of the following:
   - **Single Click the Format Painter Button**: Copy and apply the formatting to a single control.
   - **Double-Click the Format Painter Button**: Copy and apply the formatting to multiple controls. Click the Format Painter button when you’re finished pasting the formatting.

Since we want to paste the LastName text box control’s formatting to several controls we’ll double-click the Format Painter button.

4. With the LastName text box control still selected, double-click the Format Painter button on the toolbar.
   Notice the pointer changes to a [image]. Next, you need to paste, or apply the copied formatting.

5. Click the Phone text box control with the Format Painter ([image]).
   The Format Painter applies the copied formatting to the Phone text box control, saving you some time and work if you had manually formatted the control. Since we double-clicked the Format Painter the pointer remains a [image] so that we can paste the copied formatting to multiple controls.

6. Click the FirstName text box control with the Format Painter ([image]).
   When you’re finished with the Format Painter, click the Format Painter button to switch the pointer back to an ordinary selection arrow.

7. Click the Format Painter button on the Formatting toolbar to stop pasting formatting attributes.
   You’re finished with this lesson so…

8. Close the frmCustomers form without saving any of your changes.

---

Quick Reference

To Copy Formatting with the Format Painter:
1. Select the control with the formatting options you want to copy.
2. Click the Format Painter button on the Toolbar.
3. Select the control where you want to apply the copied formatting.

To Copy Selected Formatting to Several Locations:
1. Select the control with the formatting options you want to copy.
2. Double-click the Format Painter button.
3. Select the controls where you want to apply the copied formatting.
4. Click the Format Painter button when you’re finished.
Lesson 9-7: Adding Pictures and Lines

Pictures, graphics, and illustrations can make your reports more professional looking. This lesson explains how to insert clip art and graphics to your reports. You can insert graphics and pictures created with graphics programs such as Microsoft Paint (which comes with Windows), scanned pictures, or graphics from a clip art library.

1. Make sure that you have the rptCustomers report open in Design view.

Here’s how to insert a picture or graphic onto a report (this works for forms too!).

2. Click the **Image button** on the Toolbox.

The pointer changes to a **️**. You use this pointer to determine where you want to place the image.
3. Click and drag the + pointer in the report heading down and to the right about an inch and a half, as shown in Figure 9-9.
   As soon as you finish clicking and dragging the Insert Picture dialog box appears, as shown in Figure 9-10. You need to specify the name and location of the graphic file you want to insert.

4. Browse to your Practice folder.
   All the graphic files located in your practice folder appear in the file window.

5. Select the Plane file.
   You can display a preview of the graphic in the left side of the Insert Picture dialog box by clicking the list and selecting Preview.

6. Click OK to insert the Plane graphic.
   Access inserts the plane picture on the report.

7. Click the Line button on the Toolbox.
   The pointer changes to a line draw tool. Unless you actually want to draw a diagonal line, hold down the <Shift> key as you click and drag to draw a straight line.

8. Position the + pointer in the far left side of the top of the Detail Header (just above the LastName text box). Click and hold down the <Shift> key as you drag the + pointer to the far right edge of the report.
   More than likely your screen will not be wide enough to display the entire report—don’t worry, simply drag the + pointer past the right edge of the screen to automatically scroll to the right.
   Let’s see how our report looks.

9. Click the View button to view the report in Print Preview.
   Notice the line you added appears not once, but under every record! That’s because you added the line to the report’s details section, which prints for every record in the report.
   We’ll learn more about report sections in the next lesson.

10. Save your changes and close the report.
    You can also use this technique to add pictures to your forms. Here’s a list of some of the types of graphic formats that you can use in Access:

### Table 9-5: Common Graphic File Formats

<table>
<thead>
<tr>
<th>Format</th>
<th>File Size</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMP</td>
<td>Large</td>
<td>Also known as a bitmap, this is a generic graphics format used by Paintbrush and many other programs.</td>
</tr>
<tr>
<td>CGM</td>
<td>Small</td>
<td>Clip art pictures often come in Computer Graphics Metafile format.</td>
</tr>
<tr>
<td>GIF</td>
<td>Small</td>
<td>Picture file format commonly used on the Internet.</td>
</tr>
<tr>
<td>JPG</td>
<td>Small</td>
<td>Digital photographs are usually saved as JPEG files. Because of its small size JPEG files are also commonly used on the Internet.</td>
</tr>
<tr>
<td>WMF</td>
<td>Small</td>
<td>Another file format used for clip art pictures.</td>
</tr>
<tr>
<td>TIF</td>
<td>Large</td>
<td>A file format used by scanners, fax programs, and some drawing programs.</td>
</tr>
</tbody>
</table>

---

Quick Reference

**To Insert a Graphic:**
1. Click the Image button on the Toolbox.
2. Move the + pointer onto the form or report, then click and drag to draw a rectangle placeholder for the graphic.
3. Select the graphic file you want to insert and click OK.

**To Draw a Line:**
1. Click the Line button on the Toolbox.
2. Move the + pointer onto the form or report, then click and drag to draw the line.
   - Hold down the <Shift> key as you drag to draw a straight line.
Lesson 9-8: Aligning Controls with One Another

Forms and reports that have controls scattered randomly about them look terrible. The Align command, located under the Format menu, aligns controls relative to one another. You can align controls so that they are lined up with one another or spaced equally apart from one another. This lesson will give you some practice aligning controls with the Align command.

1. Select the controls you want to align by holding down the <Shift> key as you click each control.

2. Select Format → Align from the menu and select an alignment option.

The objects are aligned with one another.
1. **Open the rptEmployeeSales report in Design view.**
   Someone sure was sloppy when they created this report—it’s controls are all over the place!
   First you need to select the controls you want to align with one another. There are three ways to select more than one control:
   - Press and hold down the <Shift> key as you click each control that you want to select.
   - Use the arrow pointer (↑) to draw a box around the controls that you want to select. Point to a location above and to the left of the controls that you want to select, and click and drag the mouse down and to the right until the box surrounds all the controls. When you release the mouse button, all the controls in the box will be selected. The disadvantage of this method is that it’s not as selective as using the <Shift> + click method.
   - If the controls you want to select are aligned along a horizontal line, click to the left of the objects in the vertical ruler to select every control to the right of the ruler.

2. **Hold down the <Shift> key as you select the Employee text label and Employee text box control as shown in Figure 9-11.**
   Now you can align the selected controls with each other. Here’s how:

3. **Select Format → Align → Left from the menu.**
   The Employee text box control is left aligned with the Employee text label. Click anywhere outside the Employee controls to deselect them.
   Next let’s try vertically aligning two controls—the procedure is almost the same.

4. **Hold down the <Shift> key as you select the Employee text box control and Date text box control.**
   Now let’s vertically align the controls with each other.

5. **Select Format → Align → Top from the menu.**
   Access vertically aligns the two controls with each other.
   You can also quickly adjust the amount of horizontal or vertical space between controls by selecting the controls and then selecting a command from either the Horizontal Spacing or Vertical Spacing submenu under the Format menu. Click anywhere outside the Employee and Date controls to deselect them.
   Move on to the next step and we’ll adjust the amount of space between the controls on the report.

6. **Hold down the <Shift> key as you click the Vertical Ruler to the left of the text labels in the Report Header. Keep holding the <Shift> key and click the Vertical Ruler to the left of the fields in the Details Section.**
   You’ve selected all the text labels in the Report Header and all the fields in the Details section. Here’s how to adjust the spacing between the selected controls with just a few quick clicks of the mouse.

7. **Select Format → Horizontal Spacing → Make Equal from the menu.**
   Access evenly distributes the selected controls.

8. **Click and drag the Page Footer divider up to reduce the amount of empty space in the Details section.**
   You’re finished!

9. **Save your changes and close the form.**
   Give yourself a pat on the back when you have finished this lesson—probably less than ten percent of all Access users know this fast and easy method of aligning controls.

---

**Quick Reference**

**To Select Multiple Controls:**
- Press and hold down the <Shift> key as you click each object that you want to select.

Or...
- Use the arrow pointer (↑) to draw a box around the objects that you want to select.

Or...
- If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

**To Align Objects with Each Other:**
1. Follow the above steps to select the objects you want to align.
2. Select Format → Align and select an alignment option from the menu.
Lesson 9-9: Changing a Control's Formatting Properties

The Formatting toolbar is great for quickly applying the most common formatting options to the controls on your forms and reports, but it doesn’t offer every formatting option available. To see and/or use every possible formatting option you need to view the control’s Formatting Properties. Each type of control has its own set of formatting properties—for example, a line control has a Border Style property, which determines if the line should be solid, dashed, or dotted.

To display the Formatting Properties for a control do one of the following:
- Select the control and click the Properties button on the toolbar.
- Right-click the control and select Properties from the shortcut menu.
- Double-click the control
- Select the control and select View → Properties from the menu.

…and then click the Format tab if necessary. The more common Formatting Properties are listed in Table 9-6: Common Formatting Properties. You might want to review the Working with Tables and Fields chapter as well, which contains information on formatting fields.

This lesson will give you some practice working with a control’s Formatting Properties.

1. **Make sure that you have the rptTourSales report open in Design View.**
   For this exercise we’ll view and change the Formatting Properties of the dark red line in the report’s Page Header.

2. **Click the dark red line in the Page Header to select it, then click the Properties button on the toolbar. Click the Format tab if necessary.**
   The Formatting Properties for the red line appear, as shown in Figure 9-12. There’s not much to an ordinary line, so its Formatting Properties are rather limited. One Formatting Property that we can change is the line’s Border Style property.
3. Click in the **Border Style box** click the arrow and select **Dashes** from the list.

   The line changes from a solid line to a dashed line. Let’s make one more formatting change while the Properties dialog box is still open.

4. **With the line still selected and the Properties dialog box still open, click the Border Width button arrow and select 5 pt from the list.**

   The width of the line changes to three five points.

5. **Exit Microsoft Access without saving any of your changes.**

| **Table 9-6: Common Formatting Properties** |
| **Property** | **Description** |
| Format | Use to customize the way numbers, dates, times, and text are displayed. |
| Decimal Places | Specify the number of decimal places displayed (for numeric values). |
| Visible | Used to show or hide a control. Useful if you want to use information on a form without it being visible. |
| Hide Duplicates | Use to hide a control on a report when its value is the same as in the preceding record. For example, on a report listing suppliers and their products, each supplier’s name can appear once for each group of products, rather than once for each product. |
| Can Grow | Specify if a control on a report can expand vertically when printed to fit text. |
| Can Shrink | Specify if a control on a report can shrink vertically when printed to eliminate blank lines. |
| Left | The horizontal position of a control. |
| Top | The vertical position of a control. |
| Width | The width of a control. |
| Height | The height of a control. |
| Back Color | Determines the color of a control. Click the button to select a color from a palette. |
| Special Effect | Applies the specified 3-D effect to the control. |
| Border Style | Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc. |
| Border Color | Determines the color of a control’s border. |
| Border Width | Determines the width of a control’s border (in points). |
| Fore Color | Determines the color of text in a control or the fill color of a drawing object. |
| Font Name | Determines the font used in a control (such as Arial or Times New Roman). |
| Font Weight | Determines the thickness (boldface) of text in a control. |
| Font Italic | Specify if you want the text in a control to appear in italics. |
| Font Underline | Specify if you want the text in a control to be underlined. |
| Alignment | Specify how text should be aligned in a control. |
Chapter Nine Review

Lesson Summary

Formatting Fonts with the Formatting Toolbar

- **To Change Font Size:** Select the control and select the pt. size from the **Font Size list** on the Formatting toolbar.

- **To Change Font Type:** Select the control and select the font from the **Font Style list** on the Formatting toolbar.

- **To Format Text with Bold, Italics, or Underlining:** Select the control and click the **Bold**, **Italics**, or **Underline button** on the Formatting toolbar.

Changing Text Alignment

- **To Change Text Alignment:** Select the control and click the **Align Left**, **Center**, or **Align Right button**.

Using AutoFormat

- **To Format a Form or Report with AutoFormat:** Display the form or report you want to format in Design view, click the **AutoFormat button** on the Formatting toolbar, select one of the AutoFormats from the list and click **OK**.

Changing Colors

- **To Change a Control’s Colors:** Select the control and click one of the following buttons on the Formatting toolbar:
  - Fill/Back Color
  - Font/Fore Color
  - Line/Border Color

Applying Special Effects

- **To Apply a Special Effect to a Control:** Select the control, click the **Special Effect button** and select the desired special effect.

Using the Format Painter

- **To Copy Formatting with the Format Painter:** Select the control with the formatting options you want to copy, click the **Format Painter button** on the toolbar, and select the control where you want to apply the copied formatting.

- **To Copy Selected Formatting to Several Locations:** Select the control with the formatting options you want to copy, double-click the **Format Painter button**, and select the controls where you want to apply the copied formatting. Click the **Format Painter button** when you’re finished.
Adding Pictures and Lines

- **To Insert a Graphic:** Click the Image button on the Toolbox, move the pointer onto the form or report, then click and drag to draw a rectangle placeholder for the graphic. Select the graphic file you want to insert and click OK.

- **To Draw a Line:** Click the Line button on the Toolbox, move the pointer onto the form or report, then click and drag to draw the line.

Aligning Controls with One Another

- **To Select Multiple Controls:** Do any of the following:
  - Press and hold down the Shift key as you click each object that you want to select.
  - Use the arrow pointer (↑) to draw a box around the objects that you want to select.
  - If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

- **To Align Objects with Each Other:** Follow the above steps to select the objects you want to align, then select Format → Align and select an alignment option from the menu.

Changing a Control’s Formatting Properties

- **To Format a Control using the Properties Dialog Box:** Display the form in Design View, select the control and click the Properties button on the toolbar, click the Format tab and make the desired formatting changes.

Quiz

1. Fonts are measured in points. The larger the number of points, the smaller the size of the font. (True or False?)

2. You select a control and then click the Left Align button on the Formatting toolbar. What happens?
   A. The control is aligned to the left side of the form or report.
   B. Nothing – the Alignment buttons on the Formatting toolbar are used to determine the position of the form or report on the screen.
   C. The text inside the control is aligned to the left side of the control.
   D. Nothing – you must also select the control that you want to use to align the selected control with.

3. AutoFormat automatically applies formatting options as you type. (True or False?)

4. The Fill/Back Color button on the Formatting toolbar applies color to:
   A. The text in the selected control.
   B. The background of the selected control.
   C. The border of the selected control.
   D. All aspects of the control.
5. What does the Special Effect button on the Formatting toolbar do?
   A. It applies a 3-D effect to a selected control.
   B. It lets you select a transitional effect for how a form opens and closes.
   C. It lets you add animation to your forms and reports to make them more entertaining and amusing.
   D. None of the above.

6. Which of the following are reasons why you might want to format a control using the Properties dialog box instead of the Formatting toolbar? (Select all that apply.)
   A. You want to show off your Microsoft Access expertise and do things the hard way.
   B. The Properties dialog box offers every formatting option available for the control—something the Formatting toolbar doesn’t have.
   C. The Properties dialog box gives you greater control over how a control is formatted.
   D. You can change the language used in a control using the Properties dialog box. For example, you could select Spanish or French instead of English.

7. You want to insert a graphic of your company’s logo on a report. How can you do this?
   A. You can’t—Microsoft Access won’t let you insert graphic files.
   B. Click the Image button on the Toolbox and drag on the report to draw a place holder for the graphic.
   C. Select Insert → Picture from the menu.
   D. Select Tools → Insert Picture from the menu.

8. How can you align several controls with each other?
   A. Select the controls by holding down the <Shift> key as you click each object, then select Format → Align and select an alignment option from the menu.
   B. Select the controls by holding down the <Ctrl> key as you click each object, then select Format → Align and select an alignment option from the menu.
   C. Select the controls by holding down the <Ctrl> key as you click each object, then click the appropriate alignment button on the Drawing toolbar.
   D. Select the controls by holding down the <Shift> key as you click each object, then click the appropriate alignment button on the Drawing toolbar.

Homework

1. Open the Homework database and open the Test Answers form in Design View.
2. Use AutoFormat to apply the International present formatting style to the Test Answers form.
3. Change the back color of the Grade field to light yellow.
4. Change the font size of the Grade field to 10 pt.
5. Use the Format Painter tool to copy the formatting from the Grade field and apply it to the two remaining fields on the Test Answers form.
6. Resize the controls as necessary to make room for the new font size.

7. Save the changes to the form.

8. Close the Homework database.

Quiz Answers

1. False. It’s true that fonts are measured in points, however the larger the number of points, the larger the size of the font.

2. C. The text inside the control is aligned to the left side of the control.

3. False. AutoFormat lets you quickly format a form or report using a set of predefined formatting options.

4. B. The Back Color button on the Formatting toolbar applies color to the background of a selected control.

5. A. The Special Effect button applies a 3-D effect to a selected control.

6. B and C. The Properties dialog box gives you more control and options over how a control is formatted.

7. B. To insert a picture on a form or report, click the Image button on the Toolbox and drag on the report to draw a place holder for the graphic.

8. A. To align several controls with each other, select the controls by holding down the <Shift> key as you click each object, then select Format → Align and select an alignment option from the menu.
Chapter Ten: Working with Macros

Chapter Objectives:

• Create and run a macro
• Create a collection of macros in a single macro group
• Assign a macro to a button on a form
• Assign a macro keystroke combination
• Create a conditional IF/THEN expression

Chapter Task: Create macros that automate database tasks

If you find yourself doing the same routine task over and over again you might want to consider creating a macro to complete the task for you. A macro helps you perform routine tasks by automating them. Instead of manually performing a series of time-consuming, repetitive actions, you can record a single macro that does the entire task all at once for you.

A macro is a set of one or more actions that perform a particular operation, such as opening a form or printing a report. Macros can help you to automate common tasks. For example, you can run a macro that prints a report when a user clicks a command button.

In a way, you can think of macros as a very simple introduction to programming, because you can use them to create automated tasks and somewhat complex procedures. Best of all, you don’t have to know a single line of code—Access provides you with everything you need to write a macro.
Lesson 10-1: Creating and Running a Macro

In some programs, such as Microsoft Excel or Word, you can create macros with a “macro recorder” to record your commands, keystrokes, and mouse clicks. Unfortunately, there isn’t a “macro recorder” or Macro Wizard to help you create a macro in Microsoft Access. Instead, you create macros by entering the actions and arguments directly in Macro Design view, shown in Figure 10-1. Don’t worry—it’s not as difficult as it sounds. Working in Macro Design view really isn’t all that different from working in Table Design view—it’s where you define and edit your macro objects.

Simple macros that automate a single task, such as opening a form or report, are incredibly simple to create—we’ll create such a macro in this lesson. More complicated macros with several steps or procedures may require a little bit of planning. Before you create a complicated macro, think about what you want the macro to do and the individual actions that are required to complete this operation. Practice the steps needed to carry out the operation and write them down as you go—it will make writing the macro a lot easier.

And so, without any further ado, let’s create our first macro.

1. Start Microsoft Access, open the Lesson 10 database, click the Macros icon in the Objects bar, then click New.

   The Macro1: Macro window appears, as shown in Figure 10-1. The Action cell is where you tell Access what you want the macro to do.

2. Click the Action list arrow.

   A list of Actions appear. An Action, or command, is the basic building block of a macro—it’s an instruction that tells Access what you want the macro to do. There are nearly 50 different Actions you can choose from. When you start creating your own macros you will almost certainly want to refer to this chapter’s Macro Action Reference at the end of this chapter to help find the right Action.
3. Scroll down and select the OpenForm action.
   The OpenForm action is added to the first line of the macro window. Most of the time you will have to give Access more information about how to execute each Action. For example, here we will have to tell Access which form to open with the OpenForm action. You use arguments to supply Microsoft Access with this information about how to carry out the action. Each type of action has its own set of arguments, which appear in the Action Arguments panel, located at the bottom of the macro window.

4. Click the Form Name text box in the Action Argument panel, click the Form Name list arrow, and select frmEmployees.
   That’s the only argument we need to specify for this exercise, but notice that there are additional arguments for the OpenForm action, such as the View argument, which lets you select the view in which to open the form (Form view, Design view, or Print Preview).
   If you want you can type a comment to explain the action in the Comments column. If you’ve ever had any programming experience, the Comments column is the same as a remark statement.

5. Click the first blank Comments box and type This macro opens the frmEmployee Form.
   Comments are completely optional, but they do make your macros easier to understand, especially if other users will edit them.

6. Click the Save button on the toolbar, save the macro as mcrEmployees and click OK.
   You’re finished working in the Macro window for now so…

7. Close the Macro window.
   Time to test your new macro. You should be looking at the Macros tab in the Database window.

8. Double-click the mcrEmployees macro.
   Access runs the mcrEmployees macro and opens the frmEmployees form.

9. Close the frmEmployees form.
   That’s all there is to creating a macro—not nearly as hard as you thought it would be, was it? Even the Microsoft Access developers don’t have all the macro actions memorized so make sure you have this chapter’s Macro Action Reference at the end of this chapter handy so that you know what action to use in your macros.
Lesson 10-2: Editing a Macro

Some Microsoft Access tasks require several steps. For example, a particular task might require you to (1) open a form, (2) select a specific record, (3) select a specific field in that record, and then (4) copy the information in that field to the Windows clipboard. Macros can contain as many actions as necessary to automate even the most complicated tasks. Each action appears in its own row, and is evaluated and executed in the order in which it appears in the Macro window, from top to bottom.

In this lesson you will edit the macro you created in the previous lesson to change its arguments and add some more steps or actions.

1. **Select the mcrEmployees macro and open it in Design View.**
   You want to add two more actions to this macro.

2. **Click the Action cell just below the OpenForm action, click the Action list arrow, scroll down the list and select Maximize.**
   The Maximize action maximizes the window so that it fills the Microsoft Access window. Because the Maximize action is so simple and straightforward it doesn’t have any additional arguments.
   Let’s add another action to the mcrEmployees macro.
3. **Click the Action cell just below the Maximize action, click the Action list arrow, scroll down and select MsgBox.**
   The MsgBox action displays a message box that contains a warning or an informational message. The Message argument is the most important argument for the MsgBox action because it determines the text that is displayed in the message box.

4. **Click the Message argument box and type Please make sure that you remember to add the employee's phone number!**
   There are several other arguments you may want to specify for the MsgBox action, such as the type of icon that is displayed in the message box: None, Critical, Warning?, Warning!, and Information.

5. **Click the Type argument box, click the Type argument list arrow and select Information. Type Notice in the Title argument box.**
   Your macro should look like the one shown in Figure 10-2. Remember that actions are evaluated and/or executed in the order in which they appear, so the mcrEmployees macro will (1) open the frmEmployees form, (2) maximize the form window, and (3) display the message box.

6. **Click the Save button on the toolbar.**
   That’s all the editing we need to do for this lesson.

7. **Close the macro window.**
   Let’s test the macro.

8. **Double-click the mcrEmployees macro.**
   Sure enough, the mcrEmployees macro (1) opens the frmEmployees form, (2) maximizes the form window, and (3) displays the message box.

9. **Click OK to close the message box and close the frmEmployees form.**

---

**Quick Reference**

**To Modify a Macro:**
- In the Database window, click the Macros icon, select the macro you want to edit and click Design.
Lesson 10-3: Working with Macro Groups

If you are creating lots of macros, you might want to consider organizing them into a macro group to help you manage them. A macro group stores several related macros together in a single macro object. When you create a macro group you must give each macro in the macro group its own unique name to identify where each macro starts and ends. You do this by entering the macro names in the Macro Name column, which you display by clicking the Macro Name button on the toolbar.

When you combine two or more macros within the same macro group you must run them separately, by referring to the macro group name, followed by the macro name. For example, mcrEmployees.Open frmEmployees refers to the Open frmEmployees macro in the mcrEmployees macro group.

In this lesson you will learn how to group several related macros together in a macro group.

1. **Open the mcrEmployees macro in Design View.**
   You need to display the Macro Name Column.

2. **Click the Macro Names button on the toolbar.**
   The Macro Name Column appears in the Macro window. First you need to give the macro you created in the previous two lessons a name. The cursor is already positioned in the Macro Name cell of the first row.

   **NOTE:** Always enter the macro name in the Macro Name column next to the Action where the macro starts.
3. **Type Open frmEmployees in the first blank cell in the Macro Name column.**
   The macro name Open frmEmployees identifies the macro you created in the previous two lessons. To create another macro in the same macro group, type its name in the Macro Name column next to the first action of the new macro.

4. **Press the <↓> key three times.**
   The cursor should be positioned in the Macro Name column next to the first blank Action row. This is where you can add another macro to the macro group.

5. **Type Print rptEmployeeSales.**
   Print rptEmployeeSales is the name of the new macro we will create.

6. **Click the Action cell to the right of the Print rptEmployeeSales name, click the Action list arrow, scroll down and select OpenReport.**
   Similar to the OpenForm action, which opens a form, the OpenReport action opens a report. Next, you need to specify the arguments for the OpenReport action.

7. **Type Open frmEmployees in the first blank cell in the Macro Name column.**
   The macro name Open frmEmployees identifies the macro you created in the previous two lessons. To create another macro in the same macro group, type its name in the Macro Name column next to the first action of the new macro.

8. **Press the <↓> key three times.**
   The cursor should be positioned in the Macro Name column next to the first blank Action row. This is where you can add another macro to the macro group.

9. **Type Print rptEmployeeSales.**
   Print rptEmployeeSales is the name of the new macro we will create.

10. **Click the Action cell to the right of the Print rptEmployeeSales name, click the Action list arrow, scroll down and select OpenReport.**
    Similar to the OpenForm action, which opens a form, the OpenReport action opens a report. Next, you need to specify the arguments for the OpenReport action.

11. **Click the Report Name text box in the Action Argument panel, click the Report Name list arrow and select rptEmployeeSales.**
    This macro will open the rptEmployeeSales report. Notice Print appears in the View argument—this will send the rptEmployeeSales report directly to the printer. Let’s add a comment to this new macro.

12. **Click the blank Comments box in the Print rptEmployeeSales macro row and type This macro prints the rptEmployeeSales report.**
    You want to add one more action to the Print rptEmployeeSales macro.

13. **Click the Action cell just below the OpenReport action, click the Action list arrow, scroll down and select MsgBox.**
    You need to tell Access what you want the message box to say.

14. **Click the Type box, click the Type list arrow and select Information.**
    Your macro should look like the one shown in Figure 10-4.

15. **Click the Save button on the toolbar and close the macro window.**
    Let’s test our new macro. When you combine several macros within the same macro group you must run them separately using the Tools command on the Access menu.

**NOTE:** Don’t run a macro group by double-clicking it or selecting it and clicking run. Doing so will run every macro in the macro group—often with disastrous results!

16. **Select Tools → Macro → Run Macro from the menu.**
    The Run Macro dialog box appears, as shown in Figure 10-5. Here’s where you select the specific macro you want to run.

17. **Click the Macro Name list arrow, select mcrEmployees.Open frmEmployees and click OK.**
    Access runs the Open frmEmployees macro.

18. **Click OK to close the message box and close the frmEmployees form.**
    If you want, go ahead and repeat Step 13 and run the Print rptEmployeeSales macro. Make sure your computer is connected to a printer, as this macro will send a copy of the rptEmployeeSales to the printer.

---

### Quick Reference

**To Create a Macro Group:**

1. Create a new macro or edit an existing macro.
2. Click the Macro Names button on the toolbar.
3. Type the macro name in the Macro Name column next to the Action where the macro starts.
4. If necessary, add the macro actions or edit the existing macro actions.
5. Save the macro and close the macro window.

**To Run a Macro in a Macro Group:**

1. Select Tools → Macro → Run Macro from the menu.
2. Click the Macro Name list arrow, select the macro you want to run and click OK.
Lesson 10-4: Assigning a Macro to an Event

Running macros from the Database window or menu is a pain in the neck. That’s why most database developers assign macros to controls, particularly buttons, so that when a user clicks the button or control, a macro is activated.

1. **Open the frmEmployees form in Design View.**
   You want to add a command button to the frmEmployees form to open a report that displays the sales for each employee. First you need to add the command button.

2. **Click the Toolbox button if necessary and click the Command Button button on the Toolbox.**
   The mouse pointer changes to a \( \text{+} \), indicating that you can click and drag the command button control on the form.

3. **Place the \( \text{+} \) pointer below the DOB field label and click and drag the \( \text{+} \) pointer down and to the right to create a command button like the one in Figure 10-6. Click Cancel if the Command Wizard dialog box appears.**
   The Command Button Wizard is useful for adding preset action to controls but you don’t need it if you’re attaching a user-created macro to a button. Before we assign a macro to the new command button we should give it a more meaningful text label.
4. Make sure that the command button is still selected, then click its text label and replace its text with Sales Report. Click anywhere outside of the command button when you’re finished.

Okay, we’re ready to assign a macro to the button—to do this you will need to display the command button’s Properties.

5. Select the command button, click the Properties button on the toolbar, and click the Event tab.

The Event tab lists all the events to which you can assign a macro—most of them you will never use, as you can see in Table 10-9: Macro Actions and Their Descriptions.

6. Click the On Click box, click the list arrow, and select the mcrSales macro. Close the properties dialog box when you’re finished.

Let’s see how our new command button works.

7. Click the View button on the toolbar to switch to Form View then click the new Sales Report button.

Microsoft Access runs the mcrSales macro and displays the rptCommission report for the current employee.

8. Close the report and save the changes to the form.

Table 10-7: Event Properties that can Trigger Macros

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before Update</td>
<td>Macro or function that runs when data in a field or record is changed but before the changes are actually saved to the database. Often used to validate data.</td>
</tr>
<tr>
<td>After Update</td>
<td>Macro or function that runs when data in a field or record is changed and is saved to the database.</td>
</tr>
<tr>
<td>On Change</td>
<td>Macro or function that runs when the contents of a text box or combo box changes or when you move from one page to another in a tab control.</td>
</tr>
<tr>
<td>On Enter</td>
<td>Macro or function that runs when a control first gets the focus (is selected). The Enter event occurs before the focus moves to a particular control (before the GotFocus event). You can use an Enter macro or event procedure to display instructions when a form or report first opens.</td>
</tr>
<tr>
<td>On Exit</td>
<td>Macro or function that runs when a control loses focus (is deselected) on the same form.</td>
</tr>
<tr>
<td>On Got Focus</td>
<td>Macro or function that runs when a control gets the focus (is selected).</td>
</tr>
<tr>
<td>On Lost Focus</td>
<td>Macro or function that runs when a control loses the focus (is deselected).</td>
</tr>
<tr>
<td>On Click</td>
<td>Macro or function that runs when a control is clicked.</td>
</tr>
<tr>
<td>On Dbl Click</td>
<td>Macro or function that runs when a control is double-clicked.</td>
</tr>
<tr>
<td>On Mouse Down</td>
<td>Macro or function that runs when the user presses the mouse button.</td>
</tr>
<tr>
<td>On Mouse Move</td>
<td>Macro or function that runs when the user moves the mouse over a control.</td>
</tr>
<tr>
<td>On Mouse Up</td>
<td>Macro or function that runs when the user releases the mouse button.</td>
</tr>
<tr>
<td>On Key Down</td>
<td>Macro or function that runs when the user presses a key on the keyboard.</td>
</tr>
<tr>
<td>On Key Up</td>
<td>Macro or function that runs when the user releases a key on the keyboard.</td>
</tr>
<tr>
<td>On Key Press</td>
<td>Macro or function that runs when the user presses an ANSI key on the keyboard.</td>
</tr>
</tbody>
</table>
Lesson 10-5: Creating Conditional Expressions

A condition takes action based on a certain condition. For example, if an employee’s weekly sales are more than $2,500, then a condition could calculate a 5% commission bonus for the employee; otherwise it wouldn’t calculate a bonus. If you’re at all familiar with programming, a condition is similar to an If…Then statement.

You enter conditions in the Conditions column in the Macro window. If a condition is true, Access executes the action in that row. If a condition isn’t true, Access skips the action in that row and moves to the next row. Conditions often compare values in a specific control on a form or report to a number, date, or constant. For example, the expression in Figure 10-9 evaluates if the value in a City field is not equal to Minneapolis. Make sure that you use the proper Microsoft Access syntax when referring to controls in forms or reports.

1. Make sure you have the frmEmployees form from the previous lesson open. Click the View button on the toolbar to switch to Design view.

   We want to add a conditional expression to the mcrEmployees macro. If a macro is assigned to a control on a form or report you can open and edit the macro directly from the form or report without having to access it through the Database window.

2. Select the command button, click the Properties button on the toolbar, click the Event tab, and click the On Click box.

   A build button appears in every event property. Click this button to create or modify the macro or Visual Basic procedure assigned to the event.
3. Click the On Click button.
The mcrSales macro appears in the Macro Design window.

4. Click the Conditions button on the toolbar.
The Condition column appears. This is where you need to add the conditions you want Access to evaluate before it executes an action. It’s often easier if you use the Expression Builder to help you create your macro conditions.

5. Click in the first blank cell in the Condition column and click the Build button on the toolbar.
The Expression Builder dialog box appears.

6. Double-click the Forms folder in the bottom-left window, double-click the All Forms folder, then click the frmEmployees folder.
When you select the frmEmployees folder in the left window, the middle window displays all the controls in the selected form.

7. Scroll down the bottom-middle window, find and double-click the City control.
Access adds [Forms]![frmEmployees]![City] to the expression area. Now you need to specify how you want to use the City field.

8. Click in the Expression box and add <="Minneapolis".
Your expression should look like the one in Figure 10-9.

9. Click OK.
The Expression dialog box closes. The condition you entered will execute the OpenForm action only if the City field is not equal to Minneapolis. The condition you entered only effects the first row or action in the macro—the other actions in the macro will execute without being evaluated. If you want to evaluate the other actions they must each have their own statement in the Condition column. Let’s add some more actions to the macro.

10. Copy the first row and paste it in the second and third rows.
Add another action that will execute only if the City is not equal to Minneapolis.

11. Click the Action cell in the second row, click the Action list arrow and select MsgBox. Click the Message argument box and type This is the current commission for non-Minneapolis employees.
Next you need to add an action that will execute if the City is equal to Minneapolis.

12. Select the expression you pasted into the third row of the Condition column and edit the expression so it reads [Forms]![frmEmployees]![City]="Minneapolis".
Now you need to specify the action to execute if the condition is true.

13. Click the Action cell next to the condition you entered, click the Action list arrow, scroll down and select MsgBox. Click the Message argument box and type Call Linda Ross for the Minneapolis Commission report.
We’re finished modifying the macro.

14. Save your changes and close the Macro Design window. Click the View button on the toolbar to display the form in Form view.
Let’s test our conditional macro.

15. Move to a record whose City field IS NOT from Minneapolis and click the Sales Report button. Try moving to another record whose City field IS from Minneapolis and try clicking the Sales Report button. When you’re finished save your changes and close the frmEmployees form.
Lesson 10-6: Assigning a Macro to a Keystroke Combination

Sometimes, instead of assigning a macro to a command button, you may want to assign it to a specific keystroke combination, such as <Ctrl> + <D>. Assigning a keystroke combination to a macro makes it fast and easy to access—you can execute the macro at any time by pressing its assigned keystroke combination.

Assigning a keystroke combination to a macro can be a somewhat complicated process. There are two things you need to know about assigning a macro to a key combination:

- You must create a special macro group, named AutoKeys, which contains all your keystroke combination macros.
- You type the keystroke combination to which you want to assign the macro in the Macro Name column of the AutoKeys macro window. Enter the keystrokes combinations using the Table 10-8: The SendKey Syntax for how to enter the names of keystroke combinations.

In this lesson you will learn how to create an AutoKeys macro to assign a macro to a keystroke combination.

1. Click the Macros tab if necessary and click New.

The Macro window appears, as shown in Figure 10-11. You need to display the Macro Name Column in order to tell Access which keystroke combination you want to assign to the macro.

2. Click the Macro Names button on the toolbar if necessary.

Now you need to type the keystroke combination to which you want to assign the macro. Table 10-8: The SendKey Syntax shows the key combinations you can use to make key assignments in an AutoKeys macro group. We want to assign a macro to the keystroke combination <Ctrl> + <L>. Here’s what you need to enter:
3. **Type \(^L\) in the first blank Macro Name box.**
   The name \(^L\) refers to <Ctrl> + <L>. The \(^\) (caret) signifies the <Ctrl> key and the L signifies the L key.

   **NOTE:** If you assign a macro to a keystroke combination that Microsoft Access is already using (for example <Ctrl> + <X> is the keystroke combination for the Cut command), the macro you assign to this keystroke combination will override the Microsoft Access keystroke combination assignment.

   Now we need to specify what we want the macro to do.

4. **Click the first blank Action box, click the \(\) Action list arrow and select RunApp from the list.**
   The RunApp action starts another program, such as Microsoft Excel or Word. We want the RunApp action to start the Calculator program. You need to specify the name and location of the program you want to run in the Action Arguments area.

5. **Click the Command Line box.**
   - If you’re using Windows 95, 98, ME, or XP, type c:\windows\calc.exe.
   - If you’re using Windows NT or 2000, type c:\winnt\calc.exe.

   Now let’s save the macro, making sure that we name it AutoKeys.

6. **Click the Save button on the toolbar, type AutoKeys and click OK.**
   Close the macro window.

7. **Press <Ctrl> + <L>.**
   Microsoft Access executes the macro assigned to the <Ctrl> + <L> keystroke combination and starts the Calculator application.

   Give yourself a pat on the back if you’ve gotten through this chapter. You’ve just learned how to automate your Microsoft Access databases to work more like a full-featured application than a dull, static database.

---

### Table 10-8: The SendKey Syntax

<table>
<thead>
<tr>
<th>Heading</th>
<th>Heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Any Key</td>
<td>^ For Example, enter ^E for &lt;Ctrl&gt; + &lt;E&gt;</td>
</tr>
<tr>
<td>Shift + Any Key</td>
<td>+ For Example, enter +E for &lt;Shift&gt; + &lt;E&gt;</td>
</tr>
<tr>
<td>Alt</td>
<td>% For Example, enter %E for &lt;Alt&gt; + &lt;E&gt;</td>
</tr>
<tr>
<td>Enter</td>
<td>{ENTER}</td>
</tr>
<tr>
<td>Esc</td>
<td>{ESC}</td>
</tr>
<tr>
<td>Tab</td>
<td>{TAB}</td>
</tr>
<tr>
<td>Insert, Delete</td>
<td>{INSERT} or {INS}, {DELETE} or {DEL}</td>
</tr>
<tr>
<td>Page Down, Page Up</td>
<td>{PGDN}, {PGUP}</td>
</tr>
<tr>
<td>Home, End</td>
<td>{HOME}, {END}</td>
</tr>
<tr>
<td>Arrow Keys</td>
<td>{UP}, {DOWN}, {LEFT}, {RIGHT}</td>
</tr>
<tr>
<td>Caps Lock</td>
<td>{CAPSLOCK}</td>
</tr>
<tr>
<td>Function Keys</td>
<td>{F1}, {F2}, {F3}, etc...</td>
</tr>
</tbody>
</table>

---

### Quick Reference

**To Assign a Macro to a Keystroke Combination:**

1. Create a macro group named AutoKeys. This will store all the macros that are assigned to a keystroke combination.
2. Click the Macro Names button on the toolbar.
3. Type the keystroke combination in SendKey syntax in the Macro Name column next to the Action where the macro starts. See Table 10-8: The SendKey Syntax.
## Macro Action Reference

Table 10-9: Macro Actions and Their Descriptions

<table>
<thead>
<tr>
<th><strong>Action</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>AddMenu</td>
<td>Adds a menu to a custom menu bar for a form or report. Each menu on the menu bar requires a separate AddMenu action.</td>
</tr>
<tr>
<td>ApplyFilter</td>
<td>Applies a filter or query to a table, form, or report.</td>
</tr>
<tr>
<td>Beep</td>
<td>Causes the computer to beep.</td>
</tr>
<tr>
<td>CancelEvent</td>
<td>Cancels the event that caused the macro to run.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the specified window or the active window if none is specified.</td>
</tr>
<tr>
<td>CopyObject</td>
<td>Copies the specified database object to a different Microsoft Access database or to the same database with a new name.</td>
</tr>
<tr>
<td>DeleteObject</td>
<td>Deletes the specified object, or the object selected in the Database window if no object is specified.</td>
</tr>
<tr>
<td>Echo</td>
<td>Hides or shows the results of a macro while it runs.</td>
</tr>
<tr>
<td>FindNext</td>
<td>Finds the next record that meets the criteria specified with the most recent FindRecord action or Find dialog box. Use to move successively through records that meet the same criteria.</td>
</tr>
<tr>
<td>FindRecord</td>
<td>Finds the first or next record that meets the specified criteria. Records can be found in the active form or Datasheet.</td>
</tr>
<tr>
<td>GoToControl</td>
<td>Selects the specified field on the active Datasheet or form.</td>
</tr>
<tr>
<td>GoToPage</td>
<td>Selects the first control on the specified page of the active form.</td>
</tr>
<tr>
<td>GoToRecord</td>
<td>Makes the specified record the current record in a table, form, or query. Use to move to the first, last, next, or previous record.</td>
</tr>
<tr>
<td>Hourglass</td>
<td>Changes the mouse pointer to an hourglass while the macro runs.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Maximizes the active window.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Minimizes the active window.</td>
</tr>
<tr>
<td>MoveSize</td>
<td>Moves and/or changes the size of the active window.</td>
</tr>
<tr>
<td>MsgBox</td>
<td>Displays a message box containing a warning or informational message.</td>
</tr>
<tr>
<td>OpenForm</td>
<td>Opens a form in Form view, Design view, Print Preview, or Datasheet view.</td>
</tr>
<tr>
<td>OpenModule</td>
<td>Opens the specified Visual Basic module in Design view.</td>
</tr>
<tr>
<td>OpenQuery</td>
<td>Opens a query in Datasheet view, Design view, or Print Preview.</td>
</tr>
<tr>
<td>OpenReport</td>
<td>Opens a report in Design view, Print Preview, or prints the report immediately.</td>
</tr>
<tr>
<td>OpenTable</td>
<td>Opens a table in Datasheet view, Design view, or Print Preview.</td>
</tr>
<tr>
<td>OutputTo</td>
<td>Exports the specified database object to a Microsoft Excel file (.xls), rich-text file (.rtf), text file (.txt), or HTML file (.htm).</td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PrintOut</td>
<td>Prints the active database object. You can print datasheets, reports, forms, and modules.</td>
</tr>
<tr>
<td>Quit</td>
<td>Quits Microsoft Access.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the specified object.</td>
</tr>
<tr>
<td>RepaintObject</td>
<td>Completes any pending screen updates or pending recalculations of controls on the specified object, or on the active object if none is specified.</td>
</tr>
<tr>
<td>Requery</td>
<td>Forces a requery of a specific control on the active database object, or the object if no control is specified.</td>
</tr>
<tr>
<td>Restore</td>
<td>Restores a maximized or minimized window to its previous size.</td>
</tr>
<tr>
<td>RunApp</td>
<td>Starts another program, such as Microsoft Excel or Word.</td>
</tr>
<tr>
<td>RunCode</td>
<td>Runs a Visual Basic Function procedure.</td>
</tr>
<tr>
<td>RunCommand</td>
<td>Runs a command from Microsoft Access’s menus – for example File → Save.</td>
</tr>
<tr>
<td>RunMacro</td>
<td>Runs a macro.</td>
</tr>
<tr>
<td>RunSQL</td>
<td>Runs the specified SQL statement for an action query.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the specified object, or the active object if none is specified.</td>
</tr>
<tr>
<td>SelectObject</td>
<td>Selects a specified database object. You can then run an action that applies to that object.</td>
</tr>
<tr>
<td>SendKeys</td>
<td>Sends keystrokes to Microsoft Access or another active application. These keystrokes are processed as if you had typed them yourself on the keyboard.</td>
</tr>
<tr>
<td>SendObject</td>
<td>Sends the specified database objects as an attachment in an e-mail.</td>
</tr>
<tr>
<td>SetMenuItem</td>
<td>Sets the state of menu items (enabled or disabled, checked or unchecked) on custom menus. Works only on custom menus created using menu bar macros.</td>
</tr>
<tr>
<td>SetValue</td>
<td>Sets the value for a control, field, or property on a form or report.</td>
</tr>
<tr>
<td>SetWarnings</td>
<td>Turns all system messages on or off. This has the same effect as clicking OK or Yes in each message box.</td>
</tr>
<tr>
<td>ShowAllRecords</td>
<td>Removes any applied filter from the active table, query, or form.</td>
</tr>
<tr>
<td>ShowToolbar</td>
<td>Shows or hides a built-in toolbar or a custom toolbar.</td>
</tr>
<tr>
<td>StopAllMacros</td>
<td>Stops all currently running macros.</td>
</tr>
<tr>
<td>StopMacro</td>
<td>Stops the currently running macro. Use to stop a macro when a certain condition is met.</td>
</tr>
<tr>
<td>TransferDatabase</td>
<td>Imports or exports data to or from the current database to or from another database.</td>
</tr>
<tr>
<td>TransferSpreadsheet</td>
<td>Imports data from a spreadsheet file into the current database or exports data from the current database into a spreadsheet file.</td>
</tr>
<tr>
<td>TransferText</td>
<td>Imports data from a text file into the current database or exports data from the current database into a text file.</td>
</tr>
</tbody>
</table>
Chapter Ten Review

Lesson Summary

Creating and Running a Macro

- **To Create a Macro:** From the database window click the Macros icon in the Objects bar and click New. Click the first blank Action box, click the Action list arrow and select the action you want the macro to perform. Specify any required arguments for the action in the Action Arguments area. Repeat for each additional action you want the macro to execute. Click the Save button on the toolbar, give your new macro a name and click OK.

- **To Run a Macro:** Click the Macros tab and double-click the macro you want to run.

Editing a Macro

- **To Modify a Macro:** In the Database window, click the Macros tab, select the macro you want to edit and click Design.

Working with Macro Groups

- **To Create a Macro Group:** Create a new macro or edit an existing macro, click the Macro Names button on the toolbar. Type the macro name in the Macro Name column next to the Action where the macro starts. If necessary, add the macro actions or edit the existing macro actions. Save the macro and close the macro window.

- **To Run a Macro in a Macro Group:** Select Tools → Macro → Run Macro from the menu, click the Macro Name list arrow, select the macro you want to run and click OK.

Assigning a Macro to an Event

- **To Assign a Macro to a Control on a Form or Report:** Open the form or report in Design View, click the control to which you want to assign the macro and click the Properties button on the toolbar. Click the Event tab and click in the box for the type of event you want to assign the macro and click the list arrow and select the macro you want to assign to the event. Close the Properties dialog box and save the form or report.

Creating Conditional Expressions

- **To Create a Conditional Expression in a Macro:** Create a new macro or edit an existing macro. Click the Conditions button on the toolbar and click the Conditions box next to the action you want to evaluate. Enter the conditional expression in the Conditions box, using proper Access syntax. You can use the Expression Builder to help you create the expression by clicking the Build button on the toolbar. Repeat these steps for each action you want to evaluation. Save the macro and close the macro window.
Assigning a Macro to a Keystroke Combination

To Assign a Macro to a Keystroke Combination: Create a macro group named AutoKeys - this will store all the macros that are assigned to a keystroke combination. Click the Macro Names button on the toolbar. Type the keystroke combination in SendKey syntax in the Macro Name column next to the Action where the macro starts.

Quiz

1. The fastest and easiest way to create a macro in Microsoft Access is with the Macro Recorder. (True or False?)

2. A(n) _____, or command is the basic building block of a macro.
   A. Expression.
   B. Action.
   C. Procedure.
   D. Function.

3. Macros may contain more than one action to perform several steps in sequence. (True or False?)

4. Which of the following statements is NOT true?
   A. You can add an optional comment to a macro action in the Comments column.
   B. You use arguments to supply Microsoft Access with information about how to carry out specific actions.
   C. A macro group stores several named macros together in a single group.
   D. To run a specific macro in a macro group double-click the macro, select the specific macro from the list and click Run.

5. Which of the following columns cannot be found in the Macro Design window?
   A. Names column (if the Macro Names button on the toolbar is selected).
   B. Arguments column.
   C. Conditions column (if the Conditions button on the toolbar is selected).
   D. Actions column.

6. You can assign a macro to a button, so that when a user clicks the button or control, a macro is activated. The procedure for doing this is:
   A. (1) Open the form in Design View, (2) select the button and display its properties, (3) click the Events tab and click the On Click box, and (4) click the down arrow and select the macro you want to assign to the button.
   B. (1) Open the macro in Design View, (2) select the form and button you want to assign the macro to from the Assign box, and (3) click Event box, click the down arrow and select On Click from the list.
   C. (1) Open the form in Design View, (2) select the button, and (3) select the macro from the Macro List on the toolbar.
   D. Too lengthy and complicated to be described in a brief quiz question.
7. **Conditions only effect the corresponding Action row in the macro—the other actions in the macro will execute without being evaluated. If you want to evaluate the other actions they must each have their own statement in the Condition column. (True or False?)**

**Homework**

1. Open the Homework database.
2. Create a macro named OpenReport that opens the Insurance Claims by Date report. Try running this macro.
3. Create a new macro to open the Test Answers form. Add a conditional expression so that the OpenForm action won’t execute if the Score field in the Test Answers form equals an ‘F’. 
   **Hint:** Use the Expression builder if you need help creating the conditional expression.
4. Add another conditional action to the OpenForm macro—one that displays a message box that says “Sorry you failed!” if the Score field in the Test Answers form equals an ‘F’.
5. Open the Test Answers form in Design View.
6. Add a command button to the form whose On Click event property runs the OpenReport macro.
7. Save the Test Answers form, display it in Form View and test the command button.
8. Close the Homework database.

**Quiz Answers**

1. False. Microsoft Excel and Word both have macro recorders you can use to create macros, but with Microsoft Access you create a macros in the Macro Design window.
2. B. An action is the basic building block of a macro.
3. True. Macros can contain multiple actions to automate several steps in a sequence.
4. D. Double-clicking a macro group will run every named macro in the group, often with disastrous results.
5. B. This was a trick question. Macro actions do have arguments, however they can be found in the Augments panel—not in a column.
6. A. The correct procedure for assigning a macro to a button is: (1) Open the form in Design View, (2) select the button and display its properties, (3) click the Events tab and click the On Click box, and (4) click the down arrow and select the macro you want to assign to the button.
7. True. Conditions only effect the corresponding Action row in the macro. If you want to evaluate the other actions they must each have their own statement in the Condition column.
Chapter Eleven:
Using Access with Other Programs

Chapter Objectives:
- Importing information from an external file
- Exporting information to an external data file
- Importing objects from another Microsoft Access database
- Linking tables from an external database
- Export information to a Microsoft Excel worksheet
- Export records to a Microsoft Word table
- Mail merge records to Microsoft Word
- Create and work with hyperlink and OLE object fields

Chapter Task: Export and import information to and from a Microsoft Access database

One of the great benefits of working with Windows is that you can share information between different programs. Nowhere is this truer than it is with Microsoft Access. This chapter explains how you can use Access with other programs. You’ll learn how to import and export databases in other file formats. You’ll also learn the difference between importing objects from another database versus linking to objects in another database. And you’ll learn how to create a Microsoft Excel worksheet based on an Access query, transfer an Access table to Microsoft Word, or use Word with Access to create mail-merge letters.

Prerequisites
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- A basic understanding of Microsoft Excel and Microsoft Word.
Lesson 11-1: Importing Information

People from different countries speak different languages, so naturally computer programs save files in different formats. Fortunately, just like some people can speak several languages, Access can read and write in other file formats.

This lesson shows how to open one of the most common file formats in programs—a tab delimited text file in Microsoft Access.

1. **Start Microsoft Access and open the Lesson 11 database.**

2. **Select File → Get External Data → Import from the menu.**

   The Import dialog box appears. Normally the Import dialog box only displays Microsoft Access databases. To import files created with other programs you need to select the file type you want from the Files of type list arrow—in your case Text files.

3. **Click the Files of type list arrow and select Text Files.**

   Access displays any text files in the current folder. Next you have to specify the text file that you want to open.
4. **Browse to your practice folder and double-click the Europe Expenses file.**

The Text Import Wizard dialog box appears, as shown in Figure 11-1. You must specify how the information is stored in the text file. There are two options:

- **Delimited:** Tabs, colons, semicolons, or other characters separate items in your text file. This is the most common (and default) option.
- **Fixed Width:** All the items in your text file are the same length.

The Europe Expenses is a tab delimited text file, that is, tabs separate its fields, so you don’t need to make any changes and can continue on to the next step.

5. **Click Next.**

The second step of the Text Import Wizard appears. Here you have to specify the delimiter character used to separate the fields in the text file. Surprisingly, Access is usually smart enough to figure out which character is used as the delimiter (usually a tab or comma). What is vitally important here is the “First Row Contains Field Names” check box. Hopefully the data you’re importing will include field names in the first row—otherwise you will have to add the field names to the table on your own later. Luckily the Europe Expenses text file does include field names in the first row, so we’ll need to tell this to Access.

6. **Check the First Row Contains Field Names check box and click Next.**

Next Access asks where you want to import the data—to a new table or to an existing table that you select from a drop-down list.

We want to store the imported data in a new table, so we don’t have to make any changes here.

7. **Click Next.**

The next step of the Import Wizard allows you to specify the data types for the fields in the imported data. For example, you could specify that a particular field is a date or number field. Access is usually quite smart at guessing the data type for most fields, but you might want to double-check each imported field just to be sure. Simply click the imported field heading that you want to view and make any changes to the data type.

8. **Click Next.**

Next the Import Wizard asks if you want to add a primary key to the imported data. You can let Access add an AutoNumber primary field to the new table, use one of the imported fields as the primary (providing it meets the criteria for primary fields), or not use a primary key.

9. **Select the No Primary Key option and click Finish. Click OK when the dialog box appears saying that the table has been successfully created.**

Access imports the text file and stores it in a new table called “Europe Expenses”.

---

**Quick Reference**

To Import Information from another File into Access:

1. From the Database window, select **File → Get External Data → Import** from the menu.
2. Select the type of file you want to import from the **Files of type list**.
3. Browse to the appropriate drive and/or folder and double-click the file you want to import.
4. Follow the on-screen instructions of the Import Wizard to import the data.

---

| **Table 11-10: Importable and Exportable File Formats and Extensions** |
|------------------------|---------------------|
| **File Format**        | **Extensions**      |
| Microsoft Excel        | .xls, .xlt          |
| Lotus 1-2-3            | .wk4, .wk3, .fm3, .fmt, .all, .wk1, .wks |
| Text (Both tab and comma delimited) | .txt, .csv |
| Dbase 2, 3, 4          | .dbf                |
| Microsoft Access 2.0, 95, 97 | .mdb                |
Lesson 11-2: Exporting Information

When you export an Access table, you save its information in a different format so that it can be understood and opened by different programs. In this lesson you will learn how to export an Access table to a comma delimited text file.

1. Make sure the Database window is displayed and click the Tables icon in the Objects bar if necessary.

You want to export the tblCustomers table to a tab delimited text file so that it can be opened by other programs.

2. Right-click the tblCustomers table and select Export from the shortcut menu.

Access asks where you want to export the table. You need to specify a file name and file format. For this exercise you can use the default “tblCustomers” file name, however you do need to change the file format.

3. If necessary, browse to your practice folder. Click the Save as type list and select Text Files. Click the Save button when you’re finished.

The Export Wizard dialog box appears, as shown in Figure 11-5. You must specify how the information is stored in the text file. There are two options:

- **Delimited:** Tabs, colons, semicolons, or other characters separate items in your text file. This is the most common (and default) option.
- **Fixed Width:** All the items in your text file are the same length.

Other Ways to Export a Table:
- Select the table and select **File → Save As/Export** from the menu.
If you’re saving to a text file you will almost always want to select the Delimited option.

4. **Click Next.**
   The second step of the Text Import Wizard appears. You have to specify the character you want to use as the delimiter to separate the fields in the text file (usually a tab or comma). What is vitally important here is the “Include Field Names on First Row” check box. You will usually want to include field names in the first row—otherwise you may have to add the field names to the data on your own later.

5. **Check the Include Field Names on First Row check box and click Finish.** Click OK on the dialog box.
   Access exports the tblCustomers table to a comma delimited text file. If you want, move on to the next couple of steps and we’ll see how the exported text file looks. Otherwise feel free to skip them and move on to the next lesson.

6. **Click the Windows Start button and select Programs → Accessories → Notepad.**
   Windows starts the Notepad program.

7. **Select File → Open from the menu.**
   The Open dialog box for the Notepad program appears.

8. **Browse to your practice folder and double-click the tblCustomers text file.**
   The comma delimited text file appears, as shown in Figure 11-7. It doesn’t look pretty, but the information you’re looking at is in a format that is very easy for most computer programs to understand.

9. **Close the Notepad program.

---

### Quick Reference

**To Export a Table to an External File:**

1. From the Database window, right-click the table and select **Export** from the shortcut menu.
   Or…
   Select the table and select **File → Export** from the menu.

2. Select either:
   **To an External File or Database:** To save the table in an external file in a different format.
   **Within the Current Database as:** To duplicate the table within the same database.

3. Click **OK.**

4. Follow the on-screen instructions of the Export Wizard to export the data.
Lesson 11-3: Importing Objects from another Access Database

Not only does the Import command insert information from other file formats, it also lets you import objects from other Microsoft Access databases. You can import tables, forms, reports, queries, macros, and VBA modules from one Access database into another Access database. Inserting objects from another Access database saves you lots of time: instead of creating a new object (such as a form) from scratch, you can import an object from another database and then modify it as needed.

In this lesson you will learn how to import an object from another Microsoft Access database.

1. **Select File → Get External Data → Import from the menu.**
   The Import dialog box appears. Here you need to specify the Microsoft Access database that contains the object(s) you want to import into the current database.

2. **Browse to your practice folder and double-click the Promotions database file.**
   The Import Objects dialog box appears, as shown in Figure 11-8. The Import Objects dialog box looks a lot like the Database window—you click the tab that corresponds to the type of database object you want to import.
   You can insert any type of database object—we’ll try inserting a form.

3. **Click the Forms tab.**
   Access displays all the forms in the Promotions database.

4. **Click the frmPromotions form.**
   You can import more than one database object at a time—simply click the appropriate object tab(s) and select the database objects you want to select. When you’re finished here’s what to do:

5. **Click OK.**
   Access imports the frmPromotions form into the current database.
Lesson 11-4: Linking Information from an External Source

Another way that you can access information in another database is by creating a linked table. A linked table may sound a lot like an imported table, but there are some very important differences between the two:

- **Imported**: When you import a table, you copy data from a table in one Access database and place it in a new table in your database.
- **Linked**: When you link a table, that data stays in its original location. You can add, delete, and edit records in a linked table from within Access, but you can’t change the table’s structure. If the data in the original database changes, the changes will appear in your database too.

Many databases often use a front-end database file, which contains the forms, reports, and queries and is linked to a back-end database file, which contains the actual tables. Such designs work great when you want several users on several front-end databases to be able to access the same information in a single back-end database.

1. **Select File → Get External Data → Link Tables** from the menu.
   The Link dialog box appears. Here you need to specify the database that contains the table you want to link.

2. **Browse to your practice folder and double-click the Promotions database file**.
   The Link Tables dialog box appears, as shown in Figure 11-9. All you have to do here is select the table(s) that you want to link to.

3. **Click the tblPromotions table and click OK**.
   The dialog box closes and Access creates a link to the tblPromotions table. You can identify linked tables by their ➤ arrow. Let’s try opening the linked table.

4. **Click the Tables tab if necessary, and double-click the tblPromotions table**.
   Access opens the tblPromotions table. Though you can view, add, edit, and delete the records in the tblPromotions table, it remains in the Promotions database.

5. **Close the tblPromotions table**.
   You can also create linked tables that access external information from such sources as dBase, Paradox, FoxPro, and SQL databases.
Lesson 11-5: Analyzing Records with Microsoft Excel

Access is capable of performing calculations on groups of records, but it can’t hold a candle to its Microsoft Office 2000 counterpart, Microsoft Excel, when it comes to number crunching. An Excel spreadsheet is similar to an Access Datasheet in many ways, with one important difference. Not only can you enter information in an Excel spreadsheet, but you can also easily add formulas directly into the spreadsheet grid—something you can’t do in Access. It makes sense then, that more people use Excel together with Access than any other program.

In this lesson you will learn how to create a Microsoft Excel spreadsheet based on an Access query.

1. Make sure that the Database window is displayed.
   We will be using a query to create our Excel spreadsheet in this exercise, but you can also create a spreadsheet based on tables and reports.

2. Click the Queries tab and select the qrySales query.
   Here’s how to export the selected database object to Microsoft Excel.

3. Click the Office Links button arrow on the toolbar and select Analyze It with MS Excel from the list.
   Microsoft Access sends the results of the qrySales query to Microsoft Excel, as shown in Figure 11-10. We won’t spend much time working in Excel—this is a book about Access—but let’s at least try adding a formula to the spreadsheet.

4. Scroll to the right if necessary, click in cell H2, type =G2*.9 and press <Enter>.
   Excel multiplies the value in cell G2 with 90% and displays the results.

5. Close Microsoft Excel without saving any changes.

Quick Reference

To Export Access Data to Microsoft Excel:
1. Open or select the table, query or report you want to export.
2. Click the Office Links button arrow on the toolbar and select Analyze It with MS Excel from the list.
Lesson 11-6: Exporting Records to Microsoft Word

If Microsoft Excel is the best tool for number crunching, Microsoft Word is definitely the best program to use for formatting and presenting large amounts of text. You can easily transfer records from a table or query using simple copy and paste commands or by using the “Publish It with MS Word” command, found under the Office Links button on the toolbar. When records are transferred from Access to Word, they are formatted within the document as a Word document. This makes it easy to edit, sort, and format.

In this lesson you will learn how to transfer an Access table to a Microsoft Word document.

1. Make sure that the Database window is displayed.
   Although we’ll be using a query to create our Excel spreadsheet in this exercise, you can also create a spreadsheet based on tables and reports.

2. Click the Tables tab and select the tblCustomers table.
   Here’s how to export the selected the database object to Microsoft Word.

3. Click the Office Links button arrow on the toolbar and select Publish It with MS Word from the list.
   Microsoft Access sends the tblCustomers table to Microsoft Word, as shown in Figure 11-11. The results usually aren’t pretty—but it’s easy to fix this problem with some formatting and editing.


Quick Reference
To Export Access Data to Microsoft Word:
1. Open or select the table, query or report you want to export.
2. Click the Office Links button arrow on the toolbar and select Publish It with MS Word from the list.
Lesson 11-7: Mail Merging Records to Microsoft Word

Ever wondered who at Publisher’s Clearing House Sweepstakes types your name on those letters you receive on a weekly basis? Well, thanks to a process known as mail merge, creating these “personalized” letters require no more effort than a few keystrokes. Mail merge letters are used to send the same or similar documents to many different people at once.

To perform a mail merge you need two files:
• **Main Document:** Which is a Microsoft Word document that contains the text that is the same in all of the merged documents (also known as boiler-plate text).
• **Data Source:** Which contains the records that you want to insert into the merged documents. A Microsoft Access database makes a great data source.

In this lesson you will learn to merge information from an Access into Microsoft Word.

1. **From the Database window click the Tables tab, select the tblCompanies table, click the Office Links button arrow and select Merge It with MS Word from the list.**

   The Microsoft Word Mail Merge Wizard appears and asks if you want to link the data to an existing Microsoft Word document or create a new Word document and then link the data to it. For this exercise you will use an existing Word document.
2. **Click OK to link your data to an existing Word document.**
   The Wizard prompts you for the name and location of the existing Word document.

3. **Browse to your practice folder, find and double-click the Cover Letter document.**
   The Cover Letter document opens in Microsoft Word.

   Now comes the most important part of the mail merge process: you have to specify where you want to insert the information from the data source or Access database into your main document. You do this by inserting merge fields. Merge fields are where the information from your data source gets inserted into the main document.

4. **Place the insertion point at the end of the date line and press <Enter> twice.**
   This is where you will place your first merge field.

5. **Click the Insert Merge Field button on the Mail Merge toolbar and select Name from the field list.**
   The Name field (from the Microsoft Access database) is inserted in the document. You may have noticed chevrons surround the field («»). The chevrons differentiate the merge fields from other text in the document.

6. **Press <Enter>, click the Insert Merge Field button, select Company from the field list, press <Enter>, click the Insert Merge Field button, and select Address from the field list.**
   Move on to the next step and finish the address.

7. **Press <Enter>, click the Insert Merge Field button, select City from the field list, type a , (comma) and press <Spacebar>. Click the Insert Merge Field button, select State from the field list, press <Spacebar>, click the Insert Merge Field button again, and select PostalCode from the field list.**
   Getting the hang of it? If you’re feeling ambitious feel free to replace every instance of the word PRODUCT with a «<Product>» merge field.

   You can merge the information in the data source with the main document in one of two ways:
   - **Merge to New Document**: Merges the data source with the main document and places the results in a single, new document. Each record in the data source will appear on a separate page. You can then save the new merged document.
   - **Merge to Printer**: Merges the data source with the main document and prints the results.

   For this lesson, we’ll merge to a new document.

8. **Click the Merge to New Document button on the Mail Merge toolbar.**
   Word merges the main document “Mail Merge Letter” and the data source “Mail Merge Letter Data” into a new document called “FormLetters1.” The new merged document contains three letters—one letter for each record in the data source—that are separated with a page break.

9. **Press <Page Down> several times to move to the next page of the document to view the second letter.**
   Notice that this letter uses data from the second record in the data source.

10. **Close Microsoft Word without saving any of your changes.**
   Congratulations, you’ve performed a mail merge—a task many people consider to be one of the most difficult procedures in word-processing.

---

**Quick Reference**

To Mail Merge Records with Microsoft Word:

1. Open or select the table, query or report you want to use for the mail merge.
2. Click the Office Links button arrow on the toolbar and select Merge It with MS Word from the list.
3. Specify whether you wish to merge to an existing Word document or if you want to create a new Word document.
4. Perform the mail merge using Microsoft Word.
Lesson 11-8: Using Hyperlink Fields

In this lesson, you will learn about how to use hyperlinks in Microsoft Access. A hyperlink can point to any file on your computer, on the network, or even a Web page on the Internet. Whenever you click on a hyperlink, you jump to the hyperlink’s destination (if it’s available). A hyperlink is usually indicated by colored and underlined text. If you have ever been on the World Wide Web you’ve used hyperlinks all the time to move between different Web pages.

You can use the hyperlink field to store clickable links to files on your computer or network or to Web pages on the Internet.

In this lesson you will learn how to use hyperlink fields to create links that point to files on your network or on the Internet.

1. **Open the tblTours table in Design view.**
   First we need to add a hyperlink field to this table.

2. **Click in the first blank row and type Link.** Click the Link Data Type arrow and select Hyperlink from the list.
   You’ve created a hyperlink field!

---

© 2000 CustomGuide.com
3. **Save your changes and then click the View button on the toolbar to display the table in Datasheet view.**

   Let’s try adding a hyperlink to the Western Canada record.

4. **Click the Link field for the Western Canada record and click the Insert Hyperlink button on the toolbar.**

   The Insert Hyperlink dialog box appears, as shown in Figure 11-14. This is where you specify the name and location of the file or Web page you want to add as a hyperlink. If you know the location and name of the file or Web address you can type it directly in the dialog box, otherwise you can use the Browse button to locate the file.

5. **Click the File button next to the “Or Select From List” list.**

   The Link to File dialog box appears, which displays a list of files that you can use as the destination for your hyperlink.

6. **Browse to your practice folder, find and double-click the Canada Memo document.**

   The Link to File dialog box closes and the name and location of the Canada Memo is added to the Link to file or URL text box.

7. **Click OK.**

   The dialog box closes and you return to the Datasheet. Notice the text “Canada Memo.doc” appears blue and underlined, signifying that it’s a hyperlink. Let’s see how our new hyperlink works.

8. **Click the Canada Memo.doc hyperlink**

   You immediately jump to the hyperlink’s destination—in this case, the Canada Memo document.

9. **Close Microsoft Word without saving any changes.**

   You should be back in Microsoft Access, looking at the tblTours Datasheet.

   Once you create a hyperlink, you can easily edit it to change its title or target, copy it, or delete it by right-clicking the hyperlink. Try it!

10. **Right-click the Canada Memo.doc hyperlink and select Hyperlink from the shortcut menu.**

    A shortcut menu with the most frequently used hyperlink commands appears, as shown in Figure 11-15. Here you could select Edit Hyperlink to change the hyperlink’s target or Select Hyperlink to edit the hyperlink’s title. Your hyperlink is fine the way it is, so close the shortcut menu.

11. **Click anywhere in the Datasheet to close the shortcut menu. Close the tblTours table without saving any changes.**
Lesson 11-9: Using OLE Object Fields

Perhaps the least understood of all fields, the OLE Object data type lets you store files created in other programs such as graphics, Excel spreadsheets, or Word documents. This lesson will give you some practice working with OLE object fields.

1. **Open the tblEmployees table in Design view.**
   First we need to add an OLE field to this table.

2. **Click in the first blank row and type Photo. Click the Photo Data Type arrow and select OLE Object from the list.**
   You’ve created an OLE Object field!

3. **Save your changes and then click the View button on the toolbar to display the table in Datasheet view.**
   Let’s try adding an OLE Object.

4. **Click in any field for Maria Wyatt, scroll to the right, click in the Photo field for the Maria Wyatt record (use the record selector as a guide) and select Insert → Object from the menu.**
   The Object dialog box appears, as shown in Figure 11-16. You can create and then insert new objects by selecting the Create New option, or by clicking the Create from File option to insert an existing file. For this exercise, we already created and saved a photo, so you need to select the Create from File option.
5. Click the **Create from File** option.
   The Object dialog box displays the Create from File options, as shown in Figure 11-17. Here you specify the name and location of the file you want to insert.

6. Click the **Browse button**.
   Now you need to find and locate the file you want to insert into your document.

7. **Browse to your Practice folder, find and double-click the Maria.bmp file.**
   The name and location of the Maria.bmp file appears in the File box. Before we close the Insert Object dialog box, there is one more very important option we need to explore—the Link check box. The Link check box determines whether the OLE object is actually *embedded* within the database or merely *linked* to it. This is rather difficult concept for most people—you might want to look at Table 11-11: *Embedded vs. Linked Objects* for more on the differences between the two.

   For this exercise, we want to embed the graphic within the database, so we’ll leave the Link box unchecked.

8. **Click OK.**
   The dialog box closes, and Access embeds the Maria.bmp picture in the Photo field.

9. Close the tblEmployees table. Click the **Forms icon** in the Objects bar, click the **frmEmployees form**, and click the **Design button**.
   First we need to add the new photo field to the form.

10. **Click the Field List button** on the toolbar, if necessary. Click and drag the Photo field anywhere on the form.
    Don’t worry about where you place the Photo OLE object field or if it covers other fields—we’re not striving for perfection here. As with any other form control, you can move and resize OLE object fields.

    Let’s see how the Photo field looks in Form view.

11. **Click the View button** on the toolbar to switch to Form View. Click the Next Record Navigation button until you find the record for Maria.
    Yep! There’s the picture!

12. **Exit Microsoft Access without saving any changes.**

### Table 11-11: Embedded vs. Linked Objects

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Embedded (Link box not checked)</td>
<td>An embedded object is actually saved within the database. Databases with embedded objects are larger than databases with linked objects. The advantage of using embedded objects is that the objects are actually saved inside the database, so you don’t have to worry about any attached files becoming lost or erased.</td>
</tr>
<tr>
<td>Linked (Link box checked)</td>
<td>A linked object is not saved in the database. Instead, a link contains information on where to find the source data file. The advantage of using linked objects is that if the source file is changed, the linked object in the database is automatically updated to reflect the changes.</td>
</tr>
</tbody>
</table>

**Field List button**

Other Ways to Display the Field List:
- Select **View → Field List** from the menu.

---

### Quick Reference

**To Create an OLE Object Field:**
1. Display the table in Design View.
2. Create a new field to store the OLE objects.
3. Click the **Data Type box**, click the **Data Type list arrow**, and select **OLE Object**.
4. Save the table.

**To Insert an OLE Object:**
1. Select the OLE Object field, select **Insert → Object** from the menu.
2. Select either:
   - **Create New**: To create a new OLE object file—you must select the type of file you wish to create.
   - **Create from File**: To insert an existing file.
3. Click **OK**.
4. If you selected the Create from File option, browse to and double-click the file you want to insert and click **OK**.
Chapter Eleven Review

Lesson Summary

Importing Information

- **To Import Information from another File into Access:** From the Database window, select **File ➔ Get External Data ➔ Import** from the menu. Select the type of file you want to import from the **Files of type list**, browse to the appropriate drive and/or folder and double-click the file you want to import. Follow the on-screen instructions of the Import Wizard to import the data.

Exporting Information

- **To Export a Table to an External File:** From the Database window, right-click the table and select **Export** from the shortcut menu or select the table and select **File ➔ Export** from the menu. Select either: To an External File or Database (to save the table in an external file in a different format) or Within the Current Database as (to duplicate the table within the same database). Click **OK** and follow the on-screen instructions of the Export Wizard to export the data.

Importing Objects from another Access Database

- **To Import an Object from another Access Database:** From the Database window, select **File ➔ Get External Data ➔ Import** from the menu, browse to the appropriate drive and/or folder and double-click the database that contains the object(s) you want to import. Select the database object(s) you want to import and click **OK**.

Linking Information from an External Source

- **To Link a Table in another Database:** From the Database window, select **File ➔ Get External Data ➔ Link Tables** from the menu, browse to the appropriate drive and/or folder and double-click the database that contains the table you wish to link to. Click the table you wish to link and click **OK**.

Analyzing Records with Microsoft Excel

- **To Export Access Data to Microsoft Excel:** Open or select the table, query or report you want to export. Click the **Office Links button arrow** on the toolbar and select **Analyze It with MS Excel** from the list.

Exporting Records to Microsoft Word

- **To Export Access Data to Microsoft Word:** Open or select the table, query or report you want to export, click the **Office Links button arrow** on the toolbar and select **Publish It with MS Word** from the list.
Mail Merging Records to Microsoft Word

- **To Mail Merge Records with Microsoft Word:** Open or select the table, query or report you want to use for the mail merge, click the **Office Links button arrow** on the toolbar and select **Merge It with MS Word** from the list. Specify whether you wish to merge to an existing Word document or if you want to create a new Word document and perform the mail merge using Microsoft Word.

Using Hyperlink Fields

- **To Create a Hyperlink Field:** Display the table in Design View, create a new field to store the hyperlinks, click the new hyperlink field’s **Data Type box**, click the **Data Type list arrow** and select **Hyperlink** and save the table.

- **To Insert a Hyperlink:** Select the hyperlink field and click the **Insert Hyperlink button** on the toolbar or select the hyperlink field and select **Insert → Hyperlink** from the menu. Either select a file you want (use the browse button to help you locate the file) or type a Web address for the hyperlink’s destination and click **OK**.

- **To Edit a Hyperlink:** Right-click the hyperlink and select **Hyperlink → Edit Hyperlink** from the shortcut menu.

Using OLE Object Fields

- **To Create an OLE Field:** Display the table in Design View, create a new field to store the OLE objects, and click the new OLE field’s **Data Type box**, click the **Data Type list arrow** and select **OLE Object** and save the table.

- **To Insert an OLE Object:** Select the OLE Object field, select **Insert → Object** from the menu, select either Create New (to create a new OLE object file – you must select the type of file you wish to create) or Create from File (to insert an existing file), and click **OK**. If you selected the Create from File option, browse to and double-click the file you want to insert and click **OK**.

**Quiz**

1. One of the most common and basic file formats used to import, export, and exchange information between different programs is:
   
   A. A JPEG file.  
   B. A GIF file.  
   C. A tab or comma delimited text file.  
   D. A Microsoft Exchange-It file.

2. When you export a Microsoft Access table to an external data file, Access automatically includes the field names in the first row of the data file. (True or False?)

3. Which of the following database objects can you import from one Microsoft Access database to another? (Select all that apply.)
   
   A. Tables.  
   B. Queries.  
   C. Forms.  
   D. Reports.
4. When you create a link to a table in external database, Access imports the table into the current database. (True or False?)

5. The only way to export Access database information to Microsoft Excel is by saving it to an external file. (True or False?)

6. When you use the Publish It with MS Word command to send information to Microsoft Word, the data appears in:
   A. In a frightening dialog box that says General Protection Fault.
   B. In a comma delimited text format.
   C. In a tab delimited text format.
   D. In a table.

7. A hyperlink can point to: (Select all that apply.)
   A. A file on your computer.
   B. A file on a network.
   C. A Web page on the Internet.
   D. Only Microsoft Access database files.

8. Microsoft Access can import information from which of the following file formats?
   A. Excel workbooks.
   B. Comma-delimited text files.
   C. dBase database files.
   D. All of these.

9. You’re building a database for your mail-order bride company. You want your table to include a field that stores the picture of your prospective brides. What field type would you need to use?
   A. Memo.
   B. OLE.
   C. Hyperlink.
   D. Access can’t store graphics.

**Homework**

1. Open the Homework database.
2. Export the Insurance Claims table to a comma-delimited text file.
3. Create a link to the Employees table in the Lesson 1 database.
4. Export the Science Test Answers to a Microsoft Excel worksheet.
5. Export the Insurance Claims table to a Microsoft Word document. (If you’re really motivated, change the document’s Page Orientation so that the table fits on the page.)
6. Create a hyperlink in the Products table to the Maria.bmp file.
   **Hint:** You must first add a hyperlink field to the table.
Quiz Answers

1. C. Tab and comma delimited text files are the most common and basic type of file formats used to exchange information between different types of programs.

2. False. You must check the Include Field Names in the First Row of the Data File option to include the fields names in an imported or exported file.

3. A, B, C, and D. Any of these Microsoft Access objects from one Access database to another Access database.

4. False. When you link a table, that data stays in its original location.

5. False. You can export information to Excel by saving it to an external file—but you can also export it directly to Excel by clicking the Office Links list arrow and selecting Analyze It with Microsoft Excel.

6. D. When you use the Publish It with MS Word command, information sent to Word appears in a table.

7. D. Hyperlinks can point to any of these items.

8. D. Access can import information from all of these file formats.

9. B. OLE fields can store objects created in other programs, such as pictures and graphics.
Index

A
Access
  exiting ............................................... 57
Access 2000
  starting .............................................. 16
  what's new .......................................... 14
Access 97, converting from .................. 95
action queries ...................................... 181
  append queries ............................. 204
  delete queries ............................. 202
  make-table queries .......................... 206
  update queries ................................. 208
action reference, macros ..................... 314
actions
  arguments ........................................ 302
  conditional ...................................... 310
  description of .................................. 302
adding
  controls to a form............................ 237
  fields to a form................................ 222
  pictures and graphics....................... 290
  subforms to a form.......................... 244
advanced filter......................................112
aligning
  controls ........................................... 292
  text .................................................. 284
AND criteria ...................................... 82
append queries .................................. 181, 204
arguments, actions ................................ 302
ascending sort order ............................ 106
AutoForm Wizard .................................. 218
AutoFormat ........................................ 285
AutoKeys macro .................................. 312
AutoReport Wizard ................................ 254
avg function .................................... 191
B
between, criteria .................................. 180
blank
  databases .......................................... 70
tables .................................................. 76
bold .................................................. 282
bound object frame tool .................. 221, 257
buttons
  adding to forms ................................ 242
  macros, assign to .......................... 308
C
calculated controls
  forms .............................................. 240
  queries, in .................................... 184
  reports, on ...................................... 270
caption property .................................... 139
cascade delete related records.............. 171
cascade update related fields.............. 171
center alignment .................................... 284
charts, adding to reports .................. 274
check box tool .................................... 221, 257
check spelling ...................................... 50
chiseled, special effect format ............ 287
ClipArt, inserting ............................... 290
close button ......................................... 57
color, changing ..................................... 286
columnar
  forms ............................................... 85, 219
  reports ............................................ 255
columns
  adjusting width of ......................... 114
  freezing ......................................... 118
  hiding ............................................ 119
combo box tool ................................... 221, 257
command button tool ......................... 221, 257
compact, database .................................. 94
conditions
  macros, assigning to ......................... 310
  queries, using the IIF function .......... 188
Control Wizard .................................... 242
control wizard tool ........................... 221, 257
controls
  adding to forms ................................ 237
  aligning with one another ................. 292
moving ..................................... 224, 260
resizing ..................................... 224, 260
selecting multiple ......................... 236
converting, Access 97 databases ............ 95
copying
  database objects ........................... 90
  form controls ............................... 237
  text ............................................ 46
count function .................................. 191
creating
  blank databases ................................ 70
  database with the Database Wizard .... 68
  forms using the Form Wizard ............. 84
  forms, using the AutoForm Wizard ....... 218
  queries ........................................ 78
  reports ....................................... 254
  tables ......................................... 72
  tables from scratch ....................... 76
criteria ........................................ 78, 110, 180
cross-tab queries ............................ 78, 180
Ctrl key ........................................ 26
cutting
  database objects ............................ 90
  form controls ............................... 237
  text .......................................... 46
data entry
  in form ....................................... 36
  in tables ..................................... 32
data types ..................................... 74, 136
database objects
  inserting ...................................... 324
  managing ..................................... 90
  printing ...................................... 42
  Database Wizard ............................. 68
  databases
  closing ........................................ 57
  converting .................................... 95
  creating from scratch ..................... 70
  creating with the Database Wizard ...... 68
guidelines for creating ..................... 66
  introduction to ............................. 12
  objects, description of .................. 13
  opening ...................................... 28
  planning ..................................... 66
datasheets
  formatting .................................. 117, 120
  forms ......................................... 85, 219
dates
  adding to reports .......................... 264
  data type ................................... 74, 136
default property ............................. 148, 241
delete queries .................................. 181, 202
deleting
  database objects ........................... 90
  fields in a table ............................ 134
  records ...................................... 34, 36
delimited text files
  exporting ..................................... 322
  importing ..................................... 320
descending sort order ...................... 106
description property .......................... 138
Design View
  forms ......................................... 220
  queries ....................................... 78, 80
  reports ....................................... 256
  tables ......................................... 74
  working with ................................ 28
dialog boxes ................................... 24
duplicate records, finding .................. 196
E
editing records in a table .................. 34
etched, special effect format .............. 287
events, macro, assigning to .............. 308
Excel, exporting to .......................... 326
exit, Excel program ......................... 57
exporting
  external files ............................... 322
  records to a mail merge .................. 328
  to Microsoft Word .......................... 327
  to Microsoft Excel .......................... 326
Expression Builder
  macros, using with ......................... 310
  using .......................................... 186
expressions
  calculated controls in forms ........... 240
  calculated controls in reports .......... 270
  conditional .................................. 188
  macros, conditional statements ........ 310
  queries ...................................... 184, 186
F
F1 key ........................................... 52
Field List button ............................ 223, 259
field size property .......................... 140
fields
  adding to a table ........................... 74, 134, 136
  AutoNumber .................................. 75
  caption property ............................ 139
  currency ...................................... 75
  data types ................................... 74, 136
  date/time ..................................... 75
default property ............................. 148, 241
  deleting from a table ...................... 134
description property.......................... 138
field size property......................... 140
format property......................... 142, 144, 146
forms, adding to.......................... 222
hyperlink.................................. 75
hyperlink, creating...................... 330
indexing................................... 130
Input Mask property.................... 152
lookup lists................................ 154
memo........................................ 75
number...................................... 75
OLE object.............................. 75, 332
properties, description of............. 128
reports, adding to....................... 258
required property....................... 149
text.......................................... 75
validation rule property............... 150
value lists............................... 156
Yes/No...................................... 75
file management........................... 92
files
  deleting.................................. 92
  exporting................................ 322
  importing............................... 320
  renaming................................ 92
filter
  advanced................................. 112
  AND/OR criteria ....................... 110
  by form.................................. 110
  by selection............................ 108
  criteria, using......................... 110
  excluding selection................... 108
  remove.................................. 108
first function............................ 191
flat file databases, description of.... 166
flat, special effect format............. 287
fonts
  colors, changing....................... 286
  formatting in Datasheets............. 120
  formatting using the toolbar........ 282
  style.................................... 282
footer, report........................... 266
form selector............................ 232
Form Wizard............................... 84
format codes............................ 144
Format Painter............................ 288
format property......................... 142, 144, 146
formatting
  AutoFormat.............................. 285
  colors, changing....................... 286
  copying................................ 288
  currency fields....................... 142, 144
  date/time fields...................... 142, 144
  fonts in Datasheets................... 120
number fields........................... 142, 144
Properties dialog box, using........ 294
special effects........................ 287
text alignment......................... 284
text fields............................... 146
forms
  adding fields to....................... 222
  AutoForm, creating forms with...... 218
  buttons, adding to.................... 242
  calculated controls................... 240
  columnar................................ 219
  creating using the Form Wizard...... 84
data entry in............................ 36
datasheet................................ 219
default views............................ 233
description of.......................... 36, 217
Design View................................ 220
modifying................................ 220
moving controls........................ 224
pictures, adding to.................... 290
properties, viewing and modifying.... 232
property reference..................... 234
sizing controls........................ 224
subforms, adding to..................... 244
subforms, modifying.................... 246
tab order................................. 226
tabular.................................... 219
uses........................................ 217
freezing, columns....................... 118
functions
  average.................................. 271
  count.................................... 271
  IIF......................................... 188
  maximum.................................. 271
  minimum.................................. 271
  sum........................................ 271
G
graphics, inserting....................... 290
gridlines, formatting................... 117
group by, queries......................... 191
grouping report sections............... 268
groups, macro............................ 306
guidelines
  for creating a database.............. 66
table relationships, creating........ 166
H
header, report........................... 266
height, row................................ 114
help
  by contents............................ 52
  Office Assistant, using............... 52
  what is this button................... 54
hiding, columns ........................................ 119
hyperlinks
  fields, creating ................................ 330
  fields, working with .......................... 330
I
IIF function......................................... 188
image tool ........................................... 221, 257, 290
importing
  database objects .................................. 324
  external files .................................. 320
indexing fields .................................. 130
Input Mask property ............................ 152
inserting
  fields in a table ................................ 134
  objects from other Access databases ........ 324
pictures and graphics ............................ 290
is not null, criteria .............................. 180
is null, criteria .................................. 180
italics ............................................. 282
J
joining tables ..................................... 168
justified, form type .............................. 85
K
keyboard ............................................. 26
keystroke shortcuts ................................ 26
  common shortcuts ................................ 27
  macros, assigning to ............................ 312
L
label tool ........................................... 221, 257
labels, mailing ..................................... 88
landscape orientation ............................ 262
last function....................................... 191
left alignment ..................................... 284
like, criteria ....................................... 180
line tool ........................................... 221, 257
linking tables ..................................... 168, 325
list box tool ....................................... 221, 257
lookup lists
  creating ......................................... 154
  modifying ....................................... 158
M
macros
  action reference ............................... 314
  AutoKeys macro ................................ 312
  conditional actions ........................... 310
  creating ........................................ 302
  description of .................................. 301
  editing ......................................... 304
groups .............................................. 306
keystroke shortcuts, assigning to ............. 312
names .............................................. 306
running ............................................ 302
magnifying
  cells and field entries ........................ 56
  in Print Preview ................................ 42
mail merge records ................................ 328
mailing labels ..................................... 88
make-table queries ............................... 181, 206
managing
  database objects ............................... 90
  margins ......................................... 262
max function ....................................... 191
menus, using ....................................... 20
min function ....................................... 191
modifying
  forms ........................................... 220
  reports ......................................... 256
  subforms ....................................... 246
more controls tool .............................. 221, 257
mouse, right-clicking ............................ 91
moving
  columns ......................................... 116
  controls ......................................... 224, 260
  form controls .................................. 224
  pictures and graphics ......................... 290
  report controls ............................... 260
N
navigation buttons .............................. 36
new
  database from scratch ......................... 70
  database, using the Database Wizard ........ 68
  table from scratch .............................. 76
  table using the Table Wizard ................. 72
new in Access 2000 ............................... 14
not, criteria ..................................... 180
null, criteria .................................... 180
O
Office Assistant
  changing ......................................... 54
  using ............................................ 52
OLE object fields ............................... 332
opening
  database ........................................ 28
  forms ............................................ 36
  queries ......................................... 38
  reports ......................................... 40
  tables .......................................... 32
option button tool .............................. 221, 257
option tool ....................................... 221, 257
OR criteria ............................................ 82

P
page break tool.............................221, 257
page numbers ...................................... 264
page orientation................................... 262
paper size, changing............................ 262
parameter queries.........................181, 194
pasting
database objects ................................ 90
form controls................................... 237
text .................................................... 46
pictures, inserting................................ 290
planning
databases ........................................... 66
table relationships ........................... 166
portrait orientation .............................. 262
previewing
database objects ................................ 42
reports .............................................. 40
primary key
referential integrity, using in ........... 170
setting............................................... 132
table relationships, using in ......... 168
Print button ........................................... 43
printing
advanced options................................ 42
number of copies................................ 43
page range............................................ 43
properties .......................................... 43
reports .............................................. 40
selecting printers ................................ 43
properties
caption............................................. 139
control reference ............................ 230
control, viewing and modifying .... 228
data source, changing...................... 238
default ............................................. 148, 241
description ....................................... 138
description of ................................... 128
field size ............................................ 140
form reference ................................... 234
format ................................................. 142, 144, 146
formatting ....................................... 294
forms ................................................. 232
Input Mask ......................................... 152
required ............................................ 149
section ............................................... 272
validation rule .................................... 150

Q
queries
action ................................................. 181
AND/OR criteria ................................. 82
append queries ................................. 181, 204
calculated fields ................................. 184, 186
conditional expressions ........................ 188
creating ............................................. 78
creating in Design View ...................... 78
criteria ................................................. 78, 180
crosstab queries ................................. 181, 200
delete queries ................................. 181, 202
description of ...................................... 38
displaying in Design View ................... 38
duplicate records, finding .................. 196
Expression Builder, using ................. 186
expressions ........................................... 186
IIF function ......................................... 188
make-table queries ............................. 181, 206
modifying .........................................38, 80
multiple tables, adding to ................. 182
parameter queries ............................. 181, 194
select queries .................................. 181
sorting with ....................................... 81
summerizing information .................. 190
top and bottom values ....................... 192
types of ............................................... 181
union queries ...................................... 181
unmatched records, finding .............. 198
update query ..................................... 181, 208

R
raised, special effect format ................. 287
rearranging
columns ............................................ 116
fields ................................................. 134
form tab order ................................... 226
record navigation buttons ................... 32
records
adding .............................................. 32, 34
deleting ........................................... 34, 36
duplicate, finding ......................... 196
editing ............................................... 34
navigating ......................................... 32, 36
sorting .............................................. 106
unmatched, finding ....................... 198
rectangle tool ....................................... 221, 257
referential integrity
setting............................................. 170
working with ................................... 172
relational databases, description of ...... 166
relationships
creating ........................................... 168
referential integrity, setting ............ 170
referential integrity, working with ... 172
types of ............................................. 174
renaming
control labels ..................................... 258
database objects .................................................90
reordering
  fields in a table .............................................134
form tab order ..................................................226
table columns ..................................................116
repair, database ..................................................94
Report Wizard ..................................................86
reports
  adding fields to ............................................258
  AutoReport, creating reports with ..........................254
  calculated controls .........................................270
  charts, adding to ............................................274
columnar ..........................................................255
  creating using the Report Wizard .........................86
description of ..................................................40, 253
Design View ....................................................256
  fields to a form ..............................................258
  footer ................................................................266
  header ................................................................266
  margins, changing ............................................262
  modifying ..........................................................256
  moving controls ...............................................260
  opening .............................................................40
  page numbers, adding .........................................264
  page orientation ...............................................262
  pictures, adding to ............................................290
  printing .............................................................40
section properties ..............................................272
sections, description of .....................................266
sections, grouping and sorting ..............................268
size, changing ....................................................262
sizing controls ....................................................260
tabular ...............................................................255
uses .................................................................253
required property ..................................................149
resizing
  controls ............................................................224, 260
  forms and reports ..............................................262
  windows ............................................................30
right alignment .....................................................284
right-clicking ......................................................26, 91
rows, adjusting height of ....................................114
run
  macros .............................................................302
  macros, when user click button .........................308
  macros, with keystroke shortcuts ......................312
S
screen, Microsoft Access ............................................19
sections, reports
  description of ..................................................266
  grouping and sorting ........................................268
  properties ........................................................272
select objects tool ..............................................221, 236, 257
select queries ......................................................181
selecting
  controls, multiple .............................................236
  forms and reports .............................................232
  records .............................................................44
text .................................................................44
selection handles ..............................................224, 260
SendKey syntax ...................................................312
shortcut menus ....................................................26, 91
size, font ...........................................................282
sorting
  queries, using ..................................................81
  report sections ..................................................268
  using queries ...................................................81
  using the Sort command .....................................106
special effects, formatting ...................................287
spell check ..........................................................50
starting, Microsoft Access .....................................16
status bar
  description of ..................................................19
  user prompts, adding to ....................................138
  stdev function ..................................................191
subform/subreport tool ......................................221, 257
subforms
  creating ..........................................................244
  modifying ..........................................................246
  sum function .....................................................191
summerizing
  information with crosstab queries ......................200
  information with queries ..................................190
  reports, records in ...........................................268
  sunken, special effect format ................................287
T
tab control tool ..................................................221, 257
tab order ...........................................................226
Table Wizard .....................................................72
tables
  adding to a query .............................................182
  creating ...........................................................72
  creating from scratch ........................................74, 76, 136
description of ..................................................32
Design View .....................................................74
edit information in .............................................34
linking .............................................................325
modifying in Design View .....................................74
relationships, creating .......................................168
tabular
  forms .............................................................85, 219
  reports ............................................................255
text
  alignment ........................................................284
formatting ....................................... 282
text box tool ..................................... 221, 257
text files
   exporting ....................................... 322
   importing ....................................... 320
title bar
   caption, changing ............................ 232
   description of .................................... 19
toggle button tool .........................221, 257
toolbars, using....................................... 22
Toolbox ........................................220, 256
top and bottom values ......................... 192
totals
   crosstab queries, finding with ....... 200
   queries, finding with ...................... 190
   reports, adding to ......................... 270
U
   unbound object frame tool ........221, 257
   underline ............................................. 282
   undo ...................................................... 48
   union queries ................................. 181
unmatched records, finding.................198
update queries .............................181, 208
V
   validation rule property .................... 150
   value lists
      creating ......................................... 156
      modifying ....................................... 158
   var function ...................................... 191
W
   what is this button ......................... 54
   width, column .................................... 114
   windows, working with ..................... 30
Word
   exporting records to ....................... 327
   mail merge, performing ................... 328
Z
   Zoom dialog box ................................ 56