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Introduction
Welcome to CustomGuide: Microsoft Excel 2000. CustomGuide courseware allows
instructors to create and print manuals that contain the specific lessons that best meet their
students’ needs. In other words, this book was designed and printed just for you.
Unlike most other computer-training courseware, each CustomGuide manual is uniquely
designed to be three books in one:
•

Step-by-step instructions make this manual great for use in an instructor-led class or as a
self-paced tutorial.

•

Detailed descriptions, illustrated diagrams, informative tables, and an index make this
manual suitable as a reference guide when you want to learn more about a topic or
process.

•

The handy Quick Reference box, found on the last page of each lesson, is great for when
you need to know how to do something quickly.

CustomGuide manuals are designed both for users who want to learn the basics of the
software and those who want to learn more advanced features.
Here’s how a CustomGuide manual is organized:

Chapters
Each manual is divided into several chapters. Aren’t sure if you’re ready for a chapter? Look
at the prerequisites that appear at the beginning of each chapter. They will tell you what you
should know before you start the chapter.

Lessons
Each chapter contains several lessons on related topics. Each lesson explains a new skill or
topic and contains a step-by-step exercise to give you hands-on-experience.

Chapter Reviews
A review is included at the end of each chapter to help you absorb and retain all that you have
learned. This review contains a brief recap of everything covered in the chapter’s lessons, a
quiz to assess how much you’ve learned (and which lessons you might want to look over
again), and a homework assignment where you can put your new skills into practice. If you’re
having problems with a homework exercise, you can always refer back to the lessons in the
chapter to get help.
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How to Use the Lessons
Every topic is presented on two facing pages, so that you can concentrate on the lesson
without having to worry about turning the page. Since this is a hands-on course, each lesson
contains an exercise with step-by-step instructions for you to follow.
To make learning easier, every exercise follows certain conventions:
•

Anything you’re supposed to click, drag, or press appears like this.

•

Anything you’re supposed to type appears like this.

•

This book never assumes you know where (or what) something is. The first time you’re
told to click something, a picture of what you’re supposed to click appears either in the
margin next to the step or in the illustrations at the beginning of the lesson.

Illustrations show what your
screen should look like as you
follow the lesson. They also
describe controls, dialog boxes,
and processes.

24
24
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Lesson
Lesson4-2:
4-2:Formatting
FormattingValues
Values
Figure 4-3
TheFigure
Numbers tab4-3
of the

Format
dialogtabbox.
The Cells
Numbers
of the
Format Cells dialog box.

Figure 4-4
TheFigure
Expense Report
4-4

worksheet
values Report
before
The Expense
being
formatted.
worksheet
values before
being formatted.

Preview of the
selected
number
Preview
of the
format
selected number
format

Select a number
category
Select a number
category

Select a number
format
Select a number
format

Figure 4-5
TheFigure
Expense Report
4-5

An easy-to-understand
introduction explains the task or
topic covered in the lesson and
what you’ll be doing in the
exercise.

worksheet
values Report
after being
The Expense
formatted.
worksheet values after being
formatted.

Figure 4-3
Figure 4-3

Figure 4-4
Figure 4-4

Tips and traps appear in the
margin.
Icons and pictures appear in the
margin, showing you what to
click or look for.
Clear step-by-step instructions
guide you through the exercise.
Anything you need to click
appears like this.
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You can also format
values
the
You by
canusing
also format
Formatting
values by toolbar
using the
or Formatting
by selectingtoolbar
Cells
Format
or by →
selecting
from
the menu
and
→ Cells
Format
clicking
from the menu and
Number
tab.
clicking
the
Number tab.

Comma Style
Comma
button Style
button

Figure 4-5
Figure 4-5

In this lesson, you will learn how to apply number formats. Applying number formatting changes
how
are displayed—it
doesn’t
actual
information
in any
way. Excel
is often
In values
this lesson,
you will learn
how tochange
apply the
number
formats.
Applying
number
formatting
changes
smart
some number
formatting
automatically.
For example,
you Excel
use a dollar
howenough
values to
areapply
displayed—it
doesn’t
change the
actual information
in anyifway.
is often
sign
to indicate
$548.67),
Excel will
automatically
the currency
smart
enoughcurrency
to apply (such
some as
number
formatting
automatically.
Forapply
example,
if you usenumber
a dollar
format
you. currency (such as $548.67), Excel will automatically apply the currency number
sign for
to indicate
format for you.
The Formatting toolbar has five buttons (Currency, Percent, Comma, Increase Decimal, and
The Formatting
buttons apply
(Currency,
Percent,
Comma,
Increase
Decrease
Decimal)toolbar
you canhas
usefive
to quickly
common
number
formats.
If noneDecimal,
of these and
buttons
Decimal)
you
can
useneed
to quickly
apply
common
formats.
If none of
these →
buttons
hasDecrease
what you’re
looking
for,
you
to use the
Format
Cellsnumber
dialog box
by selecting
Format
menulooking
and clicking
theneed
Number
numbers
theselecting
Format Cells
Cells
hasfrom
whatthe
you’re
for, you
to usetab.
theFormatting
Format Cells
dialog with
box by
Format →
from
theasmenu
and
clicking
the Number
Formatting
Format options.
Cells
Cellsbox
dialog
isn’t
fast as
using
the toolbar,
but ittab.
gives
you morenumbers
precisionwith
and the
formatting
dialog
as fastinasthis
using
the toolbar, but it gives you more precision and formatting options.
We’ll
usebox
bothisn’t
methods
lesson.
We’ll use both methods in this lesson.

1. Select the cell range D5:D17 and click the Comma Style button on
the celltoolbar.
range D5:D17 and click the Comma Style button on
1.theSelect
Formatting
theadds
Formatting
toolbar.(the comma) and two decimal places to the selected cell
Excel
a hundreds separator
range.
Excel adds a hundreds separator (the comma) and two decimal places to the selected cell
range.

Introduction

•

When you see a keyboard instruction like “press <Ctrl> + <B>,” you should press and
hold the first key (<Ctrl> in this example) while you press the second key (<B> in this
example). Then, after you’ve pressed both keys, you can release them.

•

There is usually more than one way to do something in Excel. The exercise explains the
most common method of doing something, while the alternate methods appear in the
margin. Use whatever approach feels most comfortable for you.

•

Important terms appear in italics the first time they’re presented.

•

Whenever something is especially difficult or can easily go wrong, you’ll see a:
NOTE:
immediately after the step, warning you of pitfalls that you could encounter if you’re not
careful.

•

Our exclusive Quick Reference box appears at the end of every lesson. You can use it to
review the skills you’ve learned in the lesson and as a handy reference—when you need
to know how to do something fast and don’t need to step through the sample exercises.

Formatting a Worksheet
Formatting a Worksheet
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2. Click cell A4 and type Annual Sales.
cell A4inand
type Annual
Sales. as currency.
2. Click
The numbers
this column
should be formatted

Anything you need to type
appears like this.

The numbers in this column should be formatted as currency.

3. Press <Enter> to confirm your entry and overwrite the existing
<Enter> to confirm your entry and overwrite the existing
3. Press
information.
information.

4. Select the cell range G5:G17 and click the Currency Style button on
the cell range
G5:G17 and click the Currency Style button on
4. Select
the Formatting
toolbar.
theA Formatting
dollar sign and toolbar.
two decimal places are added to the values in the selected cell range.

A dollar sign and two decimal places are added to the values in the selected cell range.

5. Select the cell range F5:F17 and click the Percent Style button on
the cell range
F5:F17 and click the Percent Style button on
5. Select
the Formatting
toolbar.
theExcel
Formatting
toolbar.
applies percentage style number formatting to the information in the Tax column.

Notice
therepercentage
isn’t a decimal
place—Excel
rounds
decimal places
to the
whole
Excel
applies
style number
formatting
to any
the information
in the
Taxnearest
column.
number.
suitable
here—you want
to include
a decimal
tonearest
accurately
show
Notice
thereThat
isn’tisn’t
a decimal
place—Excel
rounds
any decimal
placesplace
to the
whole
number.
Thattax
isn’t
suitable here—you want to include a decimal place to accurately show
the exact
rate.
the exact tax rate.

Currency Style
Currency
Style
button
Otherbutton
Ways to Apply

Currency
Formatting:
Other
Ways to
Apply
Currency
Formatting:
• Type the
dollar sign ($)
you enter
a number.
• Typebefore
the dollar
sign ($)
before you enter a number.

6. With the Tax cell range still selected, click the Increase Decimal
the Tax
cellFormatting
range still toolbar.
selected, click the Increase Decimal
6. With
button
on the

Whenever there is more than
one way to do something, the
most common method is
presented in the exercise and
the alternate methods are
presented in the margin.

button
on the
Formatting
Excel adds
one decimal
place totoolbar.
the information in the tax rate column.

Excel
adds
decimal
placethe
to date
the information
in date
the tax
rate column.
Next,
youone
want
to change
format in the
column.
There isn’t a “Format Date”
button
thetoFormatting
so you
havecolumn.
to format
the date
using
the
Next,
youon
want
change thetoolbar,
date format
inwill
the date
There
isn’tcolumn
a “Format
Date”
button
on the
Formatting
toolbar, so you will have to format the date column using the
Format
Cells
dialog box.
Format
Cells dialogtoolbar
box. is great for quickly applying the most common formatting options to
The Formatting
but it doesn’t
every
formatting
To see and/or
use every
possible
Thecells,
Formatting
toolbaroffer
is great
foravailable
quickly applying
theoption.
most common
formatting
options
to
cells,
but it doesn’t
offeroption
everyyou
available
formatting
option.Cells
To see
and/or
useYou
every
character
formatting
have to
use the Format
dialog
box.
canpossible
open the
character
option
youeither
haveselecting
to use theFormat→
Format Cells
box.menu
You or
canright-clicking
open the
Formatformatting
Cells dialog
box by
Cellsdialog
from the
fromselecting
the shortcut
menu.Cells from the menu or right-clicking
and selecting
Format
Format
Cells dialog
box Cells
by either
Format→
and selecting Format Cells from the shortcut menu.

7. With the Date cell range still selected, select Format → Cells from
Dateselect
cell range
still from
selected,
select
Format
→ click
Cells OK.
from
7. With
thethe
menu,
4-Mar-97
the Type
list
box and
the menu, select 4-Mar-97 from the Type list box and click OK.

That’s all there is to formatting values–not as difficult as you thought it would be, was it? The
following
table
lists
the five buttons
on the
Formatting
toolbar
you it
can
use tobe,apply
That’s
all there
is to
formatting
values–not
as difficult
as you
thought
would
was number
it? The
formatting
the values
your worksheets.
following
tabletolists
the fiveinbuttons
on the Formatting toolbar you can use to apply number
formatting to the values in your worksheets.

Table 4-2: Number Formatting Buttons on the Formatting Toolbar
Table
4-2:
Number Formatting
on the Formatting Toolbar
Button
Name
Example Buttons
Formatting
Button Name
Example
$1,000.00 Formatting
Adds a dollar sign, comma, and two decimal places.
Currency
$1,000.00 Adds a dollar sign, comma, and two decimal places.
Currency
100%
Displays the value as a percentage with no decimal places.
Percent
100%
Displays the value as a percentage with no decimal places.
Percent
1,000
Separates thousands with a comma.
Comma
1,000
Separates thousands with a comma.
Comma
1000.00
Increases the number of digits after the decimal point by one
Increase Decimal
1000.00
Increases the number of digits after the decimal point by one
Increase Decimal
1000.0
Decreases the number of digits after the decimal point by one
Decrease Decimal
1000.0
Decreases the number of digits after the decimal point by one
Decrease Decimal

Quick Reference
Quick Reference
To Apply Number
To Formatting:
Apply Number
Formatting:
• Select the cell or cell range
youthe
want
and click
• Select
celltoorformat
cell range
appropriate
number
youthe
want
to format and
click
the formatting
appropriatebutton(s)
number on the
Formatting
toolbar.
formatting
button(s)
on the
Formatting
toolbar.
Or...

Or...• Select the cell or cell range you
want
format,
select
• Select
thetocell
or cell
rangeFormat
you
from
the menu,
want→toCells
format,
select
Formatclick
the Number
and click
specify
→ Cells
from thetab,
menu,
number
you want
the the
Number
tab,formatting
and specify
apply.formatting you want
the to
number
toOr...
apply.
Or...• Select the cell or cell range you
want
format,
right-click
the
• Select
thetocell
or cell
range you
cell range
and select
wantcell
to or
format,
right-click
the
Cellsand
fromselect
the shortcut
cell Format
or cell range
menu,
clickfrom
the the
Number
tab,
Format
Cells
shortcut
andclick
specify
number
menu,
the the
Number
tab,
want to apply.
andformatting
specify theyou
number
formatting you want to apply.

Tables provide summaries of the
terms, toolbar buttons, or
shortcuts covered in the lesson.

CustomGuide’s exclusive Quick
Reference is great for when you
need to know how to do
something fast. It also lets you
review what you’ve learned in
the lesson.

Chapter One: The
Fundamentals
Chapter Objectives:
•

Starting Microsoft Excel

•

Giving commands to Excel

•

Entering labels and values into a workbook

•

Navigating a workbook

•

Naming and saving a workbook

•

Previewing, and printing a workbook

•

Closing a workbook and exiting Excel

Chapter Task: Create a simple income and expense report
Welcome to your first lesson of Microsoft Excel 2000. Excel is a powerful spreadsheet
software program that allows you to make quick and accurate numerical calculations.
Entering data onto a spreadsheet (or worksheet as they are called in Excel) is quick and easy.
Once data has been entered in a worksheet, Excel can instantly perform any type of
calculation on it. Excel can also make your information look sharp and professional. The uses
for Excel are limitless: businesses use Excel for creating financial reports, scientists use Excel
for statistical analysis, families use Excel to help manage their investment portfolios.
Microsoft Excel is by far the most widely used and, according to most reviews, the most
powerful and user-friendly spreadsheet program available. You’ve made a great choice by
deciding to learn Microsoft Excel 2000.
This chapter will introduce you to the Excel basics—what you need to know to create, print,
and save a worksheet. If you’ve already seen the Microsoft Excel program screen before, you
know that it is filled with cryptic-looking buttons, menus, and icons. By the time you have
finished this chapter, you will know what most of those buttons, menus, and icons are used
for.

; Prerequisites
• A computer with
Windows 95, 98, 2000
or NT and Excel 2000
installed.
• An understanding of
basic computer
functions (how to use
the mouse and
keyboard).
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Lesson 1-1: Starting Excel
Figure 1-1
The Windows Desktop.
Figure 1-2
Programs located under
the Windows Start button.
Figure 1-3
The Microsoft Excel
program screen.
Figure 1-1

Figure 1-2

Figure 1-3

Before starting Microsoft Excel 2000 you have to make sure your computer is on—if it’s not,
turn it on! You start Excel 2000 the same as you would start any other Windows program on
your computer—with the Start button. Because every computer is set up differently (some
people like to rearrange their program menu) the procedure for starting Excel on your
computer may be slightly different from the one listed here.

Start button

1.
2.
3.

 2000 CustomGuide, Inc.

Make sure your computer is on and the Windows desktop is open.
Your computer screen should look similar to the one shown in Figure 1-1.
Use your mouse to point to and click the Start Button, located at the
bottom-left corner of the screen.
The Windows Start menu pops up.
Use the mouse to move the pointer over the word Programs.
A menu similar to the one shown in Figure 1-2 pops out to the right of Programs. The
programs and menus listed will depend on the programs installed on your computer, so
your menu will probably look somewhat different from the illustration.

Chapter One: The Fundamentals

4.
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On the Programs menu, point to and click Microsoft Excel.
Depending on how many programs are installed on your computer and how they are
organized, it might be a little difficult to find the Microsoft Excel program. Once you
click the Microsoft Excel program, your computer’s hard drive will whir for a moment
while it loads Excel. The Excel program screen appears, as shown in Figure 1-3.

That’s it! You are ready to start creating spreadsheets with Microsoft Excel. In the next lesson,
you will learn what all those funny-looking objects on your screen are.

Quick Reference
To Start the Microsoft
Excel Program:
1. Click the Windows Start
button.
2. Select Programs →
Microsoft Excel.
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Lesson 1-2: What’s New in
Excel 2000?
Figure 1-4
Creating interactive Web
pages is just one of Excel
2000’s new abilities.

Figure 1-4

If you’re upgrading from Excel 97 to Excel 2000 you’re in luck—in most respects Excel 2000
looks and works almost the same as your trusty version of Excel 97. Here’s what’s new in
Excel 2000:
Now you can see
through your
selections in Excel
2000.

Table 1-1: What’s New

 2000 CustomGuide, Inc.

New Feature

Description

Personalized
Menus

Office 2000 displays only the commands that you use most often on new
personalized menus and toolbars. A menu’s more advanced commands are
hidden from view, although you can easily expand a menu to reveal all of its
commands. After you click a command, it appears on your personalized menu.

Multiple Cut, Copy,
and Paste
Clipboard

Office 2000 programs share a multiple clipboard, which can hold up to 12
copied or cut objects instead of just one. The only problem with the new
clipboard is only Office 2000 programs can access all 12 copied or cut objects.

See What You
Have Open

Use the Windows taskbar to switch between open Office documents. Each
document appears as an icon on the taskbar.

Improved Office
Assistant

The Assistant uses less space on your screen, while still providing you with all
the help you need. If the Office Assistant can't answer your question, it can take
you to the Web for more information.

See-Through
Selection

Selected cells in Excel are easier to see and read, since Excel now uses a seethrough color scheme to indicate selected cells.

Euro Currency
Symbol

Additional number formats are available with the Euro currency symbol: .
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New Feature

Description

Detect and Repair

If you find that your Excel program is getting buggy, instead of reinstalling the
entire program, you can use Office 2000’s new Detect and Repair feature to
diagnose and fix the problem.

Create Web Pages

Support for the Internet has been greatly improved in all Office 2000 programs.
You can easily save your Excel workbooks as Web pages, and even create
interactive Web pages which have basic spreadsheet functionality and allow
users to add, change, calculate, and analyze data.

Keep Officespecific
Formatting in Web
Pages

You can still use Excel features that aren’t supported on the Web. When you
save a workbook as a Web page, formatting options that aren’t supported on
the Web are still stored in the file, so when you open the Web page in Excel the
non-supported Web options are retained.

Start a Discussion

In either your Web browser or in Excel, you and your colleagues can review a
workbook. You can place a discussion pane at the bottom of a workbook to add
comments or have conversations about the workbook, or you can add your
comments right in the text of the workbook. (This feature requires that Office
Server Extensions be installed on your Web server.)

Improved
PivotTable Reports

PivotTable Reports have been completely revamped in Excel 2000. Instead of
using a non-intuitive diagram to create a PivotTable report, now you can use
drop and drag to lay out a PivotTable directly on the worksheet. PivotTable
reports can now easily be formatted with the AutoFormat command. Finally, row,
column, and page fields now have drop-down arrows, which you can use to
show or hide items in the fields.

PivotCharts

PivotCharts bring the power of PivotTable reports to your charts. Just like
PivotTable reports, PivotCharts are interactive and have field buttons that you
can use to show and hide items in a chart.
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Lesson 1-3: Understanding the
Excel Program Screen
Title bar

Figure 1-5

Menu bar

Standard toolbar

Formatting
toolbar

Formula bar

Elements of the Excel
program screen.
Name box

Cell pointer and
currently active
cell
Worksheet
window

Column
headings

Row headings

Sheet tab
scrolling buttons

Status bar

Worksheet
tabs

Horizontal
scroll bar

Vertical
scroll bar

Figure 1-5

You might find the Excel 2000 program screen a bit confusing and overwhelming the first
time you see it. What are all those buttons, icons, menus, and arrows for? This lesson will
help you become familiar with the Excel program screen. There are no step-by-step
instructions in this lesson. All you have to do is look at Figure 1-5 then refer to Table 1-1: The
Excel Program Screen, to see what everything you’re looking at means. And, most of all,
relax! This lesson is only meant to help you get aquatinted with the Excel screen; you don’t
have to memorize anything.

 2000 CustomGuide, Inc.
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Table 1-1: The Excel Program Screen
Element

What it’s Used For

Title bar

Displays the name of the program you are currently using (in this case,
Microsoft Excel) and the name of the workbook you are working on. The title bar
appears at the top of all Windows programs.

Menu Bar

Displays a list of menus you use to give commands to Excel. Clicking a menu
name displays a list of commands. For example, clicking the Format menu
name displays different formatting commands.

Standard toolbar

Toolbars are shortcuts—they contain buttons for the most commonly used
commands (instead of having to wade through several menus). The Standard
toolbar contains buttons for the Excel commands you use the most, such as
saving, opening, and printing workbooks.

Formatting toolbar

Contains buttons for the most commonly used formatting commands, such as
making text bold or italicized.

Worksheet window

This is where you enter data and work on your worksheets. You can have more
than one worksheet window open at a time, allowing you to work on several
worksheets.

Cell Pointer and
Active Cell

This highlights the cell you are working on. The current cell in Figure 1-5 is
located at A1. To make another cell active just click the cell with the mouse or
press the arrow keys on the keyboard to move the cell pointer to a new location.

Formula Bar

Allows you to view, enter, and edit data in the current cell. The Formula bar
displays any formulas a cell might contain.

Name Box

Displays the active cell address. In Figure 1-5 “A1” appears in the name box,
indicating that the active cell is A1.

Worksheet Tabs

You can keep multiple worksheets together in a group called a workbook. You
can move quickly from one worksheet to another by clicking the worksheet tabs.
You can give worksheets your own meaningful names, such as “Budget” instead
of “Sheet1.” Excel workbooks contain three worksheets by default.

Scroll bars

There are both vertical and horizontal scroll bars; you use them to view and
move around your spreadsheet. The scroll box shows where you are in the
workbook. For example, if the scroll box is near the top of the scroll bar, you’re
at the beginning of a workbook.

Status bar

Displays messages and feedback.
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Lesson 1-4: Using Menus
Figure 1-6
The File menu.
Check to hide
more advanced
menu commands.

Figure 1-7
The Customize dialog box.
Figure 1-6

Figure 1-7
Open a menu by
clicking it or by
pressing the <Alt> key
and the underlined
letter in the menu.

This lesson explains one of the easiest ways to give commands to Excel—by using the menus.
Menus for all Windows programs can be found at the top of a window, just beneath the
program’s title bar. In Figure 1-6 notice the words File, Edit, View, Insert, Tools, Data,
Window, and Help. The next steps will show you why they’re there.

1.

2.

The Tools menu with
every command
displayed.

3.
4.
5.

The Tools menu with
less frequently used
commands hidden.

 2000 CustomGuide, Inc.

Click the word File on the menu bar.
A menu drops down from the word File, as shown in Figure 1-6. The File menu
contains a list of file-related commands such as New, which creates a new file; Open,
which opens or loads a saved file; Save, which saves the currently opened file; and
Close, which closes the currently opened file. Move on to the next step to try selecting
a command from the File menu.
Click the word Close in the File menu.
The workbook window disappears—you have just closed the current workbook. Notice
each of the words in the menu has an underlined letter somewhere in it. For example,
the F in the File menu is underlined. Holding down the <Alt> key and pressing the
underlined letter in a menu does the same thing as clicking it. For example, pressing
the <Alt> key and then the <F> key would open the File menu. Move on to the next
step and try it for yourself.
Press the <Alt> key then press the <F> key.
The File menu appears. Once you open a menu you can navigate through the different
menus using either the mouse, the arrow keys, or by typing the letter that is underlined
in the menu name.
Press the Right Arrow Key <→ >.
The next menu to the right, the Edit menu, appears. If you open a menu and then
change your mind, it’s easy to close it without selecting any commands. Just click
anywhere outside the menu or press the <Esc> key.
Click anywhere outside the menu to close the menu without issuing any
commands.
NOTE: The menus in Excel 2000 work quite a bit differently than in other Windows
programs—even than previous versions of Excel. Microsoft Excel 2000
displays its menu commands on the screen in three different ways:
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6.

7.

8.

•

By displaying every command possible, just like most Windows programs,
including earlier versions of Excel.

•

By hiding the commands you don’t use as frequently (the more advanced
commands) from view.

•

By displaying the hidden commands by clicking the downward-pointing arrows
( ) at the bottom of the menu or after waiting a couple of seconds.

Click the word Tools in the menu.
The most common menu commands appear first in the Tools menu. Some people feel
intimidated by being confronted with so many menu options, so the menus in Office
2000 don’t display the more advanced commands at first. To display a menu’s
advanced commands either click the downward-pointing ( ) at the bottom of the menu,
or keep the menu open a few seconds.
Click the downward-pointing arrow ( ) at the bottom of the Tools menu.
The more advanced commands appear shaded on the Tools menu.
If you’re accustomed to working with earlier versions of Microsoft Office you may
find that hiding the more advanced commands is disconcerting. If so, you can easily
change how Excel’s menus work. Here’s how:
Select View → Toolbars → Customize from the menu.
The Customize dialog box appears, as shown in Figure 1-7. Make sure the Options tab
is selected. This is where you can change how Excel’s menus work. There are two
check boxes here that are important:
•

Menus Show Recently Used Commands First: Clear this check box if
you want to show all the commands on the menus, instead of hiding the
advanced commands.

•

9.

Show Full Menus After a Short Delay: If checked, this option waits a few
seconds before displaying the more advanced commands on a menu.
Click Close.

Table 1-2: Menus found in Microsoft Excel
File

Description

File

File-related commands to open, save, close, print, and create new files.

Edit

Commands to copy, cut, paste, find, and replace text.

View

Commands to change how the workbook is displayed on the screen.

Insert

Lists items that you can insert into a workbook, such as graphics and charts.

Format

Commands to format fonts, cell alignment, and borders.

Tools

Lists tools such the spell checker and macros. You can also change Excel’s
default options here.

Data

Commands to analyze and work with data information.

Window

Commands to display and arrange multiple windows (if you have more than one
file open).

Help

Get help on using the program.
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The Tools menu with
less frequently used
commands is displayed
after clicking the
downward-pointing
arrow ( ) at the
bottom of the menu.

Quick Reference
To Open a Menu:
• Click the menu name with
the mouse.
Or…
• Press <Alt> and then the
underlined letter in menu.
To Display a Menu’s
Hidden Commands:
• Click the downwardpointing arrow ( ) at the
bottom of the menu.
Or…
• Open the menu and wait
a few seconds.
To Change How Menus
Work:
1. Select View → Toolbars
→ Customize from the
menu.
2. Check or clear either the
Menus Show Recently
Used Commands First
and/or Show Full Menus
After a Short Delay
options, then click Close.

20

Microsoft Excel 2000

Lesson 1-5: Using Toolbars and
Creating a New Workbook
Click the to see additional
buttons on the toolbar.

Figure 1-8
The Standard and
Formatting toolbars
squished together on the
same bar.
Figure 1-9

Figure 1-8

Standard toolbar

Formatting toolbar

Standard toolbar

The Standard and
Formatting toolbars
stacked as separate
toolbars.
Figure 1-10
The Customize dialog box.

Figure 1-9

Formatting toolbar

Clear this option to display
the Standard and
Formatting toolbars
stacked as separate
toolbars.

Figure 1-10

New Workbook
button
Other Ways to Create a
New Workbook:
• Select File → New
from the menu.

In this lesson we move on to another very common way of giving commands to Excel—using
toolbars. Toolbars are shortcuts—they contain buttons for the most commonly used
commands. Instead of wading through several menus to access a command, you can click a
single button on a toolbar. Two toolbars appear by default when you start Excel for the first
time: the Standard toolbar and the Formatting toolbar.
The Standard toolbar is the toolbar located either on the left or on the top and contains buttons
for the commands you’ll use most often in Excel, such as Save and Print. The Formatting
toolbar is located either to the right or below the Standard toolbar bar and contains buttons for
quickly formatting fonts and paragraphs.

1.
Screen Tip
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Position the mouse pointer over the New button on the Standard toolbar
(but don’t click the mouse yet!)
A Screen Tip appears over the button briefly identifying what the button is, in this case
“New.” If you don’t know what a button on a toolbar does, simply move the pointer
over it, wait a second, and a Screen Tip will appear over the button, telling you what it
does.
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2.

3.
4.
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Click the New button on the Standard toolbar.
A new, blank workbook appears. Not only have you learned how to use Microsoft
Excel’s toolbars, but you’ve also learned how to create a new, blank workbook.
Today many computers have larger monitors, so Microsoft decided to save space on
the screen in Office 2000 and squished both the Standard and Formatting toolbars
together on the same bar, as shown in Figure 1-8. While squishing two toolbars
together on the same bar gives you more space on the screen, it also makes the two
toolbars look confusing—especially if you’re used to working with a previous version
of Microsoft Office. If you don’t like having both toolbars share the same bar you can
separate the Standard and Formatting toolbars and stack them on top of each other, as
illustrated in Figure 1-9.
Select View → Toolbars → Customize from the menu.
The Customize dialog box appears, as shown in Figure 1-10. This is where you can
change how Excel’s toolbars are displayed. To stack the Standard and Formatting
toolbars simply clear the “Standard and Formatting toolbars share one row” box.
Click Close.
The Customize dialog box closes.

Quick Reference
To Use a Toolbar Button:
• Click the button you want
to use.
To Display a Toolbar
Button’s Description:
• Position the pointer over
the toolbar button and
wait a second. A
ScreenTip will appear
above the button.
To Create a New
Workbook:
• Click the New button on
the Standard toolbar.
Or…
• Select File → New from
the menu.
To Stack the Standard and
Formatting toolbars in
Two Separate Rows:
• Select View → Toolbars
→ Customize from the
menu and remove the
check from the “Standard
and Formatting toolbars
share one row” option.
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Lesson 1-6: Hiding, Displaying,
and Moving Toolbars
Figure 1-11
Selecting a toolbar to
view.
Figure 1-12
Moving a toolbar.
Move a toolbar by
dragging its move handle.

Figure 1-11

Figure 1-12

When you first start Excel the Standard and Formatting toolbars appear by default. As you
work with Excel, you may want to display other toolbars, such the Drawing toolbar or the
Chart toolbar to help you accomplish your tasks. Soon your worksheet window is covered
with more buttons than NASA’s mission control room. This lesson explains how to free up
valuable space by moving Excel’s toolbars to different positions on the screen, or by
removing them entirely.

1.

Other Ways to Hide or
Display a Toolbar:
• Right-click any toolbar
and select the toolbar
you want to hide or
display from the
shortcut menu.

2.
3.
4.
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Select View → Toolbars from the menu.
A list of available toolbars appears, as shown in Figure 1-11. Notice check marks
appear next to the Standard and Formatting toolbars. This indicates the toolbars are
already selected and appear on the Excel screen.
Select Formatting from the toolbar menu.
The Formatting toolbar disappears. You can hide a toolbar if you don’t need to use any
of its commands or if you need to make more room available on the screen to view a
worksheet.
Select View → Toolbars → Formatting from the menu.
The Formatting toolbar reappears. Another way to add and remove toolbars is to
right-click anywhere on a toolbar or menu.
Right-click either the Standard toolbar or the Formatting toolbar.
A shortcut menu appears with the names of available toolbars.
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5.

6.

7.
8.
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Click Drawing from the Toolbar shortcut menu.
The Drawing toolbar appears along the bottom of the Excel screen (unless someone
has previously moved it). You can view as many toolbars as you want, but the more
toolbars you display, the less of the worksheet window you will be able to see.
Move the pointer to the move handle at the far left side of the Drawing
toolbar. Click and drag the toolbar to the middle of the screen, then
release the mouse button.
The Drawing toolbar is torn from the bottom of the screen and floats in the middle of
the worksheet window. Notice a title bar appears above the Drawing toolbar. You can
move a floating toolbar by clicking its title bar and dragging it to a new position. If you
drag a floating toolbar to the edge of the program window, it becomes a docked toolbar.
Click the Drawing toolbar’s title bar and drag the toolbar down until it
docks with the bottom of the screen.
The Drawing toolbar is reattached to the bottom of the Excel screen.
Right-click any of the toolbars and select Drawing from the Toolbar
shortcut menu.
The Drawing toolbar disappears.

Move handle

Quick Reference
To View or Hide a Toolbar:
• Select View → Toolbars
from the menu and select
the toolbar you want to
display or hide.
Or…
• Right-click any toolbar or
menu and select the
toolbar you want to
display or hide from the
shortcut menu.
To Move a Toolbar to a
New Location Onscreen:
• Drag the toolbar by its
move handle (if the
toolbar is docked) or title
bar (if the toolbar is
floating) to the desired
location.
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Lesson 1-7: Filling Out Dialog
Boxes
Figure 1-13

Tab

The Font dialog box.

Text box

Figure 1-14

List box

Using a Scroll Bar.

Scroll Up Button
Click here to scroll
up.
Scroll Down Button
Click here to scroll
down.

Combo box
Preview area: See
how your changes
will appear before
you make them.

Scroll Box
Indicates your current
position in the list (you
can also click and drag
the scroll box to scroll
up or down).

Figure 1-14
Check box

Figure 1-13

Some commands are more complicated than others are. Saving a file is a simple process—just
select File → Save from the menu or click the Save button on the Standard toolbar. Other
commands are more complex. For example, suppose you want to change the top margin of the
current workbook to a half-inch. Whenever you want to do something relatively complicated,
you must fill out a dialog box. Filling out a dialog box is usually quite easy—if you’ve
worked at all with Windows, you’ve undoubtedly filled out hundreds of dialog boxes. Dialog
boxes usually contain several types of controls, including:

Text Box

•

Text boxes

•

List boxes

•

Check boxes

•

Combo boxes (also called drop down lists)

It’s important that you know the names of these controls, because this book will refer to them
in just about every lesson. This lesson gives you a tour of a dialog box, and explains each of
these controls, so you will know what they are and how to use them.

List Box

1.
2.

Tabs
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Click the word Format from the menu.
The Format menu appears. Notice the items listed in the Format menu are followed by
ellipses (…). The ellipses indicate there is a dialog box behind the menu.
Select Cells from the Format menu.
The Format Cells dialog box appears. The Format Cells dialog box is actually one of
the most complex dialog boxes in Microsoft Excel, and contains several different types
of components you can fill out.
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3.
4.

5.

6.

7.
8.
9.

First, let’s look at the tabs in the Format Cells dialog box. Some dialog boxes have so
many options that they can’t all fit on the same screen. When this happens, Windows
divides the dialog box into several related Tabs or sections. To view a different tab,
simply click it.
Click the Alignment tab.
The Alignment tab appears in front.
Click the Font tab.
The Font tab of the Format Cells dialog box appears, as shown in Figure 1-13.
Remember: the purpose of this lesson is to learn about dialog boxes, not how to format
fonts (we’ll cover that later). The next destination on our dialog box tour is the text
box.
Look at the Font text box, located in the upper left corner of the dialog box. Text boxes
are the most common component of a dialog box, and are nothing more than the old
fill-in-the-blank you’re already familiar with if you’ve filled out any type of form. To
use a text box, click the text box or press the <Tab> key until the insertion point
appears in the text box, then simply type what you want to appear in the text box.
Make sure the Font text box is selected and type Arial.
You’ve just filled out the text box—nothing to it. The next stop in our dialog box tour
is the list box. There’s a list box located directly below the Font text box you just typed
in. A list box is a way of listing several (or many) options into a small box. Sometimes
list boxes contain so many options that they can’t all be displayed at once, and you
must use the list box’s scroll bar, as shown in Figure 1-14, to move up or down the list.
Click and hold the Font list box’s Scroll Down button until Times New
Roman appears in the list, then click the Times New Roman option to
select it.
Our next destination is the combo box. The combo box is the cousin of the list box—it
also displays a list of options. The only difference is you must click the combo box’s
downward pointing arrow to display its options.
Click the Underline combo box down arrow.
A list of underlining options appears below the combo box.
Select Single from the combo box.
Sometimes you need to select more than one item from a dialog box. For example,
what if you want to add Shadow formatting and Small Caps formatting to the selected
font? You use the check box control when you’re presented with multiple choices.
In the Effect section click the Strikethrough check box and click the
Superscript check box.
The last destination on our dialog box tour is the button. Buttons found in dialog boxes
are used to execute or cancel commands. Two buttons are in just about every dialog
box:
•
•

10.

OK: Applies and saves any changes you have made and then closes this dialog
box. Pressing the <Enter> key is usually the same as clicking the OK button.

Cancel: Closes the dialog box without applying and saving any changes.
Pressing the <Esc> key is the same as clicking the cancel button.
Click the Cancel button to cancel the changes and close the dialog box.
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Check Box

Combo Box
Button

Quick Reference
To Use a Text Box:
• Simply type the
information directly into
the text box.
To Use a List Box:
• Click the option you want
from list box. Use the
scroll bar to move up and
down through the list
box’s options.
To Use a Combo Box:
• Click the Down Arrow to
list the combo box’s
options. Click an option
from the list to select it.
To Check or Uncheck a
Check Box:
• Click the check box.
To View a Dialog Box Tab:
• Click the tab you want to
view.
To Save Your Changes
and Close a Dialog Box:
• Click the OK button or
press <Enter>.
To Close a Dialog Box
without Saving Your
Changes:
• Click the Cancel button or
press <Esc>.

26

Microsoft Excel 2000

Lesson 1-8: Keystroke and Right
Mouse Button Shortcuts
Figure 1-15
Hold down the <Ctrl> key
and press another key to
execute a keystroke
shortcut.
Figure 1-16
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Figure 1-15

Opening a shortcut menu
for toolbars.

Figure 1-16

You are probably starting to realize that there are several methods to do the same thing in
Excel. For example, to save a file, you can use the menu (select File → Save) or the toolbar
(click the Save button). This lesson introduces you to two more methods of executing
commands: Right mouse button shortcut menus and keystroke shortcuts.

Shortcut menu

You know that the left mouse button is the primary mouse button, used for clicking and
double-clicking, and it’s the mouse button you will use over 95 percent of the time when you
work with Excel. So what’s the right mouse button for? Whenever you right-click something,
it brings up a shortcut menu that lists everything you can do to an object. Whenever you’re
unsure or curious about what you can do with an object, click it with the right mouse button.
A shortcut menu will appear with a list of commands related to the object or area you rightclicked.
Right mouse button shortcut menus are a great way to give commands to Excel because you
don’t have to wade through several levels of unfamiliar menus when you want to do
something.

1.
Right-click an object
to open a shortcut
menu that lists
everything you can do
to the object.

2.
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Click the right mouse button while the cursor is anywhere inside the
workbook window.
A shortcut menu appears where you clicked the mouse. Notice one of the items listed
on the shortcut menu is Format Cells. This is the same Format Cells command you can
select from the menu (clicking Format → Format Cells). Using the right mouse button
shortcut method is slightly faster and usually easier to remember than Excel’s menus. If
you open a shortcut menu and then change your mind, you can close it without
selecting anything. Here’s how:
Move the mouse button anywhere outside the menu and click the left
mouse button to close the shortcut menu.
Remember that the options listed in the shortcut menu will be different, depending on
what you right-clicked.
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3.
4.

5.
6.

Position the pointer over either the Standard or Formatting toolbar and
click the right mouse button.
A shortcut menu appears listing all the toolbars you can view, as shown in Figure 1-16.
Move the mouse button anywhere outside the menu in the workbook
window and click the left mouse button to close the shortcut menu.
On to keystroke shortcuts. Without a doubt, keystroke shortcuts are the fastest way to
give commands to Excel, even if they are a little hard to remember. They’re great time
savers for issuing common commands that you do all the time. To issue a keystroke
shortcut press and hold the <Ctrl> key, press the shortcut key, and release both buttons.
Press <Ctrl> + <I> (the Control and I keys at the same time.)
This is the keystroke shortcut for Italics. Note that the Italics button on the Formatting
toolbar is now depressed.
Type Italics.
The text appears in italics.
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The Control key

NOTE: Although we won’t discuss it in this lesson, Excel’s default keystroke
shortcuts can be changed or remapped to execute other commands.
Table 1-3: Common Keystroke Shortcuts lists the shortcut keystrokes you’re likely to use the
most in Excel.
Table 1-3: Common Keystroke Shortcuts
Keystroke

Description

<Ctrl> + <B>

Toggles bold font formatting.

<Ctrl> + <I>

Toggles italics font formatting.

<Ctrl> + <U>

Toggles underline font formatting.

<Ctrl> + <Spacebar>

Returns the font formatting to the default setting.

<Ctrl> + <O>

Opens a workbook.

<Ctrl> + <S>

Saves the current workbook.

<Ctrl> + <P>

Prints the current workbook to the default printer.

<Ctrl> + <C>

Copies the selected text or object to the Windows clipboard.

<Ctrl> + <X>

Cuts the selected text or object from its current location to the Windows
clipboard.

<Ctrl> + <V>

Pastes any copied or cut text or object in the Windows clipboard to the current
location.

<Ctrl> + <Home>

Moves the insertion point to the beginning of the workbook.

<Ctrl> + <End>

Moves the insertion point to the end of the workbook.

Quick Reference
To Open a Shortcut Menu:
• Right-click the object.
To Use a Keystroke
Shortcut:
• Press <Ctrl> + the letter
of the keystroke shortcut
you want to execute.
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Lesson 1-9: Opening a Workbook
Figure 1-17

Displays files in special
folders.

Currently selected
folder or drive.

The Open dialog box.
Figure 1-18
The Lesson 1 workbook
appears in the Excel
program.

Files in the selected
folder or drive.

Select the file you
want to open.

Figure 1-17

File name

Change the type of files that are
displayed in the Open dialog box.
Name of the program you’re using
(Microsoft Excel) and the currently
opened workbook (Lesson1).

Figure 1-18

Open button
Other Ways to Open a
File:
• Select File → Open
from the menu.
• Press <Ctrl> + <O>.
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When you work with Excel you will sometimes need to create a new workbook from scratch
but more often you’ll want to work on an existing workbook that you or someone else has
previously saved. This lesson explains how to open a saved workbook.

1.
2.

Click the Open button on the Standard toolbar.
The Open dialog box appears.
Navigate to and open your practice folder or floppy disk.
Your computer stores information in files and folders, just like you store information in
a filing cabinet. To open a file, you must first find and open the folder where it’s saved.
Normally new files are saved in a folder named “My Documents” but sometimes you
will want to save or open files in another folder.
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The Open and Save dialog boxes both have their own toolbars that make it easy to
browse through your computer’s drives and folders. Two controls on this toolbar are
particularly helpful:
•

3.

Look in list: Click to list the drives on your
computer and the current folder, then select the drive and/or folder with the
contents you want to display.

•
Up One Level button: Click to move up one folder.
If necessary, follow your instructor’s directions to select the appropriate drive and
folder where your practice files are located.
Click the workbook named Lesson 1 in the file list box and click Open.
Excel opens the Lesson 1 workbook and displays it in the window, as shown in Figure
1-18.

Look in list

Table 1-4: Special Folders in the Open and Save As Dialog Boxes
Heading

Description
Displays a list of files that you’ve recently worked on.

History

My Documents

Displays all the files in the My Documents folder—the default location where
Microsoft Office programs save their files.
Temporarily minimizes or hides all your programs so that you can see the
Windows desktop.

Desktop

Favorites

Display a list of your “Favorite” folders, although these are often used to
organize your favorite Web pages.
Displays all the files in any Web folders—special locations to save Web pages.

Web Folders

Quick Reference
To Open a Workbook:
• Click the Open button on
the Standard toolbar.
Or…
• Select File → Open from
the menu.
Or…
• Press <Ctrl> + <O>.
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Lesson 1-10: Saving a Workbook
Figure 1-19

Specify the drive or
folder where you want to
save your workbook.

The Save As dialog box.

Enter a file name.

Figure 1-19

You can save Excel workbooks in
different file formats by selecting
the format you want to save in
here.

After you’ve created a worksheet, you need to save it if you intend on using it ever again.
Saving a worksheet stores it in a file on your computer’s hard disk—similar to putting a file
away in a filing cabinet so you can retrieve it later. Once you have saved a worksheet the first
time, it’s a good idea to save it again from time to time as you work on it. You don’t want to
lose all your work if the power suddenly goes out, or if your computer crashes. In this lesson,
you will learn how to save an existing workbook with a different name without changing the
original workbook. It’s often easier and more efficient to create a workbook by modifying one
that already exists, instead of having to retype a lot of information.
You want to use the information in the Lesson 1 workbook that we opened in the previous
lesson to create a new workbook. Since you don’t want to modify the original workbook,
Lesson 1, save it as a new workbook named Income and Expenses.

1.

2.
3.
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Select File → Save As from the menu.
The Save As dialog box appears. Here is where you can save the workbook with a
different name. If you only want to save any changes you’ve made to a workbook—
instead of saving them in a new file—click the Save button on the Standard toolbar, or
select File → Save from the menu, or press <Ctrl> + <S>.
First you have to tell Excel where to save your workbook.
If necessary, navigate to and open your practice folder or floppy disk.
Next you need to specify a new name that you want to save the document under.
In the File name text box, type Income and Expenses and click Save.
The Lesson 1 workbook is saved with the new name, Income and Expenses. Now you
can work on our new workbook, Income and Expenses, without changing the original
workbook, Lesson 1.
When you make changes to your workbook, you simply save your changes in the same
file. Go ahead and try it.
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4.

5.
6.

Click Save.
The Lesson 1 workbook is saved with the new name, Income and Expenses. Now you
can work on our new workbook, Income and Expenses, without changing the original
workbook, Lesson 1.
When you make changes to your workbook, you simply save your changes in the same
file. Go ahead and try it.
Type Income and press the <Enter> key.
Now save your changes.
Click the Save button on the Standard toolbar.
Excel saves the changes you’ve made to the Income and Expenses workbook.

Congratulations! You’ve just saved your first Excel workbook.
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Save button
Other Ways to Save:
• Select File → Save
from the menu.
• Press <Ctrl> + <S>.

Quick Reference
To Save a Workbook:
• Click the Save button on
the Standard toolbar.
Or…
• Select File → Save from
the menu.
Or…
• Press <Ctrl> + <S>.
Quick
Reference
To Save
a Workbook
in a
NewSave
File awith
a Different
To
Document:
Name:
• Click the Save button
1. on
Select
→ Save
As
theFile
Standard
toolbar.
from the menu.
Or…
2. Type a new name for the
• Select
Fileand
→ click
SaveSave.
worksheet
from the menu.
Or…
• Press <Ctrl> + <S>.
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Lesson 1-11: Moving the Cell
Pointer
Figure 1-20
Cells are referenced as
A1, A2, B1, B2, and so on,
with the letter representing
a column and the number
representing a row.

1
2
3

A

B

C

A1
A2
A3

B1
B2
B3

C1
C2
C4

Figure 1-20

The active cell is in:
column B…
…row 2…

Figure 1-21

Active cell

…so its cell
reference would
be B2

Name box

Figure 1-21
The cell reference for the
active cell in this example
would be B2.
Figure 1-22
Use the keyboard or the
mouse to move the cell
pointer.

Move the active cell
with the arrow keys
on your computer’s
keyboard…

…or by using the
mouse to click the
cell you want with
pointer
the

Figure 1-22

Before you start entering data into a worksheet, you need to learn one very important task:
how to move around in a worksheet. This lesson will teach you how to do just that. You must
first make a cell active before you can enter information in it. You can make a cell active
using:
•

The Mouse: You can click any cell with the white cross pointer (

•

The Keyboard: You can move the cell pointer using the keyboard’s arrow keys.

).

Worksheets can be confusing places for many people. To help you know where you are in a
worksheet, Excel displays row headings, indentified by numbers, on the left side of the
worksheet, and column headings, identified with letters on the top of the workbook (see
Figure 1-20). Each cell in a worksheet is given its own unique cell address made from its
column letter and row number, such as cell A1, A2, B1, B2, etc. You can immediately find the
address of a cell by looking at the name box, which shows the current cell address.

1.
Name box
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2.

Click cell C3 (located in column C and Row 3) with the
pointer to make
it active.
Once you click C3 it becomes the active cell, and its cell address (C3) appears in the
name box.
Make cell E9 active by clicking it.
Now that you’re familiar with moving the cell pointer with the mouse, try using the
keyboard.
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3.
4.
5.
6.

7.

8.
9.
10.

Make cell D5 active moving the cell pointer by pressing the <←> arrow
key once and the <↑> arrow key four times.
As you press the arrow keys, watch the name box. Notice it is updated to display the
current cell address.
Press the <Enter> key once.
Pressing <Enter> causes the cell pointer to move down to the next cell, D6. The Enter
key is a real time saver when you’re entering data.
Press the <Tab> key twice.
Pressing <Tab> causes the cell pointer to move to the right, the same as pressing the
<→> key.
Press and hold the <Shift> key as you press the <Tab> key.
Pressing the <Shift> and <Tab> keys at the same time is the same as pressing the
< ←> key. This may seem like an unusual, hard-to-remember keystroke, but it is
actually used in many other Windows-based programs.
You have probably already guessed that the worksheet is larger than what you can
currently see in the worksheet window. Actually, it is much, much larger: there are 256
columns and 65,536 rows in a worksheet! To view the portions of the worksheet that
are currently located off-screen you can use the horizontal and vertical scroll bars,
which are located at the bottom and far right of the worksheet screen.
Click and hold the right-arrow scroll button on the horizontal scroll bar,
until you can see columns X, Y, Z, and AA on your screen.
If you accidently go too far you can easily move back by clicking the left-arrow scroll
button.
When you arrive at the AA column, notice that the cell pointer is not currently located
on this screen—you left it way back in cell D8. Let’s see if you remember how to make
cell Z4 the active cell.
Make cell Z4 active by clicking it with the mouse.
Scrolling up and down in a worksheet is just as easy as scrolling to the right and left.
Try it!
Click the down-arrow scroll button on the vertical scroll bar several
times.
You don’t have to use the scroll button to move to worksheet areas that are hidden offscreen—you can do the same thing with the keyboard.
Press and hold down the <←> key until you reach cell A4.

Congratulations! In one brief lesson you’ve become familiar with moving the cell pointer
around in a worksheet. Turn the page to go on to the next lesson where you will learn how to
become an expert on getting around in Excel.
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Scroll Right
button

Scroll Down
button

Quick Reference
To Move the Cell Pointer:
• Click any cell with the
crosshair pointer ( ) to
make it active.
• Use the arrows keys to
move the active cell and
to navigate the
worksheet.
• Pressing <Enter> moves
the active cell down.
• Pressing <Tab> moves
the active cell to the right.
• Pressing
<Shift> + <Tab> moves
the active cell to the left.
To Scroll the Worksheet:
• Click the left and right
scroll button arrows on
the horizontal scroll bar to
scroll the worksheet to the
left or right.
• Click the up and down
scroll button arrows on
the vertical scroll bar to
scroll the worksheet up or
down.
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Lesson 1-12: Navigating a
Worksheet
The worksheet extends to the
right to cell IV.

Figure 1-23
Worksheets are actually
much larger than what you
can see on the screen at
one time.

The
worksheet
extends down
to cell 65,536.

Figure 1-23

The previous lesson introduced you to the basics of getting around in an Excel worksheet. As
workbooks get larger it gets more difficult to find your way around in them. In large
worksheets, the simple navigation commands you learned in the previous lesson may take you
longer to get to a destination than you would like. This lesson covers the more advanced
methods of getting around in Excel.

1.
2.
3.

Click cell C15.
You can quickly move up to the first occupied cell in the table by pressing <End> and
then the <↑>.
Press and hold the <Ctrl> key, press the <↑> key, and release both
buttons.
The cell pointer moves to the first cell that contains information—C10. Try another
shortcut keystroke—the <Home> key, which moves to column A of the current row.
Press <Home>.
Viola! You’re in the A column in the current row.

Table 1-5: Keyboard Shortcuts for Moving Around in a Worksheet displays all the more
advanced navigational keystrokes you can use to quickly get around a worksheet.
NOTE: When you refer to the shortcuts in the following table, remember the plus (+)
sign between two keys (<Ctrl> + <Home>) means you press and hold the first
key while you press the other key at the same time.
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Table 1-5: Keyboard Shortcuts for Moving Around in a Worksheet
Press

To Move

<→> or <Tab>

One cell to the right.

<←> or
<Shift> + <Tab>

One cell to the left.

<↑>

Up one row.

<↓>

Down one row.

<Home>

To cell in column A in the current row.

<Ctrl> + <Home>

To the first cell (A1) in the worksheet.

<Ctrl> + <End>

To the last cell with data in a worksheet.

<Page Up>

Up one screen.

<Page Down>

Down one screen.

<F5>

Opens the Go To dialog box where you can go to a specified cell address.

<End> + <→> or
<Ctrl> + <→>

First occupied cell to the right that is either preceded or followed by a blank
cell.

<End> + <←> or
<Ctrl> + <←>

First occupied cell to the left that is either preceded or followed by a blank cell.

<End> + <↑> or
<Ctrl> + <↑>

First occupied cell to the top that is either preceded or followed by a blank cell.

<End> + <↓> or
<Ctrl> + <↓>

First occupied cell to the bottom that is either preceded or followed by a blank
cell.

Quick Reference
To Use Keystroke
Shortcuts to Navigate in a
Worksheet:
• Refer to Table 1-5:
Keyboard Shortcuts for
Moving Around in a
Worksheet.
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Lesson 1-13: Entering Labels in a
Worksheet
Figure 1-24
Entering text labels in a
worksheet.

Enter and
Cancel buttons

Labels

Figure 1-24

Now that you are an expert on getting around in Excel, you’re ready to start entering data.
There are two basic types of information you can enter in a cell:
•

Labels: Any type of text or information not used in any calculations.

•

Values: Any type of numerical data: numbers, percentages, fractions, currencies, dates,
or times, usually used in formulas or calculations.

This lesson focuses on labels. Labels are used for worksheet headings and make your
worksheets easy to read and understand. Labels usually contain text, but can also consist of
numerical information not used in any calculations, such as serial numbers and dates. Excel
treats information beginning with a letter as a label and automatically left-aligns it inside the
cell.

1.
2.
Formula bar
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Click cell A1 to make it the active cell.
This is where you want to add a title for your worksheet. Don’t worry if the cell
already contains text—anything you type will replace the old cell contents.
Type Income and Expenses.
If you make a mistake while you’re typing a cell entry you can press the <Backspace>
key to delete any characters, one at a time.
Notice as you start typing that the text appears in both the cell and in the formula bar.
Also, look at the formula bar—three new buttons have appeared: the Cancel button (the
red X), the Enter button (the green check mark), and the Edit Formula button (the =
sign), as shown in Figure 1-24. You can click the Enter button when you’ve finished
typing to confirm the cell entry or the Cancel button to cancel the entry and return the
cell to its previous state.
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3.

4.
5.

6.
7.
8.
9.

Click the Enter button on the Formula bar (see Figure 1-24 if you can’t
find it).
Clicking the Enter button on the Formula bar confirms the cell entry. There are several
other, more efficient methods for entering and confirming data. We’ll take a look at
these methods in the next steps. Notice the text label is too large to fit in the current
cell and the text spills into the empty adjacent cells to the right. Excel will use adjacent
cells to display labels that are too long to fit in a single cell, so long as they are empty.
If the adjacent cells aren’t empty, Excel truncates the text—everything’s still there, but
you just can’t see all of it.
Next, you need to add some labels to make the worksheet more meaningful.
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Enter button
Other Ways to Enter:
• Press the <Enter> key.
• Press the <Tab> key.
• Press any of the arrow
keys.

Click cell A7 to make it the active cell.
The series of numbers located directly to the right of the current cell are the basic
monthly expenses for North Shore Travel. Go ahead and enter the labels for the
expenses.
Type Advertising and press the <Enter> key.
Excel confirms your entry and moves down to the next cell, A8. You can also complete
an entry by pressing any of the arrow keys, <Tab>, or as you’ve already learned, by
clicking the Enter button on the formula toolbar. Notice the label Advertising doesn’t
quite fit into the cell. Add the remaining expense labels.
Type Office and press <Enter>.
The cell pointer moves down to the next cell, A9. This row contains the monthly
payroll expenses.
Type Payroll but don’t press <Enter> this time.
You decide you would rather use the label “Salary” instead of “Payroll” so cancel the
change and return the cell to its empty state.
Click the Cancel button on the Formula bar.
The Payroll label disappears from both the Formula bar and the current cell. Go on to
the next step to enter the new correct label, for this cell and the remaining labels.
Type Salary and press <Enter>, type Rent and press <Enter>, and then
type Totals and press <Enter>.
NOTE: Excel normally treats any information beginning with a letter as a label and
any information beginning with a number as a value. If you want to create a
label that starts with a number, to prevent Excel from recognizing it as a value
type an ' (apostrophe) before typing the number.

Congratulations! You’ve finished entering the expense labels for the worksheet, making it
much easier to read and understand. Compare your worksheet with the one in Figure 1-24,
and then go on to the next lesson to enter some values into the worksheet.

Cancel button
Other Ways to Cancel:
• Press the <Esc> key.

Quick Reference
To Confirm a Cell Entry:
• Click the Enter button on
the Formula bar.
Or…
• Press either the <Enter>
or <Tab> key.
Or…
• Press any of the arrow
keys on keyboard.
To Cancel a Cell Entry:
• Click the Cancel button
on the Formula bar.
Or…
• Press the <Esc> key.
To Enter a Label:
1. Select the cell you want to
contain the label.
2. Type the label – Excel will
recognize it as a label if it
begins with a letter. Type
an ' (apostrophe) if your
label begins with a
number.
3. Confirm the entry.
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Lesson 1-14: Entering Values in a
Worksheet and Selecting a Cell
Range
Figure 1-25
Entering values in a
worksheet and selecting a
range.

Click the first cell of
the range you want to
select.

Drag the mouse
pointer to the last cell
of the range.

Figure 1-25

Ranges are identified
by the first and last
cells in the range, so
this range would be
F7:G10.

In the previous lesson, you learned how to enter labels in a worksheet. In this lesson, you will
be working with the other basic type of worksheet information: values. Values are the
numbers, dates, and other numerical information in a worksheet that are usually used in
calculations. A value can be any type of numerical data: numbers, percentages, fractions,
currencies, dates, and times. Excel treats information that contains numbers, dates or times,
and certain numerical punctuation as a value and automatically right-aligns it in the cell.
Values don’t have to contain only numbers. You can also use numerical punctuation including:
the period (.) for a decimal point, the hyphen (-) for negative values, the dollar sign ($) for
currencies, the percent sign (%) for percentages, and the comma (,) for separating numbers
like 1,000.
Entering values in a worksheet is no different from entering labels: you simply type the value
and confirm the entry by clicking the Enter, Tab or any of the arrow keys. One more important
thing to know about entering values: You can use the numeric keypad on your keyboard to
key in values, which for most people is a very fast method to enter data once you’re familiar
with it.
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1.
2.

3.

4.

5.

6.

7.
8.
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Click cell E7 to make it the active cell, type 2500, and press <Enter> to
complete the entry and move the cell pointer to cell E8.
Type 400, press <Enter>, type 7000, press <Enter>, type 3000, and
press <Enter>.
Up until now, you have only worked with a single cell. In order to be proficient at
Excel you need to know how to select and work with multiple cells.
Move the pointer over cell F7, click and hold down the mouse button,
drag the pointer over cell G10, then release the mouse button.
You have just selected a range of cells. A range consists of two or more selected cells
and is identified by the first and last cells in the range, for example F7:G10. To select a
range all you have to do is position the pointer over the first cell, click and hold the
mouse button, drag the pointer to the last cell you want in the range, then release the
mouse button.
Whenever you see that you’re going to have to enter data in a block or range of cells, it
is sometimes a good idea to select the range to make data entry easier and faster.
Selecting a range of cells restricts the cell pointer so it can only move inside the
selected range.
Type 1500, press <Enter>, type 400, press <Enter>, type 7000, press
<Enter>, and then type 3000. Do not press <Enter> after typing 3000.
By now, you know that pressing <Enter> normally completes the cell entry and moves
the cell pointer down to the next cell. Remember, however, that right now you are
working in a selected cell range. Go on to the next step and see what happens when
you press the <Enter> key.
Press <Enter>.
Instead of moving down to the next cell, F11, the cell pointer moves to the next cell in
the selected range, cell G7. By selecting a range, you restrict where the cell pointer can
move and can concentrate on your data entry instead of worrying about where the cell
pointer is. Go ahead and enter the remaining numbers.
Enter the following numbers, making sure to press <Enter> after you
enter each number, except the last number, 3000. Do not press <Enter>
after typing 3000.
1200
500
7000
3000
You’re at G10, the last cell in the selected range. So, what will happen if you press the
<Enter> key now? Go on to the next step and find out.
Press <Enter>.
The cell pointer moves back to the first cell in the selected range, F7. Once you’re
finished working on a selected range you can deselect the range by clicking any cell in
the worksheet.
Click any cell in the worksheet to deselect the range.

Compare your worksheet with the one in Figure 1-25 when you have finished.

Selecting a Cell
Range
Ranges are identified
by the first and last
cells in the range, such
as F7:G10.

Other Ways to Select a
Cell Range:
• Make sure the active
cell is the first cell of the
cell range, and then
press and hold the
<Shift> key while
moving the cell pointer
to the last cell.

Quick Reference
To Select a Cell Range:
• Click the first cell of the
range, and then drag the
mouse pointer to the last
cell.
Or…
• Make sure the active cell
is the first cell of the cell
range, then press and
hold the <Shift> key while
moving the cell pointer to
the last cell.
To Deselect a Cell Range:
• Click any cell outside of
the selected cell range.
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Lesson 1-15: Calculating Value
Totals with AutoSum
Figure 1-26
AutoSum button

Using the AutoSum
function to find the column
totals.

AutoSum totals
any adjacent
cells above, to
the right, or that
are selected.

Figure 1-26

All formulas in Excel
must begin with an
equal sign (=).

This lesson introduces what spreadsheet programs are really all about: formulas. A formula
performs calculations, such as adding, subtracting, and multiplying. Formulas are actually a
type of value, like the numerical values you worked with in the previous lesson. Unlike the
values in the previous lesson that contained only numbers, formulas contain information to
perform a numerical calculation, such as adding, subtracting, multiplying, or even finding an
average. A cell with the formula =5+3 will display the result of the calculation: 8.
All formulas must start with an equal sign (=). The equal sign tells Excel you want to perform
a calculation. Once you have entered an equal sign, you must specify two more types of
information: the values you want to calculate and the arithmetic operator(s) or function
name(s) you want to use to calculate the values. Formulas can contain explicit values, such as
the numbers 5 or 8, but more often will reference the values contained in other cells. For
example, the formula =A5+A6 would add together whatever values were in the cells A5 and
A6. You’re already familiar with some of the arithmetic operators used in Excel formulas:
they include math symbols such as the plus sign (+) to perform addition between values and
the minus sign (-) to perform subtraction. Functions are used in formulas to perform
calculations that are more complicated. For example, the SUM function adds together a range
of cells, and the PMT function calculates the loan payments based on an interest rate, the
length of the loan, and the principal amount of the loan. In this lesson, you will learn how to
use one of the most commonly used functions in Excel, the SUM function, which finds the
total of a block of cells.

1.
AutoSum button
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Click cell B11 to make it the active cell.
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2.

3.
4.

5.
6.

This is where you want to enter a formula to total the expenses in B column. The
easiest way to add together several numbers values in a cell range is to use the
AutoSum button. The AutoSum button inserts the SUM function (which adds all the
values in a range of cells) and selects the range of cells Excel thinks you want totaled.
Click the AutoSum button on the Standard toolbar.
Excel enters =SUM(B7:B10) in cell B11. Notice that the cells included in the formula
range—B7, B8, B9, and B10—are surrounded by what looks like a line of marching
ants. The AutoSum function is quite good at guessing which cells you want to total, but
sometimes you will want to modify the cell selection. In our case, AutoSum has
correctly selected the cells.
NOTE: Excel is usually smart enough to determine which cells you want to total;
however, if the suggested range is incorrect, select the range you want using
the mouse to select the cells and press <Enter>.
Click the Enter button on the Formula bar.
Excel instantly calculates the totals of the values in the cell range B7:B10 and displays
the result, 11700, in the cell. Look at the formula bar—notice the formula
=SUM(B7:B10), appears instead of the result of the calculation.
Click cell B7, enter 2000, and press <Enter>.
You’ve just made two very important discoveries! The first is that entering data in a
cell replaces or overwrites whatever information was currently there. The second
discovery is what is more relevant to this lesson: look at cell B11, where you just
entered the SUM formula. Cell B11 now reads 12500—it has automatically
recalculated the total for the cell range. Go ahead and find the total for the expenses in
the C column.
Click cell C11, click the AutoSum button, and press <Enter>.
Excel totals the expenses in the C column. Finish entering totals for the remaining
expense columns.
Repeat Step 6 and enter SUM formulas for the remaining columns (D
through G). Compare your worksheet with the one in Figure 1-26 when
you’re finished.
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Finding the Total
of a Cell Range

Enter button

Formula bar

Quick Reference
To Use the AutoSum
Function to Find the
Totals of a Cell Range:
1. Click the cell where you
want to insert the total.
2. Click the AutoSum
button on the Standard
toolbar.
3. Verify the cell range
selected by AutoSum is
correct. If it isn’t, select
the cell range you want to
total.
4. Complete the formula by
pressing <Enter>.
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Lesson 1-16: Entering Formulas
Figure 1-27
Entering a formula in
Excel to find the Net
Income.

Figure 1-27

The previous lesson introduced you to formulas and how you can use the AutoSum button to
total a cell range. This lesson takes a closer look at formulas, and instead of using the
AutoSum function, you’ll get a chance to enter a formula yourself.
Before you start the exercise, let’s review. A formula is a value and performs calculations,
such as adding, subtracting, and multiplying. Formulas start with the equal sign (=), which
tells Excel you want to perform a calculation. After the equal sign, you must specify two more
types of information: the values you want to calculate and the arithmetic operator(s) or
function name(s) you want to use to calculate the values. Formulas can contain explicit
values, such as the numbers 4 or 5, but more often will reference the values contained in other
cells. For example, the formula =A3+A4 would add together whatever values were in the
cells A3 and A4. Look at Table 1-6: Examples of Operators, References, and Formulas to see
a variety of formulas that contain different operators, references, and values.
Remember: All
formulas in Excel must
begin with an equal
sign (=).

1.
2.
3.
4.
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Click cell A13, type Net Income, and press <Tab>.
This row will contain the net income, which you can find by subtracting the total
expense values from the sales value.
Type = (the equal sign) in cell B13.
Typing an equal sign at the beginning of a cell entry tells Excel you want to enter a
formula rather than a value or label.
Type B4-B11.
This will subtract the value in cell B11 (12,500) from the value in B4 (12,000).
Press <Enter>.
Excel displays the result of the formula, -500, in cell B13. Notice, however, that the
cell’s formula still appears in the formula bar. Instead of manually typing cell
references, like you did in Step 3, you can specify cell references in a formula by
clicking and selecting the cell or cell ranges with the mouse.
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5.
6.
7.
8.
9.
10.

Click cell C13.
This is where you will enter the formula to find the net income for the C column.
Type =.
Excel is now ready to accept the formula for this cell. Instead of typing in the cell
references this time, enter them using the mouse.
Click cell C4.
A line of marching ants appears around the cell C4, indicating the cell range. Look
back at cell C13. Notice Excel inserts the cell reference C4 in the formula. The next
step is entering the arithmetic operator in the formula.
Type – (the minus sign or hyphen).
To complete the formula you must specify the cell reference for the total expenses,
C11.
Click cell C11.
Excel enters the cell reference, C11 in the formula.
Press <Enter> to complete the formula.
The result of the formula (3900) appears in cell C13.

43

Enter button

Use Table 1-6: Examples of Operators, References, and Formulas as a reference when you
start creating your own formulas. Not only does it contain examples of formulas, but also the
most common operators and functions used in formulas.
Table 1-6: Examples of Operators, References, and Formulas
Operator or
Function Name

Purpose

=

All formulas must start with an equal sign

+

Performs addition between values

-

Performs subtraction between values

=A1-B1

*

Performs multiplication between values

=B1*2

/

Performs division between values

=A1/C2

SUM

Adds all the numbers in a range

=SUM(A1:A3)

AVERAGE

Calculates the average of all the numbers in
a range

=AVERAGE(A2,B1,C3)

COUNT

Counts the number of items in a range

=COUNT(A2:C3)

Example

=4+3

Quick Reference
To Enter a Formula:
1. Click the cell where you
want to insert the formula.
2. Press = (the equals sign)
to begin any formula.
3. Enter the formula.
4. Press <Enter>.
To Reference a Cell in a
Formula:
• Type the cell reference—
for example A3.
Or…
• Click the cell you want to
reference.
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Lesson 1-17: Using AutoFill
Figure 1-28
Using AutoFill to enter a
series of incremental
dates.

1. Enter at least two values
in the series into
adjacent cells

2. Select the cells

3. Click and drag the fill
handle to complete the
series in the cells that
you select
Excel displays what it’s
planning to enter in each cell

Excel completes the series
in the selected cells

Figure 1-28

Enter button

AutoFill is the best timesaving feature for data entry in Excel. AutoFill automatically enters a
series of values in any cells you select. For example, imagine you’re entering all twelve
months as labels in a worksheet. With AutoFill you only have to enter a couple of months and
let AutoFill enter the rest for you! Excel can’t read your mind (Microsoft’s still a few versions
away from that feature), so the first cell or cells you select must contain the values and
increment you want AutoFill to use when it automatically enters values. AutoFill makes a lot
more sense when you see it in action, so let’s start this lesson…

1.
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Click cell B3, type January and then click the Enter button on the
formula bar.
Here’s how to use the AutoFill feature:
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2.
3.

4.
5.
6.

7.
8.
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With the cell pointer still in cell B3, position the mouse pointer over the
fill handle—the tiny box in the cell’s lower-right corner, until the pointer
changes to a .
Click and hold the fill handle and drag the mouse pointer to the right until
the cell range is extended to include cell G3, then release the mouse
button.
When you release the mouse button, Excel enters the months February through June in
cells C3 through G3.
If you’re working with a more complex data series, such as one that increases by
increments other than one (such as every other day or month), you need to enter both
the first and second entries to show Excel what increments to use when filling the data
series.
Click cell C3, type March, and press <Enter>.

Fill Handle

Select the cell range B3:C3, as shown in Figure 1-28.
By selecting the cell range B3:C3 you show Excel how you want to increment the data
series. Now that Excel knows how you want to increment the data series, use AutoFill
to recreate the series.
With the cell range B3:C3 still selected, click and drag the fill handle to
the right until you select cell G3 and then release the mouse button.
When you release the mouse button, Excel follows your selected example and
completes the data series with cell entries that contain every other month. AutoFill has
another very useful purpose: you can use it to quickly copy data (labels, values, or
formulas) from one cell to other cells. You are going to use AutoFill to copy the net
income formula in you created in the previous lesson cell C13 to the remaining cells in
the worksheet.
Click cell C13 to make it active.
Cell C13 contains the formula you want to copy.
Drag the fill handle to the right until you reach cell G13, then release the
mouse button.
When you release the mouse button, Excel copies the formula in cell C13 to the cells
D13, E13, F13, and G13.

Table 1-7: Examples of AutoFill
First Cell Entry

AutoFill Entries Created in the Next Three Cells

January

February, March, April

Jan

Feb, Mar, Apr

1/10/98

1/11/98, 1/12/98, 1/13/98

5:00

6:00, 7:00, 8:00

Quarter 1

Quarter 2, Quarter 3, Quarter 4

Project 1

Project 2, Project 3, Project 4

Quick Reference
To Use AutoFill to Enter a
Series of Incremental
Values:
1. Enter at least two values
into adjacent cells.
2. Select the cells you used
in Step 1.
3. Click and drag the fill
handle to complete the
series in the cells you
select.
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Lesson 1-18: Previewing and
Printing a Worksheet
Figure 1-29
The Print Preview screen.
Figure 1-30
The Print dialog box.

Figure 1-29

Figure 1-30

Print Preview
button
Other Ways to Preview:
• Select File → Print
Preview from the
menu.

Once you have created a worksheet, you can create a printed copy of it (if your computer is
connected to a printer.) Sometimes, it is a good idea to preview a document on screen to see if
something needs to be changed before sending it to the printer. You can preview a document
by using Excel’s Print Preview feature.

1.
2.
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Click the Print Preview button on the Standard toolbar.
The worksheet is previewed on the screen, as shown in Figure 1-29. You can enlarge
the spreadsheet by clicking the area of the worksheet you want to magnify with the
pointer.
Move the
pointer over an area of the spreadsheet that contains data
and click the mouse button.
Excel magnifies the selected area. Once you have seen an enlarged area, you can zoom
back out to see the overall page again.
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3.
4.

5.

Move the
pointer over any area of the spreadsheet and click the mouse
button.
Excel returns to the previous preview size. Your worksheet looks good so you can go
ahead and print it from the Print Preview window.
Click Print.
The Print Dialog box appears, as shown in Figure 1-30. The Print Dialog box allows
you to specify printing options such as which pages to print and the number of copies
you want printed. You don’t need to worry about any printing options for now. You just
want to print the worksheet.
Click OK.
Excel prints the worksheet to the default printer connected to your computer.
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Print button
Other Ways to Print:
• Select File → Print
from the menu.
• Press <Ctrl> + <P>.

NOTE: If you weren’t in Print Preview mode you could also print by clicking the
Print button on the Standard toolbar, by selecting File → Print from the menu,
or by pressing <Ctrl> + <P>.

Quick Reference
To Preview a Worksheet
on Screen:
• Click the Print Preview
button on the Standard
toolbar.
Or…
• Select File → Print
Preview from the menu.
To Print a Worksheet:
• Click the Print button on
the Standard toolbar.
Or…
• Select File → Print from
the menu.
Or…
• Press <Ctrl> + <P>.
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Lesson 1-19: Getting Help from
the Office Assistant
Figure 1-31
Asking the Office Assistant
a question.
Figure 1-32
Selecting the appropriate
topic.
Figure 1-33
Selecting what you want
to do.
Figure 1-34
The Help text for the
selected topic.
Figure 1-31

Figure 1-32

Figure 1-33

Figure 1-34

When you don’t know how to do something in Windows or a Windows based program, don’t
panic—ask the Office Assistant for help. The Office Assistant is a cute animated character (a
paperclip by default) that can answer your questions, offer tips, and provide help for all of
Excel’s features. Many Excel users don’t use the Office Assistant because they think that it’s
nothing more than an amusing distraction—something to keep them entertained when they
pound out boring budget numbers with Excel. This is sad, because the Office Assistant knows
more about Excel than most Excel books do!
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Whenever you use Excel, you can make the Office Assistant appear by pressing the <F1> key.
Then all you have to do is ask the Office Assistant your question in normal English. This
lesson will show you how you can get help by asking the Office Assistant a question about an
Excel feature in normal English.

1.
2.

3.
4.
5.

6.

Press the <F1> key.
The Office Assistant appears and asks what you would like to do, as shown in Figure
1-31.
Type How do I create a formula? in the Office Assistant’s speech
balloon, as shown in Figure 1-31.
You can ask the Office Assistant questions about Excel in normal English, just as if you
were asking a person instead of a computer. No, the Office Assistant doesn’t really
understand the English language—computers have a while to go before they can do
that. The Office Assistant actually looks for key words and phrases in your questions
like “create” and “formula”.
Click Search.
The Office Assistant presents you with a list of topics it thinks may be relevant for your
question, as shown in Figure 1-32. You have to select the help topic that you’re looking
for.
Click the Enter a formula to calculate a value help topic.
More help subtopics to choose from appear, as shown in Figure 1-33. Again, you have
to select the most appropriate help topic.
Click the Enter a formula help topic.
Excel displays information on how to enter a formula. Notice the help window has a
row of buttons, or toolbar, that look vaguely like some of the buttons you might have
seen on a Web browser. Microsoft redesigned the Help system in Office 2000 so that
you can navigate through help topics just like you would browse the Web.
Click the Help window’s Close button ( ) to close the help window.
The Help window closes, but Office Assistant remains on-screen and will remain there,
annoying you with its animated antics, unless you close it as well.

Table 1-8: Help Buttons
Button

Description
Shows or hides a list of all available Help topics.
Moves back to the previous help topic.
Moves forward to the next help topic.
Prints the current help topic.
Displays a list of help options and commands.
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The <F1> key is the
help key for all
Windows-based
programs.

Quick Reference
To Get Help from the
Office Assistant:
1. Press the <F1> key.
2. Type your question in the
Office Assistant’s speech
balloon and click Search
or press <Enter>.
3. Click the help topic that
best matches what you’re
looking for (repeat this
step as necessary.)
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Lesson 1-20: Changing the Office
Assistant and Using the What’s
This? Button
Figure 1-35
The Options tab of the
Office Assistant dialog box
allows you to change how
your Office Assistant
works.
Figure 1-36
Choosing a new Office
Assistant.
Figure 1-37

Figure 1-35

Figure 1-36
Click the What’s This? button
( ) and then click the control
you want more information on.

Click the “What’s This”
button ( ) to display help
on what a dialog box
control does.

Figure 1-37

If you find that Clippit’s (the cartoon paperclip) antics are getting old, you can choose a
different Office Assistant at any time. People have different tastes and personalities, and that’s
why Microsoft allows you to select from eight different Office Assistants (see Table 1-9:
Office Assistants) to guide you through Excel. Of course, if you really hate the Office
Assistant, you can always completely shut it off too.
The other topic covered in this lesson is how to use the “What’s This” button. During your
journey with Excel you will undoubtedly come across a dialog box or two with a number of
confusing controls and options. To help you find out what the various controls and options in
a dialog box are there for, many dialog boxes contain a What’s This? ( ) button that explains
the purpose of each of the dialog box’s controls. This lesson will show you how to use the
What’s This? button. But first, let’s start taming the Office Assistant.
To hide the Office
Assistant, right-click
the Office Assistant
and click Hide.
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1.
2.

If necessary, select Help → Show the Office Assistant from the menu.
The Office Assistant appears.
Right-click the Office Assistant and select Choose Assistant from the
shortcut menu.
The Office Assistant dialog box appears.
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3.
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Click the Back or Next button to see the available Office Assistants.
The Office Assistant you select is completely up to you. They all work the same—they
just have different antics.
Click OK when you find an Office Assistant you like.
If you find the Office Assistant annoying and want to get rid of it altogether here’s
how:
Right-click the Office Assistant
A shortcut menu appears.
Select Hide from the shortcut menu.
You can always bring the Office Assistant back whenever you require its help by
pressing the <F1> key. Now let’s move on to how to use the “What’s This” button to
discover the purpose of confusing dialog box controls.
Select Format → Cells from the menu and click the Font tab.
The Format cells dialog box appears. Notice the “What’s This” button located in the
dialog box’s title bar just to the left of the dialog box’s close button.
Click the What’s This? button ( ).

4.
5.
6.
7.
8.
9.
10.

The mouse pointer changes to a , indicating you can point to anything on the dialog
box to find out what it does. The Normal Font check box is rather confusing isn’t it?
Move on to the next step and we’ll find out what it’s there for.
Click the Normal Font check box with the
pointer.
A brief description of the Normal Font check box appears as shown in Figure 1-37.
Close the Format Cells dialog box.

Table 1-9: Office Assistants1
Office Assistant
Clippit

Description
Though nothing more than a thin metal wire, Clippit will help you find what
you need and keep it together. Clippit is the default Office Assistant.

The Dot

Need a guide on the electronic frontier? Able to transform into any shape, the
Dot will always point you in the right direction.

F1

F1 is the first of the 300/M series, built to serve. This robot is fully optimized
for Office use.

The Genius
Office Logo
Mother Nature
Links
Rocky

The mind of the Genius works at the speed of light. Harness his power of
thought to save yourself time and energy.
The Office Logo gives you help accompanied by a simple spin of its colored
pieces. It won’t distract you as you’re taking care of business.
Transforming into images from nature, such as the dove, the volcano, and the
flower, Mother Nature provides gentle help and guidance.
If you’re on the prowl for answers in Windows, Links can chase them down
for you.
If you fall into a ravine, call Lassie. If you need help in Office, call Rocky.

1. Microsoft Office 2000 Help files, © 1999, Microsoft Corporation.

Quick Reference
To Change Office
Assistants:
1. If necessary, select Help
→ Show the Office
Assistant from the menu.
2. Right-click the Office
Assistant and select
Choose Assistant from
the shortcut menu.
3. Click the Next or Back
buttons until you find an
Office Assistant you like,
then click OK.
To Hide the Office
Assistant:
• Right-click the Office
Assistant and select Hide
from the shortcut menu.
To See what a Control in a
Dialog Box Does:
1. Click the Dialog box
What’s This? button
(located right next to the
close button.)
2. Click the control you want
more information on with
the
pointer.
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Lesson 1-21: Closing a Workbook
and Exiting Excel
Figure 1-38
Excel without any opened
workbooks.

Closes the
Microsoft Excel
program.

Figure 1-39
The Program and
Workbook close buttons.

Closes the current
workbook.

Figure 1-39

Figure 1-38

Save button
Other Ways to Save:
• Select File → Save
from the menu.
• Press <Ctrl> + <S>.

Because the tasks covered in this lesson are so simple —closing a workbook and exiting the
Excel program—this is one of the briefest lessons in the book. Before you close a workbook
or exit Excel, you should always make sure you save any changes you’ve made to the active
workbook.

1.
2.

Close button
Other Ways to Close a
Workbook:
• Select File → Close
from the menu.
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3.

Save the Income and Expenses worksheet by clicking the Save button
on the Standard toolbar.
Your disk drive whirrs as it saves the changes you’ve made to the worksheet. Once the
worksheet is saved you can close it.
Click the workbook Close button. (Make sure you click the worksheet
Close button, not the Excel Program Close button.)
You will probably see two close buttons on your screen—make sure you click the
lower close button. The close button located in the far upper-right hand corner of the
screen would close the Excel program. The current worksheet closes, but the Excel
program does not. You can close a worksheet when you’re finished working on it but
still want to remain in the Excel program—perhaps to open and work on another
worksheet. You’ve finished both this lesson and this chapter, so now you want to exit,
or close the Excel program.
Click the Close button on the Microsoft Excel title bar.
This time, click the Close button in the very far upper-right hand corner of the screen
to close Excel. The Excel Program window closes and you return back to the Windows
desktop.

Chapter One: The Fundamentals
That’s it! You’ve just completed your first chapter and are well on your way toward mastering
Microsoft Excel. You’ve already learned some very important things: how to start Excel; enter
values, labels, and formulas; create, preview, print, and save a worksheet; select and work
with cell ranges; and use the AutoFill feature. You will use these skills all the time in your
long career with Microsoft Excel.
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Close button
Other Ways to Exit Excel
• Select File → Exit from
the menu.

Quick Reference
To Close a Workbook:
• Click the document
window close button.
Or…
• Select File → Close from
the menu.
To Exit Microsoft Excel:
• Click the Excel Program
close button.
Or…
• Select File → Exit from
the menu.
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Chapter One Review
Lesson Summary
Starting Excel
•

Start Excel by clicking the Start button, selecting Programs, and selecting Microsoft Excel.

Understanding the Excel Screen
•

Be able to identify the main components of the Excel program screen.

Using Menus
•

To Use a Menu: Either click the menu name with the mouse pointer or press the <Alt> key and the
letter that is underlined in the menu name.

•

Excel 2000’s new personalized menus hide more advanced commands from view. To display a
menu’s hidden commands click the downward-pointing arrow ( ) at the bottom of the menu or
open the menu and wait a few seconds.

•

To Change How Menus Work: Select View → Toolbars → Customize from the menu, check or
clear either the Menus Show Recently Used Commands First and/or Show Full Menus After a
Short Delay options, then click Close.

Using Toolbars and Creating a New Workbook
•

To Use Excel’s Toolbars: Simply click the toolbar button you want to use. Leave the pointer over
the button to display a screen tip of what the button does.

•

Excel 2000 places the Standard and Formatting toolbars together on the same row. To stack these
toolbars on separate rows select View → Toolbars → Customize from the menu and remove the
check from the Standard and Formatting Toolbars Share Same Row option.

•

To Create a New Workbook: Click the
New from the menu.

New button on the Standard toolbar or select File →

Hiding, Displaying, and Moving Toolbars
•

To View or Hide a Toolbar: Select View → Toolbars from the menu and select the toolbar you
want to display or hide or right-click any toolbar or menu and select the toolbar you want to display
or hide from the shortcut menu.

•

Move a toolbar by dragging its move handle (if the toolbar is docked) or title bar (if the toolbar is
floating).

Filling Out Dialog Boxes
•
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Be able to identify and use text boxes, list boxes, combo boxes, check boxes, and sheet tabs.
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Keystroke and Right-Mouse Button Shortcuts
•

Keystroke shortcuts: Press <Ctrl> and the letter that corresponds to the shortcut command at the
same time.

•

Right-mouse button shortcut menus: Whenever you’re unsure or curious about what you can do
with an object, click it with the right mouse button to display a list of commands related to the
object.

Opening a Workbook
•

To Open a Workbook: Click the Open button on the Standard toolbar, or select File → Open
from the menu, or press <Ctrl> + <O>.

Saving a Workbook
•

To Save a Workbook: Click the Save button on the Standard toolbar, or select File → Save
from the menu, or press <Ctrl> + <S>.

•

To Save a Workbook with a Different Name: Select File → Save As from the menu and enter a
different name for the workbook.

Moving the Cell Pointer
•

Using the mouse: Select the cell you want to edit by clicking it with the mouse pointer or by using
the keyboard arrow keys.

•

Using the keyboard: Move the cell pointer by pressing the keyboard arrow key that corresponds
to the direction you want to move.

•

Pressing <Enter> moves the cell pointer down, <Tab> moves the cell pointer to the right, and
<Shift> + <Tab> moves the cell pointer to the left.

•

Use the horizontal and vertical scroll bars and buttons to view portions of the worksheet that are
located off-screen.

Navigating a Worksheet
•

<Page Up> moves up one screen, <Page Down> moves down one screen.

•

<Ctrl> + <Home> moves to the first cell (A1) in a worksheet.

•

<Ctrl> + <End> moves to the last cell with data in a worksheet.

•

<F5> opens the Go To dialog box, where you can specify a cell address to jump to.

Entering Labels in a Worksheet
•

Labels are used for worksheet heading and (usually) text. Excel treats information beginning with a
letter as a label, and left-aligns it in the cell.

Entering Values in a Worksheet and Selecting a Cell Range
•

Values are the numerical information in a worksheet that are usually used in calculations. Excel
treats numbers, dates, and times as values and automatically right-aligns them in the cell.
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•

To Select a Cell Range: (Using the mouse) Click the first cell or the range and drag the mouse
pointer to the last cell of the range. (Using the keyboard) Make sure the active cell is the first cell of
the cell range, then press and hold down the <Shift> key while using the arrow keys to move the
mouse pointer to the last cell of the range.

Calculating Value Totals with AutoSum
•

1) Click the cell where you want to insert the total, 2) Click the AutoSum button on the
Standard toolbar, 3) Verify that the cell range selected is correct—if it isn’t select the cell range you
want to total, 4) Press <Enter>.

Entering Formulas
•

Every formula must start with the equal symbol (=).

•

To Enter a Formula: 1) Select the cell where you want to insert the formula, 2) Press = (the
equals sign), 3) Enter the formula, using values, cell references, operators, and functions, 4) Press
<Enter>.

•

To Reference a Cell in a Formula: Type the cell reference, for example B5, or simply click the cell
you want to reference.

Using AutoFill
•

1) Enter at least two values into adjacent cells, 2) Select those cells, 3) Click and drag the cell
pointer’s fill handle to complete the series in the cells you select.

Previewing and Printing a Worksheet
•

To Print a Worksheet: Click the Print button on the Standard toolbar, or select File → Print
from the menu, or press <Ctrl> + <P>.

•

To Preview a Worksheet: Click the Print Preview button on the Standard toolbar, or select
File → Print Preview from the menu.

Getting Help from the Office Assistant
•

You can ask the Office Assistant (the cute animated character) your help questions in
conversational English. This is the easiest and most common method of getting help.

•

Press <F1> to open the Office Assistant, type your question in normal English, and click Search.

Changing the Office Assistant and Using the What’s This? Button
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•

To Change Office Assistants: If necessary, select Help → Show the Office Assistant from the
menu. Right-click the Office Assistant and select Choose Assistant from the shortcut menu. Click
the Next or Back buttons until you find an Office Assistant you like, then click OK.

•

To Hide the Office Assistant: Right-click the Office Assistant and select Hide from the shortcut
menu.

•

“What’s This” button
To See what a Control in a Dialog Box Does: Click the Dialog box
(located right next to the close button) and click the control you want more information on with the
pointer.
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Closing a Workbook and Exiting Excel
•

To Close a Workbook: Click the workbook window’s
from the menu.

•

To Exit Microsoft Excel: Click the Excel program
menu.

close button or select File → Close
close button or select File → Exit from the

Quiz
1. Right-clicking something in Excel:
A.
B.
C.
D.

Deletes the object.
Opens a shortcut menu listing everything you can do to the object.
Selects the object.
Nothing—the right mouse button is there for left-handed people.

2. Which of the following is NOT a way to complete a cell entry?
A.
B.
C.
D.

Clicking the Enter button on the Formula bar.
Pressing any arrow key on the keyboard.
Pressing <Enter>.
Pressing <Spacebar>.

3. Which of the following formulas is NOT entered correctly?
A.
B.
C.
D.

=B7+14
=B7*B1
10+50
=10+50

4. Which of the following is NOT an example of a value?
A.
B.
C.
D.

May 10, 2001
Serial Number 50671
57%
350

5. Which symbol do formulas begin with?
A.
B.
C.
D.

=
@
+
(

6. You can reference cells in a formula by: (Select all that apply.)
A.
B.
C.
D.

Typing the cell reference; for example B10.
Clicking the cell(s) you want to reference with the mouse.
Selecting Edit → Reference from the menu and type the cell reference.
Clicking the Enter button on the Formula bar and clicking the cell with the mouse.
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7. Cell ranges consist of two or more cells and are identified by the first and
last cell in the range, such as F7:G10 (True or False?)
8. To save a workbook you: (Select all that apply)
A.
B.
C.
D.

Press <Ctrl> +<F5>
Select File → Save from the menu.
Click the Save button on the Standard toolbar.
Click Save on the Windows Start button.

9. You enter “300 Orders” in cell A1 and “250 Orders” in cell A2. You then
select both cells and drag the fill handle down to cell A3. When you release
the mouse button, which value will appear in cell A3?
A.
B.
C.
D.

250 Orders
250
200 Orders
200

10. What symbol is used before a number to make it a label?
A.
B.
C.
D.

=
' (apostrophe)
" (quote)
_ (underscore)

11. Without using the mouse or the arrow keys, what is the fastest way of
getting to cell A1 in a spreadsheet?
A.
B.
C.
D.

Press <Home>.
Press <Shift> + <Home>.
Press <Ctrl> + <Home>.
Press <Alt> + <Home>.

12. Which button do you click to add up a series of numbers?
A.
B.
C.
D.

The AutoSum button.
The Formula button.
The Total button.
The QuickTotal button.

13. How do you select an entire column?
A.
B.
C.
D.

Select Edit → Select → Column from the menu.
Click the column heading letter.
Hold down the <Ctrl> key as you click anywhere in the column.
Hold down the <Shift> key as you click anywhere in the column.

14. You want to manually spell check a workbook. You open the Tools menu
but can’t find the Spelling command. What’s wrong?
A. The Spelling command is in the Edit menu silly!
B. You need to display all the options in the Tools menu by clicking the downwardpointing arrow at the bottom of the menu.
C. There isn’t a Spelling command.
D. You need to display all the options in the Tools menu by pressing <F2>.
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15. What key can you press to get help in any Windows-based program?
A.
B.
C.
D.

<F12>.
<Esc>.
<Scroll Lock>.
<F1>.

Homework
1. Find cell AA75 in any worksheet.
2. Using the skills you’ve learned in this chapter, create a worksheet similar to the one
shown here (you can fill it in using your own numbers if you want.)

3. Create a Total row in row 10. Use the AutoSum function to find the totals for each
quarter.
4. Preview and print your worksheet, and then save it as “Homework One” in your
practice folder or disk.
5. Make a silent vow that from this moment forward you will use Excel anytime you
need to add together more than 8 numbers instead of a calculator.

Quiz Answers
1. B. Right-clicking an object displays a shortcut menu for the object.
2. D. There are a lot of ways to complete a cell entry, but pressing the <Spacebar> isn’t
one of them.
3. C. 10+50 is missing the equal sign. It should be “=10+50”.
4. B. “Serial No. 50671” contains a number, but since it starts with letters Excel treats it
as a label.
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5. A. All formulas in Excel must begin with an equal sign (=). There’s no exception to
this rule.
6. A and B. You can reference cells by typing their cell reference or clicking the cell or
cell range you want to reference.
7. True. Cells ranges are identified by the first and last cell in the range, such as
A1:B10.
8. B and C.
9. C.
10. B. Type an ' (apostrophe) before a number to make it a label.
11. C. Press <Ctrl> + <Home> to move the cell pointer to cell A1.
12. A. Click the AutoSum button.
13. B. Click the column heading letter of the column you want to select.
14. B. You need to display all the options in the Tools menu by clicking the downwardpointing arrow at the bottom of the menu.
15. D. The <F1> key brings up help in every Windows program.
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Chapter Two: Editing
a Workbook
Chapter Objectives:
•

Enter and work with date values

•

Edit, clear, and replace cell contents

•

Cut, copy, paste, and move cells

•

Work with and understand absolute and relative cell references

•

Insert and delete cells, rows, and columns

•

Use Undo and Redo

•

Check the spelling of your worksheets

•

Use advanced print options

•

Basic file management

•

Insert cell comments

Chapter Task: Edit a mileage reimbursement report
Now that you have the Microsoft Excel basics down, this chapter will show you how to
become a sophisticated Excel user. This chapter explains how to enter date values; cut, copy
and paste information in your workbook; insert and delete columns and rows; undo any
mistakes you might make; and even correct your spelling errors.

; Prerequisites
• How to start Excel.
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to move the cell
pointer.
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Lesson 2-1: Entering Date Values
and Using AutoComplete
Figure 2-1
You can enter dates into a
worksheet using a variety
of formats. No matter
which method you use to
enter dates, they will be
displayed according to
how the cell is formatted.

Press
<Enter>

Figure 2-1
Both of these cells contain the same
date value—they’re just formatted
differently.

Normally Excel treats dates in your worksheets as values rather than labels. The reason for
this is simple—so you can perform calculations and formulas on them. For example, you can
subtract one date from another to find how many days are between them. You can enter dates
using many different types of date formats, as shown in Table 2-1: Examples of Valid Date
and Time Entries.

Open button
Other Ways to Open a
Workbook:
• Select File → Open
from the menu.
• Press <Ctrl> + <O>.

1.
2.
3.

Start Microsoft Excel.
Click the Open button on the Standard toolbar.
The Open dialog box appears.
Navigate to and open your practice folder or floppy disk.
Your computer stores information in files and folders, just like you store information in
a filing cabinet. To open a file, you must first find and open the folder where it’s saved.
Normally new files are saved in a folder named “My Documents,” but sometimes you
will want to save or open files in another folder.
The Open and Save dialog boxes both have their own toolbars that make it easy to
browse through your computer’s drives and folders. Two controls on this toolbar are
particularly helpful:
•

Look in list
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Look in List: Click to list the drives on your
computer and the current folder, then select the drive and/or folder with the
contents you want to display.

•
Up One Level button: Click to move up one folder.
If necessary, follow your instructor’s directions to select the appropriate drive and
folder where your practice files are located.
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4.

5.

6.

7.

8.

9.
10.
11.

Click the workbook named Lesson 2A in the file list box to select it and
click Open.
The workbook Lesson 2A opens and appears in the worksheet window. You don’t want
to modify the original Lesson 2A workbook, so save it as a new workbook file with a
different name—“Mileage Reimbursement.”
Select File → Save As from the menu, type Mileage Reimbursement in
the File name box and click Save.
Excel saves the workbook with the new name, “Mileage Reimbursement,” and closes
the original document, Lesson 2A. Now you can work on the new workbook, Mileage
Reimbursement, without modifying the original workbook, Lesson 2.
Click cell A11, type 2/24 and press <Enter>.
Notice that Excel completes the date entry by automatically inserting the current year
for you.
NOTE: Excel assumes any two-digit years entered between 01/01/30 and 12/31/99 are
in the 20th century, so when you enter 10/3/54 Excel assumes you mean
October 10, 1954. Excel assumes any two-digit years entered between
01/01/00 and 12/31/29 are in the 21st century, so when you enter 10/3/15
Excel assumes you mean October 10, 2015.
You don’t have to enter your dates using a 10/5/98 format. Excel understands a variety
of date formats. Try entering a date using a different format.
Type Feb 27 and press <Enter>.
You can change how dates are formatted, so that 10/10/98 is displayed as October 10,
1998, but that’s in another lesson.
Excel’s AutoComplete feature helps speed up data entry, especially if you’re using
repetitive information.
Click cell B11 and type Ma.
As soon as you type the “Ma” in “Mankato,” Excel cleverly recognizes what you’re
typing from the cells in the B column, and displays the label “Mankato.” If you want to
accept “Mankato” simply press <Enter> to confirm the cell entry. If you’re entering a
different word, such as “Manitoba” simply ignore Excel’s suggestion and finish typing
“Manitoba”.
Press <Enter>.
You can also use Excel’s Pick From List to help you enter labels in your worksheet.
The Pick From List is a list of labels you’ve used and helps keep your information
consistent.
Right-click cell B12 and select Pick from List from the shortcut menu.
A list containing all the labels in the column appears—simply click the entry you want
to use.
Select St. Cloud from the Pick From List.

Table 2-1: Examples of Valid Date and Time Entries
Date Entries

Time Entries

October 17, 1995

5:45 PM

10/17/95

5:45 AM

10-17-95

5:45

(Excel assumes that it’s 5:45 AM)

17-Oct-95

17:45

(5:45 PM on a 24-hour clock)

Oct-17

17:45:20 (5:45 PM and 20 seconds)

(Excel assumes that it’s the current year.)
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When you type the
first few characters
of a label, Excel
displays the label if it
already appears in the
column. Press <Enter>
to accept the entry or
resume typing to
ignore the suggestion.

Pick from List
Quick Reference
To Enter Date Values in
Excel:
• Excel treats dates and
times as values, so once
you enter a date in one
format, such as 4/4/99,
you can reformat the
date.
To Use AutoComplete:
• Type the first few
characters of a label;
Excel displays the label, if
it appears previously in
the column. Press
<Enter> to accept the
entry or resume typing to
ignore the suggestion.
To Use the Pick From List:
• Right-click the cell where
you want to enter a label,
select Pick From List
from the shortcut menu,
and select the entry from
the list.
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Lesson 2-2: Editing, Clearing, and
Replacing Cell Contents
Figure 2-2
Pressing the <Delete> key
clears the contents of the
selected cell or cell range.

Press

Figure 2-3
Typing replaces the
contents of a cell.

Figure 2-2

Type any text

Figure 2-3

You can change or clear the contents of your cells any time. To clear a cell entry, simply select
the cell or cell range you want to delete and press the <Delete> key. You don’t have to clear a
cell entry if you want to replace it altogether—just select the cell and enter the new entry on
top of the old entry.

Press <Delete> to clear
the contents of the
active cell.

There are a couple methods you can use to edit the contents of a cell. One method is to select
the cell you want to edit, click the formula bar, and then edit the cell contents in the formula
bar. Another method is to double-click the cell you want to edit and then change the cell
contents directly in the cell. Either method causes Excel to go to Edit mode, and the Cancel
and Enter buttons appear on the formula bar. In Edit mode the arrow keys move from
character to character in the cell, instead of from cell to cell. While Excel is in Edit mode, you
can also move the insertion point by clicking the I-beam pointer ( ) where you want to insert
text.

1.
2.
3.
4.

Selecting a Cell
Range
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5.

Click cell B3 to make it active.
Press <Delete> to clear the contents of the active cell.
The contents of cell B3—the label “location”—is deleted, or cleared, from the cell.
Move on to the next step to add a better description for this label.
Type Destination and press <Enter>.
You can clear the contents of several cells at once by first selecting the cells and then
pressing the <Delete> key.
Select the cell range G3:G10 by clicking cell G3 and holding down the
mouse button and dragging it to cell G10.
Now clear the selected cell range (G3:G10).
Press the <Delete> key.
The contents of the cells in the selected range are deleted.
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6.
7.
8.

9.
10.
11.
12.
13.

Click cell A1 to make it active, then type Reimbursable Mileage
Report and press <Enter>.
The original content of the cell, the label “Mileage” is replaced with the new label
“Reimbursable Mileage Report” as shown in Figure 2-3.
Click cell C3.
This cell label needs to be changed from “Starting” to “Beginning.” There are several
different methods you can use to edit the contents of a cell. The first is to select the cell
you want to edit and then click the formula bar.
Click anywhere in the formula bar.
Notice that the status bar at the bottom of the Excel screen changes from “Ready” to
“Edit” indicating Excel is in Edit mode. The blinking vertical line ( ) that appears in
the Formula bar is called the insertion point. Once Excel is in Edit mode you can move
the insertion point in the formula bar to edit any area by either pressing the arrow keys
or by moving the I-beam pointer ( ) where you want to place the insertion point and
clicking.
Press the <Backspace> key.
Excel deletes one letter to the left of the insertion point.
Press and hold the <Backspace> key to delete the word “Starting,” then
type Beginning, and press <Enter>.
Another method you can use to edit a cell entry is to edit inside of the cell instead of in
the Formula bar, by double-clicking the cell.
Double-click cell D3.
The insertion point appears directly in the cell so that you can edit the cell’s entry.
Delete ing, so the cell reads “End” and press <Enter>.
You can edit cells that contain values and formulas just like cell entries with labels.
Click cell E2, type Cost Per Mile, press <Tab> or <→> to move to cell
F2, type .32, and then press <Enter>.

14. Click cell F4, click anywhere in the formula bar or double-click cell F4 to
15.
16.

enter Edit mode.
You want to edit the formula in this cell so that it references whatever value is in cell
F2 rather than the fixed value of .30, currently used in the formula.
Press the <Backspace> key three times to delete the 0.3.
Now that you’ve deleted the explicit, fixed value used in the formula, create a
reference to cell F2.
Click cell F2.
Excel automatically enters the cell reference, F2, to the formula in cell F4. The formula
should now read =E4*F2.
Press <Enter> to confirm the cell entry.

17.
18. Click the Save button on the Standard toolbar.
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Editing a Cell
Entry with the
Formula Bar

Editing a Cell
Entry In Place

Save button

Quick Reference
To Clear a Cell’s Contents:
1. Select the cell.
2. Press the <Delete> key.
To Edit a Cell’s Contents
in the Formula Bar:
1. Select the cell.
2. Click anywhere in the
Formula bar.
3. Edit the cell’s contents
(use the arrow, <Delete>
and <Backspace> keys).
4. Press <Enter> when
you’re finished editing the
cell.
To Edit a Cell’s Contents
in the Cell Itself:
1. Double-click the cell you
want to edit.
2. Edit the contents of the
cell itself.
3. Press <Enter> when
you’re finished editing the
cell.
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Lesson 2-3: Cutting, Copying, and
Pasting Cells
Figure 2-4
Selecting and cutting a
range of cells.
Figure 2-5
Pasting the selected cells
in a new location in the
workbook.

Figure 2-4

Copy button
Other Ways to Copy:
• Select Edit → Copy
from the menu.
• Press <Ctrl> + <C>.

Figure 2-5

You already know how to select a cell and ranges of cells using the mouse or keyboard. Once
you have selected a cell or cell range, you can cut it, removing it from its original location,
and then paste it in another location in the worksheet. Copying is similar to cutting, except the
cells are copied instead of removed. Whenever you cut or copy something, it is placed in a
temporary storage area called the Clipboard. The Clipboard is available to any Windows
program, so you can cut and paste between different programs.
Cutting and copying cell entries is one of the more common tasks you’re likely to use in
Excel (and in many other programs, too). This lesson will give you some practice cutting,
copying, and pasting in Excel.
If you are continuing from the previous Editing and Clearing Cell Contents lesson you can
skip the first step of this exercise, otherwise you will need to open the Lesson 2B file…

1.
2.
Paste button
Other Ways to Paste:
• Select Edit → Paste
from the menu.
• Press <Ctrl> + <V>.
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3.
4.

Open the workbook named Lesson 2B on your Practice disk or in your
Practice folder then save it as Mileage Report.
First you need to select the cell or cell range you want to copy…
Click cell B5 to make it active.
You want to copy this cell to the clipboard so you can paste it in a different location in
the worksheet. There are several different methods of copying something—we’ll look
at all of them. Try out each method and then use the method you prefer.
Click the Copy button on the Standard toolbar.
A line of marching ants appears around the selected cell and the message “Select
destination and press ENTER or choose Paste” appears on the status bar. Now you
must move the cell pointer to the location where you want to paste the copied cell.
Select cell B11.
This is where you want to paste the cell you copied. There are several methods you can
use to paste what you copied or cut to the Windows clipboard.
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5.

6.

7.
8.

9.
10.
11.

Click the Paste button on the Standard toolbar.
The contents you copied from cell B5 are pasted into the active cell, B11, replacing its
original contents. When you use the Paste command, Excel still keeps the copied cells
in the Clipboard so that you can paste them again in other locations. Try pasting the
copied cell in another location.
Select cell B12 and repeat Step 5 to paste the copied cell again.
The copied cell is inserted in the active cell.
Now that you’re familiar with copying, let’s try cutting several cells. You can cut (or
copy) several cells at once by selecting the cells you want to cut (or copy).
Select the cell range A3:F12.
By now you should know how to select a cell range.
Click the Cut button on the Standard toolbar.
A line of marching ants appears around the selected cells and the message “Select
destination and press ENTER or choose Paste” appears on the status bar. When you
select a destination to paste a range of cells you only have to designate the first cell
where you want to paste the cell range.
Select cell A13.
This is where you want to paste the selected cell range.
Click the Paste button on the Standard toolbar to paste the cut cell
range.
Excel removes or “cuts” the selected cells from their original location and inserts them
at the new location that begins with the active cell.
Save the document by clicking the Save button on the Standard toolbar.

You can also copy, cut, and paste text between two different Windows programs. For
example, you could copy information from an Excel worksheet and paste it in a Word
document. The cut, copy, and paste commands (the toolbar buttons, menus, and/or keyboard
shortcuts) you learned in Excel will work with most Windows applications.
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Cut button
Other Ways to Cut:
• Select Edit → Cut from
the menu.
• Press <Ctrl> + <X>.

Quick Reference
To Cut and Paste:
1. Select the cell or cell
range you want to cut.
2. Click the Cut button on
the Standard toolbar.
Or…
Select Edit → Cut from
the menu.
Or…
Press <Ctrl> + <X>.
3. Select the cell where you
want to paste the cut
cell(s).
4. Press <Enter>.
To Copy and Paste:
1. Select the cell or cell
range you want to copy.
2. Click the Copy button on
the Standard toolbar.
Or…
Select Edit → Copy from
the menu.
Or…
Press <Ctrl> + <C>.
3. Select the cell where you
want to paste the cut
cell(s).
4. Click the Paste button on
the Standard toolbar.
Or…
Select Edit → Paste
from the menu.
Or…
Press <Ctrl> + <V>.
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Lesson 2-4: Moving and Copying
Cells with Drag and Drop
Figure 2-6
Use drag and drop to
move a range of cells to a
new destination in a
worksheet.
Figure 2-7
The worksheet after
moving the cell range.
Figure 2-8
Confirmation to replace
occupied cell contents.
Figure 2-6 Drag a cell selection by its border to

Figure 2-7

another location on the worksheet.

Figure 2-8

In the previous lesson, you learned how to cut, copy, and paste cells. This lesson will show
you another way to move or copy cells to different parts of a worksheet: using the drag and
drop method. Drag and drop allows you to pick up a cell or cell range and place it in a new
location on the worksheet—all without using any menus, toolbar buttons, or keystrokes!
In this lesson, you use drag and drop to move the block of text you cut and pasted in the
previous lesson back to its original location.

1.
Clicking the Edge
of a Cell Range
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2.

Select the cell range A13:F22.
You may have to scroll down the worksheet in order to see the cell range A13:F22.
Once you have selected the cell range, you can move it using drag and drop.
Position the pointer over any of the edges of the selected range, until it
changes to a , then click and hold the mouse button, drag the selected
range to cell A3 and release the mouse button.
As you drag the mouse, an outline of the cell range moves with the pointer, as shown in
Figure 2-6. A tip box also appears while you drag the cell range, which displays the
current position of the selected cell range as you move it. The selected cell range is
dropped in the location, beginning with cell A3.
You can also copy cells and cell ranges using the drag and drop method. The procedure
is almost exactly the same, except you hold down the <Ctrl> key as you drag the cell or
cell range.
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3.
4.
5.
6.
7.
8.
9.

Select the cell range E2:F2.
Now that you have selected the cells you want to copy, copy them to a new destination
in the worksheet using drop-and-drag.
Hold down the <Ctrl> key to copy the selected cell range and repeat
Step 2 to copy the cell range to cell E1. Release the <Ctrl> key when
you’re finished.
Excel copies the selected cells to the new location.
Select the cell Range E1:F1.
If you drag and drop into occupied cells, Excel will ask you if you want to replace the
existing cells, as shown in Figure 2-8.
Using the drag and drop technique you’ve learned, drag and drop the
selected cell range to cell A1.
Since this cell is already occupied, Excel asks whether you want to replace the contents
of the destination cells.
Click Cancel.
Excel cancels the drag and drop procedure. You might have noticed the label “Cost Per
Mile” and the value “. 32” appear twice in the worksheet. You don’t need this
information to appear twice, so delete one of the entries.
Select the cell Range E1:F1 and press <Delete> to clear the cell
contents.
Now you can save the changes you’ve made to the workbook.
Save your work by clicking the Save button on the Standard toolbar.

If you’ve made it through the last two lessons consider yourself an expert on moving and
copying cells in Microsoft Excel. Actually, you can consider yourself an expert on copying
and moving things in general, because the techniques you’ve learned in the last two lessons—
cutting, copying, pasting, and dragging and dropping—will work with almost any Windows
program!
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Press and hold down
the <Ctrl> key while
using drag and drop to
copy the cell(s)
instead of moving
them.

Quick Reference
To Move Cells with Drop
and Drag:
1. Select the cell or the cell
range you want to move.
2. Move the pointer to the
border of the cell or cell
range, click and hold
down the mouse button
and drag the cell or cell
range to the upper-left cell
of the area where you
want to move the data.
3. Release the mouse
button.
To Copy Cells with Drag
and Drop:
• Follow the above
procedure, only hold
down the <Ctrl> key while
you drag and drop the
cell(s).
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Lesson 2-5: Collecting and Pasting
Multiple Items
Figure 2-9
The Clipboard toolbar
displays the cut or copied
objects you’ve collected.
Clipboard toolbar

Figure 2-10
The Office 2000 Clipboard
toolbar.

Figure 2-9

Copy selected
item.

Pastes all the contents of the Office
clipboard.
Clears the contents of the Office
clipboard.
Contents of the Office clipboard.
Point to an icon to see what it is and
click an icon to paste it.

Figure 2-10

If you do a lot of cutting, copying, and pasting, you will probably appreciate Excel 2000’s
new and improved Office clipboard, which holds not one but 12—count ’em 12—cut or
copied objects.
You can use the Office Clipboard to collect and paste multiple items. For example, you can
copy text in a Microsoft Word document, switch to Excel and copy a drawing object, switch
to PowerPoint and copy a bulleted list, switch to Access and copy a datasheet, and then switch
back to Word and paste the collection of copied items.
In order to “collect and paste” multiple items you need to display the Clipboard toolbar.

Copy button
Other Ways to Copy:
• Select Edit → Copy
from the menu.
• Press <Ctrl> + <C>.

 2000 CustomGuide, Inc.

1.
2.

Select View → Toolbars → Clipboard from the menu.
The Clipboard toolbar appears. Anything you cut or copy (up to 12 items) will appear
in the Clipboard toolbar.
Select the cell range A6:D6 and click the Copy button on the Standard
toolbar.
You’ve just added the contents of the cell range A6:D6 to the Office clipboard.
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3.

4.

5.
6.
7.
8.

Select the cell range A10:D10 and click the Copy button on the
Standard toolbar.
Excel adds the copied cell range to the Office 2000 clipboard as shown in Figure 2-9.
Several Excel icons appear on the Clipboard toolbar—these represent everything you
have cut or copied recently in any Office 2000 program. Notice more than two Excel
icons appear on your Clipboard toolbar—that’s because the contents from the previous
cut, copy, and paste lesson are still there as well as what you’ve just copied.
Let’s add one more item to the clipboard.
Select the cell range A12:D12 and click the Copy button on the
Standard toolbar.
Another Excel icon appears on the clipboard. The type of clipboard icon indicates
which program the object was collected from, as described in Table 2-2: Icons in the
Clipboard Toolbar, but that’s still not very descriptive. To see the contents of an icon
on the Clipboard toolbar, simply hover the pointer over the icon (but don’t click it!).
Point to the last icon on the Clipboard toolbar without clicking it.
A small window displays a succinct description of what the cut or copied object is.
Click cell A13 and click the Paste All button on the Clipboard toolbar.
Excel pastes all the contents of the Office clipboard. Let’s see if you remember how to
clear cell contents…
Select the range of pasted cells and press the <Delete> key.
Move on to the next step and close the Clipboard toolbar.
Click the Clipboard toolbar’s Close button.

Table 2-2: Icons in the Clipboard Toolbar
Clipboard Icon

Description Contents
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Point to a collected
object on the
Clipboard toolbar to
see what it is.

Paste All button

Quick Reference
To Display the Clipboard
Toolbar:
• Select View → Toolbars
→ Clipboard from the
menu.
Or…

Object cut or copied from a Microsoft Excel 2000 workbook.

• Right-click any toolbar or
the menu bar and select
Clipboard from the
shortcut menu.

Object cut or copied from a Microsoft PowerPoint 2000 presentation.

To Add Items to the Office
Clipboard:

Object cut or copied from a Microsoft Access 2000 database.

Object cut or copied from a Microsoft Word 2000 document.

• Copy and/or cut the items
as you normally would or
consecutively.

Web page contents cut or copied from Microsoft Internet Explorer.

To View the Contents of a
Clipboard Item:

Cut or copied graphic object.

• Point to the item on the
Clipboard toolbar.

Object cut or copied from a program other than Microsoft Office 2000.

To Paste from the Office
Clipboard:
• Display the Clipboard
toolbar and then click the
item you want to paste.
Click the Paste All
button to paste
everything.
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Lesson 2-6: Working with
Absolute and Relative Cell
References
Figure 2-11
Using AutoFill to copy a
formula to other cells.

Click the fill
handle of a
selected cell or
cell range…

Figure 2-12
Relative vs. absolute cell
references.

…and drag to
select the cell
where you
want to copy
the cell.

Figure 2-11

Relative cell references
are based on their
position relative to the
cell that contains the
formula. The cell
references change if the
cell is moved to a new
location.

Absolute cell references
always refer to a
particular cell address.
They do not change if
the cell is moved to a
new location.

Figure 2-12

One of the more difficult Excel concepts you need to understand is the difference between
relative and absolute cell references. You should already know that a cell reference identifies
a cell or a range of cells on a worksheet and tells Microsoft Excel where to look for values
you want to use in a formula. Here is the description and differences between absolute and
relative cell references:
•

Relative: Relative references tell Excel how to find another cell starting from the cell
that contains the formula. Using a relative reference is a lot like giving someone
directions based on where they’re standing right now. When a formula containing relative
references is moved, it will reference new cells based on their location to the formula.
Relative references are the default type of references used in Excel.

•

Absolute: Absolute references always refer to the same cell address, even if the formula
is moved.

If you’re continuing from the previous Copying and Pasting lessons you can skip the first step
of this exercise, otherwise you will need to open the Lesson 2B file…

1.
2.
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If necessary, open the workbook named Lesson 2B on your Practice
disk or in your Practice folder then save it as Mileage Report.
First we need to create a simple formula…
Click cell E5, type the formula =D5-C5 and press <Enter>.
You’ve just created a simple formula that finds out the number of miles driven to a
location by subtracting the beginning mileage from the ending mileage. Instead of
retyping the total miles formula for every one of the destinations, you can copy the
formula using any of the copy and paste methods you’ve already learned. The easiest
and fastest way of copying the formula to the other cells is using the AutoFill function.
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3.

4.

5.

6.
7.

8.
9.

10.

Click cell E5 and position the pointer over the fill handle of cell E5, until it
changes to a , click and hold the mouse and drag the fill handle down to
cell E12 and release the mouse button, as shown in Figure 2-11.
Poof! AutoFill copies the formula you entered in cell E5 to the cells you selected,
saving you a lot of time if you manually entered the formulas yourself. Now let’s take
a look at what is meant by a relative cell reference.
Click cell E6 to make it active.
Look at the formula bar. The formula that Excel copied to this cell isn’t exactly the one
you entered in cell E5. Instead of the original formula you entered, =D5-C5, this cell
contains the formula =D6-C6. Do you see what happened? Excel copied the formula,
but substituted new cell references so that although the location of the cell has
changed, its relationship with the cells in the formula hasn’t. This is an example of
relative cell addresses—they are based on their position relative to the cell that
contains the formula.
Relative cell addresses are almost always the best way to reference other cells in
formulas, which is why they are the default way Excel uses to reference cells.
Sometimes, however, you might want a cell reference to always refer to a particular
cell address. In this case, you would use an absolute cell reference, which always refers
to a specific cell address, even if you move the formula to a new location. Create
another formula to see how to use an absolute cell reference.
Select cell F5, type =, click cell E5 (the total miles), type * (the
multiplication operator), click cell F2 (the cost per mile), and complete
the formula by pressing <Enter>.
Great! You’ve just created a formula that multiples the totals miles driven by the cost
per mile, currently .32. Now use AutoFill to copy the formula to the other cells.
Position the pointer over the fill handle of cell F5, until it changes to a ,
click and hold the mouse and drag the fill handle down to cell F12 and
release the mouse button.
Excel copies the formula, but what went wrong? Let’s take a look.
Click cell F6 to make it active.
Look at the formula bar. The formula, =E6*F3, that Excel copied to this cell is not
correct. Look at cell F3—there’s nothing there to multiply (unless you consider the text
label), hence the #VALUE! error message. You need to use an absolute reference so the
formula always refers to cell F2, even if a formula is moved or copied.
Click cell F5 to make it active and click anywhere in the Formula bar to
change to Edit mode.
Verify the insertion point is touching the F2 in the formula and press the
<F4> key.
Dollar signs appear, changing the F2 reference to $F$2—indicating it is an absolute
reference. You can create an absolute reference to a cell by placing a dollar sign ($)
before the parts of the reference that do not change. To create an absolute reference to
cell A1, for example, add dollar signs to the formula: $A$1. Pressing <F4> changes a
relative cell reference to an absolute cell reference.
Press <Enter> and repeat Step 6 to copy the formula to the other cells.
This time the formula is copied correctly. The first cell reference in the formula is
relative and changes based on the formula’s location. The second cell reference in the
formula, ($F$2), on the other hand, is an absolute cell reference and always points to
cell F2, regardless of the formula’s location.
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Fill Handle
A1
Relative
Reference
$A$1
Absolute
Reference
Press the <F4> key
when clicking a cell to
create an absolute cell
reference.

Quick Reference
To Create an Relative
Reference in a Formula:
• Click the cell you want to
reference, for example
click cell B4.
Or…
• Type the address of the
cell, for example type B4.
To Create an Absolute
Reference in a Formula:
• Press and hold the <F4>
key as you click the cell
you want to reference, for
example click cell B4.
Or…
• Type the address of the
cell with $ (dollar signs)
before every reference
heading. For example,
type $B$4.
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Lesson 2-7: Using the Paste
Special Command
Figure 2-13
Standard method of
copying and pasting cells.
Notice the pasted
formulas all result in 0.
Figure 2-14
The Paste Special dialog
box.
Figure 2-15
Pasting cell values.
Figure 2-16

Figure 2-13

Figure 2-14

Figure 2-15

Figure 2-16

Pasting using the Multiply
operator.

Excel’s Paste Special command lets you specify exactly what you want to copy. For example,
you can use the Paste Special command to copy the resulting value of a formula without
copying the formula itself, or to copy the values of a range of cells without any of the cell’s
formatting options.

Copy button
Other Ways to Copy:
• Select Edit → Copy
from the menu.
• Press <Ctrl> + <C>.
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If you’re continuing from the previous absolute and relative address lesson you can skip the
first step of this exercise, otherwise you will need to open the Lesson 2C file…

1.
2.

If necessary, open the workbook named Lesson 2C on your Practice
disk or in your Practice folder then save it as Mileage Report.
First we need to copy something…
Select the cell range E4:E12 and click the Copy button on the Standard
toolbar (or use the keyboard shortcut: <Ctrl> + <C>).
The cell range is copied to the clipboard.
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3.

4.
5.
6.
7.
8.

9.
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Select cell E14 and click the Paste button on the Standard toolbar (or
use the keyboard shortcut: <Ctrl> + <V>).
Excel pastes the contents of the copied cells, as shown in Figure 2-13. Notice, however,
that the resulting values from the copied formulas are all 0. Instead of copying the cell
formulas, you wanted to copy the cell values. You can do this with the Paste Special
command.
Repeat Step 2 to copy the cell range E4:E12, then select cell E14.
Now use the Paste Special command to paste the current values from the copied cells.
Select Edit → Paste Special from the menu.
The Paste Special dialog box appears, as shown in Figure 2-14. The Paste Special
dialog box lets you specify special options for pasting information.
Select the Values option and click OK.
Excel pastes the resulting values from the copied cell range formulas, as shown in
Figure 2-15. Try using another Paste Special option. Suppose you need to increase the
mileage reimbursement for the month by 25 percent.
Select cell G4, type 1.25 and press <Enter>.
Select cell G4, copy the cell’s contents by clicking the Copy button on
the Standard toolbar, select the cell range F4:F12, and then select Edit
→ Paste Special from the menu.
The Paste Special dialog box reappears. This time you will use an operation to multiply
the value of the copied cell with the values in the selected cell range.
Select the Multiply option under the Operations section and click OK.
The dialog box closes and the selected cell range is multiplied by the value of cell G5,
as shown in Figure 2-16.

Table 2-3: Paste Special Options describes the options in the Paste Special dialog box.
Table 2-3: Paste Special Options
Paste Option

Description

All

Pastes all cell contents and formatting. Same as the Paste command.

Formulas

Pastes only the formulas as entered in the formula bar.

Values

Pastes only the values as displayed in the cells (very useful!)

Formats

Pastes only cell formatting. Same as using the Format Painter button.

Comments

Pastes only comments attached to the cell.

Validation

Pastes data validation rules for the copied cells to the paste area.

All except borders

Pastes all cell contents and formatting applied to the copied cell except
borders.

Operations

Specifies which mathematical operation, if any, you want to apply to the
copied data. For example, you could multiply the pasted data by 5.

Skip Blanks

Avoids replacing values in your paste area when blank cells occur in the
copy area.

Transpose

Changes columns of copied data to rows, and vice versa.

Link

Links the pasted data to the source data.

Quick Reference
To Use the Paste Special
Command:
1. Select the cell or cell
range you want to copy.
2. Cut or copy the selection
using standard cut or
copy procedures.
3. Select the upper-left cell
of the area or select the
cell range where you want
to paste the copied
cell(s).
4. Select Edit → Paste
Special from the menu.
5. Refer to Table 2-3: Paste
Special Options for the
different Paste options.
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Lesson 2-8: Inserting and Deleting
Cells, Rows, and Columns
Figure 2-17
The Insert dialog box.
Figure 2-18
The Delete dialog box.
Figure 2-19

Figure 2-17

Figure 2-18

Selecting a cell range to
insert.
Figure 2-20
Two inserted cell ranges.

Figure 2-19
Existing cells move to
make room for the
inserted cells.

Figure 2-20

While working on a worksheet, you may need to insert new cells, columns, or rows into your
worksheet. Other times you may need to delete existing cells, columns, or rows from the
worksheet. When you insert cells, you must shift any existing cells down or to the right to
make room from the new cells. Likewise, when you delete cells (which is not the same as
clearing the cell contents) you must shift any existing cells to fill the space left by the
deletion.

Shortcut Menu

In this lesson, you will get some practice inserting and deleting cells, rows, and columns. If
you’re continuing from the previous absolute and relative address lesson you can skip the first
step of this exercise, otherwise you will need to open the Lesson 2C file.

1.
2.
Select rows and
columns by clicking the
heading for first row
or column you want to
select, then dragging
the mouse pointer to
the last row or column
heading.
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3.

4.

If necessary, open the workbook named Lesson 2C on your Practice
disk or in your Practice folder then save it as Mileage Report.
First you need to specify where you want to insert the new cell.
Select the cell range A2:F2.
This is where you want to insert the new cells.
Select Insert → Cells from the menu.
The Insert dialog box appears, as shown in Figure 2-17. You can choose to shift the
existing cells to the right or down, or you can insert an entire row or entire column. The
“Shift cells down” option is selected by default. This is the option you want to use.
You’re going to be inserting a new row of cells.
Click OK.
Excel inserts six new cells and shifts the cells below down one row.
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You can also insert entire columns and rows using a couple different methods:
•

Menu: Select the column or row heading where you want to insert the new
column or row and select Insert → Rows or Insert→ Columns from the menu.

•

5.
6.
7.
8.

9.

Shortcut Menu: Right-click the selected row or column heading(s) and select
Insert from the shortcut menu.
Select the second and third rows by clicking the 2 row heading and
dragging the pointer to the 3 row heading and then releasing the mouse
button.
You’ve selected both the sixth and seventh rows.
Right-click either of the selected row headings and select Insert from the
shortcut menu.
Excel inserts two new rows. Inserting a column is almost the same as inserting a row.
Select the cell range F3:F15 and select Insert → Cells from the menu.
The Insert dialog box reappears. This time you want to shift the existing cells to the
right. Based on the selected cell range, Excel recognizes this is the most likely option,
so the “Shift cells right” option is selected by default.
Click OK.
Excel inserts the new cells and shifts the selected cell range to the right.
Deleting cells, cell ranges, columns, and rows is just as easy and straightforward as
inserting them.
Repeat the procedure you learned1 in Step 5 to select the second, third,
and fourth rows.

10. Select Edit → Delete from the menu.
11.

The selected rows are deleted. You can also delete cells using the shortcut menu
method:
Right-click the F column heading and select Delete from the shortcut
menu.
Excel deletes the entire F column.

That’s it! You’ve learned how to insert and delete cells, columns, and rows to and from your
worksheets.

Quick Reference
To Insert a Row or
Column:
1. Select the row or column
headings where you want
to insert the column or
row.
2. Right-click the selected
row or column heading(s)
and select Insert from the
shortcut menu.
Or…
Select Edit → Insert
Columns or Insert Rows
from the menu.
To Delete a Row or
Column:
1. Select the row or column
heading(s) you want to
delete.
2. Right-click the selected
row or column heading(s)
and select Delete from
the shortcut menu.
Or…
Select Edit → Delete
from the menu.
To Delete a Cell Range:
1. Select a cell range you
want to delete.
2. Right-click the selection
and select Delete from
the shortcut menu. Or
select Edit → Delete
from the menu.
3. Specify how you want
adjacent cells shifted.
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Lesson 2-9: Using Undo, Redo,
and Repeat
Figure 2-21
Undoing a clear cell
command.

You just deleted the
contents of this cell.

Undo button
Other Ways to Undo:
• Select Edit → Undo
from the menu.
• Press <Ctrl> + <Z>.

Redo button
Other Ways to Redo:
• Select Edit → Redo
from the menu.
• Press <Ctrl> + <Y>.
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Figure 2-21 The undo command brings the cell
contents back, undoing your deletion.

You may not want to admit this, but you’re going to make mistakes when you use Excel. You
might accidentally delete a column or row you didn’t mean to delete, or paste something you
didn’t mean to paste. Fortunately, Excel has a wonderful feature called Undo that does just
that—undoes your mistakes and actions, making them as though they never happened. Excel
can undo up to 16 of your last actions or mistakes. This lesson explains how you can undo
both single and multiple mistakes, and how to redo your actions in case you change your
mind.

1.

Select cell A1 to make it active and press the <Delete> key to delete the
worksheet’s title.
The worksheet’s title, “Reimbursable Mileage Report,” disappears. Whoops! You
didn’t really want to delete that! Watch how you can undo your “mistake.”
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2.

3.

4.
5.
6.

7.

8.

9.
10.
11.

Click the Undo button.
Poof! The deleted title “Reimbursable Mileage Report” is back again. Hmmm…
maybe you did want to erase the worksheet title after all. Anything that can be undone
can be redone if you change you change your mind or want to “undo an undo.” Here’s
how you can redo the previous clear command.
Click the Redo button.
The contents of cell A1, the worksheet title, disappear again.
Often you will probably make not one, but several mistakes, and it may be a minute or
two before you’ve even realized you’ve made them. Fortunately, the programmers at
Microsoft thought of this when they developed Excel, because the undo feature is
multileveled—meaning you can undo up to 16 of the last things you did. The next few
stops will show you how you can undo multiple errors.
Select cell F2 to make it active, type .35, and press <Enter>.
There’s your second mistake (the first was deleting the worksheet title in cell A1.)
Select the fourth and fifth rows in the worksheet by clicking the 4 row
heading, holding down the mouse button and dragging the pointer over
the 5 row heading and releasing the mouse button.
Now that you have selected the fourth and fifth rows, you can delete them.
Right-click the selected 4 or 5 row heading and select Delete from the
shortcut menu.
The fourth and fifth rows are deleted from the worksheet. Mistake number three.
You’ve made enough mistakes now to see how multilevel undo works. Here’s how to
undo all of your mistakes.
Click the downward pointing arrow to the right of the undo button.
A list of your recent actions appear beneath the Undo button. Notice that there are more
actions listed than just your three recent “mistakes.” If you wanted you could undo the
last sixteen actions. You don’t want to undo the sixteen actions—just the last three
mistakes.
Select the word Clear from the undo list (it should be the third one on the
list.)
The last three changes you made to the workbook—deleting two rows, typing .35 in
cell F2, and clearing the worksheet’s title—are all undone.
The opposite of the Undo command is the Repeat command, which repeats your last
command or action, if possible. Here’s how to use it.
Select the cell range A3:A12, right-click the selection, select Delete from
the shortcut menu and click OK.
You’ve just deleted the Date column. Now let’s see how you can repeat your last
command.
Select the cell range D3:D12 and press <Ctrl> + <Y>.
Excel repeats your last command and deletes the Total Miles range.
Click the Undo button on the Standard toolbar twice to undo your
deletions, and then save your work.
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Selecting Multiple
Rows

Multilevel Undo

Other Ways to Repeat:
• Select Edit → Repeat
from the menu.

Quick Reference
To Undo:
• Click the Undo button on
the Standard toolbar.
Or…
• Select Edit → Undo from
the menu.
Or…
• Press <Ctrl> + <Z>.
To Redo:
• Click the Redo button on
the Standard toolbar.
Or…
• Select Edit → Redo from
the menu.
Or…
• Press <Ctrl> + <Y>.
To Redo:
• Select Edit → Repeat
from the menu.
Or…
• Press <Ctrl> + <Y>.
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Lesson 2-10: Checking Your
Spelling
Figure 2-22
The Spelling dialog box.
Figure 2-23
Excel starts checking the
worksheet’s spelling at the
active cell. When it
reaches the end of the
worksheet it asks if you
want to continue checking
at the beginning of the
document.
Figure 2-24
The spell check complete
dialog box.

Figure 2-22

Figure 2-23

Figure 2-24

Spell check used to be a feature only available in word processing programs—but no more!
You can use Excel’s spell checker to find and correct any spelling errors you might have made
in your workbooks. Excel’s spell checker is shared and used by the other programs in the
Microsoft Office suite. Any words you add to the custom spelling dictionary in one Microsoft
Office program will be available in all the other programs. Worksheets are not the same as
documents created by word processors and may contain abbreviations that the spell checker
may not recognize. When this happens click either Ignore to ignore the abbreviation, or Add
to add the abbreviation to the custom spelling dictionary.

1.
Spelling button
Other Ways to Spell
Check:
• Select Tools →
Spelling from the
menu.
• Press <F7>.
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2.
3.

Press <Ctrl> + <Home> to move to the first cell in the worksheet, A1.
Excel starts checking the spelling of the words in a worksheet at the active cell and
stops whenever it encounters a word that is not found in its dictionary.
Click the Spelling button on the Standard toolbar.
The Spelling dialog box appears; as shown in Figure 2-22, with the misspelled word
“Amuont” listed as the first misspelled word in the worksheet. Excel lists several
possible suggestions for the correct spelling of the word.
Click Amount in the Suggestions list and click Change.
Excel makes the spelling correction for you. The spell checker moves on and selects
the word “Cloquet” as the next misspelled word in the worksheet. Excel couldn’t find
the word “Cloquet” in its dictionary, but since it is the name of a city and is spelled
correctly you can ignore it.
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4.
5.

Click Ignore All to ignore all occurrences of the word “Cloquet” in the
worksheet.
When the spell checker can’t find any more incorrectly spelled words, Excel will
indicate the spell check is complete by displaying the dialog box shown in Figure 2-24.
Click the Save button on the Standard toolbar to save the changes
you’ve made to the worksheet.
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Save button

No doubt about it, the spell checker is a great tool to assist you in creating accurate
worksheets. It’s important to note, however, that Excel won’t catch all of your spelling errors.
For example, if you mistakenly type the word “Repeat” when you meant to type “Report”
Excel won’t catch the mistake because “Repeat” is a correctly spelled word.

Quick Reference
To Check the Spelling in a
Worksheet:
• Click the Spelling button
on the Standard toolbar.
Or…
• Select Tools → Spelling
from the menu.
Or…
• Press <F7>.
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Lesson 2-11: Finding and Replacing
Information
Figure 2-25
The Find dialog box.
Figure 2-26
The Replace dialog box.
Figure 2-27

Figure 2-25

Replaced labels.
Figure 2-27

Replaced label

Figure 2-26

Imagine you are working on a huge worksheet that tracks the feeding patterns of various
squirrels. You’re almost finished with the worksheet when you realize that you’ve mistakenly
referred to one of the species of squirrels you’re tracking—flying squirrels—not by their
proper scientific name “Sciuridae Glaucomys,” but by the scientific name for the common
gray squirrel “Sciuridae Sciurus.” Yikes! It will take hours to go back and find every instance
of “Sciuridae Sciurus” and replace it with “Sciuridae Glaucomys.” It could. Or it could take
you less than a minute if you use Excel’s Find and Replace function.
This lesson explains how to find specific words, phrases, and values in your workbooks, and
how you can automatically replace those words, phrases, and values.

1.
Other Ways to Find
Information:
• Press <Ctrl> + <F>

2.
3.
4.
5.

Other Ways to Find and
Replace Information:
• Press <Ctrl> + <H>
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6.
7.

Press <Ctrl> + <Home> to move to the beginning of the worksheet, cell
A1.
Select Edit → Find from the menu.
The Find dialog box appears, as shown in Figure 2-25.
In the Find what box type Minneapolis.
You want to find every occurrence of the phrase “Minneapolis” in the worksheet.
Click the Find Next button.
Excel jumps to the first occurrence of the word “Minneapolis” it finds in the
worksheet.
Click the Find Next button.
Excel jumps to the next occurrence of the word “Minneapolis” in the worksheet.
Click Close to close the Find dialog box.
The Find dialog box closes. You can also replace information in a worksheet.
Select Edit → Replace from the menu.
The Replace dialog box appears, as shown in Figure 2-26.
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8.
9.
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In the Find what text box type Mankato.
You want to replace every occurrence of the word “Mankato” with the word “St.
Peter.”
Select the Replace with box by clicking it or by pressing the <Tab> key
and type St. Peter.

10. Click Replace All.
Excel finds all the occurrences of the word “Mankato” in the worksheet and replaces
them with the word “St Peter.”

11.

NOTE: Think before you use the Replace All button—you might not want it to
replace every instance of a label or value! You can find and replace each
individual occurrence of a label or value by clicking Find Next and then
Replace.
Click OK.
The Replace dialog box disappears and you’re back to your worksheet. Notice how all
the occurrences of the word “Mankato” have been replaced by “St. Peter.”

Quick Reference
To Find Information in a
Workbook:
1. Select Edit → Find from
the menu.
Or…
Press <Ctrl> + <F>.
2. Enter the text you want to
search for in the Find
what box.
3. Click the Find next
button.
4. Repeat Step 3 until you
find the text you’re looking
for.
To Find and Replace
Information:
1. Select Edit → Replace
from the menu.
Or…
Press <Ctrl> + <H>.
2. Enter the text you want to
search for in the Find
what box.
3. Enter the new text in the
Replace with box.
4. Click the Find next
button.
5. Click the Replace button
to replace the text.
6. Repeat Steps 4 and 5 if
there is more than one
occurrence that you want
to replace.
Or…
Click Replace All to
search and replace every
occurrence of text in the
workbook.

84

Microsoft Excel 2000

Lesson 2-12: Advanced Printing
Options
Figure 2-28
The Print dialog box.

Figure 2-28

You already know how to print. In this lesson you will become an expert at printing. This
lesson explains how to print more than one copy of a document, send a document to a
different printer, and print specific pages of a document.

1.
Other Ways to Print:
• Press <Ctrl> + <P>

2.
3.

Click File → Print from the menu.
The Print dialog box opens, as shown in Figure 2-28. The Print dialog box is where
you can specify printing options when you print your workbook. Several commonly
used print options you might specify would be: how many pages to print, specific
pages to print, or to which printer to print (if your computer is attached to more than
one printer). See Table 2-4: Print Dialog Box Options for a description of what print
options are available.
In the Number of copies box, type 2.
Click OK.
The Print dialog box closes, and Excel prints two copies of your worksheet (if your
computer is attached to a printer.)

Table 2-4: Print Dialog Box Options on the following page explains some of the other print
options you can use when printing a worksheet.
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Table 2-4: Print Dialog Box Options
Print option

Description

Name

Used to select which printer to send your workbook to when it prints (if you
are connected to more than one printer). The currently selected printer is
displayed.

Properties

Displays a dialog box with options available for your specific printer such as
what paper size you’re using, if your document should be printed in color or
black and white, etc.

Print to file

Prints the workbook to a file instead of sending it to the printer.

Page range

Allows you to specify what pages you want printed. There are several options
here:
All: Prints the entire document.
Current page: Prints only the page of the workbook you’re currently on.
Selection: Prints only selected cells.
Pages: Prints only the pages of the workbook you specify. Select a
range of pages with a hyphen (like 5-8) and separate single pages with a
comma (like 3,7).

Number of copies

Specify the number of copies you want to print.

Print what

Allows you to select what is printed: the currently selected cells, the active
sheet(s), or the entire workbook.

Options

Lets you specify other printing options, such as printing a document in
reverse order (from the last page to the first).
Quick Reference
For Advanced Printing
Options:
1. Select File → Print from
the menu.
2. Refer to Table 2-4: Print
Dialog Box Options for
information on various
printing options.

86

Microsoft Excel 2000

Lesson 2-13: File Management
Currently selected folder or drive. Click the
list and change drives or folders.

Figure 2-29

to

The Open and Save As
dialog boxes’ toolbar.

Go back to
the previous
folder.

Search the Create a Menu of file
Web.
new folder. management
commands.

Figure 2-30
The View list button lets
you change how files are
displayed in the Open or
Save As dialog boxes.

Figure 2-29

Files and folders are
displayed in a list,
allowing you to view as
many files as possible.

Displays information
about every file, such as
its name and size.

Go up one
folder or level.

Delete the View: Change
selected how files are
file(s).
displayed.

Displays detailed
information about the
selected file.

Displays a preview of
the selected file (when
possible).

Figure 2-30

Open button

File management includes moving, copying, deleting, and renaming the files you’ve created.
Although it’s a little easier to work with and organize your files using Windows Explorer or
My Computer you can also perform a surprising number of file management chores right
from inside Microsoft Excel 2000—especially with its new and improved Open and Save
dialog boxes.

1.

Click the Open button on the Standard toolbar.
The Open dialog appears. The Open dialog box is normally used to open files, but you
can also use it to perform several file management functions. There are two different
ways to access file management commands from inside the Open or Save As dialog
boxes:
•

Tools menu

2.
3.

View list button

 2000 CustomGuide, Inc.

4.

Select a file and then select the command you want from the dialog box’s Tools
menu.

• Right-click a file and select the command you want from a shortcut menu.
Right-click the Rename Me file.
A shortcut menu appears with a list of available file management commands for the
selected file.
Select Rename from the shortcut menu, type Home Budget and press
<Enter>.
You have just changed the name of the selected file from “Rename Me” to “Home
Budget.” Instead of right-clicking the file, you could have selected it and then selected
Rename from the Tools menu. Move on to the next step to learn how to delete a file.
Click the Home Budget file to select it and press the <Delete> key.
A dialog box appears, asking you to confirm the deletion of the Home Budget file.
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5.
6.

7.
8.
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Click Yes.
The Home Budget file is deleted. If you work with and create numerous files, you may
find it difficult to remember what you named a file. To find the file(s) you’re looking
for, it can help to preview your files without opening them.
Click the View button arrow and select Preview.
The Open dialog changes the display of Excel files on your Practice folder or disk from
List View to Preview View. To see the contents of a file, select it in the file list on the
left side of the dialog box and it will appear in the Preview area to the right side of the
dialog box. Try previewing the contents of a file without opening it now.
Click the Lesson 1 file.
The Lesson 1 file is selected and a preview of its contents appear in the Preview
section. Change back to List mode to display as many files in the window as possible.
Click the View button arrow, select List to display the files in list view,
then close the dialog box by clicking Cancel.

Table 2-5: File Shortcut Menu Commands
Command

Description

Open

Opens the selected file.

Open Read-Only

Opens the selected file so that it can be read but not changed.

Open as Copy

Creates a copy of the selected file with the name “Copy of” and the name of
the original file, and then opens the new, copied file.

Print

Sends the selected file to the default printer.

Quick View

Displays the contents of the selected file without opening the file.

Send To

Depending on how your computer is set up, it lets you send the selected file
to a printer, to an e-mail recipient, to a fax, or to a floppy drive.

Cut

Used in conjunction with the Paste command to move files. Cuts, or removes
the selected file from its current folder or location.

Copy

Used in conjunction with the Paste command to copy files. Copies the
selected file.

Paste

Pastes a cut or copied file or files.

Create Shortcut

Creates a shortcut—a quick way access a file or folder without having to go
to its permanent location—to the file

Delete

Deletes the selected file or files.

Rename

Renames the selected files.

Properties

Displays the properties of the selected file, such as when the file was created
or last modified, or how large the file is.

File Shortcut
menu

Quick Reference
Basic File Management in
the Open Dialog box:
1. Open the Open or Save
As dialog boxes by
selecting Open or Save
As from the File menu.
2. Right-click the file and
refer to Table 2-5: File
Shortcut Menu
Commands for a list of
things you can do to the
selected file or select the
file and select a command
from the Tools menu.
To Change How Files are
Displayed:
• Click the View button
arrow and select a view.
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Lesson 2-14: Inserting Cell
Comments
Figure 2-31
Inserting a comment.

Sizing handles

Comment
indicator
User name

Figure 2-31

Sometimes you may need to add notes to your worksheet to document complicated formulas,
questionable values, or leave a comment to another user. Excel’s cell comments command
helps you document your worksheets and make them easier to understand. Think of cell
comments as Post-It Notes that you can attach to any cell. Cell comments appear whenever
you point at the cell they’re attached to.

1.
2.
Shortcut menu
Other Ways to Insert a
Cell Comment:
• Select Insert → Insert
Comment from the
menu.

Comment
Indicator
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3.
4.

Right-click cell B12.
A shortcut menu appears.
Select Insert Comment from the shortcut menu.
A comment box appears by the cell, as shown in Figure 2-31. Notice a name appears at
the beginning of the comment—this is the user name, which can be found by selecting
Tools → Options from the menu and clicking the General tab. The user name appears
on the comment so that other users will know who added the comment. You can add a
note to the comment box by just typing.
Type This destination may be incorrect.
Now that you’ve finished writing the note, you can close the comment box.
Click anywhere outside the comment box to close it.
The comment box closes. Notice a small red triangle now appears in the upper-right
corner of cell B12. This triangle indicates that there is a comment attached to the cell.
Displaying a comment is easy.
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5.
6.
7.
8.

9.

Position the pointer over cell B12.
The comment appears next to the cell whenever the pointer is positioned over it. Here’s
how to edit a comment:
Right-click cell B12.
A shortcut menu appears.
Select Edit Comment from the shortcut menu.
An insertion point () appears at the end of the text in the comment box, indicating
you can edit the text in the comment box. Add some more text to the comment box.
Press the <Spacebar>, then type Could you check my receipts to
verify this?
You can also change the size and position of a comment box while in Edit mode.
Notice the white boxes that appear at the corners and sides of the comment box, as
shown in Figure 2-31? These are sizing handles, which you can use to change the size
of the box.
Position the pointer over the lower-right sizing handle, until the pointer
changes to a , then click and hold the left mouse button and drag the
mouse diagonally up and to the left about a half-inch, then release the
mouse button.
The comment is resized, and the text is wrapped accordingly. You can also move a
comment to a different location on the screen.

10. Position the pointer over the border of the comment box, until it changes

11.
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, click and drag the comment down an inch, then release the
to a
mouse button to drop the comment.
You’ve just moved the comment to a new position on the worksheet. Now delete the
comment.
Right-click cell B12 and select Delete Comment from the shortcut
menu.

Resize a comment box
by clicking and
dragging any of its
sizing handles until the
comment box is the
size you want.

Quick Reference
To Insert a Comment:
1. Right-click the cell you
want to attach a comment
to.
2. Select Insert Comment
from the shortcut menu.
3. Type the comment.
4. Click anywhere outside
the comment area when
you’re finished.
To Edit a Comment:
1. Right-click the cell that
contains the comment
you want to edit.
2. Select Edit Comment
from the shortcut menu.
3. Edit the comment.
4. Click anywhere outside
the comment area when
you’re finished.
To Delete a Comment:
1. Right-click the cell that
contains the comment
you want to edit.
2. Select Delete Comment
from the shortcut menu.
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Chapter Two Review
Lesson Summary
Entering Data Values and Using AutoComplete
•

Excel treats dates and times as values.

•

You can enter dates in cells using almost any type of date format: 1/1/99, 1-1-99, January 1, 1999,
etc.

•

To Use AutoComplete: Type the first few characters of a label; Excel displays the label, if it
appears previously in the column. Press <Enter> to accept the entry or resume typing to ignore the
suggestion.

•

To Use the Pick From List: Right-click the cell where you want to enter a label, select Pick from
List from the shortcut menu, and select the entry from the list.

Editing, Clearing, and Replacing Cell Contents
•

To Clear Cell Contents: Select the cell or cell range and press the <Delete> key.

•

Entering information into a cell replaces its previous contents.

•

To Edit a Cell’s Contents in the Formula Bar: Select the cell, click the Formula bar and edit the
cell contents and press <Enter> when you’re finished.

•

To Edit a Cell’s Contents in the Cell Itself: Double-click the cell you want to edit, edit the cell
contents, and press <Enter> when you’re finished.

Cutting, Copying, and Pasting Cells
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•

Cut cells or cell ranges by selecting the cell or cell range and using one of four methods to cut:
1) Click the Cut button on the Standard toolbar.
2) Select Edit → Cut from the menu.
3) Press <Ctrl> + <X>.
4) Right-click and select Cut from the shortcut menu.

•

Select the cell where you want to paste the cut cell(s) and press <Enter>.

•

Copy cell or cell ranges by selecting the cell or cell range and using one of four methods to cut:
1) Click the Copy button on the Standard toolbar.
2) Select Edit → Copy from the menu.
3) Press <Ctrl> + <C>.
4) Right-click and select Copy from the shortcut menu.

•

Paste copied cells by selecting the cell where you want to paste the copied cell(s) and using one of
four methods:
1) Click the Paste button on the Standard toolbar.
2) Select Edit → Paste from the menu.
3) Press <Ctrl> + <V>
4) Right-click and select Paste from the shortcut menu.
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Moving Cells with Drag and Drop
•

Select the cell or cell range you want to move, drag the selection by its outside border to the upperleft cell of the area where you want to move the cells, and release the mouse button.

Collecting and Pasting Multiple Items
•

The Office 2000 clipboard can collect up to 12 cut or copied objects. You can use the Office
clipboard with other Microsoft Office 2000 programs, although you can still cut, copy, and paste a
single item using the Windows clipboard with other programs.

•

To Add Items to the Office Clipboard: Copy and/or cut the items as you normally would or
consecutively.

•

To Display the Clipboard Toolbar: Select View → Toolbars → Clipboard from the menu or
right-click any toolbar or the menu bar and select Clipboard from the shortcut menu.

•

To View the Contents of a Clipboard Item: Point to the item on the Clipboard toolbar.

•

To Paste from the Office Clipboard: Display the Clipboard toolbar and then click the item you
want to paste. Click the Paste All button to paste everything.

Working with Absolute and Relative Cell References
•

Relative cell references are based on their position relative to the cell that contains the formula.
The cell references change if the cell is moved to a new location.

•

Absolute cell references are preceded by $ signs and always refer to a particular cell address.
They do not change if the cell is moved to a new location.

•

Press <F4> while selecting a cell range to make it an absolute reference.

Using the Paste Special Command
•

The Paste Special command lets you specify what you want to copy, such as the resulting value of
a formula without copying the formula itself or a cell’s formatting options.

•

To Use the Paste Special command: Cut or copy a cell or cell range, select the upper-left cell of
the area where you want to paste the copied cell(s), select Edit → Paste Special from the menu,
select an option from the Paste Special dialog box, and click OK.

Inserting and Deleting Cells, Rows, and Columns
•

To Insert a Row or Column: Select the row or column headings where you to insert the
column or row, right-click the selected row or column heading(s) and select Insert from the shortcut
menu. Or select the row or column headings where you want the row or column to be inserted, and
select Insert → Columns or Rows from the menu.

•

To Delete a Row or Column: Select the row or column heading(s) you want to delete and either
right-click the selected row or column heading(s) and select Delete from the shortcut menu or
select Edit → Delete from the menu.

•

To Delete a Cell Range: Select the cell range you want to delete, either right-click the selection
and select Delete from the shortcut menu, or select Edit → Delete from the menu, and then
specify how you want adjacent cells shifted.
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Using Undo and Redo
•

Undo: Undo your mistake or last action by clicking the
Undo button on the Standard toolbar,
or by selecting Edit → Undo from the menu, or by pressing <Ctrl> + <Z>.

•

Redo: Redo an undone action by clicking the
Redo button on the Standard toolbar, or by
selecting Edit → Redo from the menu, or by pressing <Ctrl> + <Y>.

•

Multilevel Undo/Redo: Click the arrows on the Undo or Redo buttons on the Standard toolbar to
undo or redo several actions at once.

•

Repeat: Repeat your last command by pressing <Ctrl> + <Y> or by selecting Edit → Repeat from
the menu.

Checking Your Spelling
•

To Check for Spelling Errors: Click the
Tools → Spelling from the menu.

Spelling button on the Standard toolbar or select

Finding and Replacing Information
•

To Find Information: Select Edit → Find from the menu or press <Ctrl> + <F>. Enter the text
you want to search for in the Find what box, and click the Find next button. You can click the Find
next button if there is more than one occurrence until you find the text you’re looking for.

•

To Replace Information: Select Edit → Replace from the menu or press <Ctrl> + <H>. Enter the
text you want to search for in the Find what box type the new text in the Replace with box. Click the
Find next button to find the text and the Replace button to replace the text. Click Replace All to
replace every occurrence of the text in the workbook.

Advanced Printing Options
•

Open the Print Dialog box by selecting File → Print from the menu. You can specify the number of
copies and which pages to print. You can also press <Ctrl> + <P>.

File Management
•

You can perform most file management functions, such as delete, rename, and copy, from the
Open File or Save As dialog boxes. Right-click a file and select a file command from the shortcut
menu or select the file and select a command from the Tools menu.

•

To Change How Files are Displayed: Click the View button arrow and select a view.

Inserting Cell Comments
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•

To Insert a Comment: Right-click the cell you want to attach a comment to and select Insert
Comment from the shortcut menu. Enter the comment and click anywhere outside the comment
area when you’re finished.

•

To Edit a Comment: Right-click the cell that contains the comment you want to edit and select
Edit Comment from the shortcut menu. Edit the comment and click anywhere outside the
comment area when you’re finished adding to the comment.

•

To Delete a Comment: Right-click the cell that contains the comment you want to edit and select
Delete Comment from the shortcut menu.
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Quiz
1. You’re going to the bank on Monday and somehow lose the daily receipts
that you’re supposed to deposit at the end of every day. When you
complete the daily receipts summary worksheet on Friday how can you add
a note to the Monday cell to explain what happened to your boss?
A. Who cares about adding a note? You better start brushing up your resume.
B. Print out the worksheet and add a Post-It note by the Monday receipt cell.
C. Select the Monday receipt cell and select Insert → Comment from the menu to add a
comment.
D. Don’t add a note—just guess what the amount of the deposit would be and enter that.
Let your boss figure it out when she gets the bank statement.
2. Which is the fastest method of replacing the contents of a cell?
A. Press <Delete> to clear the cell’s contents and enter the new contents.
B. Enter the new contents—they will replace the old contents.
C. Click the formula bar to edit the cell contents, press <Backspace> to erase the old
contents, and enter the new contents.
D. Double-click the cell to edit it in-place, press <Backspace> to erase the old contents,
and enter the new contents.
3. Which of the following will NOT cut information?
A.
B.
C.
D.

Clicking the Cut button on the Standard toolbar.
Pressing <Ctrl> + <C>.
Pressing <Ctrl> + <X>.
Selecting Edit → Cut from the menu.

4. Relative references always refer to a particular cell address. They don’t
change if they are moved to a new location (True or False?)
5. The Paste Special command lets you copy and paste: (Select all that apply)
A.
B.
C.
D.

The resulting values of a formula instead of the actual formula.
Formatting options.
Cell comments.
Multiply the selection by a copied value.

6. Which of the following statements is NOT true?
A. You can spell check your worksheets by clicking the Spelling button on the Standard
toolbar.
B. To find information in a worksheet select Edit → Find from the menu.
C. The Undo function can only undo the most recent action you performed.
D. When you delete a cell range, row, or column, you must shift any existing cell to take
the place of the deleted cells.
7. You can edit a cell by: (Select all that apply)
A.
B.
C.
D.

Double-clicking the cell to edit it in-place.
Selecting Edit → Edit Workbook → Edit Worksheet → Edit Cell from the menu.
You can’t—you’re just going to have to retype all that information over again.
Clicking the Formula bar.
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8. The spell checker always marks your name as a spelling error. How can
you get Excel to stop saying your name is spelled incorrectly?
A.
B.
C.
D.

Select Tools → Spelling from the menu and click Add when your name appears.
Right-click your name and select Add from the shortcut menu.
Select Tools → Spelling and Grammar from the menu and click Add to Dictionary.
You can’t do anything about it.

9. How can you print three copies of a workbook?
A.
B.
C.
D.

Select File → Print from the menu and type 3 in the Number of copies text box.
Press <Ctrl> + <P> + <3>.
Select File → Properties from the menu and type 3 in the Copies to print text box.
Click the Print button on the Standard toolbar to print the document then take it to
Kinko’s and have two more copies made.

10. You discover you’ve made minor calculation error in a worksheet. How can
you replace every instance of the word “profit” in your worksheet with the
word “loss”?
A. Select Edit → Replace from the menu, type “profit” in the Find what box, type
“loss” in the Replace with box and click Replace All.
B. There isn’t any easy way—you’ll have to go through your worksheet and replace the
words yourself.
C. Click the Find and Replace button on the Standard toolbar, then follow the Find and
Replace Wizard’s on-screen instructions to replace the word.
D. Select Tools → Replace from the menu, type “profit” in the Find what box, type
“loss” in the Replace with box and click Replace All.
11. Which of following is an absolute cell reference?
A.
B.
C.
D.

A1.
#A#1.
!A!1.
$A$1.

12. You can use the Copy button on the Standard toolbar to copy a worksheet’s
values but not its formulas. (True or False?)
13. How do you insert a row? (Select all that apply.)
A. Right-click the row heading where you want to insert the new row and select Insert
from the shortcut menu.
B. Select the row heading where you want to insert the new row and select Edit →
Insert Row from the menu.
C. Select the row heading where you want to insert the new row and click the Insert
Row button on the Standard toolbar.
D. Select the row heading where you want to insert the new row and select Insert →
Row from the menu.
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14. How do you delete a column? (Select all that apply.)
A. Right-click the column heading you want to delete and select Delete from the
shortcut menu.
B. Select the column heading you want to delete and select Edit → Delete from the
menu.
C. Select the column heading you want to delete and select the Delete Row button on
the Standard toolbar.
D. Select the column heading you want to delete and select Insert → Delete from the
menu.

Homework
1. Open the Homework 2 workbook and save it as “Doodads”.

2. Change the worksheet title in cell A1 to “2000 Manufacturing Summary”.
3. Create a formula that finds the profit per unit in cell D4 (hint: you’ll have to subtract
cell C4 from cell B4.)
4. Copy the formula you created in cell D4 to the remaining cells under the Profit Per
Unit heading (the cell range D5:D7).
5. Copy the labels in cell range A4:A7 to the cell range A11:A14.
6. Use AutoFill to add the remaining months in row 10.
7. Check the worksheet for spelling errors.
Extra Credit: Create a formula in cell B15 that totals the September column, then
multiplies by the value in cell D4. Only make the reference to the D column an
absolute reference. Copy the formula to the remaining cells in the Sales Forecast
table.
Can’t figure out the formula? It’s =SUM(B11:B14)*$D4.
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Quiz Answers
1. C. Selecting Insert → Comment attaches a note to the current cell.
2. B. Typing replaces the previous contents of a cell. The other methods also work—
they’re just not nearly as fast.
3. B. <Ctrl> + <C> copies information instead of cutting it.
4. False. Relative cell references are based on their position from the cell that contains
the formula, and change if the cell that contains the formula is moved.
5. A, B, C, and D. You can use the Paste Special command to copy and paste all of
these items.
6. C. The Undo function can undo up to 16 of your last actions.
7. A and D. You can edit the contents of a cell by clicking the formula bar or by doubleclicking the cell.
8. A. Add your name to the dictionary by selecting Tools → Spelling from the menu
and clicking Add when your name appears.
9. A. You need to open the Print dialog box and specify the number of copies you want
to print.
10. A. Select Edit → Replace from the menu, type “profit” in the Find what box, type
“loss” in the Replace with box and click Replace All.
11. D. Absolute cell references have $ (dollar signs) before the column and/or number
cell indicator.
12. False. The Copy button on the Standard toolbar can copy both values and formulas.
13. A and D. Either of these procedures will insert a new row.
14. A and B. Either of these procedures will delete a column.
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Chapter Three:
Formatting a
Worksheet
Chapter Objectives:
•

Format fonts with the Formatting toolbar and menus

•

Format values

•

Adjust row height and column width

•

Align a cell’s contents

•

Add borders, colors, and patterns to cells

•

Use the format painter to copy formatting

•

Create a custom number format

•

Create, apply, and modify a Style

•

Use conditional formatting

•

Merge cells

Chapter Task: Format an Expense Report
You probably have several colleagues at work whodazzle everyone at meetings with their
sharp-looking spreadsheets that use colorful fonts and neat-looking borders. This chapter
explains how to format your worksheet to make it more visually attractive and easier to read.
You will learn how to change the appearance, size, and color of fonts and how to align text
inside a cell. You will also learn how to increase the height of a row and the width of a
column. This chapter describes how you can make your worksheets more organized and
professional looking by adding borders and shading.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to select cell
ranges.
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Lesson 3-1: Formatting Fonts with
the Formatting Toolbar
Font list Font size list

Figure 3-1

Bold

Center Merge & Percent Increase
Decimal
Center
Style
Underline

Increase
Indent

Font Color

The Formatting toolbar.
Figure 3-2

Figure 3-1

The steps in formatting
changing font size.

Font list
arrow

Font size Italics Align Align Currency Comma Increase Decrease
right Style
Style
Decimal Indent
left
list arrow

Fill Color
Borders

Click here to
scroll down
the list
1. Select the cell(s) you
want to format.

Figure 3-2

Font List

Font Size List

Italics button
Other Ways to Italics:
• Select Format → Font
from the menu, select
Italic from the Font
Style box, and then
click OK.
• Press <Ctrl> + <I>.
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The size of the fonts in
the selected cell(s) is
changed.

You can emphasize text in a worksheet by making the text darker and heavier (bold), slanted
(italics), or larger in a different typeface (or font). The Formatting toolbar makes it easy to
apply character formatting. The Formatting toolbar includes buttons for applying the most
common character and paragraph formatting options.

1.

Bold button
Other Ways to Bold:
• Select Format → Font
from the menu, select
Bold from the Font.
Style box and click OK.
• Press <Ctrl> + <B>.

2. Click the Size List
arrow ( ) and select
the font size.

2.
3.

4.

Start Microsoft Excel, open the document named Lesson 3 and save it as
Expense Report.
Excel saves the worksheet in a new file with the name “Expense Report.” The first
thing you need to do is make the title “Expense Report” stand out from the rest of the
worksheet.
Click cell A1 to make it active.
Once you have selected a cell or cell range you can format it.
Click the Font list arrow ( ) on the Formatting toolbar, then scroll to
and select Times New Roman from the list of fonts.
The contents of the active cell, the title “Expense Report,” appear in the Times New
Roman font. Arial and Times New Roman are two of the most commonly used fonts in
Windows.
With cell A1 still selected, click the Font Size list arrow ( ) on the
Formatting toolbar and select 16, as shown in Figure 3-2.
The label “Expense Report” appears in a larger font size (16 point type instead of the
previous 12 point type). Wow! That font formatting really makes the title stand out
from the rest of the worksheet doesn’t it? Font sizes are measured in points (pt.), which
are 1/72 of an inch. The larger the number of points, the larger the font.
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5.

6.

7.
8.

9.
10.

11.

12.
13.
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Select the cell range A4:G4 and click the Bold button on the Formatting
toolbar.
The cells in the selected range—the column headings for the worksheet—appear in
bold.
Click the Italics button on the Formatting toolbar.
The text in the selected cells is formatted with italics. Notice that both the Bold and
Italics buttons are pushed down on the Formatting toolbar, indicating the selected cells
are formatted with Bold and Italics formatting.
Another way you can format fonts is by changing their color.
Click cell A1 to make it active.
Click the Font Color arrow ( ) on the formatting toolbar and select the
Dark Red color from the color palette.
The text in the selected cell changes from black to dark red.
So far, you have been formatting all the fonts in a cell at once. What if you want to use
different font formatting in the same cell—is that possible? Yes it is—go to the next
step to find out how.
Click cell G2 to make it active.
Here you only want the words “Submitted By:” in bold and leave the rest of the text,
“Bill Smith,” formatted the way it is.
Position the pointer at the very beginning of the formula bar,
immediately before the word Submitted.
The insertion point—the blinking vertical bar ( )—appears at the beginning of the
formula bar.
Click and hold down the mouse button and drag the across the words
Submitted By:. When you’re finished (the words should be highlighted),
release the left mouse button.
Another way to select text is to hold down the <Shift> key, move the insertion point
with the arrow keys, and release the <Shift> key when you’re finished. Now you can
format the selected text.
Click the Bold button on the Formatting toolbar.
Only the selected text “Submitted By:” is formatted with Bold. The remaining text in
the cell is left unchanged.
Click the Save button on the Standard toolbar to save your work.

Table 3-1: Examples of Common Font Types and Sizes

Font Color
Palette

Selecting Text in
the Formula bar
Other Ways to Select
Text:
• Press and hold the
<Shift> key as you
select the text.

Quick Reference
To Bold Text:
• Click the Bold button
on the Formatting toolbar
or press <Ctrl> + <B>.
To Italicize Text:
• Click the Italics
button on the Formatting
toolbar or press <Ctrl> +
<I>.
To Underline Text:
• Click the Underline
button on the Formatting
toolbar or press <Ctrl> +
<U>.

Common Font Types

Common Font Sizes

Arial

Arial 8 point

To Change Font Size:

Comic Sans MS

Arial 10 point

Courier New

Arial 12 point

• Select the pt. size from
the
Font Size list
on the Formatting toolbar.

Times New Roman

Arial 14 point

To Change Font Type:
• Select the font from the
Font list on
the Formatting toolbar.
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Lesson 3-2: Formatting Values
Figure 3-3
The Numbers tab of the
Format Cells dialog box.

Preview of the
selected number
format

Select a number
category

Figure 3-4
The Expense Report
worksheet values before
being formatted.

Select a number
format

Figure 3-5
The Expense Report
worksheet values after
being formatted.

Figure 3-3

Figure 3-4

Figure 3-5

In this lesson, you will learn how to apply number formats. Applying number formatting
changes how values are displayed—it doesn’t change the actual information in any way. Excel
is often smart enough to apply some number formatting automatically. For example, if you
use a dollar sign to indicate currency, such as $548.67, Excel will automatically apply the
currency number format for you.

Currency Style
button

The Formatting toolbar has five buttons (Currency, Percent, Comma, Increase Decimal, and
Decrease Decimal) you can use to quickly apply common number formats. If none of these
buttons has what you’re looking for, you need to use the Format Cells dialog box by selecting
Format → Cells from the menu and clicking the Number tab. Formatting numbers with the
Format Cells dialog box isn’t as fast as using the toolbar, but it gives you more precision and
more formatting options. We’ll use both methods in this lesson.

1.
Comma Style
button
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2.

Select the cell range D5:D17 and click the Currency Style button on
the Formatting toolbar.
A dollar sign and two decimal places are added to the values in the selected cell range.
Select the cell range G5:G17 and click the Comma Style button on the
Formatting toolbar.
Excel adds a thousands separator (the comma) and two decimal places to the selected
cell range.
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3.

4.

5.

6.
7.
8.
9.

Select the cell range F5:F17 and click the Percent Style button on the
Formatting toolbar.
Excel applies percentage style number formatting to the information in the Tax column.
Notice there isn’t a decimal place—Excel rounds any decimal places to the nearest
whole number. That isn’t suitable here—you want to include a decimal place to
accurately show the exact tax rate.
With the Tax cell range still selected, click the Increase Decimal button
on the Formatting toolbar.
Excel adds one decimal place to the information in the tax rate column.
Next, you want to change the date format in the date column. There isn’t a “Format
Date” button on the Formatting toolbar, so you will have to format the date column
using the Format Cells dialog box.
The Formatting toolbar is great for quickly applying the most common formatting
options to cells, but it doesn’t offer every available formatting option. To see and/or use
every possible character formatting option, you have to use the Format Cells dialog
box. You can open the Format Cells dialog box by either selecting Format→ Cells from
the menu or right-clicking and selecting Format Cells from the shortcut menu.
Select the cell range A5:A17, select Format → Cells from the menu, and
click the Number tab, if necessary.
The Format Cells dialog box appears with the Number tab in front and Date format
category selected, as shown in Figure 3-3. You can also use the Number tab of the
Format Cells dialog box to format cells with any type of number option: percentages,
currencies, dates, and—as you can see in the Category list—many more.
From the Category list, select Date and then select the format 4-Mar
from the Type list box and click OK.
The Format Cells dialog box closes and the selected cell range is formatted with the
date format you selected. Try using another date format.
With the Date cell range still selected, select Format → Cells from the
menu.
The Format Cells dialog box reappears.
Select 4-Mar-98 from the Type list box and click OK.
The dates are now formatted to display the year.
Save your work.

Table 3-2: Number Formatting Buttons on the Formatting Toolbar
Button Name

Example

Formatting

Currency

$1,000.00

Adds a dollar sign, comma, and two decimal places

Percent

100%

Displays the value as a percentage with no decimal places

Comma

1,000

Separates thousands with a comma

Increase Decimal

1000.00

Increases the number of digits after the decimal point by one

Decrease Decimal

1000.0

Decreases the number of digits after the decimal point by
one
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Percent Style
button

Increase Decimal
button

Quick Reference
To Apply Number
Formatting:
• Select the cell or cell
range you want to format
and click the appropriate
number formatting
button(s) on the
Formatting toolbar.
Or…
• Select the cell or cell
range you want to format,
select Format → Cells
from the menu, click the
Number tab, and specify
the number formatting
you want to apply.
Or…
• Select the cell or cell
range you want to format,
right-click the cell or cell
range and select Format
Cells from the shortcut
menu, click the Number
tab, and specify the
number formatting you
want to apply.
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Lesson 3-3: Adjusting Row Height
and Column Width
Figure 3-6
Adjusting the width of a
column.
Figure 3-7
Adjusting the height of a
row.
Figure 3-8
The Row Height dialog
box.

Figure 3-6

Figure 3-9

Click and drag the line that
separates column headers to
change the width of a column

Figure 3-7

Click and drag the line that
separates row headers to
change the height of a row

The Column Width dialog
box.

Figure 3-8

Figure 3-9

When you start working on a worksheet, all the rows and columns are the same size. As you
enter information into the worksheet, you will quickly discover that some of the columns or
rows are not large enough to display the information they contain. This lesson explains how to
change the width of a column and the height of a row.

1.

Column Header
Shortcut menu

Click to select all the
cells in a worksheet

Select All button
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2.

3.

Carefully position the pointer over the line between the B and C in the
column header area, until it changes to a .
Once the pointer is positioned over the column line and appears as a , you can adjust
the column width to make it smaller or wider.
Click and hold the mouse button and drag the line to the right until
Column B is wide enough to see all of the Type labels, as shown in Figure
3-6.
Notice that while you are dragging the column line, a tip box appears displaying the
current width of the column.
Position the pointer over the line between the D and E in the column
header area, until it changes to a , then double-click the left mouse
button.
Excel automatically adjusts the width of the selected column so that it can hold the
widest cell entry. This neat feature is called AutoFit. You can also use AutoFit by
selecting Format → Column (or Row) → AutoFit from the menu.
The procedure for adjusting the height of a row is almost the same as adjusting the
width of a column:
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4.
5.

6.
7.
8.

9.
10.
11.
12.
13.
14.

Carefully position the pointer over the line between the 4 and 5 in the row
header area, until it changes to a .
Once the pointer is positioned over the column line and appears as a , you can adjust
the row height to make it smaller or wider.
Click and hold the mouse button and drag the line down until the height
of Row 4 is doubled, as shown in Figure 3-7.
Notice that while you are dragging the column, a tip box appears displaying the current
height of the row.
In most instances, using the mouse is the fastest and easiest method to adjust the height
of a row or the width of a column. There are times, however, when you may want to
adjust the height of a row or the width of a column by using a dialog box. For example,
you can select and adjust the width of several columns at the same time with a dialog
box.
Click the Select All button (the gray rectangle in the upper-left corner of
the worksheet where the row and column headings meet) to select the
entire worksheet.
Excel selects all the cells in the worksheet.
Select Format → Row → Height from the menu.
The Row Height dialog box appears, as shown in Figure 3-8. Here you can enter an
exact measurement to adjust the row height. The default row height is 12.75.
Type 14 in the Row Height text box and click OK.
The height of all the rows in the worksheet changes to 14. Notice, however that the
new row height is not sufficient to accommodate the worksheet’s title, so you will need
to adjust the height of row A. You can use the AutoFit feature to automatically adjust
the height of row 1.
De-select the entire worksheet by clicking any cell in the worksheet.
The entire worksheet is no longer selected.
Double-click the line between the 1 and 2 in the row header area.
Excel automatically adjusts the height of the first row so the title Expense Report fits in
the row. A faster way to open either the Row Height or the Column Width dialog box is
to use the right mouse button shortcut menu.
Right-click the A column header.
A shortcut menu containing the most commonly used commands used with columns
appears. Had you right-clicked a row heading, a shortcut menu with the most
commonly used Row commands would have appeared.
Select Column Width from the shortcut menu.
The Column Width dialog box appears, as shown in Figure 3-9. Here you can enter an
exact measurement to adjust the column width. The default column width is 8.43.
Type 10 in the Column Width box and click OK.
The width of the selected column, column A, changes to 10.
Save your work.

Splendid! In just one lesson you’ve learned how to adjust the width of columns and height of
rows using several different methods.
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Quick Reference
To Adjust the Width of a
Column:
• Drag the column header’s
right border to the left or
right.
Or…
• Right-click the column
header(s), select Column
Width from the shortcut
menu and enter the
column width.
Or…
• Select the column
header(s), select Format
→ Column → Width
from menu and enter the
column width.
To Adjust the Height of a
Row:
• Drag the row header’s
bottom border up or
down.
Or…
• Right-click the row
header(s), select Row
Height from the shortcut
menu and enter the row
height.
Or…
• Select the row header(s),
select Format → Row →
Height from menu and
enter the row height.
To Automatically Adjust
the Width of a Column or
Row (AutoFit):
• Double-click the right
border of the column or
bottom border of a row.
Or…
• Click the column heading
to select the column and
select Format →
Column → AutoFit from
the menu.
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Lesson 3-4: Changing Cell
Alignment
Figure 3-10

Merged cell

Examples of how different
cell alignment options.
Figure 3-11
The worksheet with new
alignment formatting.
Figure 3-12
The Alignment tab of the
Format Cells dialog box.

Figure 3-10

Merged cell

Figure 3-11

Select how text is
aligned horizontally in
a cell
Wrap text into multiple
lines in a cell

Select how text is
aligned vertically in a
cell

Reduce the displayed
font size of a cell so
that all data fits in it

Specify how much
text should be
indented in a cell

Combines two or more
selected cells into a
single cell

Figure 3-12

By default, the contents of a cell appear at the bottom of the cell, with values (numbers)
aligned to the right and labels (text) aligned to the left. This lesson explains how to control
how data is aligned in a cell using the Formatting toolbar and the Format Cells dialog box.

Center button

1.
2.
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Select the cell range A4:G4 and click the Center button on the
Formatting toolbar.
Excel centers the selected headings inside the cells. Notice the Center button on the
Formatting toolbar is depressed, indicating the cells are center aligned.
Select the cell range A5:A17 and click the Center button on the
Formatting toolbar.
The dates in the A column are centered.
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3.
4.

5.
6.
7.

8.
9.
10.
11.

Select cell G2, then click the Align Right button on the Formatting
toolbar.
Excel aligns the label to the right side of the cell. Notice the text spills over into the
cells to the left of the cell, since they are currently unoccupied.
Select the cell range A1:G1 and click the Merge and Center button on
the Formatting toolbar.
Excel merges, or combines, the seven selected cells into a single larger cell that spans
across seven columns, and centers the text inside the single merged cell. A merged cell
is a single cell created by combining two or more selected cells. The cell reference for
a merged cell is the upper-left cell in the original selected range.
Select the cell range E19:G21.
You want to combine all the cells in the selected range into a single merged cell.
Select Format → Cells from the menu and click the Alignment tab.
The Format Cells dialog box appears with the Alignment tab in front, as shown in
Figure 3-12. Here you can specify more advanced cell alignment options.
Select the Merge cells checkbox and click OK.
The Format Cells dialog box closes and the selected cell range is merged into a single
cell. Hey! The new merged cell is large enough to hold all of the notes text, so why is
only a single line of text displayed? To display multiple lines of text in a cell you must
select the Wrap text option on the Alignment tab of the Format Cells dialog box.
With the merged cell still selected, select Format → Cells from the
menu.
The Format Cells dialog box reappears with the Alignment tab in front.
Select the Wrap text checkbox and click OK.
The notes wrap on multiple lines so that all the text fits inside the merged cell.
Sometimes you might want to indent the contents of several cells to make a worksheet
appear more organized and easier to read.
Select the cell range B5:B17 and click the Increase Indent button on
the Formatting toolbar.
The labels in the selected cells are indented one space to the right.
With the same cell range selected, click the Decrease Indent button on
the Formatting toolbar, then save your work.

Table 3-3: Alignment Formatting Buttons on the Formatting Toolbar
Button Name
Align Left

Example

Formatting

Left

Aligns the cell contents to the left side of the cell

Center

Center

Centers the cell contents in the cell

Merge and Center

Center

Merges the selected cells and centers the cell contents

Right

Align Right
Increase Indent
Decrease Indent

Indent
Indent

Aligns the cell contents to the right side of the cell
Indents the cell contents by one character
Decreases indented cell contents by one character
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Align Right button

Merge and Center
button
Increase Indent
button

Decrease Indent
button

Quick Reference
To Change Cell
Alignment:
1. Select the cell or cell
range you want to align.
2. Click the appropriate
alignment button(s) on the
Formatting toolbar.
Or…
1. Select the cell or cell
range you want to align.
2. Either right-click the
selection and select
Format Cells from the
shortcut menu or select
Format → Cells from the
menu.
2. Click the Alignment tab
and select the desired
alignment option.
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Lesson 3-5: Adding Borders
Figure 3-13
The View tab of the
Options dialog box.
Figure 3-14
The Expense Report
worksheet with borders
added.
Figure 3-15
The Border tab of the
Format Cells dialog box.

Figure 3-14
Figure 3-13

Display/Hide gridlines

Preset border formats
Adds a border around
only the outside edge,
inside the grid, or
removes any borders
from the selected cell
range.

Select a line size and
style for a border

Click one or more buttons
to add or remove borders
for the selected cells

Select a line color for
a border

Figure 3-15

Borders make worksheets more visually attractive. Adding borders to ranges of similar cells
also makes them more organized and easier to read. Just like any other formatting attributes,
you can add a variety of borders to the cells in your worksheet using the Formatting toolbar
(specifically, the Border button) or the Format cells dialog box. Just like the previous
formatting lessons, we’ll cover both methods of adding borders in this lesson.
Although it isn’t absolutely necessary, removing the gridlines in the worksheet makes it easier
to see any borders.

1.

Border button

 2000 CustomGuide, Inc.

2.

Select Tools → Options from the menu and click the View tab.
The Options dialog box appears with the View tab selected, as shown in Figure 3-13.
Here you can change how the worksheet is displayed. You’re only interested in one
view option here: you want to remove the cell gridlines in this worksheet so you can
more easily see the borders you will be adding in this lesson.
Click the Gridlines checkbox to remove the checkmark and click OK.
The dialog box closes and the cell gridlines no longer appear on the worksheet. Don’t
worry—the worksheet works exactly the same with or without the gridlines. Gridlines
are only a visual aid to help to you determine which column and row a cell is in.
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3.

4.

5.

6.

7.
8.
9.

10.
11.

12.

13.

Select the cell range A4:G4, click the Border button arrow ( ) on the
Formatting toolbar, and select the single bottom border (located in the
second column of the first row).
A single, thin border appears at the bottom of the selected cells. You can choose from
several different border styles. Try using a different border style in the next step.
Select the cell G17, click the Border button arrow on the Formatting
toolbar and select the double bottom border (located in the first
column, second row).
Excel adds a double-lined border to the bottom of the selected cell. The Border button
is usually the fastest and easiest way to add borders to your worksheets, but you can
also add borders using the Borders tab of the Format Cells dialog box.
Select the cell range A5:G17, select Format → Cells from the menu and
click the Border tab.
The Format Cells dialog box appears with the Border tab selected, as shown in Figure
3-15. The Border tab of the Format Cells dialog box gives you more options for adding
borders than the Borders button on the Formatting toolbar does.
Select the thickest line style in the Style list (the second to the last
option in the second column). Click the Color list arrow and select a
dark blue color, then click the Outline button to apply the specified
border style to the outside of the selected cell range.
This will add a thick, dark blue border around the outside of the selected cell range.
Click OK.
The Format Cells dialog box closes and the borders you specified are added to the
selected cell range. Let’s add a different border style inside the cell range.
With the cell range A5:G17 still selected, select Format → Cells from
the menu.
The Format Cells dialog box appears.
Select the thinnest solid line style (the last option in the first column).
Click the Color list arrow and select Automatic, then click the Inside
button to apply the specified border style to the inside of the selected
cell range.
Notice that a preview of how your borders will look appears in the Border section of
the dialog box.
Click OK.
The Format Cells dialog box closes and the borders you specified are added to the
selected cell range, as shown in Figure 3-15.
Select the cell range E19:G19 (the merged notes cell), click the Border
button arrow, and select the thick outline border option (located in
the last column and last row) and click OK.
Excel adds a thick border around the outside of the selected cells. You decide you want
to remove the border. It is just as easy to remove a border as it is to add it.
With the cell range E19:G19 selected, click the Border button arrow
and select the No Border option (located in the first column and first
row).
The border is removed from the selected cell range. Before we finish this lesson we
must once again display the worksheet gridlines.
Select Tools → Options from the menu, click the View tab, check the
Gridlines checkbox and click OK.
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Selecting a Thick
Border Line

Selecting an
Outline Border

Quick Reference
To Add a Border:
1. Select the cell or cell
range you want to add the
border(s) to.
2. Click the
Border
Style list arrow on the
Formatting toolbar and
select the border you
want.
Or…
Either right-click the
selection and select
Format Cells from the
shortcut menu or select
Format → Cells from the
menu. Click the Border
tab and select the
border(s) you want to
add.
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Lesson 3-6: Applying Colors and
Patterns
Figure 3-16
The Patterns tab of the
Format Cells dialog box.
Figure 3-17
The Expense Report with
Pattern formatting.

Figure 3-17
Figure 3-16

In the last lesson, you learned how to add borders to the cells in your worksheet. In this
lesson, you will see how you can change the background colors and patterns of cells.
Applying colors and patterns to cells is actually a very, very easy procedure, so let’s get
started!

1.
Selecting a Fill
Color

2.
3.
4.
5.
Pattern List
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Click cell E19 (the merged cell that contains the notes) to make it active,
click the Fill Color button arrow on the Formatting toolbar and select
the Yellow color from the color palette.
The background of the selected cell changes to the yellow. Like all other formatting
options in Excel, you can also change the background color of cells with the Format
Cells dialog box.
Select the cell range A5:G17, select Format → Cells from the menu and
click the Patterns tab.
The Format Cells dialog appears with the Patterns tab selected, as shown in Figure
3-16. Here you can add both colors and patterns to the background of cells.
Select the purple and click OK.
The dialog box closes and the selected purple color is added to the selected cell range.
The procedure for adding a pattern to the background of a cell range is the same as
adding colors.
Click cell A1 to make it active and select Format → Cells from the menu.
The Format Cells dialog appears with the Patterns tab selected.
Click the Pattern List Arrow, select the thin horizontal stripe option
and click OK.
The Format Cells dialog box closes and the selected pattern, the thin horizontal stripe,
is applied to the background of the cell.
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6.
7.
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NOTE: If you intend on printing a worksheet, be careful which colors and patterns
you use, especially if you don’t have a color printer. Some colors may look
great on the computer screen, but not when printed. Some background colors
and patterns can even cause the cell information to be illegible when printed.
You are usually better off if you use lighter background colors and patterns,
such as yellow, light gray, or light blue.
All these colors and patterns look pretty gaudy, huh? Go ahead and
remove the colors and patterns you just applied using the Undo function.
Save your work.

Selecting a
Pattern

Quick Reference
To Apply Background
Colors and Patterns:
1. Select the cell or cell
range you want to format.
2. Click the
Fill Color
list arrow on the
Formatting toolbar and
select the color you want.
Or…
Either right-click the
selection and select
Format Cells from the
shortcut menu, or select
Format → Cells from the
menu. Click the Patterns
tab and select the color or
pattern you want to use.
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Lesson 3-7: Using the Format
Painter
Figure 3-18
Use the Format Painter to
copy formatting to other
cells.

Select the cell range with
the formatting you want to
copy and click or doubleclick the Format Painter
button.

Drag the Format Painter
pointer across the cell
range where you want to
apply the copied
formatting.

The copied formatting is
applied to the destination
cells.

Figure 3-18

If you find yourself applying exactly the same formatting to cells repeatedly, the Format
Painter is the tool for you. The Format Painter allows you to copy the formatting attributes
from a cell or cell range and apply them elsewhere. Sound confusing? It won’t once you have
finished this lesson.

1.
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Select the cell range D5:D17 and select Format → Cells from the menu.
The Format Cell dialog box appears. You want to change several of the formatting
options for the selected cell range. Start by changing the number format.
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2.

3.
4.

5.
6.

7.

8.

Select the Number tab, select Currency under the Category list, and
select the fourth option in the Negative numbers list (the ($1234.10)
option).
The next formatting option you need to change for the selected cell range is the font
formatting.
Select the Font tab, select Courier New from the Font list, and then
select a dark red color from the color list.
The last two formatting options you want to modify are the borders and shading
options.
Select the Border tab and click the None button, then select the
Patterns tab, select the yellow color and click OK.
The Format Cells dialog box closes and the selected cell range is formatted with all the
various formatting options you specified. It took a lot of work to do all of that
formatting, didn’t it? Now imagine you want to format the cell range G5:G17 (the
Totals column) with exactly the same formatting options. Instead of doing all those
steps again, you can use the Format Painter tool to copy the formatting from the Price
Per Unit cells and then paste, or apply, the copied formatting to the Totals column.
First, you need to select the cell or cell range that contains the formatting you want to
copy.
With the cell range (D5:D17) still selected, click the Format Painter
button on the Standard toolbar.
Notice the pointer changes to a . Next, you need to paste, or apply the copied
formatting.
Select the cell range G5:G17 with the Format Painter ( ).
Like other mouse-intense operations, this can be a little tricky for some people the first
time they try it. Once you have selected the cell range, the cell formatting from the
Price Per Unit cell range is applied to the Total cell range, saving you a lot of time and
work if you had you manually formatted the cells. Notice cell G8 displays a series of
####’s. That’s because the G column is no longer wide enough to display the contents
of cell G8. To fix this problem you merely have to adjust the column width.
Adjust the width of the G column so that you can see the contents of cell
G9.
Remember how to adjust the width of a column? Move the pointer to the column
header area and drag the column’s right edge with the mouse to adjust its width. The G
column will correctly display the contents of all its cells when it’s wide enough.
Save your work.
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Format Painter
button

Quick Reference
To Copy Formatting with
the Format Painter:
1. Select the cell range with
the formatting options you
want to copy.
2. Click the Format
Painter button on the
Standard toolbar.
3. Select the cell range
where you want to apply
the copied formatting.
To Copy Selected
Formatting to Several
Locations:
1. Select the cell range with
the formatting options you
want to copy.
2. Double-click the
Format Painter
button.
3. Select the cell range
where you want to apply
the copied formatting.
4. Click the Format
Painter button when
you’re finished.
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Lesson 3-8: Using AutoFormat
Figure 3-19
The AutoFormat dialog
box.
Figure 3-20
Preview of the selected
format

A worksheet
AutoFormatted with the
Colorful 2 option.

Select which elements you
want AutoFormat to apply

Figure 3-19

Select the present format
you want to use

Figure 3-20

Congratulations! You’re just about finished with the chapter. This lesson explains how Excel
can automatically format your worksheets with the AutoFormat command. AutoFormat is a
built-in collection of formats such as font sizes, patterns, and alignments you can quickly
apply to a cell range or entire worksheet. AutoFormat lets you select from 16 different preset
formats. AutoFormat is a great feature if you want your worksheet to look sharp and
professional but don’t have the time to format it yourself.

1.
2.
3.
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Place the cell pointer anywhere in the table (the cell range A4:G17).
Excel will automatically determine the table’s boundaries. You can also manually
select the cell range.
Select Format → AutoFormat from the menu.
The AutoFormat dialog box appears, as shown in Figure 3-19. The 16 present formats
are listed in the Table format list. You can see what a present format looks like by
selecting it and looking at the sample area of the dialog box.
Click the Options button.
The AutoFormat dialog box expands to show six check boxes. You can control the type
of formatting that is applied by checking or unchecking any of the boxes. If you want
AutoFormat to skip one of the formatting categories, simply uncheck the appropriate
box.
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4.
5.
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Select the Colorful 2 option from the Table format list and click OK.
The dialog box closes and the selected cell range is formatted with the Colorful 2
formatting options, as shown in Figure 3-20.
Save your work.

Quick Reference
To Format a Table Using
AutoFormat:
1. Place the cell pointer
anywhere within a table
you want to format, or
else select the cell range
you want to format.
2. Select Format →
AutoFormat from the
menu.
3. Select one of the 16
AutoFormats from the list
and click OK.
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Lesson 3-9: Creating a Custom
Number Format
Figure 3-21
Entering a custom number
format in the Format Cells
dialog box.

Displays how the custom
number format will appear
Enter the Format codes for
the custom number format
here

Figure 3-22
Cells formatted using
custom number formats
Figure 3-23
Example of how to use
Format codes to create a
custom number format.

Figure 3-21

Figure 3-22

Figure 3-23

You learned how to format values (numbers) in a previous lesson in this chapter. Excel comes
with a huge number of predefined number formats you can use. With so many available
number formats, it is unlikely that you will ever need to create your own custom number, but
if you do, this lesson explains how to do it.

Enter button

1.
2.
3.

4.
5.
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Select cell A19 to make it active, type 6125555555 and press <Enter>.
This cell contains the employee’s telephone number. To make the phone number easier
to read, you can apply special number formatting to the cell.
Select cell A19 again, select Format → Cells from the menu, then click
the Number tab.
The Format Cells dialog box appears with the Numbers tab selected.
Select Special under the Category list and select Phone Number under
the Type list.
This will add area code parenthesis and a prefix separator (hyphen) format to the
number, making it easy to recognize as a telephone number. A preview of how the
number will look with the selected formatting appears in the Sample area of the dialog
box.
Click OK.
The Format Cells dialog box closes and the Phone Number format is applied to the
active cell. Whoops! You’re going to have to widen the A column in order to see the
newly formatted number.
Double-click the right border of the A column heading.
Excel automatically adjusts the width of the A column. There’s the phone number!
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6.
7.
8.

9.

10.
11.
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If you find that none of the formatting options is satisfactory, here’s how to create your
own:
Enter 521876 into cell A20.
The number you just entered is the employee ID. This number should be displayed like
52-1876. Since there isn’t a number format like this, you’ll have to create your own.
Make sure cell A20 is the active cell and select Format → Cells from the
menu and click the Number tab.
The Format Cells dialog box appears.
Select Custom under the Category list.
This is where you can create your own number formats. You create a custom number
format by specifying format codes that describe how you want to display a number,
date, time, or text. Table 3-4: Format Codes for Numbers and Dates gives some
examples of how to use these codes when creating custom number formats.
In the Type box replace the word “General” with ##-#### and click OK.
The dialog box closes and Excel formats cell A20 with the custom number format you
created.
NOTE: The sample area of the number dialog box becomes very important when
you’re creating custom number formats. Watch the sample area carefully to
see how the custom number format you create will be displayed.
To verify that cell A20 is selected, select Format → Cells from the menu
and click the Number tab.
Now create a new custom number format.
Select Custom under the Category list, type ”Employee ID:” ##-####
in the Type field and click OK.
The dialog box closes and the new custom number format is applied to the cell, as
shown in Figure 3-22.

You can create custom number formats by entering format codes that describe how you want
to display a number, date, time, or text. Table 3-4: Format Codes for Numbers and Dates
shows several examples which demonstrate how you can use number codes to create your
own custom number formats.
Table 3-4: Format Codes for Numbers and Dates
To Display

Numbers
Use this Code

To Display

Dates and Times
Use this Code

1234.59 as 1234.6

####.#

1/1/99 as 1-1-99

m-d-yy

12499 as 12,499

#,###

1/1/99 as Jan 1, 99

mmm d, yy

12499 as 12,499.00

#,###.##

1/1/99 as January 1, 1999

mmmm, d, yyyy

1489 as $1,489.00

$#,###.##

1/1/99 as Fri 1/1/99

ddd m/d/yy

.5 as 50%

0%

1/1/99 as Friday, January 1

dddd, mmmm, d

.055 as 5.5%

0.0%

4:30 PM as 4:30 PM

h:mm AM/PM

Hide value

;;

4:30 PM as 16:30

h:mm

Quick Reference
To Create a Custom
Number Format:
1. Select the cell or cell
range you want to format.
2. Select Format → Cells
from the menu and click
the Number tab.
3. Select the Custom
category and type a
number format in the
Type box using the
format codes shown in
Table 3-4: Format Codes
for Numbers and Dates.
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Lesson 3-10: Creating, Applying,
and Modifying a Style
Figure 3-24

Select a style to apply the
style to the selected cells or
redefine a style's formats

The Style dialog box.
Figure 3-25
The Expense Report
worksheet with the Money
Style applied.

Select which
formatting
elements you
want to include
in the style

Modify the selected style

Delete the selected style

Figure 3-24

Figure 3-25

If you find yourself applying the same formatting options repeatedly, you could probably save
a lot of time by using a style. A style is a collection of formats—such as font size, color,
patterns, and alignment—that you can define and save as a group. Once you have defined and
saved a style, you can apply all of the formatting elements at once.
A style can contain any (or all) of the following formatting attributes:
•

Number

•

Font (type, size, and color)

•

Borders

•

Alignment

•

Pattern

•

Protection (locked and hidden)

In this lesson, you will learn how to create, apply, and modify a style. The easiest way to
create a style is by example. This means you have to format a cell or cell range and then
create a style based on that cell or cell range. Here’s how:

1.
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Select the cell range D5:D17 and select Format → Cells from the menu.
The Format Cells dialog box appears. Specify how you want to format the selected
cell range.
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2.
3.
4.

5.

6.
7.

8.
9.

10.

Click the Number tab, select Currency from the Category list, and select
the first option, -$1,234.00, from the Negative numbers list.
The next formatting option you want to change is the font formatting.
Click the Font tab, select Times New Roman from the Font list, select
Regular from the Font style list, click the Font color list arrow and
select the blue color.
The last formatting option you want to change is the pattern.
Click the Patterns tab, select No Color, and then click OK.
The Format Cells dialog box closes and the formatting options you specified are
applied to the selected cell range.
Instead of applying the same formatting options to other cells by repeating steps 2-4,
you can create a Style based on the cells you just formatted.
Verify the cell range D5:D17 is selected and select Format → Style from
the menu.
The Style dialog box appears, as shown in Figure 3-24. Here you can create, define, or
apply a style. You want to create a new style named Money based on the selected cell
range.
Type Money in the Style name text box and click OK.
You’ve just created a new Style named money. Try applying the Money style to a new
cell range in the worksheet.
Select the cell range G5:G17, select Format → Style from the menu,
select Money from the Style name list and click OK.
The dialog box closes and the selected cell range is formatted with the Money style, as
shown in Figure 3-25. See how quickly and easily you can apply cell formatting to
using styles?
Now that you know how to create and apply styles, we can move on to what’s really
neat about styles: modifying them. You can modify the formatting options for a style
just like you would modify the formatting for a cell or cell range. However, when you
modify a style, every cell formatted with that style is updated to reflect the formatting
changes. Here is how to modify a style:
Select Format → Style from the menu, select Money from the Style list
and click Modify.
The Format Cells dialog box appears.
Click the Font tab, select Arial from the Font list. Click OK to close the
Format cells dialog box, then click OK again to close the Style dialog
box.
The dialog box closes and every cell formatted with the Money style is updated to
reflect the change in fonts.
You can delete the Money style, since you will no longer be using it. Here’s how:
Select Format → Style from the menu, select Money from the Style list
and click Delete.
Excel deletes the Money style.

Look how much time you just saved by modifying the Money style. If you hadn’t used a style,
you would have had to go and change the font formatting manually. Plus, there is always the
chance that you might miss reformatting something.
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Quick Reference
To Create a Style by
Example:
1. Select a cell or cell range
and apply the formatting
you want to use in the
style.
2. Make sure the cell or cell
range you formatted in
Step 1 is selected, then
select Format → Style
from the menu.
3. Enter a name for the style
in the Style name box.
4. (Optional) Remove the
checkmarks for any
formatting attributes that
you don’t want to be part
of the style.
5. Click OK.
To Apply a Style:
1. Select a cell or cell range
you want to format.
2. Select Format → Style
from the menu, select the
style from the Style list
and click OK.
To Modify a Style:
1. Select Format → Style
from the menu, select the
style you want to modify
from the Style list and
click Modify.
2. Modify any of the styles
formatting attributes and
click OK when you’re
finished.
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Lesson 3-11: Formatting Cells
with Conditional Formatting
Operator list
Specify the cell
condition in these boxes

Figure 3-26
The Conditional
Formatting dialog box.

Value text box

Figure 3-27
The Format Cells dialog
box.

Figure 3-26

Figure 3-28

Add another
conditional format

Delete the
conditional format

The Total cells with
conditional formatting
applied (note the numbers
in displayed in blue and in
green.)

Specify how the cell
should be formatted if
that condition is met

If one condition
is met (here, the
cell value is
more than
1000) a
specified type of
formatting is
applied

Figure 3-29
The Delete Conditional
Format dialog box.

Figure 3-27

Figure 3-28

If another
condition is met
(here, the cell
value is less
than 5) another
type of
formatting is
applied

Figure 3-29

You already know how to format most attributes of a cell: color, font and font size, and
borders, to name only a few. In this lesson, you will learn how to use conditional formatting.
Conditional formatting formats cells only if a specified condition is true. For example, you
could use conditional formatting to display weekly sales totals that exceeded $50,000 in
bright red boldface formatting, and sales totals that were under $20,000 in bright blue italics
formatting. If the value of the cell changes and no longer meets the specified condition, the
cell returns to its original formatting.

1.
2.
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Select the cell range G5:G17.
You want to apply conditional formatting to the Totals column to highlight any values
that meet a certain condition.
Select Format → Conditional Formatting from the menu.
The Conditional Formatting dialog box appears, as shown in Figure 3-26. This is where
you can add conditional formatting options to the selected cell range.
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3.
4.
5.
6.

7.
8.

9.

10.

11.
12.

You want to conditionally format the selected cell range, the Totals column, so that any
values over 100 are formatted in a red, bold italics font.
Click the Operator list arrow (the second field) and select greater than
or equal to.
Next, you need to specify what value the cell must be equal or greater to apply the
conditional formatting.
Click the Value text box (the third field) and type 100.
Next, you must specify how you want the cells to be formatted if the condition is met
(if the cell value is equal to or greater than 100.)
Click the Format button.
The Format Cells dialog box appears, as shown in Figure 3-27.
Select Bold Italic from the Style list, click the Color list arrow, select a
Green color and click OK.
You return to the Conditional Formatting dialog box. You have finished entering a
conditional format for the selected cell range. You are not limited to adding a single
conditional format—you can specify up to three.
Here’s how to add another conditional formatting option:
Click the Add button.
The Conditional Formatting dialog box expands to display a second condition.
Click the Condition 2 Operator list arrow, select less than, click the
Value text box, and type 5.
Make sure you’re selecting the Condition 2 options and not the Condition 1 options!
Now specify how you want the cell to be formatted if its value is less than 5.
Click the Format button, select Bold from the Style list, click the Color
list arrow, select Blue (sixth column, second row), and then click OK.
You return to the Conditional Formatting dialog box. Since you’ve finished entering
your conditional formatting options for the selected cell range, you can close the dialog
box.
Click OK.
The dialog box closes and the cells are conditionally formatted according to their
values, as shown in Figure 3-28.
You can easily delete conditional formatting from a cell if you decide you no longer
need it.
With the cell range G5:G17 still selected, select Format → Conditional
Formatting from the menu, then click the Delete button.
The Delete Conditional Format dialog box appears, as shown in Figure 3-29.
Click both the Condition 1 and Condition 2 check boxes, click OK, then
click OK again to close the Conditional Formatting dialog box.
The conditional formatting for the selected cells is removed.
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Quick Reference
To Conditionally Format a
Cell or Cell Range:
1. Select the cell or cell
range you want to format
conditionally.
2. Select Format →
Conditional Formatting
from the menu.
3. Enter the condition (for
example, Cell Value is
greater than 10).
4. Click the Format button
and specify the formatting
you want to use if the
condition is true.
5. If you want to specify
additional conditions for
the selected cells, click
the Add button and
repeat Steps 3 and 4.
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Lesson 3-12: Merging Cells,
Rotating Text, and using AutoFit
Figure 3-30
The Alignment tab of the
Format Cells dialog box.

Text Rotation Tool
Rotate text in the
selected cell

Figure 3-31
The Expense Report
workbook with a merged,
90-degree vertically
aligned cell.

Change the vertical
alignment of text in the
selected cell

Figure 3-30

Figure 3-31

Merged cell with vertical 90-degree
vertical alignment.

We’ve got a lot of ground to cover in this short lesson! This lesson briefly examines a variety
of different formatting options not covered in the previous lessons. In this lesson, you’ll learn
how to merge several cells together into a single, larger cell, how to rotate text within a cell,
and how to automatically adjust the width of a column to fit the column’s widest entry.

1.
2.
The Text
Rotation tool

3.

Select the cell range A4:A17, select Insert → Cells from the menu and
click OK.
Excel inserts a cell range, shifting the other cells in the worksheet to the right.
Select the cell range A5:A12.
You want to merge the cells in the selected cell range.
Select Format → Cells from the menu and click the Alignment tab.
The Format Cells dialog box appears with the alignment tab in front, as shown in
Figure 3-30. The text control section of the Alignment tab has three options:
•
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Wrap text: Wraps text into multiple lines in a cell. The number of wrapped
lines depends on how wide the column is and how much text is in the cell.
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•
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Shrink to fit: Automatically reduces the displayed font size of a cell so that all
data fits within the cell.

•

Merge cells: Combines two or more selected cells into a single cell. The
reference for a merged cell is the upper-left cell.
Try merging the selected cell range into a single cell.

4.
5.
6.
7.

8.
9.

Click the Merge cells checkbox, and then click OK.
The dialog box closes, and the selected cells are merged into a single, larger cell.
With cell A5 still selected (the merged cell) type Boston Trip and click
the Enter button on the Formula bar.
You already know how to change the horizontal alignment of text in a cell. Now you’ll
learn how to change a cell’s vertical alignment.
Select Format → Cells from the menu, drag the text rotation tool in the
Orientation section to a 45-degree angle and click OK.
The dialog box closes and the text in cell A5 is aligned at a 45-degree angle.
With cell A5 still selected (the merged cell), select Format → Cells from
the menu, drag the text rotation tool in the Orientation section to a
90-degree angle, click the Vertical list arrow, and select Center.
This will align the text at a 90-degree angle in the cell and center the text vertically.
Add a colored background to the cell to make it stand out.
Click the Patterns tab, select the light blue color and click OK.
The dialog box closes and cell A5 is formatted with the selected background color and
vertical alignment formatting options. To finish the lesson, reduce the width of column
A using AutoFit.
Position the pointer on the right border of the A column heading until it
changes to a . Then resize the column to match the size of the A
column shown in Figure 3-31.

10. Save your work and exit Microsoft Excel.
Congratulations! You’ve worked your way through a long and rather difficult chapter! The
next time you’re called on to create a worksheet, make sure you use some of the formatting
techniques you’ve learned to impress your colleagues.

Enter button

Quick Reference
To Merge Cells:
1. Select the cells that you
want to merge.
2. Select Format → Cells
from the menu, click the
Alignment tab, select the
Merge cells checkbox
and click OK.
To Rotate Text in a Cell:
1. Select the cell or cell
range you want to modify.
2. Select Format → Cells
from the menu and click
the Alignment tab.
3. Select one of the options
in the Orientation section
or adjust the angle by
dragging the text rotation
tool.
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Chapter Three Review
Lesson Summary
Formatting Fonts with the Formatting Toolbar
•

Change the style of text by clicking the
button on the Formatting toolbar.

•

Change the font type by selecting a font from the

•

Change the font size by selecting the pt. size from the

Bold button,

Italics button, or

Underline

Font list on the Formatting toolbar.
Font Size list.

Formatting Values
•

To Apply Number Formatting using the Formatting Toolbar: Select the cell or cell range you
want to format, and click the appropriate number formatting button(s) on the Formatting toolbar.

•

The Number Formatting Buttons on the Formatting toolbar include:
Comma, Increase Decimal, and Decrease Decimal.

•

To Apply Number Formatting using the Format Cells Dialog Box: Select the cell or cell range
you want to format, right-click the cell or cell range and select Format Cells from the shortcut
menu, click the Number tab, and specify the number formatting you want to apply.

Currency,

Percent,

Adjusting Row Height and Column Width
•

To Adjust the Width of a Column: There are three methods:
1.) Drag the column header’s right border to the left or right.
2.) Right-click the column header, select Column Width from the shortcut menu and enter the
column width.
3.) Select the column header(s), select Format → Column → Width from menu and enter the
column width.

•

To Adjust the Height of a Row: There are three methods:
1.) Drag the row header’s bottom border up or down.
2.) Right-click the row header(s), select Row Height from the shortcut menu and enter the row
height.
3.) Select the row header(s), select Format → Row → Height from menu and enter the row
height.

•

To Automatically Adjust the Width of a Column or Row (AutoFit): Double-click the right border
of the column or click the column heading to select the column and select Format → Column →
AutoFit from the menu.

Changing Cell Alignment
•
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Using the Formatting Toolbar: Select the cell or cell range and click the appropriate alignment
button ( Left, Center, Right, or
Merge and Center) on the Formatting toolbar.
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•

Using the Format Cells Dialog Box: Select the cell or cell range and either right-click the
selection and select Format Cells from the shortcut menu or select Format → Cells from the
menu. Click the Alignment tab and select the desired alignment option.

Adding Borders
•

Using the Formatting Toolbar: Select the cell or cell range you want to add a border(s) to and
Border Style list arrow on the Formatting toolbar and select the border you want.
click the

•

Using the Format Cells Dialog Box: Either right-click the selection and select Format Cells from
the shortcut menu or select Format → Cells from the menu. Click the Border tab and select the
border(s) you want to add.

Applying Colors and Patterns
•

Using the Formatting Toolbar: Select the cell or cell range and click the
arrow on the Formatting toolbar and select the color you want.

•

Using the Format Cells Dialog Box: Either right-click the selection and select Format Cells from
the shortcut menu, or select Format → Cells from the menu. Click the Patterns tab and select the
color or pattern you want to use.

Fill Color list

Using the Format Painter
•

The Format Painter lets you copy the formatting of a cell or cell range formatting attributes and
apply or paste the formatting to other cells.

•

To Use the Format Painter: Select the cells with the formatting options you want to copy, click the
Format Painter button on the Standard toolbar, and select the cell range where you want to
apply the copied formatting.

•

Double-click the Format Painter button to apply formatting to several locations. Click the
Format Painter button again when you’re finished.

Using AutoFormat
•

AutoFormat automatically formats your worksheets using one of sixteen 16 preset formatting
schemes.

•

Select Format → AutoFormat from the menu and select one of the 16 AutoFormats from the list.

Creating a Custom Number Format
•

To Create a Custom Number Format: Select the cell or cell range you want to format, select
Format → Cells from the menu and click the Number tab, and select the Custom category. Type
a number format in the Type box using the appropriate format codes.

Creating, Applying, and Modifying a Style
•

A style is a collection of formats (Number, Font, Borders, Alignment, Pattern, and Protection) you
can define and save as a group so you can apply all of the formatting elements at once.

•

To Create a Style by Example: Select a cell or cell range and apply the formatting you want to
use in the style. Once the cell or cell range is formatted, select it and select Format → Style from
the menu. Enter a name for the style in the Style name box.

•

To Apply a Style: Select a cell or cell range you want to format, Select Format → Style from the
menu, select the style from the Style list and click OK.
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•

To Modify a Style: Select Format → Style from the menu, select the style you want to modify
from the Style list and click Modify. Modify any of the styles formatting attributes and click OK
when you’re finished. Every cell formatted using that style will be updated.

Formatting Cells with Conditional Formatting
•

Conditional formatting is a format, such as cell shading or font color, that Excel automatically
applies to cells if a specified condition is true.

•

To Conditionally Format a Cell or Cell Range: Select the cell or cell range you want to format
conditionally and select Format → Conditional Formatting from the menu. Enter the condition
(for example Cell Value is greater than 10), click the Format button and specify the formatting you
want to use if the condition is true. If you want to specify additional conditions for the selected cells,
click the Add button, otherwise click OK.

Merging Cells, Rotating Text, and using AutoFit
•

To Merge Cells: Select the cells that you want to merge, select Format → Cells from the menu,
click the Alignment tab, select the Merge cells checkbox and click OK.

•

To Rotate Text in a Cell: Select the cell or cell range, select Format → Cells from the menu and
click the Alignment tab. Select one of the options in the Orientation section or adjust the angle by
dragging the text rotation tool.

Quiz
1. Which of the following procedures changes the font size? (Select all that
apply).
A. Select the text and choose a point size from the Font list on the Formatting toolbar.
B. Select the cell(s) and right-click the selection, select Format Cells from the shortcut
menu, click the Font tab, select the font size, and click OK.
C. Select the cell(s), select Format → Cells from the menu, click the Font tab, select the
font size, and click OK.
D. All of the above.
2. Which is NOT a method for applying boldface to a selected cell range?
A. Select Format → Cells from the menu, click the Font tab, and select Bold from the
Font style list.
B. Press <Ctrl> + <B>.
C. Right-click the text and select Boldface from the shortcut menu.
D. Click the Bold button on the Formatting toolbar.
3. To copy formatting from one cell in a worksheet and apply it to another cell
you would use:
A. The Edit → Copy Format and Edit → Paste Format commands from the menu.
B. The Format Painter button on the Standard toolbar.
C. There is no way to copy and apply formatting in Excel; you would have to do it
manually.
D. The Copy and Apply Formatting dialog box, located under the Format → Copy and
Apply menu.
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4. The numbers in your worksheet look like this: 1000. You want them to look
like this: $1,000.00. How can you accomplish this?
A. Click the Currency Style button on the Formatting toolbar.
B. Select Format → Money from the menu.
C. You have to re-type everything and manually add the dollar signs, commas, and
decimals.
D. None of the above.
5. A date is considered a value, and therefore you can change how it is
displayed. For example, 5/12/99 could be reformatted to May 12, 1999. (True
or False?)
6. Which of the following is NOT a method for adjusting the width of a
column?
A.
B.
C.
D.

Drag the column header’s right border to the left or right.
Double-click the column header’s right border.
Select the column header and click the Column Width button on the Standard toolbar.
Right-click the column header, select Column Width from the shortcut menu, and
enter the column’s width.

7. Which of the following statements is NOT true?
A. Clicking the Center button centers the text or numbers inside the cell.
B. The Merge and Center button merges several cells into a single larger cell and
centers the contents inside the cell.
C. You can change cell alignment by clicking Format → Cells from the menu and
clicking the Alignment tab.
D. Cells can only display one line of text—they can’t wrap text inside the cell.
8. What is the procedure(s) for adding a border above and below a selected
cell range? (Select all that apply.)
A. Select Format → Cells from the menu, click the Borders tab, click the top and
bottom lines in the border preview diagram, and click OK.
B. Type several underscore (_) characters cells above and below the cell range.
C. Click the Border button arrow on the Formatting toolbar, and select the appropriate
border formatting from the list.
D. Click the Underline button on the Formatting toolbar.
9. AutoFormat automatically formats your worksheet using one of sixteen
present formatting styles. (True or False?)
10. How can you make a certain cell yellow?
A.
B.
C.
D.

Click the Highlight button on the Standard toolbar.
Click the Fill button arrow on the Formatting toolbar and click the yellow color.
Select Format → Color → Yellow from the menu.
Click the Borders button arrow on the Formatting toolbar and click the yellow color.
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11. You have four cells that you want to combine into one. How can you do
this?
A.
B.
C.
D.

Select the cells and click the Merge Cells button on the Formatting toolbar.
Select the cells and select Tools → Merge Wizard from the menu.
Select the cells and click the Merge and Center button on the Formatting toolbar.
Select the cells and select Edit → Merge Cells from the menu.

12. You want to use the Format Painter to apply formatting to several cells in a
worksheet that are not next to each other. How can you do this?
A.
B.
C.
D.

Click the Format Painter button on the Standard toolbar.
Double-click the Format Painter button on the Standard toolbar.
This isn’t possible.
Open the Copy and Apply Formatting dialog box by selecting Format → Copy
Formatting from the menu.

13. How can you rotate text in a cell?
A. Select Format → Cells from the menu and click the Alignment tab.
B. Click the Alignment button arrow from the Formatting toolbar and select the desired
alignment.
C. Select Format → Text Direction from the menu.
D. Right-click the cell and select Text Direction from the shortcut menu.
14. You want to change the dates in a worksheet so that they appear as
October 15, 2001 instead of 10/15/01. How can you do this?
A. Select the cells and click the Long Date button on the Formatting toolbar.
B. You will have retype all the dates, as there is no way to reformat them.
C. Select the cells and select Format → Cells from the menu, click the Number tab,
select Date from the Number list and select the date format you want.
D. You will need to call your system administrator have him or her install the Microsoft
Long Date patch for you.
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Homework
1. Open the Homework 3 workbook and save it as “Formatting Practice”.

2. Resize the A column so that you can completely see all the tour packages.
3. Change the font of the worksheet title to Times New Roman.
4. Make the worksheet title bold, change its color to dark blue, and its size to 14 pt.
5. Change the tour package sales amounts to currency formatting.
6. Center the column headings (Qtr 1 to Total) and apply bold formatting to them.
7. Add a bottom border to cell range B7:F7.
8. Merge the cell range A1:F1 into a single cell that spans the worksheet.

Quiz Answers
1. D. All of these procedures change the font size.
2. C. There is not a Boldface option in the shortcut menu.
3. B. The Format Painter copies formatting from one area of a worksheet and applies it
to another area.
4. A. The currency button on the Formatting toolbar applies the currency number
formatting.
5. True. Date value can be displayed in a number of ways, but they’re still the same
date.
6. C. There isn’t a Column Width button on the Standard toolbar.
7. D. Cell can display multiple lines of text. Select Format → Cells, click the
Alignment tab, and check the Wrap Text check box.
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8. A and C. You can add a border to a select cell range by selecting a border from the
Border button on the Formatting toolbar or by selecting Format → Cells from the
menu and clicking the Borders tab.
9. True. AutoFormat automatically applies one of sixteen formatting styles to your
worksheet.
10. B. You can make a cell yellow by clicking the Fill button arrow on the Formatting
toolbar and selecting a yellow color.
11. C. You can merge several selected cells into a single cell by clicking the Merge and
Center button on the Formatting toolbar.
12. B. Double-click the Format Painter button on the Standard toolbar to apply
formatting to several non-adjacent cells in a worksheet. Click the Format Painter
button when you’re finished applying the formatting.
13. A. You can rotate text in a cell by selecting Format → Cells from the menu and
clicking the Alignment tab.
14. C. You can format date values by selecting Format → Cells from the menu, clicking
the Number tab, select Date from the Number list and selecting the date format.
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Chapter Four:
Creating and Working
with Charts
Chapter Objectives:
•

Create a chart

•

Move and resize a chart

•

Format objects in a chart

•

Change a chart’s source data

•

Change a chart type

•

Add titles, gridlines, annotations, and a data table to a chart

•

Work with a 3-D chart

•

Create and work with a custom chart

•

Plot data on a map

Chapter Task: Create a chart that plots survey data
You already know what a chart is. Charts illustrate data, relationships, or trends graphically.
Like the saying “a picture is worth a thousand words,” charts are often better at presenting
information than hard-to-read numbers in a table or spreadsheet.
In this chapter, you will learn just about everything there is to know about charts: how to
create dynamic-looking charts, edit and format charts, and work with different types of charts.
Creating and working with charts in Excel is easier than you might think and actually is quite
fun. The dazzling charts you will be able to create after you finish this chapter will amaze
both you and your colleagues.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to select cell
ranges.

130

Microsoft Excel 2000

Lesson 4-1: Creating a Chart
Figure 4-1
Step One of the Chart
Wizard – selecting a type
of chart.
Figure 4-2
Step Three of the Chart
Wizard – specifying chart
options.
Figure 4-3

Figure 4-2

The new chart.
Figure 4-1

Figure 4-3

Chart Wizard
button
Other Ways to Insert a
Chart:
• Select Insert → Chart
from the menu.
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You can plot most of the information in a worksheet on a chart—and that’s what this lesson is
about! This lesson will give you practice creating a chart based on data that’s already been
entered in a worksheet. The most common (and by far the easiest method) of creating a chart
is to use the ChartWizard. Get that image of mysterious old bearded men wearing purple
robes, and pointy hats with stars and moons on them out of your mind—the ChartWizard is a
feature that walks you through the process of creating a chart.

1.

Start Excel, open the workbook named Lesson 4A and save it as Survey
Results.
The first step in creating a chart is to select the cells that contain both the values and
labels you want to chart.
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2.

3.

4.
5.
6.

Select the cell range A4:E7 then click the Chart Wizard button on the
Standard toolbar.
The Chart Wizard opens, as shown in Figure 4-1. The first step in creating a chart is
selecting the type of chart you want to create from the Chart type list. You can preview
how your data will appear in each type of chart by selecting the chart type and then
clicking the Press and hold to view sample button. You want to create a Column chart,
and since the Column chart type is already selected you can move on to the next step.
Click Next to accept the Column chart type and move to the second step
in the Chart Wizard.
The second step in the Chart Wizard lets you select the cell range you want to chart.
You also have to specify if the data series (the information you’re plotting in your
chart) is from the rows or columns of the worksheet. You want to use the rows option
so your chart will be plotted by destination. Since this is the current selection you don’t
need to change anything. The cell range A4:E7 appears in the Data range text box
because you have already selected the cell range before starting the Chart Wizard.
Since the chart options here are correct, you can move on to the next step.
Click Next to move to the third step in the Chart Wizard.
The third step in the Chart Wizard presents you with a sample of your chart, as shown
in Figure 4-2. Here you can add data labels, gridlines; a legend and data table; and
titles to the chart and axis.
Click the Chart title box and type Travel Purpose Survey Results.
The Chart title appears in the Sample Chart.
Click Next to move to the fourth step in the Chart Wizard.
The forth and final step in the Chart Wizard is to determine the chart’s location. There
are two options:
•

7.

8.

As new sheet: The chart will be placed on a separate, new sheet in the
workbook. You can enter a name for this new sheet, or accept Excel’s default
sheet name.

• As object in: The chart will be placed on the same sheet as the data.
You want to place your chart on the current worksheet, which is already selected, so
you can finish the Chart Wizard.
Click Finish to complete the Chart Wizard.
The Chart Wizard dialog box closes, and the column chart appears in the active
worksheet, as shown in Figure 4-3. Your chart may be covering a large portion of the
worksheet data—don’t worry about it. You’ll learn how to move and resize a chart in
the next lesson.
Save your work.

Congratulations! You’ve just created your first chart. Turn the page to learn how you can
resize the chart.
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Chart Placed as a
New Sheet

Chart Placed as
an Embedded
Object

Quick Reference
To Create a Chart with the
ChartWizard:
1. Select the cell range that
contains the data you
want to chart and click
the Chart Wizard
button on the Standard
toolbar.
Or…
Select the cell range and
select Insert → Chart
from the menu.
2. (Step 1 of 4) Select the
chart type and click Next.
3. (Step 2 of 4) Verify (or
change) the cell range
used in the chart and click
Next.
4. (Step 3 of 4) Adjust the
chart options by clicking
the categorized tabs and
selecting any options then
click Next.
5. (Step 4 of 4) Specify
where you want to place
the chart (as an
embedded object or on a
new sheet) and click
Finish.
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Lesson 4-2: Moving and Resizing a
Chart
Figure 4-4
Moving a chart.
To move a chart to a new
location, click and drag
the chart anywhere in the
white area before the
border of the chart

Figure 4-5
Resizing a chart.
Figure 4-6
The Chart toolbar.
Figure 4-4

Drag a selected
object’s sizing
handles to resize
the object

Figure 4-5
Select Chart
Objects List

Figure 4-6

Select a Type
of Chart

Add/Remove
Data Table

Chart by
Columns

Add/Remove Chart by
Format the
Selected Object Chart Legend Rows

Angle Text
Upward

Angle Text
Downward

More often than not, initially charts are not the size you want them to be. In this lesson, you
will learn how to resize a chart to make it larger or smaller. You will also learn how to move a
chart to a new location in the worksheet.

Sizing Handles
Click a chart to select
it.
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1.

Make sure the chart is selected.
If the chart isn’t selected, all you have to do is click it to select it. Six boxes, called
sizing handles, appear along the edges of a chart any time it is selected. Sizing handles
are used to change the size of charts and other objects.
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2.

3.

4.
5.
6.
7.
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Click and hold the blank area just before the border of the chart. Drag the
chart down and to the left about an inch and release the mouse button.
The pointer changes to a , and a dotted outline of the chart appears as you are
moving the chart to a new location.
You can resize a chart by clicking and dragging any of its sizing handles, located along
the border of any selected chart.
Position the pointer over the lower-right sizing handle, until the pointer
changes to a , then drag the mouse diagonally down and to the right,
until the chart is about 25% larger.
The chart is resized. You can also make a chart or object smaller by dragging the sizing
handles up and to the left. You can also move and resize objects in a chart using the
same procedures.
Click the chart legend to select it.
Selection handles appear around the legend. Once you have selected an object you can
move or resize it.
Drag the legend to the lower-right corner of the chart, so that it is at the
same level as the destination titles.
The chart legend is moved to the new location.
Click anywhere outside the chart to deselect the legend and the chart.

Chart legend

Save your work.

The skills you’ve just learned, moving and resizing objects, are especially important because
you can use them to move and resize just about any type of object. You can even use these
skills to move and resize objects in other programs, such as Microsoft Word or PowerPoint.

Quick Reference
To Resize a Chart:
• Click the chart to select it,
then drag its sizing
handles until the chart is
the size you want.
To Move a Chart:
• Click and hold down the
mouse button on the
blank area around the
chart, drag the picture to
a new location in the
workbook, then release
the mouse button.
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Lesson 4-3: Formatting and
Editing Objects in a Chart
Figure 4-7
The Patterns tab of the
Format Data Series dialog
box.
Figure 4-8
The Placement tab of the
Format Legend dialog
box.
Figure 4-9
The Font tab of the
Format Chart Title dialog
box.

Figure 4-7

Figure 4-8

Figure 4-10
The reformatted chart.

Figure 4-10
Figure 4-9

Here’s an important fact you need to know: you can select, format, and edit every object in a
chart. For example, you can change the style, size, and color of any of the fonts used in a
chart, or the background color of the chart. After you’ve completed this lesson you’ll be a pro
at formatting anything and everything in a chart. Some items that can be formatted and edited
in a chart include:
• Chart Title
• Chart Background Area

The Chart Object
list
Other Ways to Select an
Object:
• Click the object.
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•

Any Data Series

•

Chart Plot Area

•

Chart’s Gridlines

•

Data tables

•

Chart Legend

•

Category Axis

There are two methods you can use to select a chart object. The first method is to simply click
an object to select it. Sometimes when selecting a chart object it can be tricky to know exactly
where or what to click (for example, what would you click to select the chart’s plot area?). In
these cases it is easier to use the second method: select the object from the Chart Object list
on the Chart toolbar.
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1.
2.

3.

4.
5.
6.
7.
8.
9.

Click the chart to select it.
The first object you want to format on the chart is the Pleasure Data series. Of course,
you must first select the Pleasure Data series before you can format it. You can select
the Pleasure Data series from the Chart Object list on the Chart toolbar.
Click the Chart Objects list arrow on the Chart toolbar and select
Series "Pleasure" from the list.
NOTE: If the Chart toolbar doesn’t appear on your screen, you can display it by
selecting View → Toolbars → Chart from the menu.
Selection boxes appear on the three columns of the Pleasure data series in the chart.
Now that you’ve selected the Pleasure series, you can format it.
Click the Format Object button on the Chart toolbar and click the
Patterns tab if necessary.
The Format Data Series dialog box appears, as shown in Figure 4-7. You are presented
with a variety of different formatting options that you can apply to the selected data
series. We’ll take a closer look at how to format a data series in an upcoming lesson.
For now, just change the color of the data series.
Click a green color from the color palette in the Area section and click
OK.
The dialog box closes and the color of the Pleasure data series changes to green. Next,
try formatting the chart’s legend so you can place it in a better location on the chart.
Double-click the chart’s legend to format it and select the Placement
tab.
The Format Legend dialog box appears, as shown in Figure 4-8.
Select the Bottom option and click OK.
The dialog box closes and the legend appears at the bottom of the chart.
The last thing to format in this lesson is the chart’s title.
Double-click the Chart’s title (Travel Purpose Survey Results) to format
it, and click the Font tab.
The Format Chart Title dialog box appears, as shown in Figure 4-9. Change the font of
the chart’s title as follows:
Select Bold Italic from the Font Style list, click the Color list arrow and
select a Blue color, then click OK.
The dialog box closes and the chart title is formatted with the font options you selected.
Compare your chart to the one in Figure 4-10 and save your work.

There are so many different types of chart objects, each with their own individual formatting
options, that it would take days to go through all of them. Instead, this lesson has given you a
general guideline to follow to select and format any type of chart object you encounter.
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Format Object
button
Other Ways to Format
an Object:
• Double-click the object.
• Right-click the object
and select Format
Object from the
shortcut menu.
• Click the object to
select it and select
Format → Selected
Object from the menu.

Quick Reference
To Select a Chart Object:
• Click the

Chart
Objects list arrow on the
Chart toolbar and select
the object.
Or…
• Click the object.
To Format a Chart Object:
1. Double-click the object.
Or…
Select the object and click
the
Format Object
button on the Chart
toolbar.
Or…
Right-click the object and
select Format Object
from the shortcut menu.
Or…
Select the object and
select Format → Format
Object from the menu.
2. Click the tab that contains
the items you want to
format and specify your
formatting options.
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Lesson 4-4: Changing a Chart’s
Source Data
Figure 4-11
The Data Range tab of the
Source Data dialog box.
Click the Data range box, and select the
data on your worksheet that you want to
plot in your chart.

Figure 4-12
The Series tab of the
Source Data dialog box.

Collapse dialog box button:
Temporarily shrinks and moves the
dialog box so that you enter a cell range
by selecting cells in the worksheet.
When you finish, you can click the
button again or press <Enter> to display
the entire dialog box.

Figure 4-13
The updated chart.

Figure 4-11

Figure 4-13

Figure 4-12

Format Object
button
Other Ways to Format
an Object:
• Double-click the object.
• Right-click the object
and select Selected
Object from the
shortcut menu.
• Click the object to
select it and select
Format → Selected
Object from the menu.
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Once you create a chart, you may decide to change which worksheet cells contain the values
and labels you want to plot in the chart. For example, you might add a new column or row to
a worksheet and then want to include it in an existing chart. Or you might want to remove
some cells that you no longer want to be plotted in a chart. This lesson shows you how to
change a chart’s source data, or which worksheet cells that contain the values and labels the
chart is based on.

1.
2.

Click cell B5, type 100 and press <Enter>.
Notice that the chart is updated, reflecting the change in value. You decide to add
another column to display the total purposes for traveling for all the destinations. First,
you need to add a column heading.
Click cell F4, click the Bold button and the Center button on the
Formatting toolbar, type Total and press <Enter>.
Next, total the purposes for traveling for all of the destinations.
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3.

4.
5.
6.

7.

8.
9.

10.

Make sure cell F5 is the active cell, click the AutoSum button on the
Standard toolbar (note that Excel automatically selects the correct cell
range, B5:E5) and click the Enter button on the Formula bar.
Excel totals all the values in the Business row. Use AutoFill to copy the formula you
just created to the remaining cells.
Copy the formula in cell F5 to the cell range F6:F8.
You can copy the formula using AutoFill (the fastest and easiest method) or by copying
and pasting. Next, you want to modify the chart so it displays only the data from the
Total column you just added.
Click the chart to select it.
Selection handles appear at the corners and sides of the chart and the Chart toolbar
appears. Now you need to change the source data for the chart.
Select Chart → Source Data from the menu and click the Data Range
tab.
The Source Data dialog box appears, as shown in Figure 4-11. This is where you can
change the chart’s source data. Notice the Data range box currently contains
=Sheet1!$A$4:$E$7—the cell range for the chart’s current data source. You want the
data source to be the labels from the Purpose column, A4:A7, and the values from the
Total column, F4:F7.
Select the cell range A4:A7.
If the dialog box is in the way, you can temporarily hide it by clicking the data range
box’s Collapse dialog button. Okay, you’ve got the A (Purpose) column selected. So
how can you select the F (Total) column since the two columns are not next to each
other? Move on to the next step to find out.
Press and hold the <Ctrl> key and select the cell range F4:F7.
Pressing and holding the <Ctrl> key lets you select cells that are not next to each other.
The chart plots the new cells you specified as a data source. We have one more thing to
look at while the Source Data dialog box is still open.
Click the Series tab.
The Series tab of the Source Data dialog box appears, as shown in Figure 4-12. You
don’t have to touch anything here; we just want to take a quick look at this screen.
Once you have selected the source data for the chart, you can add, change, and delete
the data series and name series used here, on the Data Range tab.
Click OK.
Compare your chart with the one in Figure 4-13.
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AutoSum button

The Collapse Dialog
button temporarily
shrinks and moves the
dialog box so that you
enter a cell range by
selecting cells in the
worksheet. When you
finish, you can click
the button again or
press <Enter> to
display the entire
dialog box.

Quick Reference
To Change a Chart’s Data
Source:
1. Select the chart, select
Chart → Source Data
from the menu and click
the Data Range tab.
2. Click in the Data Range
box and select the cell
range you want to base
the chart on (click the
Collapse Dialog box
button if necessary).
3. Click OK.
To Use Non-Adjacent Cell
Ranges in a Chart:
• Select the first cell range,
then press and hold the
<Ctrl> key as you select
the remaining nonadjacent ranges.
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Lesson 4-5: Changing a Chart
Type and Working with Pie Charts
Figure 4-14
A pie chart incorrectly
plotted by rows.
Figure 4-15
The same pie chart plotted
by columns.
Figure 4-16
The steps on pulling a
slice from a pie chart.

Figure 4-14

1. Click the chart area to
enter Edit Mode

Figure 4-15

2. Click a slice of the
chart to select it

Figure 4-16

Chart Type List
button

Selecting a Pie
Chart

3.
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4. Release the mouse
button to drop the
slice

Just as some lures are better than others for catching certain types of fish, different types of
charts are better than others for presenting different types of information. So far, you have
been working on a column chart, which is great for comparing values for different items, but
not so great for illustrating trends or relationships. In this lesson, you will learn how and when
to use different types of charts. You will also learn a valuable tip when working with pie
charts: how to pull a slice of the pie away from the chart.

1.
2.

By Column button

3. Hold down the mouse
button and drag the
slice away from the
chart

Click the chart to select it.
Click the Chart Type List arrow from the Chart toolbar and select the
Pie Chart.
The chart changes to a pie chart, as shown in Figure 4-14. What happened? Why is
there only one piece of the pie instead of three? It’s because Excel is still plotting the
data by rows (destinations) instead of by columns (purpose).
NOTE: Sometimes when you change chart types, the formatting options for one chart
type may not be appropriate for another chart type. An improperly formatted
chart appears cluttered and difficult to read. To solve this problem: Select
Chart → Chart Type from the menu. Select the chart type and sub-type you
want to use. Select the Default formatting checkbox and click OK.
Click the By Column button on the Chart toolbar.
Excel changes the data series for the chart from rows to columns and properly displays
the chart. You decide you want to pull the business slice of the pie away from the pie
chart to emphasize it.
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5.
6.
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Click the actual chart plot area to enter edit mode.
The chart plot area is the actual chart, in this case, the circular pie chart. Sizing handles
appear on the business slice.
Click the business slice of the pie to select it (selection handles should
appear on the slice) and then click and drag it away from the chart about
a half-inch.

Because Excel offers so many different types of charts and graphs, you should have a general
idea which type of chart to use in which circumstances. Table 4-5: Types of Charts and
Graphs shows some of the more commonly used charts and graphs and gives explanations on
how and when they are used.

Chart Plot Area

Table 4-5: Types of Charts and Graphs
Chart or Graph Type

Column

Description
Column charts are used when you want to compare different values
vertically side-by-side. Each value is represented in the chart by a vertical
bar. If there are several series, each series is represented by a different
color.
Bar charts are just like column charts, except they display information in
horizontal bars rather than in vertical columns.
Quick Reference

Bar
Line charts are used to illustrate trends. Each value is plotted as a point
on the chart and is connected to other values by a line. Multiple items are
plotted using different lines.
Line
Area charts are the same as line charts, except the area beneath the
lines is filled with color.
Area
Pie charts are useful for showing values as a percentage of a whole. The
values for each item are represented by different colors.
Pie
Scatter charts are used to plot clusters of values using single points.
Multiple items can be plotted by using different colored points or different
point symbols.
Scatter
Combination charts combine two different types of charts together. For
example, a combination chart might contain both a column chart and a
line chart.
Combination

To Change the Chart
Type:
• Select the chart and
select Chart → Chart
Type from the menu.
Or…
• Click the
Chart
Type list arrow on the
Chart toolbar.
To Chart by Rows or
Columns:
• Select the chart and click
either the By
Columns button or the
By Rows button on
the Chart toolbar.
To Drag a Piece from a Pie
Chart:
1. Click the chart to select it.
2. Click the piece of the
chart you want to move to
select it.
3. Click and drag the piece
away from the rest of the
chart.
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Lesson 4-6: Adding Titles,
Gridlines, and a Data Table
Figure 4-17
The Titles tab of the Chart
Options dialog box.
Figure 4-18
The Gridlines tab of the
Chart Options dialog box.
Figure 4-19
The Chart with value
labels and gridlines
added.

Figure 4-17

X-axis title

Figure 4-19

Chart title

Y-axis title

Figure 4-18

There are a lot of ways you can make a chart easier to read and understand. You can add titles
to the chart’s X- (horizontal) axis or Y- (vertical) axis, add gridlines, and a legend. This lesson
explains how to add and modify these items, and how you can enhance your charts to make
them easier to understand.

1.

2.
Data Table
button
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3.

Make sure the chart is selected, then select Chart → Chart Type from
the menu, select the Column chart type from the Chart type list, click
the Default formatting checkbox and click OK.
The chart is changed from a pie chart to a column chart. Selecting the default
formatting checkbox removes any previous formatting you've applied to the chart type
and returns the chart to the default appearance. The selected chart changes from a pie
chart to a column chart. Next, you need to change the data source for the chart.
Select Chart → Source Data from the menu, select the cell range A4:E7
(click the Collapse dialog button if you need to) and press <Enter>.
The column chart is updated to reflect the changes in the data source.
Select Chart → Chart Options from the menu and click the Titles tab.
The Titles tab of the Chart Options dialog box appears as shown in Figure 4-17. The
chart title was removed when you applied the default formatting to the chart, so you
will have to re-enter it.
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4.
5.
6.
7.

8.
9.
10.
11.

Click the Chart Title text box and type Survey Results.
Now add titles to the X- and Y-axis.
Click the Category (X) axis textbox and type Purpose, then click the
Category (Y) axis textbox and type Reservations.
Next, add some data labels to the data series.
Click the Data Labels tab and click the Show value option in the Data
labels section.
The chart preview area displays a sample chart with the added data labels.
Click the Data Table tab, check both the Show data table and Show
legend keys check boxes.
A data table displays the numbers the chart is based on. Since you’re working with an
embedded chart (instead of a chart on a separate sheet) this information is already
displayed in the worksheet, so you don’t really need a data sheet. But, for practice’s
sake, try adding a data sheet.
Click OK.
The Chart Options dialog box closes and the chart is updated to reflect the changes you
made. You can remove the data table since you don’t need it.
Click the Data Table button on the Chart toolbar.
The data table disappears from the chart. Next, see how the chart will look if you add
some gridlines.
Select Chart → Chart Options from the menu, click the Gridlines tab,
make sure the Major Gridlines checkbox for the (Y) Axis and the
Major Gridlines checkbox for the (X) Axis are both checked.
Click OK.
The Chart Options dialog box closes, and the chart reflects the changes you made, as
shown in Figure 4-19.
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Quick Reference
To Add or Remove
Gridlines from a Chart:
1. Select the chart, select
Chart → Chart Options
from the menu, and click
the Gridlines tab.
2. Check or uncheck the
appropriate gridline check
boxes.
To Add or Change Titles
to a Chart:
1. Select the chart, select
Chart → Chart Options
from the menu, and click
the Titles tab.
2. Enter or modify the text in
the text boxes that
correspond to the desired
chart titles.
To Add or Remove a Data
Table:
• Click the Data Table
button on the Chart
toolbar.
Or…
1. Select the chart, select
Chart → Chart Options
from the menu, and click
the Data Table tab.
2. Check or uncheck the
appropriate check boxes
to hide or display a data
table.
3. Select one of the
placement options for the
legend.
To Add or Remove Chart
Data Labels:
1. Select the chart, select
Chart → Chart Options
from the menu, and click
the Data Labels tab.
2. Check or uncheck the
appropriate check boxes
to display or hide data
labels.
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Lesson 4-7: Formatting a Data
Series and Chart Axis
Figure 4-20
The Data Labels tab of the
Format Data Series dialog
box.
Figure 4-21
The Scale tab of the
Format Axis dialog box.

Figure 4-20

Figure 4-21

You’ve already learned how to select and format objects in a chart. This lesson explores how
to format two of the more tricky objects: a chart’s data series and axis.
First, what exactly is a data series? A data series is a group on a chart that comes from the
same row or column on a worksheet. Each data series in a chart has its own unique color or
pattern. Most chart types can plot more than one data series in a chart at a time, such as the
current column chart does, with the Business, Pleasure, and Other data series. One exception
is pie charts, which can only plot a single data series.

Chart Object list
Other Ways to Select a
Chart Object:
• Click the object.

Okay then, what is a chart axis? An axis is the line at the side of a chart that provides a scale
of measurement or comparison in a chart. For most charts, data values are plotted along the
vertical value (Y) axis and categories are plotted along the horizontal category (X) axis.
Now that you (hopefully) understand what a data series and axis are, move to Step 1 to learn
how to format them.

1.

2.
Format Object
button

3.
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Make sure the chart is selected, click the Chart Objects list arrow on
the Chart toolbar and select Series “Eastern U.S.”
Remember, if the Chart toolbar doesn’t appear on your screen you can display it by
selecting View → Toolbars → Chart from the menu.
Selection handles appear around each of the Eastern U.S. columns, indicating the series
is selected. Once you select a chart element you can format and change the element’s
settings.
Click the Format Object button on the Chart toolbar. Then click the
Patterns tab.
The Format Data Series dialog box appears with the Patterns tab in front. Here you can
change the color, texture, border and other options of the selected data series.
Select a dark blue color.
This will format the columns in the Eastern U.S. data series with a dark blue color. You
could also change the border or line color, style, and weight for the data series—or
remove it all together.
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4.

5.
6.
7.
8.

Click the Data Labels tab, select the Show label option and click OK.
This option will display a label above the data series. The Format Data Series dialog
box closes and the changes are made to the Eastern data series.
Here’s how to format a chart’s axis.
Click the Chart Objects list arrow on the Chart toolbar and select the
Value Axis.
Now format the Y-axis.
Click the Format Object button and click the Scale tab.
When you create a chart, Excel automatically creates the scale of the chart. Ninety
percent of the time you won’t need to change a chart’s default scale. For that other ten
percent of time, here’s how you can enter your own values for the chart’s scale:
Click the Major unit textbox, type 25, click the Maximum box and type
90.
This will adjust the scale of the chart, so the maximum value on the scale will be 90
instead of 120, and the increment scale will be 25 instead of 20.
Click OK.
The Format Axis dialog box closes and the changes are made to the Y-axis.

Since we only looked at a couple tabs in the Data Series dialog box, refer to Table 4-6: The
Data Series Dialog Box Tabs to see what those other tabs do.
Table 4-6: The Data Series Dialog Box Tabs
Tab

Description

Patterns

Changes a data series’ colors, borders, and fill effects.

Axis

Allows you to plot the selected data series on a secondary axis—often
used in combination charts.

Y Error Bars

Adds graphic bars that express the potential error (or degree of
uncertainty) for each data marker in a series.

Data Labels

Adds value or data labels to the selected data series.

Series Order

Changes the order of the selected data series in the chart.

Options

Changes the width of all the data series in a chart, and if the data series
should overlap one another.
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Quick Reference
To Add Labels to a Data
Series:
1. Double-click the data
series.
Or…
Right-click the data series
and select Selected
Object from the shortcut
menu.
Or…
Select the data series and
select Format →
Selected Object from the
menu.
2. Click the Data Labels tab
and select the appropriate
option.
To Change the Scale of a
Chart:
1. Double-click the axis.
Or…
Right-click the axis and
select Format Axis from
the shortcut menu.
Or…
Select the axis and select
Format → Selected
Object from the menu.
2. Click the Scale tab and
make the changes to the
scale.
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Lesson 4-8: Annotating a Chart
Figure 4-22

Select Object Tool

Draw
Arrow

Draw Insert
Oval WordArt

Line Color

Line Style
3-D Effects
Arrow Style

The Drawing toolbar.
Figure 4-23
The chart with a text
annotation and an arrow
added.

Drawing

Rotate Insert
AutoShape

Figure 4-22

Draw Draw
Line Rectangle

Fill Object
Color

Font Color

Dash
Style

Shadow

Insert Text Box

Figure 4-23

Drawing button
Other Ways to View the
Drawing Toolbar:
• Select View →
Toolbars → Drawing
from the menu.
• Right-click any toolbar
and select Drawing.

One of the best new features in Excel is its greatly improved drawing capabilities. You can
easily annotate your charts and worksheets by adding lines, arrows, text boxes, and a huge
variety of shapes. To use Excel’s drawing capabilities, you need to use the Drawing toolbar,
which contains many tools for drawing shapes, lines, and arrows, and for formatting graphic
objects with different coloring, shadow, and 3-D effect options.
Although we’ll be using Excel’s drawing features to annotate a chart in this lesson, you can
also draw on worksheets to enhance them with arrows, text, and shapes.

1.
2.

Text Box button

3.
Arrow button
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4.

Click the Drawing button on the Standard toolbar.
The Drawing toolbar appears, as shown in Figure 4-22. The Drawing toolbar gives you
several tools you can use to add text, lines, and graphics to charts and worksheets.
Click the Text Box button on the Drawing toolbar.
The pointer changes to a , indicating you can click and enter a caption or callout in
the chart or worksheet.
Click to the right and slightly below the chart title with the pointer and
type End of Promotion, as shown in Figure 4-23.
Go to the next step to add an arrow to the annotation.
Click the Arrow button on the Drawing toolbar.
This time the pointer changes to a .
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5.

6.
7.
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Move the pointer to the left of the End of Promotion text, click and
hold down the mouse button, drag the line to the Pleasure columns, and
release the mouse button.
Compare your chart with the one in Figure 4-23. You won’t need the drawing toolbar
any more in this chapter, so here’s how to get rid of it.
Click the Drawing button on the Standard toolbar.
The Drawing toolbar disappears.
Save your work.

Quick Reference
To View the Drawing
Toolbar:
• Click the Drawing
button on the Standard
toolbar.
Or…
• Select View → Toolbars
→ Drawing from the
menu.
To Draw an Object:
1. Click the object you want
to draw on the drawing
toolbar (such as a line or
circle).
2. Drag the crosshair pointer
to draw the object.
To Resize an Object:
1. Click the object to select
it.
2. Drag the object’s sizing
handles to resize it.
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Lesson 4-9: Working with 3-D
Charts
Figure 4-24
Selecting a 3-D column
chart in the Chart Type
dialog box.
Figure 4-25
The steps in rotating a
chart.

1. Click and hold any of the
selection handles of the chart.

Figure 4-26
The 3-D View dialog box.

Figure 4-24
Increase Perspective
Increase Elevation
Decrease Perspective
Decrease Elevation
2. Drag the selection handle to
change the perspective of the
chart.

Increase
Rotation

Figure 4-26

Decrease
Rotation
3. Release the mouse button
when you are finished rotating
the chart.

Figure 4-25

Three-dimensional (3-D) charts are some of the coolest-looking types of charts, but they don’t
always display their information correctly. The data in 3-D charts is often obscured by another
data series. This lesson explains how you can rotate and elevate a 3-D chart to make sure
everything is visible. There are two methods you can use to change the rotation and elevation
of a 3-D chart:
•

Using the 3-D View Dialog box: Using the 3-D View dialog box (which you can find
by selecting Chart → 3-D View from the menu) lets you rotate a 3-D chart with a high
degree of precision.

•

Using the Mouse: Using the mouse is a quick method of rotating a 3-D chart, but it
can be tricky and requires a lot of mouse dexterity.

This lesson explains how to rotate a 3-D chart using both methods.
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1.
2.
3.
4.
5.

6.
7.
8.
9.
10.

Make sure the chart is selected and select Chart → Chart Type from the
menu.
The Chart Type dialog box appears, as shown in Figure 4-24.
Select the Clustered column with a 3-D visual effect, as shown in
Figure 4-24, click the Default formatting checkbox to select it.
The Default formatting checkbox will remove any formatting you’ve applied to the
chart and will return the chart to the default appearance.
Click OK.
The chart type is changed to a 3-D clustered column. Here’s how to rotate the chart
using the mouse:
Click the Chart Object list arrow on the Chart toolbar and select
Corners.
Selection handles appear on the corners of the chart. Now you can rotate the 3-D chart
by clicking and dragging any of the selection handles.
Position the pointer over the lower-right corner selection handle of
the chart, click and hold the left mouse button, drag the chart down and
to the right an inch, as shown in Figure 4-25, then release the mouse
button.
Compare your chart with the one in Figure 4-25. Another way to rotate 3-D charts is
with the 3-D View command on the Chart menu.
Select Chart → 3-D View from the menu.
The 3-D View dialog box appears, as shown in Figure 4-26. The 3-D View dialog box
lets you rotate a 3-D chart with a high degree of precision. Before you rotate the chart,
however, return it to its original position.
Click Default.
The chart is reset to its original position.
In the Increase Elevation text box type 35.
This will change the elevation of the chart. Notice how the preview section displays
how the chart will look in the new position.
In the Increase Rotation textbox type 40.
The charted is formatted with the new rotation and elevation settings.
Click Close and save your work.
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Increase
Elevation button

Increase Rotation
button

Quick Reference
To Rotate a 3-D Chart:
1. Select the chart and
select Chart → 3-D View
from the menu.
2. Make the rotation and
perspective changes in
the 3-D View dialog by
clicking the appropriate
controls and click OK.
Or…
1. Select the chart.
2. Drag the chart’s selection
handles.
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Lesson 4-10: Selecting and Saving
a Custom Chart
Figure 4-27
The Custom Types tab of
the Chart Type dialog box.
Figure 4-28
The Patterns tab of the
Format Chart Area dialog
box.
Figure 4-29
The reformatted chart.
Figure 4-30
Figure 4-28

The Add Custom Chart
Type dialog box.

Use the settings from the selected chart as
the default settings for new charts

Figure 4-27

Figure 4-29

Figure 4-30

So far in this chapter, you have worked with standard charts. You can also create and work
with custom charts. Here are the basic differences between the two:
•

Standard Chart Type: Standard charts include standard, bare bones formatting and
chart options. You must add additional formatting and chart options, such as data labels
and colors that you want to appear in your chart. You can’t save your own standard chart
types.

•

Custom Chart Type: A Custom chart is similar to a template or style, and contains
additional formatting and chart options, such as a legend, gridlines, data labels, colors,
and patterns for various chart items. You can save custom charts, so you can create new
charts based on a custom chart’s formatting and options, saving a lot of time.

This lesson will give you practice creating and saving a custom chart type.

1.
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Make sure the chart is selected, select Chart → Chart Type from the
menu, and click the Custom Types tab.
The Custom Types tab of the Chart Type dialog box appears, as shown in Figure 4-27.
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2.
3.
4.
5.
6.
7.

8.

9.
10.

Scroll down the Chart types list and select Outdoor Bars, as shown in
Figure 4-27 and click Next.
The chart is updated with the Outdoor Bars custom chart settings. The green color of
the chart is difficult to read, so you decide to change it.
Click the Chart Objects List Arrow on the Chart toolbar and select the
Chart Area.
Now you can format the chart area.
Click the Format button on the Chart toolbar under the Area section,
select the light yellow color, as shown in Figure 4-28, and click OK.
The chart area is re-formatted with the light yellow color you selected. Next, remove
the green coloring from the chart’s legend.
Double-click the chart’s legend.
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Chart Objects
list

Format Object
button

In the Area section, select None and click OK.
The green fill color for the legend disappears.
Select Chart → Chart Type from the menu, click the Custom Types
tab, click the User-defined option under the Select from section, and
click Add.
The Add Custom Chart Type dialog box appears, as shown in Figure 4-30. You must
give your custom chart type a name, and if you want, a description.
In the Name textbox, type Modified Outdoor Bars and click OK.
You return to the Chart Type dialog box. The formatting and options for the current
chart have been saved as a user-defined custom chart named Modified Outdoor Bars.
You can format a chart using the Modified Outdoor Bars settings by: (1) Selecting
Chart → Chart Type from the menu, or (2) clicking the Custom Types tab and selecting
the User-defined option under the Select from section, or (3) clicking the Modified
Outdoors Bars, or (4) clicking OK.
Click OK.
The Chart Type dialog box closes.
You can easily delete any custom charts you no longer need.
Select Chart → Chart Type from the menu, click the Custom Types
tab, click the User-defined option under the Select from section.

13. Select the Modified Outdoor Bars custom chart and click Delete.
If you normally use a different type of chart than Excel’s default 2-D column chart, you can
change the default chart type. Just select the chart you want to use as the default chart, select
Chart → Chart Type from the menu, and click the Set as default chart button.

Quick Reference
To Create a Custom Chart:
1. Either create or open a
chart that is formatted and
customized the way you
want.
2. Select the chart, select
Chart → Chart Type
from the menu, and click
the Custom tab.
3. Click the User-defined
option and click Add to
create a custom chart
based on the current
chart.
4. Enter a name and
description for the custom
chart and click OK.
To Change the Default
Chart Type:
1. Either create or open a
chart that is formatted and
customized the way you
want.
2. Select the chart, select
Chart → Chart Type
from the menu, and click
the Set as default chart
button.
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Lesson 4-11: Using Fill Effects
Figure 4-31
The Gradient tab of the Fill
Effects dialog box.
Figure 4-32
The Texture tab of the Fill
Effects dialog box.
Figure 4-33
The Pattern tab of the Fill
Effects dialog box.
Figure 4-34

Figure 4-31

Figure 4-32

Figure 4-33

Figure 4-34

The Picture tab of the Fill
Effects dialog box.

Format Object
button
Other Ways to Format
an Object:
• Double-click the object.
• Right-click the object
and select Selected
Object from the
shortcut menu.
• Click the object to
select it and select
Format → Selected
Object from the menu.
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You can change the fill pattern used in chart objects to produce dramatic and eye-catching
effects. You can change the fill patterns for the Chart Area, the Plot Area, and any columns,
bars, or similar plot areas in a chart. This lesson explains how to do just that.

1.
2.

3.

Make sure the chart is selected, click the Chart Objects List Arrow on
the Chart toolbar and select the Chart Area.
You can also double-click the chart area (if you know what it is) to modify it. Now that
you have selected the chart area, you can format it.
Click the Format button on the Chart toolbar and click the Patterns tab.
The Format Chart Area dialog box appears with the Patterns tab in front. Notice the
area section contains a color palette that you can use to fill the selected object. When
you want to use more dramatic fill effects to color an object than an ordinary color, you
click the Fill Effects button.
Click the Fill Effects and click the Gradient tab if necessary.
The Fill Effects dialog box opens with the Gradient tab in front, as shown in Figure
4-31.
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4.
5.
6.
7.
8.

9.
10.

11.
12.

Click the Two colors option in the Colors section.
This indicates that you want to fill the background of the chart using a two-color
gradient. You need to select the two colors you want to use in the fill pattern.
Click the Color 1 list arrow, select a Bright Green color then click the
Color 2 list and click the Light Green color, as shown in Figure 4-31.
Next, you need to select a shading style.
Select the Horizontal option under the Shading Styles section.
Notice the sample area in the lower right side of the dialog box previews how your
gradient options will look.
Click OK to close the Fill Effect dialog box, then click OK to close the
Format Chart Area dialog box.
The chart area is formatted with the two-color gradient you selected. Move on to the
next step and format the Europe data series with another custom fill effect.
Click the Chart Objects List Arrow on the Chart toolbar, select the
“Series Europe” and click the Format button on the Chart toolbar.
Click the Fill Effects button, then click the Picture tab.
The Fill Effects dialog box opens, with the Picture tab in front, as shown in Figure
4-33. The Picture tab lets you use a picture or graphic as the fill for the selected object.
Click Select Picture.
The Select Picture dialog box appears. You must specify the location and name of the
picture or graphic you want to use to fill the data series.
Navigate to your practice folder or disk, select the Triangles file and
click Insert.
This will insert the Triangles graphic file as the fill object for the Europe data series.
Notice the sample area in the lower right side of the dialog box, which previews what
the picture or graphic looks like.
Under the Format section select Stack and click OK to close the Fill
Effect dialog box, then click OK again to close the Format Chart Area
dialog box.
The Europe data series is formatted with the Triangle pictures as the fill.
Save your changes and close the workbook.

Believe it or not, by learning how to use fill patterns, you’ve learned a formatting trick that
probably less than five percent of all Excel users know. You should feel proud of yourself!
Table 4-7: Types of Fill Patterns
Fill Pattern Tab

Example

Description

Gradient

Fills objects with a two-color gradient.

Texture

Fills objects with a texture.

Pattern

Fills objects with a pattern.

Picture

Fills objects with a graphic or picture file.
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Quick Reference
To Add Fill Effects:
1. Double-click the chart
object.
Or…
Select the object and click
the Format button on
the Chart toolbar.
2. Click the Patterns tab
and click the Fill Effects
button.
3. Select one of the four
tabs, select a fill effect,
and click OK.
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Lesson 4-12: Mapping Data
Figure 4-35
The Microsoft Map Control
dialog box.
Figure 4-36

Click and drag
map format
buttons or data
buttons into or out
of the box

The flights plotted as dots
on a map.

Map format
buttons change
how data is
plotted on the
map

Figure 4-35

Data you can plot on
the map

Data that is currently
plotted on the map
and the format used
to plot it

Figure 4-36

Map button
Other Ways to Create a
Map:
• Select Insert → Map
from the menu.
Your data must contain
geographical
information and values
to plot it on a map.
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If you’re working with data that is categorized geographically, you can use Microsoft’s Map
feature to plot the information.

1.
2.
3.

Open the workbook named Lesson 4B and save it as Flight Map.
This worksheet contains information on how many airline tickets North Shore Travel
sold to various states for the past year. You want to plot this information on a map.
Select the cell range A4:B52.
The A column contains the names of the states and the B column contains the number
of flights to each particular state. Whenever you map data from a worksheet, one
column must contain geographic data, such as the names of countries or states.
Click the Map button on the Standard toolbar.
The mouse pointer changes to a , indicating you must drag a rectangle where you
want the map to appear on the worksheet.
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4.

5.
6.

7.
8.

Making sure you keep the cell range A4:B52 selected, scroll up until you
can see cell D38. Move the pointer to the upper left corner of cell D38,
click and hold the left mouse button and drag the pointer to the lower
right corner of cell I52 and release the mouse button.
The outline for the map appears on the worksheet and the Multiple Maps Available
dialog box appears, indicating that there are several maps you can use to plot your
information on. Since all of the states listed on the worksheet are in the continental
United States, you can select the United States in North America map option.
Select the United States in North America option and click OK.
The Multiple Maps Available dialog box closes.
Drag the Dot Density button in the Microsoft Map Control dialog box
over the top of the Value Shading button in the box, as shown in Figure
4-35.
The map display changes, plotting the information as dots instead as shading. Notice
the legend, which indicates that one dot equals 50 flights.
Double-click the North America title, select the existing text by dragging
the mouse pointer across it, type Flights by State, and press
<Enter>.
The new title replaces the old selected title.
Compare your map to the one in Figure 4-36, then save your work.

The following table lists the map formats you can use in Microsoft Map and their
descriptions.
Table 4-8: Map Formats
Format Button

Description

Value Shading

Map regions shaded based on the value of its data.

Category Shading

Each data value has a unique color, which are used to shade map
regions.

Dot Density

Data is displayed as a series of dots. Larger values = more dots.

Graduated Symbol

Data is displayed as a symbol. Larger values = larger symbol size.

Pie Chart

(Requires 2 data values) Displays a pie chart inside each map region.

Column Chart

(Requires 2 data values) Displays a column chart inside each map
region.
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Dot Density
button

Value Shading
button

Quick Reference
To Create a Map:
1. Select the worksheet data
you want to use in the
map.
2. Select Insert → Map
from the menu.
Or…
Click the Map button
on the Standard toolbar.
3. Click and drag in the
worksheet to specify the
chart’s location and size.
4. If more than one map is
available, select the map
you want.
To Select or Remove a
Map Format:
1. Double-click the map to
edit it.
2. Click the Show/Hide
Map Control button on
the Map toolbar if the Map
Control dialog box isn’t
visible.
3. Drag the Map Format you
want into the box to add a
map format, drag the map
format from the box to
remove a map format.
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Lesson 4-13: Modifying a Map
Figure 4-37
The Map Features dialog
box.
Figure 4-38
Figure 4-38

The Map Labels dialog
box.
Figure 4-39

Figure 4-37

The Custom Pin Map
dialog box.
Figure 4-40
The Map toolbar.

Figure 4-39
Custom Pin Map

Redraw Map

Select Objects Center Map

Add Text

Grab Objects

Figure 4-40

Double-click a map to
edit it.

Map Labels

What is This Help button

Map Refresh

Display Entire Map

Zoom Percentage of Map

Now that you know how to create a map from worksheet data, this lesson explains how you
can modify a map by adding labels and features to the map.

1.

2.

3.

Make sure the map object is selected (double-click the map if it isn’t) and
select Map → Features from the menu.
The Map Features dialog box appears, as shown in Figure 4-37. Here you can change
which features, such as highways and major cities, appear on the map. You can also
change the color of these features.
Select the United States from the list (if it isn’t already selected), click
the Custom option, click the Custom list arrow, select the gray color
and click OK.
The color of the United States portion of the map changes to gray. Here’s how you can
add labels to a map:
Select Tools → Labeler from the menu.
The Map Labels dialog box appears, as shown in Figure 4-38. You can create two
different types of map labels:
•
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Show/Hide Map Control

Map feature names: Creates labels that show the names of map features,
such as the names of the states.
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4.
5.
6.
7.
8.
9.

• Values from: Creates labels that show numeric data for each map region.
Select the Values from option and click OK.
The Map Labels dialog box closes and the mouse pointer changes to a .
Click the state of Minnesota with the pointer.
A value label, 2,015, is added to the state of Minnesota.
Repeat Step 5, adding value labels to the states of California, Texas,
and New York.
You can also add your own custom labels, or “pins” to your maps. You can do this by
creating a Pin Map.
Click the Custom Pin Map button on the Map toolbar.
The Custom Pin Map dialog box opens, as shown in Figure 4-39. Here you can create a
custom pin map, a set of related pins that overlays the map, or you can open an existing
pin map.
Type New Offices and click OK.
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Adding a Value
Label

Custom Pin Map
button

“New Offices” is the name of your pin map. The pointer changes to a , indicating
you can add pins to the map. You will be adding pins indicating where and when
North Shore Travel will be open new branch offices.
Click the state of California with the
pointer, type Open 1st Qtr and
press <Enter>.

10. Click the state of Florida with the

pointer, type Open 3rd Qtr, and

press <Enter>.

11. Save your work, and then exit Excel.
The following table lists the maps and features that you can use with the Map Feature.
Table 4-9: Available Maps and Features
Map

Features

Australia

Airports, Cities, Highways, Major Cities

Canada

Airports, Cities, Highways, Lakes, Major Cities

Europe

Airports, Cities, Highways, Major Cities

Mexico

Cities, Highways, Major Cities

UK

2-Digit Post Codes, Airports, Cities, Highways, Major Cities, Standard Regions

US (North America)

5-Digit Post Codes, Highways, Major Cities, Great Lakes

US (AK & HI)

Airport, Cities, Major Cities

World

Capitals, Countries, Lines of Latitude & Longitude, Oceans

Quick Reference
To Add or Remove Map
Features:
1. Double-click the map to
edit it.
2. Select Map → Features
from the menu.
3. Add or remove a map
feature to a map by
adding or removing the
checkmark next to it.
To Add a Label or Data
Value to a Map:
1. Double-click the map to
edit it.
2. Click the Label button
on the Map toolbar.
Or…
Select Tools → Labeler
from the menu.
3. Select either the Map
feature names option or
the Values from option
and click OK.
4. Click where you want to
place the label or data
value with the pointer.
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Chapter Four Review
Lesson Summary
Creating a Chart
•

To Create a Chart with the ChartWizard: (1) Select the cell range that contains the data you want
to chart and click the Chart Wizard button on the Standard toolbar or select Insert → Chart
from the menu. (2) Select the chart type and click Next. (3) Verify (or change) the cell range used
in the chart and click Next. (4) Adjust the chart options by clicking the categorized tabs and
selecting any options then click Next. (5) Specify where you want to place the chart (as an
embedded object or on a new sheet) and click Finish.

Moving and Resizing a Chart
•

To Resize a Chart: Click the chart to select it, then drag its sizing handles (located along the
edges of the chart) until the chart is the size you want.

•

To Move a Chart: Click and hold down the mouse button on the blank area around a chart, drag
the picture to a new location in the workbook, then release the mouse button.

Formatting Objects in a Chart
•

To Select a Chart Object: Click the object or click the
the Chart toolbar and select the object.

•

To Format a Chart Object: Double-click the object or select the object and click the Format
Object button on the Chart toolbar. You can also format a chart object by right-clicking the object
and selecting Format Object from the shortcut menu.

Chart Objects list arrow on

Changing a Chart’s Source Data
•

To Change a Chart’s Data Source: Select Chart → Source Data from the menu and click the
Data Range tab. Click in the Data Range box and select the cell range you want to base the chart
on (click the Collapse Dialog box button if necessary).

•

The
Collapse Dialog button temporarily shrinks and moves the dialog box so that you enter
a cell range by selecting cells in the worksheet. When you finish, you can click the button again or
press <Enter> to display the entire dialog box.

•

Select non-adjacent cell ranges by pressing and holding the <Ctrl> key while you select additional
cells.

Changing a Chart Type and Working with Pie Charts
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•

The most common types of charts are column, bar, line, area, pie, and scatter.

•

To Change the Chart Type: Click the
Chart → Chart Type from the menu.

Chart Type list arrow on the Chart toolbar or select
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•

To Chart by Rows or Columns: Click either the
button on the Chart toolbar.

•

To Drag a Piece from a Pie Chart: Click the chart to select it, click the piece of the chart you want
to move to select it, drag the piece away from the rest of the chart.

By Columns button of the

By Rows

Adding Titles, Gridlines, and a Data Table
•

To Add or Remove Gridlines from a Chart: Select Chart → Chart Options from the menu, and
click the Gridlines tab. Check or uncheck the appropriate grid line check boxes.

•

To Add or Change Titles to a Chart: Select Chart → Chart Options from the menu, and click
the Titles tab. Enter or modify the text in the text boxes that correspond to the desired chart titles.

•

To Add or Remove a Data Table: Click the

•

To Add or Remove Chart Data Labels: Select Chart → Chart Options from the menu, and click
the Data Labels tab. Check or uncheck the appropriate check boxes to display or the chart hide
data labels.

Data Table button on the Chart toolbar.

Formatting a Data Series and a Chart Axis
•

A data series is a group on a chart that comes from a row or column on a worksheet. An axis is a
line that borders one side of a chart that provides a scale of measurement or comparison in a
chart. For most charts, data values are plotted along the value (Y) axis, which is usually vertical,
and categories are plotted along the category (X) axis, which is usually horizontal.

•

To Add Labels to a Data Series: Double-click the data series or select the data series and select
Format → Selected Object from the menu. Click the Data Labels tab and select the appropriate
option.

•

To Change the Scale of a Chart: Double-click the axis, or right-click the axis and select Format
Axis from the shortcut menu, or select the axis and select Format → Selected Object from the
menu. Click the Scale tab and make the changes to the scale.

Annotating a Chart
•

To View the Drawing Toolbar: Click the Drawing button on the Standard toolbar or select
View → Toolbars → Drawing from the menu.

•

To Draw an Object: Click the object you want to draw on the drawing toolbar, such as a line or
circle, and drag the crosshair pointer to draw the object.

•

Resize a drawing object by selecting it and dragging its sizing handles.

Working with 3-D Charts
•

To Rotate a 3-D Chart: Select the chart and select Chart → 3-D View from the menu. Make the
rotation and perspective changes in the 3-D View dialog by clicking the appropriate controls and
click OK.

Selecting and Saving a Custom Chart
•

A Custom chart contains formatting and options you specify, such as a legend, gridlines, data
labels, and formatting options. You can save custom charts, so you can create new charts based
on a custom chart’s formatting and options.
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•

To Create a Custom Chart: Either create or open a chart that is formatted and customized the
way you want. Select the chart, select Chart → Chart Type from the menu, and click the Custom
tab. Click the User-defined option and click Add to create a custom chart based on the current
chart. Enter a name and description for the custom chart and click OK.

Using Fill Effects
•

To Add Fill Effects: Double-click the chart object or select the object and click the Format
button on the Chart toolbar. Click the Patterns tab and click the Fill Effects button. Select one of
the four tabs, select a fill effect, and click OK.

Mapping Data
•

Your data must contain geographical information and values to plot it on a map.

•

To Create a Map: Select the worksheet data you want to use in the map, click the Map button
on the Standard toolbar or select Insert → Map from the menu. Click and drag in the worksheet to
specify the chart’s location and size.

•

To Select or Remove a Map Format: Double-click the map to edit it, click the Show/Hide Map
Control button on the Map toolbar if the Map Control dialog box isn’t visible. Drag the Map Format
you want into the box to add a map format, drag the map format from the box to remove a map
format.

Modifying a Map
•

To Add or Remove Map Features: Double-click the map to edit it and select Map → Features
from the menu. Add or remove a map feature to a map by adding or removing the checkmark next
to it.

•

To Add a Label or Data Value to a Map: Double-click the map to edit it and either click the
Label button on the Map toolbar or select Tools → Labeler from the menu. Select either the
Map feature names option or the Values from option and click OK. Click where you want to place
the label or data value with the pointer.

Quiz
1. All of the following statements about charts are true except…
A. You can place a chart on the same sheets as the data or on a new worksheet.
B. To create a chart, select Tools → Chart from the menu.
C. You can move a chart by clicking it and dragging it by the blank area around the
chart to its new location.
D. You can resize a chart by clicking it and dragging its sizing handles.
2. You want to track the progress of the stock market on a daily basis. Which
type of chart should you use?
A.
B.
C.
D.
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Line chart.
Column chart.
Row chart.
Pie chart.
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3. All of the following are methods to edit or format a chart object except…
A. Double-click the object
B. Right-click the object and select Format from the shortcut menu.
C. Select the object from the Chart Object list on the Chart toolbar and click the Format
Object button.
D. Select Chart → Format from the menu, select the object from the Object list and
click Format.
4. Which of the following statements is NOT true?
A. You can change the cells that are plotted in a chart by selecting the new cells and
clicking the Chart Wizard button on the Standard toolbar.
B. When you change the chart type, all its formatting options will always transfer
perfectly to the new type of chart.
C. Holding down the <Ctrl> lets you select cell ranges that are not next to each other.
D. You can change the cells that are plotted in a chart by selecting Chart → Source Data
from the menu and selecting the new cells.
5. The Drawing toolbar can only be used to annotate charts. (True or False?)
6. All of the following statements are true except…
A. You can change the perspective of 3-D charts by selecting Chart → 3-D View from
the menu.
B. A Standard chart lets you save your chart formatting and settings, so you can create
new charts using the same settings.
C. To add or remove a legend from a chart, click the Legend button on the Chart
toolbar.
D. Many Excel dialog boxes have several Collapse Dialog box buttons, which you can
use to temporarily shrink the dialog box to select cells.
7. The categories at the bottom of a chart are also called the…
A.
B.
C.
D.

X-axis.
Y-axis.
Z-axis.
Category axis.

8. Charts cannot be moved or resized once they have been created. (True or
False?)
9. How can you open the Chart Options dialog box?
A.
B.
C.
D.

Click the Chart Options button on the Standard toolbar.
Quadruple-click any chart.
Select Chart → Chart Options from the menu.
Select Tools → Chart Options from the menu.

10. Which of the following are objects that you can add to an Excel chart?
(Select all that apply.)
A.
B.
C.
D.

A legend.
A data table.
A category or x-axis title.
Data labels.
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Homework
1. Open the Homework 4 workbook and save it as “Chart Practice”.
2. What type of chart do you think would work best to present the information in this
worksheet?
3. Use the Chart Wizard to create a chart that plots the cell range A3:E7. Give the chart
the Chart Title “Package Sales” and place the chart in a separate sheet.
4. Click the legend to select it, and change the font size used in the legend to 12 pt.
5. Make the legend taller by about ½”, and drag it to the bottom right of the chart.
6. Change the chart type to a 3-D Bar chart.
7. Change the color of the Vancouver color series to light green.
8. Use the drawing toolbar to add an arrow that points to the largest number in the chart
(Montreal in the fourth quarter) and add a textbox at the other end of the arrow that
says, “Wow!”

9. Change the chart’s data source so that only the totals for each tour (cell range F4:F7)
are plotted in the chart.
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Quiz Answers
1. B. Create a chart by clicking the Chart Wizard button on the Standard toolbar or by
selecting Insert → Chart from the menu.
2. A. Line charts are used to illustrate trends. If you used the other three chart types to
track the stock market, there would be too many data points.
3. A. You change the data source for a chart by selecting Chart → Source Data from the
menu and selecting the new cells.
4. A. To change a chart’s source data, select the chart and select Chart → Source Data
from the menu.
5. True. You can annotate charts and worksheets with the Drawing toolbar.
6. B. Custom charts, not Standard charts, allow you to save your chart formatting and
settings, so you can create new charts using the same settings.
7. A. The categories at the bottom of a chart are also known as the X-axis.
8. False. You can easily move or resize any chart in Excel.
9. C. Select Chart → Chart Options from the menu to open the Chart Options dialog
box.
10. A, B, C, and D. All of these are types of objects that you can add to an Excel chart.
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Chapter Five:
Managing Your
Workbooks
Chapter Objectives:
•

Navigate between the sheets in a workbook

•

Insert, delete, rename, and move worksheets

•

Work with several worksheets and workbooks

•

Split and freeze a window

•

Add headers, footers, and page numbers to a worksheet

•

Specify what gets printed and where the page breaks

•

Adjust the margins, page size and orientation, and print scale

•

Protect and hide a worksheet

•

Create and use a template

•

Consolidate multiple worksheets

Chapter Task: Work with a weekly summary report
Financial and numeric information often does not fit on a single page. For example, a
business’s financial statement usually has several pages: an expense page, an income page, a
cash-flow page, and so on. Similarly, Excel’s workbooks contain several worksheets. New
workbooks contain three blank worksheets, and you can easily add more.
Up until now, you have only worked with a single worksheet. In this chapter, you will learn
how to work with and manage workbooks. You’ll learn how to move between the worksheets,
add, rename, move, and delete worksheets, and how to create formulas that reference
information from several different worksheets. Along the way, you’ll learn a lot more about
printing.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• Open and save
workbooks.
• How to enter values
and labels.
• How to reference cells.
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Lesson 5-1: Switching Between
Sheets in a Workbook
Figure 5-1
The Sheet Tab Scroll
Buttons.

Scrolls to the first
sheet tab in the
active workbook

Scrolls to the last
sheet tab in the
active workbook

Scrolls the previous
sheet tab into view

Scrolls the next
sheet tab into view

Figure 5-2
Right-clicking any of the
tab scroll buttons displays
a menu of sheets in a
workbook.

Figure 5-1

Figure 5-2

Sheet tab scroll tabs

This lesson covers the basics of working with worksheets; namely how to move between
them. Each worksheet has a tab that appears near the bottom of the workbook window. To
switch to a different sheet, all you have to do is click its tab. Easy, huh? When there are too
many tabs in a workbook to display them all, you can scroll through the worksheet tabs by
clicking the scroll tab buttons, located at the bottom of the screen near the worksheet tabs.

Worksheet tabs

1.
2.

Start Microsoft Excel.
Open the Lesson 5 workbook and save it as Weekly Reservations.
Excel saves the worksheet in a new file with the name “Weekly Reservations.” This
workbook contains several worksheets. It’s easy to switch between the various
worksheets in a workbook; simply click the worksheet’s sheet tab. Move on to the next
step and try it!
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3.
4.

5.
6.
7.
8.
9.

Click the Friday tab.
The Friday worksheet appears in front. You can tell the Friday worksheet is active
because its sheet tab appears white. Once a worksheet is active, you can edit it using
any of the techniques you already know.
Practice viewing the various worksheets in the workbook by clicking the
worksheet tabs.
You may have noticed by now that there is not enough room to display all of the sheet
tabs. Whenever this happens, you must use the tab scrolling buttons to scroll through
the sheet tabs until the tab you want appears. Figure 5-1 describes the function of the
various Tab Scrolling buttons.
Click the Next Sheet Tab Scroll button until the Summary tab
appears.
Click the Summary tab.
The Summary sheet tab becomes active and its sheet tab changes from gray to white.
Click the First Tab Scroll button to move to the first sheet tab (Tuesday)
in the workbook.
You can also switch between worksheets by using a right mouse button shortcut menu.
Right-click any of the Tab Scroll buttons.
Excel displays a shortcut menu listing the sheets in the current workbook, as shown in
Figure 5-2.
Select Wednesday from the shortcut menu.
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Next Sheet Tab
Scroll button

First Sheet Tab
Scroll button

Quick Reference
To Activate a Worksheet:
• Click the sheet tab at the
bottom of the screen.
Or…
• Right-click the sheet tab
scroll buttons and select
the worksheet from the
shortcut menu.
To Scroll through
Worksheets in a
Workbook:
• Click the corresponding
scroll sheet tabs at the
bottom of the screen.
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Lesson 5-2: Inserting and Deleting
Worksheets
Figure 5-3
Deleting a selected
worksheet.
Figure 5-4
Delete confirmation dialog
box.
Figure 5-5
The Insert dialog box.

Figure 5-3

Figure 5-4

Figure 5-5

An Excel workbook contains three blank worksheets by default. You can easily add and delete
worksheets to and from a workbook, and you’ll learn how to do it in this lesson.

1.
2.
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Right-click the Comments tab.
A shortcut menu appears with commands to insert, delete, rename, move or copy, select
all sheets, or view the Visual Basic code in a workbook, as shown in Figure 5-3.
Select Delete from the shortcut menu.
A dialog box appears warning you that the selected sheet will be permanently deleted,
as shown in Figure 5-4.

Chapter Five: Managing Your Workbooks

3.
4.

5.
6.
7.
8.
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Click OK to confirm the worksheet deletion.
The Comments worksheet is deleted from the workbook.
Delete the Foreign, Domestic, Receipts, and Summary sheets from the
workbook.
There are several worksheets that you need to add to the Weekly Reservations
workbook—a worksheet for Monday’s reservations and another to summarize the
entire week. Inserting a new worksheet to a workbook is just as easy as deleting one.
Select Insert → Worksheet from the menu.
Excel inserts a new worksheet tab labeled Sheet1 to the left of the selected sheet. You
can also insert worksheets using a right mouse button shortcut menu.
Right-click any of the sheet tabs and select Insert from the shortcut
menu.
The Insert dialog box appears, as shown in Figure 5-3.
Verify that the Worksheet option is selected and click OK.
Excel inserts another worksheet tab labeled Sheet2 to the left of the Sheet1.
Save your work.

Quick Reference
To Add a New Worksheet:
• Right-click on a sheet tab,
select Insert from the
shortcut menu, and select
Worksheet from the
Insert dialog box.
Or…
• Select Insert →
Worksheet from the
menu.
To Delete a Worksheet:
• Right-click on the sheet
tab and select Delete
from the shortcut menu.
Or…
• Select Edit → Delete
Sheet from the menu.
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Lesson 5-3: Renaming and Moving
Worksheets
Figure 5-6
Moving a worksheet to a
different location in a
workbook.

Figure 5-6

New sheet location
indicator

Worksheets are given the rather boring and meaningless default names Sheet1, Sheet2,
Sheet3, and so on. By the end of this lesson, you will know how to change a sheet’s name to
something more meaningful, such as “Budget” instead of “Sheet3”.
Another important worksheet skill you’ll learn in this lesson is how to move worksheets, so
you can rearrange the order of worksheets in a workbook. Let’s get started!

1.
Renaming a
Worksheet tab
Other Ways to Rename a
Worksheet:
• Right-click the
worksheet and select
Rename from the
shortcut menu.
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2.
3.
4.

Double-click the Sheet1 tab.
The Sheet1 text is selected; indicating you can rename the worksheet. Worksheet
names can contain up to 31 characters, including punctuation and spacing.
Type Monday and press <Enter>.
The name of the selected worksheet tab changes from Sheet1 to Monday. Move on to
the next step to rename Sheet2.
Rename the Sheet2 tab Summary.
You have probably already noticed that the sheets in this workbook are out of order.
Rearranging the order of sheets in a workbook is very easy and straightforward: simply
drag and drop the sheets to a new location.
Click and drag the Wednesday tab after the Tuesday tab.
As you drag the Wednesday sheet, notice that the mouse pointer indicates where the
sheet will be relocated, as shown in Figure 5-6.

Chapter Five: Managing Your Workbooks

5.
6.
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Drag the Summary sheet after the Friday sheet.
Great! You’ve just learned how to move a worksheet.
Save your work.

One more thing: instead of moving a worksheet, you can also copy it by pressing the <Ctrl>
key as you drag the worksheet tab. How are you doing? Working with worksheets is really
quite easy, isn’t it?
Quick Reference
To Rename a Worksheet:
• Right-click the sheet tab,
select Rename from the
shortcut menu, and enter
a new name for the
worksheet.
Or…
• Double-click the sheet tab
and enter a new name for
the worksheet.
Or…
• Select Format → Sheet
→ Rename from the
menu, and enter a new
name for the worksheet.
To Move a Worksheet:
• Click and drag the sheet
tab to the desired
location.
Or…
• Select Edit → Move or
Copy Sheet from the
menu, then select the
workbook and location
where you want to move
the worksheet.
To Copy a Worksheet:
• Hold down the <Ctrl> key
while you click and drag
the sheet tab to its
desired location.
Or…
• Select Edit → Move or
Copy Sheet from the
menu, then select the
workbook and location
where you want to move
the worksheet.
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Lesson 5-4: Working with Several
Workbooks and Windows
Figure 5-7
Moving between workbook
files using the Window
menu.
Figure 5-8
Figure 5-8

The Arrange Windows
dialog box.
Figure 5-9

Figure 5-7

Viewing two workbook
files in horizontal windows.

Figure 5-9

One of the benefits of Excel (and many other Windows programs) is that you can open and
work with several files at once. Each workbook you open in Excel gets its own window. This
lesson explains how to open and work with more than one workbook at a time. You will also
learn some tricks on sizing and arranging windows.
Click to select all the
cells in a worksheet

Select All button
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1.

Open the Monday Reservations workbook.
The workbook Monday Reservations appears. The Weekly Reservations workbook is
also open, you just can’t see it because the Monday Reservations workbook occupies
the entire worksheet window area. To move back to the Weekly Reservations
workbook you use the Window menu command. Before you return to the Weekly
Reservations workbook, move on to Step 2 to copy the reservation information for
Monday.
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2.

3.
4.

5.

6.
7.
8.
9.

10.
11.
12.

Click the Select All button on Sheet1 to select the entire sheet, then
click the Copy button on the Standard toolbar (or use any of the other
copy methods you’ve learned) to copy the entire worksheet.
Now that the entire worksheet is copied, you need to move back to the Weekly
Reservations file to paste the information.
Select Window from the menu.
The Window menu appears, as shown in Figure 5-7. The Window menu contains a list
of all the currently open workbooks, as well as several viewing commands.
Select Weekly Reservations.xls from the Window menu.
You’re back in the Weekly Reservations workbook. Now you can paste the information
you copied from the Monday Reservations workbook.
NOTE: Don’t confuse working with several Excel workbooks with working with
several worksheets. Workbooks are the Excel files you open and save.
Workbooks contain several worksheets within the same file.
Click the Monday tab, click cell A1 to make it active and click the Paste
button on the Standard toolbar (or use any of the other paste methods
you’ve learned) to paste the copied information.
The information you copied from Sheet1 of the Monday Reservations workbook is
pasted into the Monday sheet of the Weekly Reservations workbook.
When you’re working with two or more files, sometimes it’s useful to view both
workbooks at the same time.
Select Window → Arrange from the menu.
The Arrange dialog box opens as shown in Figure 5-8, inquiring how you want to view
the windows.
Select Horizontal and click OK.
Excel displays both of the open files in two horizontally aligned windows, as shown in
Figure 5-9. You need to copy a little more information from the Monday Reservations
workbook into the Weekly Reservations workbook.
Click the Sheet2 tab in the Monday Reservations window, click cell A1,
and click the Copy button on the Standard toolbar.
Now paste the copied label into the Weekly Reservations workbook.
Click the Summary tab in the Weekly Reservations window, click cell A1,
and click the Paste button on the Standard toolbar.
The copied label is pasted into the Summary sheet of the Weekly Reservations
workbook. You’re finished gathering information from the Monday Reservations
workbook, so close the file.
Close the Monday Reservations window by clicking its Close button.
The Monday Reservations workbook closes. Since you’re only working with the
Weekly Reservations workbook, you can maximize its window.
Click the Weekly Reservations window’s Maximize button.
The Weekly Reservations window maximizes to occupy the entire Excel worksheet
window area.
Save your work.
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Copy button

Paste button
Maximize button

Quick Reference
To Switch between
Multiple Open Workbooks:
• Select Window from the
menu and select the
name of the workbook
you want to view.
To View Multiple Windows
at the Same Time:
• Select Window →
Arrange All.
To Maximize a Window:
• Click the window’s
Maximize button.
To Restore a Window:
• Click the window’s
Restore button.
To Manually Resize a
Window:
1. Position the mouse
pointer over the edge of
the window.
2. Hold down the mouse
button and drag the
mouse to resize the
window.
3. Release the mouse
button.
To Move a Window:
• Drag the window’s title
bar to the location where
you want to position the
window.
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Lesson 5-5: Splitting and Freezing
a Window
Figure 5-10

Window splits
above the
active cell

Splitting a window into two
panes.

Click and drag the
vertical split box to
split a worksheet
window

Figure 5-11
Use the Window → Split
or Freeze Panes
command splits the
window above and to the
right of the active cell.

Figure 5-11

Window splits to
the right of the
active cell

Figure 5-10

Figure 5-12
Freezing a window.

The window is
horizontally frozen
here

Information in the
frozen panes remains
on the screen as you
scroll and move
through a worksheet

Figure 5-12

Split Box

Vertical Split Box
Click to select all the
cells in a worksheet

Select All button
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The window is vertically
frozen here

It doesn’t take long to fill up a worksheet with so much data that it won’t all fit on the same
screen. When this happens, you have to scroll through the worksheet to add, delete, modify,
and view information, a skill you learned in a previous chapter. The problem with scrolling
and viewing information in a large worksheet is that it can be confusing without the row or
column labels.
To overcome this problem, you can split a window into two or four panes, which let you view
multiple parts of the same worksheet. Once you create a pane, you can freeze it so it stays in
the same place while you scroll around the rest of the worksheet.
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1.

2.

3.

4.

5.
6.
7.

Move the pointer over the vertical split box, located at the top of the
vertical scroll bar. When the pointer changes to a , drag the split box
down directly beneath row 4, as shown in Figure 5-10.
Excel splits the worksheet window vertically into two separate panes. Panes are used
to view different areas of a large worksheet at the same time. You can split a window
into two panes either horizontally (as you’ve done) or vertically. Notice each of the
panes contains its own vertical scroll bar, enabling you to scroll the pane to a different
area of the worksheet.
Scroll down the worksheet in the lower pane until you reach row 60.
NOTE: Each pane has its own set of scroll boxes. Make sure you scroll down using
the vertical scroll bar in the lower pane and not the upper pane.
Notice that the worksheet scrolls down only in the lower pane. The upper pane stays in
the same location in the worksheet, independent of the lower pane.
Move the pointer over the horizontal split box, located at the far right of
the horizontal scroll bar. When the pointer changes to a , drag the split
box to the left, immediately after column B.
Excel splits the worksheet window vertically, so it now contains four panes. Once you
have split a window into several panes, you can freeze the panes so they stay in place.
Select Window → Freeze Panes from the menu.
Thin lines appear between the B and C column, and the fourth and fifth rows as shown
in Figure 5-12. When you freeze a window, data in the frozen panes (the left and/or top
panes) will not scroll and remains visible as you move through the rest of the
worksheet. Try scrolling the worksheet window to see for yourself.
Scroll the worksheet vertically and horizontally to view the data.
Notice how the frozen panes—column A through B, and rows 1 through 4, stay on the
screen as you scroll the worksheet, allowing you to see the row and column labels.
Now you’re ready to unfreeze the panes.
Select Window → Unfreeze Panes from the menu.
The panes are now unfrozen. You can once more navigate in any of the four panes to
view different areas of the worksheet at the same time. Since the exercise is almost
over, you want to view the window in a single pane instead of four.
Select Window → Remove Split from the menu.
You are returned to a single pane view of the worksheet window.
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Split Box

Horizontal Split
Box
Other Ways to Split or
Freeze Panes:
• Move the cell pointer to
the cell below the row
you want to freeze and
to the right of the
column you want to split
or freeze and select
Window → Split or
Freeze Panes from the
menu.

Quick Reference
To Split Panes:
• Drag either the vertical or
horizontal split bar.
Or…
• Move the cell pointer to
the cell below the row
you and to the right of the
column you want to split
and select Window →
Split from the menu.
To Freeze Panes:
1. Follow the previous
instructions to split the
window into panes.
2. Select Window →
Freeze Panes from the
menu.
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Lesson 5-6: Referencing External
Data
Figure 5-13

External reference indicator

Referencing data in
another sheet in the same
workbook.

=Monday ! D61
Sheet referenced

Figure 5-14
An example of an external
cell reference.

Cell referenced

Figure 5-14
Figure 5-13

Figure 5-15
The Summary sheet with
references to data in other
sheets and in another
workbook file.

Figure 5-15

You already know how to create references to cells in the same worksheet. This lesson
explains how you can create references to cells in other worksheets, and even to cells in other
workbook files altogether! References to cells or cell ranges on other sheets are called
external references or 3-D references. One of the most common reasons for using external
references is to create a worksheet that summarizes the totals from other worksheets. For
example, a workbook might contain 13 worksheets, one for each month, and an annual
summary worksheet that references and totals the data from each monthly worksheet.

1.
2.

3.
Fill Handle
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Click the Summary tab.
Click cell A3, click the Bold button and the Center button on the
Formatting toolbar, type Monday, and then click the Enter button on the
formula bar.
You need to need to add column headings for the remaining business days. Use the
AutoFill feature to accomplish this task faster.
Position the pointer over the fill handle of cell A3, until it changes to a ,
click and hold the mouse button, and drag the fill handle to select the cell
range A3:E3.
The AutoFill function automatically fills the cell range with the days of the week. Now
it’s time to create a reference to a cell on another sheet in the workbook. To refer to a
cell in another sheet: (1) Type = (equal sign) or entering a formula (2) Click the sheet
tab that contains the cell or cell range you want to use (3) Click the cell or cell range
you want to reference, and (4) Complete the entry by pressing <Enter> or clicking the
Enter button on the formula bar.
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4.

5.

6.
7.
8.
9.
10.
11.

Click cell A4, type =, click the Monday sheet tab, click cell D61 (you will
probably have to scroll the worksheet down), and press <Tab>.
Excel completes the entry and creates a reference to cell D61 on the Monday sheet, as
shown in Figure 5-13. The Formula bar reads =Monday!D61. The Monday refers to the
Monday sheet. The ! (examination point) is an external reference indicator—it means
that the referenced cell is located outside the active sheet. D61 is the cell reference
inside the external sheet.
Repeat Step 4, adding external references to the Total formula in cell D61
on the Tuesday, Wednesday, Thursday, and Friday sheets.
You can also reference data between different workbook files, just as you can reference
data between sheets. This process of referencing data between different workbooks is
called linking. Linking is dynamic, meaning that any changes made in one workbook
are reflected in the other workbook. Try referencing a cell in a different workbook
now—the first thing you’ll need to do is open the workbook file that contains the data
you want to reference.
Open the workbook Internet Reservations from your Practice folder or
disk.
To create a reference to a cell in this workbook you first need to return to the Weekly
Reservations workbook because it will contain the reference.
Select Window → Weekly Reservations.xls from the menu.
You return to the Summary sheet of the Weekly Reservations workbook.
Click cell F3, type Internet, click the Bold button and the Center
button on the Formatting toolbar. Press <Enter> to move to cell F4, type
= (equal sign) to start creating the external reference.
Now you need to select the cell that contains the data you want to reference, or link.
Select Window → Internet Reservations.xls from the menu.
You’re back to the Internet Reservations workbook. All you need to do is click the cell
containing the data you want to reference and complete the entry.
Click cell B8 and press <Enter>.
Complete the Summary sheet by totaling the information from the various external
sources.
Click cell G3, click the Bold button and Center button on the
Formatting toolbar, type Total, and press <Enter> to complete the entry
and move to cell G4.

12. Click the AutoSum button on the Standard toolbar, notice that the cell

13.

range is correct (A4:F4), then press <Enter>.
Excel totals the cell range (A4:F4) containing the externally referenced data. Compare
your worksheet with the one in Figure 5-15.
Save your work.

175

You can create
references to cells in
other worksheets by
clicking the sheet tab
where the cell or cell
range is located, and
then clicking the cell
or cell range.

AutoSum button

Quick Reference
To Create an External Cell
Reference:
1. Click the cell where you
want to enter the formula.
2. Type = (an equal sign),
and enter any necessary
parts of the formula.
3. Click the tab for the
worksheet that contains
the cell or cell range you
want to reference. If you
want to reference another
workbook file, open that
workbook and select the
appropriate worksheet
tab.
4. Select the cell or cell
range you want to
reference and complete
the formula.
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Lesson 5-7: Creating Headers,
Footers, and Page Numbers
Figure 5-16
The Header/Footer tab of
the Page Setup dialog
box.

Select a preset header

Figure 5-17

Create a custom header or footer

You can create your own
custom headers in the
Header dialog box.

Select a preset footer

Figure 5-16

Figure 5-17

Worksheets that are several pages long often have information such as the page number, title,
or date, located at the top or bottom of every page. Text that appears at the top of every page
in a document is called a header, while text appearing at the bottom of each page is called
footer. In this lesson, you will learn how to use both headers and footers.

1.
2.

3.
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Click the Monday sheet tab to make the Monday worksheet active.
You need to specify the header and footer for the Monday worksheet.
Select File → Page Setup from the menu and click the Header/Footer
tab.
The Header/Footer tab of the Page Setup dialog box appears, as shown in Figure 5-16.
You can add a header and/or footer by selecting one of the preset headers and footers
from the Header or Footer list, or you can create your own. The next few steps explain
how to create a custom header.
Click the Custom Header button.
The Header dialog box appears, as shown in Figure 5-17. The Header dialog box lets
you customize the header for the worksheet.
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4.
5.
6.
7.
8.

9.
10.

Click the Center section box.
Any text typed in the Center section box will appear centered across the top of the
worksheet. You can format the text that appears in the header and footer by clicking the
Font button.
Click the Font button, select Bold from the Font Style list, and click OK.
Now that you have formatted the header’s font, type the text for the header in the
Center section box.
Type Monday Reservations and click OK.
You return to the Header/Footer tab of the Page Setup dialog box. Notice that the
header appears in the header preview area. Next, add a footer to the worksheet.
Click the Custom Footer button.
The Footer dialog box appears. You want to add the name of the workbook file in the
left side of the footer.
Click the Left Section box and click the File Name button to insert the
filename code.
Excel inserts the filename code, &[File]. This cryptic-looking code will display the
name of the file, Weekly Reservations.xls, in the footer. Since the filename code is in
the Left Section box, it will appear left-aligned on the worksheet’s footer. Now you
want to add the page number to the right side of the footer.
Click the Right Section box, type Page, press the <Spacebar>, click
the Page Number button to insert the page number code, and click OK
to close the Footer dialog box.
You’re back to the Header/Footer tab. Notice how the footer appears in the footer box.
Click Print Preview to preview your worksheet, then save it.

Table 5-10: Header and Footer buttons
Button
Font
Page Number
Total Pages
Date
Time
File Name
Sheet Name

Description
Formats the font for the header and footer
Inserts the current page number
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Font button

File Name button

Page Number
button

Quick Reference
To Add or Change the
Header or Footer:
1. Select File → Page
Setup from the menu and
click the Header/Footer
tab.
2. Select one of the preset
headers or footers from
the Header or Footer
drop-down list.

Inserts the total number of pages in the workbook

To Add a Custom Header
or Footer:

Inserts the current date

1. Select the File → Page
Setup from the menu and
click the Header/Footer
tab.
2. Click the Custom Header
or Custom Footer button.
3. Enter the header or footer
in any or all of the three
sections. Refer to Table
5-10: Header and Footer
buttons to enter special
information.

Inserts the current time
Inserts the workbook file name
Inserts the worksheet name
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Lesson 5-8: Specifying a Print
Area and Controlling Page Breaks
Figure 5-18
You can adjust where the
page breaks in Page
Break Preview mode.

Figure 5-18

Drag the page break indicator line to
where you want the page to break

Sometimes you may want to print only a particular area of a worksheet, instead of all of it.
You can specify an area of a worksheet to print using the File → Print Area → Set Print Area
menu command. The Set Print Area command is especially useful when you’re working with
a huge worksheet. Instead of taking dozens of pages to print everything, you can use the Set
Print Area command to print what is important, such as the worksheet totals.
Another topic covered in this lesson is how to force the page to break where you want when
you print out a worksheet.

1.
2.

3.
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Press <Ctrl> + <Home> to move to the beginning of the worksheet.
Select the cell range A1:E61.
Yes, this is a very large cell range. You must hold down the mouse button and move the
pointer down, below the Excel worksheet window. If you have trouble selecting this
cell range using the mouse, click cell A1, press and hold down the <Shift> key, scroll
down and click cell E61 and release the <Shift> key. The cell range you just selected is
the part of the worksheet you want to print.
Select File → Print Area → Set Print Area from the menu.
Excel sets the currently selected cell range, A1:E61, as the print area. Unless you
remove this print area, Excel will only print this cell range whenever you print the
worksheet. Removing a print area is even easier than setting one.
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4.
5.

6.

7.

8.

9.

Select File → Print Area → Clear Print Area from the menu.
The print area you selected, A1:E61, is cleared and Excel will now print the entire
worksheet whenever you send it to the printer. For this exercise, however, you need to
keep using the print range A1:E61, so undo the previous Clear Print Area command.
Click the Undo button on the Standard toolbar.
Excel undoes the Clear Print Area command.
When you print your worksheets, sometimes the page will break where you don’t want
it to. You can adjust where the page breaks with Excel’s Page Break Preview feature.
Select View → Page Break Preview from the menu.
Excel changes the worksheet’s window view from Normal to Page Break Preview
mode, as shown in Figure 5-18. Print Break Preview mode shows you where the
worksheet’s pages will break when printed, as indicated by a dark blue line. The areas
of the worksheet that are not included in the current print area appear in dark gray. You
can adjust where the page breaks by clicking and dragging the dark blue page break
indicator line to where you want the page to break.
Scroll down the worksheet, and click and drag the Page Break Indicator
line until it appears immediately after row 40, as shown in Figure 5-18.
When you print the Monday worksheet, the page will break immediately after row 40.
You’re finished using Page Break Preview mode, so change the view back to normal
mode.
Select View → Normal from the menu.
You return to the Normal view of the workbook. Notice that a dotted line appears at the
edge of the print area and after row 40. This dotted line indicates where the page will
break when the worksheet is printed. Normally Excel automatically inserts a page
break when the worksheet won’t fit on the page, but you can manually insert your own
page breaks as well.
Click cell A18 then select Insert → Page Break from the menu.
A dashed page break indicator line appears between rows 17 and 18, indicating a
horizontal page break.

Table 5-11: Inserting Page Breaks
To Break the Page This Way

Position the Cell Pointer Here

Horizontally

Select the cell in column A that is below where you want the
page break

Vertically

Select the cell in row 1 that is to the right of where you want
the page break

Both Horizontally and Vertically

Select the cell below and to the right of where you want the
page break
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Adjusting where
the page breaks

Page Break
Indicator
Quick Reference
To Specify a Print Area:
1. Select the cell range you
want to print.
2. Select File → Print Area
→ Set Print Area from
the menu.
To Clear a Print Area:
• Select File → Print Area
→ Clear Print Area from
the menu.
To Insert a Manual Page
Break:
1. Move the cell pointer to
the cell where the next
page should start, but
make sure it’s in the A
column (otherwise you
will insert a horizontal
page break and a vertical
page break).
2. Select Insert → Page
Break from the menu.
To Adjust Where the Page
Breaks:
1. Select View → Page
Break Preview from the
menu.
2. Drag the Page Break
Indicator line to where
you want the page break
to occur.
3. Select View → Normal
from the menu to return to
Normal view.
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Lesson 5-9: Adjusting Page
Margins and Orientation
Figure 5-19

1

The Margins tab of the
Page Setup dialog box.

Top margin

Figure 5-20

Left margin

Right margin

Margins on a page.
Figure 5-21

Bottom margin

Figure 5-20

The Page tab of the Page
Setup dialog box.
Figure 5-22
Comparison of portrait and
landscape page
orientations.

Figure 5-19

Portrait

Landscape
Figure 5-21

Figure 5-22

You’re probably already aware that margins are the empty space between the text and the left,
right, top, and bottom edges of a printed page. Excel’s default margins are one inch at the top
and bottom and .75 inch margins to the left and right. There are many reasons to change the
margins for a document: to make more room for text information on a page, to add some extra
space if you’re binding a document, or to leave a blank space to write in notes. If you don’t
already know how to adjust a page's margins, you will after this lesson.
This lesson also explains how to change the page orientation. Everything you print uses one
of two different types of paper orientations: Portrait and Landscape. In Portrait orientation,
the paper is taller than it is wide, like a painting of a person’s portrait. In Landscape
orientation, the paper is wider than it is tall, like a painting of a landscape. Portrait orientation
is the default setting for printing worksheets, but there are many times when you will want to
use landscape orientation instead.
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2.
3.
4.

5.
6.
7.
8.

9.

Click File → Page Setup from the menu and click the Margins tab if it is
not already in front.
The Margins tab of the Page Setup dialog box appears, as shown in Figure 5-19. Here
you can view and adjust the margin sizes for the current worksheet. Notice there are
margins settings in the Top, Left, Right, Header, and Footer boxes.
Click the Top Margin box down arrow until .5 appears in the box.
This will change the size of the top margin from 1 inch to .5 inch. Notice that the
Preview area of the Page Setup dialog box displays where the new margins for the
worksheet will be.
Click the Bottom Margin box down arrow until .5 appears in the box.
In the same manner, you could adjust the left and right margins, and how far you want
the worksheet’s header and footer to print from the edge of the page. You can also
specify if you want to center the worksheet horizontally or vertically on the page.
Click the Horizontally and Vertically checkboxes in the Center on page
section.
This will vertically and horizontally center the worksheet page when it is printed.
Do you think you have a handle on changing the margins of a worksheet? Good,
because without further ado, we’ll move on to page orientation.
Click the Page tab.
The Page tab appears, as shown in Figure 5-22.
In the Orientation area, click the Landscape option button.
This will change the worksheet’s orientation to Landscape when it is printed.
Click OK.
The Page setup dialog box closes, and the worksheet’s margins and page orientation
settings are changed.
Click the Print Preview button on the Standard toolbar to preview the
Monday worksheet.
A print preview of the Monday worksheet appears on the screen. Unless you have eyes
like a hawk (or a very large monitor) you probably won’t notice the small changes you
made to the worksheet’s margins, but you can certainly tell that the page is using
landscape orientation.
Save your work.

181

Adjusting the Top
Margin

Print Preview
button

Quick Reference
To Adjust Margins:
1. Select File → Page
Setup from the menu and
click the Margins tab.
2. Adjust the appropriate
margins.
To Change a Page’s
Orientation:
1. Select File → Page
Setup from the menu,
and click the Page tab.
2. In the Orientation section,
select either the Portrait
or Landscape option.
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Lesson 5-10: Adding Print Titles
and Gridlines
Figure 5-23

Print area: Select the cell range you
want to print

The Sheet tab of the Page
Setup dialog box.

Print titles: Specify which row(s) or
column(s) should appear at the top
and/or left of every page

Additional print options, such as if the
gridlines, and row and column
headings should be printed

Figure 5-23

If a worksheet requires more than one page to print, it can be confusing to read any
subsequent pages because the column and row labels won’t be printed. You can fix this
problem by selecting File → Page Setup from the menu, clicking the Sheet tab, and telling
Excel which row and column titles you want to appear at the top and/or left of every printed
page.
This lesson will also show you how to make sure your worksheet’s column and row labels
appear on every printed page, and how to turn on and off the worksheet’s gridlines when
printing.

Print Preview
button

1.
2.

3.
4.

Click the Print Preview button on the Standard toolbar.
Excel displays how the Monday worksheet will look when printed. Notice the status
bar displays 1 of 3, indicating that the worksheet spreads across three pages.
Click Next to move to the next page and click near the top of the page
with the pointer.
Notice that the cells on page two don’t have column labels (First, Last, Number of
Bookings, etc.), making the data on the second and third page difficult to read and
understand. You want the column labels on the first page to appear at the top of every
page.
Click Close to close the Print Preview window.
Select File → Page Setup from the menu and click the Sheet tab.
The Sheet tab of the Page Setup dialog box is where you can specify which parts of the
worksheet are printed. Notice the print area—the cell range A1:E61—appears in the
Print area text box. You need to specify which rows you want to repeat at the top of
every page. Move on to the next step to find out how to do this.
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Click the Rows to repeat at top box and click any cell in Row 4.
You may have to click the Collapse Dialog button if the dialog box is in the way. When
you click any cell in row 4, Excel inserts a reference to row 4 in the rows to repeat at
top text box. You aren’t limited to repeating a single row across the top of a page; you
can also select several rows. You can also specify that you want a column(s) to repeat
to the right side of every page.
By default, Excel does not print the horizontal and vertical cell gridlines on
worksheets; however, you can elect to print a worksheet’s gridlines. Printing a
worksheet’s gridlines can sometimes make them easier to read.
Click the Gridlines checkbox.
Now when you print the worksheet, the horizontal and vertical cell gridlines will also
be printed.
Click Print Preview to display how the changes you’ve made to the
worksheet will appear when printed.
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The Collapse Dialog
button temporarily
shrinks and moves the
dialog box so that you
enter a cell range by
selecting cells in the
worksheet. When you
finish, you can click
the button again or
press <Enter> to
display the entire
dialog box.

Click Next to move to the next page and click near the top of the page
with the pointer.
Notice that the heading row now appears at the top of every page, and that gridlines
appear on the worksheet.
Save your work.

Quick Reference
To Print or Suppress
Gridlines:
1. Select File → Page
Setup from the menu and
click the Sheet tab.
2. Add or remove the check
mark in the Gridlines
check box.
To Print Row or Column
Titles:
1. Select File → Page
Setup from the menu and
click the Sheet tab.
2. Specify which row(s) or
column(s) should appear
at the top and/or left of
every page in the
appropriate boxes under
the Title section.
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Lesson 5-11: Changing the Paper
Size and Print Scale
Figure 5-24
The Page tab of the Page
Setup dialog box.

Adjust to: Lets you scale a
worksheet by percentage, such as
80%

Fit to: Lets you scale a worksheet
so it fits on the number of pages
you specify

Figure 5-24

Select the paper size you
want to print to here

This lesson covers two important printing options: how to reduce the size of the printed
worksheet so that it fits on a specified number of pages, and how to print on different paper
sizes. Most people normally print on standard Letter-sized (8½ × 11) paper, but Excel can also
print on other paper sizes, such as Legal-sized (8½ × 14) and most other custom sized paper.

1.

Select File → Page Setup from the menu and click the Page tab.
The Page tab of the Page Setup dialog box appears, as shown in Figure 5-24. You want
to scale the Monday worksheet so that it fits on a single page. Notice under the Scaling
section that there are two different ways you can scale a worksheet:
•

Adjust to: This option lets you scale a worksheet by a percentage. For
example, you could scale a worksheet so that it is 80% of its normal size.

•

2.
3.
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Fit to: This option lets you scale the worksheet so that it fits on the number of
pages you specify. You must specify how many pages wide by tall you want the
worksheet to be printed on. This is usually the easiest and best way to scale a
worksheet.
You want to scale the Monday worksheet so that it fits on a single page.
Click the Fit to option under the Scaling section, click the pages wide
down arrow to select 1 and click the pages tall down arrow to select
1.
Click Print Preview to see how the newly scaled worksheet will look
when printed.
Yikes! The data in the worksheet has become so small that it’s almost unreadable.
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5.
6.
7.
8.
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Click Close to close the Print Preview window.
You return to the worksheet window. You decide using a larger sheet of paper—legal
sized—may help fit the entire worksheet on a single page.
Select File → Page Setup from the menu.
Now change the paper size from letter (the default setting) to legal.
Click the Paper size arrow and select Legal (8.5 x 14 in.) from the
paper size list. In the Orientation area, click the Portrait option button, if
necessary.
Preview the worksheet to see how it will look if it is printed on legal sized paper.
Click Print Preview to see how the worksheet will look when printed.
Click Close when you’re finished.
Save your work.

Quick Reference
To Change the Print Scale:
1. Select File → Page
Setup from the menu and
click the Page tab.
2. Enter percent number in
the % Normal Size text
box or enter the number
of pages you want the
worksheet to fit on.
To Change the Paper Size:
1. Select File → Page
Setup from the menu and
click the Page tab.
2. Click the Paper size list
to select the paper size.
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Lesson 5-12: Protecting a
Worksheet
Figure 5-25
The Protection tab of the
Format Cells dialog box
Figure 5-26
The Protect Sheet dialog
box
Figure 5-27

Figure 5-26

Message informing user
that the current cell is
protected

Figure 5-25

Figure 5-27

Sometimes you may want to prevent other users from changing some of the contents in a
worksheet. For example, you might want to allow users to enter information in a particular
cell range, without being able to alter the labels or formulas in another cell range in the same
worksheet. You can protect selected cells so that their contents cannot be altered, while still
allowing the contents of unprotected cells in the same worksheet to be changed. You can
protect cells by locking them on the Protection tab of the Format Cells dialog box.
Using a protected worksheet is useful if you want another user to enter or modify data in the
worksheet without altering or damaging the worksheet’s formulas and design. In this lesson,
you will learn all about locking and unlocking cells, and protecting worksheets.

1.
Cells are protected by
default.
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Select the cell range D5:E60, select Format → Cells from the menu and
click the Protection tab.
The Protection tab of the Format Cells dialog box appears, as shown in Figure 5-25.
There are only two options on this tab. There are:
•

Locked: Which prevents selected cells from being changed, moved, resized, or
deleted. Notice the Locked box is checked: Excel locks all cells by default.

•

Hidden: Which hides a formula in a cell so that it does not appear in the
formula bar when the cell is selected.
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2.

3.
4.
5.
6.
7.

8.
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Neither of these options has any effect unless the sheet is protected, which you’ll learn
how to do in a minute. Since you want users to be able to modify the cells in the
selected cell range you need to unlock them.
Uncheck the Locked check box and click OK.
The Format Cells dialog box closes and you return to the worksheet. At first, nothing
appears to have changed. You need to protect the worksheet in order to see how cell
protection works.
NOTE: By default, all cells are locked. Before you protect a worksheet, unlock the
cells where you want a user to enter or modify information.
Select Tools → Protection → Protect Sheet from the menu.
The Protect Sheet dialog box appears, as shown in Figure 5-26. You can specify which
parts of the worksheet you want to protect and you can assign a password that users
must enter in order to unprotect the worksheet, once it has been protected.
Click OK.
The Protection Sheet dialog box closes and you return to the worksheet. Move on to
the next step to see how the protected worksheet works.
Click cell A8 and press the <Delete> key.
When you try to delete or modify a locked cell, Excel displays a message informing
you that the cell is protected, as shown in Figure 5-27. Go ahead and click OK. Now
try modifying an unprotected cell.
Click cell D8 and press the <Delete> key.
Since you unlocked this cell in a previous step, Excel lets you clear its contents. Now
that you have an understanding of cell protection, you can unprotect the worksheet.
Select Tools → Protection → Unprotect Sheet from the menu.
Excel unprotects the Monday sheet. Now you can modify all of the cells in the
worksheet, whether they are locked or not.
Another way you can prevent unauthorized users from viewing or modifying restricted
or confidential areas of your workbooks is to hide them. You can hide rows, columns,
and entire worksheets. To prevent others from displaying hidden rows or columns you
can protect the workbook, as shown in Step 3.
Save your work.

Quick Reference
To Lock or Hide a Cell or
Cell Range:
1. Select the cell or cell
range you want to protect
or hide.
2. Select Format → Cells
from the menu and click
the Protection tab.
Or…
Right-click the selected
cell or cell range and
select Format Cells from
the shortcut menu.
3. Add or remove check
marks in the Locked and
Hidden check boxes to
specify if the cell or cell
range should be locked or
hidden.
To Protect a Worksheet:
1. Select Tools →
Protection → Protect
Sheet from the menu.
2. Select the appropriate
options for what you want
to protect.
3. (Optional) Enter a
password.
To Unprotect a
Worksheet:
• Select Tools →
Protection → Unprotect
Sheet from the menu.
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Lesson 5-13: Hiding Columns,
Rows and Sheets
Figure 5-28
Selecting and hiding the F
column.
Figure 5-29
The F column is hidden
from view.
Figure 5-30
The Unhide dialog box,
used to unhide individual
sheets.

Figure 5-28

Figure 5-29

The F column is
hidden from view.

Figure 5-30

In addition to protecting cells, Excel also gives you the ability to hide individual columns,
rows or sheets. Hiding a worbook's contents is the Excel equivalent of stuffing paperwork into
your desk drawers: if you feel your screen is too cluttered with data, you can make part of
your workbook disappear without actually deleting it.
Hiding data makes it easier to work with large, unwieldy workbooks. If you know you won’t
be working with a particular row or column, you can hide it while you enter data and then
unhide it later. The same goes for individual sheets. If you know you will only be working
with the Monday and Tuesday sheets, it makes sense to hide the Wednesday, Thursday and
Friday sheets so you don’t accidentally enter data there. If you know you will be printing a
workbook or turning it in to a presentation, you can hide sensitive data, such as a column that
contains social security numbers. Let’s try hiding a column:

1.
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Select the Tuesday sheet tab. Right-click the Column F heading and
select Hide from the shortcut menu.
The F column disappears from the worksheet. It’s not deleted, it’s merely hidden from
view. Notice how the column headings now go from E to G, skipping the F column.
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2.

3.
4.

5.

NOTE: If a worksheet is protected, you cannot hide or unhide columns or rows.
Select the E and G columns by clicking and dragging the pointer across
the column headings. Once the column headings are selected, right-click
either of the column headings and select Unhide from the shortcut
menu.
The F column reappears. You can also hide and unhide other columns or rows in the
same manner. Hiding a sheet is a lot like hiding a column.
Select the Wednesday sheet tab and select Format → Sheet → Hide.
Excel hides the Wednesday sheet. You cannot hide a sheet by right-clicking a sheet’s
tab. Now let’s unhide the sheet:
Select Format → Sheet → Unhide. In the Unhide dialog box, select
Wednesday.
The Wednesday sheet reappears. You can hide more than one sheet at a time. Just
repeat the method in Step 3.
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Use the Format menu
to hide or unhide a
sheet.

NOTE: If you protect a sheet, you can still hide it. However, if your protect an entire
workbook, you cannot hide or unhide an individual worksheet.
Save your work.

Quick Reference
To Hide a Column or Row:
1. Right-click the column
heading or the row
heading.
2. Select Hide from the
shortcut menu.
Or…
Select the Column or Row
and select Format →
Columns (or Rows) →
Hide from the menu
To Hide a Sheet:
1. Select the sheet you want
to hide.
2. Select Format → Sheet
→ Hide.
To Unhide a Sheet
• Select Format → Sheet
→ Unhide. In the Unhide
dialog box, select the
sheet you want to unhide.
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Lesson 5-14: Viewing a Worksheet
and Saving a Custom View
1.

Figure 5-31

Displays the worksheet using the
selected custom view

The Custom View dialog
box

Adds the print and view
settings to a custom view

Figure 5-32

Deletes the selected
custom view

Adding a Custom View.
Figure 5-31

Figure 5-32

Changing the print settings, zoom level, and workbook appearance every time you view or
print a workbook can get old. By creating a custom view, you can save the view and print
settings so you don’t have to manually change them. A custom view saves the following
settings:
•

Any print settings, including the print area, scale level, paper size and orientation.

•

Any view settings, including the zoom level, if gridlines should be displayed, and any
hidden worksheets, rows, or columns.

•

Any filters and filter settings.

This lesson explains how to create and work with a custom view, and zoom in (magnify) and
out of a worksheet, and how to view a worksheet in Full Screen mode.

Zoom list

1.
2.
3.
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Click the Zoom list arrow on the Standard toolbar and select 75%.
The worksheet appears on-screen at a magnification of 75 percent, allowing you to see
more of the worksheet on screen. However, the reduced magnification makes the
worksheet a bit more difficult to read.
Click the Zoom list arrow on the Standard toolbar and select 100%.
The worksheet returns to the normal level of magnification. You can also see more of a
worksheet by dedicating 100 percent of the screen to the worksheet in full screen
mode.
Select View → Full Screen from the menu.
All the familiar title bars, menus, and toolbars disappear and the worksheet appears in
full screen mode. Full screen mode is useful because it devotes 100 percent of the
screen real estate to viewing a worksheet. The disadvantage of full screen mode is all
the Excel tools: the toolbars, status bar, etc. are not as readily available. You can still
access the menus, although you can no longer see them, by clicking the mouse at the
very top of the screen.
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Click the Close Full Screen button floating over the worksheet.
The full screen view closes and you are returned to the previous view. Next, save the
current view and a custom view. Here’s how:
Select View → Custom Views from the menu.
The Custom Views dialog box appears, as shown in Figure 5-27. Any saved views for
the current worksheet are listed here. You want to save the current, generic view of the
Monday worksheet.
Click Add.
The Add View dialog box appears, as shown in Figure 5-31. You must enter a name for
the current view, and decide if you want to include the worksheet’s print settings and/or
any hidden rows, columns and filter settings.
Type Normal in the Name box and click OK.
Excel saves the custom view and closes the dialog box. Now you want to create
another view of the worksheet—one that uses Portrait orientation and hides the
Commissions column.
Right-click the Column I heading and select Hide from the shortcut
menu.
Excel hides the I column.
Select File → Page Setup from the menu, click the Page tab, select the
Landscape option under the Orientation section, and click OK.
Save the settings you made to the worksheet in a custom view.
Select View → Custom Views from the menu.
The Custom Views dialog box appears.
Click Add, type No Commission in the Name box and click OK.
Excel saves the custom view and returns you to the worksheet. Now try retrieving one
of your custom views.
Select View → Custom Views from the menu, select Normal, and click
Show.
Excel displays the worksheet using the Normal custom view. Notice that the
commission column is no longer hidden.
Click the Print Preview button on the Standard toolbar to preview the
worksheet.
Excel displays a preview of the Monday worksheet. Notice that the worksheet is
landscape oriented—the orientation setting you saved in the Normal custom view.
Save and close the current workbook.
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Quick Reference
To Create a Custom View:
1. Setup the worksheet’s
appearance and print
settings.
2. Select View → Custom
Views from the menu.
3. Click Add and give the
view a name.
To Use a Custom View:
• Select View → Custom
Views from the menu,
select the view you want
to use and click Show.
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Lesson 5-15: Working with
Templates
Figure 5-33
Saving a workbook as a
Template.
Figure 5-34
The New dialog box.

Figure 5-33

Figure 5-34

A Workbook
Template

If you find yourself recreating the same type of workbook over and over, you can probably
save yourself some time by using a template. A template is a workbook that contains standard
data such as labels, formulas, formatting, and macros you use frequently. Once you have
created a template, you can use it to create new workbooks, which saves you time since you
don’t have to enter the same information again and again. Creating a template is easy—you
simply create the template, just like you would any other workbook, and then tell Excel you
want to save the workbook as a template instead of as a standard workbook. To create a
workbook from a template, you just select File → New from the menu and select the template
you want to use. Excel comes with several built-in templates for common purposes such as
invoices and expense reports.
In this lesson you will learn how to create a template and how to create a new workbook
based on a template.
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Open the Time Card Form workbook.
This worksheet tracks and totals the number of hours employees work in a week. You
will be saving this worksheet as a template. But first you have to remove the
information in the worksheet that will change: the hours.
Clear the information in the cell range B6:H10.
(Select the cell range B6:H11 and press the <Delete> key.) Now you’re ready to save
the worksheet as a template.
Select File → Save As from the menu.
The Save As dialog box appears. Here you must specify that you want to save the
current workbook as a template. Excel templates are stored with an .XLT extension
instead of the normal .XLS extension (used for Excel workbooks).
Click the Save as type list arrow and select Template from the list, as
shown in Figure 5-33.
Templates are normally kept in a special template folder (usually
C:\ProgramFiles\Microsoft Office\Templates). When you select the Template file
format, Excel automatically changes the file location to save the template in this folder.
The file list window is updated to show the contents of the Template folder.
In the File Name box, type Time Card and click the Save button.
Excel saves the workbook as a template.
Close all open workbooks.
Now that you have created a template, you can use the template to create a new
workbook. Try it!
Select File → New from the menu.
The New dialog box appears as shown in Figure 5-34. Here you can select the template
you want to use to create your new workbook. Excel organizes the templates into
different categories, organized by tabs.
Select the Time Card template, then click OK.
A new workbook based on the Time Care template appears in the document window.
Fill out the time card worksheet by entering various hours for the
employees (use your imagination).
Once you have finished filling out the time card, you can save it as a normal workbook
file.
Click the Save button on the Standard toolbar.
The Save As dialog box appears.
Save the workbook as Week 1 Timecard.
The workbook is saved as a normal Excel workbook.
Close the Week 1 Time card worksheet.
You don’t want to leave the Time Card template on this computer, so delete it.
Select File → New from the menu, right-click the Time Card template
and select Delete from the shortcut menu. Close the New dialog box
when you’re finished.
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Quick Reference
To Create a Template:
1. Either create or open a
workbook that you want to
use for the template.
2. Select File → Save As
from the menu.
3. Select Template from the
Save As type list, give the
template a name, and
click OK to save the
template.
To Create a Workbook
based on a Template:
1. Select File → New from
the menu.
2. Double-click the template
you want to use (you may
have to select it from one
of the tabbed categories).
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Lesson 5-16: Consolidating
Worksheets
Figure 5-35
The Consolidate dialog
box.
Figure 5-36
The Consolidate
command has
summarized the
information from each of
the daily worksheets.

Select the function
Excel will use to
consolidate data

Open other workbook
files that contain data
you want to
consolidate.

Specify the cell
range you want to
consolidate with the
cell ranges listed in
the All references
box
Lists all the cell
references that will
be consolidated

Figure 5-35

Adds the selected cell
range to the All
references list
Deletes the selected
cell range from the All
references list
Uses labels from the
selected cell range to
consolidate by category

Select to update the consolidation data
automatically whenever the data changes in
any of the source areas

Figure 5-36

Earlier in this chapter, you manually created a summary worksheet that summarized
information on other worksheets. You can have Excel automatically summarize or consolidate
information from up to 255 worksheets into a single master worksheet using the Data →
Consolidate command. This lesson will give you some practice consolidating data.

1.

2.
3.
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Open the Lesson 5 workbook.
You should remember this workbook; it’s the one you’ve already worked on that
contains worksheets for each weekday. The first step in consolidating several
worksheets is to select the destination area, the worksheet and cells where the
consolidated data will go.
Activate the Summary worksheet by clicking the Summary tab, and then
click cell A2.
Cell A2 is the first cell in the destination range (where the consolidated information
will go).
Select Data → Consolidate from the menu.
The Consolidate dialog box appears, as shown in Figure 5-35. You can consolidate data
in two ways:
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•
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By Position: In which data is gathered and summarized from the same cell
location in each worksheet.

•

4.

5.
6.

7.
8.
9.
10.
11.

12.

By Category: In which data is gathered and summarized by its column or row
headings. For example, if your January column is column A in one worksheet
and column C in another, you can still gather and summarize the January when
you consolidate by category. Make sure the Top row and/or Left column check
boxes in the Use labels section of the Consolidate dialog box are selected to
consolidate by category.
For this exercise, you will consolidate by category.
Make sure the insertion point is in the Reference text box, then click the
Tuesday tab and select the cell range A4:I60.
The absolute reference Tuesday!$A$4:$I$60 appears in the reference text box. Now
you need to add the selected cell range to the list of information you want to
consolidate.
Click Add to add the selected cell range to the All references list.
The selected cell reference, Monday!$A$4:$I$60, appears in the All references list.
Next, you have to add the next cell range or worksheet you want to consolidate.
Click the Wednesday tab.
When you click the Wednesday tab, Excel assumes the cell range for this worksheet
will be the same as the previously selected Tuesday worksheet, and enters the absolute
Tuesday!$A$4:$I$60 in the reference text box for you. Excel has guessed correctly;
this is the information you want to add to the consolidation list, so you can click the
Add button.
Click Add to add the selected cell range to the All references list.
Now that you know how to add references to the All references list, you can finish
adding the remaining worksheets.
Finish adding the remaining worksheets (Thursday, and Friday) to the
All references list by repeating Steps 6 and 7.
Once you’ve finished adding the cell ranges that contain the information you want to
consolidate, you need to tell Excel you want to consolidate by category.
Add checkmarks to both the Top row and Left column check boxes to
consolidate by category.
If these check boxes were empty, Excel would consolidate the information by position.
There’s just one more thing to do before you consolidate the selected information.
Add a checkmark to the Create links to source data check box.
This will link the consolidated data, ensuring that it is updated automatically if the data
changes in any of the source areas.
Click OK to consolidate the information from the selected worksheets.
The dialog box closes and Excel consolidates the information, totaling the sales for all
the worksheets. You will probably have to adjust the width of any columns that display
########’s so they properly display their contents. Notice Excel also now displays the
outline symbols to the left of the worksheet, as shown in Figure 5-36. We’ll explain
outlining for another lesson.
Exit Excel without saving your work to finish the lesson.

Quick Reference
To Consolidate Data:
1. If possible, start with a
new workbook and select
a cell in that workbook as
the destination for the
consolidated information.
2. Select Data →
Consolidate from the
menu.
3. Select a consolidation
function (SUM is the most
commonly used function).
4. Select the cell range for
the first worksheet (click
the Browse button if you
want to reference another
workbook file) and click
Add.
5. Repeat Step 4 for each
worksheet you want to
consolidate.
6. Select the Left Column
and/or Top Row check
boxes to consolidate by
category. Leave these
check boxes blank to
consolidate by position.
7. Select the Create links to
source data check box if
you want the consolidated
data to be updated.
8. Click OK.
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Chapter Five Review
Lesson Summary
Switching Between Sheets in a Workbook
•

Switch to a worksheet by clicking its sheet tab at the bottom of the screen.

•

Right-clicking the sheet tab scroll buttons lists all the worksheets in a shortcut menu.

•

The sheet scroll tab buttons, located at the bottom of the screen, scroll through the worksheet
tabs in a workbook.

Inserting and Deleting Worksheets
•

To Add a New Worksheet: Select Insert → Worksheet from the menu or right-click on a sheet
tab, select Insert from the shortcut menu, and select Worksheet from the Insert dialog box.

•

To Delete a Worksheet: Select Edit → Delete Sheet from the menu or right-click on the sheet tab
and select Delete from the shortcut menu.

Renaming and Moving Worksheets
•

By default, worksheets are named Sheet1, Sheet2, Sheet3, and so on.

•

To Rename a Worksheet: There are three methods:
(1) Double-click the sheet tab and enter a new name for the worksheet.
(2) Right-click the sheet tab, select Rename from the shortcut menu, and enter a new name for
the worksheet.
(3) Select Format → Sheet → Rename from the menu, and enter a new name for the
worksheet.

•

Move a worksheet by dragging its sheet tab to the desired location.

•

Copy a worksheet by holding down the <Ctrl> key while dragging the worksheet’s tab to a new
location.

Working with Several Workbooks and Windows
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•

Click the Select All button to select all the cells in a worksheet.

•

Switch between open windows by selecting Window from the menu and selecting the name of the
workbook you want to view.

•

Select Window → Arrange All to view multiple windows at the same time.

•

Click a window’s Maximize button to maximize a window, and click the window’s Restore button
to return the window to its original size.

•

To Manually Resize a Window: Restore the window, then drag the edge of the window until the
window is the size you want.

•

To Move a Window: Drag the window by its title bar to the location where you want to position the
window.
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Splitting and Freezing a Window
•

To Split Panes: Drag either the vertical or horizontal split bar or move the cell pointer to the cell
below the row and to the right of the column you want to split and select Window → Split from
the menu.

•

To Freeze Panes: Split the window into panes, then select Window → Freeze Panes from the
menu.

Referencing External Data
•

You can include references to values in other worksheets and workbooks by simply selecting the
worksheet or workbook (open it if necessary) and clicking the cell that you want to reference.

Creating Headers, Footers, and Page Numbers
•

Add headers and footers to your worksheet by selecting File → Page Setup from the menu and
clicking the Header/Footer tab. Select a preset header or footer from the Header or Footer dropdown list or create your own by clicking the Custom Header or Custom Footer button.

Specifying a Print Area and Controlling Page Breaks
•

To Select a Print Area: Select the cell range you want to print and select File → Print Area →
Set Print Area from the menu.

•

To Clear a Print Area: Select File → Print Area → Clear Print Area from the menu.

•

You can insert a manual page break by moving the cell pointer to the cell where the page should
start and selecting Insert → Page Break from the menu.

•

To Adjust Where the Page Breaks: Select View → Page Break Preview from the menu, drag
the Page Break Indicator line to where you want the page break to occur. Select View → Normal
from the menu when you’re finished.

Adjusting Page Margins and Orientation
•

To Adjust Margins: Select File → Page Setup from the menu and click the Margins tab. Adjust
the appropriate margins.

•

To Change a Page’s Orientation: Select File → Page Setup from the menu, and click the Page
tab. In the Orientation section, select either the Portrait or Landscape option.

Adding Print Titles and Gridlines
•

To Print or Suppress Gridlines: Select File → Page Setup from the menu can click the Sheet
tab. Add or remove the check mark in the Gridlines check box.

•

To Print Row or Column Titles: Select File → Page Setup from the menu can click the Sheet
tab. Specify which row(s) or column(s) should appear at the top and/or left of every page in the
appropriate boxes under the Title section.

Changing the Paper Size and Print Scale
•

To Change the Print Scale: Select File → Page Setup from the menu and click the Page tab.
Enter percent number in the % Normal Size text box or enter the number of pages you want the
worksheet to fit on.
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•

To Change the Paper Size: Select File → Page Setup from the menu and click the Page tab.
Click the Paper size list to select the paper size.

Protecting a Worksheet
•

To Protect a Cell or Cell Range: Select the cell or cell range you want to protect, select Format
→ Cells from the menu and click the Protection tab. Check the Locked check box.

•

By default, all cells are locked.

•

You must protect a worksheet to prevent changes to be made to any locked cells. Protect a
worksheet by selecting Tools → Protection → Protect Sheet from the menu and specifying the
areas you want protected.

•

Select Tools → Protection → Unprotect Sheet from the menu to unprotect a worksheet.

Hiding Columns, Rows, and Sheets
•

To Hide a Column or Row: Right-click the column heading or the row heading. Select Hide
from the shortcut menu.

•

To Hide a Sheet: Select the sheet you want to hide. Select Format → Sheet → Hide.

•

To Unhide a Sheet: Select Format → Sheet → Unhide. Select the worksheet you want to
unhide.

Viewing a Worksheet and Saving a Custom View
•

A custom view saves the current appearance of a workbook so that you don't have to change the
settings every time you view or print the workbook.

•

To Create a Custom View: Setup the worksheet’s appearance and print settings, select View →
Custom Views from the menu.

•

To Use a Custom View: Select View → Custom Views from the menu, select the view you want
to use, and click Show.

Working with Templates
•

To Create a Template: Create a new workbook or open an existing workbook you want to use for
the template, select File → Save As from the menu. Select Template from the Save As type list,
give the template a name, and click OK to save the template.

•

To Create a Workbook based on a Template: Select File → New from the menu and select the
template you want to use.

•

Templates are kept in a special template folder (usually C:\ProgramFiles\Microsoft
Office\Templates).

Consolidating Worksheets

 2000 CustomGuide, Inc.

•

You can summarize or consolidate information from multiple worksheets into a single master sheet
with the Data → Consolidate command.

•

To Consolidate Data: If possible, start with a new workbook and select a cell in that workbook as
the destination for the consolidated information. Select Data → Consolidate from the menu and
select a consolidation function (SUM is the most commonly used function). Select the cell range for
the first worksheet (click the Browse button if you want to reference another workbook file) and
click Add. Select the other worksheets you want to consolidate, clicking Add after each one. Select
the Create links to source data check box if you want the consolidated data to be updated.
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Quiz
1. All of the following statements are true except…
A. You can change the order of worksheets in a workbook by dragging their sheet tabs
to new positions.
B. You can rename a sheet by double-clicking its sheet tab.
C. You can switch between worksheets by selecting Window from the menu and
selecting the name of the sheet from the Window menu.
D. You can add and delete worksheets from the workbook.
2. How can you switch between worksheets when there isn’t enough room on
the screen to display all the sheet tabs? (Select all that apply.)
A. Click the Sheet Tab Scroll buttons until the sheet tab you want appears, then click
that sheet tab.
B. Select Window from the menu and select the name of the sheet from the Window
menu.
C. Right-click any sheet tab and select the name of the sheet from the shortcut menu.
D. Press <Ctrl> + <→> or <Ctrl> + <←> to move between the sheets.
3. Formulas can contain references to cells in other worksheets and even in
other workbooks. (True or False?)
4. Which of the following statements is NOT true?
A. You can delete a sheet by right-clicking its sheet tab and selecting Delete from the
shortcut menu.
B. The Select All button, located to in the upper-left corner of the worksheet window,
selects the entire worksheet.
C. You can split a window into several panes by clicking the Panes button on the
Standard toolbar.
D. You can freeze a pane so that it stays in place.
5. You’re trying to print a worksheet that has just a few columns that won’t fit
on a single page. Which of the following methods is the easiest way to get
this worksheet to fit on a single page?
A. Open the Print dialog box (File → Page Setup), click the Page tab, select the Fit to
option and specify that you want the worksheet to fit on one page wide by one page
tall.
B. Open the Print dialog box (File → Page Setup), click the Margins tab, and adjust the
worksheet’s margins.
C. Click the Preview button on the Standard toolbar and click the Shrink to Fit button.
D. Adjust the size of the fonts and the width of the columns in the worksheet.
6. Cells in a worksheet are unlocked by default (True or False?)
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7. Which of the following statements is NOT true?
A. You must protect a document to prevent changes being made to any locked cell.
B. You can lock or unlock a cell or cell range by clicking the Lock button on the
Standard toolbar.
C. You can switch between open workbooks by selecting Window from the menu and
selecting the name of the workbook from the Window menu.
D. Excel normally prints the column and row heading labels on every page of
worksheet.
8. Which of the following options is NOT located in the Page Setup dialog
box?
A.
B.
C.
D.

Page Orientation
Margins
Headers and Footers
Page Break Preview

9. How do you add a new worksheet to a workbook?
A.
B.
C.
D.

Click the New Worksheet button on the Standard toolbar.
New worksheets must be purchased from Microsoft for $.25 a piece.
Right-click any worksheet tab and select Insert from the shortcut menu.
Select New → Worksheet from the menu.

10. How do you set a print area, so that Excel only prints part of a worksheet?
A. Select the area you want to print and select File → Print Area → Set Print Area from
the menu.
B. Select the area you want to print and click the Print Preview button on the Standard
toolbar.
C. Select the area you want to print and click the Print button on the Standard toolbar.
D. There’s isn’t a way of doing this.
11. How can you view and/or add a page header to a worksheet?
A.
B.
C.
D.

Click the Header button on the Formatting toolbar.
Select File → Page Setup from the menu and click the Header/Footer tab.
Select the area you want to print and click the Print button on the Standard toolbar.
There’s isn’t a way of doing this.

12. The page isn’t breaking where you want it to when you print a worksheet.
How can you change this?
A. Click the Break Page button on the Standard toolbar, and then click where you want
the page to break several times with the little hammer icon.
B. Click the cell where you want the page to break and select Window → Freeze Panes
from the menu.
C. Click the Print Preview button on the Standard toolbar and click the Fit to Print
button on the toolbar.
D. Select View → Page Break Preview from the menu and drag the page break indicator
line to where you want the page to break.
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13. How can you hide a row or column?
A.
B.
C.
D.

Right-click the row or column heading and select Hide from the shortcut menu.
Select the row or column heading and select Tools → Hide from the menu.
Cover the row or column with a piece of masking tape.
Select the row or column heading and click the Hide button on the Formatting
toolbar.

14. You want to print a worksheet on legal-sized paper. How can you do this?
A. Select Format → Paper from the menu and select Legal from the Paper Size list.
B. Right-click the Select All button on the worksheet and select Legal Size from the
shortcut menu.
C. Select File → Page Setup from the menu, click the Paper Size tab and select Legal
from the Paper Size list.
D. You need to purchase a legal-sized printer and the legal version of Microsoft Excel.

Homework
1. Open the Homework 5A workbook and save it as “Regional Expenses”.

2. Move the Boston sheet tab in front of the Minneapolis tab.
3. Rename the “Minneapolis” tab “Twin Cities”.
4. Insert two new worksheets with the names “Dallas” and “Totals”
5. Open the Homework 5B workbook. Copy its information to the Dallas worksheet in
your Regional Expenses workbook. Close the Homework 5B workbook when you’re
finished.
6. Go to the Totals worksheet and create a worksheet that summarizes the monthly
expenses for all four regional offices. (Hint: You’ll have to create external references
to do this.)
7. Go to the Twin Cities worksheet, select the range A3:C11 and set it as a Print Area.
8. Add a header to the worksheet that says “Regional Expenses, First Quarter.”
9. Split any worksheet into two panes, freeze the panes, and then remove the split.
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Quiz Answers
1. C. You switch to a worksheet by clicking its sheet tab. You switch between open
workbooks by selecting them from the Window menu.
2. A and C. Clicking the Sheet Tab Scroll buttons displays new sheet tabs, which you
can then click. Right-clicking a sheet tab displays a shortcut menu that lists all the
worksheets in a workbook.
3. True. You can create references to cells in other worksheets and other workbooks by
viewing the worksheet or workbook and selecting the cell(s) you want to reference.
4. C. There isn’t a Panes button on the Standard toolbar.
5. A. Using the Fit to scaling option is by far the easiest method to force the worksheet
to fit on a single page. B and D might work, but they take a lot more time and effort.
6. False. Cells are locked by default. You must unlock them by selecting Format →
Cells from the menu, clicking the Protection tab and removing the check from the
Locked check box.
7. B. There isn’t a Lock button on the Standard toolbar (although adding a Lock button
might not be a bad idea).
8. D. Page Break Preview is located under View → Page Break Preview.
9. C. To add a new worksheet to a workbook right-click any worksheet tab and select
Insert from the shortcut menu.
10. A. To set a print area select area you want to print and select File → Print Area →
Set Print Area from the menu.
11. B. You can add and/or view the page header by selecting File → Page Setup from the
menu and clicking the Header/Footer tab.
12. D. You can change where the page breaks by selecting View → Page Break Preview
from the menu and dragging the page break indicator line to where you want the
page to break.
13. A. You can hide a row or column by right-clicking the row or column heading and
selecting Hide from the shortcut menu.
14. C. To print on legal-sized paper select File → Page Setup from the menu, click the
Paper Size tab and select Legal from the Paper Size list.
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Chapter Six: More
Functions and
Formulas
Chapter Objectives:
•

Create a formula with several operators and cell ranges

•

Use the Formula Palette to enter and edit formulas

•

Create and use range names

•

Select nonadjacent cell ranges

•

Use the AutoCalculate feature

•

Create a conditional formula with the IF function

•

Use the PMT function

•

Display and print formulas in a worksheet

•

Identify and fix formula errors

Chapter Task: Create payroll and mortgage worksheets
Formulas are the heart and soul of a spreadsheet. Without formulas, Excel would be nothing
more than a grid you could use to enter numbers and text. As you will see in this chapter,
formulas can do a lot more than just adding, subtracting, multiplying, and dividing. Excel has
hundreds of different formulas you can use to create complex statistical, financial, and
scientific calculations. The most expensive calculator in the world couldn’t come close to
matching all the functions Excel has.
This chapter is somewhat different from the others in this book: it’s broken into two different
parts. In the first part of this chapter, you will become an expert at creating formulas and
using different types of functions. The second part of this chapter is a reference of the most
commonly used functions, organized by category.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to select cell
ranges.
• How to enter values,
labels, and formulas
into a cell.
• How to reference cells.
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Lesson 6-1: Formulas with Several
Operators and Cell Ranges
Figure 6-1
Entering a formula with
several operators and cell
ranges in cell B19.
Figure 6-2
The completed worksheet.

Figure 6-1

Figure 6-2

We’ll start this chapter by creating some more complicated formulas. First let’s review:
Formulas can contain several values, such as 81 and 3.5; cell references, such as B5 and
C1:D11; operators, such as * (multiplication) + (addition); and functions, such as SUM and
AVERAGE. When you combine several operations and functions into a single formula, Excel
performs the operations in the order shown in Table 6-1: Order in Which Excel Performs
Operations in Formulas. When a formula contains several operators with the same
precedence Excel calculates the formula from left to right. You can change the order Excel
calculates a formula by enclosing the part of the formula you want Excel to calculate first in
parentheses.
You’ll get some practice creating formulas with several references and operators in this lesson
by creating formulas to compute employee 401(K) contributions and net pay.

1.

Remember: All
formulas in Excel must
begin with an equal
sign (=).

2.
3.

4.
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Start Microsoft Excel if necessary, open the workbook Lesson 6A and
save it as Time Card.
This time card calculates the employees weekly payroll for the Duluth North Shore
Travel office. All the information and almost all of the formulas are already here, you
just need to add a few more formulas to complete the timecard workbook. First, you
need to create a formula to calculate how much to deposit to each employee’s 401K
account. North Shore Travel matches the employee’s 401K contribution, so this
formula will be a little trickier than what you’re used to.
Click cell B16 and type =.
Typing an equal sign tells Excel that you want to enter a formula.
Click cell B14, type * and click cell B15 (or you can type B14*B15). Don’t
Press <Enter> after entering the formula!
This part of the formula multiples gross pay (in cell B14) with the percentage the
employees want to deduct for their 401K contribution (in cell B15.) You’re not finished
with the formula yet: remember that North Shore Travel matches any 401K
contributions made by their employees.
Type *2 and press <Enter>.
Excel calculates the total 401K amount, $50. Copy the formula you just created to the
rest of the row.

Chapter Six: More Functions and Formulas

5.
6.

7.
8.

9.
10.
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Copy the formula in cell B16 to the cell range C16:H16.
The worksheet needs one more formula: one to calculate the net pay.
Click cell B19, type = , click cell B14, and type – (minus sign).
Here’s where the formula gets tricky. You can’t directly subtract the 401K amount from
cell B16 since it includes both the employee and company contribution. You will have
to calculate the amount of the employee’s 401K contribution and then subtract it from
the gross pay.
Click cell B14, type * click cell B15 and press <Enter>.
The formula subtracts the amount of the employee deduction (5% of $500, or $25)
from the gross pay. The formula isn’t finished yet—you have to go back and subtract
the Federal Income Tax and Social Security amounts.
Click cell B19 and click the formula bar and type –B17-B18 at the end of
the formula. The complete formula should now read =B14-B14*B15-B17B18. Complete the formula by pressing <Enter>.
Your formula is finished and Excel calculates the net pay for the employee. Wow!
There’s not much money left over, is there?
Copy the formula in cell B19 to the cell range C19:H19.
Compare your worksheet with the one in Figure 6-2.
Save your work.

When you use several operators in a formula, Excel performs the operations in the order
shown in the following table. When a formula contains operators with the same precedence—
for example, if a formula contains both a multiplication and division operator—Excel
calculates them from left to right. To change the order of evaluation, enclose the part of the
formula to be calculated first in parentheses. For example, the formula =(10-5)+(4/2) would
subtract 5 from 10, then divide 4 by 2, and then add the results.

Operations Preformed in this Order

Table 6-1: Order in Which Excel Performs Operations in Formulas
Operator

Description

()

Parentheses change the order of evaluation. For
example:
=(20+5) / (10-5) would add 20 and 5 (25), subtract
10 by 5 (5) and then divide the results to equal 5.
But…
=20+5/10-5 would divide 5 by 10 (0.5), add the result
to 20 (20.5) and then subtract 5 to equal 15.5.

:

Reference Operator

%

Percent

^

Exponent

* and /

Multiplication and division

+ and -

Addition and subtraction

= < > <= >=

Comparison

Quick Reference
To Change the Order in
which Excel Performs
Operations in Formulas:
• Enclose the part of the
formula you want to
calculate first in
parentheses.
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Lesson 6-2: Using the Formula
Palette to Enter and Edit Formulas
Figure 6-3
Select a function category to display
function names grouped by category in
the Function name box.

The Paste Function dialog
box.
Figure 6-4

Click a function name to view the
description of the function and its syntax.

Using the Formula Palette
to enter a formula.

Displays a description and the syntax of
the formula you select in the Function
name box.

Figure 6-3

Figure 6-4

There are several hundred functions available in Excel. Some functions are rather easy to
enter, such as the SUM function, while others are much more difficult. For example, the
syntax for the DB function, which is used do depreciate an asset, is
DB(cost,salvage,life,period,month). Yikes! How are you supposed to remember that? Luckily,
if you use Excel’s Formula Palette you don’t have to. The Formula Palette helps you select,
enter, and edit worksheet functions. To use the Formula Palette all you have to do is click the
Paste Function button on the Standard toolbar.
In this lesson, you will use the Formula Palette to create a simple AVERAGE formula.

1.
2.
Paste Function
button
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3.

Click cell A22, click the Bold button on the Formatting toolbar, type
Average Net Pay, and press <Enter>.
In cell B22 you will use the Paste Function button to help you create a formula that
calculates the average Net Pay.
Click the Paste Function button on the Standard toolbar.
The Paste Function dialog box appears, as shown in Figure 6-3. The Paste Function
dialog box displays a list of functions organized by category.
In the Function category list select Statistical.
The Function name list displays the names of all the statistical function names you can
use in Excel.
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4.
5.

6.
7.
8.

Select AVERAGE from the Function list.
Notice that the bottom of the Paste Function dialog box displays a description and the
syntax of the selected function.
Click OK.
The Paste Function dialog box closes, and the Function Palette appears beneath the
formula bar, as shown in Figure 6-4. The AVERAGE function is actually a very simple
function—the only arguments (parts or values) it requires are the numbers you that you
want to average.
Select the cell range B19:H19.
This range contains the Net Pay for all the employees.
Press <Enter>.
The Function palette completes the formula for you and closes.
Save your work.

The Formula Palette organizes formulas by categories. Table 6-2: Function Categories lists
and describes the different types of function categories that are available.
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The Collapse Dialog
button temporarily
shrinks and moves the
dialog box so that you
enter a cell range by
selecting cells in the
worksheet. When you
finish, you can click
the button again or
press <Enter> to
display the entire
dialog box.

Table 6-2: Function Categories
Category

Description

Most Recently Used

Lists the functions you’ve used most recently.

All

Lists every function available in Excel.

Financial

Lists financial functions to calculate interest, payments, loans, etc.

Date & Time

Lists functions to calculate date and times values.

Math & Trig

Lists math and trigonometry functions, such as SUM, COS, and TAN.

Statistical

Lists statistical functions, to calculate averages, standard deviations, etc.

Lookup & Reference

Lists functions that lookup or reference values.

Database

Lists functions that lookup or calculate values in a list or database.

Text

List functions that can be used with text or labels.

Logical

Lists IF…THEN functions.

Information

List functions that return information about values and the worksheet itself.

User Defined

Lists custom functions that you (or another use) have created.

Quick Reference
To Use the Formula
Palette to Enter or Edit a
Formula:
• Select the cell where you
want to enter or edit a
formula and click the
Paste Function
button on the Standard
toolbar.
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Lesson 6-3: Creating and Using
Range Names
Figure 6-5
Naming a selected cell or
cell range.
Figure 6-6
The selected cell
range, B16:H16, is
named Retirement.

The Create Names dialog
box.
Figure 6-5

Click the Name Box, type a name,
and press <Enter> to name the
selected cell or cell range.

Figure 6-6

You can create a range
name by selecting a
cell range and then
giving it a name in the
Name box in the
Formula bar.

References for cells and cell ranges can sometimes be difficult to read and remember.
Quickly, in the current workbook, to what does the cell range B16:H16 refer? It’s the cell
range that contains the total 401K contributions (both the employee’s and employer’s) for
each employee. Assigning a name to a cell or cell range makes it easier to read, remember,
and use in formulas. So instead of totaling the 401K contributions with the formula,
=SUM(B16:H16), you could use a range name to create the more legible formula,
=SUM(Total401K).
This lesson will show you how to create range names and use them in your formulas. This
lesson also explains how to use column and row heading labels in your formulas, and how
Excel can automatically create range names for you.

1.
2.
The Name
Submenu

3.
4.

 2000 CustomGuide, Inc.

Select the cell range B16:H16.
The selected cell range contains the employer and employee contributions to each
employee’s 401K account. Here’s how to give the selected cell range a meaningful
name, instead of referring to it as B16:H16.
With the cell range B16:H16 still selected, click the Name box in the
formula bar, type Retirement and press <Enter>.
Now when you need to reference the 401(K) amounts, you can use the Range Name
“Retirement” instead of the obscure and hard-to-remember cell reference B16:H16.
Click cell A23, click the Bold button on the Formatting toolbar, type
Total 401K and press <Tab>.
In cell B23, type =SUM(Retirement) and press <Enter>.
Excel calculates the sum of the Retirement range, B16:H16.
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5.
6.

Once you create a Named Range you can quickly select it by picking it from the Name
box in the Formula bar.
Click the Name box arrow and select Retirement.
Excel selects the Retirement range. You don’t have to manually create names; you can
have Excel automatically create them for you.
Select the cell range A5:H11, and select Insert → Name from the menu.
Here’s a brief summary of what each of the items in the Name submenu does:
•

Define: Creates a name for a cell, a cell range, or constant or computed value
that you can use to refer to the cell, range, or value. (This is the same as typing it
directly in the Name box.) You can also delete any existing names.

•

Paste: Inserts the selected name into the formula bar. If the formula bar is
active and you begin a formula by typing an equal sign (=), clicking Paste will
paste the selected name at the insertion point. If the formula bar is not active,
double-clicking a name in the Paste Name box pastes an equal sign (=) followed
by the selected name into the formula bar.

•
•

Create: Creates names by using labels in a selected range.
Apply: Searches formulas in the selected cells and replaces references with
names defined for them, if they exist.

•

7.
8.

9.
10.
11.

Label: Creates names for formulas by using text labels from the rows or
columns of a selected range.
Select Create from the Name menu.
The Create Names dialog box appears, as shown in Figure 6-6. The Create Names will
automatically create range names based on the current selection.
Verify that the Top row and Left column check boxes are checked and
click OK.
The Create Names dialog box closes, and Excel automatically creates names for the
selected cell range. You can verify that Excel created the correct names by clicking the
Name box arrow.
Click the Name Box List arrow.
The column heading names should appear in the Name Box list.
Click anywhere in the worksheet window to close the Name Box list.
You can also use column and row labels in the worksheet to refer to data in formulas—
without having to create any names at all!
Click cell A24, click the Bold button on the Formatting toolbar, type Max
Hourly Rate and press <Tab>.

12. In cell B24, type =MAX(Hourly
13.

Rate) and press <Enter>.

Excel returns the maximum value in the Hourly Rate row, 18.50.
Save your work.
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Name Box List

Quick Reference
To Name a Cell or Cell
Range:
1. Select the cell or cell
range you want to name.
2. Click the
Name box
on the Formula bar, enter
the name, and press
<Enter>.
To Automatically Create
Names:
1. Select the cell or cell
range you want to name.
2. Select Insert → Name
→ Create from the menu.
3. If necessary, change the
check boxes in the Create
Names dialog box.
4. Click OK.
To Change the Cell
Reference of a Name:
1. Select the new cell or cell
range you want to use as
the reference.
2. Select Insert → Name
→ Apply from the menu.
3. Select the name you want
to use on the selected
reference and click OK.
To Delete Names:
• Select Insert → Name
→ Create from the menu,
select the name you want
to delete and click Delete.
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Lesson 6-4: Selecting Nonadjacent
Ranges and Using AutoCalculate
Figure 6-7
Selecting multiple nonadjacent ranges with the
<Ctrl> key.

1. Select the first
cell range

Figure 6-8
Shortcut menu list of
AutoCalculate options.

2. Press and
hold the
<Ctrl> key
while you
select each
additional cell
or cell range.

Figure 6-7

Figure 6-8

AutoCalculate value

This lesson covers two, almost unrelated topics since both of them are so simple and easy to
explain. If you’ve gotten this far in the book you obviously know how to select and use cell
ranges in your formulas. But, how do you select cell ranges that aren’t next to each other?
That’s the first topic explained in this lesson.
The second topic covered in this lesson is how you can use Excel’s nifty AutoCalculate
feature to calculate a total or average of a cell range without entering a formula.

AutoSum button

1.

2.
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Click cell A25, click the Bold button on the Formatting toolbar, type
M-W-F and press <Tab>.
Next you want to total the hours from only the Monday, Wednesday, and Friday rows.
You can select several non-adjacent cell ranges by holding down the <Ctrl> key when
you select the ranges.
Make sure cell B25 is active and click the AutoSum button on the
Standard toolbar.
Excel selects the closest cell with data in it (B24) as the argument for the SUM
function. This isn’t the cell range you want to use in your formula—you want to find
the totals of the Monday, Wednesday, and Friday rows.
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3.

4.

5.
6.

7.
8.
9.

Select Monday’s cell range, B6:H6, press and hold the <Ctrl> key, select
Wednesday’s cell range, B8:H8, and then select Friday’s cell range,
B10:H10. Release the <Ctrl> button when you’re finished.
The nonadjacent ranges in the Monday, Wednesday, and Friday rows are all selected, as
indicated by the shimmering dotted line around each of the columns. Notice the
formula bar displays the cell ranges: =SUM(B6:H6,B8:H8,B10:H10).
Press <Enter>.
Excel calculates the total hours for the Monday, Wednesday, and Friday rows.
On to the second topic covered in this lesson: AutoCalculate. Sometimes you may want
to calculate the total of several cells without actually creating a formula. Excel’s
AutoCalculate makes this incredibly easy; simply select the cell range you want to
total, and the calculation is displayed down on the status bar.
Select the cell range B6:H10.
The AutoCalculate area of the status bar displays the total of the selected cell range:
Sum=240. You can also use AutoCalculate to do other simple and quick calculations.
To change the calculation type, right-click the AutoCalculate area of the status bar.
Right-click the AutoCalculate area of the Status bar.
A shortcut menu appears with a list of the AutoCalculate options:
•

None: Disables AutoCalculate.

•

Average: Calculates the average of the selected cells.

•

Count: Counts the number of non-empty cells.

•

Count Nums: Counts the number of cells that contain numbers.

•

Max: Returns the largest value in a range of cells.

•

Min: Returns the smallest value in a range of cells.

• Sum: Adds all the numbers in a range of cells (the default setting).
You want AutoCalculate to display the average of any selected cells.
Select Average from the AutoCalculate shortcut menu.
AutoCalculate calculates the average for the selected cell range. Return AutoCorrect
back to the default Sum setting.
Right-click the AutoCalculate area of the Status bar and select Sum.
Save your work.
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AutoCalculate,
found in the
Status Bar

Quick Reference
To Select Nonadjacent
Cell Ranges:
• Select the first cell range,
then press and hold the
<Ctrl> key while you
select additional cell
ranges.
To Use AutoCalculate:
• Select the cell range you
want to total or calculate.
The Status bar will display
the results.
To Change the
AutoCalculate Function:
• Right-click the
AutoCalculate area of the
Status bar and select the
function you want
AutoCalculate to use from
the shortcut menu.
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Lesson 6-5: Using the IF Function
to Create Conditional Formulas
Figure 6-9
Creating a conditional
formula using the IF
function and the Formula
Palette.
Figure 6-10
The syntax for the IF
function.
Figure 6-9

=IF(A5>10,A4*.75,A4)
Function
Logical Test
Value or
expression that
can be evaluated
to True or False

Value if True
Value that is
returned if
Logical Test is
True

Value if False
Value that is
returned if
Logical Test is
False

Figure 6-10

This lesson introduces a very useful function, the IF function. The IF function is a conditional
function or logical function because it will evaluate a condition you specify and return one
value if the condition is true and another value if the condition is false. For example, you
could use the IF function in an invoice to create a formula that would subtract a 5 percent
discount from the invoice if the total was more than $500.00, otherwise it wouldn’t subtract
anything.
The IF function contains three parts or arguments, as shown in Figure 6-10. Since you can use
the Formula Palette to help you create IF function formulas you really don’t need to memorize
the syntax of the IF function.

1.
Paste Function
button

2.
3.
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Click cell B17 and press <Delete> to clear the cell contents.
The Federal Income tax rate changes at different income levels. You have determined
that employees who earn $500 or more in a week are subject to a 15 percent tax rate,
while employees who earn less than $500 in a week are subject to a 10 percent tax rate.
You can create a formula using the IF function to evaluate the employee’s earnings and
then multiply it by the appropriate tax rate. The IF function is a little more difficult
than other functions, so use the Formula Palette to help you enter it.
Click the Paste Function on the Standard toolbar.
The Paste Function dialog box appears.
Select Logical in the Function category list, select IF in the Function
name list, and click OK.
The Formula Palette appears, as shown in Figure 6-9. You’re ready to start entering the
IF formula.
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4.

5.

6.
7.
8.
9.
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Type B14>=500 in the in Logical_test text box.
You just entered the first argument of the IF function, which evaluates a statement as
true or false (see Figure 6-10). Here you want to evaluate if the value in B14 is equal to
or greater than $500.
NOTE: Remember, you can also create cell references by clicking the cell or cell
range you want to reference. Click the Collapse Dialog button to collapse the
function palette and select the cell range if the Function Palette is in the way.
The next step is entering true argument of the IF function. The value the function
should enter if the value is equal to or greater than $500.
Select the Value_if_true text box by clicking it or pressing the <Tab>
key, and type B14*.15.
If the values in B14 is equal to or greater than 500, the IF function will multiple the
value in cell B14 by 0.15. Move on to the next step to complete the IF function by
entering the Value if false argument—what the function should do if the value is not
equal to or greater than $500.
Move to the Value_if_false text box by clicking it or pressing the <Tab>
key, and type B14*.1.
If the value in B14 is less than $500, the IF function will multiple the value in cell B14
by 0.10. Compare your Formula palette with the one shown in Figure 6-9.
Click OK to complete the formula.
The Formula palette closes. The IF function in B17 multiplies the Gross Pay by 15%,
since it is equal to or greater than $500.
Copy the formula in cell B17 to the remaining cells in row 17.
After copying the IF formula, notice that those columns with Gross Pay less than $500
are multiplied by 10% instead of 15%.
Save your work and close the current workbook.

Collapse Dialog
Box button

Quick Reference
To Use the IF Function in
a Formula:
• Write the formula using
the syntax
=IF(logical_test,value_if_t
rue,value_if_false).
Or…
1. Click the Paste
Function button on the
Standard toolbar to open
the Formula Palette.
2. Select Logical in the
Function category list,
select IF in the Function
name list, and click OK.
3. Enter the required
arguments for the IF
function.
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Lesson 6-6: Using the PMT
Function
Figure 6-11
The Paste Function dialog
box.
Figure 6-12
The Formula Palette.
Figure 6-13
The PMT Function.
Figure 6-14
Using the PMT function to
calculate monthly loan
payments.

Figure 6-12
Figure 6-11

=PMT(.09/12,36,10000)
Function
Rate
Nper
The interest The number
of payments
rate per
period
Figure 6-13

Pv
The present
value of loan Figure 6-14
amount, or
principal

The PMT function is a very valuable function if you work with real estate, investments, or are
considering taking out a loan. The PMT function calculates the payment for a loan based on
periodic payments and a constant interest rate. For example, say you want to take out a
$10,000 car loan at 8 percent interest and will pay the loan off in four years. You can use the
PMT function to calculate that the monthly payments for such a loan would be $244.13.You
can also use the PMT function to determine payments to annuities or investments. For
example, if you want to save $50,000 in 20 years by saving the same amount each month, you
can use PMT to determine how much you must save.

Paste Function
button

1.

2.
3.

Open the workbook named Lesson 6B and save it as Mortgage Table.
All of the information you need to find the monthly payments has already been
entered. All you have to do use the PMT function to calculate the monthly payment.
The PMT function is a little complicated, so use the Formula Palette to help you enter
it.
Click cell D4 and click the Paste Function button on the Standard
toolbar.
Select Financial from the Function Category list, scroll down the
Function list, select PMT and then click OK.
The Formula Palette appears, as shown in Figure 6-12. You’re ready to start entering
the PMT formula to calculate the monthly mortgage payments. Look at Figure 6-12:
the first argument of the PMT function is the interest rate. Since the Function Palette is
in the way you’ll have to click the Collapse Dialog button to see and reference the cells
on the worksheet.
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4.
5.
6.
7.
8.

9.

10.

11.

12.
13.

Click the Rate Collapse Dialog Box button, click cell C4, and press
<Enter>.
Because you want to calculate monthly payments instead of annual payments, you will
need to divide the annual interest rates by 12.
Type /12 to divide the annual interest rate.
C4/12 should appear in the Rate text box. The next argument in the PMT function is
the Nper—the total number of payments for the loan.
Click the Nper box and type B4*12.
Again, you want to calculate monthly, not annual, payments so you need to multiply
the total number of years by 12. The last step in the PMT formula is entering the Pv—
the principal.
Click the Pv Collapse Dialog Box button, click cell A4, and press
<Enter>.
You’re finished entering the PMT formula, so you can close the Formula Palette.
Click OK.
The Formula Palette closes, and the monthly payment, $1,162.95, appears in cell D4.
Hey! Why does the monthly payment appear as a negative number? It’s because the
PMT formula shows the borrower’s point of view, and therefore the payments are
calculated as a negative cash flow. You can easily change the formula so that it shows a
positive number by editing the formula and placing a minus sign in front of the Pv
value.
Edit the formula in cell D4 by clicking the Formula bar, and adding a
- (minus sign) immediately after the = sign, so that the formula reads
=-PMT(C4/12,B4*12,A4), then click the Enter button on the Formula
bar.
The PMT formula now displays the monthly payments as a positive number. Copy the
formula to find the monthly payments for the other loans.
Copy the formula you just created to the cell range D4:D6.
The PMT formula is copied. Cell D5 displays a monthly payment of $1,208.39 and cell
D6 displays a monthly payment of $1,048.82. Now that you have calculated the
monthly payments for each of the three loans, you can easily calculate even more
information, such as the total interest paid and total amount paid on each loan.
Click cell E4, type =, click cell D4, type *, click cell B4, type *12 so the
formula reads =D4*B4*12, and click the Enter button on the Formula
bar.
Now that you know the total amount of all the loan payments, you can find how much
the total interest will be.
Click cell F4, type =, click cell E4, type -, click cell A4, and click the
Enter button on the Formula bar.
Wow! That interest really adds up, doesn’t it?
Copy the formulas in cells E4:F4 into the cells E5:F7. Compare your
workbook with the one in Figure 6-14.

14. Save your work.
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Collapse Dialog
Box button

Enter button

Quick Reference
To Use the IF Function in
a Formula:
• Write the formula using
the syntax
PMT(rate,nper,pv).
Or…
1. Click the Paste Function
button on the Standard
toolbar to open the
Formula Palette.
2. Select Financial in the
Function category list,
select PMT in the
Function name list, and
click OK.
3. Enter the required
arguments for the PMT
function.
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Lesson 6-7: Displaying and Printing
Formulas
Figure 6-15
The View tab of the
Options dialog box.
Figure 6-16

Click to display
formulas

A worksheet with formulas
displayed.

Figure 6-15

Figure 6-16

Excel normally displays the results of formulas in the worksheet. You have to select a cell and
look in the formula bar if you want to see the cell’s formula. You can have Excel display the
actual formulas in the worksheet cells instead of their results, and learning how to do that is
the topic of this lesson. Once you display a worksheet’s formulas, you can print them for
documentation purposes.

1.
2.
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Select Tools → Options from the menu and click the View tab.
The View tab of the Options dialog box appears, as shown in Figure 6-15.
Under the Windows options section, click the Formulas check box to
select it, then click OK.
The Options dialog box closes. Notice the worksheet columns are widened, and instead
of displaying the results of formulas, they now display the actual formulas, as shown in
Figure 6-16. Since the worksheet columns are so wide, you will have to scroll the
worksheet to see all of the formulas.
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3.
4.
5.
6.
7.
8.

9.

Scroll the worksheet horizontally, until you can see the F column.
You can also print the worksheet with the formulas displayed. For the formulas to be
meaningful when they are printed, however, you need to tell Excel to print the
worksheet row number and column letter headings.
Select File → Page Setup from the menu and click the Sheet tab.
Now specify that you want the row and column headings to be printed.
Click the Row and Column Headings check box and click OK.
Now preview your worksheet to see how it will look when printed.
Click the Print Preview button on the Standard toolbar. Use the
pointer to zoom in and out of the worksheet.
The worksheet will be printed with the formulas and row and column headings
displayed.
Click Close.

217

Print Preview
button

Select Tools → Options from the menu, make sure the View tab is
selected, click the Formulas check box to de-select it, and then click
OK.
Excel displays the results of the formulas instead of the formulas themselves.
Close the workbook without saving it.

Quick Reference
To Display or Hide
Worksheet Formulas:
1. Select Tools → Options
from the menu and click
the View tab.
2. Check or uncheck the
Formulas check box.
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Lesson 6-8: Fixing Errors in Your
Formulas
Figure 6-17

Trace Precedents

Remove All Arrows

Trace Dependents

New Comment

Clear Validation
Circles

The Auditing toolbar.
Figure 6-18
A worksheet with several
error values.
Figure 6-19
Tracing the source of an
error using the Auditing
toolbar.

Trace Error
Remove Precedent
Arrows
Remove Dependent
Arrows

Figure 6-17

Circle Invalid
Data

Figure 6-18

Figure 6-19

Sometimes Excel comes across a formula that it cannot calculate. When this happens, it
displays an error value (see Table 6-3: Excel Error Values). Error values occur because of
incorrectly written formulas, referencing cells or data that doesn’t exist, or breaking the
fundamental laws of mathematics, like division by 0.
In this lesson, you will learn about the error values you might encounter in Excel, and what
you can do to fix them.

1.

2.

3.
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Open the workbook Lesson 6C.
This workbook, created by a user who is not as proficient in Excel as you are, contains
several common errors that you will likely encounter. Notice cells B7, B8, B10, and
B12 all have a string of #####’s in them, as shown in Figure 6-18. Technically, this
isn’t an error—the numerical information in the cells is just too large to be displayed in
the current cell width. To fix the problem you simply need to widen the column.
Double-click the line between the B and C column headers.
Excel automatically adjusts the width of the selected column so that it can display the
widest cell entry and the #####’s disappear. Next let’s find out what went wrong in cell
D5. This cell displays #DIV/0!. This error code results when Excel tries to divide a
number by zero. You can use the Auditing toolbar to track what caused the error.
Select Tools → Auditing → Show Auditing Toolbar.
The Auditing toolbar appears, as shown in Figure 6-17. The Auditing toolbar helps you
find cells that have a relationship to a formula, displays formulas affected by changes
made to the cell, and tracks down the sources of error values.
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4.

5.

6.

7.
8.

Click cell D5, and then click the Trace Error button on the Auditing
toolbar.
An arrow appears from the active cell, D5, to the cells that caused the error. Notice cell
B5 contains a value, while cell C5 is blank—the source of the #DIV/0! error in cell D5.
To fix the error, you must enter a value in cell C5.
Click cell C5, type 1,and press <Enter>. Click the Remove All Arrows
button on the Auditing toolbar to remove the tracer arrow.
The error value in cell D5 is replaced by the correct calculation of the formula. Next,
look at cell B12, the one that calculates the agent’s commission. Hmm… considering
the commission rate at North Shore travel is 5 percent this commission amount seems
too large. You can investigate this value by tracing the cell precedents—the cells that
are related in some way to the formula.
Click cell B12 and click the Trace Precedents button on the Auditing
toolbar.
Arrows appear from the cell range B4:B10 to cell B12. You can now easily see the
source of the problem: the cell range includes both the sales totals and the sum of the
sales totals, doubling the value used to calculate commission. Fix the error.
Edit the formula in cell B12 so it reads =B10*0.05 and press <Enter>.
The formula now calculates a more reasonable commission amount, $731.70. You can
close the Auditing toolbar since you’re finished using it.
Click the Auditing toolbar’s close button to close it, and then close the
workbook without saving it.
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Trace Error
button

Remove All
Arrows button

Trace Precedents
button

Table 6-3: Excel Error Values lists the error values Excel displays when it encounters an error
and what these rather cryptic-looking error values mean.
Table 6-3: Excel Error Values
Error Value

Description

#####

The numeric value is too wide to display within the cell. You can resize the
column by dragging the boundary between the column headings.

#VALUE!

You entered a mathematical formula that references a text entry instead of a
numerical entry.

#DIV/0!

You tried to divide a number by zero. This error often occurs when you create a
formula that refers to a blank cell as a divisor.

#NAME?

You entered text in a formula that Excel doesn't recognize. You may have
misspelled the name or function, or typed a deleted name. You also may have
entered text in a formula without enclosing the text in double quotation marks.

#N/A

This error occurs when a value is not available to a function or a formula. If
certain cells on your worksheet contain data that is not yet available, enter #N/A
in those cells. Formulas that refer to those cells will then return #N/A instead of
attempting to calculate a value.

#REF!

The #REF! error value occurs when a cell reference is not valid. You probably
deleted the cell range referenced to in a formula.

#NUM!

The #NUM! error value occurs when you used an invalid argument in a
worksheet function.

#NULL!

You specified an intersection of two ranges in a formula that do not intersect.

Quick Reference
To Display or Hide the
Auditing Toolbar:
• Select Tools → Auditing
→ Show Auditing
Toolbar.
To Correct Formula
Errors:
• Refer to Table 6-3: Excel
Error Values.
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Mathematical Functions
You can find any of Excel’s mathematical functions on a typical scientific calculator. If you
still remember your algebra classes, many of these functions, such as SIN, COS, and LOG
should be familiar to you.
Function

Syntax

Description

ABS

=ABS(number)

Determines the absolute value of a number. The
absolute value of a number is the number without its
sign.

ACOS

=ACOS(number)

Returns the arccosine of an angle. ACOS is the inverse
of the COS function.

ASIN

=ASIN(number)

Returns the arcsine of an angle. ASIN is the inverse of
the SIN function.

COMBIN

=COMBIN(number,
number_chosen)

Calculates the number of possible combinations from a
given number of items.
Example: You want to form a two-person team from five
candidates, and you want to know how many possible
teams can be formed.
COMBIN(5, 2) equals 10 teams.

COS

=COS(number)

Returns the cosine of an angle.

DEGREES

=DEGREES(angle)

Converts radians into degrees.

EVEN

=EVEN(number)

Rounds a number up to the nearest even or odd integer.

=EXP(number)

Calculates the value of the constant e (approximately
2.71828182845904) raised to the power specified by its
argument.

ODD
EXP

Example: EXP(2) equals e2, or 7.389056
FACT

=FACT(number)

Calculates the factorial of a number. The factorial of a
number is the product of all the positive integers from
one up to the specified number.
Example: FACT(5) equals 1*2*3*4*5 equals 120

LN

=LN(number)

Calculates the natural (base e) logarithm of a positive
number.

LOG

=LOG(number, base)

Calculates the logarithm of a positive number using a
specified base.

LOG10

=LOG(number)

Calculates the base 10 logarithm of a number.

MOD

=MOD(number,
divisor)

Returns the remainder after number is divided by
divisor.
Example: MOD(3, 2) equals 1, the remainder of dividing
3 by 2.
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Function

Syntax

Description

PI

=PI( )

Returns the value of the constant pi (π), accurate to 14
decimal places.

POWER

=POWER(number,
power)

Raises a number to the specified power.

PRODUCT

=PRODUCT(number1,
number2…)

Multiplies all the numbers in a range of cells

RADIANS

=DEGREES(angle)

Converts degrees to radians.

RAND

=RAND()

Generates a random number between 0 and 1.

RANDBETWEEN

=RANDBETWEEN
(bottom, top)

Generates a random number between the bottom and
top arguments.

ROUND

=ROUND(number,
num_digits)

Rounds a number to a specified number of digits. The
ROUNDDOWN and ROUNDUP function take the same
form as the ROUND function, and as their name implies,
always round either up or down.

SIGN

=SIGN(number)

Determines the sign of a number. Results in 1 if the
number is positive, zero (0) if the number is 0, and -1 if
the number is negative.

SIN

=SIN(number)

Returns the sine of an angle.

SQRT

=SQRT(number)

Returns a positive square root of a number.

SUM

=SUM(number1,
number2…)

Adds all the numbers in a range of cells. You can enter
the SUM function by clicking the AutoSum button on the
Standard toolbar.

TAN

=TAN(number)

Returns the tangent of an angle.

ROUNDDOWN
ROUNDUP

221

222

Microsoft Excel 2000

Financial Functions
Excel’s financial functions are vital if you work with investments or real estate. Financial
functions help determine loan payment amounts, calculate the future value of investments,
and find rates of return.
Function

Syntax

Description

FV

=FV(rate, number of
periods, payment, present
value*, type*)

Calculates the future value of an investment based on
periodic, constant payments and a constant interest rate.

IMPT

=PMT(rate, period,
number of periods,
present value, future
value*, type*)

Calculates the interest payment for over a specified period
of time, with constant periodic payments and a constant
interest rate.
Example: The following formula calculates the interest due
in the first month of a three-year $8000 loan at 10 percent
annual interest:
IPMT(0.1/12, 1, 36, 8000) equals -$66.67

IRR

=IRR(values, guess)

Calculates the internal rate of return of investment. The
investments do not have to be equal, but they must occur
at regular intervals. The internal rate of return is the
interest rate received for an investment consisting of
payments (negative values) and income (positive values)
that occur at regular periods.

Example: You plan to deposit $2,000 a year for 35 into an
IRA, and you expect a 10 percent average rate of return.
=FV(10%,35,-2000) equals $542,048.74

Example: You want to start a business. It will cost $40,000
to start the business, and you expect to net the following
income in the first three years: $10,000, $15,000, and
$20,000. Enter the four values in the cells A1:A4 of the
worksheet, making sure to enter the initial $40,000
investment as a negative value.
IRR(A1:A4) equals 5 percent
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NPV

=NPV(rate, value1,
value2, ...)

Calculates the net present value of an investment by using
a discount rate and a series of future payments (negative
values) and income (positive values).

PMT

=PMT(rate, number of
periods, present value,
future value*, type*)

Calculates the payment for a loan based on constant
payments and a constant interest rate.
Example: The following formula calculates the monthly
payment on a $20,000 loan with an annual interest rate of
9 percent that must be paid in 36-months.
PMT(9%/12, 36, 20000) equals ($635.99)
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Function

Syntax

Description

PV

=PV(rate, number of
periods, payment, future
value*, type*)

Returns the present value of an investment.
Example: An annuity that pays $600 every month for the
next 20 years costs $50,000, and the money paid out will
earn seven percent. You want to determine whether this
would be a good investment. Using the PV function, you
find that the present value of the annuity is:
PV(0.07/12, 12*20, 600, , 0) equals ($77,389.50)

RATE

=RATE(total number of
payments, payment,
present value)

Determines the interest rate per period of an annuity.
Example: You want to calculate the rate of a four-year (48
month) $8,000 loan with monthly payments of $200. Using
the RATE function you find:
RATE(48, -200, 8000) equals 0.77 percent
This is the monthly rate, because the period is monthly.
The annual rate is 0.77%*12, which equals 9.24 percent.

* Optional arguments.
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Date and Time Functions
You can use dates and time in your formulas just like any other value. For example, if cell A1
contained the entry 5/1/99 you could use the formula =A1+100 to calculate the date 100 days
later, which is 8/9/99.
One very important thing to know about working with date and time functions: while Excel
can display dates and times using just about any format, it actually stores dates as
chronological numbers called serial values. So when you think of dates as months, days, and,
years, such as May 1, 1999, Excel thinks of dates in terms of serial numbers, such as 36281.
NOTE: Since the following date and time formulas often return serial number values,
you should format any cells with date or time formulas with data and time
formats that you can easily understand. You can also create custom number
formats to display the results of date formulas. For example, the custom
format dddd would display only the day, Monday, instead of the entire date,
8/9/99.
Function
Syntax
Description
DATE

=DATE(year, month,
day)

Enters a date in the cell.
Example: DATE(99,5,1) equals May 1, 1999.

TODAY

=TODAY( )

A special version of the DATE function. While the DATE
function can return the value of any date, the TODAY
function always returns the value of the current date.

TIME

=TIME(hour, minute,
second)

Enters a time in the cell. Uses a 24-hour (military) time
system.
Example: TIME(14,30) equals 2:30 PM.

TODAY

=NOW( )

A special version of the TIME function. While the TIME
function can return the value of any time, the NOW
function always returns the value of the current time.

WEEKDAY

=WEEKDATE
(serial_number,
return_type)

Returns a day of the week for a specific date. The
serial_number argument is a date value (or reference to
one).
Example: WEEKDAY("2/14/90") equals Wednesday.

YEAR

=YEAR
(serial_number,
return_type)

Returns a value of the year for a specific date. The
serial_number argument is a date value (or reference to
one).
Example: YEAR("3/15/1998”) equals 1998.

MONTH

=MONTH
(serial_number,
return_type)

Returns a value of the month for a specific date. The
serial_number argument is a date value (or reference to
one).
Example: MONTH("3/15/1998”) equals 3.
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Function

Syntax

Description

DAY

=DAY(serial_number,
return_type)

Returns a value of the day for a specific date. The
serial_number argument is a date value (or reference to
one).
Example: DAY("3/15/1998”) equals 15.

HOUR

=HOUR
(serial_number)

Returns hour value for a specific time. The
serial_number argument is a time value (or reference to
one). Uses a 24-hour time format.
Example: HOUR("12:15:45”) equals 12.

MINUTE

=MINUTE
(serial_number)

Returns the minute value for a specific time. The
serial_number argument is a time value (or reference to
one). Uses a 24-hour time format.
Example: MINUTE("12:15:45”) equals 15.

SECOND

=SECOND
(serial_number)

Returns a value of a second for a specific time. The
serial_number argument is a time value (or reference to
one). Uses a 24-hour time format.
Example: SECOND("12:15:45”) equals 45.

HOUR

=HOUR(number,
number_chosen)

Calculates the number of possible combinations from a
given number of items.
Example: You want to form a two-person team from five
candidates, and you want to know how many possible
teams can be formed.
COMBIN(5, 2) equals 10 teams.

DAYS360

=DAYS360(start_date,
end_date)

Returns the number of days between two dates based
on a 360-day year (twelve 30-day months), which is
used in some accounting calculations.
Example: DAYS360("1/30/93", "2/1/93") equals 1
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Statistical Functions
Excel offers a large number of functions to help you analyze statistical data. If they’re not
enough you can also use the Analysis Toolpak, found under Tools → Data Analysis.
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Function

Syntax

Description

AVERAGE

=AVERAGE(number1,
number2…)

Calculates the average, or arithmetic mean, of the
numbers in the range or arguments.

COUNT

=COUNT(number1,
number2…)

Counts the number of cells that contain numbers, including
dates and formulas. Ignores all blank cells and cells that
contain text or errors.

COUNTA

=COUNTA(number1,
number2…)

Counts the number of all nonblank cells, regardless of
what they contain.

COUNTIF

=COUNTIF(range,criteria,
sum_range)

Counts the cells only if they meet the specified criteria.
Similar to SUMIF.

MAX

=MAX(number1,
number2…)

Returns the largest value in a range.

MEDIAN

=MEDIAN(number1,
number2…)

Calculates the median of the numbers in the range or
arguments. The median is the number in the middle of a
set of numbers—half the numbers have values that are
greater than the median, and half have values that are
less.

MIN

=MIN(number1,
number2…)

Returns the smallest value in a range.

MODE

=MODE(number1,
number2…)

Determines which value occurs most frequently in a set of
numbers.

STDEV

=STDEV(number1,
number2…)

Estimates standard deviation based on a sample. The
standard deviation is a measure of how widely values are
dispersed from the average value.

STDEVP

=STDEVP(number1,
number2…)

Estimates standard deviation based on an entire
population.

SUMIF

=SUMIF(range,criteria,
sum_range)

Adds the cells only if they meet the specified criteria.

VAR

=VAR(number1,
number2…)

Estimates variance based on a sample.

VARP

=VARP(number1,
number2…)

Estimates variance based on an entire population.

Example: You want to total the cell range B1:B5 only if the
value in cellA1 is greater than 500.
SUMIF(A1,">500",B1:B5)
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Database Functions
Database functions return results based on filtered criteria. All the database functions use the
same basic syntax =Function(database, field, criteria). The arguments include:
•

Database: The cell range that makes up the list or database.

•

Field: Indicates which column is used in the function. You can refer to fields by their
column label enclosed with double quotation marks, such as "Name" or as a number that
represents the position of the column in the list: 1 for the first column, 2 for the second,
and so on—not the column heading numbers!

•

Criteria: Is a reference to the cell or cell range that specifies the criteria for the function.
For example, you might only want to total records from a certain region.

Function

Syntax

Description

DAVERAGE

=DAVERAGE(database,
field, criteria)

Find the average of values in a column in a list or
database that match the criteria you specify.

DCOUNT

=DCOUNT(database,
field, criteria)

Counts the number of cells that contain numbers from a
list or database that match the criteria you specify.

DGET

=DGET(database, field,
criteria)

Extracts a single record from a database that matches the
criteria you specify.

DMAX

=DMAX(database, field,
criteria)

Returns the largest value from a database that matches
the criteria you specify.

DMIN

=DMIN(database, field,
criteria)

Returns the smallest value from a database that matches
the criteria you specify.

DSTDEV

=DSTDEVP(database,
field, criteria)

Estimates standard deviation based on a sample. The
standard deviation is a measure of how widely values are
dispersed from the average value.

DSUM

=DSUM(database, field,
criteria)

Adds the values in a column in a list or database that
match the criteria you specify.

DVAR

=DVAR(database, field,
criteria)

Estimates variance based on a sample from selected list
or database entries.

Using this criteria
range (A1:A3) in a
database function
would only calculate
records with New York
or Boston in the
Destination field.
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Chapter Six Review
Lesson Summary
Formulas with Several Operators and Cell Ranges
•

If you combine several operators in a single formula, Microsoft Excel performs the operations in
this order: ( ), :, %, ^, * and /, + and -, = <> <= >=.

•

Change the order of precedence by enclosing the part of the formula you want to calculate first in
parentheses.

Using the Formula Palette to Enter and Edit Formulas
•

The Formula Palette assists you in selecting, entering, and editing worksheet functions.

•

To Use the Formula Palette to Enter or Edit a Formula: Select the cell where you want to enter
or edit a formula and click the Paste Function button on the Standard toolbar.

Creating and Using Range Names
•

You can create a range name by selecting a cell range and then giving it a name in the
Name box in the Formula bar.

•

You can refer to names in your formulas. For example, =SUM(Expenses) instead of
=SUM(B3:B35). You can also refer to column and row headings in your formulas.

•

To Automatically Create Names: Select the cell or cell range you want to name and select Insert
→ Name → Create from the menu. Change the check boxes in the Create Names dialog box and
click OK.

•

To Change the Cell Reference of a Name: Select the new cell or cell range you want to use as
the reference and Select Insert → Name → Apply from the menu. Select the name you want to
use in the selected reference and click OK.

Selecting Non-adjacent Ranges and Using AutoCalculate
•

Select cell ranges that aren’t next to each other by selecting the first range, then press and hold the
<Ctrl> key while you select additional cells.

•

The Status bar displays the total (or other selected calculation) of the selected cell range.

•

To Change the AutoCalculate Function: Right-click the AutoCalculate area of the Status bar and
select the function you want AutoCalculate to use from the shortcut menu.

Using the IF Function to Create Conditional Formulas
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•

The IF function evaluates a condition you specify and returns one value if the condition is true and
another value if the condition is false.

•

The syntax for the IF function is =IF(logical_test,value_if_true,value_if_false). It’s much easier to
create IF formulas using the Formula Palette.
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Using the PMT Function
•

The PMT function calculates the payment for a loan based on periodic payments and a constant
interest rate.

•

The syntax for the PMT function is =PMT(rate,nper,pv). It’s much easier to create PMT formulas
using the Formula Palette.

Displaying and Printing Formulas
•

To Display or Hide Worksheet Formulas: Select Tools → Options from the menu and click the
View tab and check or uncheck the Formulas check box.

Fixing Errors in Your Formulas
•

Be able to identify and correct any error values.

•

The Auditing toolbar helps track the cause of an error. Display it by selecting Tools → Auditing →
Show Auditing Toolbar.

Quiz
1. Excel always calculates formulas from left to right. (True or False?)
2. Which of the following formulas will Excel NOT be able to calculate? (Trick
Question!)
A.
B.
C.
D.

=SUM(A1:A5)-10
=SUM(Sales)-A3
=SUM(A1:A5)/(10-10)
=SUM(A1:A5)*.5

3. Which of the following statements is NOT true?
A. The Paste Function button on the Standard toolbar helps you select, enter, and edit
formulas.
B. Range names can contain up to 255 characters, including spaces.
C. You can create a range name by selecting a cell range and entering the range name in
the Name box in the Formula bar.
D. You can refer to range names when you reference cells in your formulas.
4. Which of the following statements is NOT true?
A. You can select cell ranges that aren’t next to each other by selecting the first cell
range, pressing and holding the <Ctrl> key and select any additional cell ranges.
B. =IF(A4 >10, 0.5, 0) is a example of a properly entered formula using the IF function.
C. If the Formula Palette obscures the cells you want to reference in a formula you can
click the Collapse Dialog box to temporarily shrink the Formula Palette.
D. Excel displays the error value “######” when it doesn’t recognize the text you’ve
entered into a formula.
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5. Which is the fastest method to find the total of a cell range?
A. Select a blank cell, click the AutoSum button on the Standard toolbar, select the cell
range and click <Enter>.
B. Select a blank cell, type “=SUM”, select the cell range, type “)” and click <Enter>.
C. Select the cell range and the status bar will display its total.
D. Select the cell range, click the AutoSum button, and the Name box in the Formula
bar will display the total.
6. What does the error #DIV/0! mean?
A.
B.
C.
D.

That a number value is too wide to display within the cell.
That a formula is divided by zero or an empty cell.
That a formula is divided by the letter O.
That you won’t be receiving any stock dividends this year.

7. You are thinking about buying a $250,000 house. What function can help
you calculate your monthly payments?
A.
B.
C.
D.

SUM.
IF.
PMT.
COUNT.

8. Which of the following statements is NOT true?
A. Range names can make it to reference cells. For example, instead of typing (A1:B10)
you could refer to the same cell range by its name, Expenses.
B. You can create a range name by selecting a cell range and then entering its name in
the Name box in the Formula bar.
C. You can’t use range names in a formula.
D. You can use column and row labels in a worksheet to refer to data in formulas.
9. Which of the following formulas would find the smallest number in the cell
range B10 to E25?
A.
B.
C.
D.

=COUNT(B10:E25).
=MIN(B10:E25).
=FIND(B10:E25).
=SMALL(B10:E25).

Homework
1. Open the Homework 6 workbook and save it as “Commission Bonus.”
2. Add formulas in the Total column and Total row that total the appropriate column or
row.
3. Create a formula in cell B10 that calculates the average of the cell range B4:F8.
4. Use AutoCalculate to find the totals sales to W Europe and E Europe. (Hint: select
cell range B4:C8 and look at the status bar.)
5. In cell B14 create a formula that calculates how much of a commission bonus each
agent receives. If an agent’s sales were more than $30,000 they receive a $500 bonus
otherwise they receive nothing. (Hint: You’ll have to use the IF function.) Copy the
formula to the remaining travel agents when you’ve completed the formula.
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6. Display the formulas used in the Commission Bonus worksheet instead of their
results. Change the display back to results when you’re finished.

7. Create a range name: Select the cell range A14:B18 click in the Name box and type
“Commissions”.

Quiz Answers
1. False. If you combine several operators in a single formula, Microsoft Excel
performs the operations in this order: ( ), :, %, ^, * and /, + and -, = <> <= >=.
2. C. The (10-10) portion of the formula would result in 0, causing the formula to
divide by 0, which, if you remember your math classes, is impossible.
3. B. Range names cannot have spaces in them.
4. D. The error value “######”means a numeric value is too wide to display within the
cell. You can resize the column by dragging the boundary between the column
headings.
5. D. AutoCalculate automatically displays the total of any selected cells and is the
fastest and easiest method to find the total of a cell range.
6. B. #DIV/0! is the division by zero error.
7. C. The PMT function calculates the payment for a loan based on periodic payments
and a constant interest rate.
8. C. You can use range names in a formula, for example =SUM(Income).
9. B. =MIN(B10:E25) would find the smallest number.
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Chapter Seven:
Working with Lists
Chapter Objectives:
•

Create a list

•

Use the Data Form to add, find, edit, and delete records

•

Sort a list

•

Use the AutoFilter to filter a list

•

Create a custom AutoFilter

•

Create and use an advanced filter

•

Use data validation when entering records to a list

Chapter Task: Create a list that tracks customers and flights
Another task Excel can perform is keeping track of information in lists or databases. Some
examples of things you might track in a list include telephone numbers, clients, and employee
rosters. Once you create a list in Excel, you can easily find, organize, and analyze its
information with Excel’s rich set of list-management features.
In this chapter, you will learn how to create a list, and then add, modify, delete, and find
information in it. You’ll also learn how you can use Excel’s filter commands to display
specific information, such as records from a specific zip code.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to enter values
and labels.
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Lesson 7-1: Creating a List
Figure 7-1
The list’s field names are
entered in the first row of
the list.
Figure 7-2
A list with two records.

Figure 7-1

Figure 7-2

Fields for the list
appear in columns

Each record is
stored in a row

We’ll start this chapter by creating a list. Lists are organized by records. Each record contains
information about a thing or person, just like an individual listing in a phone book. Records
are broken up into fields which store specific pieces of information. For example, the
LastName field would contain people’s last names, and the Phone field would contain their
phone numbers. In Excel, the columns contain the list’s fields, and the rows contain the list’s
records. See Figure 7-2 for an example of how information is stored in columns and rows.
Creating a list in Excel is easy (almost too easy) and people often create lists without planning
and thinking about how they will work with the information in the future. Think ahead when
you create a list. It’s often difficult to make changes to the structure of the list once there is
information in it. Consult Table 7-1: Guidelines for Creating Lists for some guidance on
creating lists.

1.
2.
3.
4.
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Start Microsoft Excel.
The first step in creating a list is entering the field names for the list. Make sure you
always put the field names in the first row of the list.
Type First in cell A1 and press the <Tab> key to move to the next cell.
Type the remaining field names, each in its own cell, as shown in Figure
7-1.
Enter the information from Figure 7-2 in the second and third rows. Add
an apostrophe (') before you type the Zip Codes (i.e. '55701).
The apostrophe enters the Zip Code as a label instead of a value. If you didn’t add an
apostrophe, Excel would remove the leading zeros (0) from any Zip Codes beginning
(0), such as 01586.
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5.

6.
7.

That’s all there is to creating a list. There are, however a few things you can do to the
list to make working with it a little easier. First, make the field headings stand out more
by making them bold.
Select the cell range A1:H1 and click the Bold button on the Formatting
toolbar.
When working with lists (especially longer ones) it is usually also a good idea to split
and freeze the worksheet window so the field headings always remain visible when
you move through the rest of the worksheet.
Move the pointer over the vertical split box, located at the top of the
vertical scroll bar. When the pointer changes to a , drag the split box
down directly beneath row 1.
Excel splits the worksheet window vertically into two separate panes.
Select Window → Freeze Panes from the menu.
The frozen heading row will always be visible at the top of the worksheet, even if the
list contains thousands of records.
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Split Box

Vertical Split Box

Table 7-1: Guidelines for Creating Lists
Guideline

Why?

Only have one list on a worksheet

Some list management features, such as filtering, can be
used on only one list at a time.

Leave at least one blank column and
one blank row between the list and
other data on the worksheet.

Excel can then more easily detect and select the list when
you sort, filter, or insert automatic subtotals.

Avoid putting blank rows and columns
in the list.

So that Microsoft Excel can more easily detect and select
the list.

Create column labels in the first row of
the list.

Excel uses the labels to create reports and to find and
organize data.

Design the list so that all rows have
similar items in the same column.

This makes the list more meaningful and organized.

Try to break up information as much
as possible.

This gives you more power to sort, filter and manipulate
the list.

Each column should contain the same
type of information.

This will make the list easier to read and understand.

Don’t use duplicate field names.

Duplicate field names can cause problems when entering
and sorting information.

Quick Reference
To Create a List or
Database in Excel:
• Enter the field names as
column headers.
• Enter records as rows.
• Refer to Table 7-1:
Guidelines for Creating
Lists for tips on designing
your lists.
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Lesson 7-2: Using the Data Form
to Add Records
Figure 7-3

Current record
number

The Data Form dialog box.

Click to add a new
record to the list

Total number of
records in the list

Click to delete the current
record from the list
Click to restore any changes you
made in the data form
Click to find records based
on the criteria you specify
Click to close the Data
Form

Displays the previous record
in a list. If you specified
criteria using the Criteria
button, displays the previous
record that matches the
criteria.

Use the scroll bar
when there are too
many fields to fit on the
Data Form

Displays the next record in a
list. If you specified criteria
using the Criteria button,
displays the next record that
matches the criteria.

Figure 7-3

There are two ways to add records to a list. We already covered the first method in the
previous lesson—simply by entering them to the rows in the list range. Once you have entered
the field names for a list, another way to add records to a list is with Excel’s Data Form dialog
box, which you can find under the Data → Form menu. Actually, the Data Form can do a lot
of things, including:
•

Adding records

•

Displaying and scrolling through records

•

Editing existing records

•

Deleting records

•

Finding specific records

This lesson focuses on using the Data Form to display and add records to the current list.
We’ll cover some of the other topics in the next few lessons.

1.
2.
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Make sure the active cell is located somewhere inside the list (the cell
range (A1:H3).
The active cell must be within the list in order to use the Data Form.
Select Data → Form from the menu.
The Data Form dialog box appears, with the first record in the list, John Peters, as
shown in Figure 7-3. One of the benefits of the Data Form is that it makes it easy to
display and navigate through the various records in a list.
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3.
4.
5.
6.
7.

8.

9.
10.

Click the Find Next button to move to the next record in the list.
The next record in the list, Mary Smith, appears in the Data Form.
Click the Find Prev button to move to the previous record in the list.
The previous record, John Peters, appears in the Data Form. You can also use the Data
Form to add new records.
Click the New button.
A blank data form appears. Notice the text “New Record” appears where the record
number counter was, indicating you are adding a new record to the list. The insertion
point appears in the first field of the Data Form.
Type Susan in the First box and press <Tab> to move the insertion point
to the next field.
Go ahead and enter the rest of the information for this record, as shown in the next
step. You should still type an apostrophe (’) before the zip code entries.
Enter the rest of the information for Susan Ratcliff in the fields as follows:
First
Last
Address
City
Susan
Ratcliff
Rt. 8, Box 109
Duluth
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New Record
Indicator

State
Zip
Annual Trips
Income
MN
‘55801
4
$40,000
Press <Tab>after each entry to move to the next field. Go on to the next step when
you’ve finished.
Click the New button to open another blank Data Form, and enter a
record for Harold Williams using the following information:
First
Last
Address
City
Harold
Williams
55 Sugar Lane
Duluth
State
MN

Zip
‘55701

Annual Trips
2

Income
$25,000

Click Close when you have finished entering the information for Harold
Williams.
The Data Form dialog box closes. Notice the records you added are placed at the end
of the list.
Save your worksheet as List Practice and close it.

Quick Reference
To Add Records Using the
Data Form:
1. Make sure the active cell
is located somewhere in
the list and select Data
→ Form from the menu.
2. Click New and enter the
information for the record
in the appropriate text
boxes.
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Lesson 7-3: Finding Records
Figure 7-4
The Criteria Data Form.
Figure 7-5
Finding a record with the
Data Form.
Figure 7-6
The Replace dialog box.

Figure 7-4
Enter the text you
want to find here
Enter the text you
want to replace it
with here

Figure 7-6

Figure 7-5
Find the next
occurrence of the text

Replace the selected
text
Replace every
occurrence of text in
the entire worksheet

A task you will undoubtedly want to do if you work with a list is look up or find a specific
record or records, such as a record for a particular client. Like so many other procedures in
Excel, there are two different ways to search for records in your lists:
•

Using the Edit → Find Command

• Using the Data Form dialog box
This lesson examines both methods; plus you’ll also learn how you can find and replace
information. For example, if you misspell a city’s name throughout a list, you can use the Find
and Replace command to replace every occurrence of the incorrect spelling with the correct
spelling.

1.
2.
3.

 2000 CustomGuide, Inc.

Open the workbook named Lesson 7 and save it as Database List.
One method of finding a specific record in a list is to use the Data Form.
Make sure the active cell is located inside the list and select Data →
Form from the menu.
The Data Form appears, as shown in Figure 7-4.
Click the Criteria button.
A blank data form appears. Notice the text Criteria appears where the record number
counter was, indicating you are working with a Criteria Data Form. To use the Criteria
Data Form, simply type what you want to look for in the appropriate fields and click
the Find Next button.
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4.
5.
6.

7.
8.
9.
10.

Click the State field, type WI and click Find Next.
The Data Form displays the first record it finds in the list that is from WI.
Click Find Next to move to the next record that matches the WI criteria.
The Data Form moves to the next record from WI.
Click Close.
You can also find information in a list using Excel’s standard Find function, located
under Edit → Find. You can also find and replace information. You discover a mistake
in the list: the zip codes for Chekov, MN 55411 should be 55414. Use Replace to fix
the mistake.
Select Edit → Replace from the menu.
The Replace dialog box appears, as shown in Figure 7-6. Enter the incorrect zip code
you want to replace—55411, and the zip code you want to replace it with—55414.
In the Find what box, type 55411, click the Replace with box, and type
55414.
Now you can replace all the incorrect zip codes with the correct zip codes.
Click Replace All.
The Replace dialog box closes, and all of the 55411 zip codes are changed to 55414.
Save your work.
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Other Ways to Find:
• Press <Ctrl> + <F>.
Other Ways to Replace:
• Press <Ctrl> + <H>.

Quick Reference
To Find Records using the
Data Form:
1. Make sure the active cell
is located inside the list
and select Data → Form
from the menu.
2. Click the Criteria button,
enter the information you
want to search for in the
appropriate fields, and
click either the Find Next
or Find Prev button.
To Find Records using the
Edit → Find Command:
1. Select Edit → Find from
the menu.
2. Enter the information you
want to search for and
click the Find Next
button.
To Find and Replace
Information:
1. Select Edit → Replace
from the menu.
2. Enter the text you want to
search for in the Find
what box, and enter the
text you want to replace it
with in the Replace with
box.
3. Click Replace All to
search and replace every
occurrence of the text or
click the Find Next
button to verify each
replacement.
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Lesson 7-4: Deleting Records
Figure 7-7
You can easily delete
selected records in the
Data Form dialog box.

Figure 7-8

Figure 7-8

Click to delete the
current record

Excel asks you to confirm
a record deletion.

Figure 7-7

Deleting records is another basic list or database skill you need to know. For example, if you
used a list to track membership, you keep the list up-to-date by deleting people that are no
longer members. There are two ways to delete records:
•

By using the Data Form dialog box.

• By deleting the row in which the record is stored.
This lesson will give you some practice using each method.

1.
2.
3.
4.
5.
6.
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Make sure the active cell is located inside the list and select Data →
Form from the menu.
You need to delete the record for Nancy Pauls. First, you need to find her record.
Click the Criteria button.
The Criteria Data Form appears.
In the First field box type Nancy, click the Last field box, type Pauls,
and click the Find Next button.
The record for Nancy Pauls appears in the Data Form.
Click the Delete button.
A dialog box appears, asking you to confirm the deletion, as shown in Figure 7-8.
Click OK to confirm the deletion of the record.
The record for Nancy Pauls is deleted, and the next record, Peter Boggins, appears in
the data form.
Click Close to return to the worksheet.
Notice that there are no blank rows where the previously deleted records were. When
you delete a record using the Data Form dialog box, Excel automatically moves the
following rows up to replace the deleted record.
You can also delete records by deleting the record’s row.
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Right-click the Row 12 Heading and select Delete from the shortcut
menu.
The entire row is deleted, and the remaining rows move up to replace the deleted row.

You’re doing great! Believe it or not, you’ve already made it halfway through the chapter and
are well on your way to learning everything there is to know about lists.

Quick Reference
To Delete a Record:
1. Make sure the active cell
is located inside the list
and select Data → Form
from the menu.
2. Find the record you want
to delete using the Find
Next, Find Prev, or
Criteria buttons.
3. Click Delete and confirm
the deletion of the record.
Or…
• Delete the record’s rows
or cells.
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Lesson 7-5: Sorting a List
Figure 7-9
An unsorted list.
Figure 7-10
The same list, sorted in
ascending order by last
name.
Figure 7-11
The Sort dialog box.

Figure 7-9

Figure 7-10

First sort field

Second sort field

Third sort field
Make sure the Header row
option is selected to make
sure the field labels will not
be included in the sort

Figure 7-11

Sort Ascending
button

Sort Descending
button
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Normally, when you enter new records to a list, you add them to the end of the list, in the
order you receive them. That’s fine, but what if you want the list’s records to appear in
alphabetical order? Another of Excel’s useful functions is its ability to sort information. Excel
can sort records alphabetically, numerically, or chronically (by date). Additionally, Excel can
sort information in ascending (A to Z) or descending (Z to A) order. You can sort an entire list
or any portion of a list by selecting it. This lesson will show you several techniques you can
use to sort information in your lists.

1.
2.

Click cell B1 to make it active.
You want to sort the list by the last name, so you have selected the Last field.
Click the Sort Ascending button on the Standard toolbar.
Excel sorts this list, ordering the records in ascending (A-Z) order by last name, as
shown in Figure 7-10. You can also sort a list in descending (Z-A) order.
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Click cell A1 to make it active, then click the Sort Descending button
on the Standard toolbar.
The list is sorted in descending (Z-A) order by the First field.
So far, you have sorted the list by a single field. You can sort lists by up to three fields
by using the Sort dialog box found under Data → Sort.
Select Data → Sort from the menu.
The Sort dialog box appears, as shown in Figure 7-11. You want to sort the list by the
last name and then by the first name.
Select Last from the Sort by list arrow and make sure the Ascending
option is selected.
The list will be sorted in ascending order (A-Z) by the last name. Next, specify the
second field you want to sort the list by.
Click the first Then by arrow, select First, and make sure the
Ascending option is selected.
You’re ready to sort the list.
Click OK.
The Sort dialog box closes and the list is sorted in ascending order, first by the last
names, and then by first names.
Save your work.

The information you sorted in this lesson was in a list, but you can use the same sorting
techniques to sort information anywhere in a worksheet, whether it is in a list or not.
Table 7-2: Sort Examples
Order

Alphabetic

Numeric

Date

Ascending

A, B, C

1, 2, 3

1/1/99, 1/15/99, 2/1/99

Descending

C, B, A

3, 2, 1,

2/1/99, 1/15/99, 1/1/99

Quick Reference
To Sort a List by One
Field:
1. Move the cell pointer to
the column you want to
use to sort the list.
2. Click either the Sort
Ascending button or
Sort Descending
button on the Standard
toolbar.
To Sort a List by More
than One Field:
1. Make sure the cell pointer
is located within the list
and select Data → Sort
from the menu.
2. Select the first field you
want to sort by from the
drop-down list and specify
Ascending or Descending
order.
3. Repeat Step 2 for the
second and third fields
you want to sort by (if
desired).
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Lesson 7-6: Filtering a List with
the AutoFilter
Figure 7-12
Using the AutoFilter on a
worksheet.
Figure 7-13
A list filtered by AutoFilter.

Figure 7-12

Figure 7-13

Sometimes you may want to see only certain records in your lists. By filtering a list, you
display only the records that meet your criteria, and hide the records that do not. For example,
you could filter a client list to display only clients who live in California. There are several
ways to filter your lists. In this lesson, you will learn how to use the fastest and easiest way to
filter a list with Excel’s nifty AutoFilter feature.

1.
2.
AutoFilter list

 2000 CustomGuide, Inc.

Select Data → Filter → AutoFilter from the menu.
List arrows appear to the right of each of the field names.
Click the City list arrow.
An AutoFilter list containing all the cities in the column appears beneath the City field.
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Select Duluth from the AutoFilter list.
Excel filters the list so that only records that contain Duluth in the City field are
displayed, as shown in Figure 7-13. Notice the status bar indicates the number of
records that matched the filter and that the AutoFilter list arrow for the City field
changes colors, indicating it is filtering the worksheet. You can filter a list by more than
one field at a time.
Click the Annual Trips list arrow and select 2 from the AutoFilter list.
Excel narrows the filter so that only those records that contain Duluth in the City field
and 2 in the Annual Trips field are displayed. Notice that the colors of the AutoFilter
list arrows for both the City field and Annual Trip field are different colors, indicating
they are filtering the worksheet. Here’s how to remove the current filter criteria and
display all the records.
Select Data → Filter → Show All from the menu.
All the records are displayed. You can also completely remove an AutoFilter.
Select Data → Filter → AutoFilter from the menu to deselect it.
The AutoFilter is turned off, all the records are listed, and the AutoFilter arrows
disappear from the right of the field headings.
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Number of
Filtered Records

The following table describes those other confusing items that appear in a field’s AutoFilter
list.
Table 7-3: AutoFilter Options
Options

Description

(All)

Display all rows.

(Top 10…)

Display all rows that fall within the upper or lower limits you specify, either by item or
percentage; for example, the amounts within the top 10 percent of income.

(Custom…)

Apply two criteria values within the current column, or use comparison operators other
than AND (the default operator). See the next lesson for more information on this
option.

(Blanks)

Display only rows that contain a blank cell in the column.

(NonBlanks)

Display only rows that contain a value in the column.

Quick Reference
To Filter a List with
AutoFilter:
1. Move the cell pointer
anywhere within the list
and select Data → Filter
→ AutoFilter from the
menu.
2. Click one of the
drop-down arrows in the
field names of the header
row and select an item
you want to use to filter
the list.
To Remove an AutoFilter:
• Select Data → Filter →
AutoFilter from the
menu.

246

Microsoft Excel 2000

Lesson 7-7: Creating a Custom
AutoFilter
Figure 7-14

Show the Top or
Bottom values

Number of values to
display

Select Items or Percent to
display

The Top 10 AutoFilter
dialog box.
Figure 7-15
The Custom AutoFilter
dialog box.

Figure 7-14

Figure 7-15

In the previous lesson, you learned how to use the AutoFilter feature to filter records by
selecting a single value for one or more columns. When you need to filter using more
complicated criteria, you have to use a Custom AutoFilter. Custom AutoFilters are more
difficult to set up and create than ordinary AutoFilters, but they’re much more flexible and
powerful. Custom AutoFilter can filter records based on more than one value, such as clients
in a list that live in California or Oregon and can filter records based on ranges, such as clients
with an income greater than $40,000.
This lesson explains how to create and use a Custom AutoFilter. First, though, we need to
cover one more ordinary AutoFilter topic—how to use the Top 10 option:

1.
2.
3.
4.
5.

 2000 CustomGuide, Inc.

Select Data → Filter → AutoFilter from the menu.
Lists arrows appear to the right of each of the field names. You can use AutoFilter to
filter records with the highest (top) or lowest (bottom) values in a list.
Click the Income list arrow and select (Top 10…) from the AutoFilter
list.
The Top 10 AutoFilter dialog box appears, as shown in Figure 7-14.
Replace the 10 in the middle box with a 5 and click OK.
The records for the clients with the highest five incomes are displayed. Now that you
know which clients have the highest incomes, you can remove the filter.
Click the Income list arrow and select (All) from the AutoFilter list.
The filter is removed and all the records are displayed.
Click the City list arrow and select (Custom…) from the AutoFilter list.
The Custom AutoFilter dialog box appears, as shown in Figure 7-15.
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Make sure the equal sign appears in the City list, then click the top
comparison list arrow and select Duluth.
In the next step, you’ll specify that you want to filter records from Two Harbors as
well.
Click the Or option, click the bottom City list arrow and select equals,
click the bottom comparison list arrow and select Two Harbors.
The custom AutoFilter will now display records in which the City field equals Duluth
or Two Harbors. This type of search criteria is called a Logical Condition. You could
also specify the logical condition criteria in a way so that only records from Duluth and
those with incomes greater than $30,000 are filtered.
Click OK.
The dialog box closes, and only the records from the city of Duluth or Two Harbors are
displayed.
Select Data → Filter → AutoFilter from the menu to deselect it.
The AutoFilter is turned off and all the records are displayed.

Quick Reference
To Use a Custom
AutoFilter:
1. Move the cell pointer
anywhere within the list
and select Data → Filter
→ AutoFilter from the
menu.
2. Click one of the
drop-down arrows in the
field names of the header
row and select Custom
from the list.
3. Specify your filter criteria
in the Custom AutoFilter
dialog box.
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Lesson 7-8: Filtering a List with
an Advanced Filter
Figure 7-16

Copied column
heading labels

Creating the criteria range
for an advanced filter.
Figure 7-17

Criteria
range

The Advanced Filter dialog
box.

List range

Figure 7-16

Specify the list range here
Specify the criteria range here

Figure 7-17

Advanced filtering is by far the most powerful and flexible way to filter your lists. It’s also by
far the most difficult method, and requires a lot of work to set up and use. Advanced Filters
do have several capabilities their simpler AutoFilter cousins lack, including:
•

More complex filtering criteria: You can filter a list based on as many values in as
many columns as you want.

•

The ability to extract the filtered records: Once you have created an Advanced
Filter, you can copy the filtered records to a new location. This is the main reason most
people use Advanced Filters.

To create an Advanced Filter you must start by defining a criteria range. A criteria range is a
cell range, located at the top of your list, which contains the filter criteria. Figure 7-16 shows
an example of a worksheet with a criteria range.

1.

2.

Status Bar
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Select rows 1 through 4, right-click any of the selected row number
headings and select Insert from the shortcut menu.
Excel inserts 4 blank rows above the list. These blank rows will be the Criteria
Range—the cell range that contains a set of search conditions you will use in your
advanced filter. The next step in creating an Advanced Filter is to copy the column
labels from the list you want to filter.
Select the cell range A5:H5, click the Copy button on the Standard
toolbar, click cell A1, and click the Paste button on the Standard toolbar
to paste the copied cells.
Next, you need to specify the criteria for the advanced filter. You want to display only
those clients with incomes greater than $30,000 and that have taken more than five
trips or those clients that have taken more than seven trips.
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Click cell G2, type >5, click cell H2, type >30000, and press <Enter>.
This will filter clients that have taken more than five annual trips and have incomes
greater than $30,000. Next, you want to add a logical condition so that any clients who
have taken more than seven annual trips are also selected, regardless of their income.
Type >7 in cell G3 and press <Enter>.
Compare your worksheet to the one in Figure 7-16. You’re ready to filter the data.
NOTE: Make sure there is always only one blank row between the criteria values and
the list. Having more than one blank row or no blank row at all will cause
your Advanced filter not to work!
Click any of the cells in the list range A5:H21 and select Data → Filter →
Advanced Filter from the menu.
The Advanced Filter dialog box appears, as shown in Figure 7-17. Since you opened
the Advanced Filter with the active cell in the list, the list range is already selected. You
still have to specify what the criteria range is, however.
Click the Criteria range box and select the Criteria range—A1:H3.
You’re ready to apply the advanced filter.
NOTE: Make sure you don’t select the blank row between the criteria range and the
list range, or the Advanced Filter won’t work!
Verify that the Filter the list, in-place option is selected and click OK.
The list range is filtered to match the criteria you specified in the criteria range. Notice
the Status bar displays how many records were found. You remove Advanced Filters
just the same as AutoFilters.
Select Data → Filter → Show All from the menu.
All the records are again displayed.

Table 7-1: Comparison operators and Wildcards
Options

Description

=

Equal to

<>

Not equal to

>

Greater than

<

Less than

>=

Greater than or equal to

<=

Less than or equal to

*

Wildcard--any number of characters in the same position as the asterisk
Example: *east finds "Northeast" and "Southeast"

?

Any single character in the same position as the question mark.
Example: sm?th finds "smith" and "smyth"

Quick Reference
To Create an Advanced
Filter:
1. Your worksheet should
have at least three blank
rows that can be used as
a criteria range above the
list.
2. Copy the column labels
from the list and paste
them in the first blank row
of the criteria range.
3. In the rows below the
criteria labels, type the
criteria you want to
match. Make sure there is
at least one blank row
between the criteria
values and the list.
4. Select Data → Filter →
Advanced Filter from the
menu.
5. In the Advanced Filter
dialog box, specify the list
range and the criteria
range.
6. Make sure the Filter list,
in-place option is selected
and click OK.
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Lesson 7-9: Copying Filtered
Records
Figure 7-18
Copying filtered records in
the Advanced Filter dialog
box.
Figure 7-19
Copying filtered records to
another location in a
worksheet.

Specify a location to copy the
filtered records

Figure 7-18

Figure 7-19

When you filter a list, you may want to copy or extract the records that meet your search
criteria. You must use an Advanced Filter to copy filtered records to a new location.
(Microsoft really should have let you to copy filtered records with the much simpler
AutoFilter as well, but they didn’t, so there’s no use complaining about it.)

1.
2.
3.
4.
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Clear the current criteria in the Criteria Range by selecting the cell range
G2:H3 and pressing the <Delete> key.
Since you will only need one row for your criteria you’ll need to delete one of the rows
in the criteria range.
Right-click the Row 2 heading and select Delete from the shortcut
menu.
Next you need to enter a new set of search criteria. This time you want to find and then
extract all the records that are in the 55701 zip code.
Click cell F2, type 55701 and press <Enter>.
You’re ready to filter the list, only this time instead of filtering the list in-place, you
want to copy the filtered records to a new location in the workbook.
Click any cell in the list range (A5:H27) and select Data → Filter →
Advanced Filter from the menu.
The Advanced Filter dialog box appears, as shown in Figure 7-18. This time, instead of
Filtering the list in place you want to copy it to a new location in the worksheet.
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Verify that the List Range and Criteria Range match what is shown in
Figure 7-18, then select the Copy to another location option in the
Action section.
The last step in extracting the records from the 55701 zip code is to specify where you
want to paste the filtered records.
Click the Copy to box and click cell J5.
This is where the filtered records—those that meet the 55701 zip code criteria you
specified in the Advanced Filter—will be copied.
NOTE: You can only copy filtered records to the same worksheet when you use the
Advanced Filter copy to new location option. If you want to copy the filtered
records to a different sheet in the workbook, or to a different workbook
altogether, you have to: (1) Copy the filtered records to a location on the
current sheet, and (2) Either cut or copy the filtered records to the desired
location in a different worksheet or workbook.
Click OK.
The Advanced Filter dialog box closes and Excel copies the records that meet the
search criteria with the 55701 zip code to the new location.
Save your work.

You deserve a medal if you’ve made it through the last couple lessons in one piece. Creating
and working with advanced Filters are one of the most difficult procedures you can perform in
Excel.

Quick Reference
To Copy or Extract
Filtered Records:
1. Your worksheet should
have at least three blank
rows that can be used as
a criteria range above the
list.
2. Copy the column labels
from the list and paste
them in the first blank row
of the criteria range.
3. In the rows below the
criteria labels, type the
criteria you want to
match. Make sure there is
at least one blank row
between the criteria
values and the list.
4. Select Data → Filter →
Advanced Filter from the
menu.
5. In the Advanced Filter
dialog box, specify the list
range and the criteria
range.
6. Select the Copy to
another location option.
7. Select the Copy to box,
select the cell where you
want to copy the filtered
records and click OK.
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Lesson 7-10: Using Data
Validation
Figure 7-20
The Settings tab of the
Data Validation dialog box.
Figure 7-21
A drop-down list appears
when you select a
restricted cell.

Figure 7-21

Figure 7-22
The Input Message tab of
the Data Validation dialog
box.
Figure 7-23

Figure 7-20

A pop-up message
appears when you select
the restricted cell.

Figure 7-23

Figure 7-22

You can help users enter accurate and appropriate information into your worksheets with
Excel’s Data Validation feature. Data validation restricts the type of information that can be
entered in a cell and can provide the user with instructions on entering information in a cell.

1.
2.
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Click cell I5 to select it, click the Bold button and the Center button on
the Formatting toolbar, type Purpose, and press <Enter>.
You have just entered a new field heading for your list.
Click the Column I header to select the entire column.
You want to restrict any entries to the Purpose field to a list of specific options.
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Select Data → Validation from the menu and click the Settings tab if
necessary.
The Data Validation dialog box appears, as shown in Figure 7-20. You want to provide
the user with a list of entries they can select from for the Purpose.
Click the Allow list arrow, select List, then click the Source box and
type Business, Pleasure, Other, Not Stated, as shown in Figure
7-20. Make sure the In-cell dropdown checkbox is checked to display
the list of valid entries whenever a cell in the Purpose column is selected
You’re ready to test your data validation rules.
Click OK, then click cell I6.
Notice a dropdown list arrow appears to the right of the cell.
Click the dropdown list arrow and select Pleasure from the list.
Excel enters the Pleasure option from the list. Move on to the next step to see what
happens if you type an invalid entry.
Make sure cell I6 is selected, type Unknown, and press <Enter>.
A warning dialog box appears, preventing you from entering invalid information.
A list is just one way of validating data—there are many other ways to restrict data
entry. In the next step, you will use the Validation feature to verify that entries made to
the State column use two-digit state abbreviations.
Click the Column E column header to select the entire column, then
select Data → Validation from the menu.
The Data Validation dialog box appears. You must specify that any entries in the
selected cells must contain no more or no less than two digits.
Click the Allow list arrow, select Text Length, click the Minimum
textbox and type 2, and then click the Maximum textbox and type 2.
You can also use the Data Validation dialog box to provide a user filling out your form
with helpful information or feedback.
Click the Input Message tab.
The Input Message tab appears, as shown in Figure 7-21.
Click the Input Message textbox, type Enter the client’s state
of residence and click OK.
The dialog closes. Test out the data validation options for the state column.
Click cell E6.
The message “Enter the client’s state of residence” you entered in the Data Validation
dialog box appears next to the cell, as shown in Figure 7-23.
Save your work and exit Excel.
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Quick Reference
To Use Data Validation:
1. Select the cell or cell
range you want to
validate.
2. Select Data →
Validation from the
menu.
3. Click one or more of the
three tabs and change the
necessary settings.
Setting: Specify the type
of data the cell will
accept.
Input Message: Specify
a message to appear
when the cell is selected.
Error Alert: Specify a
message that appears if
invalid data is entered.
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Chapter Seven Review
Lesson Summary
Creating a List
•

To Create a List in Excel: Enter the field names as column headers and records as rows.

Using the Data Form to Add Records
•

To Add Records to a List Using the Data Form: Make sure the active cell is located somewhere
in the list and select Data → Form from the menu. Click New and enter the information for the
record in the appropriate text boxes.

Finding Records
•

To Find Records using the Data Form: Make sure the active cell is located inside the list and
select Data → Form from the menu. Click the Criteria button, enter the information you want to
search for in the appropriate fields, and click either the Find Next or Find Prev button.

•

To Find Records using the Edit → Find Command: Select Edit → Find from the menu. Enter
the information you want to search for and click the Find Next button.

•

To Find and Replace Information: Select Edit → Replace from the menu. Enter the text you
want to search for in the Find what box, and enter the text you want to replace it with in the
Replace with box. Click Replace All to search and replace every occurrence of the text or click
the Find Next.

Deleting Records
•

To Delete a Record with the Data Form: Make sure the active cell is located inside the list and
select Data → Form from the menu. Find the record you want to delete using the Find Next, Find
Prev, or Criteria buttons, click Delete and confirm the deletion of the record.

•

To Delete a Record Directly in the Worksheet: Delete the record’s rows or cells.

Sorting a List
•

To Sort a List by One Field: Move the cell pointer to the column you want to use to sort the list
and click either the Sort Ascending button or Sort Descending button on the Standard
toolbar.

•

To Sort a List by More than One Field: Make sure the cell pointer is located within the list and
select Data → Sort from the menu. Select the first field you want to sort by from the drop-down list
and specify Ascending or Descending order. Select the second and third fields you want to sort by
(if desired).

Filtering a List with the AutoFilter
•
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AutoFilter displays only the records that meet your criteria, and hides the records that do not.
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•

To Filter a List with AutoFilter: Move the cell pointer anywhere within the list, select Data →
Filter → AutoFilter from the menu, and select the filter criteria from the drop-down arrows in the
field names of the header row.

•

To Remove an AutoFilter: Select Data → Filter → AutoFilter from the menu.

Creating a Custom AutoFilter
•

A Custom AutoFilter allows you to filter records based on more than one value or a range.

•

To Use a Custom AutoFilter: Move the cell pointer anywhere within the list and select Data →
Filter → AutoFilter from the menu, click one of the drop-down arrows in the field names of the
header row and select Custom from the list. Specify your filter criteria in the Custom AutoFilter
dialog box.

Filtering a List with an Advanced Filter
•

Advanced filters are difficult to set up, but they enable you to filter a list based on as many values
in as many columns as you want and copy the filtered records to a new location.

•

To Create an Advanced Filter: Your worksheet should have at least three blank rows that can be
used as a criteria range above the list. Copy the column labels from the list and paste them in the
first blank row of the criteria range. In the rows below the criteria labels, type the criteria you want
to match (make sure there is at least one blank row between the criteria values and the list). Select
Data → Filter → Advanced Filter from the menu, specify the list range and the criteria range,
make sure the Filter list, in-place option is selected and click OK.

Copying Filtered Records
•

To Copy or Extract Filtered Records: Set up an Advanced Filter and enter the filter criteria.
Select Data → Filter → Advanced Filter from the menu and specify the list range and the criteria
range. Select the Copy to another location option, Select the Copy to box, select the cell where
you want to copy the filtered records, and click OK.

Using Data Validation
•

Data Validation restricts the type of information that is entered in a cell and provides the user with
feedback and instructions.

•

To Use Data Validation: Select the cell or cell range you want to validate and select Data →
Validation from the menu. Click any or all of the tabs (Settings, Input Messages, and Error Alert)
and change the settings.

Quiz
1. Which of the following statements is NOT true?
A. To create a list, you need to enter the field names in the first row.
B. Each record in a list is stored in a column.
C. Selecting Data → Form from the menu opens the Data Form dialog box, which you
can use to add, modify, find, and delete list records.
D. You can add a new record to the database by entering the data as a new row in the
worksheet, or by selecting Data → Form from the menu, clicking the New button,
and filling out the New Record form.
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2. How can you find specific information in a list? (Select all that apply.)
A.
B.
C.
D.

Click the Find button on the Standard toolbar.
Select Edit → Find from the menu.
Select Tools → Finder from the menu.
Select Data → Form from the menu to open the Data Form dialog box and click the
Criteria button.

3. How can delete a record? (Select all that apply).
A. Select Data → Form from the menu to open the Data Form dialog box, find the
record and click the Delete button.
B. Click the Delete button on the Standard toolbar.
C. Delete the cells or row that contain the record from the worksheet.
D. Select Data → Delete Record from the menu.
4. Which of the following statements is NOT true?
A

You can quickly sort a list by placing the cell pointer in the column/field you want to
sort by and clicking either the Sort Ascending or Sort Descending button on the
Standard toolbar.
B. You can sort by up to three fields at a time by selecting Data → Sort from the menu.
C. To display only records that meet your criteria, select Data → AutoFilter from the
menu.
D. To display only records that meet your criteria, click the AutoFilter button on the
Standard toolbar.

5. You can extract filtered records from a Custom AutoFilter. (True or False?)
6. Which of the following is NOT a step in creating an Advanced filter?
A. Add a criteria range above the list. Make sure it contains the list’s column labels.
B. Add the criteria to the criteria range. Make sure you leave a blank row between the
criteria range and the list.
C. Select Data → Filter from the menu and specify the list and criteria ranges.
D. Select the data you want to use to filter the list by the field’s drop-down lists.
7. Which of the following statements is NOT true?
A.
B.
C.
D.

You must protect the worksheet in order to use Excel’s data validation feature.
Data Validation lets you restrict which type of information is entered in a cell.
You can provide users with information and feedback using Data Validation.
To use Data Validation, select Data → Validation from the menu.

8. How can you apply an AutoFilter to a list?
A. Move the cell pointer anywhere within the list and select Data → Filter → AutoFilter
from the menu.
B. Right-click any column heading in the worksheet and select AutoFilter from the
shortcut menu.
C. Click the AutoFilter button on the Standard toolbar.
D. Add the formula =AUTOFILTER(LIST) somewhere in the list.
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Homework
1. Open the Lesson 11A workbook and save it as “Sales Data”.

2. Use the AutoFilter to display only records that are from the Minneapolis office.
3. Display all the records, then use the AutoFilter to display the top 10 total amounts.
4. Use the Data Form to add a new record with the following information:
Date: 5/3/2000
Last: Schmidt
First: Jamie
Office: St. Paul
Destination: New York
Amount: $700 Tickets: 1
Commission: Yes

Quiz Answers
1. B. Records in a list are stored in rows, not columns.
2. B and D. You can find information in a list by selecting Edit → Find from the menu
or by selecting Data → Form from the menu to open the Data Form dialog box and
click the Criteria button.
3. A and C. You can delete a record by selecting Data → Form from the menu to open
the Data Form dialog box, find the record and click the Delete button. You can also
delete a record by deleting the cells or row that contain the record from the
worksheet.
4. D. There isn’t an AutoFilter button on the Standard toolbar (although it would make
a nice addition).
5. False. You can only extract filtered records from an Advanced filter.
6. D. You specify the criteria for an Advanced filter in the criteria range, so there’s no
need to select the criteria from drop-down lists.
7. A. You don’t have to protect a worksheet to use data validation.
8. A. To apply an AutoFilter to a list move the cell pointer anywhere within the list and
select Data → Filter → AutoFilter from the menu.
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Chapter Eight:
Automating Tasks
with Macros
Chapter Objectives:
•

Record a macro

•

Play a macro

•

Assign a shortcut key and toolbar button to a macro

•

Edit a macro’s Visual Basic code

•

Insert code into an existing macro

•

Declare variables using the DIM statement

•

Prompt for user input

•

Use If…Then statements

Chapter Task: Create and edit several macros
If you find yourself doing the same routine task over and over again you might want to
consider creating a macro to complete the task for you. A macro helps you perform routine
tasks by automating them. Instead of manually performing a series of time-consuming,
repetitive actions, you can record a single macro that does the entire task all at once for you.
This entire chapter is devoted to macros. We start with the basics: learn how to record and
play a macro. Next, you will learn how to assign shortcut keys and toolbar buttons to your
macros. Finally, you’ll move into some advanced topics; how to write and edit macros using
the Visual Basic programming language.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to enter text and
values into cells.
• How to edit, cut, copy,
and paste text.
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Lesson 8-1: Recording a Macro
Figure 8-1

Enter a name for the macro

The Record Macro dialog
box.
Figure 8-2

Specify where you want to
save the macro

The Macro Recorder
toolbar.

Enter a description for the
macro

Figure 8-1 Assign a shortcut key to
the macro
Stop

Figure 8-2

Use relative cell references in the
macro (the macro recorder uses
absolutely references by default)

A macro is a series of Excel commands and instructions that are grouped together and
executed as a single command. Instead of manually performing a series of time-consuming,
repetitive actions in Excel yourself, you can create a macro to perform the task for you. There
are two ways to create a macro: by recording them or by writing them in Excel’s built-in
Visual Basic programming language. This lesson explains the easy way to create a macro—by
recording the task(s) you want the macro to execute for you.
When you record a macro, imagine you’re being videotaped. Everything is recorded—all your
commands, the data you enter, even any mistakes you make! Before you record a macro, you
should write down a script that contains all the steps you want the macro to record. Practice or
rehearse your script a couple times, to make sure it works, before you actually record it. If you
do make a mistake while recording a macro, don’t worry—you can delete the existing macro
and try again or you can edit the macro’s Visual Basic source code and fix the mistake (more
on that later). Let’s get started!

1.

2.
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Open the workbook Lesson 8A and save it as Macro Practice.
In this exercise, you’ll create a macro that inserts the current data into a cell. You can
do this by entering the =TODAY() function (which inserts the current date) into a cell
and then copying the formula and using the Paste Special command to paste only the
formula’s resulting value, because the =TODAY() function displays whatever the
current date is and would keep changing. Writing a formula and using the Paste Special
command is a time-consuming process, however, so you decide to record a macro to
perform this repetitive task for you.
Click cell B3.
This is where you want to insert the current date. You’re ready to start recording your
macro.
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3.

4.
5.

6.
7.
8.
9.
10.
11.

Select Tools → Macro → Record New Macro from the menu.
The Record Macro dialog box opens, as shown in Figure 8-1. You must give your new
macro a name, and if you want, assign a shortcut key to it. Notice the store macro list
box—you can store macros in one of three locations:
•

Personal Macro Workbook: If you want a macro to be available whenever
you use Microsoft Excel, store the macro in your Personal Macro Workbook.

•

New Workbook: Stores the macro in a new workbook.

• This Workbook: Stores the macro in the active or current workbook.
In the Macro name box, type DateStamp, then in the Description box,
type This macro inserts the current date.
Macro names can be no longer than 25 characters and cannot include spaces.
Click OK.
The Record Macro dialog disappears and you return to the worksheet. Notice the
Macro toolbar appears in the document window, as shown in Figure 8-2. The Macro
toolbar indicates that Excel is currently recording everything you type and every
command into the DateStamp macro. Do the next several steps very carefully—you
don’t want to make a mistake and have it recorded in your macro!
Type =Today() and click the Enter button on the Formula bar.
The TODAY() function will display the current date in the active cell. That’s OK for
today, but not for any day after, when the date changes. You need to copy the formula
and then paste the resulting value using the Paste Special command.
Make sure cell B3 is selected and click the Copy button on the Standard
toolbar.
Next, use the Paste Special command to paste the resulting value of the TODAY()
formula in the cell.
Make sure cell B3 is selected and select Edit → Paste Special from the
menu.
The Paste Special dialog box appears.
Select the Values option under the Paste section and click OK.
The Paste Special dialog box closes, and Excel pastes the value of the TODAY()
formula in cell B3. Next, format the cell.
Click the Center button and then the Bold button on the Formatting
toolbar.
The active cell is now boldfaced and centered. This is the last step you want in the
macro, so you can stop the macro recorder.
Click the Stop button on the Macro Record toolbar.
The Macro toolbar closes indicating that you are no longer recording a macro.
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Enter button

Stop button

Quick Reference
To Record a Macro:
1. Select Tools → Macro
→ Record New Macro
from the menu.
2. Enter a name and
description for the macro.
3. If you want, assign a
shortcut keystroke to your
macro and specify where
you want your macro to
be saved.
4. Click OK and carefully
perform the actions you
want to include in your
macro.
5. Click the Stop button
on the Macro Record
toolbar when you’re
finished recording your
macro.
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Lesson 8-2: Playing a Macro and
Assigning a Macro a Shortcut Key
Figure 8-3
The Macro dialog box.
Figure 8-4
Assigning a shortcut key
to a macro in the Macro
Options dialog box.

Figure 8-4

Figure 8-3

In this lesson you get to play the DateStamp macro you recorded in the previous lesson. Once
you have created a macro you can assign a keystroke shortcut to it, such as <Ctrl> + <D>, to
make it faster and easier to access—something you’ll learn in this lesson.

1.
2.
3.

4.
5.
6.
7.
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Click cell C3.
You want to enter the current date in this cell. Watch how your DateStamp macro saves
you time.
Select Tools → Macro → Macros from the menu.
The Macro dialog box appears, as shown in Figure 8-3. The Macro dialog box displays
the available macros you can run.
Click the DateStamp from the Macro Name list macro and click Run.
The DateStamp macro you recorded in the previous lesson runs, automatically entering
the TODAY() function, then copying and pasting its resulting value, and finally
formatting it.
If you use a particular macro frequently, you can assign it a keyboard shortcut. For
example, instead of selecting Tools → Macro → Macro from the menu, after selecting
the macro and clicking the Run button you could run the macro simply by pressing a
keystroke shortcut, such as <Ctrl> + <D>.
Select Tools → Macro → Macros from the menu.
The Macro dialog box appears.
Select the DateStamp macro and click the Options button.
The Macro Options dialog box appears, as shown in Figure 8-4. Here’s how you can
assign a shortcut key to the macro:
Click the Shortcut key box, type d, and click OK.
Close the Macro dialog box and try running the macro using your new <Ctrl> + <D>
shortcut key.
Click the Macro dialog box’s close button.
The Macro dialog box closes.
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8.
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Click cell D3 and press <Ctrl> + <D>.
Excel executes the DateStamp macro and inserts today’s date in the active cell.

Quick Reference
To Play a Macro:
1. Select Tools → Macro
→ Macros from the
menu.
2. Select the macro you
want to play and click
Run.
To Assign a Shortcut Key
to a Macro:
1. Select Tools → Macro
→ Macros from the
menu.
2. Select the macro you
want to assign a shortcut
keystroke to and click
Options.
3. Enter the keystroke in
Shortcut key box.
To Delete a Macro:
1. Select Tools → Macro
→ Macros from the
menu.
2. Select the macro and
click Delete.
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Lesson 8-3: Adding a Macro to a
Toolbar
Figure 8-5
Adding a macro to the
Standard toolbar.
Figure 8-6
The Assign Macro dialog
box.
Figure 8-7
Selecting a button image
from the Button Shortcut
menu.

Drag a command
from the Customize
dialog box to its
desired location on
any toolbar.

Figure 8-5

Figure 8-6
Figure 8-7

Another way to make macros fast and easy to access is by adding them as buttons to a toolbar.
In this lesson, you will add the DateStamp macro you’ve created to a button on the Standard
toolbar.

1.

2.
Custom button
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Select View → Toolbars → Customize from the menu and click the
Commands tab.
The Customize dialog box appears, as shown in Figure 8-5. The Commands tab lets
you select commands and macros you want to add on your toolbars. The commands are
organized by categories, just like Excel’s menus.
In the Categories list, scroll to and click the Macros category.
Notice the Commands list is updated and lists a custom menu item and a custom
button, as shown in Figure 8-5.
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3.
4.
5.
6.
7.

8.
9.
10.
11.
12.
13.
14.

Drag the Custom button to the very beginning of the Standard toolbar,
as shown in Figure 8-5.
Now you need to assign a macro to the button.
With the Customize dialog box still open, right-click the custom button
you just added and select Assign Macro from the Shortcut menu.
The Assign Macro dialog box appears, as shown in Figure 8-6.
Select the DateStamp macro and click OK.
The DateStamp macro is assigned to the selected button. Follow the next step to give
the DateStamp button a more meaningful name and image.
With the Customize dialog box still open, right-click the Custom button
you just added.
The button shortcut menu appears.
Select the Name textbox from the Shortcut menu and replace the text
&Custom Button with Date Stamp.
Don’t press <Enter> yet. You still need the shortcut menu open in order to change the
image on the button.
Select Change Button Image from the Shortcut menu, and select
from the list of pictures, as shown in Figure 8-7.
You’re finished adding the DateStamp macro to a button on the Standard toolbar, so
you can close the Customize dialog box.
Click Close to close the Customize dialog box.
The Customize dialog closes. Now test the new toolbar button.
Move the pointer over the Date Stamp button on the Standard toolbar.
After a moment, a tooltip appears by the button with its name—Date Stamp.
Click cell E3 and click the Date Stamp button on the Standard toolbar.
Excel executes the DateStamp macro and inserts today’s date in the active cell. Now
that you know how to add macros to toolbar buttons, you can remove the Date Stamp
button from the Standard toolbar.
Select View → Toolbars → Customize from the menu.
Now that the Customize dialog is displayed, you can remove the Date Stamp button
from the Standard toolbar.
Drag the Date Stamp button off the Standard toolbar.
The Date Stamp button is deleted from the Standard toolbar.
Click Close to close the Customize dialog box.
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Button Shortcut
menu
Quick Reference
To Add a Macro to a
Toolbar:
1. Select View → Toolbars
→ Customize from the
menu.
Or…
Right-click any toolbar or
the menu and select
Customize from the
shortcut menu.
2. Click the Commands tab.
3. Select the Macros
category from the
Categories list and drag
the Custom button to the
desired toolbar.
4. Right-click the custom
button, select Assign
Macro from the shortcut
menu and select the
macro you want to assign.
To Remove a Button from
a Toolbar:
1. Select View → Toolbars
→ Customize from the
menu.
2. Drag the button off the
toolbar.
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Lesson 8-4: Editing a Macro’s
Visual Basic Code
Figure 8-8
The Microsoft Visual Basic
Editor.

Figure 8-8

This lesson introduces you to the Visual Basic (also called VB or VBA) programming
language. Visual Basic is the code Excel uses to record macros. Okay, you’re probably
thinking, “You can’t be serious! I can’t program my VCR!” Relax. This lesson is meant to
help you become familiar with the Visual Basic language and the Visual Basic editor so you
can make minor changes to your macros once you have recorded them. Just imagine you’re
learning several words in a foreign language so when you’re presented with a menu you’ll
recognize some of the entrées. Let’s get started, and don’t worry; it’s not going to be nearly
bad as you might think it will be.
The best way to learn about Visual Basic is to view existing code. In this lesson we’ll view
and edit the DateStamp macro.

1.
2.
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Select Tools → Macro → Macros from the menu.
The Macros dialog box appears.
Select the DateStamp macro from the Macro Name list and click Edit.
The Microsoft Visual Basic Editor program appears, as shown in Figure 8-8. Yikes!
You’re probably thinking, “What is all of that complex programming code doing on my
screen?” Those funny-looking words aren’t Hungarian, they’re Visual Basic—the code
or language the macro you recorded is written in. Whenever you record a macro, Excel
writes and saves it in Visual Basic.
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3.

4.
5.
6.
7.
8.
9.
10.

You don’t have to learn Visual Basic to be proficient at Excel, but knowing the basics
can be helpful if you ever want to modify an existing macro. Take a closer look at the
code for the DateStamp macro. Some of the procedures should make a little sense to
you. For example, the line “Selection.Copy” is the copy procedure and the
“Selection.Paste” is the paste procedure.
You decide that you no longer want the DateStamp macro to center and bold the
current cell’s contents. Before you move on to the next step, look at the macro’s code
and see if you can guess which lines of code apply the bold and center formatting.
Find the line of code that says With Selection.
Believe it or not, the portion of code beginning with “With Selection” and ending with
“End Selection” (eight lines down) is the part of the macro that centers and boldfaces
the current selection. The line of code after End Selection, Selection.Font.Bold = True
is what applies bold formatting to the current selection. Since you no longer want the
macro to format or align the selected cell, you can delete all of this code.
Select the block of code beginning with With Selection and ending with
Selection.Font.Bold = True, as shown in Figure 8-8.
Delete the selected text.
Press <Delete> to delete the selected code.
That’s it! You’ve made the necessary modifications so that the DateStamp macro still
enters the current date but will no longer perform any formatting functions.
Click the Save button on the Visual Basic Standard toolbar to save the
code.
Now that you’ve finished editing the macro’s code, you can close the Visual Basic
Editor.
Close the Visual Basic Editor by clicking the close button or selecting
File → Close from the menu.
The Visual Basic Editor window closes and you return to Excel. Try out your newly
modified macro to see if it works.
Click cell A3, then select Tools → Macro → Macros from the menu.
The Macro dialog box appears.
In the Macro Name list, click the DateStamp macro, then click Run.
The modified DateStamp macro runs, this time entering the current date without
formatting the cell.
Save your work.
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Quick Reference
To Edit a Macro’s Visual
Basic Code:
1. Select Tools → Macro
→ Macros from the
menu.
2. Select the macro and
click Edit.
3. When you’re finished
editing the macro’s code
click the Save button and
then close the Visual
Basic Editor window.
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Lesson 8-5: Inserting Code in an
Existing Macro
Figure 8-9
The Macro dialog box.
Figure 8-10
Because of the potential
risk of viruses, you must
enable any macros in a
workbook when you open
it.
Figure 8-11
Copying a portion of code
from the InsertDate macro
and pasting it in the
ExpenseFillIn macro.

Figure 8-9

Figure 8-10

Sub DateStamp()
'
' DateStamp Macro
'
ActiveCell.FormulaR1C1 = "=TODAY()"
Selection.Copy
Selection.PasteSpecial
Paste:=xlValues,
Operation:=xlNone,
SkipBlanks:= False,
Transpose:=False
End Sub

This portion of code of the

Figure 8-11 DateStamp macro’s code is copied…

Sub ExpenseFillIn()
'
' ExpenseFillIn Macro
'
Range("A5:C5").Select
Range("C5").Activate
Selection.ClearContents
Range("A5").Select
ActiveCell.FormulaR1C1 = "Jeff Nelson"
Range("B5").Select
ActiveCell.FormulaR1C1 = "45177"
Range("C5").Select
ActiveCell.FormulaR1C1 = "=TODAY()"
Selection.Copy
Selection.PasteSpecial
Paste:=xlValues,
Operation:=xlNone,
SkipBlanks:= False,
Transpose:=False
End Sub

…and pasted here in the
ExpenseFillIn macro’s code

Let’s face it—unless you’re a programmer, it’s unlikely that you will ever learn any of Visual
Basic’s hundreds of functions, statements, and expressions. No matter. You have already
learned how you can view and even edit Visual Basic code created by Excel’s macro recorder.
A very useful technique you can use to edit and create macros is to insert code that has been
copied, or plagiarized, from another macro. This technique lets you add steps to your existing
macros by recording the steps you want to add in new macros, copying the appropriate code
and inserting it in the existing macro.

1.

2.

 2000 CustomGuide, Inc.

Open the Lesson 8B workbook and save it as Employee Expenses
(leave the current Macro Practice workbook open).
When you open the Lesson 8B file a frightening-looking dialog box like the one shown
in Figure 8-11 appears. Macros are like miniature programs, so there is an almost
infinitesimally small chance that a macro in an Excel worksheet could in fact be a virus
created by some disgruntled, malicious loser. If you know where the workbook came
from, it’s probably safe to enable the macros it contains.
Click Enable Macros.
Imagine this is an employee expense report you have to fill out once a week. Since you
enter the same information in this workbook on a regular basis, you have recorded a
macro to perform some of the repetitive work of FillIng out the form for you.
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3.
4.

5.
6.
7.

8.
9.

10.

11.
12.
13.

Select Tools → Macro → Macros from the menu.
The Macro dialog box opens. The name of the macro that fills in the basic, repetitive
information is ExpenseFillIn.
Select the macro ExpenseFillIn and click Run.
The Macro dialog box closes, and Excel runs the ExpenseFillIn macro, which fills in
the employee name and number. It would be nice if the ExpenseFillIn macro also
added the date you completed the Expense Report. You can do this by copying the
procedure from the DateStamp macro you created in the Macro Practice workbook and
pasting it in the code of the ExpenseFillIn macro.
Select Tools → Macro → Macros from the menu.
The Macro dialog box appears. First, you need to copy the code from the DateStamp
macro, located in the Macro Practice workbook.
Select the macro 'Macro Practice.xls'!DateStamp and click Edit.
The Microsoft Visual Basic editor appears with the DateStamp macro code. You need
to copy only the portion of code inserts today’s date into the active cell.
Select the block of code beginning with ActiveCell.FormulaR1C1 =
"=TODAY()" and ending with Selection.PasteSpecial
Paste:=xlValues, as shown in Figure 8-11, and click the Copy button on
the Visual Basic toolbar.
Now that you’ve copied the procedure that inserts the current date, you must insert, or
paste it into the appropriate place in the ExpenseFillIn macro.
Close the Visual Basic Editor by clicking the close button or selecting
File → Close from the menu.
The Visual Basic Editor window closes and you return to Excel.
Select Tools → Macro → Macros from the menu, select the macro
ExpenseFillIn and click Edit.
The Microsoft Visual Basic editor appears with code for the ExpenseFillIn macro. You
need to paste the copied DateStamp code into the appropriate place in the
ExpenseFillIn macro code.
Move the insertion point to the end of the line Range("C5").Select,
press <Enter> to add a blank line, then click the Paste button on the
Visual Basic toolbar.
The copied code from the DateStamp macro is inserted into the ExpenseFillIn macro.
Compare your macro to the one shown in Figure 8-11 (don’t worry if your code is
spaced differently and has different tabs.)
Close the Visual Basic Editor by clicking the close button or selecting
File → Close from the menu.
It’s time to test your macro.
Select Tools → Macro, and then Macros from the menu, select the
ExpenseFillIn macro, and click Run.
Excel runs the ExpenseFillIn macro, which now also adds the current date in cell C5.
Clear the information the macro entered and save the workbook to finish this lesson.
Select the cell range A5:C5, press the <Delete> key, and then save the
workbook.
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Quick Reference
To Insert Visual Basic
Code into an Existing
Macro:
1. Open the workbook that
contains the macro with
the code you want to
copy.
Or…
Record a new macro with
the steps you want to add
to an existing macro.
2. Select Tools → Macro
→ Macros from the
menu.
3. Select the macro that
contains the code you
want to copy and click
Edit.
4. Copy the necessary
portion of code using
standard text copy
procedure.
5. Close the Visual Basic
editor and repeat Step 2.
6. Select the existing macro
where you want to paste
the copied code and click
Edit.
7. Place the insertion point
where you want to paste
the copied code, add a
blank line by pressing
<Enter> and click the
Paste button on the
Visual Basic Standard
toolbar.
8. If necessary, edit the
pasted code.
9. Click the Save button
and exit the Visual Basic
editor.
You may want to delete
the other macro if it is no
longer needed.
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Lesson 8-6: Declaring Variables
and Adding Remarks to VBA Code
Figure 8-12
Using the Dim statement
to declare variables and
the remark statement (‘) to
add comments to Visual
Basic code.

Dim statement
Remark

Figure 8-13
The syntax for the Dim
statement.

Figure 8-12

Dim Cost As Integer
Dim
Variable Name Data Type
Statement The name of
The type of
the variable
data used in
the variable

Figure 8-13

You’ve probably heard that programming is a lot like algebra. In algebra you use variables,
like the r in the equation πr2. Programming uses variables too. You should always declare any
variables when you use them in code. Declaring a variable is like telling Excel “I’m going to
be using a variable named ‘r’ in my code.” In Visual Basic, you use the DIM statement to
declare variables, using the syntax DIM variablename As datatype, as shown in Figure 8-13.
This lesson explains how to declare variables using the Dim statement (you’ll actually get to
use the variables you declare in the next lesson.)
Another topic covered in this lesson is how to add remarks to your code. Code can be
confusing—you can make it easier to understand by adding explanatory remarks to by adding
REM statements. A REM statement doesn’t do anything as far as the code is concerned—it’s
just a way to add notes explaining the function of the code. You can add a REM statement by
typing an apostrophe before the comment. For example: ‘Adds the current date.

1.
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Make sure the Employee Expenses is the active workbook, then select
Tools → Macro → Macros from the menu, select the macro
ExpenseFillIn and click Edit.
The Microsoft Visual Basic editor appears with the code for the ExpenseFillIn macro.
Since several other users occasionally use this report, you decide you want to edit the
macro so it prompts the user for their name and employee number. You’ll learn how to
prompt the user for information or Input in the next lesson. For now, you have to
declare the variables for the employee name and number.
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2.
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Add a blank line immediately above the line Range("A5").Select. Place
the insertion point in the blank line and type Dim EmployeeName As
String and press <Enter>.
Remember, a variable is any piece of information that changes, like the x in an algebra
problem. In the case of the ExpenseFillIn macro, the employee’s name will be the
variable. Variables must have a name, like the x in the algebra problem. You give a
variable a name by declaring it with the Dim statement. The Dim statement must be
entered in the following syntax: Dim variablename as datatype. Here’s what the
arguments of the Dim statement mean:
•

VariableName: The name of the variable. Example: EmployeeName.

•

3.
4.

5.
6.

DataType: The type of data you want to use in the variable, such as a number,
date, or text. See Table 8-1: Data Types used in Variables for a list of data types.
Make sure you add an As between the variable name and the data type.
Example: As String.
Since the line of code “Dim EmployeeName As String” you just entered is a little
confusing, you can add a REM statement after it to explain what it does. Here’s how:
Type 'Declares the EmployeeName variable as a text string
and press <Enter>.
Next, you’ll need to declare the Employee Number.
Type Dim EmployeeNo as Long and press <Enter>.
Notice as you enter code, the Visual Basic editor displays a list of words that can be
used in the current statement. To accept a word, select the word from the list and press
<Tab>. You declare the EmployeeNo as a Long integer, since it will always be a
numeric value. Add a remark explaining what the preceding line of code does.
Type 'Declares the EmployeeNo variable as an integer and
press <Enter>.
Save the updated macro.
Click the Save button on the Visual Basic toolbar.

Table 8-1: Data Types used in Variables lists the more common data types that can be used
with the DIM statement.
Table 8-1: Data Types used in Variables
Date Type

Size

Range

Byte

1 byte

0 to 255

Boolean

2 bytes

True or False

Integer

2 bytes

-32,768 to 32,767

Long (Long Integer)

4 bytes

2,147,483,648 to 2,147,483,647

Date

8 bytes

January 1, 1000 to December 31, 9999

String (Text)

Varies

Approximately 2 billion characters

Member List

Quick Reference
To Declare a Variable:
• Add a Dim statement at
the beginning of the
procedure, using the
syntax Dim VariableName
As DataType.
To Add a Remark to a
Procedure:
• Add an apostrophe (')
before the remark.
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Lesson 8-7: Prompting for User
Input
Figure 8-14
An Input Box generated
from the InputBox
statement.
Figure 8-15
The edited ExpenseFillIn
VBA code.

Figure 8-14
Sub ExpenseFillIn()
'
' ExpenseFillIn Macro
'
Dim EmployeeName As String
'Declares the EmployeeName as a text string
Dim EmployeeNo As Long
'Declares the EmployeeNo as an Integer
The InputBox function
EmployeeName = InputBox("Enter the Employee's Name.")
EmployeeNo = InputBox("Enter the Employee Number.")
Range("A5:C5").Select
Range("C5").Activate
Selection.ClearContents
Range("A5").Select
ActiveCell.FormulaR1C1 = EmployeeName
Range("B5").Select
ActiveCell.FormulaR1C1 = EmployeeNo
Worksheets("Sheet1").PageSetup.CenterFooter = "Expense Report for: " &
EmployeeName
Range("C5").Select
ActiveCell.FormulaR1C1 = "=TODAY()"
Selection.Copy
Selection.PasteSpecial Paste:=xlValues, Operation:=xlNone, SkipBlanks:= False,
Transpose:=False
End Sub

Figure 8-15

When creating macros and code it is often useful to prompt the user for information. You can
then use this information in any number of ways—place it in a cell, use it in a calculation, or
print it in a header or footer.
This lesson explains one of the easiest methods of prompting the user for information—using
the InputBox function. The InputBox function prompts the user for information by displaying
a dialog box like the one shown in Figure 8-14. The syntax for the InputBox function is
InputBox(Prompt) where Prompt is the message you want to display (usually enclosed in
quotation marks “ ”).

1.
Quick Info
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2.

Make sure the Visual Basic editor is still open and displays the
ExpenseFillIn code.
Place the insertion point immediately after the 'Declares the
EmployeeNo variable as an integer statement, press <Enter>, type
EmployeeName = InputBox("Enter the Employee's Name."), and
press <Enter>.
As you type, Visual Basic displays a small window that displays information about the
function you’re entering and its parameters. This statement will display an InputBox,
as shown in Figure 8-14, which will ask the user to enter the EmployeName variable.
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3.

4.

5.
6.

7.
8.
9.

10.
11.
12.

Type EmployeeNo = InputBox("Enter the Employee Number.").
This will display another dialog box, which will ask the user to enter the
EmployeNumber variable. Once the user has entered the EmployeeName and
EmployeeNo variables in the Input Boxes, you can place EmployeeName and
EmployeeNo variables in the appropriate cells.
Find the ActiveCell.FormulaR1C1 = "Jeff Nelson" statement and edit
it so it reads ActiveCell.FormulaR1C1 = EmployeeName.
Make sure you remove the quotation marks! Now the macro will insert the
EmployeeName variable the user enters in the Input Box instead of the name “Jeff
Nelson.”
Find the ActiveCell.FormulaR1C1 = "45177" statement and edit it so it
reads ActiveCell.FormulaR1C1 = EmployeeNo and press <Enter>.
You decide to enter the text from the EmployeeName variable in the page footer for the
worksheet as well.
Type Worksheets("Sheet1").PageSetup.CenterFooter = "Expense
Report for: " & EmployeeName.
That last statement was a bit confusing—here’s what it does. We’ll start from the end
of the code and work our way to the beginning. EmployeeName is the variable you
declared and it equals whatever the user enters in the InputBox. Before that is the
ampersand symbol (&), which combines the EmployeeName variable with the text
message “Expense Report for: ”. Note that the text message (or text string) must be
enclosed in quotation marks (“ ”). The first part of the statement,
Worksheets(“Sheet1”).PageSetup.CenterFooter, refers to the center footer of the
Sheet1 worksheet. So the line of code tells Excel you want the center footer of Sheet1
to equal, or display the message “Expense Report for: EmployeeName variable” or
whatever name the user enters in the InputBox.
You’re ready to test your macro.
Click the Save button on the Visual Basic toolbar to save the macro,
then close the Visual Basic Editor by clicking the close button or
selecting File → Close from the menu.
The Visual Basic editor closes and you return to the Excel program screen.
Select Tools → Macro, and then Macros from the menu, select the
macro ExpenseFillIn and click Run.
An Input Box appears asking you to input the employee’s name, as shown in Figure
8-14.
Type in your name, click OK, type 7000 in the second Input Box, and
click OK.
The ExpenseFillIn macro fills in the Expense report with the EmployeeName and
EmployeeNo variables you entered in the two Input Boxes. Preview the workbook to
verify that the EmployeeName also appears in the workbook footer.
Click the Print Preview button on the Standard toolbar.
The workbook appears in Print Preview mode. Notice that the ExpenseFillIn macro has
entered the employee name at the center footer.
Click Close to close the Print Preview window.
Clear the information entered by the ExpenseFillIn macro.
Select the cell range A5:C5 and press the <Delete> key, then save your
work.
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Quick Reference
To Use the Inputbox
Statement:
• Add an Input statement
using the syntax
InputBox(Prompt).
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Lesson 8-8: Using the
If…Then…Else Statement
Figure 8-16
The Syntax for the If
…Then statement.
Figure 8-17
The If …Then statement in
a VBA macro’s code.

If condition Then
statement
Else
elsestatement
End If

If the stated condition is true
then this action will happen.
Otherwise, this action will
happen.

Figure 8-16
Dim EmployeeName As String
'Declares the EmployeeName as a text string
'Declares the EmployeeNo as an Integer
Dim EmployeeNo As Long
EmployeeName = InputBox("Enter the Employee's Name.")
If EmployeeName = "Jeff Nelson" Then
EmployeeNo = 45177
Else
EmployeeNo = InputBox("Enter the Employee Number.")
End If

Figure 8-17

The If…Then…Else statement takes action based on a certain condition. For example, if an
employee’s weekly sales are more than $2,500, then calculate a 5% commission bonus for the
employee, else don’t calculate a bonus. The syntax for the If…Then…Else statement is shown
in Figure 8-16.
In this lesson you will use the If…Then…Else statement to enter the employee number 45177
if the employee is Jeff Nelson, else the user will have to enter their employee number.

1.

2.
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Make sure the Employee Expenses is the active workbook, select Tools
→ Macro, and then Macros from the menu, select the macro
ExpenseFillIn, and click Edit.
The Microsoft Visual Basic editor appears with the ExpenseFillIn macro code. Jeff
Nelson is normally the only person that uses the Employee Expense workbook. To save
time, you decide to add a conditional statement to the ExpenseFillIn macro, so if the
EmployeeName is “Jeff Nelson” the macro will automatically enter Jeff’s Employee
Number, otherwise if the EmployeeName is not “Jeff Nelson” the macro will prompt
the user to enter their Employee Number.
Add a blank line immediately after the statement EmployeeName =
InputBox("Enter the Employee's Name"), enter the statement
If EmployeeName = "Jeff Nelson" THEN and press <Enter>.
This is the beginning of your IF…THEN…ELSE statement. IF the EmployeeName
equals “Jeff Nelson” THEN you want to set the EmployeeNo variable to equal Jeff’s
employee number, 45177.
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3.
4.

5.
6.
7.
8.
9.
10.
11.
12.
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Press <Tab>, type EmployeeNo = 45177 and press <Enter>.
You don’t have to add a <Tab> before the statement—it just makes your code easier to
read, and is a standard practice in programming. The next step in the
IF…THEN…ELSE statement is adding the ELSE statement.
Type Else and press <Enter>.
The next step is entering the ELSE statement—what to do if the EmployeeName does
not equal “Jeff Nelson.” If the EmployeeName does not equal “Jeff Nelson,” you want
Excel to display the InputBox to prompt the user for their Employee Number. You’ve
already written this statement, so you can include it as the ELSE statement.
Place the insertion point at the beginning of the statement EmployeeNo
= InputBox("Enter the Employee Number"), press <Tab>, press
<End> to move to the end of the line, and press <Enter>.
Finish the IF…THEN…ELSE statement by adding the closing statement: End If.
Type End If.
Compare your code with the code shown in Figure 8-17. You’re ready to save and test
your new macro code.
Click the Save button on the Standard toolbar to save the macro, then
close the Visual Basic Editor by clicking the close button or selecting
File → Close from the menu.
The Visual Basic editor closes and you return to the Excel program screen.
Select Tools → Macro, and then Macros from the menu, select the
macro ExpenseFillIn and click Run.
Type Jeff Nelson in the InputBox and press <Enter>.
The macro enters “Jeff Nelson” in cell A5 and his employee number “45177” in cell
B5.
Select Tools → Macro, and then Macros from the menu, select the
macro ExpenseFillIn and click Run.
See what happens when you enter a name other than “Jeff Nelson”.
Enter your own name in the InputBox.
Since the EmployeeName variable wasn’t “Jeff Nelson” another InputBox appears,
asking for the employee number.
Type 55555, press <Enter>, save your work, and exit Microsoft Excel.

Quick Reference
To Use an If…Then
Statement:
• Add an If…Then…Else
statement using the
following syntax:
If Condition Then
Statement If True
Else
Statement If False
End If
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Chapter Eight Review
Lesson Summary
Recording a Macro
•

To Record a Macro: Select Tools → Macro → Record New Macro from the menu. Enter a
name, description, and shortcut keystroke (optional) for the macro. Click OK and carefully perform
the actions you want to include in your macro. Click the Stop button on the Macro Record
toolbar when you’re finished recording your macro.

•

When you record a macro, everything is recorded—including any mistakes you make. You should
create a script that contains the steps you want the macro to record to minimize the amount of
mistakes.

Playing a Macro and Assigning a Macro a Shortcut Key
•

To Play a Macro: Select Tools → Macro → Macros from the menu, select the macro you want
to play and click Run.

•

To Assign a Shortcut Key to a Macro: Select Tools → Macro → Macros from the menu, select
the macro you want to assign a shortcut keystroke to and click Options. Enter the keystroke in
Shortcut key box.

•

To Delete a Macro: Select Tools → Macro → Macros from the menu, select the macro you want
to delete and click Delete.

Adding a Macro to a Toolbar
•

To Add a Macro to a Toolbar: Select View → Toolbars → Customize from the menu and click
the Commands tab. Select the Macros category from the Categories list and drag the Custom
button to the desired toolbar. Right-click the custom button, select Assign Macro from the
shortcut menu and select the macro you want to assign.

•

To Remove a Button from a Toolbar: Select View → Toolbars → Customize from the menu,
and drag the button off the toolbar.

Editing a Macro’s Visual Basic Code
•

To Edit a Macro’s Visual Basic Code: Select Tools → Macro → Macros from the menu, select
the macro and click Edit. When you’ve finished editing the macro’s code click the Save button and
then close the Visual Basic Editor window.

Inserting Code in an Existing Macro
•
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You can create macros that are more complex by copying sections of code from one macro to
another macro.
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Declaring Variables and Adding Remarks to VBA Code
•

You must declare any variables using the DIM statement, which uses the syntax Dim
VariableName As DataType.

•

You can add a REM statement or comment to your code by typing an apostrophe before the
comment.

Prompting for User Input
•

The Input statement prompts the user for information. The syntax for the InputBox statement is
InputBox(Prompt).

Using the If…Then…Else Statement
•

The If…Then statement takes action based on one condition and another action based on another
condition.

•

The syntax for the IF...THEN … ELSE statement is:
If Condition Then
Statement If True
Else
Statement If False
End If

Quiz
1. Only menu and toolbar commands are recorded when you record a macro.
(True or False?)
2. Which of the following statements is NOT true?
A. Excel records macros in Visual Basic language.
B. Macros names can be up to 25 characters long, including spaces.
C. You start the macro recorder by selecting Tools → Macro → Record New Macro
from the menu.
D. You can assign a keystroke shortcut to a macro to make it quicker to access.
3. Which of the following statements declares a variable?
A.
B.
C.
D.

REM HireDate as Date
InputBox(HireDate) = Date
Dim HireDate as Date
Sub HireDate() = Date

4. Which of the following statements is NOT true?
A. You can edit a macro’s Visual Basic source code by selecting Tools → Macro →
Macros from the menu, selecting the macro and clicking the Edit button.
B. You can edit, cut, copy, and paste Visual Basic code just like ordinary text.
C. The InputBox function lets you add remarks to your code.
D. IF…THEN…ELSE statement takes an action based on a certain condition.
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5. How can you play a macro?
A.
B.
C.
D.

Select Tools → Macro → Macros from the menu and select the macro.
Select Tools → Play Macro from the menu and select the macro.
Click the Play Macro button on the toolbar and select the macro.
Take music lessons from a professional macro player to learn how to do this.

6. You can assign a macro to which of the following? (Select all that apply.)
A.
B.
C.
D.

The Office Assistant, to punish it for appearing unexpectedly.
A keystroke shortcut, such as <Ctrl> + <D>.
A button on any toolbar.
A button on the Status bar.

Homework
1. Create a new workbook and save it as “My Macros.”
2. Select Tools → Macro → Record New Macro from the menu. In the Macro name
box type “EnterAddress,” click the Store macro in arrow and select This Workbook,
then click OK to start recording.
3. Type your name, address, and phone number in the following format:

4. Click the cell that contains your name and apply bold formatting.
5. Click the Stop button.
6. Clear the address information you just entered and try running your macro.
7. Edit the macro’s Visual Basic code so that it enters the “Nancy Gordon” instead of
your name.
8. Assign the shortcut key <Ctrl> + <E> to the macro.

Quiz Answers
1. False. Everything is recorded: every menu you select, button you click, everything
you type, even any mistakes you make!
2. B. Macros can’t have spaces in them.
3. C. The Dim statement declares a variable, so the statement “Dim HireDate as Date”
would declare the “HireDate” variable as a date data type variable.
4. C. The InputBox allows you to accept input from a user.
5. A. You can play a macro by selecting Tools → Macro → Macros from the menu and
selecting the macro.
6. B and C. You can assign a macro to either a keystroke shortcut or to a button on any
toolbar.

 2000 CustomGuide, Inc.

Chapter Nine:
Working with Other
Programs
Chapter Objectives:
•

Insert an Excel worksheet into a Word document

•

Modify an embedded worksheet

•

Link an Excel chart into a Word document

•

Insert a graphic into a worksheet

•

Open and save files in different formats

Chapter Task: Insert information between different programs
One of the great benefits of working with Windows is that you can share information between
different programs. This chapter explains how you can use Excel with other programs. You’ll
learn how to insert an Excel worksheet and chart into a Microsoft Word document. You’ll also
learn the subtle differences between embedding and linking files into other programs. This
chapter also explains how to open and save different file formats, such as Lotus 1-2-3 or text
files, in Excel.

; Prerequisites
• How to start and
operate Microsoft Word.
• How to edit and work
with Excel worksheets
and charts.
• How to open and save
files.
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Lesson 9-1: Inserting an Excel
Worksheet into a Word Document
Figure 9-1
The Create New tab of the
Object dialog box.
Figure 9-2
The Create from File tab
of the Object dialog box.
Figure 9-3
A Microsoft Excel
worksheet inserted in a
Word document.

Figure 9-1

Figure 9-2

Figure 9-3

Microsoft Word is a powerful word processing program that can create professional-looking
documents. Since Word is part of the Microsoft Office 2000 Suite, it makes sense that more
people use Excel together with Word than any other program. In this lesson, you will learn
how to embed an Excel worksheet into a Word document.

1.
2.
3.
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Start the Microsoft Word program.
Open the document named Interoffice Memo.
The procedure for opening a file in Word is identical to opening a file in Excel. Click
the Open button on the Standard toolbar or select File → Open from the menu. The
Interoffice Memo document appears in Word’s main document window.
Move the insertion point ( ) to the end of the document by pressing the
down arrow key <↓>, or else clicking to the end of the document with the
mouse.
This is where you want to insert an Excel worksheet.
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4.

5.
6.
7.
8.

Select Insert → Object from the menu.
The Object dialog box appears with the Create New tab in front, as shown in Figure
9-1. You can create and insert new objects with the Create New tab, or you can insert
an existing file with the Create from File tab. You have already created and saved a
worksheet in Excel, so you need to insert the worksheet from an existing file.
Click the Create from File tab.
The Create from File tab appears in front, as shown in Figure 9-2. You need to specify
the name and location of the file you want to insert into the document.
Click the Browse button.
The Browse dialog box appears, allowing you to find and locate the file you want to
insert into your document.
Navigate to your practice folder or disk and select the Expenses file.
Notice that the icon for the Expenses file indicates that it is a Microsoft Excel file.
Click OK.
The Browse dialog box closes and you return to the Create from File tab of the Object
dialog box. Notice the Expenses file name and location appear in the File name box.
There are several other options on this page you should know about:
•
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Insert Microsoft
Excel Worksheet
button

Link to file: Inserted objects are normally embedded, or saved inside the
documents in which they are inserted. If you check the Link to file option the
object will still be inserted in the document, but Word will only create a link to
the original file instead of saving a copy of it inside the document. You should
use the Link to file when you want to ensure that any changes made in the
original file are updated and reflected in the document it is inserted in.

•

9.

Display as icon: Inserted objects are normally viewable directly from the
Word document window. Checking the Display as icon box option causes the
inserted objects to appear only as an icon. You must double-click the object in
order to view it.
Click OK.
Word accesses the Excel file and then inserts it into the document at the insertion point.
Compare your document with the one in Figure 9-3.

10.
11. Save the changes you’ve made to the Word document by clicking the
Save button on the Standard toolbar.

Quick Reference
To Insert an Embedded
Excel Worksheet into a
Word Document:
1. Place the insertion point
where you want the
worksheet to be inserted.
2. Select Insert → Object
from the menu.
3. Click the Create from File
tab to use an existing
worksheet file or click the
Create New tab to create
a new worksheet.
4. Specify the Excel
worksheet file you want to
insert (if you selected
Create from File) or else
create the worksheet from
scratch (if you selected
Create New).
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Lesson 9-2: Modifying an Inserted
Excel Worksheet
Figure 9-4
Modifying an Excel
Worksheet object.
Figure 9-5
The modified worksheet.

Figure 9-4

Figure 9-5

After you insert an Excel worksheet, you can make changes to the worksheet simply by
double-clicking it. Double-clicking any embedded or linked object opens the source program
the object was created in, or, in the case of this lesson, Microsoft Excel. If the program the
object was created with isn’t installed on your computer you can still view and print the object
but you can’t make changes to it.

1.
2.
3.
4.
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Double-click the inserted worksheet object in the document.
The Excel program opens inside of the Word document, as shown in Figure 9-4. Notice
that Excel menus and toolbars replace the Word toolbars and menus. Now you can
make changes to the worksheet object.
Select cell B5.
With the cell selected, you can replace the cell’s data simply by typing.
Type 515 and press <Tab>.
The number 515 replaces the number 500 and Excel moves to the next cell.
Select the entire Detroit row by clicking the row 6 heading.
The entire row is selected.
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5.
6.
7.
8.
9.
10.

11.
12.

Select Insert → Rows from the menu.
A new row is inserted immediately above the Detroit row. Now enter the data for the
new row.
Click cell A6, type Milwaukee and press <Tab> to move to the next cell.
Type the following, pressing <Tab> after making each entry.
470
135
110
25
Now that you have entered the data you must calculate the total for the row.
Click the AutoSum button on the Standard toolbar.
Excel makes an educated guess regarding which cells you want to use to calculate the
total and selects them. In your case, Excel guesses correctly.
Press <Enter> to accept the formula.
Excel calculates the row total and moves to the next cell. Notice that after you inserted
a new row, the bottom total row is no longer displayed. Here’s how to resize the Excel
worksheet object so that the entire worksheet is displayed.
Position the pointer over the lower-right sizing handle, until the pointer
changes to a , then click and hold the left mouse button and drag the
mouse down until you can see the bottom row of the worksheet, then
release the mouse button.
The entire worksheet object should be visible in the document window.
Click anywhere outside the worksheet object to stop modifying the
worksheet to and return to Word.
The standard Word menu and toolbars replace the Excel menu and toolbars. Compare
your document to the one in Figure 9-5.
Save your work.
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AutoSum button

It can be confusing knowing what the differences are between linked and embedded objects.
Table 9-1: Embedded vs. Linked Objects compares each of these methods for inserting
information created with other programs into Word documents.
Table 9-1: Embedded vs. Linked Objects
Heading

Heading

Embedded

An embedded object is actually saved within the file. Files with
embedded objects are larger than files with linked objects. The
advantage of using embedded objects is that the objects are
actually saved inside the file, so you don’t have to worry about any
attached files becoming erased or lost.

Linked

A linked object is not saved in the file. Instead, a link contains
information on where to find the source data file. The advantage of
using linked objects is that when the source file is changed, the
linked object in the file is automatically updated to reflect the
changes.

Quick Reference
To Modify an Embedded
or Linked Object:
1. Double-click the
embedded object.
2. When you have finished
editing the object, click
anywhere outside the
object to return to the host
program.
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Lesson 9-3: Inserting a Linked
Excel Chart in a Word Document
Figure 9-6
Inserting a linked
Microsoft Excel chart
object.
Figure 9-7
A linked Excel chart.

Figure 9-6

Figure 9-7

So far you have been inserting and working with an embedded Excel worksheet. This lesson
mixes things up a bit. You will still be inserting information created in Excel, but in this
lesson you will be inserting a linked Excel chart. Remember, when you insert an embedded
object you are actually storing and saving the object inside the file. A linked file is not stored
and saved in a Word document, but is connected to it. So if you make changes to the linked
source file it will be automatically updated in the Word document.

1.
2.
3.
4.
5.
6.
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Press <Ctrl> + <End> to move to the end of the document.
Just like in Excel, <Ctrl> + <End> moves you to the end of a document in Word.
Press <Enter> twice to add two blank lines.
Now insert the linked chart object.
Select Insert → Object from the menu and click the Create from File
tab if it does not appear in front.
The Create from File tab appears in front, as shown in Figure 9-6. You need to specify
the name and location of the file you want to insert into your document.
Click the Browse button.
The Browse dialog box appears, allowing you to find and locate the file you want to
insert into your document.
Navigate to your Practice folder or disk and select the Trade Show
Chart file.
Notice the icon for the Trade Show Chart file indicates that it is a Microsoft Excel file.
Click OK.
The Browse dialog box closes and you return to the Create from File tab of the Object
dialog box. Notice the “Trade Show Chart” file name and location now appears in the
File name text box.
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7.
8.
9.
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Click the Link to file checkbox.
Checking the Link to file checkbox only inserts a link to the specified file in the Word
document instead of inserting an embedded copy of the file. You should use Link to
file if you want to display any changes made to the original file in your document.
Click OK.
Word accesses the Excel chart and then inserts a link to it in the document at the
insertion point.
Resize the Chart object so it is similar in size to the one shown in Figure
9-7.

10. Save your work.
11. Select File → Exit from the menu to close the Microsoft Word program.

Quick Reference
To Insert a Linked Object
File:
1. Place the insertion point
where you want to insert
the linked object.
2. Select Insert→ Object
from the menu and click
the Create from File tab.
3. Make sure the Link to
File check box is
selected, and then specify
the file you want to insert.
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Lesson 9-4: Inserting a Graphic
into a Worksheet
Figure 9-8
The Insert Picture dialog
box.
Figure 9-9
Move an object by
dragging and dropping it.
Figure 9-10
The Picture toolbar.
Figure 9-8

Click and drag an object
to move it to a new
location

Figure 9-9
Insert
Picture

More
More
Contrast Brightness Crop Wrap text

Set Transparent
Color

Line Style
Less
Less
Contrast Brightness
Format
Picture
Figure 9-10
Image
Control

Reset
Picture

Pictures, graphics, and illustrations can make your worksheets more professional looking.
This lesson explains how to insert clip art and graphics into your worksheets. You can insert
graphics and pictures created with graphics programs such as Microsoft Paint (which comes
with Windows), scanned pictures, or graphics from a clip art library.

1.
Inserting a
Picture from a
File
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2.

Start Microsoft Excel, open the Expenses workbook and save it as
Trade Show Expenses.
Click cell A1.
This is where you want to insert the graphic.
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3.
4.
5.
6.
7.

8.
9.

Select Insert → Picture → From File from the menu.
The Insert Picture dialog box appears, as shown in Figure 9-8. You need to specify the
name and location of the graphic file to be inserted into your Excel worksheet.
Navigate to your Practice folder or disk and select the PCLogo file.
Excel displays a preview of the graphic in the left side panel of the Insert Picture dialog
box.
Click the Insert button to insert the PC Logo graphic.
Excel inserts the picture file PC Logo in the worksheet.
Select the picture (if necessary) of the PC Logo by clicking it.
See the six boxes along the edges of the picture? Those are sizing handles and are used
to resize or crop objects. Go ahead and resize the picture.
Position the pointer over the lower-right sizing handle, until the pointer
changes to a , then click and hold the left mouse button and drag the
mouse diagonally down and to the right until the bottom of the
picture is flush with the bottom of row 4, then release the mouse button.
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Sizing handles

With the picture still selected, click and hold the left mouse button and
drag the picture to the right side of the page, as shown in Figure 9-9.
Release the left mouse button to drop the picture.
Save your work and close the Trade Show Expenses workbook.

You probably noticed several other options listed under the Insert → Picture menu. Here’s
what they are and what they do:
Table 9-2: The Insert Picture Menu
Insert

Quick Reference

Description

Clip Art

Opens the Clip Gallery where you can select a clip art image to insert.

From File

Inserts a graphic file in the active cell.

AutoShapes

Inserts a ready-made shape, such as a circle, rectangle, star, arrow, etc.

Organization Chart

Inserts a Microsoft Organization Chart object into worksheet.

WordArt

Creates spectacular text effects, such as

From Scanner

Scans an image and inserts it at the insertion point.

To Insert a Graphic:
1. Click the cell where you
want to insert the graphic
and Select Insert →
Picture → From File
from the menu.
2. Select the file location
and name and click OK.
To Resize an Graphic:

.

• Click the object to select
it, then drag its sizing
handles until the object is
the size you want.
To Move a Graphic:
• Click the picture and hold
mouse button, drag the
picture to a new location
in the document then
release the mouse button.
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Lesson 9-5: Opening and Saving
Files in Different Formats
Figure 9-11
The Text Import Wizard
dialog box.
Figure 9-12
The imported text file.

Figure 9-11

Figure 9-12

People from different countries speak different languages. Likewise, computer programs save
files in different formats that other programs sometimes can’t read. Fortunately, just as some
people can speak several languages, Excel can read and write in other file formats.
This lesson shows how you can open one of the most common file formats in Excel—a tab
delimited text file.

1.

2.
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Click the Open button on the Standard toolbar and navigate to your
Practice folder or disk.
Normally the Open dialog box only displays files created with Microsoft Excel. To
open files created with other programs you need to select the file type you want from
the Files of type list arrow—in your case Text files.
Click the Files of type list arrow, select Text Files, select the Europe
Expenses file and click Open.
The Text Import Wizard dialog box appears, as shown in Figure 9-11. You must specify
how the information is stored in the text file. There are two options:

Chapter Nine: Working with Other Programs
•

3.
4.

5.

6.
7.
8.
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Delimited: Tabs, colons, semicolons, or other characters separate items in your
text file. This is the most common (and default) option.

• Fixed Width: All the items in your text file are the same length.
The Europe Expenses is a tab delimited text file, that is, tabs separate its fields, so you
don’t need to make any changes and can continue on to the next step.
Click Next.
The second step of the Text Import Wizard appears. Notice the tab box is selected
under Delimiters (what separates the text). No changes needed here.
Click Next.
The third step of the Text Import Wizard allows specifying formatting options for any
of the columns of data. For example, you could specify that a particular column be
formatted as a data or number field. It isn’t important to format any of the columns
here, however, so you can complete the Text Import Wizard.
Click Finish.
The Text Import Wizard closes and the imported text file appears in the Excel
worksheet window.
Here’s how to save a workbook in a different format:
Select File → Save As from the menu.
The Save As dialog box appears.
Click the Save as type list arrow, scroll down the list and select
WKS (1-2-3).
This will save the file in Lotus 1-2-3 format.
Click Save to save the Europe Expenses workbook as a Lotus 1-2-3 file,
then close it (but leave Microsoft Excel open!).

Table 9-3: Importable and Exportable File Formats and Extensions
File Format

Extensions

Microsoft Excel 2000

.xls, .xlt

Microsoft Excel 5.0/95

.xls, .xlt

Microsoft Excel 4.0, 3.0, 2.0

.xls, .xlw, .wlc, .xlm

Lotus 1-2-3

.wk4, .wk3, .fm3, .fmt, .all, .wk1, .wks

Quattro Pro

.wb1, .wbi

Text (Both tab and comma delimited)

.txt, .csv

Dbase 2, 3, 4

.dbf

Microsoft Access 2.0, 95, 97

.mdb

Save As Type list

Quick Reference
To Open a Non-Excel File
in Excel:
Quick
Reference
1. Click
the Open
button on
the
Standard
toolbar.
To Save a Worksheet as a
2. Click
the Files of type list
Web
Page:
arrow and select All Files
• Open the workbook and
to display all files.
select File → Save as
3. HTML
Find and
double-click
from
the menu,the
file
you
want
to on-screen
open.
then follow the
Toinstructions.
Save a File in a
Different File Format:
1. Select File → Save As
from the menu.
2. Click the Save as type
list arrow and select the
file format you want to
save the file in.
3. Enter a new name for the
file, if you want, and click
Save.
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Chapter Nine Review
Lesson Summary
Inserting an Excel Worksheet into a Word Document
•

To Insert an Embedded Excel Worksheet into a Word Document: Place the insertion point
where you want the worksheet to be inserted and select Insert → Object from the menu. Click the
Create from File tab to use an existing worksheet file or click the Create New tab to create a new
worksheet. Select the worksheet you want to insert (if you selected Create from File), or create the
worksheet from scratch (if you selected Create New).

Modifying an Inserted Excel Worksheet
•

Double-click any embedded or linked object to edit it. Click anywhere outside the object when
you’re finished.

•

An embedded object is saved within the file. Files with embedded objects are larger than files with
linked objects. The advantage of using embedded objects is that the objects are actually saved
inside the file, so you don’t have to worry about any attached files becoming erased or lost.

•

A linked object is not saved in the file. Instead, a link contains information on where to find the
source data file. The advantage of using linked objects is, if the source file is changed, the linked
object in the file is automatically updated to reflect the changes.

Inserting a Linked Excel Chart in a Word Document
•

To Insert a Linked Object File: Place the insertion point where you want the worksheet to be
inserted and select Insert → Object from the menu and click the Create from File tab. Make sure
the Link to File check box is selected and specify the file you want to insert.

Inserting a Graphic into a Worksheet
•

To Insert a Graphic: Click the cell where you want to insert the graphic and Select Insert →
Picture → From File from the menu. Select the file location and name, and click OK.

•

Resize an object by dragging its sizing handles until the object is the size you want.

•

Move an object by clicking and dragging it to a new location and releasing the mouse button.

Opening and Saving Files in Different Formats
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•

To Open a Non-Excel File in Excel: Click the Open button on the Standard toolbar, select Click
select All Files from the Files of type list. Find and open the file.

•

To Save a File in a Different File Format: Select File → Save As from the menu and select the
file format from the Save as type list.

Chapter Nine: Working with Other Programs

Quiz
1. What is the difference between an embedded and linked object?
A. An embedded object is saved within the file, a linked object is a hyperlink to another
file.
B. An embedded object is saved within the file, a linked object is not saved in the file.
Instead, a connection to the file is inserted.
C. An embedded object can be inserted on the same page as other text or information, a
linked file must be placed on its own separate page.
D. An embedded object is saved in a separate file, a linked object is saved with the file
it was inserted into.
2. Double-click an embedded or linked object to modify it. (True or False?)
3. Which of the following statements is NOT true?
A. When you insert an object, you can either insert an existing file or you can create a
new file.
B. Clicking the Link to file check box inserts a link to the file instead of embedding the
file.
C. You can only insert graphics or pictures into Excel charts.
D. You insert graphics by selecting Insert → Picture → From File from the menu.

Homework
1. Open the workbook Lesson 2 and save it as a .CSV (Comma Delimited) text file
named “Mileage”.
2. Create a new workbook, select Insert → Picture → ClipArt from the menu, and
insert a picture of a turtle into the workbook.
3. Resize the turtle picture so that it is about 50% of the original size, then move it
down about an inch.
4. Open the Lesson 5 workbook and save it as “Web Practice”.
5. Click cell A10, type “Expenses”, and press <Enter>. Click cell A10, click the Insert
Hyperlink button on the Standard toolbar and create a hyperlink to the Expenses
workbook.
6. Exit Microsoft Excel and start Microsoft Word. Type “Here are the results of last
month’s survey:” and press <Enter>.
7. Insert the Lesson 5A workbook into the Word document at the insertion point.

Quiz Answers
1. B. An embedded object is saved within a file. A linked object is not actually saved
within a file, but points to the inserted file.
2. True. Double-clicking an object lets you modify it.
3. C. You can insert graphics or pictures into worksheets or charts.
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Chapter Ten: Using
Excel with the
Internet
Chapter Objectives:
•

Add Hyperlinks to a Worksheet

•

Browse Hyperlinks and using the Web Toolbar

•

Save a Workbook as a Non-Interactive Web Page

•

Save a Workbook as an Interactive Web Page

•

Retrieve Information from a Web Page

Chapter Task: Publish an Excel worksheet to the Web
In a mere five years, the Internet has changed how most businesses and computers work, so
it’s no surprise that the biggest changes and improvements in Excel 2000 have to do with how
it works and interacts with the Internet.
Excel’s Internet features let you add hyperlinks to your workbooks to link them to other
workbooks, a file created in another program, or even a Web page. You can also save your
worksheets and charts as a Web page and place them on your corporate Intranet or the World
Wide Web so that other users can view them. You can also create interactive Web pages that
allow users to add, change, and calculate your worksheet’s information from Microsoft
Internet Explorer 4.01 or later. Finally, you can retrieve information stored on a Web page and
place it on your worksheets.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• Basic familiarity with the
Internet and the World
Wide Web.
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Lesson 10-1: Adding Hyperlinks to
a Worksheet
Figure 10-1

Insert a link to another
workbook or file
created in another
program

The Insert Hyperlink
dialog box.
Figure 10-2

Insert a link to a Web
page on the Internet or
your corporate Intranet

A hyperlink inserted into
an Excel workbook.

Insert a link to a cell
reference in the same
workbook

Figure 10-3
Editing a Hyperlink using a
right-mouse button
shortcut menu.

Figure 10-1

Figure 10-2

Figure 10-3

Hyperlink

In this lesson, you will learn about how to use hyperlinks in Excel. A hyperlink points to a file,
a specific location in a file, or a Web page on the Internet or on an Intranet. Whenever you
click on a hyperlink, you jump to the hyperlink’s destination (if it’s available.) A hyperlink is
usually indicated by colored and underlined text. If you have ever been on the World Wide
Web you’ve used hyperlinks all the time to move between different Web pages.

1.
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Open the workbook named Lesson 10 and save it as Trade Show
Expenses.
You may need to click the Files of Type list and select Microsoft Excel Files if you
can’t find it.

Chapter Ten: Using Excel with the Internet

2.
3.

4.
5.
6.
7.

8.

Click cell A10, type Mileage Report and press <Enter>.
This is the text for the hyperlink. The next step is to create the destination for the
hyperlink. A hyperlink’s destination can be any file on your computer, on the network,
or even on the Internet.
Click cell A10 and click the Insert Hyperlink button on the Standard
toolbar.
The Insert Hyperlink dialog box appears, as shown in Figure 10-1. Here you can
specify a Web address or name and location of a file you want to add as a hyperlink. If
you know the location and name of the file or Web address, you can type it directly in
the dialog box, otherwise you can use the Browse buttons to locate the file. There are
three different browse buttons in the Insert Hyperlink dialog box that let you browse
for three different types of Hyperlink destinations. These buttons are:
•

File: Creates a link that takes you to another Excel workbook or to a file created
in another program, such as a Microsoft Word document.

•

Web Page: Creates a link that takes you to a Web page on the Internet or that
sends an e-mail to a specified e-mail address.

• Bookmark: Takes you to a cell address in the same workbook.
Click the File button.
The Link to File dialog box appears, which displays a list of files that you can use as
the destination for your hyperlink.
Click the Files of type list arrow and select Workbooks (.xls) from the
list to display only Excel workbooks in the window.
The Link to File dialog box is updated so that it displays only Excel workbook files.
Select the Lesson 2A workbook file and click OK.
The Link to File dialog box closes and the name and location of the Lesson 2A is
added to the Link to File or URL text box.
Click OK.
The dialog box closes and you return to the worksheet window. Notice the text
“Mileage Report” appears blue and underlined, signifying it’s a hyperlink. For now,
don’t click the Mileage Report Hyperlink! We’ll cover that in the next lesson.
Once you create a hyperlink, you can easily edit it to change its title or target, copy it,
or delete it by right-clicking the hyperlink. Try it!
Right-click the hyperlink in cell A10 and select Hyperlink from the
shortcut menu.
A shortcut menu with the most frequently-used hyperlink commands appears, as shown
in Figure 10-2. Here you could select Edit Hyperlink to change the hyperlink’s target or
Select Hyperlink to edit the hyperlink’s title. Your hyperlink is fine the way it is, so
close the shortcut menu.
Click anywhere in the worksheet window to close the shortcut menu.

9.
10. Save your work.

In the next lesson, you will get a chance to actually use the hyperlink you just created and see
how you can browse Excel’s files using the Web toolbar.
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Insert Hyperlink
button
Other Ways to Insert a
Hyperlink:
• Select Insert →
Hyperlink from the
menu.

Quick Reference
To Insert a Hyperlink:
1. Select the cell you want to
use for the hyperlink and
click the Insert Hyperlink
button from the Standard
toolbar.
Or…
Select the text you want
to use for the hyperlink
and select Insert →
Hyperlink from the menu.
2. Either select a file you
want (use the browse
button to help you locate
the file) or else type a
Web address for the
hyperlink’s destination
and click OK.
To Edit a Hyperlink:
• Right-click the hyperlink
and select Hyperlink →
Edit Hyperlink from the
shortcut menu.
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Lesson 10-2: Browsing Hyperlinks
and using the Web Toolbar
Figure 10-4
Click a hyperlink…
Figure 10-5
…and Excel jumps to the
destination file or Web
page.

Figure 10-4
When you
position the
pointer over a
hyperlink it
changes to a .

Figure 10-5

The Web toolbar appears
whenever you click a hyperlink

If an Excel workbook contains one or more hyperlinks, you can navigate or browse between
the files connected by the hyperlinks. In this lesson you will test the hyperlinks you created
earlier to make sure they work. Chances are, browsing between two files will be nothing new
to you, because browsing hyperlinks in Microsoft Excel is no different than browsing the
Web.

1.

2.
3.
Insert Hyperlink
button
Other Ways to Insert a
Hyperlink:
• Select Insert →
Hyperlink from the
menu.
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4.
5.

Click the hyperlink Mileage Report in cell A10.
Two things happen whenever you click a hyperlink in Excel: First, you immediately
jump to the hyperlink’s destination—in this case the Mileage Report workbook.
Second, Excel displays the Web toolbar (if it isn’t there already) so you can easily
navigate between your files just like you would if you were surfing the ‘net.
Move on to the next step, and we’ll create a hyperlink back to the first workbook,
Trade Show Expenses, so that the user can easily return to it.
Click cell A14, type Return to Trade Show Expenses and press
<Enter>.
This text will contain the hyperlink to the workbook “Trade Show Expenses.”
Click cell A14 and click the Insert Hyperlink button on the Standard
toolbar.
The Insert Hyperlink dialog box appears.
Click the Browse button next to the Link to file or URL text box.
Click the Files of type list arrow and select Workbooks (.xls) from the
list to display only Excel workbooks in the window.
The Link to File dialog box is updated so that it displays only Excel workbook files.
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6.
7.
8.
9.
10.

11.

Select the Trade Show Expenses workbook file and click OK.
The Link to File dialog box closes and the name and location of the Trade Show
Expenses is added to the Link to file or URL text box.
Click OK.
The dialog box closes and you return to the worksheet window. Test the new hyperlink
by clicking it.
Click the hyperlink Return to Trade Show Expenses in cell A14.
The Trade Show Expenses workbook appears in the worksheet window. Use the Web
toolbar to jump back to the previously viewed document.
Click the Back button on the Web toolbar.
You’re back to the Lesson 2 workbook. Now jump forward to the Trade Show
Expenses workbook.
Click the Forward button on the Web toolbar.
The Trade Show Expenses workbook appears in the worksheet window. Excel can
browse and navigate Web pages on the Internet just as easily as it can browse
workbooks. In the next lesson, you’ll learn how to save an Excel workbook as a Web
page, so it can be viewed on the Internet.
You don’t need the Web toolbar anymore, so go ahead and close it.
Right-click the Web toolbar and select Web to close the Web toolbar.
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Back button

Forward button

Table 10-4: The Web toolbar buttons
Button

Description
Brings you back to the previously viewed Web page.

Back

Brings to forward to the next viewed Web page.

Forward
Stop Current Jump

Stops loading a Web page.

Refresh Current Page

Reloads or refreshes the current Web page.

To Jump to a Hyperlink’s
Destination:

Start Page

Brings you to your home page.

• Click the Hyperlink.

Search the Web

Search the Web for specified information.

To Browse Files with
Excel:

Quickly brings you to Web pages that you have bookmarked
and use frequently.

• Use the Web toolbar (see
Table 10-4: The Web
toolbar buttons) to
navigate between files
just like you would browse
the Internet.

Favorites
Go
Shown Only Web Toolbar

Displays a list of Web commands that also appear on the Web
toolbar.
Toggles whether toolbars other than the Web toolbar should
be displayed or hidden.

Quick Reference

To Hide the Web Toolbar:
• Right-click the Web
toolbar and select Web.
Or…
• Select View → Toolbars
→ Web from the menu.
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Lesson 10-3: Saving a Workbook
as a Non-Interactive Web Page
Figure 10-6

Specify which parts of your
workbook you want to publish as a
Web page and if the Web page
should be interactive or not (see
Table 10-5: Interactive vs. NonInteractive Web Pages)

Specify how you want to
save your Web Page in
the Save As dialog box.
Figure 10-7
The Publish as Web Page
dialog box.

Select from more Web publishing
options

Figure 10-8
Displaying a noninteractive Web page in a
Web browser.

Specify what area of your workbook
you want to publish as a Web page

Figure 10-6

Figure 10-8

Figure 10-7
Add Spreadsheet or
PivotTable interactivity

Creates or changes the
title for your Web page

This lesson explains how you can save your Excel worksheets as Web pages so they can be
viewed on the Internet. You can save any existing Excel worksheets as Web pages files (also
known as HTML files) by selecting File → Save as Web Page from the menu.

Save as Web
Page

Saving Excel workbooks as Web pages isn’t anything new—Excel 97 had this feature as well.
But Excel 2000 can save workbooks as interactive Web pages. This means that users can
interact with the data on your Web page because they have basic spreadsheet functionality.
Interactive Web Pages let your users enter data, format data, calculate data, and sort and filter.
There is one major drawback to Interactive Web pages—only users who have Microsoft’s
Internet Explorer 4.01 or later Web browsing software (surprise!) can use Office 2000’s
Interactive Web pages, so any Netscape Navigator users are left in the dark. If your Web
audience includes Netscape Navigator users, you can still save your workbooks as static noninteractive Web pages. Table 10-5: Interactive vs. Non-Interactive Web Pages explains some
of the differences between the two.
This lesson explains how to save a non-interactive Web page.
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1.

Make sure Trade Show Expenses is the active workbook, then select File
→ Save as Web Page from the menu.
The Save As dialog box appears, as shown in Figure 10-6. You can save an Excel
workbook as several different types of Web pages:
•

Entire Workbook (Non-Interactive): Saves everything in the workbook—
all your worksheets and charts—as non-interactive web pages. To save the entire
workbook, check the Entire Workbook check box.

•

Sheet or Selection (Interactive or Non-Interactive): Saves a worksheet
or selected cell range. To save a sheet or selection, click the Publish button and
specify the area of the workbook you want to save. You can add interactivity by
checking the Add interactivity with box and selecting Spreadsheet functionality
from the drop-down list.

•

2.
3.
4.

PivotTable (Interactive): Saves a worksheet or selected cell range as an
Interactive PivotTable on the Web, which users can use to pivot, filter, and sort
data. To save a sheet or selection as a PivotTable, click the Publish button,
specify the area of the workbook you want to save, check the Add Interactivity
with box and select PivotTable functionality from the drop-down list.
Click the Publish button.
The Publish as Web Page dialog box appears, as shown in Figure 10-7. Here you have
to specify which areas of your workbook you want to save and how to save them.
Select Items on Sheet1 from the Choose list, then select Sheet All
Contents of Sheet1 from the box under the Choose list.
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Web pages are saved
in a format called
HTML. HTML stands
for Hypertext Markup
Language. HTML files
do not support some of
the more advanced
features of Excel, so
when you save an Excel
file as an HTML file
you may lose some of
the advanced
formatting.

Type Trade Web in the File name box, check the Open published web
page in browser box and click the Publish button.
Of course, you can also click the Browse button and browse to the drive and folder
where you want to save your Web page. Excel saves Sheet1 of the Trade Show
Expenses workbook as a non-interactive Web page and then opens the Web page in
your computer’s Web browser. Since the Web page isn’t interactive, you can only view
its information. We’ll create an interactive Web page in the next lesson.

Table 10-5: Interactive vs. Non-Interactive Web Pages
Web Page Type

Description
Interactive Web pages let users interact with the data on
your Web page because they include basic spreadsheet
functionality. Interactive Web Pages let your users enter
data, format, calculate, sort and filter data.
Interactive Web Pages require Microsoft Internet Explorer
4.01 or greater.

Interactive Web Pages
Non-interactive Web pages allow users to view worksheet
data but not interact with it.
Users can view non-interactive Web pages in any Web
browser.
Non-Interactive Web Pages

Quick Reference
To Save a Workbook as a
Non-Interactive Web Page:
1. Open the workbook and
select File → Save as
Web Page from the
menu.
2. Click Publish.
3. Specify what you want to
publish on your Web page
from the Choose list and
type a name for your Web
page file in the File name
box.
4. Click Publish.
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Lesson 10-4: Saving a Workbook
as an Interactive Web Page
Figure 10-9
Interactive Web pages
have basic spreadsheet
functionality, allowing
users to change and
calculate the Web page’s
data.
Figure 10-10
The Publish as Web Page
dialog box.
Figure 10-11
You can also save
workbooks as Interactive
PivotTables (see the
PivotTable chapter for
more information about
PivotTables).

Figure 10-9

Figure 10-10

Figure 10-11

In the previous lesson you learned how to save a workbook as a non-interactive Web page.
Non-interactive Web pages are great if you only want to present information and/or if you
don’t know which Web browser your audience has. If you’re publishing to a corporate
Intranet and/or you know your audience uses Microsoft Internet Explorer 4.01 or later, you
can save your workbooks as interactive Web pages, which allow users to add, change, sort,
filter, and calculate the data presented on a Web page.

1.
2.
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Make sure Trade Show Expenses is the active workbook, then select File
→ Save as Web Page from the menu.
The Save As dialog box appears.
Click the Publish button.
The Publish as Web Page dialog box appears, as shown in Figure 10-10. First you have
to specify which areas of the workbook you want to publish.
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3.
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Select Items on Sheet1 from the Choose list, then select Sheet All
Contents of Sheet1 from the box under the Choose list.
Next you have to tell Excel that you want to save the Web page with interactivity.
When you save a worksheet as a Web page you can add interactivity with:
•

Spreadsheet functionality: Enables users to enter, change, and calculate
data like they’re using an Excel worksheet.

•

4.
5.
6.
7.

8.

9.
10.

PivotTable functionality: Enables users to pivot, filter, sort, and analyze data
like they would using an Excel PivotTable report (see the chapter on Data
Analysis and PivotTables it you’re a little unclear about what a PivotTable report
is).
Add a check to the Add interactivity with box and verify Spreadsheet
functionality appears in the drop-down list to the right.
You can also create or change the title that appears at the top of your Web page,
whether or your Web page is interactive or not.
Click the Change button.
The Set Title dialog box appears.
Type Trade Show Expenses in the Title box and click OK.
Lastly you have to specify a file name for you Web page and where you want to save it.
Type Interactive Web in the File name box add a check to the Open
published web page in browser box and click the Publish button.
Excel saves Sheet1 of the Trade Show Expenses workbook as an interactive Web page
and opens the Web page in Microsoft Internet Explorer, as shown in Figure 10-9. Let’s
test the interactive Web page.
Click cell B5, type 400, and press <Enter>.
Wow! The Web page let’s you change the worksheet’s number and recalculates it, just
like Microsoft Excel! By no means do Interactive Web pages have all of Excel’s bells
and whistles features, but they have enough functionality for you to perform basic
calculations.
Place the cell pointer anywhere in the A column and click the Sort
Ascending button on the toolbar.
Excel sorts the information from the A column on the Web page alphabetically in
ascending order.
Close Microsoft Internet Explorer and close all open workbooks in Excel.

Set Title dialog
box

Sort Ascending
button

Quick Reference
To Save a Workbook as an
Interactive Web Page:
1. Open the workbook and
select File → Save as
Web Page from the
menu.
2. Click Publish.
3. Specify what you want to
publish on your Web page
from the Choose list and
type a name for your Web
page file in the File name
box.
4. Check the Add
Interactivity with box.
5. Click Publish.
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Lesson 10-5: Using Queries to
Retrieve Information from the
Web
Figure 10-12
The New Web Query
dialog box.
Figure 10-13
The External Data toolbar.
Figure 10-14
The Web page data
extracted into an Excel
workbook.

Enter the address for
the Web page that
contains the data you
want to retrieve…

…or click Browse Web,
browse to the Web page
and then return to Excel
once you’ve found the
Web page

Select the part of the
Web page that contains
the data you want
Specify how much of
the Web page’s
formatting you want to
keep
Save the Web query so
you can use it again
later

Figure 10-12

Edit the Query
Cancel Refresh
query
parameters refresh status

Data Range
Properties

Refresh
data

Refresh all

Figure 10-13
Figure 10-14

This lesson explains how to use a Web query to get information from a Web page on the
Internet. More and more companies are putting information on the Web, so it makes sense that
Microsoft Excel 2000 has a feature that allows you to retrieve data from a Web page on your
company’s intranet or from the World Wide Web. To get data from a Web page, you must have
Internet access either through your Intranet or through a modem and an account with an
Internet service provider.

1.
2.

Create a new workbook.
Select Data → Get External Data → New Web Query from the menu.
The New Web Query dialog box appears, as shown in Figure 10-12. There are a couple
different ways to get to the Web page that contains the information you want. You can:
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•

Type the address of the Web page in the text box

•

Click the Browse Web button, browse to the Web page in your Web Browser,
and then return to Microsoft Excel
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3.

4.

5.
6.

7.
8.
9.
10.

We’ll be using the first method for our exercise.
Enter the full name of your practice folder followed by \Office
Expenses.htm in the text box.
For example, you might type C:\Practice\Office Expenses.htm . This will retrieve
information from the Office Expenses Web pages saved in your Practice folder or disk.
You also need to specify which part of the Web page to extract information from.
Select the Only the tables option.
This will return information only from any tables that appear in a Web page. Since Web
pages frequently use tables to format and align their information, the Web query may
still return some extraneous information that can clean up later. You’re ready to query
the Office Expenses Web page.
Click OK.
Excel asks where you want to put the queried information. You can place the data in a
location on any existing worksheet or you can place the data on a new worksheet.
Click OK to place the queried data in cell A1 of the current worksheet.
Excel retrieves the data from the Office Expenses Web page and puts it in cell A1 of
the current worksheet, as shown in Figure 10-14. The External Data toolbar also
appears, which you can later use to refresh the data to make sure you have the most
recent numbers.
Excel 2000 also comes with several useful saved Web queries you can use—here’s how
to use a saved query. First we have to leave our current query.
Click the Sheet2 tab to go to that sheet.
You’re ready to run a saved query.
Select Data → Get External Data → Run Saved Query from the menu.
The Run Query dialog box appears with a list of saved queries that you can use to
retrieve information about the markets. To use one of these predefined queries just
select it and click the Get Data button.
Click Cancel to close the Run Query dialog box.
You’ve covered most of Excel’s Internet features, so you can exit the Excel program.
Exit Microsoft Excel without saving any of your work.

Well done! You’ve finished another chapter and have learned a new set of skills. Move on to
the Chapter review and let’s see how much you’ve retained.
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Quick Reference
To Run a Web Query:
1. Select Data → Get
External Data → Run
Saved Query from the
menu.
2. Select the query you want
to run and click Get Data.
3. Specify where in the
workbook you want to
insert the results of the
query and click OK.
To Create a Web Query:
1. Select Data → Get
External Data → New
Web Query from the
menu.
2. Click the Browse button
and browse to the Web
page that contains the
data you want to query (or
type the URL of the Web
page if you know it).
3. Select the part of the Web
page you want to query
(usually only the tables)
and click OK.
4. Specify where in the
workbook you want to
insert the results of the
query and click OK.
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Lesson Summary
Adding Hyperlinks to a Worksheet
•

A hyperlink is a link that points to a file, a specific location in a file, or a Web page on the Internet or
on an intranet.

•

To Insert a Hyperlink: Select the cell you want to use for the hyperlink and click the Insert
Hyperlink button from the Standard toolbar or select Insert → Hyperlink from the menu. Either
select a file you want (use the browse button to help you locate the file) or type a Web address for
the hyperlink’s destination and click OK.

•

To Edit a Hyperlink: Right-click the hyperlink and select Hyperlink → Edit Hyperlink from the
shortcut menu.

Browsing Hyperlinks and using the Web Toolbar
•

Click a hyperlink to jump to its destination (the file or Website it’s linked to). The Web toolbar will
appear whenever you click a hyperlink in Excel.

•

To Browse Files with Excel: Use the Web toolbar to navigate between files just like you would
browse the Internet.

•

To Hide the Web Toolbar: Right-click the Web toolbar and select Web or select View →
Toolbars → Web from the menu.

Saving a Workbook as a Non-Interactive Web Page
•

Non-interactive Web pages allow users to view worksheet data but not interact with it. Users can
view non-interactive Web pages in any Web browser, unlike when they view interactive pages,
which requires Microsoft Internet Explorer version 4.01 or later.

•

To Save a Workbook as a Non-Interactive Web Page: Open the workbook and select File →
Save as Web Page from the menu and click Publish. Specify what you want to publish on your
Web page from the Choose list, type a name for your Web page file in the File name box and click
Publish.

Saving a Workbook as an Interactive Web Page
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•

Interactive Web pages let users interact with the data on your Web page because they include
basic spreadsheet functionality. Interactive Web Pages let your users enter data, format data,
calculate data, and sort and filter. Interactive Web Pages require Microsoft Internet Explorer 4.01 or
greater so not everyone can use them.

•

To Save a Workbook as an Interactive Web Page: Open the workbook and select File → Save
as Web Page from the menu and click Publish. Specify what you want to publish on your Web
page from the Choose list and type a name for your Web page file in the File name box, check the
Add interactivity with box and click Publish.

Chapter Ten: Using Excel with the Internet
Using Queries to Retrieve Information from the Web
•

To Run a Web Query: Select Data → Get External Data → Run Saved Query from the menu,
select the query you want to run and click Get Data. Specify where in the workbook you want to
insert the results of the query and click OK.

•

To Create a Web Query: Select Data → Get External Data → New Web Query from the menu,
click the Browse button and browse to the Web page that contains the data you want to query (or
type the URL of the Web page if you know it). Select the part of the Web page you want to query
(usually only the tables), click OK, specify where in the workbook you want to insert the results of
the query and click OK.

Quiz
1. A hyperlink can point to which of the following items? (Select all that
apply.)
A.
B.
C.
D.

A location in the same Excel workbook.
A different Excel workbook.
A Microsoft Word document.
A Web page on the Internet.

2. The Web toolbar automatically appears whenever you click a hyperlink in
an Excel workbook. (True or False?)
3. Which of the following statements is NOT true?
A. Interactive Web pages allow users to enter, format, calculate, and sort Excel
worksheet data using a Web browser.
B. Non-interactive Web pages allow users to view Excel worksheet data using a Web
browser but not change it.
C. Interactive PivotTables allow users to pivot, filter, and sort an Excel PivotTable using
a Web browser.
D. Users must have version 4.0 or later of Microsoft Internet Explorer or Netscape
Navigator in order to work with an Interactive Web page.
4. While browsing the Internet you find a Web page that contains a table
whose data you want to import into an Excel worksheet. How can you
accomplish this?
A. Select File → Save As from the Web browser’s menu and specify that you want to
save the Web page as an Excel workbook.
B. Create a Web query in Microsoft Excel by selecting Data → Get External Data →
New Web Query from the menu and browsing to the Web page that contains the table
you want to import.
C. Select File → Open from the menu, select HTML from the Files of Type list and
enter the URL of the Web page in the File Name box.
D. There isn’t an automated way to import Web based information—you will have to
manually enter the information into Excel.
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5. When you save an Excel workbook as a HTML file, some of the workbook’s
formatting may be lost. (True or False?)
6. You can edit a hyperlink by right-clicking it and selecting Hyperlink → Edit
Hyperlink from the shortcut menu. (True or False?)

Homework
1. Open the Lesson 4A workbook and save it as “Web Practice.”
2. Click cell A10 type “Expenses” and press <Enter>. Click cell A10, click the Insert
Hyperlink button on the Standard toolbar and create a hyperlink to the Expenses
workbook.
3. Save the Web Practice workbook as a Web page.
4. Try running several of Excel’s built-in Web queries.

Quiz Answers
1. A, B, C, and D. A hyperlink can point to any of these items and more.
2. True. The Web toolbar always appears whenever you click a hyperlink in any
Microsoft Office application.
3. D. Netscape Navigator cannot view Excel’s Interactive Web pages.
4. B. You can import information on a Web page into Microsoft Excel by using a Web
query (although you will probably have to clean up the data after importing it).
5. True. An HTML file doesn’t have as many formatting options as an Excel worksheet.
6. True. To edit a hyperlink, right-click it and select Hyperlink → Edit Hyperlink from
the shortcut menu.
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Chapter Eleven: Data
Analysis and
PivotTables
Chapter Objectives:
•

Create a PivotTable

•

Change or “Pivot” a PivotTable

•

Use the Page Field to filter what data is displayed in a PivotTable

•

How to group information in a PivotTable by date

•

Create and work with subtotals

•

Use Database functions (DSUM)

•

Use Lookup functions (VLOOKUP)

•

Group and outline a worksheet

Chapter Task: Analyze ticket sales
Once you have created a list, there are many ways to analyze its data. You should already
know some basic ways to analyze information, such as filtering records. This chapter explains
more advanced and powerful methods of analyzing list information.
Creating a PivotTable is usually the best way to summarize and analyze list data—which is
why we’ll spend more than half of the chapter discussing it. A PivotTable is a way to
summarize list information. Peek at Figure 11-1 and Figure 11-2 on the next page to see how
much easier it is to make sense of numbers in a list with a PivotTable. This chapter explains
the ins and outs of PivotTables—how to create them, modify their structure, and edit the data
a PivotTable is based on.
This chapter also includes lessons on several other ways to summarize and analyze worksheet
information, such as how use Excel’s subtotal function, how to create database-specific
formulas, and how to outline your worksheets.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• Create and work with a
list.
• How to enter formulas.
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Lesson 11-1: Creating a
PivotTable
Figure 11-1
It’s difficult to see the
bottom line in a long list
like this.
Figure 11-2
This Pivot Table displays a
summary view of Figure
11-1’s information.

Figure 11-2

Figure 11-3
Step 1 of 3 of the
PivotTable Wizard asks
where the data you want
to analyze comes from
and if you want to create a
PivotTable or a PivotChart
with a PivotTable.

Figure 11-1

Specify where you want to put your
PivotTable: In a new worksheet or
embedded in an existing worksheet

Figure 11-4
Step 3 of 3 of the
PivotTable Wizard asks
where you want to put the
PivotTable.

Sets advanced formatting, layout, memory
management, and external data options for
your PivotTable report

Figure 11-3

Figure 11-4

Figure 11-5
This newly created
PivotTable (without any
information).

Figure 11-5

Creating a PivotTable is remarkably easy. You create PivotTables using the PivotTable
Wizard, which asks which fields you want to include in the PivotTable, how you want your
PivotTable organized, and which types of calculations your PivotTable should perform.
PivotTables may sound confusing, but they will make a lot more sense when you’ve actually
created one.
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1.

2.
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Open the workbook named Lesson 11A and save it as PivotTable.
This workbook contains figures for ticket sales from a recent promotion. The list
contains flight dates, agents, offices which sold the tickets, destinations, sales amounts,
and if the agents received a commission or not. It’s difficult to see the bottom line in a
large list like this. For example, how many tickets did the Blaine office sell, or how
many tickets were sold to London? The PivotTable Wizard can help you summarize the
list and provide you with meaningful information.
Make sure the cell pointer is located in the list (A1:I200) and select Data
→ PilotTable and PivotChart Report from the menu.
The First Step of the PivotTable Wizard dialog box appears. Here you must specify the
location of the data you want to use in your PivotTable. There are four options:
•

Microsoft Excel list or database: Creates a PivotTable from data in
columns on your worksheet (the most commonly used option).

•

External data source: Creates a PivotTable from data stored in a file or
database outside of the current workbook or Microsoft Excel.

•

Multiple consolidation ranges: Creates one PivotTable from multiple cell
ranges in different worksheets.

•

3.

4.

Another PivotTable: Creates a PivotTable from another PivotTable in the
same workbook.
You also have to specify if you want to create a PivotTable Report or a PivotTable
Report along with a corresponding PivotChart report.
Verify that the Microsoft Excel list or database and the PivotTable
options are both selected and click Next.
Step Two of the PivotTable Wizard appears. You need to tell the PivotTable Wizard
where the data you want to use in the PivotTable is located. Because the cell pointer
was located inside the list when you started the PivotTable Wizard, the cell range of the
list (A1:I200) is already selected.
Click Next.
The third and last step of the PivotTable Wizard appears, as shown in Figure 11-4.
Here’s where you tell Excel to put your PivotTable report. You can place your
PivotTable report in:
•

5.

A new worksheet.

• Embedded in an existing worksheet.
Verify that the New worksheet option is selected and click Finish.
The PivotTable Wizard dialog box closes and the PivotTable appears on a new
worksheet, as shown in Figure 11-5. Notice the PivotTable is empty—that’s because
we haven’t specified the data we want to analyze yet—something you’ll learn in the
next lesson.

Quick Reference
To Create a PivotTable:
1. Make sure the cell pointer
is located in the list.
2. Select Data → Pivot
Table and PivotChart
Report from the menu.
3. Select the location of the
data you want to include
in your PivotTable report
and the type of report
(PivotTable report or
PivotTable with PivotChart
report) and click Next.
4. In Step 2 make sure the
list range is selected and
click Next.
5. In Step 3, specify a
location for the PivotTable
(a new worksheet or an
existing worksheet.)
6. Click Finish.
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Lesson 11-2: Specifying the Data
a PivotTable Analyzes
Figure 11-6
Dragging the Office field
from the PivotTable
toolbar to the Column area
of the PivotTable.

Column area

Figure 11-7

PivotTable toolbar
Drag the field you want to
summarize tothe row, column, or
data area of the PivotTable

The PivotTable
summarizing the total
tickets sold by Destination
and Office.

Data area

Figure 11-6

Row area

Indicates how the PivotTable is
being summarized (here by Sum)

Figure 11-7

Once you’ve created your PivotTable report, you have to specify the data you want to analyze
with the PivotTable. It’s easy to specify which data you want to analyze—simply drag it from
the PivotTable toolbar and onto the Row, Column, or Data area on the PivotTable report.
You’re not going to understand how to do this unless you try it—so let’s get started!

Destination field
button

1.
2.

3.
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Drag the Destination field button from the PivotTable toolbar to the
ROW area of the PivotTable diagram.
The Destination field appears at the top of the ROW area in the PivotTable. Next, make
the Office field the column heading for the PivotTable.
Drag the Office field button from the PivotTable toolbar to the COLUMN
area of the PivotTable diagram, as shown in Figure 11-6.
You have selected the Destination field to be the row heading and the Office field to be
the column heading for your PivotTable. Now you need to select the field you want to
summarize.
Drag the Number of Tickets field button from the PivotTable toolbar to
the DATA area of the PivotTable diagram.
Compare your dialog box with the one shown in Figure 11-7.

Chapter Eleven: Data Analysis and PivotTables

4.
5.
6.

The neat thing about PivotTables is that their information is dynamic. What this means
is once you’ve created a PivotTable, you can rearrange or “pivot” it to view its data in
different ways. For example, you could rearrange the PivotTable you just created so
that it summarizes the amount of the total ticket sales instead of the total number of
tickets sold.
Drag the Sum of Tickets field button (located in cell A3) off the
PivotTable diagram.
The PivotTable will no longer total the number of tickets sold. You can easily
summarize another field by dragging it onto the DATA area of the PivotTable diagram.
Drag the Total field button to the DATA area of the PivotTable diagram.
You can also rearrange a PivotTable’s headings.
Drag the Destination field button from the ROW area of the PivotTable
diagram to the COLUMN area and drag the Office field button from the
COLUMN area of the PivotTable diagram to the ROW area.
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Sum of Tickets
field button

Hopefully, you’re starting to understand the true power of PivotTables. PivotTables can
usually make information stored in even the longest lists easy to understand.

Quick Reference
To Create a PivotTable:
1. Make sure the cell pointer
is located in the list.
2. Select Data → Pivot
Table Report from the
menu.
3. Select either the Microsoft
Excel List or Database
option and click Next.
4. In Step 2, make sure the
list range is selected and
click Next.
5. In Step 3, drag the field
names you want to
summarize to the
appropriate section of the
PivotTable diagram
(Page, Column, Row, or
Data) and click Next.
6. In Step 4, specify a
location for the PivotTable
(a new worksheet or an
existing worksheet).
7. (Optional) Click the
Options button to specify
any additional options for
the PivotTable.
8. Click Finish.
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Lesson 11-3: Changing a
PivotTable's Calculation
Lists PivotTable
commands

Figure 11-8

Create a
PivotChart

The PivotTable Field
dialog box.

Shows or hides
Change how a
detail data in a row PivotTable is
or column field
summarized

Figure 11-9
The PivotTable toolbar.
Figure 11-10

Figure 11-8

The PivotTable
summarized by the Sum
of ticket sales.

Format the
PivotTable

Figure 11-9

Start the
PivotTable
Wizard

Updates the Display/hide
PivotTable field buttons
source data

Figure 11-11
The PivotTable
summarized by the
Average of ticket sales.

Figure 11-10

PivotTable Field
button

In the previous lesson, you learned how to change the data you want included in the
PivotTable report. You can also change how a PivotTable summarizes its information. For
example, you might want a PivotTable to display averages instead of totals.

1.
Quick Reference
To Change the Calculation
Used in a PivotTable:
1. Make sure the cell pointer
is located in the
PivotTable and click the
PivotTable Field button
on the PivotTable toolbar.
2. Select the calculation you
want to use from the
Summarize by list and
click OK.
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Figure 11-11

2.
3.
4.
5.

Click cell B3 and select Window → Freeze Panes from the menu.
Now the column and row headings to the left and above the active cell (B3) will
always be visible as you scroll through the worksheet.
Scroll down to the U column.
The PivotTable has created column totals, which calculates the total number of
reservations made at each office.
Scroll to row 23.
The PivotTable has also calculated the total number of reservations made to each
destination.
Click the PivotTable Field button on the PivotTable toolbar.
The PivotTable Field dialog box appears, as shown in Figure 11-8. The PivotTable
Field dialog box lets you change how a PivotTable is calculated. For example, instead
of totaling the ticket sales made, you could find the average:
Select Average from the Summarize by list and click OK.
The PivotTable Field dialog box closes and the PivotTable displays the average ticket
sales.
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Lesson 11-4: Selecting What
Appears in a PivotTable
Figure 11-12
Using a page field to filter
summary information in a
PivotTable.
Figure 11-13
Dragging a field to the
Page Field area of a
PivotTable report.
Figure 11-12

Figure 11-14

Figure 11-13

Page field area

Using a page field to filter
summary information in a
PivotTable.

Page field

Figure 11-14

You can filter which information is summarized in a PivotTable by clicking a row or column
field’s drop-down arrows and selecting the items you want to include in the PivotTable report
or by adding a page field to the PivotTable. In this lesson, you’ll learn how to filter the
information that is included in a PivotTable Report using both methods.

1.
2.

3.
4.

Click the Office field drop-down list located in cell A4.
A drop-down list appears beneath the Office field, as shown in Figure 11-12. You can
select which values appear in your PivotTable report by making sure they are checked
and remove values by removing their checkmark.
Remove the checkmark from the Blaine, Bloomington, Brainerd,
Brooklyn Center, and Duluth boxes and click OK.
The Bloomington, Brainerd, Brooklyn Center, and Duluth offices no longer appear in
the PivotTable report. You can also filter the information that appears in a PivotTable
report by adding a Page Field to the PivotTable.
Drag the Commission field button to the PAGE area of the PivotTable
diagram.
Now you will be able to filter the PivotTable using the commission field and display
data for sales with commissions, sales without commissions, or both.
Click the Commission list arrow, located in cell B1, select Yes and
click OK.
The PivotTable displays only information for commissioned sales.

Quick Reference
To Add a Page Field to a
PivotTable:
1. Make sure the cell pointer
is located in the
PivotTable and click the
PivotTable Wizard
button on the PivotTable
toolbar.
2. Drag the field name you
want to use to filter the
PivotTable to the PAGE
section of the PivotTable
diagram and click Finish.
To Filter a PivotTable’s
Summary Information:
• Select what you’d like to
see on the PivotTable
report from the Row
heading, Column
heading, or Page Field
drop-down list.
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Lesson 11-5: Grouping Dates in a
PivotTable
Figure 11-15
Summarizing ticket sales
by date.
Figure 11-16
The Grouping dialog box.
Figure 11-17

Figure 11-15

Grouping the dates in the
PivotTable by months.

Figure 11-16

Select a date
increment to
group by

Figure 11-17

Quick Reference
To Group Information by
Date or Time:
1. Select the row or column
heading that contains the
date or time value you
want to group by and click
the Group button on the
PivotTable toolbar.
Or…
Select any row or column
heading that contains the
date or time value you
want to group by and
select Data → Group
and Outline → Group
from the menu.
2. Specify the starting and
ending dates and the
interval you want to group
the dates or time by, then
click OK.
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PivotTables can usually summarize information without any outside help from you. When you
want to summarize a list by dates, however, you will probably need to coach Excel and tell it
how you want to group the information in the PivotTable: by days, months, quarters, or years.
In this lesson, we’ll rearrange out PivotTable and summarize its information by month. First,
you need to rearrange your PivotTable to summarize it by date.

1.
2.

3.
4.

Drag the Office field button off the PivotTable diagram and drag the
Destination field button from the Column area of the PivotTable to the
Row area.
Next, you need to add the Date field to the PivotTable’s Column area.
Drag the Date field button to the Column area of the PivotTable.
Now the PivotTable summarizes ticket sales by destination and date as shown in Figure
11-15. The only problem is that the PivotTable summarizes the dates by day—making
the summary information rather meaningless. You can make the PivotTable more
useful by grouping the days into months using the Group command. First you need to
specify what information you want to group by: the dates.
Click the Date button located in cell B3 then select Data → Group and
Outline → Group from the menu.
The Grouping dialog box appears, as shown in Figure 11-16. You need to select a date
or time interval by which to group.
Select Months from the By list and click OK.
The Group dialog box closes and the PivotTable groups the dates by month, as shown
in Figure 11-17.
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Lesson 11-6: Updating a
PivotTable
After making changes
to the list, the
PivotTable still displays
the old values

Figure 11-18
A PivotTable that needs to
be refreshed.
Figure 11-19
The Refreshed PivotTable.

Figure 11-18
The PivotTable now
displays the changes
made to the list

Figure 11-19

If you modify the source data a PivotTable is based on, the PivotTable isn’t automatically
updated. Instead you must manually refresh the PivotTable any time you change its
underlying source data. This lesson explains how to do just that.

1.
2.
3.
4.
5.

Click the Promotion Sales tab.
Click cell G19, type 100 and press <Enter>.
Obviously, Phillip Grahams didn’t sell 100 tickets to Boston, but this is a big enough
number that you will be able see the changes in the PivotTable’s January column when
you update it.
Click the Sheet1 tab to return to the PivotTable.
Look at cell B5, the January column. The PivotTable does not reflect the increased
ticket sales you made to the list, as shown in Figure 11-18.
Click anywhere in the PivotTable and click the Refresh Data button on
the PivotTable toolbar.
The PivotTable is refreshed and correctly displays the current list data, as shown in
Figure 11-19.
Save your work and then close the Pivot Table worksheet.

That’s it—we’re finished working with PivotTables! PivotTables are the most powerful way
to summarize information in a list, but they’re not the only method you can use. The
remainder of this chapter explores some of the other ways to summarize list information.

Refresh Data
button
Other Ways to Refresh a
PivotTable:
• Select Data → Refresh
Data from the menu.
Quick Reference
To Refresh a PivotTable:
• Click the Refresh
Data button on the
PivotTable toolbar.
Or…
• Select Data → Refresh
Data from the menu.
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Lesson 11-7: Formatting and
Charting a PivotTable
Figure 11-20
AutoFormatting a
PivotTable Report.
Figure 11-21
The completed PivotChart.

Scroll up or down to see all the
PivotTable report formats

Figure 11-20

Add or change the information in
a PivotChart by dragging the
PivotTable’s field buttons…

…to one of these areas on the
PivotChart.

Figure 11-21

This lesson explains how you can quickly format a PivotTable report using the AutoFormat
command and how to create a PivotChart—both new features introduced in Excel 2000.
First, let’s discuss how to format your PivotTable with AutoFormat. AutoFormat is a built-in
collection of formats such as font sizes, patterns, and alignments you can quickly apply to a
PivotTable report. AutoFormat lets you select from 20 different preset formats. AutoFormat is
a great feature if you want your PivotTables to look sharp and professional but don’t have the
time to format them yourself.

Format Report
button

1.
2.
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Make sure the cell pointer is located in the PivotTable report and click the
Format Report button on the PivotTable toolbar.
The AutoFormat dialog box appears, as shown in Figure 11-20. You can format your
PivotTable report using a preset format.
Scroll down the AutoFormat dialog box, select the Table 2 format and
click OK.
The PivotTable is formatted with the preset Table 2 formatting settings.
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3.

4.

5.
6.

7.
8.
9.

Let’s move on to this lesson’s other topic, creating a PivotChart. A PivotChart is similar
to an ordinary chart created in Excel, except that it plots a PivotTable’s information.
PivotCharts differ from ordinary Excel charts because they are dynamic, just like
PivotTables reports. You can change a PivotChart’s structure just like you would with a
PivotTable.
Make sure the cell pointer is located in the PivotTable report and click the
Chart Wizard button on the PivotTable toolbar.
Excel creates a chart from the PivotTable and places it on a new sheet tab, labeled
Chart1. You can format and work with a PivotChart just like you would with a regular
chart. Since there’s so much information in our PivotTable, the PivotChart we just
created looks cluttered. As with PivotTables, you can specify which items you want to
appear in a PivotChart.
Click the Destination drop-down list located above the chart’s legend
and remove the checkmarks from all the destinations except Cancun,
Chicago, Dallas, and Detroit.
Only the specified destinations are plotted on the PivotChart. Let’s change the chart
type to make our PivotChart easier to understand.
Select Chart → Chart Type from the menu.
The Chart Type dialog box appears.
Select a Clustered Column Chart from the Chart Sub-Type list and click
OK.
The chart type is changed to a clustered column chart, as shown in Figure 11-21.
Just about everything you can do to a PivotTable report you can do to a PivotChart. For
example, you can easily add, change, remove, or rearrange what the PivotChart plots.
Drag the Sum of Total field (located in the upper left corner of the chart)
from the PivotChart back to the PivotTable toolbar to remove it.
Since the PivotChart has no data to plot, it displays the message “Drop Data Items
Here.”
Drag the Tickets field from the PivotTable toolbar to the empty Data area
of the PivotChart.
The PivotChart now plots the total number of tickets sold to each destination.
Save your work and then close the Pivot Table worksheet.

That’s it—we’re finished working with PivotTables and PivotCharts! PivotTables are the most
powerful way to summarize information in a list, but they’re not the only method you can use.
The remainder of this chapter explores some of the other ways to summarize list information.
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Chart Wizard
button

Clustered Column
Chart Type

Quick Reference
To Format a PivotTable:
• Make sure the cell pointer
is located in the
PivotTable report and
click the Format Report
button on the PivotTable
toolbar. Select the
formatting you want to
apply and click OK.
To Create a PivotChart:
• Place the cell pointer
anywhere in a PivotTable
report and click the Chart
Wizard button on the
PivotTable toolbar. You
will probably have to
change the chart type.
Or…
• Create a PivotTable and
PivotChart from scratch.
See the instructions for
creating a PivotTable.
To Modify a PivotChart:
• Modify a PivotChart the
same as you would a
PivotTable—drag and
drop fields to and from the
PivotTable toolbar and the
PivotChart.
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Lesson 11-8: Creating Subtotals
Figure 11-22

Field to group by

The Subtotal dialog box.

Summarize groups using
this function

Figure 11-23
A subtotaled list, with all
details displayed.

Add subtotals to these
fields

Figure 11-24
A collapsed subtotal list,
with only the subtotal
values displayed.

Check to add grand totals

Figure 11-22
Column levels
buttons

Hide details button

Figure 11-23

Show details button

Figure 11-24

So far in this chapter, we’ve been summarizing information in a list using PivotTables.
Another quick and easy way to group and summarize data is to use Excel’s subtotals feature.
Usually you create subtotals with the SUM function, but you can also create subtotals using
functions such as COUNT, AVERAGE, MAX, and MIN.

1.
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Open the workbook named Lesson 11B.
You need to sort the list before you use the Subtotals command. You want to sort the
list alphabetically by destination.
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2.
3.
4.

5.
6.
7.

8.
9.
10.
11.

Click any cell in the E column and click the Sort Ascending button on
the Standard toolbar.
The list is sorted alphabetically by destination. Now that the list is sorted, you can use
the Subtotals command.
Make sure the active cell is located within the list and select Data →
Subtotals from the menu.
The Subtotal dialog box appears, as shown in Figure 11-22. You want to summarize the
list based on the Destination field—the field you sorted in the previous step.
Select Destination from the At each change in list, then select Sum
from the Use function list.
This will create subtotals every time the destination changes (which is why you had to
sort the list based on destination back in Step 2. Next, you need to specify that you
want to add subtotals to the Annual Trips and Annual Cost of Tickets fields.
In the Add subtotal to list, check the Tickets check box, and the Total
check box (you may have to scroll up or down to find them). Make sure
the other check boxes in the list aren’t checked.
This will add subtotals to the Tickets and Total columns.
Make sure the Replace current subtotals and Summary below data
check boxes are checked.
Compare your Subtotal dialog box to the one in Figure 11-22.
Click OK.
The dialog box closes and Excel summarizes the list and calculates the subtotals for
each time the destination field changes. Notice Excel displays the outline symbols to
the left of the worksheet, as shown in Figure 11-23. We’ll save outlining for another
lesson. For now, try using the Outline buttons to hide the list details.
Click the 2 Column Level Symbol button.
Excel hides the third level of detail in the list (the employees) and now only displays
the totals for each office.
Click the 3 Column Level Symbol button.
All the outline details are again visible. You can turn off the subtotaling now.
Make sure the active cell is located within the list and select Data →
Subtotals from the menu, then Remove All.
The subtotals and outlining are removed from the list. You can remove Subtotals from
a workbook at any time.
Close the workbook without saving it.
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Sort Ascending
button

Column Level
buttons

Quick Reference
To Calculate Subtotals:
1. Make sure the list is
sorted.
2. Select Data → Subtotals
from the menu.
3. Enter the appropriate
information in the Subtotal
dialog box and click OK.
To Remove Subtotals:
• Make sure the active cell
is located within the list,
then select Data →
Subtotals from the menu
and click Remove All.
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Lesson 11-9: Using Database
Functions
Figure 11-25
Using the Formula Palette
to create a DSUM formula.
Figure 11-26
The syntax of the DSUM
function.
Figure 11-27
The DSUM function totals
only those records that
meet your criteria.

Figure 11-25

=DSUM(A1:I23, "Annual Trips", C25:C26)
Function

Database
the range of
cells that make
up the list

Field
the name or number of
the column that is used
in the function

Criteria
the range of cells
that contains the
conditions you want
to specify

Figure 11-26

Field used in
DSUM formula

Criteria range
DSUM formula

Figure 11-27

Excel’s database functions perform calculations only for records that meet the criteria you
specify. For example, you might only want to count tickets that were sold to Boston. All the
database functions use the same basic syntax =Function(database, field, criteria). These
arguments (parts) of database functions include:
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•

Database: Is the cell range that makes up the list or database.

•

Field: Indicates which column is used in the function. You can refer to fields by their
column labels as long as you enclose them with double quotation marks, such as "Name."
You can also refer to fields as a number that represents the position of the column in the
list: 1 for the first column in the list, 2 for the second, and so on. Make sure you refer to
their position in the list, and not the column heading numbers!

•

Criteria: Is a reference to the cell or cell range that specifies the criteria for the function.

Chapter Eleven: Data Analysis and PivotTables

321

This lesson explains how to use database functions by creating a formula with the simplest
database function—the DSUM function.

1.
2.
3.
4.
5.

6.

7.

8.
9.
10.

Open the Lesson 11C workbook and save it as Data Functions.
Start by adding a meaningful label for the results of the DSUM formula.
Click cell C25 (scroll down if necessary), click the Bold button on the
Formatting toolbar, type Purpose and press <Enter>.
Next, enter the criteria the DSUM function will use (you’ll see how the criteria works
later when we actually create a DSUM formula.
Type Business in cell C26.
We’ll enter a DSUM formula in cell C27.
Make sure the active cell is C27, then click the Paste Function button
on the Standard toolbar.
The Paste Function dialog box appears.
Select Database from the Function Category list, select DSUM from the
Function Name list and click OK.
The Formula Palette appears, as shown in Figure 11-25. You’re ready to start entering
the DSUM formula to calculate the total for Annual Trips amounts for only those
records that have “Business” in the Purpose column. The first argument in the DSUM
function is to define the database—the cell range that makes up the list.
Click the Database text box and select the entire list—the cell range
A1:I23 (you may have to use the Collapse dialog box button) and press
<Enter>.
The second argument in the DSUM function is to define the Field—the column that is
used in the function. You can enter the Field by typing the column label enclosed
between double quotation marks, such as "Annual Trips" or as a number that represents
the position of the column in the list: 1 for the first column, 2 for the second column,
etc. For example, the column you want to total, Annual Trips, is the seventh column in
the list, so you would type either 7 or "Annual Trips" for the Field argument.
Click the Field text box and type "Annual Trips".
You also could have typed 7. The last argument in the DSUM function is the Criteria—
the range of cells that contains the conditions you want to specify. You can use any
range for the criteria argument, as long as it includes at least one column label and at
least one cell below the column label for specifying a condition for the column.
Click the Criteria text box and select the cell range C25:C26.
The cell range C25:C26 contains both the column label, Purpose, and the criteria,
“Business”.
Click OK to close the Function Palette.
Excel displays the result of the DSUM function in cell C26—42. Try changing the
criteria value in C26 to calculate the total number of annual flights for the records that
contain “Pleasure” in the Purpose column.
Click cell C26, type Pleasure, and press <Enter>.
The DSUM value in cell C26 changes to 19—the total number of annual flights for the
records that contain “Pleasure.”

11. Save your work.

Paste Function
button

Collapse Dialog
button

Quick Reference
To Use the DSUM
Function in a Formula:
• Write the formula using
the syntax
=DSUM(database, field,
criteria).
Or…
1. Click the Paste Function
button on the Standard
toolbar to open the
Formula Palette.
2. Select Database in the
Function category list,
select DSUM in the
Function name list, and
click OK.
3. Enter the required
arguments for the DSUM
function.
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Lesson 11-10: Using Lookup
Functions
Figure 11-28
Using the Formula Palette
to create a VLOOKUP
formula.
Figure 11-29
The syntax of the DSUM
function.
Figure 11-30
The VLOOKUP function
searches for a value in the
leftmost column of a table,
and then returns the value
in the same row from a
column you specify in the
table.

Figure 11-28

=VLOOKUP(D26, A1:I23, 8)
Function Lookup Value
the value to be
found in the
first column of
the table array

Figure 11-29

Table Array
the cell range
in which data is
looked up

Column Index
Number
the number of the
column from which the
matching value must
be returned

First column of
Table Array

Returned
value

Lookup Value

Figure 11-30

VLOOKUP formula

The VLOOKUP function looks up information in a worksheet. The VLOOKUP searches
vertically down the leftmost column of a cell range until it finds the value you specify. When
it finds the specified value, it then looks across the row and returns the value in column you
specify. The VLOOKUP function works a lot like looking up a number in a phonebook: first
you look down the phonebook until you find the person’s name, then you look across to
retrieve the person’s phone number.
Are you thoroughly confused yet? There’s no denying it—the VLOOKUP function is
somewhat obtuse and almost impossible to explain unless you’ve actually used it—and you’ll
get a chance to use the VLOOKUP function in this lesson.
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1.
2.
3.
4.
5.

6.

7.

8.

9.
10.

Click cell D25, click the Bold button on the Formatting toolbar, type
Sales By Rep and press <Enter>.
Next, enter the lookup value for the VLOOKUP function (you’ll see how the lookup
value works when we actually create the VLOOKUP formula).
Type Ronald in cell D26.
Before using the VLOOKUP function, you should sort the list by the column that
contains the lookup value.
Select any cell that contains data in the A column and click the Sort
Ascending button on the Standard toolbar to sort the list.
We’ll enter the VLOOKUP formula in cell D27.
Click cell D27 and click the Paste Function button on the Standard
toolbar.
The Paste Function dialog box appears.
Select Lookup and Reference from the Function Category list, select
VLOOKUP from the Function Name list and click OK.
The Formula Palette appears, as shown in Figure 11-28. You’re ready to start entering
the VLOOKUP formula to lookup annual trip costs by the employee’s first name. The
first argument in the VLOOKUP function is to specify the value you want to look up in
the first column of the cell range. Lookup values can be values, references, or labels.
Cell D26 contains the value you want to look up—the client’s first name.
Click the Lookup_value box and click cell D26 (you may need to use the
Collapse dialog box button).
The second argument in the VLOOKUP function is to define the Table Array—the cell
range that contains the data you want to look up.
NOTE: Remember when you define the Table Array, the VLOOKUP function looks
up values from the first column of the specified cell range. So if you wanted
to lookup values by City instead of by First Name, you would make sure that
the City column was the first column in the selected cell range.
Click the Table_array box and select the entire list—the cell range
A1:I23 (you may have to click the Collapse dialog box button).
The third argument in the VLOOKUP function is to specify the Column Index
Number—the column number from which the matching value must be returned. For
example, the column you want to lookup, Annual Cost of Tickets, is the eighth column
in the list, so you would type 8 for the Column Index Number argument.
Click the Col_index_num box, type 8, and click OK to close the
Function Palette.
Excel looks up the first value in the First column that matches the Lookup Value in
cell D26, “Ronald” and displays the value in the eighth column of that row, 3000. Try
changing the Lookup Value in D26 to look up the annual ticket cost for another name.
Click cell D26, type John, and press <Enter>.
The VLOOKUP value in cell D26 changes to 1686—the annual ticket cost for John
Peters.
Save your work and close the Database Functions workbook.
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Sort Ascending
button

Paste Function
button

Collapse Dialog
button

Quick Reference
To Use the VLOOKUP
Function in a Formula:
• Write the formula using
the syntax =VLOOKUP
(lookup_value,table_array
, col_index_num).
Or…
1. Click either the Paste
Function button on the
Standard toolbar to open
the Formula Palette.
2. Select Lookup and
Reference in the
Function category list,
select VLOOKUP in the
Function name list, and
click OK.
3. Enter the required
arguments for the
VLOOKUP function.
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Lesson 11-11: Grouping and
Outlining a Worksheet
Figure 11-31
A worksheet displayed in
Outline view.
Figure 11-32
Displaying and hiding an
outline’s detailed records
by clicking the group Hide
or Show Details button.

Column Level
buttons
Row Level
buttons

Hide Detail
button

Figure 11-31

Figure 11-32

Details displayed

Click the Hide
Details button

Details hidden

Many spreadsheets are created in a hierarchical style. For example, a worksheet might contain
a column for each month, followed by a total column. By outlining your worksheets, you
make them easier to understand and read. Instead of sifting through irrelevant information,
you can collapse an outline to display each group’s total or bottom line.
There are several ways to outline a workbook:

Hide Details
button

Show Details
button

•

Using the Subtotals Feature: The Data → Subtotals command calculates subtotal
and grand total values for the labeled columns you select. Excel automatically inserts and
labels the total rows and outlines the list. We covered creating and working with subtotals
earlier in this chapter.

•

Using the Consolidate Feature: You can consolidate several sheets selecting Data
→ Consolidate from the menu.

•

Using the Auto Outline Feature: The Data → Group and Outline → Auto Outline
command automatically outlines a selected range of cells or the entire worksheet, based
on formulas and the direction of references.

•

Manually Creating an Outline: You can group rows and columns manually by
selecting them and selecting Data → Group and Outline → Group from the menu.

This lesson explains how to use the third and fourth methods and how to work with an
outline.

1.
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Open the Lesson 11D workbook.
We’ll start this lesson by manually grouping the rows for the Blaine office.
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2.

3.
4.
5.

6.

7.
8.
9.
10.
11.

Select rows 5 and 6 and select Data → Group and Outline → Group
from the menu.
Excel groups the selected rows in an outline. Notice the Hide Details button that
appears to the left of the worksheet. Clicking a Hide Details button hides, or collapses,
its group of records.
Click the Hide Details button to the left of the worksheet.
Excel hides the details, rows 5 and 6, for the Blaine office and changes the Hide
Details button ( ) to a Show Details button ( ), indicating it contains hidden records.
Clicking the Show Details button displays, or expands, its group of records.
Click the Show Details button to the left of the worksheet.
Excel displays the hidden records. It’s just as easy to ungroup records as it is to group
them.
Select rows 5 and 6 and select Data → Group and Outline → Ungroup
from the menu.
Excel ungroups the records.
Before you manually create an outline by grouping dozens of records, you should see if
Excel can automatically create the outline for you. Excel can automatically outline
worksheets if they contain formulas that consistently point in the same directions.
Excel can automatically group and outline this worksheet since it does contain
formulas that all consistently point to the right (the quarterly subtotals) and down (the
office subtotals).
Select Data → Group and Outline → Auto Outline from the menu.
Excel analyzes the formulas in the worksheet and creates an outline, as shown in
Figure 11-31. You can still expand and collapse each group in the outline by clicking
the corresponding Show Details or Hide Details buttons, but an easier way is to use the
Column Level buttons. The Column Level buttons display or hide a specific level in
your worksheet. For example, if an outline has three levels, you can hide all the third
levels by clicking the button.
Click the Row Level 2 button.
Excel displays only the first two levels in the outline—the totals for each office. You
can also hide and display columns the same way.
Click the Column Level 2 button.
Excel collapses the outline so that only the quarterly and annual totals are displayed. To
expand the outline, just click the symbol for the lowest row and column level. For
example, if there are three levels, click the button.
Expand the outline by clicking the Column Level 3 button and the Row
Level 3 button.
It’s easy to remove an outline from a worksheet:
Select Data → Group and Outline → Clear Outline from the menu.
The outline is removed from the worksheet.
Exit Excel without saving your changes.
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Row Level 2
button

Column Level 2
button

Quick Reference
To Manually Group
Columns or Rows:
• Select the columns or
rows you want to group
and select Data →
Group and Outline →
Group from the menu.
To Manually Ungroup
Columns or Rows:
• Select the grouped
columns or rows and
select Data → Group
and Outline → Ungroup
from the menu.
To Outline a Worksheet
Automatically:
• Select Data → Group
and Outline → Auto
Outline from the menu.
To Remove an Outline:
• Select Data → Group
and Outline → Clear
Outline from the menu.
To Hide/Display Outline
Details:
• Click the group’s Show
Details button or the
Hide Details button.
Or…
• Click the appropriate Row
Level button or Column
Level button.

326

Microsoft Excel 2000

Chapter Eleven Review
Lesson Summary
Creating a PivotTable
•

A PivotTable summarizes list information dynamically, meaning once you have created a
PivotTable, you can rearrange or “pivot” it to view its data in different ways.

•

To Create a PivotTable: Make sure the cell pointer is located in the list and select Data → Pivot
Table Report from the menu. Follow the on-screen instruction to create the PivotTable.

Modifying a PivotTable’s Structure
•

To Rearrange a PivotTable: Make sure the cell pointer is located in the PivotTable, click the
PivotTable Wizard button on the PivotTable toolbar, and rearrange the PivotTable by dragging the
field names buttons to or from the appropriate section of the PivotTable diagram.

•

To Change the Calculation Used in a PivotTable: Make sure the cell pointer is located in the
PivotTable and click the PivotTable Field button on the PivotTable toolbar, and select the
calculation you want to use.

Adding a Page Field to a PivotTable
•

A Page Field lets you filter the information in PivotTable.

•

To Add a Page Field to a PivotTable: Make sure the cell pointer is located in the PivotTable and
click the PivotTable Wizard button on the PivotTable toolbar. Drag the field name you want to use
to filter the PivotTable to the PAGE section of the PivotTable diagram and click Finish.

•

Filter a PivotTable by selecting the criteria from the PivotTable’s Page Field.

Grouping Dates in a PivotTable
•

You can group information by days, months, quarters, or years.

•

To Group Information by Date or Time: Select the row or column heading that contains the date
or time value you want to group by and click the Group button on the PivotTable toolbar or select
Data → Group and Outline → Group from the menu. Specify the starting and ending dates and
the interval you want to group the dates or time by, then click OK.

Updating a PivotTable
•
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A PivotTable isn’t automatically updated if you modify its source data. You can refresh a PivotTable
by clicking the Refresh Data button on the PivotTable toolbar or selecting Data → Refresh
Data from the menu.
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Formatting and Charting a PivotTable
•

To Format a PivotTable: Make sure the cell pointer is located in the PivotTable report and click
the Format Report button on the PivotTable toolbar. Select the formatting you want to apply and
click OK.

•

To Create a PivotChart: Place the cell pointer anywhere in a PivotTable report and click the Chart
Wizard button on the PivotTable toolbar. You will probably have to change the chart type.

•

To Modify a PivotChart: Modify a PivotChart the same as you would a PivotTable—drag and drop
fields to and from the PivotTable toolbar and the PivotChart.

Creating Subtotals
•

To Calculate Subtotals: Sort the list, select Data → Subtotals from the menu, enter the
appropriate information in the Subtotal dialog box and click OK.

•

To Remove Subtotals: Make sure the active cell is located within the list, then select Data →
Subtotals from the menu and click Remove All.

Using Database Functions
•

Database functions perform calculations only for records that meet the criteria you specify. The
syntax for all database functions is =FUNCTION(Database, Field, Criteria).

Using Lookup Functions
•

The VLOOKUP function looks up information in a worksheet by searching vertically down the
leftmost column of a cell range until it finds the value you specify and then across the row to find
the value in column you specify.

•

The syntax for the VLOOKUP function is =VLOOKUP(lookup_value,table_array, col_index_num).

Grouping and Outlining a Worksheet
•

To Manually Group/Ungroup Columns or Rows: Select the columns or rows you want to group
and select Data → Group and Outline → Group (or Ungroup) from the menu.

•

To Outline a Worksheet Automatically: Make sure the worksheet contains formulas that
consistently point in the same directions, then select Data → Group and Outline → Auto Outline
from the menu.

•

To Remove an Outline: Select Data → Group and Outline → Clear Outline from the menu.

•

You can view the details of a group by clicking its Show Details button ( ) and hide the details
by clicking its Hide Details button ( ).

•

You can hide or display a specific level in an outline by clicking its Row Level (
Level button.

) or Column
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Quiz
1. Which of the following statements is NOT true?
A. PivotTables summarize the information in a list.
B. You can add a PivotTable as an embedded object on a worksheet, or on its own
separate worksheet.
C. The Data → Pivot Table Report command starts the PivotTable Wizard.
D. You specify which fields you want to summarize in the PivotTable by dragging them
to the appropriate areas of the PivotTable diagram.
2. You must create a new PivotTable if you want to summarize information
from different fields (True or False?)
3. Which of the following statements is NOT true?
A. You can specify how dates should be grouped in a PivotTable by selecting the field
that contains the date information, clicking the Group button on the PivotTable
toolbar, and specifying how you want the information summarized (by days, months,
quarters, or years).
B. PivotTables are automatically updated whenever you change their source data.
C. Adding a Page Field to a PivotTable lets you filter the information the PivotTable
summarizes.
D. You can modify the structure of a PivotTable by clicking the PivotTable Wizard
button on the PivotTable toolbar.
4. You should sort a list before you group and summarize its information
using the Subtotals command. (True or False?)
5. Which of the following statements is NOT true?
A.
B.
C.
D.

The Subtotals command subtotals a column at each value change.
The Subtotals command displays the worksheet in outline view.
The Subtotals command summarizes the worksheet by creating a PivotTable.
You can add Subtotals to a worksheet by selecting Data → Subtotals from the menu.

6. Excel’s database functions perform calculations only for records that meet
the criteria you specify (True or False?)
7. Which of the following statements is NOT true?
A. You should use the Function Palette to help you enter complicated database
functions.
B. You can hide or display details in an outlined worksheet by clicking the Hide Details
button or Show Details button, or by clicking the various Column Level or Row
Level buttons.
C. A worksheet must be sorted in order for Excel to automatically outline it.
D. You can manually group rows and columns in a worksheet by selecting Data →
Group and Outline → Group from the menu.
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Homework
1. Open the Homework 11 workbook and save it as “PivotTable Practice.”
2. Select any cell; in the table then select Data → PivotTable Report from the menu.
3. Using the PivotTable Wizard, create a PivotTable report that summarizes the
worksheet information like the following illustration:

4. Modify the PivotTable’s structure so that the column summarizes by Date instead of
by Type.
5. Click the Date, field and then, click the Group button on the PivotTable toolbar.
Group the dates by month.
6. Modify the PivotTable’s structure by adding the Type field as the Page Field.

7. Use the Page Field to filter the information summarized in the PivotTable by the
various Types of expenses.
8. Click the Sheet 1 sheet tab and sort the A column alphabetically.
9. Use the Data → Subtotals command to subtotal the worksheet.
10. Practice expanding and collapsing the worksheet while it’s in Outline view.

Quiz Answers
1. B. PivotTables appear on their own separate worksheets.
2. False. It is incredibly easy to modify which fields a PivotTable summarizes. Just
click the PivotTable Wizard button on the PivotTable toolbar and drag the fields you
want to summarize to the appropriate areas of the PivotTable diagram.
3. B. PivotTables are NOT automatically updated when you change their source data.
You must click the Refresh Data button on the PivotTable toolbar to update the
PivotTable.
4. True. Always sort a list before using the Subtotals command.
5. C. The Subtotals command does not summarize information using a PivotTable—
that’s what the PivotTable command is for!
6. True. Database functions calculate only those records that match your criteria.
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7. C. A worksheet must contain formulas that consistently point in the same direction to
use the automatic outline feature. Sorting the worksheet doesn’t make any difference.
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Chapter Twelve:
What-If Analysis
Chapter Objectives:
•

Create a Scenario

•

Create a Scenario Summary Report

•

Create One and Two-Input Data Tables

•

Use Goal Seek

•

Set up complex what-if analysis with Solver

Chapter Task: Analyze Different What-If Situations
If you’ve ever used a worksheet to answer the question “what if?” you’ve already performed
what-if analysis. For example, what would happen if the advertising budget for your
department increased by 40%? If you were considering taking out a home mortgage based on
your income, how much money could you borrow for a 20-year mortgage? How much money
could you borrow for a 30-year mortgage?
Most people don’t realize Excel has numerous analysis features and instead perform what-if
analysis the slow and hard way—by manually inputting different values into their worksheets,
looking at the results, and then inputting another set of values. This method is fine for simple
what-if scenarios, but doesn’t work well for answering complex what-if questions.
In this chapter, you will learn how to create multiple what-if scenarios using Excel’s Scenario
Manager. You will create one-input and two-input data tables to report several different
outcomes. You will also use Excel’s Goal Seek and Solver to solve more complex what-if
questions.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to select cell
ranges.
• How to enter values,
labels, and formulas
into a cell.
• How to reference cells.
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Lesson 12-1: Defining a Scenario
Figure 12-1
Scenario name

The Add Scenario dialog
box.

The cell range that
contains the values you
want to change.

Figure 12-2
The Scenario Values
dialog box.
Figure 12-3
The Scenario Manager
dialog box.
Figure 12-1

Display the selected
scenario.
Add a new
Delete the selected
scenario.

Figure 12-2

Edit the selected
scenario.

The current values in
A4, B4, and C4.

Figure 12-3

A scenario is a set of values you use in what-if analysis. Imagine you are considering taking
out a home mortgage and have to determine what type of loan to take out. One scenario you
are considering is a 30-year loan with a 7.5% interest rate. Another scenario is a 20-year loan
with an 8.5% interest rate. Excel’s scenario manager lets you create and store different
scenarios in the same worksheet. Once you have created a scenario, you can select it and
display the worksheet using its values.
In this lesson, you will use the scenario manager to perform what-if analysis on a home
mortgage. You will create three different scenarios to see how changing the amount and
length of the loan will change your monthly payments.

1.

2.

 2000 CustomGuide, Inc.

Start Microsoft Excel, open the workbook named Lesson 12A and save it
as Mortgage What-If.
This workbook contains information for a mortgage. To help assist you with deciding
what type of mortgage to take out, you will use Excel’s Scenario Manager to create
several scenarios with different loan amounts and terms. The first step in creating a
Scenario is to select the cells that change.
Select the cell range A4:C4 and select Tools → Scenarios from the
menu.
The Scenario Manager dialog box appears with the message “No Scenarios defined.
Choose Add to add scenarios.” You want to add a new scenario.
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3.

4.
5.
6.
7.
8.
9.
10.
11.
12.

Click Add.
The Add Scenario dialog box appears, as shown in Figure 12-1. You must give your
scenario a name and specify the scenario’s changing cells, if necessary. The cell range
A4:C4 appears in the changing cells text box because you selected those cells before
you opened the Scenario Manager. First, create a scenario with the original values.
Type Original Quote in the Scenario name box and click OK.
The Scenario Values dialog box appears, as shown in Figure 12-2 with the existing
values in the changing cells boxes. Since this is the original quote, you can save the
scenario without changing the values.
Click OK.
The Scenario Values dialog box closes and you return to the Scenario Manager dialog
box. Next, create a scenario with a longer loan length—30 years instead of 20.
Click Add, type 30 Year Loan in the Scenario name box and click OK.
The Scenario Values dialog box appears. You need to change the values for this
scenario.
Change the 20 in the second changing cell box ($B$4) to 30 and click
Add.
Excel saves the 30 Year Loan scenario and you return to the Scenario Manager dialog
box. Create another scenario with a smaller loan amount.
Type Smaller Loan in the Scenario name box and click OK.
The Scenario Values dialog box appears.
Change the 150000 in the first changing cell box ($A$4) to 125000 and
click OK.
Excel saves the Smaller Loan scenario and returns you to the Scenario Manager dialog
box. You’re ready to test your scenarios.
Select the 30 Year Loan scenario from the Scenario list and click Show.
Excel changes the length of the loan in B4 from 20 years to 30 years. Notice the
monthly payment decreases from $1,162.95 to $997.95, and the Interest paid increases
from $129,107.62 to $209,263.35.
Select the Smaller Loan scenario from the Scenario list and click Show.
The length of the loan changes back to 20 years and the amount of the loan changes to
$125,000. You’re finished working with the Scenario Manager for now.
Click Close to close the Scenario Manager and save your work.

Great! You’ve learned how to use your first What-If Analysis feature.
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Quick Reference
To Create a Scenario:
1. Create or open a
worksheet that contains
the results of one or more
formulas.
2. Select Tools →
Scenarios from the menu
and click the Add button
to add a new scenario.
3. Complete the Add
Scenario dialog box by
completing the following
settings:
Scenario Name: The
name for your scenario.
Changing Cells: The
cells that contain the
values you want to
change.
4. Click OK and enter the
values for the scenario in
the Scenario Values
dialog box.
5. Click Add to add the
scenario.
6. Repeat steps 4 and 5 for
each additional scenario.
Click Close when you’re
finished.
To View a Scenario:
1. Select Tools →
Scenarios from the
menu.
2. Select the scenario from
the list and click Show.
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Lesson 12-2: Creating a Scenario
Summary Report
Figure 12-4
The Create Names dialog
box.
Figure 12-5
The Scenario Summary
dialog box.

Figure 12-4

Figure 12-5

Figure 12-6
The Scenario Summary
dialog box.

Figure 12-6

If you’ve defined two or more scenarios, you can summarize them by creating a scenario
summary report. A scenario summary report is a single compiled report that summarizes the
results from several scenarios. It’s usually much easier to read a single scenario summary
report than switching between several different scenarios.

1.

Name Box List

2.
3.
4.
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Select the cell range A3:F4 and select Insert → Name → Create from
the menu.
The Create Names dialog box appears, as shown in Figure 12-4. The Create Names
will automatically create range names, based on the current selection. Naming the cells
will make them easier to read when you create the Scenario Summary report.
Verify the Top row check box is checked and click OK.
The Create Names dialog box closes and Excel automatically creates names for the
selected cell range. You can verify that Excel created the correct names by clicking the
Name box arrow.
Click the Name Box List arrow.
The column heading names should appear in the Name Box list.
Click anywhere in the worksheet window to close the Name Box list.
You’re ready to create a Scenario Summary report.
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5.
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Select Tools → Scenarios from the menu and click the Summary
button.
The Scenario Summary dialog box appears, as shown in Figure 12-5. You can create
two types of reports:
•

Scenario summary: Creates a report that lists your scenarios with their input
values and the resulting cells. Use this report only when your model has one set
of changing cells provided by a single user.

•

6.
7.
8.

Scenario PivotTable: Creates a PivotTable report that gives you an instant
what-if analysis of your scenarios. Use this type of report when your model has
multiple sets of changing cells provided by more than one user.
You will use the Scenario summary report, and it is the default option.
Verify that the Scenario summary report is selected, click the Results
cells text box, if necessary, then select the cell range D4:F4.
The Results Cells (Monthly Payment, Total Payment, and Interest Paid) are the cells
that are affected by the Changing Cells (Amount, Term, and Interest).
Click OK.
The Scenario Summary dialog box closes, and Excel creates a scenario summary report
on a new sheet in the workbook, as shown in Figure 12-6.
Click the Sheet1 tab to view it, and then save your work.

Quick Reference
To Create a Scenario
Summary Report:
1. Make sure you’ve defined
at least two scenarios.
2. Select Tools →
Scenarios from the
menu.
3. Select the type of report
(Scenario summary or
Scenario PivotTable).
4. Specify which cells you
want to include in the
report.
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Lesson 12-3: Using a One and
Two-Input Data Table
Figure 12-7
The Table dialog box.
Figure 12-7

Figure 12-8
The completed one-input
data table with monthly
payments for each interest
rate.

Formula used to create the data table

Figure 12-9

=-PMT(C4/12,B4*12,A4)

The completed two-input
data table with monthly
payments each interest
rate and each term.

Column input cell—the placeholder cell
Excel will substitute values for in the
formula (here, it’s the interest rate)

Figure 12-8

Values for the
column input cell

Formula used to create the data table

=-PMT(C4/12,B4*12,A4)
Column input cell

Figure 12-9

Values for the
column input cell

Row input cell

Values for the row
input cell

Another way to get answers to your what-if questions is by using a data table. A data table is
a cell range that displays the results of a formula using different values. For example, you
could create a data table to calculate loan payments for several interest rates and term lengths.
There are two types of data tables:

(Not Used)
Input Value
Input Value
Input Value

Formula
Results
Results
Results

Structure of a
One-Input Table
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•

One-input Data Table: Displays the results of a formula for multiple values of a single
input cell. For example, if you have a formula that calculates a loan payment you could
create a one-input data table that shows payment amounts for different interest rates.

•

Two-input Data Table: Displays the results of a formula for multiple values of a two
input cell. For example, if you have a formula that calculates a loan payment you could
create a two-input data table that shows payment amounts for different interest rates and
different term lengths.

We’ll work with both types of data tables in this lesson.

1.

Click cell B7.
The first step in creating a data table is to enter the formula the data table will use.
Since you want to calculate the monthly payment of the loan based on different interest
rates, you will use the same PMT formula you created in cell D4.
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2.

3.
4.

5.
6.

7.
8.
9.

10.
11.

Type =-PMT(C4/12,B4*12,A4) and press <Enter>.
Don’t worry about the results of the PMT formula that appear in cell B7. It’s the
formula that’s important. Excel will use this formula to calculate values in the data
table. The next step in creating your input data table is to enter the inputs (in your case,
the interest rates) you want to use in the data table. The cells in this workbook have
already been formatted with the correct number formatting, so you can enter the data
table inputs.
Click cell A8, type 6, press <Enter>, type 6.5, press <Enter>, type 7,
press <Enter>, type 7.5, press <Enter>, type 8, and press <Enter>.
You’re ready to have Excel fill in your data table using the different interest rates you
just entered in the A column.
Select the cell range A7:B12 and select Data → Table from the menu.
The Table dialog box appears, as shown in Figure 12-7. You must specify the location
of the input cell in the Row Input Cell or Column Input Cell box. The input cell is the
placeholder cell that is referred to in the Table formula—in your case, the Interest rate,
which is located in cell C4.
Click the Column Input Cell box, click cell C4 (the placeholder for the
interest rate in the table formula) and click OK.
Excel fills the table with the results of the table formula with one result for each input
value or interest rate.
Click cell B8.
Excel has added the formula =TABLE(,C4) to the cell. The C4 reference refers to the
Input Cell for the formula—in this case, the interest rate. You can also create data
tables based on two input variables. For example, you can create a data table that uses
the Interest Rate as one input variable (arranged in columns) and the Term as the other
input variable (arranged in rows). The structure of a two-input data table is slightly
different from that of a one-input data table—the formula has to be where the row and
column that contain the input values intersect, in your case, A7. You can’t change a
table once it has been created, so you will first have to delete the current table.
Select the cell range B8:B12, press <Del> to delete the data table, and
then move the formula in B7 to A7 by using either drag and drop or cut
and paste.
Now you can enter the different terms as Column Input values.
Verify that B7 is the active cell and type 15, <Tab>, 20, <Tab>, 25,
<Tab>, 30 and press <Enter>.
Now select the data table range and open the Table dialog box.
Select the cell range A7:E12 and select Data → Table from the menu.
The Table dialog box appears. This time you must specify two input cells. The Row
Input Cell is placeholder cell that is referred to in the Table formula—in your case, the
Term, which is located in cell B4. The Column Input Cell will be the Interest Rate,
located in cell C4.
Click the Row Input Cell, click cell B4, click the Column Input Cell,
click cell C4 and click OK.
Excel computes the table using the Term (B4) as the Row Input Cell and the Interest
Rate (C4) as the Column Input cell. Compare your table to the one in Figure 12-9.
Save your work.

Formula
Input Value
Input Value
Input Value
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Input Value
Results
Results
Results

Structure of a
Two-Input Table

Quick Reference
To Create a One-Input
Table:
1. Set up the table area.
Make sure you include
the formula in the top row,
and the input values in
the left column.
2. Select the table range
and select Data → Table
from the menu.
3. Specify the worksheet cell
you want to use as the
input value and click OK.
To Create a Two-Input
Table:
1. Setup the table area.
Make sure you include
the formula in the
upper-left cell and the
values for the first input
cell in the left column and
the values for the second
input cell in the top row.
2. Select the table range
and select Data → Table
from the menu.
3. Specify the worksheet cell
you want to use for the
Row input cell and the
Column input cell and
click OK.
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Lesson 12-4: Understanding Goal
Seek
Figure 12-10
The Goal Seek dialog box.
Figure 12-11
The Goal Seek Status
dialog box displays the
solution.

Figure 12-10

Figure 12-11

When you know the desired result of a single formula, but not the value the formula needs for
the result, you can use the Goal Seek feature. For example, you can afford a $1,200 monthly
payment, so how much of a loan can you take out? When goal seeking, Excel plugs in
different values into a cell until it finds one that works.

1.

2.

Select cell D4.
You want to know what the maximum 20-year mortgage you can afford is if the
interest rate is 7 percent and the maximum monthly payment you can make is $1,200.
Cell D4, the Monthly Payment, is the formula cell for the Goal Seek command; you
will change its value to find a specific goal. You don’t necessarily have to select the
formula cell before using the Goal Seek command, but it saves you a step later on.
Select Tools → Goal Seek from the menu.
The Goal Seek dialog box appears, as shown in Figure 12-10. To find any goal you
must specify three things:
•

Set cell: The cell that contains the formula you want to find a solution for, in
your case the monthly payments value in cell D4.

•

To Value: This is the target number you want to solve for, in your case the
maximum monthly payment you are able to make, $1,200.

•

3.
4.
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By changing cell: This is the cell that contains the value you want to change
to solve for the target value, in your case the mortgage amount, in cell A4.
Verify that D4 appears in the Set cell box.
Remember that the set cell contains the formula you want to find a solution for—the
monthly payments formula. In the next step you’ll enter the goal: the maximum
monthly payment you are able to make.
Click the To value box and type 1200.
The last step in using Goal Seek is specifying what cell will change in order to reach
the solution: the mortgage amount.
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5.
6.

7.
8.
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Click the By changing cell box and click cell A4.
You’re ready to use Goal Seek to find the maximum 20-year, 7% interest rate mortgage
you can take out with monthly payments of $1,200.
Click OK.
The Goal Seek Status dialog box appears with the message “Goal Seeking with Cell
D4 found a solution” and displays the solution in the worksheet window, as shown in
Figure 12-11. You discover the maximum mortgage you can afford, based on a 20-year
term and 7% interest rate, would be $154,779.
Click OK.
The Goal Seek dialog box closes and changes the worksheet values.
Save your work and close the current workbook.

Super! You’re almost done with the What-If Analysis chapter. Just one more lesson….

Quick Reference
To Use Goal Seek:
1. Open or create a
workbook that uses the
formulas you want to use.
2. Select Tools → Goal
Seek from the menu.
3. Complete the Goal Seek
dialog box by specifying
which formula cell to
change, the value to
change it to, and the cell
to change.
4. Click OK.
5. Click OK to replace the
original value or click
Cancel to keep the
original value.

340

Microsoft Excel 2000

Lesson 12-5: Using Solver
Figure 12-12
The Solver Parameters
dialog box.
Figure 12-13
The worksheet containing
the problem to be solved
by Solver.
Figure 12-14

Figure 12-13 Changing cells

Target cell

Figure 12-12
Figure 12-12

The Add Constraint dialog
box.
Figure 12-15
The Solver Results dialog
box.

Figure 12-14
Figure 12-15

Goal Seek works great for problems that have a single variable and an exact target value, but
not for complex problems that have several variables and/or a range of values. For these more
complex problems, you need to use Excel’s Solver command. The Solver can perform
advanced what-if analysis problems with many variable cells. You can also specify
constraints, or conditions that must be met to solve the problem.
If the Solver seems especially difficult to you, you’re not alone. The Solver is one of the most
advanced and complicated features in Excel.

1.

2.
3.
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Open the workbook named Lesson 12B.
Imagine you’ve been put in charge of a annual mailing campaign for existing clients in
five states. Your boss has given you the following budget constraints:
Your total budget is $35,000.
You must spend at least 50% of the budget on Minnesota mailings.
At least three mailings must go out in each state.
Based on this information, your job is to find out how many mailings you can send out
to the clients in each state. Yikes! It’s the math problem from hell! Luckily, you can use
Excel’s Solver to help you find the answer to this problem.
Select Tools → Solver from the menu.
The Solver Parameter dialog box appears, as shown in Figure 12-12. First, you need to
specify the goal or target you want to solve. For this lesson, you want to minimize your
total mailing cost—the value in cell F7.
Make sure the insertion point is the Set Target Cell box and click cell F7.
$F$7 appears in the Set Target Cell box. Next, you want Solver to set the target cell
(the total cost) to the lowest value possible.
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4.

5.
6.
7.
8.

9.
10.
11.
12.

13.

Click the Min option.
For other problems, you might want to find the highest possible value by selecting the
Max option. Or you might want Solver to find a solution that makes the target cell
equal to a certain value by selecting the Value option and entering the value.
Next, you need to specify which cells will change in order to reach the solution—the
number of mailings per state.
Click the By Changing Cells box, clear any previous contents, and
select cells E2:E6.
Now you’re ready to specify the constraints Solver has to work with.
Click the Add button.
The Add Constraint dialog box appears, as shown in Figure 12-14. Start by adding the
constraint that the total mailing cost cannot exceed the $35,000 budget.
Click the Cell Reference box, select cell F7 (the Total Cost cell), select
<=, click the Constraint box, and type 35000.
Compare your Add Constraint dialog box with the one in Figure 12-14. The next
constraint you need to add is that 50% of the total amount must be spent in Minnesota.
Click Add, click the Cell Reference box, select cell F2 (Minnesota’s
Total Cost), select >=, click the Constraint box, click cell F7, and type
*.5.
$F$7*.5 should be displayed in the constraint box. Next, add a constraint so at least
three mailings must be sent in each state.
Click Add, click the Cell Reference box, select the cell range E2:E6
(the Number of Mailings), select >=, click the Constraint box and type 3.
Finally, you need to add a constraint to specify that the number of mailings is restricted
to whole numbers (otherwise, Solver will use numbers with decimal places.)
Click Add, click the Cell Reference box, select the cell range E2:E6
(the Number of Mailings), and select int.
That’s it! You’ve finished adding all the constraints.
Click OK.
The Add Constraint dialog box closes and you return to the Solver Parameter dialog
box. Let’s see if the Solver can find a solution for this perplexing problem.
Click Solve.
Excel analyzes the problem and plugs trial values into the variable cells, and tests the
results. After a moment the Solver Results dialog box appears, indicating that Solver
succeeded in finding a solution to how many mailings you can afford to send out to
each state, while meeting all the constraints as shown in Figure 12-15.
You have several choices here. You can keep the values from the Solver solutions, you
can return the original values, or you can create one of three types of detailed reports
on a separate worksheet that summarize Solver’s answer.
Make sure the Keep Solver Solutions option is selected and click OK.
The dialog box closes and the solution values appear in the worksheet. You’ve
successfully found the best combination of mailings by state using Solver. The settings
you entered in Solver will be saved with the workbook, so you can easily come back to
them.

14. Save your work and exit Microsoft Excel.
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You have to be very
precise when using the
Solver. If you don’t
specify the proper
constraint, Solver
won’t be able to find a
solution to your
problem (if there
indeed is a solution) or
else may return invalid
data.

Quick Reference
To Install Solver:
• Solver is an optional
Excel add-on. If you can’t
find Solver under the
Tools menu you can
install it by selecting
Tools → Add ins from
the menu, selecting the
Solver Add-in and
clicking OK.
To Use Solver:
1. Open or create a
workbook that contains
the problem you want to
solve, and then select
Tools → Solver from the
menu.
2. Specify the goal or target
you want to solve for in
the Set Target Cell box.
3. Specify Max, Min, or
Equal to, then specify the
cells that need to change
to meet your goal in the
By Changing Cells box.
4. Add your constraints by
clicking Add and then
specifying the constraints
(repeat for as many
constraints as you need).
5. Click Solve.
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Chapter Twelve Review
Lesson Summary
Defining a Scenario
•

A scenario is a set of values you use in what-if analysis, such as various interest rates, loan
amounts, and terms for a mortgage. You can save and then easily display these values once you
have saved them in a scenario.

•

To Create a Scenario: Create or open a worksheet that contains the results of one or more
formulas. Select Tools → Scenarios from the menu and click the Add button to add a new
scenario. Complete the Add Scenario dialog box giving the scenario a name and identifying the
“changing cells” (the cells that contain the values you want to change) and click OK. Click the Add
button and enter the name and changing cells for each additional scenario.

•

To View a Scenario: Select Tools → Scenarios from the menu, select the scenario from the list
and click Show.

Creating a Scenario Summary Report
•

A scenario summary report is a single compiled report that summarizes the results from several
scenarios.

•

To Create a Scenario Summary Report: Make sure you’ve defined at least two scenarios and
select Tools → Scenarios from the menu. Select the type of report you want (Scenario summary
or Scenario PivotTable) and which cells you want to include in the report.

Using a One and Two-Input Data Table
•

A Data Table displays the results of a formula using different values. A One-Input Data Table
displays the results of a formula for multiple values of a single input cell, while a Two-Input Data
Table displays the results of a formula for multiple values of a two input cells.

•

To Create a One-Input Table: Type the list of values you want to substitute in the input cell down
one column. Type the formula in the row above the first value and one cell to the left of the column
of values. Select the substitute cell range and select Data → Table from the menu. Select the
worksheet cell you want to use as the input value and click OK.

•

To Create a Two-Input Table: In a cell on the worksheet, enter the formula that refers to the two
input cells. Type one list of input values in the same column, below the formula and type the
second list in the same row, to the right of the formula. Select the range of cells that contains the
formula and both the row and column of values and select Data → Table from the menu. Select
the Row input cell and the Column input cell and click OK.

Understanding Goal Seek
•
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When you know what the result of a single formula should be but not the value the formula needs
to determine the result, you can use the Goal Seek feature.
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•

To Use Goal Seek: Open or create a workbook that uses the formulas you want to use and select
Tools → Goal Seek from the menu. Complete the Goal Seek dialog box by specifying which
formula cell to change, the value to change it to, and the cell to change.

Using Solver
•

Use Solver to find solutions to complex what-if problems that have multiple variables and a range
of values.

•

Solver is an optional Excel add-on. If you can’t find Solver under the Tools menu you can install it
by selecting Tools → Add Ins from the menu, selecting the Solver Add-in and clicking OK.

•

To Use Solver: Open or create a workbook that contains the problem you want to solve, and then
select Tools → Solver from the menu. Specify the goal or target you want to solve for in the Set
Target Cell box, then specify the Max, Min, or Equal to. Open and specify the cells that need to
change to meet your goal in the By Changing Cells box. Add your constraints by clicking Add and
then specifying the constraints (repeat for as many constraints as you need.) Click Solve when
you’ve finished setting up the problem.

Quiz
1. Which of following is NOT one of Excel’s What-If functions?
A.
B.
C.
D.

Scenario Manager.
Solver.
Goal Seek.
Auto Outline.

2. Which of the following statements is NOT true?
A. The Scenario Manager lets you save several sets of values or scenarios to use in
what-if analysis.
B. You must specify the cells that change in a scenario.
C. You must specify the target cell in a scenario.
D. The Scenario Manager is located under Tools → Scenarios.
3. After carefully considering your budget, you decide the maximum monthly
payment you can afford is $500 on a three-year loan. Based on this
information, which feature would be the fastest and easiest way to
determine how much of a loan you can take out?
A.
B.
C.
D.

Goal Seek.
Solver.
Scenario Manager.
A Two-Input Data Table.
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4. Solver can find solutions to problems with multiple variables, constraints,
and ranges of values. (True or False?)
5. Which of the following is NOT information you can specify using the
Solver? (Select all that apply.)
A.
B.
C.
D.

Target cell.
Changing cells.
Constraints.
Input cells.

Homework
1. Open the Homework 12 workbook and save it as “What-If Practice”.
2. Click the Car Loan sheet tab. Select the cell range B3:B5 (the changing cells) and
select Tools → Scenarios from the menu.
3. Click Add, and name the scenario “Original Loan Term.” Save the scenario with the
original values.
4. Click Add and name the scenario “9 Percent, 36 Months.” Save the scenario with a
$25,000 loan amount, .09% interest rate, and 36 months.
5. Practice switching between the two scenarios by selecting Tools → Scenarios from
the menu, selecting a scenario, and clicking View.
6. Create a Scenario Summary report for the worksheet.
7. Click cell B11, type =B7 and press <Enter>.
8. Setup a one-input data table as follows:

8. Select Data → Table from the menu and select cell B4 as the Column input cell.
Your results should be:

9. Click cell B7 and select Tools → Goal Seek from the menu. Use Goal Seek to find
the maximum car loan you can take out (cell B3) if you can afford an $800 monthly
payment.
Extra Credit: Click the Solver sheet tab. Use Solver to find a solution to the specified
problem. The target cells, changing cells, and constraints are all color-coded to make
it a little easier for you.
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Quiz Answers
1. D. The auto outline feature has nothing to do with what-if analysis.
2. C. Goal Seek and the Solver have target cells, but not scenarios.
3. A. Actually, you could use any of the other methods to eventually find the answer,
but Goal Seek would be the fastest and easiest in this instance.
4. True.
5. D. Input Tables require Input cells, not Solver.

345

Chapter Thirteen:
Advanced Topics
Chapter Objectives:
•

Add, Remove, and Position Toolbars

•

Create a Custom Toolbar

•

Create a Custom AutoFill List

•

Password Protect a Workbook

•

Change Excel’s Default Options

•

Find a File

•

View and Change a File’s Properties

•

Share a Workbook for Group Collaboration

•

Revise a Shared Workbook

Chapter Task: Learn how to customize Microsoft Excel
You can customize Excel in a number of ways to meet your own individual needs and tastes.
This chapter explains how you can tailor Excel to work the way you do. You are already
familiar with toolbars and how they make it easy to access frequently used commands. In this
chapter, you will get to create your very own toolbar and add the commands you use the most
frequently to it. This chapter also explains how to create your own custom AutoFill lists.
Another topic covered in this chapter is workbook collaboration. Like it or not, if you’re part
of the corporate world, someday you will have to create a workbook as part of a team. For
example, you might create a workbook and then have your manager review it and make
changes. Then you go back to the workbook, make the changes, and send it off to its final
destination. The folks at Microsoft realized that people sometimes work together when they
create workbooks, so they included several features that enable several users to collaborate to
create and update workbooks. This chapter explains how you can share a workbook so that
several users can work on it, and how you can track, review, and then accept or reject any
changes made to the shared workbook.

; Prerequisites
• How to use menus,
toolbars, dialog boxes,
and shortcut
keystrokes.
• How to select cell
ranges.
• How to open and save
a file.
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Lesson 13-1: Creating and Using
Custom Toolbars
Figure 13-1
The Toolbars tab of the
Customize dialog box.
Figure 13-2
The Commands tab of the
Customize dialog box.
Figure 13-3
The New Toolbar dialog
box.
Figure 13-1

Figure 13-2

Figure 13-3

The purpose of Excel’s various toolbars is to provide buttons for the commands you use most
frequently. If Excel’s built-in toolbars don’t contain enough of the commands you use, you
can create your own custom toolbar. You can also modify all the toolbars that come with
Excel by adding or deleting their buttons.

1.
2.
Empty toolbar

3.
4.
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Select View → Toolbars → Customize from the menu.
The Customize dialog box appears, as shown in Figure 13-1. You can select toolbars
you want to view or create a new custom toolbar in this dialog box. Here’s how to
create a new toolbar:
Click New.
The New Toolbar dialog box appears, as shown in Figure 13-3. You need to give your
new toolbar a name.
Type North Shore in the Toolbar name box and click OK.
The new North Shore toolbar appears without any buttons in it.
Click the Commands tab of the Customize dialog box.
The Commands tab appears in front of the Customize dialog box, as shown in Figure
13-2. This is where you select the buttons and commands you want to appear on your
toolbars. The commands are organized by categories, just like Excel’s menus.
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5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.

Make sure the File category is selected in the Categories list, then scroll
down the Commands list until you see the Set Print Area button. Drag
the Set Print Area button onto the North Shore toolbar.
The Set Print Area button appears in the North Shore toolbar.
Scroll down the Categories list and select the Insert category.
Notice the Commands list is updated to display all the Insert commands.
Scroll down the Commands list and drag the Comment button to the
right of the Set Print Area button on the North Shore toolbar.
The Comment button appears in the North Shore toolbar.
In the Categories list, scroll to and click the Data category.
In the Commands list, scroll to the AutoFilter button and drag it to the
right of the Comment button on the North Shore toolbar.
The AutoFilter button appears on the North Shore toolbar. You have finished creating
the North Shore toolbar, now try using it.
Click Close to close the Customize dialog box.
The Customize dialog disappears.
Click the Comment button on the North Shore dialog box.
A comment is inserted at the active cell. You don’t really need a comment inserted
here, so…
Click any cell other than the active cell and click the Undo button on the
Standard toolbar.
If for some reason you decide you no longer need a particular custom toolbar, you can
easily delete it.
Select View → Toolbars → Customize from the menu. Click the
Toolbars tab so it appears on top of the dialog box.
Here’s how to delete a toolbar:
Select the North Shore toolbar, then click Delete.
A confirmation dialog box appears, asking if you are sure you want to delete the North
Shore toolbar.
Click OK to delete the North Shore toolbar.
The North Shore toolbar is deleted.
Click Close to close the Customize dialog box.

Adding your frequently used commands to toolbars is one of the most effective ways you can
make Excel more enjoyable and faster to use.
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North Shore
toolbar

Quick Reference
To Create a Custom
Toolbar:
1. Select View → Toolbars
→ Customize from the
menu.
2. Click New and type a
name for the new toolbar.
3. Follow the next set of
instructions to add
buttons to your toolbar.
To Add a Button to a
Toolbar:
1. Select View → Toolbars
→ Customize from the
menu.
2. Click the Commands tab.
3. Select the command
category from the
Categories list, then find
the desired command in
the Commands list and
drag the command to the
toolbar.
To Remove a Button from
a Toolbar:
1. Select View → Toolbars
→ Customize from the
menu.
2. Drag the button off the
toolbar.
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Lesson 13-2: Creating a Custom
AutoFill List
Figure 13-4
The Custom Lists tab of
the Options dialog box.
Figure 13-5
Using a custom AutoFill
list.

Figure 13-4

Figure 13-5

You’re already familiar with Excel’s AutoFill feature. It’s the nifty function that automatically
enters a series of values. If you find yourself typing the same list of words frequently, you can
save yourself a lot of time by creating a custom AutoFill list. Once you have created a custom
AutoFill list all you have to do is type the first entry of the list in a cell, and then use AutoFill
to have Excel complete the rest of the list for you.

1.
2.
3.
Fill handle
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Click cell A1 and type Monday.
For a quick refresher, we’ll use AutoFill to enter the remaining days of the week.
Position the pointer over the fill handle of cell A1, until it changes to a ,
then click and hold the mouse and drag the fill handle down to cell A7,
then release the mouse button.
AutoFill completes the series, entering the days of the week in the selected cell range.
Close the current workbook (you don’t need to save it) and open the
workbook named Lesson 13A.
This workbook contains a list you need to type out regularly—the names of the
employees in your office. To save time, you decide to add the names to an AutoFill list.
To do this you first need to select the information you want to define as an AutoFill
list—in this case the employee’s names.
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5.
6.
7.
8.
9.

10.
11.
12.
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Select the cell range A4:A13.
Now that the names are selected, you can add them to a custom AutoFill list.
Select Tools → Options from the menu and click the Custom Lists tab.
The Custom Lists tab of the Options dialog box appears, as shown in Figure 13-4. Here
you can view or delete the existing AutoFill lists, or add your own. Notice the Import
list from cells textbox contains the cell range you selected, A4:A13.
Click Import.
The list of employees is added to the Custom lists box, and its contents are displayed in
the List entries box. Close the Options dialog box.
Click OK.
Test out your new AutoFill list.
Click the Sheet2 tab type Brian Smith in cell A1 and then click the
Enter button on the Formula bar.

Enter button

Position the pointer over the fill handle of cell A1, until it changes to a ,
click and hold the mouse and drag the fill handle down to cell A10 then
release the mouse button.
Excel fills the selected range with the list of employees. Now that you know how to
create your own custom AutoFill list, you need to delete it.
Select Tools → Options, and then click the Custom Lists tab.
The Custom Lists tab of the Options dialog box reappears.
Select the list of employees in the Custom lists box and click Delete.
A dialog box appears, asking you to confirm the deletion of the custom list.
Click OK to confirm the deletion, then click OK again to close the dialog
box.

13. Close the workbook without saving any changes.

Quick Reference
To Create a Custom
AutoFill List:
1. Select the cell range that
contains the information
you want to include in
your custom AutoFill list.
2. Select Tools → Options
from the menu and click
the Custom Lists tab.
3. Click Import and click
OK.
To Use a Custom AutoFill
List:
1. Enter the first name from
the list in a cell.
2. Select the cell you used in
Step 1 and click and drag
the fill handle to complete
the series in the cells you
select.
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Lesson 13-3: Changing Excel’s
Options
Figure 13-6
The Calculation tab of the
Options dialog box.
Figure 13-7
The Edit tab of the
Options dialog box.
Figure 13-8
The General tab of the
Options dialog box.
Figure 13-9

Figure 13-6

Figure 13-7

Figure 13-8

Figure 13-9

The View tab of the
Options dialog box.

Microsoft spent a lot of time and research when it decided what the default settings for Excel
should be. However, you may find that the default settings don’t always fit your own needs.
For example, you might want to change the default folder where Excel saves your workbooks
from C:\My Documents to a drive and folder on the network.
This lesson isn’t so much an exercise as it is a reference on how to customize Excel by
changing its default settings.

1.
2.
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Select Tools → Options from the menu.
The Options dialog box appears.
Refer to Table 13-1: The Options Dialog Box Tabs and click each of the
tabs shown in the table to familiarize yourself with the Options dialog
box. Click OK when you’re finished.
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Table 13-1: The Options Dialog Box Tabs
Tab

Description

Calculation

Controls how Excel calculates the worksheet—automatically (the default
setting) or manually.

Chart

Determines how Excel plots empty cells in a chart, and if chart tips—
names and values—are displayed when you rest the pointer over a data
marker.

Color

Allows you to edit any of the original 56 colors on the color palette to
create custom colors.

Custom Lists

Allows you to view, add, and delete custom AutoFill lists.

Edit

Allows you to change Excel’s editing features, such as whether you can
directly edit a cell, where the cell pointer moves when you press
<Enter>, and if you want to enable drag and drop or AutoComplete.

General

Allows you to change the default location Excel looks for and saves files,
the user name, how many sheets appear in a new workbook, and if the
Properties dialog is displayed when saving a workbook.

Transition

For users switching to Excel from Lotus 1-2-3. Allows Excel to accept
Lotus 1-2-3 commands, navigation keys, and formulas.

View

Controls whether the Formula bar, Status bar, comments, row and
column headers, gridlines, and formulas are displayed.

Quick Reference
To Change Excel’s Default
Options:
• Select Tools → Options
from the menu, click the
appropriate tabs, and
make the necessary
changes.
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Lesson 13-4: Password Protecting
a Workbook
Figure 13-10
The Save Options dialog
box.
Figure 13-11
The Password dialog box.
Figure 13-12

Figure 13-10

The Incorrect Password
dialog box.
Figure 13-11

Figure 13-12

If a workbook contains sensitive data you don’t want anyone else to see or modify, you can
password protect the workbook, restricting the document access to only yourself or those
people that know the password. You can assign passwords so that users must enter a password
to either open and/or modify a workbook. This lesson will show you how to add a password
to a workbook, how to open a password protected workbook, and how to remove a password
if you decide a workbook no longer needs to be password protected.

1.
2.
3.
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Open the workbook named Lesson 13B and save it as Budget
Proposal.
To password protect the workbook you need to do a File → Save As.
Select File → Save As from the menu.
The Save As dialog box appears.
In the Save As dialog box, select General Options from the Tools menu.
The Save options dialog box appears, as shown in Figure 13-10. You can assign
passwords to your workbook to require users to enter a password to either open or
modify them. Notice there are two boxes where you can enter a password:
•

Password to open: Adding a password here will require that a user enter the
assigned password in order to open the workbook.

•

Password to modify: Adding a password here will require that a user enter
the assigned password in order to modify the workbook.
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7.
8.
9.

10.
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In the Password to open box, type flower.
Notice the text you type appears as a string of *****’s. This is so someone can’t look
over your shoulder and see your password. Notice there is also a Password to modify
text box—adding a password here will allow a user to open a workbook but not modify
it without entering the assigned password.
Click OK.
The Confirm Password dialog box appears. You must reenter your password, flower,
once more here, just in case you mistyped it the first time.
Type flower, then click OK.
The Save options dialog box closes and you are returned to the Save As dialog box.
Click Save.
Excel saves the Budget Proposal workbook.
Close the workbook.
Select File → 1 Budget Proposal from the recent files list from the
menu.
The Password dialog box appears, as shown in Figure 13-11. You must enter the
correct password, flower, in order to open the workbook. Try entering an incorrect
password to see what happens.
Type pencil and then click OK.
The Incorrect Password dialog appears, as shown in Figure 13-12. You cannot open a
password protected workbook without entering the correct password. A dialog box
appears informing you that you have typed an incorrect password.
Click OK to close the Incorrect Password dialog box.

11.
12. Select File → 1 Budget Proposal from the recent files list in the menu.
13.
14.

The Password dialog box appears. This time enter the correct password.
Type flower and then click OK.
The Budget Proposal opens. Removing password protection from a workbook is just as
easy as adding it.
Select File → Save As from the menu.
The Save As dialog box appears.
Click the Options button.

15.
16. Delete the ****** in the Password to open textbox, and then click OK.
17. Click Save.
Excel saves the workbook without any password protection.

Quick Reference
To Password Protect a
Workbook:
1. Select File → Save As
from the menu.
2. Click the Options button.
3. Type a password in either
the Password to open or
Password to modify text
box and click OK.
To Remove Password
Protection from a
Workbook:
• Repeat the above steps,
only remove the
password from either the
Password to open or
Password to modify text
box and click OK.
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Lesson 13-5: File Properties and
Finding a File
Figure 13-13
The file Properties dialog
box.
Figure 13-14
Search for Excel
workbooks using the
Windows Find command.
Figure 13-15
The Advanced Find dialog
box.

Figure 13-13

Figure 13-14

Type the name of the file you
want to look for

Start the search

Specify the file or folder you
want to look in

Clear the dialog
box so you can
look for a new
file

Include any subfolders in the
search

Figure 13-15

The results of
the search
appear here.
Click a file or
folder to open it

We’ll cover two related topics in this lesson. The first topic is File Properties. Information
about the size of a workbook, when it was created, when it was last modified, and who
created it, can all be found with the File → Properties command. The File Properties dialog
box also has custom fields, such as Subject and Category, so you can add your own
information to your workbooks. The second topic covered in this lesson is how to find a file.
It is just as easy to misplace and lose a file in your computer as it is to misplace your car
keys—maybe easier! Luckily, Excel comes with a great Find feature that can track down your
lost files. Find can search for a file, even if you can’t remember its exact name or location.

1.
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Verify that the Budget Proposal workbook is open, then select File →
Properties from the menu, and click the General tab.
The General tab of the Properties dialog box appears. The General tab of the Properties
dialog box tracks general information about the file, such as its size, its location, when
the file was created, and when it was last accessed or modified.
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2.
3.
4.
5.
6.
7.
8.

Click the Summary tab.
The Summary tab of the Properties dialog box lets you enter your own information to
describe and summarize the file, such as the author, subject, keywords, and category.
You can use the information in the Summary tab to help you search for files.
Click the Keywords box, type 1999 Budget Proposal and click OK.
Excel saves the summary information and closes the Properties dialog box.
Save your changes and close the workbook.
Okay, let’s move on to how to find a file.
Click the Windows Start button and select Find → Files or Folders.
The Find dialog box appears, as shown in Figure 13-15.
Type Budget in the Named box.
This will search for any file that contains the word “budget,” such as “1999 Budget
Proposal” and “Budget Report.” So, if you only know part of the file name, you can
enter the part of the file name that you know.
Navigate to your Practice folder or disk, then click Find Now.
A list of files that match the criteria you entered in the File name text box appear in the
open dialog box.
Double-click the Budget Proposal file.
The Budget Proposal workbook opens in Microsoft Excel.
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Start button

Quick Reference
To View a Workbook’s
Properties:
• Select File → Properties
from the menu.
To Find a Workbook:
1. Click the Windows Start
button and select Find
→ Files or Folders from
the Start menu.
2. Enter the search
conditions and where to
look on the appropriate
tabs: Name & Location,
Date, and Advanced).
3. Click Find Now to start
searching for the file(s).
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Lesson 13-6: Sharing a Workbook
and Tracking Changes
Figure 13-16
The Editing tab of the
Share workbook dialog
box.
Figure 13-17
Excel Revisions made in
the Budget Proposal
shared workbook

Figure 13-16

Figure 13-17

You can share your Excel workbook files with other people, so that you can work on the data
collaboratively. Sharing a workbook has several benefits:
•

Several people can use the same shared workbook simultaneously.

•

Excel keeps track of any changes made to a shared workbook, when they were made, and
who made them.

•

You can review and accept or reject any changes made to a shared workbook.

This lesson explains how you can share a workbook when you need to collaborate on a
project with other people.
Other Ways to Share a
Workbook:
• Select Tools → Share
Workbook from the
menu.

1.
2.
3.

 2000 CustomGuide, Inc.

Make sure the Budget Proposal workbook is open, select Tools →
Track Changes → Highlight Changes from the menu.
The Highlight Changes dialog box appears, as shown in Figure 13-16.
Check the Track changes while editing check box.
Checking this checkbox does two things: (1) It shares the workbook, so other users can
use it simultaneously, and (2) it tracks any changes made to the workbook.
Click OK.
A dialog box appears, informing that Excel must save the workbook in order to share
it.
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5.

6.
7.

8.
9.

10.

11.
12.

Click OK.
Excel saves and shares the Budget Proposal workbook. Notice [Shared] appears after
the workbook name in Excel’s title bar, indicating that you are working on a shared
workbook.
That’s all there is to sharing a workbook. If you’re on a network, multiple users can
now open and edit the workbook at the same time (normally only one person can open
and edit the same file at a time). Now that the workbook is shared, you or other users
can track any changes made to the workbook. The remainder of this lesson and the next
lesson will show how you can track changes in a shared workbook.
You decide to break up the insurance payment of $5,800 into payments spanning two
quarters instead of one. Move on to the next step to make the revisions.
Select cell B7, type 2900, press <Tab> to move to cell C7, type 2900,
and press <Enter>.
Excel highlights the revisions you made in cell B7 and C7 with tiny blue triangles in
the upper left-hand corners of the modified cells, as shown in Figure 13-17. You can
review your changes later and accept or reject them.
Move the cell pointer over the revised cell B7.
A note appears by the cell listing the revisions made to it.
Click the Save button on the Standard toolbar to save your changes to
the shared workbook.
You can also make copies of the workbook that you can distribute to reviewers. When
you make a copy of a shared workbook, you can later compare, or merge, the copied
workbook to the original to review any changes that have been made to the copy.
Here’s how you can create a copy of a shared workbook:
Select File → Save As from the menu.
The Save As dialog box appears. Save a copy of the shared workbook with a different
name.
Type Revised Budget in the File name text box, and click OK.
The “Budget Proposal” workbook is saved with the new name, “Revised Budget,” and
the original workbook, “Budget Proposal,” closes. Now that you’re working with a
copy of the original workbook (the Revised Budget file) make some revisions to the
workbook. You will get a chance to accept or reject the changes in the next lesson.
Click cell B5, type 6000, press <Tab> to move to cell C5, type 6000, and
press <Enter>.
Remember— now you’re working with the copied workbook “Revised Budget” and
not the original “Budget Proposal” workbook. Excel highlights your changes in cell
C6.
Click cell A10, type Expenses, and press <Enter>.
You’re finished making revisions to the Revised Budget workbook, so save your
changes and close the workbook.
Save your changes and then close the Revised Budget workbook.
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Change Indicator

Quick Reference
To Share a Workbook:
1. Select Tools → Track
Changes → Highlight
Changes from the menu.
2. Check the Track
changes while editing
check box.
3. Make sure you save the
workbook where it is
accessible to other users
(i.e. a shared folder on a
network drive).
To View Changes Made to
a Cell:
• Position the mouse
pointer over the marked
changed cell and wait a
few seconds.
To Make a Copy of a
Shared Workbook:
• Create a copy of the
shared workbook by
selecting File → Save As
and saving it with a
different name.
Then you can then
distribute these copies to
other users and later
compare or “merge” them
with the original to review
any changes made.
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Lesson 13-7: Merging and Revising
a Shared Workbook
Figure 13-18
Revisions made in the
Budget Proposal shared
workbook.
Figure 13-19
Selecting changes that
have not yet been
reviewed in the Select
Changes to Accept or
Reject dialog box.
Figure 13-20

Figure 13-18
When: Review changes for the
interval of elapsed time you specify
in the When box

The Accept or Reject
Changes dialog box.

Who: Review changes in the
workbook made by the person or
persons selected in the Who box

Figure 13-19

Where: Review changes only for a
specific range of cells box

Figure 13-20

Once a shared workbook has been revised, you can review the changes and decide if you want
to accept the changes and make them part of the workbook or reject the changes. Revising
workbooks using Excel’s revision features can save a lot of time, because you merely have to
accept the changes to incorporate them into your workbook instead of manually typing the
changes yourself.
You can also compare, or merge, copies made of a shared workbook, and review, accept,
and/or reject any changes made.

1.
2.
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Open the workbook named Budget Proposal.
Budget Proposal is the shared workbook you created in the previous lesson. Display
the revisions you made in the previous lesson.
Select Tools → Track changes → Highlight changes from the menu.
The Track Changes dialog box appears.

Chapter Thirteen: Advanced Topics

3.

4.
5.
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9.

10.

11.
12.

Verify that the When box is checked, then click the When drop-down
list, select All and click OK.
Excel highlights the revisions you made in cells B7 and C7.
Now that you have the original shared workbook open, you can merge it with the
copied workbook, Revised Budget, to review any revisions made to the copy.
Select Tools → Merge Workbooks from the menu.
The Select Files to Merge Into Current Workbook dialog box appears. Here you must
select the copy of the shared workbook that you want to compare or merge with the
original.
Select the Revised Budget workbook and click OK. Click OK if you are
prompted to save the shared workbook.
Excel merges the revisions made into the Revised Budget workbook with the original
Budget Proposal workbook, as shown in Figure 13-18.
Move the cell pointer over the revised cell B7.
A note appears by the cell with the revisions made to it. To review all the revisions
made to a shared workbook and either accept or reject them, select Tools → Track
Changes → Accept or Reject Changes from the menu.
Select Tools → Track Changes → Accept or Reject Changes from the
menu.
The Accept or Reject Changes dialog box appears, as shown in Figure 13-19.
Make sure the When check box is selected, and that Not yet reviewed
appears in the When list box, then click OK.
The Accept or Reject Changes dialog box appears with the first of five changes made
to the workbook—changed cell B7 from $5,800.00 to $2,900.00. Accept this change.
Click Accept to accept the first change, and Accept again to accept the
second change in the workbook—changed cell C7 from $5,800.00 to
$2,900.00.
After accepting the first two changes made to the workbook, the third change
appears—changed cell B5 from $5,000 to $6,000. You decide to reject this change.
Click Reject to reject the third change, and Reject again to reject the
fourth change in the workbook—changed cell C5 from $5,000.00 to
$6,000.00.
You decide to accept the fifth change made to the shared workbook—changed cell A10
from “Other Expenses” to Misc. Expenses”.
Click Accept to accept the fifth change made to the shared workbook.
The Accept or Reject Changes dialog box closes, and the revisions you accepted are
made to the workbook.
Save the Budget Proposal workbook and exit Microsoft Excel.
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Quick Reference
To Highlight Changes in a
Shared Workbook:
1. Select Tools → Track
changes → Highlight
changes from the menu.
2. Select which changes you
want to review (usually
Not yet reviewed in the
When combo box) and
click OK.
To View Changes Made to
a Cell:
• Position the mouse
pointer over the marked
changed cell and wait a
few seconds.
To Accept and/or Reject
Revisions:
1. Select Tools → Track
Changes → Accept or
Reject Changes from the
menu.
2. Select which changes you
want to review (usually
Not yet reviewed in the
When combo box) and
click OK.
3. Click either the Accept
Change button or the
Reject Change button.
To Merge Shared
Workbooks:
1. Select Tools → Merge
Workbooks from the
menu, and select the file
you wish to merge with
the open workbook.
2. See the instruction on
how to accept and/or
reject revisions.
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Lesson 13-8: Using Detect and
Repair
Figure 13-21
Selecting Detect and
Repair from the Help
menu.
Figure 13-22
The Detect and Repair
dialog box.
Figure 13-23
Detect and Repair finds
and repairs any errors it
finds in the Microsoft
Office 2000 applications.

Figure 13-21

Figure 13-22

Figure 13-23

It’s a sad fact of life. The more complicated programs get, the more can go wrong with them.
Programs sometimes become corrupted and have to be reinstalled to make them work right
again. Fortunately for you and your network administrator Microsoft has made this process
relatively painless with Office 2000’s new Detect and Repair feature. Detect and Repair
searches for corrupted files and incorrect settings in any Microsoft Office 2000 applications
and then finds and reinstalls the appropriate files.
Should your installation of Microsoft Excel become corrupted or buggy this lesson explains
how you can use Detect and Repair to fix the problem.

1.

2.
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Make sure the Office 2000 CD is inserted in your computer’s CD-ROM
drive or is available through the network.
If you are connected to a large corporate network hopefully your friendly network
administrator will have made the Office 2000 files available to everyone on the
network so that you can use the Office 2000 Detect and Repair feature. The only way
you can find out if the Office 2000 installation files are available is to run Detect and
Repair.
Select Help → Detect and Repair from the menu.
The Detect and Repair dialog box appears as shown in Figure 13-22. Here we go…
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3.
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Click Start.
If Detect and Repair finds the Office 2000 installation files, it begins looking for and
repairing any problems it finds with any Office 2000 programs. This might be a good
time for you to take a coffee break as Detect and Repair takes a long time to fix
everything.

Quick Reference
To Use Detect and Repair:
• Select Help → Detect
and Repair from the
menu.
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Chapter Thirteen Review
Lesson Summary
Adding, Positioning, and Removing Toolbars
•

To View or Hide a Toolbar: Select View → Toolbars from the menu and select the toolbar you
want to display or hide or right-click any toolbar or menu and select the toolbar you want to display
or hide from the shortcut menu.

•

Move a toolbar by dragging its move handle (if the toolbar is docked) or title bar (if the toolbar is
floating).

Creating and Using Custom Toolbars
•

To Create a Custom Toolbar: Select View → Toolbars → Customize from the menu, click
New, and type a name for the new toolbar.

•

To Add a Button to a Toolbar: Select View → Toolbars → Customize from the menu and click
the Commands tab. Select the command category from the Categories list, then find the desired
command in the Commands list and drag the command to the toolbar.

•

To Remove a Button from a Toolbar: Select View → Toolbars → Customize from the menu
and drag the button off the toolbar.

Creating a Custom AutoFill List
•

To Create a Custom AutoFill List: Select the cell range that contains the information you want to
include in your custom AutoFill list, select Tools → Options from the menu, click the Custom
Lists tab and click Import.

•

To Use a Custom AutoFill List: Enter the first name from the list in a cell, select that cell, and
then click and drag the fill handle to complete the series in the cells you select.

Changing Excel’s Options
•

You can change Excel’s default options by selecting Tools → Options from the menu.

Password Protecting a Workbook
•

To Password Protect a Workbook: Select File → Save As from the menu, click the Options
button, and enter a password in either the Password to open or Password to modify boxes.

•

To Remove Password Protection from a Workbook: Select File → Save As from the menu,
click the Options button, and remove any text from the Password to open or Password to
modify boxes.

File Properties and Finding a File
•
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You can view a file’s properties (when it was created, by whom, etc.) by selecting File →
Properties from the menu.
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•

To Find a Workbook: Click the Start button and select Find → Files or Folders from the Start
menu. Enter the search conditions and where to look on the appropriate tabs: Name & Location,
Date, and Advanced. Click Find Now to start searching for the file(s).

Sharing a Workbook and Tracking Changes
•

Sharing a workbook allows several users to open and work on it at the same time. It allows you to
track, review, and accept or reject any changes made to the workbook.

•

To Share a Workbook: Select Tools → Track Changes → Highlight Changes from the menu
and click the Track changes while editing check box.

•

If the track changes option is selected, modified cells are highlighted. To view the changes made to
a cell position the mouse pointer over cell and wait several seconds.

•

You can save copies of a shared workbook by saving the shared workbook with a different name
using File → Save As. You can then distribute these copies to other users and later compare or
“merge” them with the original to review any changes made to them.

Merging and Revising a Shared Workbook
•

To Highlight Changes in a Shared Workbook: Select Tools → Track changes → Highlight
changes from the menu, select which changes you want to review (usually Not yet reviewed in
the When combo box) and click OK.

•

To Accept and/or Reject Revisions: Select Tools → Track Changes → Accept or Reject
Changes from the menu, select which changes you want to review (usually Not yet reviewed in
the When combo box) and click OK. Click either the Accept Change button or the Reject
Change button.

•

To Merge Shared Workbooks: Select Tools → Merge Workbooks from the menu and select the
file you wish to merge with the open workbook.

Using Detect and Repair
•

To Use Detect and Repair: Select Help → Detect and Repair from the menu.

Quiz
1. Which of the following statements is NOT true?
A. You can change the position of a toolbar by dragging it by its move handle (if it’s
docked) or title bar (if it’s floating).
B. You can display a toolbar by selecting View → Toolbars and selecting the toolbar
you want to display from the list.
C. You can display a toolbar by clicking the Toolbar button on the Standard toolbar and
selecting the toolbar you wan to display from the list.
D. Toolbars attach or “dock” to the sides of the program window.
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2. Which of the following statements is NOT true?
A. You can customize a toolbar by right-clicking any toolbar or menu and selecting
Customize from the shortcut menu.
B. You can customize a toolbar by selecting View → Toolbars → Customize from the
menu.
C. Once the Customize dialog box is open you can add buttons to a toolbar by
double-clicking on the toolbar where you want to insert the button.
D. Once the Customize dialog box is open you can add buttons to a toolbar by dragging
them from the Commands list onto the toolbar.
3. You can modify Excel’s built-in toolbars, and you can create your own
toolbars. (True or False?)
4. To password protect a worksheet, select Tools → Protection and enter the
password. (True or False?)
5. Which of the following statements is NOT true?
A. You can find a workbook by clicking the Windows Start button, selecting Find →
Files and folders, entering any part of the workbook’s name in the File name box in
the Open dialog box and clicking Find Now.
B. Selecting File → Properties from the menu displays statistics on a file, such as its
size and when it was last saved.
C. Selecting File → Options from the menu opens the Options dialog box, which
contains the default settings for Excel.
D. You can create your own custom AutoFill lists.
6. Which of the following is NOT an advantage of working with a shared
workbook?
A.
B.
C.
D.

Several users can open and work on the workbook simultaneously.
Excel can create a report summarizing all the changes made to the workbook.
You can track, review, accept and/or reject any changes made to the workbook.
You can create a copy of the workbook, distribute it to other users, and then later
compare, or merge, the copy with the original to review any changes.

7. How can you track changes made by other users to a workbook?
A. Select File → Save As from the menu and select Multi-User workbook from the
Save as type list.
B. Select Tools → Track Changes → Highlight Changes from the menu.
C. Have other users place a Post-It Note on their monitors by the cells they change.
D. There’s no way of doing this in Microsoft Excel.

Homework
1. Create a new blank workbook.
2. Select Tools → Customize from the menu and click New to create a new toolbar.
Name the toolbar “My Commands.”
3. Click the Commands tab, browse through the various Categories and Commands and
drag the commands you think you will use frequently onto the new My Commands
toolbar.

 2000 CustomGuide, Inc.

Chapter Thirteen: Advanced Topics
4. Delete the My Commands toolbar when you’re finished (click the Toolbars tab,
select the My Commands toolbar and click Delete).
5. Type some text and numbers into the blank workbook, save it as “Confidential”.
Password protect the workbook so that users must enter the password “leaf” to open
the workbook.
6. Select Tools → Track Changes → Highlight Changes from the menu.
7. Modify the text and numbers you entered in the workbook—notice how Excel tracks
the changes you make.
8. Review the changes you made by selecting Tools → Track Changes → Accept or
Reject Changes.

Quiz Answers
1. C. There isn’t a toolbar button in Excel.
2. C. Once the Customize dialog box is open you can add buttons to a toolbar by
dragging commands from the commands list to the desired location on the toolbar—
not by double-clicking.
3. True. You can modify Excel’s existing toolbars and you can create your own custom
toolbars.
4. False. Select File → Save As from the menu and click the Options button to
password protect a workbook.
5. C. Select Tools → Options from the menu to open the Options dialog box.
6. B. Although you can track any changes made to a shared workbook there isn’t any
way of creating a report that summarizes the changes.
7. B. Select Tools → Track Changes → Highlight Changes from the menu to track
changes made to a workbook.
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A
Absolute cell references........................ 70
Address, cell.......................................... 30
Advanced filter ................................... 246
Align Right button .............................. 103
Alignment
horizontal ........................................ 102
shrink to fit.......................................118
tab, Format Cells dialog box. .......... 102
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wrapping text ...................................118
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Auding toolbar .................................... 216
AutoCalculate ..................................... 208
AutoComplete....................................... 60
AutoFill................................................. 42
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AutoFilter............................................ 242
AutoFilter, custom .............................. 244
AutoFit................................................ 101
AutoFormat..................................110, 314
AutoOutline ........................................ 322
AutoSum ............................................... 38
AVERAGE function............................ 205
B
Backspace key....................................... 63
Bold ...................................................... 96
Border(s) ............................................. 104
C
Cancel button ........................................ 35
Cell pointer, moving ............................. 30
Cell ranges
calculating automatically ................ 208
definition of....................................... 36
moving .............................................. 66
naming ............................................ 206
restricting the cell pointer ................. 37
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selecting .............................................37
selecting non-adjacent......................208
Cell references
absolute..............................................70
relative ...............................................70
Cells
adding borders to .............................104
adding comments to ...........................86
aligning ............................................102
clearing ..............................................62
color, changing.................................106
copying ............................64, 70, 72, 74
cutting ..............................64, 70, 72, 74
deleting ..............................................74
editing ................................................62
formatting ....................................96, 98
inserting .............................................74
locking and unlocking......................184
merging ............................................118
moving .......................64, 66, 70, 72, 74
naming .............................................206
pasting..............................64, 70, 72, 74
pattern, changing..............................106
rotating text in..................................118
Center alignment..................................102
Chart Type button ................................136
Charts
3-D charts ........................................144
annotating ........................................142
arrows, adding to .............................142
axis, formatting ................................140
colors, changing...............................133
creating ............................................128
custom..............................................146
Data Series dialog box .....................141
data source, changing.......................134
data tables ........................................138
editing ..............................................132
fill effects .........................................148
fonts .................................................132
fonts, formatting ..............................132
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formatting a data series....................140
modifying ........................................130
moving.............................................131
objects in..........................................132
pie charts..........................................136
sizing ...............................................131
standard ...........................................146
titles .................................................138
types, changing ................................136
Word, inserting in ............................282
ChartWizard.........................................128
Clearing cell contents ............................62
ClipArt, inserting .................................284
Clipboard .............................64, 70, 72, 74
Close button...........................................50
Collaboration, workbook .....................356
Collapse Dialog Box button ................135
Color
borders .............................................104
cell background ...............................106
chart objects.....................................132
fonts ...................................................96
Column Width dialog box....................100
Columns
adjusting width of ............................100
deleting ..............................................74
freezing ............................................170
hiding...............................................184
inserting .............................................74
selecting.............................................74
Comma number format..........................98
Comma Style button ..............................98
Comments..............................................86
Conditional formatting ........................ 116
Consolidating, worksheets...................192
Copy button ...........................................64
Copying .................................................64
Ctrl key ..................................................24
Currency button .....................................98
Currency format.....................................98
Custom
AutoFill list......................................348
chart .................................................146
header/footer....................................174
views................................................188
Cut button ..............................................65
Cutting ...................................................65
D
Data
entering in a worksheet................36, 38
mapping ...........................................150
outlining...........................................322

Data Form
adding records ................................. 234
criteria, specifying ........................... 238
finding records................................. 236
Data Series, formatting, Chart ............. 140
Data table, one and two input .............. 334
Data Validation .................................... 250
Database
adding records ................................. 234
AutoFilter, custom ........................... 244
AutoFilter, using.............................. 242
copying filtered records................... 248
data validation ................................. 250
deleting records ............................... 238
DSUM function ............................... 318
filter, advanced ................................ 246
finding records................................. 236
functions .......................................... 225
guideline for creating....................... 233
sorting.............................................. 240
Databases
creating ............................................ 232
Dates
entering..............................................60
functions .......................................... 222
in headers/footers ............................ 174
Decrease Decimal button.......................99
Decrease Indent button ........................ 103
Default chart type, changing................ 146
Delete key..............................................62
Deleting
cells, columns, and rows....................74
records in a list ................................ 238
worksheets ....................................... 164
detect and repair .................................. 360
Dialog boxes..........................................22
DIM statement..................................... 268
DIV/0! Error ........................................ 217
Drag-and-drop .......................................66
Drawing............................................... 142
Drawing toolbar................................... 142
Drop-down lists, adding ...................... 250
DSUM function ................................... 318
E
Editing
cell comments....................................86
cells....................................................62
macros ............................................. 264
Enter button ...........................................35
Errors in formulas................................ 216
Excel
exiting................................................50
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options, changing ............................ 350
starting Excel .................................... 10
Exiting, Excel program ......................... 50
Extracting filtered records................... 248
F
F1 key ................................................... 47
Field names, adding to a list ............... 232
File management................................... 84
Files
deleting ............................................. 84
different formats.............................. 286
HTML format.................................. 296
renaming ........................................... 84
Fill Color button.................................. 106
Fill effects ........................................... 148
Fill handle ............................................. 43
Filter
copying filtered records .................. 248
Filtering
custom AutoFilter ........................... 244
extracting records............................ 248
Filtering, advanced.............................. 246
Financial functions.............................. 220
Finding
data with Find command................... 80
records in a list................................ 236
searching and replacing data ............. 80
Fonts
changing............................................ 96
color .................................................. 97
size .................................................... 96
Footers ................See Headers and footers
Format Painter button ......................... 108
Formatting
AutoFormat..............................110, 314
chart objects .................................... 132
conditional formatting......................116
copying ........................................... 108
creating a custom number format.....112
dates .................................................. 99
fonts .................................................. 96
numbers............................................. 98
Styles................................................114
with the Formatting toolbar .............. 96
Formatting toolbar ................................ 15
Formula bar........................................... 15
Formula Palette ................................... 204
Formulas
definition of....................................... 38
displaying and printing ................... 214
entering ........................................38, 40
error values ..................................... 216
hiding .............................................. 184
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order of precedence..........................202
using several operators.....................202
Freezing, window ................................171
Functions
AVERAGE function ........................205
database ...........................................225
date and time....................................222
DSUM function ...............................318
financial ...........................................220
function categories...........................205
IF function .......................................210
mathmatical......................................218
PMT function...................................212
statistical ..........................................224
VLOOKUP function ........................320
G
Goal Seek.............................................336
Graphic, inserting ................................284
Gridlines
printing.............................................180
H
Headers and footers .............................174
Headings
adding row and column print titles ..180
Height, row ..........................................100
help
Contents tab .......................................46
what is this button..............................48
Hiding
columns, rows, and worksheets .......184
formulas ...........................................184
outline details...................................322
HLOOKUP function ............................321
HTML, save as ....................................296
Hyperlinks
adding ..............................................292
browsing with ..................................294
deleting ............................................293
editing ..............................................293
I
IF function ...........................................210
IF...THEN, Visual Basic procedure......272
Importing files .....................................286
Increase Decimal button ........................99
Increase Indent button..........................103
Insert Hyperlink button........................292
Inserting
cell comments ....................................86
chart in Microsoft Word document ..282
charts................................................128
functions ..........................................204
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graphics............................................284
maps.................................................150
page breaks ......................................176
pictures ............................................284
worksheet in Microsoft Word document
.....................................................278
worksheets .......................................164
Inserting a picture ................................284
Internet, saving workbook to ...............296
Italics .....................................................97
K
Keyboard ...............................................24
Keystroke shortcuts ...............................24
common shortcuts..............................25
navigation ..........................................33
L
Labels ....................................................34
entering numbers as ...........................35
truncated ............................................35
Landscape orientation..........................178
Linking external data ...........................172
List, creating custom AutoFill .............348
Lists
adding records .................................234
AutoFilter, custom ...........................244
AutoFilter, using ..............................242
creating ............................................232
data validation .................................250
deleting records ...............................238
DSUM function ...............................318
filter, advanced ................................246
finding records.................................236
guideline for creating.......................233
sorting ..............................................240
VLOOKUP function ........................320
Locking cells .......................................184
M
Macros
copying code....................................266
creating ............................................258
deleting ............................................261
DIM statement, using ......................268
editing ..............................................264
IF...THEN statements ......................272
input, prompting for.........................270
keystroke, assigning.........................260
playing .............................................260
recording..........................................258
Remarks, adding ..............................268
toobars, adding to ............................262

Visual Basic code ............................ 264
Map button .......................................... 150
Map toolbar ......................................... 152
Maps
features ............................................ 152
formats............................................. 151
modifying ........................................ 152
pins, adding ..................................... 152
plotting data..................................... 150
Margins................................................ 178
Mathmatical functions ......................... 218
Menus
shortcut menus........ See shortcut menus
Merge and Center button ..................... 103
Merging cells ....................................... 118
Moving
cells.............................................. 64, 66
charts ............................................... 130
pictures and graphics ....................... 284
worksheets ....................................... 166
Multiple windows, working with......... 168
N
N/A error ............................................. 217
Name box ...................................... 15, 206
NAME? Error ...................................... 217
Naming
cell ranges........................................ 206
NULL! error ........................................ 217
NUM! error ......................................... 217
O
Office Assistant .....................................47
changing ............................................48
One-input data table ............................ 334
Open dialog box ....................................28
Opening
files in different formats .................. 286
workbooks .........................................28
Operators ....................................... 40, 202
Options, default ................................... 350
Outlining.............................................. 322
P
Page Break Preview............................. 176
Page break, inserting ........................... 176
Page Numbers...................................... 175
Page orientation................................... 178
Paper size............................................. 182
Paper size, changing ............................ 178
Passwords, assigning to workbooks .... 352
Paste button ...........................................64
Paste Function button .......................... 204
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Pasting................................................... 64
Patterns
in cells............................................. 106
in chart objects .........................132, 148
Percent number format.......................... 99
Percent Style button .............................. 99
Picture, inserting ................................. 284
Pie charts...................................See Charts
PivotTable diagram ............................. 306
PivotTable toolbar............................... 310
PivotTable Wizard............................... 306
PivotTable Wizard button ................... 310
PivotTables
creating ........................................... 306
dates, grouping by........................... 312
definition of..................................... 305
editing ......................................310, 313
modifying........................................ 310
updating .......................................... 313
PMT function...................................... 212
Point size, fonts..................................... 96
Portrait orientation .............................. 178
Print button ........................................... 45
Print Preview ........................................ 44
Print titles............................................ 180
Printing
cell range......................................... 176
changing paper size......................... 182
formulas .......................................... 214
gridlines .......................................... 180
more than one copy........................... 82
options............................................... 82
previewing page breaks................... 176
scaling ............................................. 182
to a different printer .......................... 82
worksheets ........................................ 44
Protecting worksheets ......................... 184
R
Range names ....................................... 206
Ranges
charting ........................................... 128
naming ............................................ 206
printing............................................ 176
selecting ............................................ 62
selecting non-adjacent..................... 208
Recording a macro .............................. 258
Records
adding ............................................. 234
definition of..................................... 232
deleting ........................................... 238
extracting ........................................ 248
filting............................................... 242
finding............................................. 236
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sorting ..............................................240
Redo.......................................................76
REF! error............................................217
References
absolute..............................................70
external ............................................172
relative ...............................................70
Refreshing, PivotTables .......................313
Relative cell references..........................70
Remove split ........................................170
Replace dialog box. ...............................80
Reviewing changes ..............................358
Right-click .............................................24
Rotate, data in a cell.............................118
Rows
adjusting height of ...........................100
deleting ..............................................74
freezing ............................................170
hiding ...............................................184
inserting .............................................74
selecting .............................................74
S
Save dialog box .....................................28
Saving
files in different formats...................286
Lotus 1-2-3 files...............................286
views................................................188
workbooks .........................................28
worksheet as a Web page .................296
Scenario
creating ............................................330
summary report................................332
viewing ............................................330
Screen, Excel program...........................14
Scrolling
between sheet tabs ...........................163
through worksheets............................32
Search and replace .................................80
Selecting
cell ranges ..........................................36
chart objects .....................................132
entire worksheet...............................100
non-adjacent cell ranges...................208
Sharing workbooks ..............................356
Sheettabs..............................................162
Shortcut menus ......................................24
Show outline details.............................322
Solver...................................................338
Sorting information..............................240
Spell checking........................................78
Splitting, window.................................170
Statistical functions..............................224
Status bar ...............................................14
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Styles ................................................... 114
Subtotals ..............................................316
SUM formula...........39. See also formulas
Summarizing
consolidating worksheets.................192
data with outlines.............................322
data with PivotTables.......................306
data with subtotals ...........................316
T
Tables, data input.................................334
Target cell(s) ........................................338
Templates.............................................190
Text ............................................ See labels
adding to charts................................142
adding to maps.................................150
changing orientation of .................... 118
color of, changing ..............................96
rotating............................................. 118
Shrink to Fit..................................... 118
Text Box button ...................................142
Toolbars
adding and removing .........................20
adding macro button to ....................262
button image, changing....................262
creating ............................................346
customizing......................................346
moving...............................................20
Standard toolbar.................................15
Trace Error button................................217
Trace Precedents button.......................217
Two-input data table ............................334
U
Underline ...............................................96
Undo ......................................................76
Unfreezing panes .................................170
Ungrouping..........................................322
Unlocking cells ....................................184
Updating, PivotTables .........................313
V
Validation of data entry........................250
VALUE! error ......................................217
Values ..............................................34, 36
entering ..............................................36
formatting ..........................................98
in formulas.........................................38
Variables, declaring in Visual Basic ....268
VBA.................................See Visual Basic
Viewing, saving custom.......................188
Virus warning ......................................266
Visual Basic

copying code.................................... 266
editing.............................................. 264
editor, using ..................................... 264
IF...THEN statements ...................... 272
InputBox statement.......................... 270
REM statement ................................ 268
VLOOKUP function............................ 320
W
Web Page, save as................................ 296
Web toolbar ......................................... 295
what is this button..................................48
What-if analysis................................... 329
What-If Analysis
defined............................................. 329
goal seek .......................................... 336
input tables ...................................... 334
scenario summary report ................. 332
scenarios .......................................... 330
solver ............................................... 338
Width, column ..................................... 100
Windows
arranging.......................................... 169
freezing............................................ 171
splitting............................................ 170
working with.................................... 168
Word, Microsoft
chart, inserting in ............................. 282
inserting worksheet in...................... 278
modifying an embedded worksheet . 280
Workbooks
closing ...............................................50
merging............................................ 358
opening ..............................................28
password protecting......................... 352
printing ..............................................44
reviewing ......................................... 358
saving ................................................28
sharing ............................................. 356
tracking changes in .......................... 356
Web page, save as............................ 296
working with different formats........ 286
working with several workbooks..... 168
Worksheets
consolidating ................................... 192
copying ............................................ 167
deleting ............................................ 164
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inserting ........................................... 164
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protecting and unprotecting ............. 184
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switching between ........................... 162
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