# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Introduction</strong></td>
<td>7</td>
</tr>
<tr>
<td><strong>Chapter One: The Fundamentals</strong></td>
<td>11</td>
</tr>
<tr>
<td>Lesson 1-1: Introduction to FrontPage</td>
<td>12</td>
</tr>
<tr>
<td>Lesson 1-2: Introduction to the World Wide Web</td>
<td>14</td>
</tr>
<tr>
<td>Lesson 1-3: Starting Microsoft FrontPage</td>
<td>16</td>
</tr>
<tr>
<td>Lesson 1-4: Understanding the FrontPage Screen</td>
<td>18</td>
</tr>
<tr>
<td>Lesson 1-5: Using Menus</td>
<td>20</td>
</tr>
<tr>
<td>Lesson 1-6: Using Toolbars</td>
<td>22</td>
</tr>
<tr>
<td>Lesson 1-7: Using Hyperlinks</td>
<td>24</td>
</tr>
<tr>
<td>Lesson 1-8: Keystroke and Right Mouse Button Shortcuts</td>
<td>26</td>
</tr>
<tr>
<td>Lesson 1-9: Opening and Closing a Web Page</td>
<td>28</td>
</tr>
<tr>
<td>Lesson 1-10: Getting Help and Using the “What’s This” Button</td>
<td>30</td>
</tr>
<tr>
<td>Chapter One Review</td>
<td>32</td>
</tr>
<tr>
<td><strong>Chapter Two: Creating Web Pages and Web Sites</strong></td>
<td>37</td>
</tr>
<tr>
<td>Lesson 2-1: Creating a Blank Web Page</td>
<td>38</td>
</tr>
<tr>
<td>Lesson 2-2: Create a Web Page from a Template</td>
<td>40</td>
</tr>
<tr>
<td>Lesson 2-3: Create a New Web Site Using a Template</td>
<td>42</td>
</tr>
<tr>
<td>Lesson 2-4: Creating a New Web Site with a Wizard</td>
<td>44</td>
</tr>
<tr>
<td>Lesson 2-5: Importing Files and Folders</td>
<td>46</td>
</tr>
<tr>
<td>Lesson 2-6: Importing an Existing Web Page from the Internet</td>
<td>48</td>
</tr>
<tr>
<td>Lesson 2-7: Inserting and Deleting Text</td>
<td>50</td>
</tr>
<tr>
<td>Lesson 2-8: Understanding How Web Pages are Saved</td>
<td>52</td>
</tr>
<tr>
<td>Lesson 2-9: Saving a Web Page</td>
<td>54</td>
</tr>
<tr>
<td>Lesson 2-10: Cutting, Copying, and Pasting Text</td>
<td>56</td>
</tr>
<tr>
<td>Lesson 2-11: Moving and Copying Text with Drag and Drop</td>
<td>58</td>
</tr>
<tr>
<td>Lesson 2-12: Finding and Replacing Text</td>
<td>60</td>
</tr>
<tr>
<td>Lesson 2-13: Working with Paragraphs and Line Breaks</td>
<td>62</td>
</tr>
<tr>
<td>Lesson 2-14: Inserting Text from a File</td>
<td>64</td>
</tr>
<tr>
<td>Lesson 2-15: Correcting Your Spelling</td>
<td>66</td>
</tr>
<tr>
<td>Lesson 2-16: Using Undo and Redo</td>
<td>68</td>
</tr>
<tr>
<td>Chapter Two Review</td>
<td>70</td>
</tr>
<tr>
<td><strong>Chapter Three: Working with Web Pages</strong></td>
<td>77</td>
</tr>
<tr>
<td>Lesson 3-1: Working with the Views Panel</td>
<td>78</td>
</tr>
<tr>
<td>Lesson 3-2: Working with Web Pages in Different Page Views</td>
<td>80</td>
</tr>
<tr>
<td>Lesson 3-3: Using the Folder List</td>
<td>82</td>
</tr>
<tr>
<td>Lesson 3-4: Navigate Web Pages</td>
<td>84</td>
</tr>
<tr>
<td>Lesson 3-5: Printing a Web Page</td>
<td>86</td>
</tr>
<tr>
<td>Lesson 3-6: Displaying a Web Page in a Web Browser</td>
<td>88</td>
</tr>
<tr>
<td>Lesson 3-7: Changing the Title of a Web Page</td>
<td>90</td>
</tr>
<tr>
<td>Chapter Four: Formatting Web Pages</td>
<td>97</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>----</td>
</tr>
<tr>
<td>Lesson 4-1: Using Bold and Italics</td>
<td>98</td>
</tr>
<tr>
<td>Lesson 4-2: Changing Font Type</td>
<td>100</td>
</tr>
<tr>
<td>Lesson 4-3: Changing Font Size</td>
<td>101</td>
</tr>
<tr>
<td>Lesson 4-4: Changing Font Color</td>
<td>102</td>
</tr>
<tr>
<td>Lesson 4-5: Using the Font Dialog Box</td>
<td>103</td>
</tr>
<tr>
<td>Lesson 4-6: Changing Paragraph Alignment</td>
<td>104</td>
</tr>
<tr>
<td>Lesson 4-7: Using the Format Painter</td>
<td>106</td>
</tr>
<tr>
<td>Lesson 4-8: Indenting Text</td>
<td>108</td>
</tr>
<tr>
<td>Lesson 4-9: Creating Bulleted and Numbered Lists</td>
<td>110</td>
</tr>
<tr>
<td>Lesson 4-10: Changing the Background Color</td>
<td>112</td>
</tr>
<tr>
<td>Lesson 4-11: Applying a Theme</td>
<td>114</td>
</tr>
<tr>
<td>Chapter Four Review</td>
<td>116</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter Five: Working with Images</th>
<th>123</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lesson 5-1: Adding an Image from a File</td>
<td>124</td>
</tr>
<tr>
<td>Lesson 5-2: Adding a ClipArt Image</td>
<td>126</td>
</tr>
<tr>
<td>Lesson 5-3: Resize an Image</td>
<td>128</td>
</tr>
<tr>
<td>Lesson 5-4: Moving an Image</td>
<td>129</td>
</tr>
<tr>
<td>Lesson 5-5: Copying an Image</td>
<td>130</td>
</tr>
<tr>
<td>Lesson 5-6: Cropping an Image</td>
<td>131</td>
</tr>
<tr>
<td>Lesson 5-7: Adding a Border to an Image</td>
<td>132</td>
</tr>
<tr>
<td>Lesson 5-8: Aligning an Image with Text</td>
<td>133</td>
</tr>
<tr>
<td>Lesson 5-9: Positioning an Image</td>
<td>134</td>
</tr>
<tr>
<td>Lesson 5-10: Adding a Background Image</td>
<td>136</td>
</tr>
<tr>
<td>Lesson 5-11: Creating a Thumbnail Image</td>
<td>138</td>
</tr>
<tr>
<td>Lesson 5-12: Adding Alternative Text to an Image</td>
<td>139</td>
</tr>
<tr>
<td>Lesson 5-13: Adding a Hyperlink to an Image</td>
<td>140</td>
</tr>
<tr>
<td>Lesson 5-14: Working with Image Hotspots</td>
<td>142</td>
</tr>
<tr>
<td>Lesson 5-15: Changing Image File Formats</td>
<td>144</td>
</tr>
<tr>
<td>Chapter Five Review</td>
<td>146</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter Six: Working with Links and Navigation View</th>
<th>151</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lesson 6-1: Planning a Web Site</td>
<td>152</td>
</tr>
<tr>
<td>Lesson 6-2: Create a Link to Another Page in the Web Site</td>
<td>154</td>
</tr>
<tr>
<td>Lesson 6-3: Create a Link to Another Page on the Internet</td>
<td>156</td>
</tr>
<tr>
<td>Lesson 6-4: Create a Link within a Web Page</td>
<td>158</td>
</tr>
<tr>
<td>Lesson 6-5: Create an E-mail Link</td>
<td>160</td>
</tr>
<tr>
<td>Lesson 6-6: Check a Link in Preview View</td>
<td>162</td>
</tr>
<tr>
<td>Lesson 6-7: Check a Link in Reports View</td>
<td>164</td>
</tr>
<tr>
<td>Lesson 6-8: Remove a Link</td>
<td>165</td>
</tr>
<tr>
<td>Lesson 6-9: Create a Link with a Hover Button</td>
<td>166</td>
</tr>
<tr>
<td>Lesson 6-10: Creating Image Hover Buttons</td>
<td>168</td>
</tr>
<tr>
<td>Lesson 6-11: Previewing Hover Buttons</td>
<td>170</td>
</tr>
<tr>
<td>Lesson 6-12: Using Hyperlinks View</td>
<td>172</td>
</tr>
<tr>
<td>Lesson 6-13: Using Navigation View</td>
<td>173</td>
</tr>
<tr>
<td>Lesson 6-14: Add a Page to a Web Site in Navigation view</td>
<td>174</td>
</tr>
<tr>
<td>Lesson 6-15: Remove a Page from a Web Site in Navigation view</td>
<td>175</td>
</tr>
<tr>
<td>Lesson 6-16: Add Shared Borders</td>
<td>176</td>
</tr>
<tr>
<td>Lesson 6-17: Add Navigation Bars and Change Properties</td>
<td>178</td>
</tr>
<tr>
<td>Chapter Six Review</td>
<td>180</td>
</tr>
</tbody>
</table>

| Chapter Seven: Working with Tables                    | 185 |
Lesson 7-1: Using Tables for Page Layout ................................................................................... 186
Lesson 7-2: Inserting a Table ........................................................................................................188
Lesson 7-3: Modifying Table Properties ......................................................................................190
Lesson 7-4: Modifying Cell Properties .......................................................................................192
Lesson 7-5: Adding or Deleting Rows and Columns ................................................................. 194
Lesson 7-6: Changing Row Height or Column Width ..................................................................196
Lesson 7-7: Merging and Splitting Cells ......................................................................................198
Lesson 7-8: Changing Alignment of Text in a Cell ......................................................................200
Lesson 7-9: Adding an Image to a Table ......................................................................................201
Lesson 7-10: Formatting Cell Spacing .......................................................................................202
Lesson 7-11: Formatting Cell Padding .......................................................................................203
Lesson 7-12: Changing a Table’s Borders ....................................................................................204
Lesson 7-13: Displaying Tables in Pixels or Percent ................................................................. 206
Lesson 7-14: Nesting Tables .......................................................................................................208
Lesson 7-15: Adding a Background Color to a Table ................................................................. 210
Lesson 7-16: Adding a Background Image to a Table .................................................................211
Chapter Seven Review .................................................................................................................212

Chapter Eight: Working with Frames .........................................................................................219
Lesson 8-1: Create Frames ........................................................................................................220
Lesson 8-2: Add Pages to Frames ...............................................................................................221
Lesson 8-3: Create Frame Targets .............................................................................................222
Lesson 8-4: Change Frame Properties .......................................................................................224
Lesson 8-5: Save Frames ...........................................................................................................225
Lesson 8-6: Exit Frames ............................................................................................................226
Chapter Eight Review ..................................................................................................................228

Chapter Nine: Creating Forms ....................................................................................................231
Lesson 9-1: Set Up a Form ..........................................................................................................232
Lesson 9-2: Add a Text Box .......................................................................................................234
Lesson 9-3: Add Check Boxes ..................................................................................................236
Lesson 9-4: Add Radio Buttons .................................................................................................238
Lesson 9-5: Add a Drop-Down Menu .......................................................................................240
Lesson 9-6: Access Form Results ..............................................................................................242
Chapter Nine Review ..................................................................................................................245

Chapter Ten: Formatting with Cascading Style Sheets .............................................................249
Lesson 10-1: Creating and Applying a Custom Style .................................................................250
Lesson 10-2: Applying a Style ..................................................................................................252
Lesson 10-3: Modifying a Style ................................................................................................253
Lesson 10-4: Creating and Linking a Cascading Style Sheet ....................................................254
Lesson 10-5: Redefining HTML Tags Using Styles .................................................................256
Chapter Ten Review ....................................................................................................................258

Chapter Eleven: Manage Web Pages ..........................................................................................261
Lesson 11-1: Add a Task ............................................................................................................262
Lesson 11-2: View and Edit Tasks .............................................................................................264
Lesson 11-3: Start or Delete a Task ...........................................................................................265
Lesson 11-4: Using Reports View .............................................................................................266
Chapter Eleven Review ...............................................................................................................268

Chapter Twelve: Publishing Web Pages ....................................................................................271
Lesson 12-1: Choose a Web Presence Provider ........................................................................272
Lesson 12-2: Pre-publish Task List ...........................................................................................274
Lesson 12-3: Change a Web Site’s Page Options ....................................................................276
Lesson 12-4: Specify Keywords for a Web Page ......................................................................278
Lesson 12-5: Transfer Web Pages to the Web Server ..............................................................279
Lesson 12-6: Promote Your Web Site .............................................................. 280
Chapter Twelve Review .............................................................................. 282

Chapter Thirteen: Using FrontPage Components ........................................ 285
Lesson 13-1: Inserting FrontPage Components ......................................... 286
Lesson 13-2: Understanding Office Web Components ............................. 288
Lesson 13-3: Inserting a Spreadsheet Component ..................................... 290
Lesson 13-4: Using a Component Property Toolbox ................................ 292
Lesson 13-5: Importing Data into a Spreadsheet Component .................. 294
Lesson 13-6: Inserting an Office Chart ...................................................... 296
Lesson 13-7: Inserting a PivotTable ............................................................ 298
Chapter Thirteen Review ........................................................................... 300

Chapter Fourteen: Understanding HTML .................................................. 303
Lesson 14-1: Introduction to HTML ........................................................... 304
Lesson 14-2: Using HTML .......................................................................... 306
Lesson 14-3: Working with Text ................................................................. 308
Lesson 14-4: Working with Paragraphs ..................................................... 310
Lesson 14-5: Working with Lists ............................................................... 312
Lesson 14-6: Working with Images ............................................................ 314
Lesson 14-7: Working with Pages ............................................................. 316
Lesson 14-8: Working with Tables ............................................................. 318
Lesson 14-9: Working with Hyperlinks and Bookmarks ......................... 320
Lesson 14-10: Working with Forms .......................................................... 321
Lesson 14-11: Working with Frames ......................................................... 322
Lesson 14-12: Working with Cascading Style Sheets (CSS) .................... 324

Index ........................................................................................................ 325
Welcome to CustomGuide: Microsoft FrontPage 2000. CustomGuide courseware allows instructors to create and print manuals that contain the specific lessons that best meet their students’ needs. In other words, this book was designed and printed just for you.

Unlike most other computer-training courseware, each CustomGuide manual is uniquely designed to be three books in one:

- Step-by-step instructions make this manual great for use in an instructor-led class or as a self-paced tutorial.
- Detailed descriptions, illustrated diagrams, informative tables, and an index make this manual suitable as a reference guide when you want to learn more about a topic or process.
- The handy Quick Reference box, found on the last page of each lesson, is great for when you need to know how to do something quickly.

CustomGuide manuals are designed both for users who want to learn the basics of the software and those who want to learn more advanced features.

Here’s how a CustomGuide manual is organized:

**Chapters**
Each manual is divided into several chapters. Aren’t sure if you’re ready for a chapter? Look at the prerequisites that appear at the beginning of each chapter. They will tell you what you should know before you start the chapter.

**Lessons**
Each chapter contains several lessons on related topics. Each lesson explains a new skill or topic and contains a step-by-step exercise to give you hands-on-experience.

**Chapter Reviews**
A review is included at the end of each chapter to help you absorb and retain all that you have learned. This review contains a brief recap of everything covered in the chapter’s lessons, a quiz to assess how much you’ve learned (and which lessons you might want to look over again), and a homework assignment where you can put your new skills into practice. If you’re having problems with a homework exercise, you can always refer back to the lessons in the chapter to get help.
How to Use the Lessons

Every topic is presented on two facing pages, so that you can concentrate on the lesson without having to worry about turning the page. Since this is a hands-on course, each lesson contains an exercise with step-by-step instructions for you to follow.

To make learning easier, every exercise follows certain conventions:

- Anything you’re supposed to click, drag, or press appears like this.
- Anything you’re supposed to type appears like this.
- This book never assumes you know where (or what) something is. The first time you’re told to click something, a picture of what you’re supposed to click appears either in the margin next to the step or in the illustrations at the beginning of the lesson.

Tips and traps appear in the margin.

An easy-to-understand introduction explains the task or topic covered in the lesson and what you’ll be doing in the exercise.

Icons and pictures appear in the margin, showing you what to click or look for.

Clear step-by-step instructions guide you through the exercise. Anything you need to click appears like this.

Illustrations show what your screen should look like as you follow the lesson. They also describe controls, dialog boxes, and processes.
• When you see a keyboard instruction like “press <Ctrl> + <B>,” you should press and hold the first key (<Ctrl> in this example) while you press the second key (<B> in this example). Then, after you’ve pressed both keys, you can release them.

• There is usually more than one way to do something in Word. The exercise explains the most common method of doing something, while the alternate methods appear in the margin. Use whatever approach feels most comfortable for you.

• Important terms appear in italics the first time they’re presented.

• Whenever something is especially difficult or can easily go wrong, you’ll see a:

NOTE:
immediately after the step, warning you of pitfalls that you could encounter if you’re not careful.

• Our exclusive Quick Reference box appears at the end of every lesson. You can use it to review the skills you’ve learned in the lesson and as a handy reference—when you need to know how to do something fast and don’t need to step through the sample exercises.

### Formatting a Worksheet

2. Click cell A4 and type **Annual Sales**.  
The numbers in this column should be formatted as currency.

3. Press <Enter> to confirm your entry and overwrite the existing information.

4. Select the cell range G5:G17 and click the **Currency Style** button on the Formatting toolbar.  
A dollar sign and two decimal places are added to the values in the selected cell range.

5. Select the cell range F5:F17 and click the **Percent Style** button on the Formatting toolbar.  
Excel applies percentage style number formatting to the information in the Tax column. Notice there isn’t a decimal place—Excel rounds any decimal places to the nearest whole number. That isn’t suitable here—you want to include a decimal place to accurately show the exact tax rate.

6. With the Tax cell range still selected, click the **Increase Decimal** button on the Formatting toolbar.  
Excel adds one decimal place to the information in the tax rate column. Next, you want to change the date format in the date column. There isn’t a “Format Date” button on the Formatting toolbar, so you will have to format the date column using the Format Cells dialog box. The Formatting toolbar is great for quickly applying the most common formatting options to cells, but it doesn’t offer every available formatting option. To see and/or use every possible character formatting option you have to use the Format Cells dialog box. You can open the Format Cells dialog box by either selecting Format → Cells from the menu or right-clicking and selecting Format Cells from the shortcut menu.

7. With the Date cell range still selected, select Format → Cells from the menu, select 4-Mar-97 from the Type list box and click OK.  
That’s all there is to formatting values—not as difficult as you thought it would be, was it? The following table lists the five buttons on the Formatting toolbar you can use to apply number formatting to the values in your worksheet.

#### Table 4-2: Number Formatting Buttons on the Formatting Toolbar

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency</td>
<td>$1,000.00</td>
<td>Adds a dollar sign, comma, and two decimal places.</td>
</tr>
<tr>
<td>Percent</td>
<td>100%</td>
<td>Displays the value as a percentage with no decimal places.</td>
</tr>
<tr>
<td>Comma</td>
<td>1,000</td>
<td>Separates thousands with a comma.</td>
</tr>
<tr>
<td>Increase Decimal</td>
<td>1000.00</td>
<td>Increases the number of digits after the decimal point by one.</td>
</tr>
<tr>
<td>Decrease Decimal</td>
<td>1000.0</td>
<td>Decreases the number of digits after the decimal point by one.</td>
</tr>
</tbody>
</table>

### Quick Reference

To Apply **Number Formatting**:

- **Type the dollar sign ($) before you enter a number.**

### Tables

Tables provide summaries of the terms, toolbar buttons, or shortcuts covered in the lesson.

### CustomGuide’s exclusive Quick Reference

CustomGuide’s exclusive Quick Reference is great for when you need to know how to do something fast. It also lets you review what you’ve learned in the lesson.
Welcome to your first Microsoft FrontPage 2000 chapter! Microsoft FrontPage is a powerful web-development software program that gives its users the necessary tools to create a website. FrontPage also offers many different customizable templates, which saves you a lot of time.

Microsoft FrontPage is your best bet if you want to quickly create a basic website. According to many reviews, FrontPage is the most user-friendly web-development program available. You have made a great choice by deciding to learn Microsoft FrontPage 2000.

This chapter is an introduction to the FrontPage basics. If you’ve seen the Microsoft FrontPage program before, you already know the screen is filled with cryptic-looking buttons, menus, and icons. By the time you finish this chapter, you will know what many of them mean. Turn the page and let’s get started!
Lesson 1-1: Introduction to FrontPage

Designing a Web site can be a daunting task. If you’ve navigated the World Wide Web before, you’ve probably seen fancy pages with Flash imaging, and links to movies or clips that sometimes require you to download a whole new program to view them. While pages with these features are entertaining, they aren’t necessary to publish information on the Internet.

If you’re just getting into publishing Web sites on the Internet, you’ve made a good choice in starting with FrontPage. FrontPage is a user-friendly program, which makes creating, editing, managing, and publishing Web pages a snap, even for beginners like you! While it doesn’t support as many advanced features as other Web design software (though Microsoft would tell you otherwise), it is possible to design eye-catching Web pages with FrontPage.

Table 1-1: FrontPage Terms and Tasks

<table>
<thead>
<tr>
<th>Term or Task</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit and Format Text</td>
<td>FrontPage is like a simple word processor. You can enter, delete, and move text on the page, and spell check it when you’re through. You can also format text to appear in different font styles, sizes, and colors to emphasize information.</td>
</tr>
<tr>
<td>Forms</td>
<td>Forms allow you to gather information from the people who view your pages. You can use forms to allow users to send questions or feedback, or even to buy products from you online.</td>
</tr>
<tr>
<td>Frames</td>
<td>Frames allow you to separate the Web browser window into several windows. This allows users to view several pages at a time.</td>
</tr>
<tr>
<td>Images</td>
<td>Use images to enhance information on your page, illustrate concepts, or simply to make the page more interesting. FrontPage also offers many ways to enhance an image, such as beveling the image or adjusting its color contrasts. Images can also be used as hyperlinks on a page.</td>
</tr>
<tr>
<td>Term or Task</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Hyperlinks</td>
<td>Hyperlinks are what make Web pages unique. With a simple click of your mouse, you are taken to another page, image, e-mail message, or sound.</td>
</tr>
<tr>
<td>Tables</td>
<td>Tables are wonderful tools for neatly organizing lists of information on a Web page, and are great for defining the placement of text and images on a page.</td>
</tr>
<tr>
<td>WYSIWYG (What You See Is What You Get)</td>
<td>FrontPage is a WYSIWYG editor, which means you don’t have to create your page in HTML (Hypertext Markup Language) format; FrontPage translates it for you. Instead, you can create your page just as you would you see it on the Web, hence the name, What You See Is What You Get.</td>
</tr>
</tbody>
</table>
Lesson 1-2: Introduction to the World Wide Web

If you’re interested in using FrontPage, you’ve probably used the World Wide Web before. But like many Web users, you may not be exactly sure of how the Internet works, let alone know how to build and maintain your own Web site. The diagram above illustrates how this vast network is connected. The table below is an overview of terms frequently used on the Web.

Table 1-2: Frequently Used Internet Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browser</td>
<td>Browsers are Internet computer programs that allow you to navigate through the Internet. The most common Web browsers are Microsoft Internet Explorer and Netscape Navigator.</td>
</tr>
<tr>
<td>FrontPage Server Extensions</td>
<td>FrontPage Server Extensions allow advanced features in FrontPage to work, such as hit counters and scrolling marquees.</td>
</tr>
<tr>
<td>HTML (Hypertext Markup Language)</td>
<td>HTML is the programming language in which every page is written on the Internet. Programs like FrontPage automatically translate your Web pages into HTML so it can be uploaded onto the Internet.</td>
</tr>
<tr>
<td>HTTP (Hypertext Transfer Protocol)</td>
<td>HTTP is the language that is used to transfer and receive files on the Internet.</td>
</tr>
<tr>
<td>Internet</td>
<td>The Internet is a network of computers from all over the world, connected by hardware such as telephone lines, satellites and Digital Subscriber Lines (DSL).</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Search Engine</td>
<td>When you enter the keywords for a search, the search engine contacts all the servers on the Internet for the keywords you enter, and lists them in the search results.</td>
</tr>
<tr>
<td>Servers</td>
<td>Servers are computers that store all of the pages and files in a Web site. Other servers access the server’s information to make it available for others to view.</td>
</tr>
<tr>
<td>URL (Uniform Resource Locator)</td>
<td>A URL is a Web site’s network address. If you enter a Web site’s URL in a browser, you will be taken directly to the Web site.</td>
</tr>
<tr>
<td>World Wide Web</td>
<td>The Web is the part of the Internet that includes all of the files and documents that are available through servers on the Internet. The two main parts of the Web are Web clients and servers, as shown in Figure 1-2.</td>
</tr>
</tbody>
</table>
Lesson 1-3: Starting Microsoft FrontPage

Before starting FrontPage 2000 (some people refer to starting a program as opening or launching), make sure your computer is on. Start FrontPage 2000 the same way you would start any other program on your computer; with the Start button. Every computer can be set up differently (some people like to rearrange and reorder their program menu), so your procedure for starting FrontPage might be different from the one shown here.

1. Make sure your computer is on and the Windows desktop is open.
   Your computer screen should look similar to the one shown in Figure 1-3.

2. Use your mouse to point to and click the Start button, located on the left-hand corner of the Windows taskbar at the bottom of the screen.
   The Windows Start menu pops up.

3. Move your mouse until the cursor points to Programs.
   A menu similar to the one show in Figure 1-4 shoots out from the right side of Programs. The programs and menus listed will depend on the programs installed on your computer, so your menu will probably look somewhat different from the illustration.
4. **On the Programs menu, point to and click Microsoft FrontPage.**

Depending on how many programs are installed on your computer and how they are organized, it might be difficult to find the Microsoft FrontPage program. Once you click on the Microsoft FrontPage program, your computer’s hard drive will whir for a moment while it loads FrontPage. The FrontPage program screen appears, as shown in Figure 1-5.

In the next lesson, you will learn how to apply all of those strange looking buttons, bars, and menus.
Lesson 1-4: Understanding the FrontPage Screen

The FrontPage 2000 program screen may seem confusing and overwhelming the first time you see it. What are all those buttons, icons, menus, and arrows for? This lesson will help you become familiar with the FrontPage program screen. There are no step-by-step instructions for this lesson—all you have to do is look at Figure 1-6 to see what everything you’re looking at represents. This lesson is only meant to help you get acquainted with the FrontPage screen, so relax: you don’t have to memorize anything.
<table>
<thead>
<tr>
<th>Window Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>Displays the name of the program you are currently using (Microsoft FrontPage, of course) and the name of the Web site you are working on. The title bar appears at the top of all Windows programs.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>Displays a list of menus used to give commands to FrontPage. Clicking on a menu name displays a list of commands—for example, clicking the <strong>Format</strong> menu name will display different formatting commands.</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>Toolbars are shortcuts—they contain buttons for the most commonly used commands (instead of wading through several menus). The standard toolbar contains buttons for the FrontPage commands you use the most, such as saving, opening, and printing Web pages.</td>
</tr>
<tr>
<td>Formatting toolbar</td>
<td>Contains buttons for the most commonly used formatting commands, such as bold or italics.</td>
</tr>
<tr>
<td>Web page window</td>
<td>This is where you type in text and work on your Web pages. You can have more than one Web page open at a time in a FrontPage window, but you can't view more than one Web page at a time.</td>
</tr>
<tr>
<td>Web page name</td>
<td>The name of the Web page you are working on appears to the right of the Views bar.</td>
</tr>
<tr>
<td>Insertion point</td>
<td>The small, blinking line is where your typed text appears in the Web page. You can move the insertion point by moving your mouse to a new location in the document window (the pointer should change to ![]) and clicking, or by using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Views bar</td>
<td>The Views bar appears on the left-hand side of the window, and is used to display your Web site in six different views: Page, Folder, Reports, Navigation, Hyperlinks, and Tasks.</td>
</tr>
<tr>
<td>Page view tabs</td>
<td>You can view your page three different ways: Normal, HTML, and Preview.</td>
</tr>
<tr>
<td>Scroll bars</td>
<td>There are both vertical and horizontal scroll bars, and you use them to view and move around your Web page. The scroll box shows where you are in the Web page—for example, if the scroll box is near the top of the scroll bar, you’re at the beginning of a Web page.</td>
</tr>
<tr>
<td>Estimated Download time</td>
<td>Displays the total number of seconds left to download a page to the user’s computer when using a 28.8 Kb/s modem. A faster modem will take less time, and will have a bigger Kb/s number.</td>
</tr>
</tbody>
</table>

Don’t worry if you find some of these elements of the FrontPage program screen confusing at first. They will make sense after you’ve used them.
Lesson 1-5: Using Menus

1. Click the word **File** on the menu bar.
   A menu drops down from the word File, as shown in Figure 1-7. The File menu contains a list of file-related commands, such as New, which creates a new file; Open, which opens or loads a saved file; Save, which saves the currently opened file; and Close, which closes the currently opened file.

2. Click the word **Close** in the File menu.
   The page window disappears because you have just closed the current page. Notice that each of the words in the menu has an underlined letter somewhere in them. For example, the “F” in the File menu is underlined. Holding down the <Alt> key and pressing the underlined letter in a menu is the same as clicking on it. For example, pressing the <Alt> key and then the <F> key would also open the File menu. Move on to the next step and try it for yourself.

3. Press the <Alt> key then press the <F> key.
   The File menu appears. Once you open a menu, you can navigate through the different menus by using either the mouse or the <Alt> key and the letter that is underlined in the menu name, or by using the arrow keys on your keyboard.

4. Press the right arrow key <→>.
   The next menu to the right, the Edit menu, appears. If you open a menu and then change your mind, it is easy to close it without selecting any commands. Click anywhere outside the menu, or press the <Esc> key.

5. Click anywhere outside the menu or press <Esc> to close the menu without issuing any commands.
   Microsoft FrontPage 2000 displays its menu commands on the screen in three different ways:
   - By displaying every command possible.

This lesson explains one of the most common ways to give commands to FrontPage—by using the menus. Menus for all Windows programs can be found at the top of a window, just beneath the program’s title bar. In Figure 1-7, notice the words File, Edit, View, Insert, Format, Tools, Table, Frames, Window, and Help. The next steps will show you what they do.
Chapter One: The Fundamentals

21

Quick Reference

To Open a Menu:
- Click the menu name with the mouse.
- Or...
  - Press <Alt> and then the underlined letter in menu.

To Display a Menu’s Hidden Commands:
- Click the downward-pointing arrow at the bottom of the menu.
- Or...
  - Open the menu and wait a few seconds.

To Change How Menus Work:
1. Select View → Toolbars → Customize → Options tab from the menu.
2. Check or clear either the Menus Show Recently Used Commands First and/or Show Full Menus After a Short Delay options, then click Close.

- By hiding the commands you don’t use as frequently (the more advanced commands) from view.
- By displaying the hidden commands when you click the downward-pointing arrows at the bottom of the menu or after waiting a couple seconds.

NOTE: The procedure for using menus and the general order/layout of the menu is the same for most Windows programs. So once you master FrontPage’s menus, you can handle just about any Windows-based program!

6. **Click the word Tools in the menu bar.**
Some people feel intimidated by so many menu options, so the menus in FrontPage 2000 don’t display the more advanced commands at first. To display a menu’s advanced commands, either click on the downward pointing at the bottom of the menu or keep the menu open a few seconds.

7. **Click the downward-pointing arrow at the bottom of the Tools menu.**
The more advanced commands appear shaded on the Tools menu.
If you’re accustomed to working with earlier versions of Microsoft Office programs, you may find that hiding the more advanced commands is disconcerting. If so, you can easily change how FrontPage’s menus work.

8. **Select View → Toolbars → Customize from the menu and click the Options tab.**
The Customize dialog box appears, as shown in Figure 1-8. This is where you can change how FrontPage’s menus work.

   - **Menus Show Recently Used Commands First:** Clear this check box if you want to show all the commands on the menus, instead of hiding the advanced commands.

   - **Show Full Menus After a Short Delay:** If checked, this option waits a few seconds before displaying the more advanced commands on a menu.

9. **Click Close.**

<table>
<thead>
<tr>
<th>Table 1-4: Menus found in Microsoft FrontPage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
</tr>
<tr>
<td>File</td>
</tr>
<tr>
<td>Edit</td>
</tr>
<tr>
<td>View</td>
</tr>
<tr>
<td>Insert</td>
</tr>
<tr>
<td>Format</td>
</tr>
<tr>
<td>Tools</td>
</tr>
<tr>
<td>Table</td>
</tr>
<tr>
<td>Frames</td>
</tr>
<tr>
<td>Window</td>
</tr>
<tr>
<td>Help</td>
</tr>
</tbody>
</table>
Lesson 1-6: Using Toolbars

In this lesson, we move on to another common ways to give commands to FrontPage, by using toolbars. Toolbars are shortcuts; they contain buttons for the most commonly used commands. Instead of wading through several menus to access a command, you can click a single button on a toolbar.

Two toolbars appear when you start FrontPage by default: the *Standard toolbar* and the *Formatting toolbar*. As you work with FrontPage, you may want to display other toolbars, such as the Drawing toolbar or the Chart toolbar, to help you accomplish your tasks. This lesson explains how to use and manage FrontPage’s toolbars.

1. **Position the mouse pointer over the New Page button on the Standard toolbar (but don’t click on it yet!).**
   A Screen Tip appears over the button briefly identifying what the button is. If you don’t know what a button on a toolbar does, simply move the pointer over it, wait a second, and a ScreenTip will tell you what it does.

2. **Click the New Page button on the Standard toolbar.**
   A new, blank page appears.
   If you find that having both toolbars share the same bar is confusing you can adjust the “squished” appearance of the Standard and Format toolbars to look like Figure 1-9.
3. **Select View → Toolbars → Customize from the menu and click the Options tab.**
   The Customize dialog box appears. This is where you can change how FrontPage’s toolbars are displayed. To stack the Standard and Formatting toolbars, simply uncheck the “Standard and Formatting Toolbars Share Same Row” box.

4. **Click Close.**
   The Customize dialog box closes, and the toolbars are stacked on top of one another. You’ll probably want to work with different toolbars at some point. Here’s how:

5. **Select View → Toolbars from the menu.**
   A list of available toolbars appears, as shown in Figure 1-10. Notice that checkmarks appear next to the Standard and Formatting toolbars. This indicates that the toolbars are already selected and appear on the FrontPage screen.

6. **Select Formatting from the toolbar menu.**
   The Formatting toolbar disappears. You can hide a toolbar if you don’t need to use any of its commands, or if you need to make more room available on the screen to view a Web page.

7. **Select View → Toolbars → Formatting from the menu.**
   The Formatting toolbar reappears. You can also add and remove toolbars by right-clicking anywhere on a toolbar or menu.

8. **Right-click the Standard toolbar or the Formatting toolbar.**
   A shortcut menu appears with the names of available toolbars.

9. **Click Pictures from the Toolbar shortcut menu.**
   The Pictures toolbar appears along the bottom of the FrontPage screen (unless someone has previously moved it). You can view as many toolbars in the window as you want. But remember; toolbars can take up a lot of window viewing space.

10. **Move the pointer to the move handle at the far-left side of the Pictures toolbar. Click and drag the toolbar to the middle of the screen, then release the mouse button.**
    The Pictures toolbar is taken from the bottom of the screen and floats in the middle of the page window. Notice that a title bar appears above the Pictures toolbar. You can move a floating toolbar by clicking its title bar and dragging it to a new position. If you drag a floating toolbar to the edge of the program window, it becomes a docked toolbar and loses its title bar.

11. **Click the Pictures toolbar’s title bar and drag the toolbar down until it docks at the bottom of the screen.**
    The Pictures toolbar is reattached to the bottom of the FrontPage screen. Now get rid of the Pictures toolbar.

12. **Right-click any of the toolbars and select Pictures from the Toolbar shortcut menu.**
    The Pictures toolbar disappears.
Lesson 1-7: Using Hyperlinks

Hyperlinks are everywhere on the Internet. In fact, the Internet wouldn’t be the easy-to-use information tool it is without them. Hyperlinks are great tools for the Web because they put so much information within a click of your mouse. Another reason hyperlinks are popular on the Web they are user-friendly. Hyperlinks stand out on a Web page because they appear as either colored text, or an image, making them very intuitive to use.

How does this electronic “magic” work? When a user clicks on a hyperlink, the hyperlink’s destination is displayed in the Web browser. There are many different things you can connect a hyperlink to: an image, another page, another section within a page, an email message, a file, or even a program. Really, you can create a hyperlink to just about anything that will run on a computer.

This lesson is only a brief overview of ways you can use hyperlinks in your Web pages. You will get a chance to explore hyperlinks more in depth in an upcoming chapter.

Table 1-5: Types of Hyperlinks

<table>
<thead>
<tr>
<th>Hyperlink</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Link</td>
<td>The most common type of hyperlink is probably from page to page. Just click on the hyperlink and another page appears in the Web browser.</td>
</tr>
<tr>
<td>Image Link</td>
<td>Create a link to an image to help illustrate something in your Web page. Usually, it is probably best to just include the image in the Web page.</td>
</tr>
<tr>
<td>Thumbnail Link</td>
<td>Thumbnail links appear as miniature versions of a larger image. Just click on the thumbnail image and the large version of the image appears in the Web browser. This is a great link to use because it decreases the amount of time it takes to download a page.</td>
</tr>
</tbody>
</table>
Quick Reference

• Hyperlinks are important features in Web development. You can create links to a variety of destination types.

<table>
<thead>
<tr>
<th>Hyperlink</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail Link</td>
<td>Create a link to an e-mail message. All users have to do is click on the hyperlinked name or e-mail address, and a new e-mail message appears with the e-mail address already inserted.</td>
</tr>
<tr>
<td>Program File Link</td>
<td>Create a link to a file that opens in the program in which it was created. For example, you could create a link to a Notebook file, and the file would automatically open in the Notebook program.</td>
</tr>
<tr>
<td>Hotspot Link</td>
<td>You can select specific areas of an image to act as hyperlinks. For example, if you had a map image on your Web page, you could create hotspots for countries with corresponding Web pages.</td>
</tr>
<tr>
<td>Bookmark Link</td>
<td>Create a link to jump to a bookmarked section of a page. This type of link is especially useful for long pages.</td>
</tr>
</tbody>
</table>
Lesson 1-8: Keystroke and Right Mouse Button Shortcuts

You are probably starting to realize that there are several different ways to do the same thing in FrontPage. For example, to save a file, you can use the menu (select File → Save) or the toolbar (click the Save button). This lesson introduces you to two more methods of executing commands: keystroke shortcuts, and right mouse button shortcut menus.

The left mouse button is the primary mouse button; you will use it over 95 percent of the time. So what's the right mouse button for? Whenever you right-click something, it brings up a shortcut menu that lists everything you can do to the object. Whenever you're unsure or curious about what you can do with an object, click it with the right mouse button.

Right mouse button shortcut menus are a great way to give commands to FrontPage, because you don’t have to wade through several menu levels when you want to do something.

1. **Click the right mouse button while the cursor is anywhere inside the page window.**

A shortcut menu will appear where you clicked the mouse. Notice that one of the items listed on the shortcut menu is Shared Borders. This is the same Shared Borders command you can select from the menu (Format → Shared Borders). Using the right mouse button shortcut method is slightly faster and usually easier to remember than using FrontPage’s menus. If you open a shortcut menu and then change your mind, you can close it without selecting anything.

2. **Move the mouse button anywhere outside the menu and click the left mouse button to close the shortcut menu.**

Remember that the options listed in the shortcut menu will be different, depending on what or where you right-clicked.

3. **Position the pointer over either the Standard or Formatting toolbar and click the right mouse button.**

A shortcut menu appears listing all the toolbars you can view, as shown in Figure 1-14.
4. **Move the mouse button anywhere outside the menu in the Web page window and click the left mouse button to close the shortcut menu.**

Next, we’ll tackle keystroke shortcuts. Keystroke shortcuts are the fastest way to give commands to FrontPage, even if they are a little hard to remember. They’re great timesavers for issuing common commands.

To issue a keystroke shortcut, press and hold the <Ctrl> key, press the shortcut key, and release both buttons.

5. **Press <Ctrl> + <I> (the Ctrl and I keys must be pressed at the same time).**

   This is the keystroke shortcut for Italics. Note that the Italics button on the Formatting toolbar becomes indented.

6. **Type Italics.**

   The text appears in Italics formatting.

   **NOTE:** Although it’s not discussed in this lesson, FrontPage’s default keystroke shortcuts can be changed or remapped to execute other commands.

---

Table 1-6: **Common Keystroke Shortcuts**

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl&gt; + &lt;B&gt;</td>
<td>Toggles bold font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;I&gt;</td>
<td>Toggles italics font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;U&gt;</td>
<td>Toggles underline font formatting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Spacebar&gt;</td>
<td>Returns the font formatting to the default setting</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;O&gt;</td>
<td>Opens a Web page</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;S&gt;</td>
<td>Saves the current Web page</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;P&gt;</td>
<td>Prints the current Web page to the default printer</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;C&gt;</td>
<td>Copies the selected text or object to the Windows clipboard</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;X&gt;</td>
<td>Cuts the selected text or object from its current location to the Windows clipboard</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;V&gt;</td>
<td>Pastes any copied or cut text or object in the Windows clipboard to the current location</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;Home&gt;</td>
<td>Moves the insertion point to the beginning of the Web page</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;End&gt;</td>
<td>Moves the insertion point to the end of the Web page</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + &lt;&gt;</td>
<td>Shows HTML tags in the page</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

*To Open a Context-Sensitive Shortcut Menu:*  
- Right-click the object.

*To Use a Keystroke Shortcut:*  
- Press <Ctrl> + the letter of the keystroke shortcut you want to execute.
Lesson 1-9: Opening and Closing a Web Page

When you work with FrontPage you will sometimes need to work from a new blank web page. But, more often, you'll want to work on an existing Web page that you or someone else has previously saved. Once you're finished with a page, you'll want to close it so your desktop doesn't get cluttered. This lesson explains how to open, or retrieve a saved page, and how to close a page.

1. **Click the Open button** on the Standard toolbar.
   The Open dialog appears.
2. **Navigate to your Chapter 1 Practice folder and open it.**

Your computer stores information in files and folders, just like you store information in a filing cabinet. To open a file, you must first find and open the folder where it is saved.

The Open and Save dialog boxes both have their own toolbars that make it easy to browse through your computer’s drives and folders. Two controls on this toolbar are particularly helpful:

- **Look In List:** Click to list the drives on your computer and the current folder, the select the drive and/or folder whose contents you want to display.
- **Up One Level button:** Click to move up one folder.

If necessary, follow your instructor’s directions to select the appropriate drive and folder where your practice files are located.

3. **Select the page named Lesson 1 in the dialog box and click Open.**

FrontPage opens the Lesson 1 page and displays it in the window, as shown in Figure 1-16. We don’t really need to work with this page right now though, so let’s get it out of the way and close it.

4. **Click the Close button in the upper right corner of the page to close it.**

The page’s close button is different from the program’s close button. If you’re still not sure which X is the page’s close button, look at Figure 1-16 for clarification.

<table>
<thead>
<tr>
<th>Folder</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>History</td>
<td>Displays a list of files that you’ve recently worked on</td>
</tr>
<tr>
<td>My Documents</td>
<td>Displays all the files in the My Document folder—the default location where Microsoft Office programs saves its files</td>
</tr>
<tr>
<td>Desktop</td>
<td>Temporarily minimizes or hides all your programs so you can see the Windows desktop</td>
</tr>
<tr>
<td>Favorites</td>
<td>Displays a list of your “Favorite” folders, although these are often used to organize your favorite Web pages</td>
</tr>
<tr>
<td>My Network Places</td>
<td>Displays all the files in any Web Folders—special locations to save Web pages</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Open a Page:**

- Click the **Open button** on the Standard toolbar.
- Or…
- Select **File → Open** from the menu.

**To Close a Page:**

- Click the page’s **Close button** in the upper right corner of the page.
- Or…
- Select **File → Close** from the menu.
Lesson 1-10: Getting Help and Using the “What’s This” Button

When you don’t know how to do something in Windows or a Windows based program, just use the Help feature. Whenever you use FrontPage, you can make Help appear by pressing the <F1> key, or by pressing the Help button on the Standard toolbar. This lesson will show you how you can get help by asking Help a question about a FrontPage feature in normal English.

The other topic covered in this lesson is how to use the “What’s This” button. During your journey with FrontPage, you will undoubtedly come across a dialog box or two with a number of confusing controls and options. To help you find out what the various controls and options in a dialog box are for, many dialog boxes contain a “What’s This” button that explains the purpose of each of the dialog box’s controls.

1. Press the <F1> key.
   Help appears and asks you what you would like to do, as shown in Figure 1-17.

2. Delete the text in the “What would you like to do?” area, and type How do I save? in the Answer Wizard, as shown in Figure 1-17.
   You can ask Help questions about FrontPage in normal English, just as if you were asking a person instead of a computer. No, Help doesn’t really understand the English language—computers have a ways to go before they can do that. Help actually looks for key words and phrases in your questions like “save.”
Chapter One: The Fundamentals

3. **Click Search.**
   Help presents you with a list of topics it thinks may be relevant for your question, as shown in Figure 1-18. You have to select the help topic you’re looking for.

4. **Click the Save a page to the current web help topic.**
   FrontPage displays information on how to save to the current web. Depending on what you’re searching for, you may have to sift through several layers of topics to find the answer.

   Notice the Help window has a row of buttons, or toolbars, that look vaguely like some of the buttons you might have seen on a Web browser. Microsoft redesigned the Help system in Office 2000 so that you can navigate through help topics just like you would browse the Web. See Table 1-8: Help Buttons for more information.

5. **Click the Help window’s Close button to close the Help window.**
   The Help window closes. Let’s move on to working with the “What’s This” button.

6. **Select Format → Font from the menu.**
   The Font dialog box appears. Notice the “What’s This” button located in the dialog box’s title bar just to the left of the dialog box’s close button.

7. **Click the “What’s This” button.**
   The mouse pointer changes, indicating that you can point to anything on the dialog box to find out what it does.

8. **Click the Emphasis font check box with the pointer.**
   A brief description of the Emphasis font effect appears, as shown in Figure 1-19.

9. **Close the Font dialog box.**

<table>
<thead>
<tr>
<th>Table 1-8: Help Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
</tr>
<tr>
<td>![button]</td>
</tr>
<tr>
<td>![button]</td>
</tr>
<tr>
<td>![button]</td>
</tr>
<tr>
<td>![button]</td>
</tr>
<tr>
<td>![button]</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Get Help:
1. Press the `<F1>` key, or press the Help button.
2. Type your question in Help’s Answer Wizard and click Search, or press `<Enter>`.
3. Click the help topic that best matches what you’re looking for (repeat this step as necessary).

To See What a Control in a Dialog Box Does:
1. Click the Dialog box ![What’s This button] located right next to the close button.
2. Click the control you want more information on with the ![What’s This? pointer].
Chapter One Review

Lesson Summary

Starting Microsoft FrontPage

- Start FrontPage by clicking the Start button, selecting Programs, and selecting Microsoft FrontPage.

Understanding the FrontPage Screen

- Identify the main components of the FrontPage program screen.

Using Menus

- To Use a Menu: Either click the menu name with the mouse pointer, or press the <Alt> key and the letter that is underlined in the menu name.
- FrontPage 2000’s new personalized menus hide more advanced commands from view. To display a menu’s hidden commands, click the downward-pointing arrow at the bottom of the menu, or open the menu and wait a few seconds.
- To Change How Menus Work: Select View → Toolbars → Customize → Options from the menu, check or clear either the Menus Show Recently Used Commands First and/or Show Full Menus After a Short Delay options, then click Close.

Using Toolbars

- To Use FrontPage’s Toolbars: Simply click the toolbar button you want to use. Leave the pointer over the button to display a screen tip of what the buttons does.
- FrontPage 2000 places the Standard and Formatting toolbars together on the same row. To stack these toolbars on separate rows, select View → Toolbars → Customize → Options tab from the menu, and uncheck the Standard and Formatting Toolbars Share Same Row option.
- To View or Hide a Toolbar: Select View → Toolbars from the menu and select the toolbar you want to display or hide or right-click any toolbar or menu and select the toolbar you want to display or hide from the shortcut menu.
- To Move a Toolbar: Drag its move handle (if the toolbar is docked) or title bar (if the toolbar is floating.)

Using Hyperlinks

- Hyperlinks are important features in Web development. You can create links to a variety of destination types.

Keystroke and Right Mouse Button Shortcuts

- Keystroke shortcuts: Press <Ctrl> and the letter that corresponds to the shortcut command at the same time.
• **Right mouse button shortcut menus:** Whenever you’re unsure or curious about what you can do with an object, click it with the right mouse button to display a menu of commands related to the object.

**Opening and Closing a Page**

• **To Open a Page:** Click the Open button on the Standard toolbar, or select File → Open from the menu, or press <Ctrl> + <O>.

• **To Close a Page:** Click the page’s Close button on the upper right corner of the page, or select File → Close from the menu.

**Saving a Web page**

• **To Save a Web page:** Click the Save button on the Standard toolbar, or select File → Save from the menu, or press <Ctrl> + <S>.

• **To Save a Web page in a New File with a Different Name:** Select File → Save As from the menu, type a new name for the Web page and click Save.

**Getting Help and Using the “What’s This” Button**

• You can ask the Office Assistant (the cute animated character) your questions in conversational English. This is the easiest and most common method of getting help.

• Press <F1> to open Help, type your question in the Answer Wizard in normal English, and click Search.

• **To See what a Control in a Dialog Box Does:** Click the Dialog box “What’s This” button (located right next to the close button) and click the control you want more information on with the “What’s This” pointer.

**Quiz**

1. **Right-clicking something in FrontPage:**
   - A. Deletes the object.
   - B. Opens a shortcut menu listing everything you can do to the object.
   - C. Selects the object.
   - D. Nothing—the right mouse button is there for left-handed people.
2. Normal, HTML, and Preview are different ways to:
   A. Launch FrontPage.
   B. Organize paperclips.
   C. View Web-based movies.
   D. View a page in FrontPage.

3. In FrontPage you can issue commands using: (Select all that apply.)
   A. Menus.
   B. Toolbars.
   C. Keystroke shortcuts.
   D. Right-click shortcut menus.

4. FrontPage is a program that: (Select all that apply.)
   A. Allows you to design and create elaborate first pages of Word documents.
   B. Is used by journalists to design and create newspaper pages.
   C. Is used by high-end, advanced graphic designers and Web masters.
   D. Allows you to design and create Web sites and publish them onto the Internet.

5. To start the FrontPage program:
   A. Click the mouse three times, and say, “There’s no program like FrontPage.”
   B. Click Start → Programs → FrontPage.
   C. Click My Computer → Local Drive (C:) → FrontPage.
   D. Type “FrontPage” in Microsoft Word, and double-click on it to open the program.

6. A Web page is: (Select all that apply.)
   A. A type of Microsoft Word document that can be shared over a network.
   B. A document you can create in Microsoft FrontPage to publish on the Internet.
   C. Part of a Web site.
   D. An ancient cobwebbed manuscript.

7. The Estimated Download time is: (Select all that apply.)
   A. The average amount of time Americans spend waiting for pages to download from the Internet.
   B. The main cause for Road Rage in America.
   C. The amount of time it will take for the page to download onto the user’s computer.
   D. Dependant on the type of modem you use.

8. You want to manually spell check a Web page. You open the Tools menu but can’t find the Spelling and Grammar command. What's wrong?
   A. The Spelling and Grammar command is in the Edit menu, silly!
   B. You need to display all the options in the Tools menu by clicking the downward-pointing arrow at the bottom of the menu.
   C. There isn’t a Spelling and Grammar command.
   D. You need to display all the options in the Tools menu by pressing <F2>.
9. The fastest, easiest way you can get help in FrontPage is by:
   A. Asking Help your question in ordinary English.
   B. Reading the manual that came with the program.
   C. Spending your day on the phone with Microsoft Technical Support.
   D. Taking several classes on FrontPage at your local technical college.

10. What key can you press to get help in any Microsoft Windows-based program?
    A. <F12>.
    B. <Esc>.
    C. <Scroll Lock>.
    D. <F1>.

Homework

1. Start Microsoft FrontPage by clicking the Windows Start button, pointing to Programs and clicking Microsoft FrontPage.

2. Click File → Save to open the Save As dialog box.

3. Find and click the Save button on the Standard toolbar to open the Save As dialog box.

4. Press <Ctrl> + <S> to open the Save As dialog box.

5. Right-click on the page and look at the options on the shortcut menu.


Quiz Answers

1. B. Right-clicking something in FrontPage displays a shortcut menu for the object.

2. D. Normal, HTML, and Preview are different ways to view a page in FrontPage.

3. A, B, C, and D. You can issue commands using menus, toolbars, keystroke shortcuts, and right-click shortcut menus.
4. D. FrontPage is a program that allows you to design and create Web sites and publish them onto the Internet.

5. B. The Start menu contains all your computer’s programs (unless you have placed them elsewhere).

6. B and C. Web pages are parts of Web sites that are published on the Internet.

7. C. The Estimated Download time is the amount of time it will take to download a page onto the user’s computer.

8. B. Click the downward-pointing arrow at the bottom of any menu to display all its options.

9. A. You can ask the Help Answer Wizard questions in everyday English. The other methods require a lot of scrolling, clicking, and searching to find the appropriate help topic.

10. D. The <F1> key brings up help in every Windows program.
Chapter Two: Creating Web Pages and Web Sites

Chapter Objectives:

- Creating a New Web Site with a Template and a Wizard
- Importing Files and Folders
- Importing an Existing Web Site from the Internet
- Creating a Blank Web Page
- Inserting and Deleting Text
- Understanding how FrontPage Saves Web pages
- Saving and Opening a Web Page
- Cutting, Copying, and Pasting Text
- Moving and Copying Text with Drag and Drop
- Finding and Replacing Text
- Working with Paragraphs and Line Breaks
- Inserting Text from a File
- Correcting Your Spelling
- Using Undo, Redo, and Repeat

Chapter Task: Enter text into a Web Page

Prerequisites

- How to start FrontPage
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes
- How to open and save a Web page

Now that you have mastered the Microsoft FrontPage basics, this chapter will show you how to become a sophisticated FrontPage user. This chapter explains how to plan a Web site; how to open and close a page; how to create web sites and pages using templates; how to cut, copy and paste text; how to undo any mistakes you might have made; and how to correct spelling errors.
Lesson 2-1: Creating a Blank Web Page

As with other Microsoft programs, FrontPage automatically opens to a blank web page. But if you’ve been working with the program for a while, you may not want to restart the program just to create a new page. Microsoft has made the task of creating a blank web page easy.

1. **Start Microsoft FrontPage.**
   The program opens to a new page, but let’s learn a few different ways to create a new blank page.

2. **Click the New Page button on the Standard toolbar.**
   A new page appears, as shown in Figure 2-1. Just add pictures and text, and you’ve got yourself web page!
   You can also create a new page under the File menu. This method also offers you a selection of new page templates from which to choose.
   Now try another method of creating a blank Web page.

3. **Select File → New → Page from the menu.**
   A dialog box appears with a list of templates you can use for your new page. If you want to use a template sometime, the next lesson explains them in greater detail. For now, let’s just use a normal page.

4. **Select Normal Page and click OK.**
   The new page appears on your screen, ready to be worked on.
   There is another way to create a blank page in Page view.

5. **Click the New Page button list arrow.**
   A list of items you can create appears:
• Page: Creates a single Web page based on the Normal Page template.

• Web: Creates a new Web site from a template or wizard.

• Folder: Creates a new folder in the folders view.

• Task: Creates a new task and links it to the active or selected page. You can assign a task a name, a person or workgroup, and a priority.

For this lesson we’ll create a new Page.

6. Select **Page** from the list.

A new Web page appears in the window.

Simple enough, don’t you think? Go on to the next lesson, and see the many different page templates you can create in FrontPage.

7. Close the pages without saving changes.
Lesson 2-2: Create a Web Page from a Template

Sometimes you may have a clear idea of how you are going to use a Web page. For these occasions, it might be a good time-saver to use a template. A template is a file that already has some page formatting, so all you have to do is insert the information you want in the page. FrontPage has taken some of the more common uses for Web pages and made templates out of them.

1. **Select File → New → Page from the menu.**
   The New dialog box appears, as shown in Figure 2-2.

2. **Select Guest Book in the dialog box.**
   A preview of the template appears in the dialog box when it is selected.
3. **Click OK.**

   The Guest Book template appears on the page, ready for you to insert your own information into it. Notice that the template includes tips on how to use the page best.

4. **Click the page Close button and do not save changes.**

   If you want to learn more about the page templates FrontPage offers, refer to the table below.

### Table 2-1: FrontPage Web Page Templates

<table>
<thead>
<tr>
<th>Template</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bibliography</td>
<td>A page that makes references to printed or electronic items</td>
</tr>
<tr>
<td>Confirmation Form</td>
<td>A page that acknowledges user input from other pages</td>
</tr>
<tr>
<td>Feedback Form</td>
<td>A page where users can submit comments</td>
</tr>
<tr>
<td>Form Page Wizard</td>
<td>Select the types of information you want to include in the page</td>
</tr>
<tr>
<td>Frequently Asked Questions</td>
<td>A page that answers common questions about a topic</td>
</tr>
<tr>
<td>Guest Book</td>
<td>A page where visitors can leave comments in a guest log</td>
</tr>
<tr>
<td>Narrow, Left-aligned Body</td>
<td>A page with a narrow, left-aligned body</td>
</tr>
<tr>
<td>Narrow, Right-aligned Body</td>
<td>A page with a narrow, right-aligned body</td>
</tr>
<tr>
<td>One-column Body</td>
<td>A page with a centered body</td>
</tr>
<tr>
<td>One-column Body with Contents and Sidebar</td>
<td>A page with a one-column body, contents on the left, and a sidebar on the right</td>
</tr>
<tr>
<td>One-column Body with Contents on Left</td>
<td>A page with a one-column body with contents on the left</td>
</tr>
<tr>
<td>One-column Body with Contents on Right</td>
<td>A page with a one-column body with contents on the right</td>
</tr>
<tr>
<td>One-column Body with Staggered Sidebar</td>
<td>A page with an on-column body and a two-column, staggered sidebar on the left</td>
</tr>
<tr>
<td>One-column Body with Two Sidebars</td>
<td>A page with a staggered sidebar on the left and a sidebar on the right</td>
</tr>
<tr>
<td>One-Column Body with Two-column Sidebar</td>
<td>A page with a one-column body and a two-column sidebar on the right</td>
</tr>
<tr>
<td>Search Page</td>
<td>A page where users can search for keywords across the Web's pages</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>A page with links to every document in the Web</td>
</tr>
<tr>
<td>Three-column Body</td>
<td>A page with a three-column body</td>
</tr>
<tr>
<td>Two-column Body</td>
<td>A page with a two-column body</td>
</tr>
<tr>
<td>Two-column Body with Contents and Sidebar</td>
<td>A page with a two-column body, and contents on the left and a sidebar on the right</td>
</tr>
<tr>
<td>Two-column body with Contents on Left</td>
<td>A page with a two-column body and contents on the left</td>
</tr>
<tr>
<td>Two-column Staggered Body</td>
<td>A page with a body of two staggered columns</td>
</tr>
<tr>
<td>Two-column Staggered body with Contents and Sidebar</td>
<td>A page with a two-column staggered body, contents listed on the left and a sidebar on the right</td>
</tr>
<tr>
<td>User Registration</td>
<td>A page where users can self-register for a protected Web. Only useful in a root Web (&quot;)</td>
</tr>
<tr>
<td>Wide Body with Headings</td>
<td>A page with a wide body and subheadings</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Create a Web Page from a Template:**

1. Select **File → New → Page** from the menu.

   Or...

   Click the **New Page button list arrow** on the Standard toolbar, and select **Page** from the drop-down list.

2. Select the page template from the dialog box, and click **OK.**
Lesson 2-3: Create a New Web Site Using a Template

If you know what kind of information you will display in your web site (and you should before you start), FrontPage’s Web site templates are a good resource. There are several templates to choose from, ranging from a fun, personal site, to a more formal, customer support site. The pages and themes within each template change according to its type. Let’s explore what these options have to offer in this lesson.

1. **Click the New Page button list arrow.**
   A list of items you can create appears. For this lesson we’ll create a new Web site (or Web as they’re called in FrontPage.)

2. **Select Web from the list.**
   The Web Site tab of the New dialog box pops up, displaying the available templates, as shown in Figure 2-4. Click a template to see its description.
   Let’s see what the Personal Web template looks like.

3. **Select Personal Web from the Web site tab.**
   A brief description of the Personal Web template appears in the New dialog box.
Next you need to specify where you want to save your new Web site. Because Web sites usually consist of many different files, the procedure for saving a Web site is very different from saving a file in other programs. Instead of saving a Web site with a single file name you must specify the location of the Web server and/or folder where you want to save the files that will make up your new Web site. For this exercise we will save our new Web site in our Practice folder.

4. **Type c:\practice\firstweb in the Specify the location of the new web box or enter a location as specified by your instructor.**
   
   This will create a folder named “firstweb” that will store all your Web site files. Okay, let’s finish creating our Web site!

5. **Click OK.**

   FrontPage creates a new Web site based on the Personal template in the C:\Practice\firstweb folder.

6. **If necessary, click the Folder List button on the Standard toolbar.**

   A list of all the files in the Web site appears, as shown in Figure 2-5.

7. **Double-click the favorite.htm file in the Folder List.**

   The first page of the web site appears, as shown in Figure 2-5

   That’s all there is to creating a web site using a template! We’ll learn more about how to navigate through your web in different views, and how to develop your pages in later lessons.

8. **Close the page without saving changes.**

### Table 2-2: FrontPage Web Site Templates

<table>
<thead>
<tr>
<th>Template</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One Page Web</td>
<td>Create a new Web site with a single blank page</td>
</tr>
<tr>
<td>Customer Support Web</td>
<td>Create a new Web site to improve customer support services, especially tailored for software companies</td>
</tr>
<tr>
<td>Empty Web</td>
<td>Create a new Web with nothing in it. This template is advantageous for importing Web pages or Web sites.</td>
</tr>
<tr>
<td>Personal Web</td>
<td>Create a new Web with pages for your interests, photos, and favorite Web sites</td>
</tr>
<tr>
<td>Project Web</td>
<td>Keep project progress together with a Web containing a list of members, a schedule, status, an archive and a discussion board</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Create a Web Site Using a Template:**

1. Click the New Page button arrow and select Web.

   Or...

   Select File → New → Web from the menu.

2. Select the template you want to use.

3. Select a location from the Specify the location of the new web box or enter a location if one doesn’t already exist.

4. Click OK.
Lesson 2-4: Creating a New Web Site with a Wizard

Using a Wizard to create your web site is similar to using a template, but it does even more to help you create your web site. The wizard asks a series of questions that give information about your organization. The wizard then takes that information and automatically installs it into the new web site. But before you start, make sure you’ve pre-planned your web site; the wizard asks some pretty detailed questions. Ready to do some magic?

1. **Select File → New → Web from the menu.**

   The Web Site tab of the New dialog box pops up, displaying the available web site wizards. A description of each wizard appears when it is highlighted, as shown in Figure 2-6.

2. **Select the Corporate Presence Web Wizard and click OK.**

   The first dialog box of the wizard appears, as shown in Figure 2-7.
3. Click Next to begin answering the wizard’s questions.
   Answer each question according to your needs and preferences, and click Next to go to
   the next question. You can go back and change an answer by clicking the Back button.

4. Click Finish when you have answered the wizard’s questions.
   The wizard creates the web site for you with the information you entered.

5. Click the web site’s Close button and don’t save your changes.

### Table 2-3: FrontPage Web Site Wizards

<table>
<thead>
<tr>
<th>Wizard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Presence Wizard</td>
<td>Create a professional Internet presence for your corporation</td>
</tr>
<tr>
<td>Discussion Web Wizard</td>
<td>Create a discussion group with threads, a table of contents, and full-text searching</td>
</tr>
<tr>
<td>Import Web Wizard</td>
<td>Create a Web filled with documents on file from your local computer, or from the Internet</td>
</tr>
</tbody>
</table>
Lesson 2-5: Importing Files and Folders

If you're piecing together a web site from a Microsoft Word document, text file, or sites that already exist, this feature can save you a lot of time. All you have to do is tell the wizard where the files or folders you want to use are located, and Voilà! they are transferred to your web site.

1. Select **File → New → Web** from the menu.

The Web Site tab of the New dialog box pops up.

2. Select the **Import Web Wizard** and click **OK**.

The first window, Import Web Wizard – Choose Source appears, as shown in Figure 2-8.

3. Select **From a source directory of files on a local computer or network**, and click **Browse**.

Now you can navigate to the folder you want to import. The Import Web Wizard will only import entire folders at a time, but you can edit the list before to select individual files.

Other Ways to Import a File:
- Select **File → Import** from the menu.
- Click the **Add File** button, and navigate to the file you want to add to your Web site or page.
4. Navigate to your Practice Chapter 2 folder, select the Import web folder, and click OK.
   The second window, Import Web Wizard – Edit File List appears, as shown in Figure 2-9. We don’t need all of these files, however, so let’s delete some of them.

5. Press and hold down the <Ctrl> key, and select Site G3.jpg, templetoapollodelphi.JPG, templetoapollodelphi_smallJPG, and wpe12.jpg.
   Holding down the <Ctrl> key allows you to select several files at once.

6. Click the Exclude button to delete the files, and click Next to go on to the final window.
   The files you selected are deleted.

7. Click Finish to complete the process of importing the files into your web.
   That’s all there is to importing files to your web!
   Importing files can sometimes be a tricky thing because you may not know what each file in a folder is. So, make sure you have a good idea of what all the files in a folder are before you import them into a Web site.

Another Way to Import a Folder:
- Select File → Import from the menu.
- Click the Add Folder button, and navigate to the folder you want to add to your Web site or page.

Quick Reference
To Import an Existing File or Folder:
1. Select File → New → Web from the menu.
2. Select Import Web Wizard and click OK.
3. Specify the folder location of the file(s) or Web you want to import, and click Next.
4. Select unwanted files from the list and click Exclude to delete them. Click Next.
5. Click Finish to import the files into your web.
Or...
1. Click File → Import from the menu.
2. Click the Add File or Add Folder button, and navigate to the file you want to add to your Web site or page.
Lesson 2-6: Importing an Existing Web Page from the Internet

If there is a Web page you know of that you would like to use as a model for your own page, this is a fast and easy way to lay the foundations for a page, and then customize it from there. You also might want to import a Web page that has a lot of information on a topic in your Web site. In this lesson, you will import the Yahoo! home page.

Other Ways to Import a Web page:
- Select File → Import from the menu.
- Click the From Web button, and follow the instructions of the Import Web Wizard.

1. **Select File → New → Web from the menu.**
   The Web Site tab of the New dialog box pops up.
2. **Select the Import Web Wizard and click OK.**
   The first window, Import Web Wizard – Choose Source appears, as shown in Figure 2-8.

   **NOTE:** To import a page from the Web, you need to have an Internet connection.
3. **Select the From a World Wide Web site option**, type **www.yahoo.com** in the Location box, and click **Next**.

   The next window appears, Choose Download Amount.

4. **Type 0 in the levels below box to limit the number of files that will be imported.**

   The levels refer to the page’s links and the files and folders they are attached to, so the number of levels you choose is very important. If you set the number to more than 1 or 2, you could end up importing hundreds of files. For example, if you download a Web page with three images and four hyperlinks (and each hyperlink is linked to a page that has three images and four hyperlinks), and you set the number of levels to 1, you will import 20 files. (Each page has one .htm file, and three image files.) Then, if each of those pages linked to pages with three images and four hyperlinks, and you set the levels to 2, you would import 100 files!

   Therefore, if you only want to import one Web page, set the number of levels to zero. If you want to import more than one page of a Web site, set the number of levels to 1 or more, depending on the size of the site.

5. **Verify that the number of levels is zero, and click OK.**

   The final step of the Import Web Wizard appears. But to import the page from the Web, you need to be connected to the Internet.

6. **Verify that you are connected to the Internet. Click Finish to import the page from the Web.**

   A dialog box appears, indicating the status of downloading the page. When the page is imported, you will be brought back to the FrontPage screen.

7. **Click the Folders button in the Views bar and open the index.htm page.**

   FrontPage automatically names the page index.htm when it is imported to the Web. The index.htm page should appear as shown in Figure 2-12.

   Now you can make changes to the page you imported.

8. **Close the page without saving changes.**
Lesson 2-7: Inserting and Deleting Text

Over the course of developing your web site, you will often discover that you need to make several changes to your text. Perhaps you want to delete or rephrase a sentence. Editing a Web page by inserting and deleting text couldn’t be easier.

1. **Select File → New → Page** from the menu.
   Let’s start fresh with a new page.

2. **Type the paragraph:** Have you always wanted to travel, but don’t know where to begin? Let us take care of all your leisure travel needs. We specialize in subterranean travel, especially termites, roots and power lines. If you’ve been waiting for the trip of a lifetime, North Dakota Travel can be your ticket to a dream!

   Don’t worry about spelling for now, and do not press <Enter> when you reach the end of a line—just keep typing. Notice how your typing automatically starts a new line when it reaches the edge of the computer screen? This feature is called word-wrap. Now that you’ve entered some text, let’s revise it.
3. **Press the Up Arrow Key 🔄 and the Left Arrow Key ← to move the insertion point until it is at the beginning of the paragraph.**

   The insertion point should be just to the left of “Have”.

4. **Type North Shore Travel and press <Enter>.**

   **NOTE:** If you’ve used Microsoft Word, you’ll notice that the Enter key works differently in FrontPage. Here, pressing the Enter key moves the cursor down two lines. Press <Ctrl> + <Enter> at the same time to move the cursor down a single line.

5. **Type We have the tickets to your dreams. and press <Enter>.**

   That looks a little better, doesn’t it? The text doesn’t make much sense though, so it we probably need to do some editing.

6. **Use the mouse to move the insertion point to the end of the first sentence, Have you always wanted to travel, but don’t know where to begin?**

   It’s a little easier to use the mouse than it is to press the keyboard a bunch of times, don’t you think?

7. **Type Are airfares, hotel reservations, and tour offers bringing you down?.**

   You’ve just inserted text into a Web page! Let’s do that a few more times.

8. **Move the insertion point to the end of the sentence We specialize in subterranean travel, especially termites, roots, and power lines.**

   Remember, you can move the insertion point by pressing the arrows on your keyboard, or by moving the I-beam (¶) where you want to place the insertion point and then clicking the left mouse button.

9. **Press the <Backspace> key several times.**

   Pressing <Backspace> deletes one space behind, or to the left, of the insertion point.

10. **Press and hold the <Backspace> key until you have deleted subterranean travel, especially termites, roots, and power lines. Release the <Backspace> key when the sentence is deleted.**

    Great! You’ve learned how to delete text using the Backspace key. Let’s edit this so it makes more sense.

11. **Type We specialize in Mediterranean travel, especially Greece, Egypt, and Italy.**

    That’s better, don’t you think?

    The Delete key also deletes text, but in a slightly different way.

12. **Move the insertion point right before the word Dakota in the last sentence of the paragraph.**

13. **Press the <Delete> key.**

    Pressing <Delete> deletes one space in front, or to the right, of the insertion point.

14. **Press and hold the <Delete> key until you have deleted the word Dakota.**

    Now that you’ve deleted the word “Dakota,” add the word “Shore” so the name of the company is North Shore Travel.

15. **Type Shore.**

   Compare your Web page with the one shown in Figure 2-13.
Lesson 2-8: Understanding How Web Pages are Saved

Saving files is more complex in FrontPage than in most Microsoft programs. For example, if you’ve worked with other Microsoft Word, you know that saving a document with an image is as simple as clicking the Save button on the Standard toolbar. In FrontPage, the process is a little different.

First of all, there are a few conventions you should follow when naming a file:

Figure 2-14
Word saves different pages and pictures in the same, single file.

Figure 2-15
FrontPage saves different pages and pictures in separate files. These related files are usually saved in the same folder.
• **Never use spaces in the file name:** Some servers aren’t able to read spaces in a file name. Therefore, anyone using a server that can’t read spaces won’t be able to view your Web page.

• **Only use characters, numbers, and underscores ( _) in the file name:** Use underscores as an alternative to spaces in your file name.

• **Always use lowercase characters in the file name:** Avoid case-sensitive file names, to ensure their readability across different programs and servers.

There are two main types of files, other than an HTML document, that can be found in a Web site:

**Embedded Files:** The main difference between saving files in FrontPage and other Microsoft programs is that Web pages contain embedded files. *Embedded files* are files that are inserted in a Web page, but are saved as separate files in the Web site folder. So, when you view a page on the Internet that has an image, two files have been downloaded on your computer; the Web page itself, and the image file. To see how this works, look at Figure 2-15 for an illustration of how Web pages are accessed on the Internet.

**Image Files:** The most common type of embedded file is the image file. When an image is inserted into an HTML document (the Web page), the image is saved as a separate file that is embedded into the HTML document. For example, look at the Web page in Figure 2-15. The text and image appear on the same page, but the text and the image are saved separately. This is much different from other programs like Word, where the text and image are saved in the same file, as shown in Figure 2-14.

<table>
<thead>
<tr>
<th>Table 2-4: Common Files Found in a Web Site</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Type</strong></td>
</tr>
<tr>
<td>Web Page</td>
</tr>
<tr>
<td>GIF</td>
</tr>
<tr>
<td>JPEG</td>
</tr>
<tr>
<td>PNG</td>
</tr>
<tr>
<td>Cascading Style Sheet</td>
</tr>
</tbody>
</table>
Lesson 2-9: Saving a Web Page

After you’ve created a page, you need to save it if you intend on ever using it again. Saving a page stores it in a file on your computer’s hard disk—similar to putting a file away in a filing cabinet so you can use it later. Once you have saved a page the first time, it’s a good idea to save it again from time to time as you work on it. You don’t want to lose all your work if the power suddenly goes out or if your computer crashes!

1. If necessary, navigate to your Practice Chapter 2 folder, and open Lesson 2A.
   You’re going to make a change to the page, and then save it under a different file name.

2. Press <Ctrl> + <End> to move the insertion point to the end of the page and type Call 24 hours a day!
   Now save the page.
3. **Click the Save button on the Standard toolbar.**
   The file has saved the changes, so that from now on the text you just typed will appear, unless you change it once again.
   
   **NOTE:** If the page has not been saved yet, the Save As dialog box will automatically appear when the Save button is clicked.
   
   You can also save the page under a different name in the same folder, or a different folder.

4. **Select File → Save As from the menu.**
   The Save As dialog box appears, as shown in Figure 2-16.

5. **In the File name text box, type North Shore Travel.**
   The file will be saved under this file name in the folder. You could also choose to save the file in a different area.

6. **Click the Save in: drop-down list arrow and select Desktop.**
   The file will be saved on the desktop.
   
   When FrontPage is installed, a folder called My Webs is automatically created in the My Documents folder. This is where Web sites will be saved unless you specify another location.

7. **Click the Save button in the Save As dialog box.**
   The North Shore Travel page is now saved on the Desktop under the “North Shore Travel” file name.
   
   **NOTE:** Saving a page with images requires an extra step because image files are saved separately from the page. After clicking Save, another dialog box called “Save Embedded Files” pops up, displaying the picture files that have not yet been saved. Go ahead and click OK to finish saving the page.

---

**Quick Reference**

**To Save a Page:**
- Click the Save button on the Standard toolbar.
  Or...
  - Select File → Save from the menu.
  Or...
  - Press <Ctrl> + <S>.

**To Save a Page in a Different Location:**
- In the Save As dialog box, navigate to the location in the Save In drop-down list.
  - Click Save.
Lesson 2-10: Cutting, Copying, and Pasting Text

Cutting, copying, and pasting text are two of the most common tasks you’re likely to do when you use FrontPage. When you cut text, it’s removed from its original location and is placed in a temporary storage area called the Clipboard. When you copy text, it stays in its original location, but a copy of it is placed on the Clipboard. After cutting or copying text, you can then move the insertion point to a new location in a Web page and paste the cut or copied text from the Clipboard. The Clipboard is available in any Windows program, so you can cut, copy, and paste text between various software programs.

Cut button
Other Ways to Cut:
• Select Edit → Cut from the menu.
• Press <Ctrl> + <X>.

1. Select the text or object you want to cut or copy and click on the Cut or Copy button. If you use Cut, the text or object is removed, or “cut,” from its original location. If you use Copy, the text or object remains in its original location, but a copy is put on the clipboard.

2. Move the insertion point to the location where you want to place the cut or copied text or object.

3. Click the Paste button to paste the cut or copied text or object.

Figure 2-18
The steps involved in cutting, copying, and pasting text

Figure 2-19
The Cut, Copy, and Paste buttons on the Standard toolbar.
1. If necessary, navigate to your Practice Chapter 2 folder and open Lesson 2B.

2. Select the last line Call us 24 hours a day!
   To select text, place the mouse insertion point at the beginning of the sentence, press the right mouse button, and simultaneously hold the button down and move the mouse over the text so it is highlighted, as shown at the top of Figure 2-18. Now cut the text you just selected.

3. Click the Cut button on the Standard toolbar.
   The selected text is cut, or removed, from the Web page and placed in the Windows Clipboard. The Windows clipboard holds any cut or copied text. Once you have cut text from a Web page, you can paste it elsewhere from the clipboard.

4. Move the insertion point to the very beginning of the second line (to the left of the “W” in We have the tickets...).
   This is where you want to paste the previously cut text.

5. Click the Paste button on the Standard toolbar.
   The cut text is cut, or removed, from the Web page and placed in the Windows Clipboard. The Windows clipboard holds any cut or copied text. Once you have cut text from a Web page, you can paste it elsewhere from the clipboard.

6. Select the sentence you just cut and pasted, Call us 24 hours a day!, and click the Copy button on the Standard toolbar.
   Unlike cutting text, copying leaves the selected text in the page, and places a copy of the text on the clipboard.

7. Move the insertion point to the last blank line of the Web page.
   We’re just copying the text back to where it was originally. (Apparently, 24 hours a day is a big deal for North Shore Travel.)

8. Click the Paste button on the Standard toolbar.
   The text, “Call us 24 hours a day!” now appears in two places on the page.

9. Save the Web page by clicking the Save button on the Standard toolbar.
   Cutting, copying, and pasting is a pretty slick feature, isn’t it? Believe it or not, there’s another way to move and copy text, which is the topic for the following lesson.

Quick Reference

To Cut Something:
1. Select the text or object you want to cut.

2. Click the Cut button on the Standard toolbar.
   Or... Select Edit → Cut from the menu.
   Or... Press <Ctrl> + <X>.

To Copy Something:
1. Select the text or object you want to copy.

2. Click the Copy button on the Standard toolbar.
   Or... Select Edit → Copy from the menu.
   Or... Press <Ctrl> + <C>.

Other Way to Paste:
- Select Edit → Paste from the menu.
- Press <Ctrl> + <V>.

Other Ways to Copy:
- Select Edit → Copy from the menu.
- Press <Ctrl> + <C>.
Lesson 2-11: Moving and Copying Text with Drag and Drop

A faster, more advanced method of moving and copying text in FrontPage involves *dragging and dropping*. To drag and drop text, you must: (1) select the text you want to move, (2) click and hold the mouse button over the selected text, (3) while you are still holding down the mouse button, move the mouse until the pointer is over the place you want to place the text, and (4) release the mouse button.

Sound easy? Let’s try it.

Figure 2-20
The steps in moving text by using Drag and Drop

1. Select the text or object you want to move.

2. Click and hold the left mouse button anywhere on the selected text, and drag the changed cursor to where you want to move the text. A light gray insertion point appears to show where the text will be inserted.

3. Release the mouse button.

Figure 2-20

A faster, more advanced method of moving and copying text in FrontPage involves *dragging and dropping*. To drag and drop text, you must: (1) select the text you want to move, (2) click and hold the mouse button over the selected text, (3) while you are still holding down the mouse button, move the mouse until the pointer is over the place you want to place the text, and (4) release the mouse button.

Sound easy? Let’s try it.

1. **Select the entire sentence that begins with We specialize in Mediterranean travel.**
   
   The next three steps are tricky, especially if you’re still new to using a mouse. It might take you several tries before you get it right.

2. **Make sure the pointer is located over the selected text, then press and hold the left mouse button, until the pointer changes from □ to □. Do not release the left mouse button!**
   
   Your Web page should appear similar to the second step in Figure 2-20.

3. **While still holding the left mouse button, drag the pointer down to the very end of the Web page.**
   
   A light gray insertion point will appear to show where the text will be inserted.

4. **Release the mouse button.**
   
   The sentence is moved.

Moving selected text with the drag and drop method takes a lot of dexterity with the mouse, and many people accidentally drop their text in areas where they didn’t intend. If you make a mistake using drag and drop, you can undo your action by clicking the Undo button on the Standard toolbar, or by pressing <Ctrl> + <Z>.

Here’s something else you should know about drag and drop: Holding down the <Ctrl> key while using drag and drop copies the selected text instead of moving it.

---

**Quick Reference**

**To Move Text using Drag and Drop:**

1. Select the text you want to move.
2. Position the pointer anywhere on the selected text and click, and hold the left mouse button.
3. Drag the pointer to where you want to move the selected text, and then release the mouse button.

**To Copy Text using Drag and Drop:**

1. Select the text you want to copy.
2. Position the pointer anywhere on the selected text, and click and hold the left mouse button.
3. Press and hold the <Ctrl> key.
4. Drag the pointer to where you want to move the selected text and then release the mouse button and the <Ctrl> key.
Lesson 2-12: Finding and Replacing Text

Imagine you are working on a very important 50-page report about flying squirrels. You’re almost finished when you realize that you’ve mistakenly referred to flying squirrels not by their proper scientific name “Sciuridae Glaucomys” but by the scientific name of the common gray squirrel “Sciuridae Sciurus.” Yikes! It will take hours to go back and find every instance of “Sciuridae Sciurus” and replace it with “Sciuridae Glaucomys.” On the other hand, you can use FrontPage’s find and replace function, and it will take you less than a minute.

This lesson explains how to find specific words and phrases, and how you can automatically replace words and phrases.

1. Press <Ctrl> + <Home> to move to the beginning, or top, of the Web page.
   You’re going to make one minor change with find and replace; change the word Call to Contact on the page.

2. Select Edit → Find from the menu.
   The Find dialog box opens, as shown in Figure 2-21.
NOTE: If Find or Replace doesn’t show up in the Edit menu, click the expansion arrow at the bottom of the menu to see all the contents of the menu.

3. **In the Find what box, type Call and click the Find Next button.**
   FrontPage looks for the text and highlights it on the page when it is found.
The Replace feature is similar to Find, with an added step; it finds the specified text, and can replace that text with something different. Let’s try it out.

4. **Select Edit → Replace from the menu.**
The Replace dialog box opens, as shown in Figure 2-22.

5. **In the Find what box, type Call. In the Replace with box type Contact. Click Replace All.**
   FrontPage finds all occurrences of the word “Call” in the page and replaces them with the word “Contact.”

   **NOTE:** Think carefully before using the Replace All button—you might not want it to replace every instance of a word! You can find and replace individual occurrences of a word or phrase by clicking the Find Next button, and then clicking the Replace button to replace the text. If you don’t want to change a particular instance, click the Find Next button to leave the text unchanged and move on to the next occurrence.

6. **Click OK.**
The dialog box closes and you’re back at the Replace dialog box.

7. **Click the Close button.**
The Replace dialog box disappears and you’re back to your page. Notice that all occurrences of the word “Call” have been replaced by “Contact.”

Other Ways to Find:
- Press <Ctrl> + <F>.

Other Ways to Replace:
- Press <Ctrl> + <H>.

---

**Quick Reference**

To Find Text:
1. Select Edit → Find from the menu.
   Or...
   Press <Ctrl> + <F>.
2. Type the text you want to find in the Find what box and click the Find Next button.

To Replace Text:
1. Select Edit → Replace from the menu.
   Or...
   Press <Ctrl> + <H>.
2. Type the text you want to find in the Find what box and the text you want to replace it with in the Replace with box.
3. Click Find Next and then Replace to find each occurrence of the text, or click Replace All to replace every occurrence of the text in the Web page at once.
Lesson 2-13: Working with Paragraphs and Line Breaks

If you’re used to working with Microsoft Word, you’ll find that line breaks and spacing between paragraphs is different in FrontPage. The reason for this difference in programming has to do with the HTML (Hypertext Markup Language) of the Web. We’ll talk about actually formatting the paragraphs later in the book, but in this lesson you’ll learn how paragraphs and line breaks work in FrontPage.

First, to understand the difference between line breaks and paragraph breaks, we need to view the format marks to see how the page is broken up.
1. **Click the Show All button on the Standard toolbar.**

   See all those crazy looking tags on the page? They look like something that might belong in a circumference math equation, but they’re really just paragraph marks. They denote the end of a paragraph, where you pressed <Enter> to begin a new paragraph. Also, though these markings show up on the screen, they do not print.

   What if you don’t want to start a new paragraph, but you want to start a new line? Go on to the next step to find out.

2. **Place your insertion point at the beginning of the sentence that begins, If you’ve been waiting for the trip of a lifetime. Press <Shift> + <Enter> to begin the sentence on a new line.**

   See the line break character, as shown in Figure 2-25? This is another non-printing mark.

   So, why can’t you just press <Enter> once, or <Shift> + <Enter> twice? They move the cursor the same number of lines down, right? The difference is that though they are on separate lines, they are still part of the same paragraph. Any paragraph formatting changes you make to the first part of the paragraph will also change the part after the line break. No matter how many line breaks you enter in the page, it will still remain a part of the paragraph.

   Actually, though you may not see a difference on your screen, the change will appear when the page is downloaded. Browsers may download a page differently, depending on the type of computer being used, and its settings.

3. **Select View → Reveal Tags from the menu.**

   The tags mark the beginning of a paragraph and the end of a paragraph, as shown in Figure 2-25. The line break symbol stays the same. This displays a simplified version of HTML.

   This view isn’t very easy to work in, however, so go ahead and un-reveal the tags.

4. **Repeat Step 4 to remove the tags from view, and click the Show All button on the Standard toolbar.**

   Your page is back to normal. If you are ever wondering why your paragraphs are acting a certain way, revealing the tabs is a good way to find more information about them.

---

**Table 2-5: Paragraphs vs. Line Breaks**

<table>
<thead>
<tr>
<th>Type</th>
<th>HTML</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paragraph</td>
<td><code>&lt;p&gt;</code></td>
<td>You can apply separate paragraph formatting to individual paragraphs.</td>
<td>This is the first paragraph.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Paragraphs have space between them.</td>
<td>This is the second paragraph.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Press &lt;Enter&gt; to start a new paragraph.</td>
<td></td>
</tr>
<tr>
<td>Line Break</td>
<td><code>&lt;br&gt;</code></td>
<td>Line breaks let you add a new line of text to the current paragraph. You</td>
<td>This is the first paragraph.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cannot apply paragraph formatting to individual lines separated by line</td>
<td>This is a new line, separated by a line break.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>breaks.</td>
<td>This is the second paragraph.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Lines that are separated by line breaks do not have any space between</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>them.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Press &lt;Shift&gt; + &lt;Enter&gt; to insert a line break.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Display/Hide Hidden Characters (Tabs, Spaces, and Paragraph Marks):
- Click the Show All button on the Standard toolbar.

To Reveal Tags:
- Press <Ctrl> + </>. Or...
- Select View → Reveal Tags from the menu.

To Create a Line Break:
- Press <Shift> + <Enter>.
Lesson 2-14: Inserting Text from a File

When creating Web pages, it’s likely that you will have information on a previously created file that you want to insert into the page. Instead of wasting a lot of time retyping that information, just copy it from the file and paste it onto the page.

This process may seem complex, but it’s really just copying and pasting. In this lesson, you’ll practice inserting text from a file to the Web page you’ve already been working on.

1. Open the WordPad program. Click the Open button on the Standard toolbar. Navigate to your Practice folder, and open the WordPad Global Locations file.

   The Global Locations file opens in the WordPad program window on your screen. To transfer the text in the file to the Web page, all you have to do is Copy and Paste.
2. Select Edit → Select All from the menu to select all the text of the WordPad document. Press <Ctrl> + <C> to Copy the text onto the clipboard.

The text is copied onto the clipboard, ready to be pasted in the FrontPage Web page. Select All is an easy way to highlight an entire document, but sometimes you may only want to insert parts of a document. In these instances, select the text by clicking the left mouse button and drawing your mouse over the text.

3. If necessary, open FrontPage, navigate to your Practice Chapter 2 folder, and open Lesson 2C.

Move the insertion point to where you want it pasted on the page.

4. Place the insertion point at the very bottom of the page, below the sentence that begins We specialize…

This is where we want to insert the text from WordPad. Ready for the final step?

5. Press <Ctrl> + <V> to paste the text onto the Lesson 2C page.

The text is moved from the clipboard to the page. Not too tough, is it?

Other Ways to Select All:

- Press <Ctrl> + <A>.

Quick Reference

To Insert Text from a File:

1. Open the file with the text you want to insert.
2. Select the text you want to insert into your page.
3. Copy the text onto the clipboard.
4. Place the insertion point where you want to insert the copied text in the Web page.
5. Paste the text onto the Web page.
Lesson 2-15: Correcting Your Spelling

In this lesson, you will learn how to use the spell checker. FrontPage is not an advanced word processor like Word, which checks both spelling and grammar. FrontPage only identifies spelling errors, highlighting them with a red underline.

1. If necessary, navigate to your Practice Chapter 2 folder and open Lesson 2D.

First, check the spelling on the page by right-clicking a misspelled word.
2. Click the right mouse button on the red underlined word Luxor, the second misspelled word of the page.

A shortcut menu appears with suggestions for the correct spelling and several other options, as shown in Figure 2-28. “Luxor” isn’t misspelled—Word just can’t find it in its dictionary. There are two things you can do when the spell checker doesn’t recognize a correctly spelled word:

- **Ignore All**: Leaves the spelling as it is, and ignores it throughout the rest of your page.
- **Add**: Adds the word to the spelling dictionary, so that FrontPage won’t nag you about it during spell checks. Use this option for nonstandard words you use often, such as your name.

Since “Luxor” isn’t a spelling error, you can tell FrontPage to ignore it.

3. **Left-click Ignore All on the shortcut menu.**

The squiggly red underline under the word “Luxor” disappears.

The next error in the Web page is the misspelled word “nitelife.”

4. **Right-click the red-underlined missspelled word nitelife and select the correct spelling, nightlife, from the suggestion menu.**

FrontPage makes the spelling correction. That’s the last mistake right? We’d better double-check to make sure. Check your spelling by using the Spell checker.

5. **Select Tools → Spelling from the menu to run the Spell checker.**

The Spelling dialog box appears. The incorrect word “ofices” appears at the very top of the dialog box. We know that’s incorrect, so let’s change it.

6. **Click the Change button to correct the error.**

The spell checker changes the error in the Web page and goes on to the next error it finds, a repeated word, “the”.

7. **Click the Delete button to erase the repeated word.**

This is a common mistake, but it’s one that FrontPage does not underline in red. So, even if there aren’t any words underlined in red, it’s still a good idea to run the spell check!

If you find that those silly squiggly lines are annoying, you can turn them off.

8. **Select Tools → Page Options from the menu and click the General tab.**

The General tab of the Options dialog box appears, as shown in Figure 2-29. Here you can turn off the red squiggles, and you can also change the language FrontPage uses to check your spelling.

9. **Click Cancel to close the Page Options dialog box.**

No doubt about it, FrontPage’s spelling checker is a great tool to assist you in creating accurate pages. It’s important to note, however, that FrontPage will not catch all of your spelling errors. For example, if you mistype the word “hat” when you mean to type “had,” FrontPage won’t catch it because “hat” is a correctly spelled word.
Lesson 2-16: Using Undo and Redo

You may not want to admit this, but you are going to make mistakes using FrontPage. You might accidentally cut something you didn’t really mean to cut, or replace something you didn’t really mean to replace. Fortunately, FrontPage has a wonderful feature called undo that does just that—it undoes any mistakes and actions, as though they never happened. You can almost think of undo as FrontPage’s “time machine” function, because it can take you back to before you even made your mistakes. This lesson explains how you can undo both single and multiple mistakes, and how to redo your actions in case you change your mind.

1. Select the first full sentence on the page, Call us 24 hours a day!, then press the <Delete> key to erase the sentence.

   The sentence disappears. Oops! You didn’t really want to erase that! Watch how you can undo your “mistake.”

2. Click the Undo button on the Standard toolbar.

   Poof! The deleted text “Call us 24 hours a day!” is back again. Hmmmm… maybe you did want to delete that sentence after all. Anything that can be undone can be redone in case you change your mind about something, or want to “undo an undo.” Try redoing the text deletion.
Chapter Two: Creating Web Pages and Web Sites

3. **Click the Redo button on the Standard toolbar.**
   
The sentence “Call us 24 hours a day!” is deleted again.

   If you’re like most people, you will probably make not one, but several mistakes and it may be a minute or two before you’ve even realized you’ve made them. Fortunately, the programmers at Microsoft thought of us when they developed FrontPage, because the undo feature is actually multileveled—meaning you can undo any of the previous things you did.

4. **Select the word dreams in the line We have the tickets to your dreams. Type plane to replace the word dreams.**
   
   There’s your second mistake (the first mistake was deleting the “Call us 24 hours a day!” text).

5. **Select Edit → Replace from the menu.**
   
   The Replace dialog box appears.

6. **Type Shore in the Find what: text box, press the <Tab> key to move to the Replace with: text box, type Dakota and click Replace All.**
   
   Every occurrence of the word “Shore” in the Web page is replaced with the word “Dakota”. Mistake number three.

7. **Change the number of hours in the line Call us 24 hours a day! to 12.**
   
   Mistake number four. Now you’ve made enough mistakes now to see how multilevel undo works. Try undoing all of your mistakes.

8. **Click the downward pointing arrow to the right of the undo button.**
   
   A list of recent actions in FrontPage appears immediately beneath the Undo button. Notice there are more actions listed than your four recent “mistakes.” If you wanted, you could undo everything in this Web page you have worked on today, but you don’t want to do that. Just undo the last four mistakes.

9. **Select the first four items from the Undo list.**
   
   The last four changes we made to our Web page—deleting the first line of text, replacing some words, and changing the time—are all undone. Actually, the number of calling hours is 24, so go ahead and redo that change.

10. **Click the Redo button on the Standard toolbar.**

    The 12 changes back to 24 hours.

Besides correcting mistakes, undo and redo allows you to experiment with your Web pages by making changes and then undoing them if you decide you don’t like the changes.
Chapter Two Review

Lesson Summary

Creating a Blank Web Page
• To Create a New Page: Use one of the following methods.
  (1) Click the New Page button on the Standard toolbar.
  (2) Select File → New → Page from the menu.
  (3) Press <Ctrl> + <N>.

Creating a New Web Page with a Template
• Click File → New → Web, or click the New Page button list arrow on the Standard toolbar, and select Page from the drop-down list. Then select on the template you want to use from the dialog box, and click OK.

Creating a New Web Site Using a Template
• Click the New Page button arrow and select Web, or select File → New → Web from the menu. Select the template you want to use. Select a location from the Specify the location of the new web box or enter a location if one doesn’t already exist and click OK.

Creating a New Web Site with a Wizard
• Click File → New → Web. Click on the wizard you want to use, and click OK. Answer the wizard’s questions according to your preferences, and click Next after each question. Click Finish when you have answered all of the wizard’s questions.

Importing a File or Folder
• To Import a File: Click File → New → Web, select Import Web Wizard, and click OK; or click File → Import, and click the Add File button. Specify the location of the file you want to import, and click Next. Select unwanted files from the folder list, click Exclude to delete them, and click Next. Click Finish to import the files into your web.

Importing an Existing Web Site from the Internet
• Click File → New → Web, select Import Web Wizard, and click OK. Select the From a World Wide Web site option, type the URL in the Location box, and click Next. Type 0 (zero) in the levels below box, and click OK. Verify that you are connected to the Internet and click Finish to import the page from the Web. Or, select File → Import from the menu, click the From Web button, and follow the instructions of the Import Web Wizard.
Inserting and Deleting Text

- To Move the Insertion Point: Use the arrow keys. Or move the I-beam pointer where you want with the mouse, and then left-click click the mouse.
- To Insert Text: Move the insertion point where you want to insert the text, and then type the text you want to insert.
- To Delete Text: Use the <Backspace> key to delete text before, or to the left of, the insertion point. Or, use the <Delete> key to delete text after, or to the right of, the insertion point.

Understanding How Web Pages are Saved

- Web pages consist of HTML documents that have files embedded within them, such as image files. Web pages and their embedded files are saved separately within the Web site folder.

Saving a Page

- To Save a Page: Use one of the following methods:
  1. Click the Save button on the Standard toolbar.
  2. Click File → Save from the menu.
  3. Press <Ctrl> + <S>.
- To Save a Page in a Different Location: In the Save As dialog box, navigate to the location in the Save In drop-down list and click Save.

Cutting, Copying, and Pasting Text

- To Cut Something: Select the text and cut it using one of the following methods:
  1. Click the Cut button on the Standard toolbar.
  2. Select Edit → Cut from the menu.
  3. Press <Ctrl> + <X>.
- To Copy Something: Select the text and copy it using one of the following methods:
  1. Click the Copy button on the Standard toolbar.
  2. Select Edit → Copy from the menu.
  3. Press <Ctrl> + <C>.
- To Paste a Cut or Copied Object: Place the insertion point where you want to paste the text or object, and use one of the following methods to paste it:
  1. Click the Paste button on the Standard toolbar.
  2. Select Edit → Paste from the menu.

Moving and Copying Text with Drag and Drop

- Select the text you want to move, and then drag the selected text to where you want to move it. Release the mouse button to drop the text.

Finding and Replacing Text

- To Find Text: Select Edit → Find from the menu, type the text you want to find in the Find what box and click the Find Next button.
- To Replace Text: Select Edit → Replace from the menu, type the text you want to find in the Find what box and the text you want to replace it with in the Replace with box. Click either Find Next and then Replace to find each occurrence of the text, or else Replace All to replace every occurrence of the text in the Web page at once.
Working with Paragraphs and Line Breaks

- **To Reveal Tags:** Press `<Ctrl> + /`, or click View → Reveal Tags.
- **To Create a Line Break:** Press `<Shift> + <Enter>`.

Inserting Text from a File

- Open the file with the text you want to insert, copy the text, place the insertion point where you want to insert the text, and paste the text from the clipboard to the Web page.

Correcting Your Spelling

- FrontPage automatically underlines spelling errors with red.
- Right-click a spelling error to bring up a shortcut menu with suggestions for spelling corrections for the error.
- Add words to the spelling dictionary by right-clicking the red underlined word you want to add and selecting Add from the shortcut suggestion menu.
- Ignore spelling errors by clicking the red underlined word and selecting Ignore All from the shortcut suggestion menu.

Using Undo and Redo

- **To Undo:** Click the Undo button on the Standard toolbar, or select Edit → Undo from the menu, or press `<Ctrl> + <Z>`.
- **To Redo:** Click the Redo button on the Standard toolbar, or select Edit → Redo from the menu, or press `<Ctrl> + <Y>`.
- **Multilevel Undo/Redo:** Click the down arrows on the Undo or Redo buttons on the Standard toolbar to undo or redo several actions at once.

Quiz

1. When planning a web site, it is a good idea to make the pages more interesting by applying different background colors to all of them. (True or False?)

2. What is one way to save time when creating a Web site? (Select all that apply.)
   - A. Use a Web site Template.
   - B. Use a Web site Magician.
   - C. Use a Web site Wizard.
   - D. Import an existing Web site.

3. What keystroke combination starts a new line in a paragraph?
   - A. `<Alt> + <A>`.
   - B. `<Shift> + <Enter>`.
   - C. `<Ctrl> + <A>`.
   - D. `<Ctrl> + <L>`.
4. The Backspace key deletes text to the left of (or behind) the insertion point. (True or False?)

5. To view a list of suggestions for a misspelled word:
   A. Select the misspelled word and select Tools → Suggestions from the menu.
   B. Press <Ctrl> + <S>.
   C. Select the misspelled word and click the Spelling Suggestion button on the Standard toolbar.
   D. Right-click the misspelled word.

6. You've accidentally deleted the paragraph you just completed. How can you retrieve the lost text?
   A. Select Help and send Rover the Search Companion to find the text on your computer.
   B. Click the Undo button on the Standard toolbar.
   C. Go to Preview view to catch it before it is deleted from all three views.
   D. You can’t do anything about it.

7. You're designing your home page, and you want people to be impressed with your vocabulary. How can you easily replace every instance of the word “speedy” with “rakish”?
   A. Select Edit → Replace from the menu, type “speedy” in the Find what box, type “rakish” in the Replace with box and click Replace All.
   B. There isn’t any easy way – you’ll have to go through your novel and replace the words yourself.
   C. Click the Find and Replace button on the Standard toolbar, then follow the Find and Replace Wizard’s on-screen instructions to replace the word.
   D. Select Tools → Replace from the menu, type “speedy” in the Find what box, type “rakish” in the Replace with box and click Replace All.

8. Which of the following is not a command to cut text or graphics?
   A. Click the Cut button on the Standard toolbar.
   B. Press <Ctrl> + <C>.
   C. Press <Ctrl> + <X>.
   D. Select Edit → Cut from the menu.

9. How can you create a blank new page? (Select all that apply.)
   A. Select File → New → Page from the menu, select a template from the dialog box, and click OK.
   B. Press <Ctrl> + <N>.
   C. Click the New Page button on the standard toolbar.
   D. Select the entire page you’re working on and delete its contents.

10. Which of the following statements is NOT true?
    A. You can add your own words to the spelling dictionary by right-clicking the unrecognized word and selecting Add from the shortcut menu.
    B. To find a word or phrase in a Web page, select Edit → Find from the menu.
    C. The Undo function can only undo one action—the last one that you performed.
    D. Pressing <Enter> is different from pressing <Shift> + <Enter> two times.
11. Why would you use the **Save As** option in the File menu instead of the **Save** option?

A. To save a file under a new name and/or location.
B. To send someone an e-mail of a file.
C. To save time.
D. To specify if FrontPage should always create a backup copy of a file.

12. You can only move or copy text by using the Copy, Cut, and Paste buttons. (True or False?)

**Homework**

1. Start Microsoft FrontPage by clicking the Windows Start button, pointing to Programs, and clicking Microsoft FrontPage.

2. Click the Open button on the Standard toolbar. Navigate to your Practice folder with the Look in list, select the Homework 2 file, and click OK.

3. Select and cut the first paragraph.

4. Place the insertion point above the last paragraph mission statement line, and paste the text by clicking the Paste button on the Standard toolbar, or by pressing <Ctrl> + <V>.

5. Correct any spelling errors by clicking **Tools** → Spelling. Add the words pom and Pomorama! to the dictionary.

6. Select the Mission Statement near the end of the page, and drag and drop it below the first paragraph.

7. Select **Edit** → **Replace** from the menu, type “75” in the Find box, type “35” in the Replace with box, and click Replace to change the number of years Pomorama! has been in existence.

8. Select the last line, “Thanks for choosing Pomorama!” and press the delete key.

9. Click the **Undo** button on the Standard toolbar.

10. Click the **Save** button on the Standard toolbar to save your changes, and exit Microsoft FrontPage.
Quiz Answers

1. False. A Web site that is inconsistent in how it looks is confusing and frustrating to readers.

2. A, B, and C. These are all ways to save time when creating a Web site.

3. B. Press <Shift> + <Enter> to begin a new line in a paragraph.

4. True. The Backspace key deletes text to the left of (or behind) the insertion point. The Delete key deletes text to the right of (or before) the insertion point.

5. B. Right-click the misspelled word to view a list of suggestions.

6. B. Click the Undo button on the Standard toolbar to retrieve deleted text.

7. A. Select Edit → Replace from the menu, type “speedy” in the Find what box, type “rakish” in the Replace with box, and click Replace All.

8. B. <Ctrl> + <C> copies selected text or graphics, <Ctrl> + <X> cuts selected text or graphics.

9. A, B, and C. These are all ways to create a new blank page.

10. C. The Undo function can undo almost all of your actions.

11. A. You would use the Save As option in the File menu to save the file under a new name and/or location.

12. False. You can move and copy text by using the drag and drop method.
# Chapter Three: Working with Web Pages

<table>
<thead>
<tr>
<th>Chapter Objectives:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Working with Web Pages in Different Views</td>
</tr>
<tr>
<td>• Hiding and Displaying the Folder List</td>
</tr>
<tr>
<td>• Navigate and Print Web Pages</td>
</tr>
<tr>
<td>• Displaying a Web Page in a Web Browser</td>
</tr>
<tr>
<td>• Changing the Title of a Web Page</td>
</tr>
<tr>
<td>• Renaming and Deleting Web Page</td>
</tr>
</tbody>
</table>

**Chapter Task:** Work with a page in different views

---

If you have had a lot of experience using Microsoft programs, there are some elements in FrontPage that will be familiar, and others that won’t be familiar. This chapter will teach you how to use these different elements, including how to display web pages on web browsers, and how to title and rename a web page. This chapter shouldn’t take long, and by becoming familiar with these different views and basic page properties, you will be more efficient in using FrontPage.

<table>
<thead>
<tr>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Windows basics: working with the mouse, menus, and dialog boxes</td>
</tr>
<tr>
<td>• How to open and save a document</td>
</tr>
<tr>
<td>• How to select text</td>
</tr>
</tbody>
</table>
Lesson 3-1: Working with the Views Panel

The Views panel is a permanent fixture on the left side of the FrontPage window. The panel is a resourceful tool for your entire Web site, because the available views offer information on almost every aspect of your Web site. The best way to understand each of these views is to actually see them however, so go ahead and start the lesson.

1. Navigate to your Practice Chapter 3 folder and open the North Shore Travel Web site. Select the Greece page and click the Open button. The default view is Page view. Page view allows you to work with and edit the open Web page. The rest of the views in the views panel work with the entire Web site. Let’s work our way through all the views in the panel.

2. Click the Folders button in the Views panel. The window displays detailed information about all the folders and files in the Web site, such as each file’s name, when it was last modified, and the size of the file.

3. Click the Reports button in the Views panel. The window displays a Site Summary report, which includes information on various elements in the Web site, such as the number of images and hyperlinks in the Web site. The Reports view is helpful because it automatically compiles information for you. There are also a number of different types of reports you can choose from.

4. Click the Report drop-down list button on the Reporting toolbar. A list of all the reports you can view appears.

5. Scroll down the list and select the Slow Pages option. A list of all the pages that match the “slow” criteria appear in the window.
Chapter Three: Working with Web Pages

6. **Click the Navigation button in the Views panel.**
   The window displays how all the Web pages in the Web site are organized.

7. **Click the Hyperlinks button in the Views panel, and click an image file in the Folder List.**
   The window displays the image file, and the Web page it is linked to.

8. **Click the Tasks button in the Views panel.**
   The window displays a list of tasks that need to be finished on the Web site.
   Let’s end the lesson in Page view.

9. **Click the Page button in the Views panel.**
   That’s all there is to changing views in FrontPage. You will work more with these views later in the chapter, but at least you have an idea of the purpose for each view.
   Refer to Table 3-1: Buttons in the Views Panel for more information on how to use FrontPage’s views.

### Table 3-1: Buttons in the Views Panel

<table>
<thead>
<tr>
<th>Button/View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>Page view allows you to edit and change the contents of a selected Web page. You will probably work most often in this view.</td>
</tr>
<tr>
<td>Folders</td>
<td>Folders view displays details on all the files in the Web site. Folders view is good to use if you need to find out specific information on a file.</td>
</tr>
<tr>
<td>Reports</td>
<td>Reports view compiles reports on the contents of the Web site. Reports view is helpful for finding specific information, such as how many broken hyperlinks there are in the Web site.</td>
</tr>
<tr>
<td>Hyperlinks</td>
<td>Hyperlinks view shows how pages and images are linked to one another. This is useful for checking on whether you have inserted all the links you want.</td>
</tr>
<tr>
<td>Tasks</td>
<td>Tasks view lists all the tasks that must be completed in a Web site. This view is helpful for keeping track of how much work is completed, and how much work is left on the Web site.</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Use the Views Panel:

1. Click the button of the view you want to use in the Views Panel.
Lesson 3-2: Working with Web Pages in Different Page Views

Page view is probably the view you will use most often while working with your Web pages in FrontPage. In fact, you will use it so much that Microsoft has installed different views within Page view: Normal, HTML, and Preview. Normal view is where you will add to and make changes to your page, but the other two views show different parts of the page that can really help you with design.
This lesson might seem intimidating, but its purpose is to help you understand how Web pages work.

1. **If necessary, navigate to your Practice Chapter 3 folder and open the North Shore Travel Web site. Select the Greece page and click the Open button.**

   The lesson opens to Normal view by default. Normal view is the WYSIWYG (What You See Is What You Get) editor, so whatever you add to the Web page in this view is how close to how it will appear on the World Wide Web.

   See the view tabs on the bottom left corner of the page window? That’s what you’ll be exploring in this lesson.

2. **Click the HTML tab.**

   Yikes! What is all that stuff on the page? This is HTML (Hypertext Markup Language), the programming language that all pages must be translated into before they are published on the Internet. If HTML is completely foreign to you, this view might be a bit overwhelming.

   **NOTE:** As you enter your information in Normal view, FrontPage automatically writes the HTML code for the page.

3. **Click the Preview tab.**

   That looks a little better. This view is the closest you’ll get to viewing the page as it will appear on the Internet, without actually uploading it onto the Internet. Look closely at the page, because there may be a few spacing differences between the Normal and Preview views.

   **NOTE:** To view the page in Preview, you must have Microsoft Internet Explorer Web browser installed on your computer.

### Table 3-2: Page Views in FrontPage

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Normal view allows you to edit the Web page in WYSIWYG (What You See Is What You Get) mode.</td>
</tr>
<tr>
<td>HTML</td>
<td>HTML view allows you to edit the Web page directly in HTML code.</td>
</tr>
<tr>
<td>Preview</td>
<td>Preview view allows you to see the Web page as it would appear in a Web browser.</td>
</tr>
</tbody>
</table>
Lesson 3-3: Using the Folder List

Figure 3-5
The Greece page with the Folder List displayed

Figure 3-6
The Greece page without the Folder List

The Folder List appears on your screen automatically when you create a Web site, displaying all the pages and folders in the site. While it’s a good way to find out what’s in your site, the Folder List is something you might not always want to view, since it takes up valuable screen space.

This lesson will give you a brief overview of how to hide or display the Folder List, and how to open pages with the Folders List.
1. **With the Greece page open, click the Folder List button on the Standard toolbar.**

   The Folder List appears just to the left of the page window, as shown in Figure 3-5. All the folders and pages in your Web site are displayed here.

2. **Click the Folder List button to hide the list.**

   The Folder List disappears.

   Notice that there is much more room to work with the Web page when the Folder List is hidden. For this reason, you will probably not show the Folder List all the time. The Folder List is a valuable tool to use when you want to open a different page in the Web site, however.

3. **Click the Folder List button on the Standard toolbar.**

   The Folder List appears once again. Now open a different Web page from the Folder List.

4. **Double-click the Italy.htm page in the Folder List.**

   The Italy page opens in the window.

   Notice that the icons in the Folder List for the Italy.htm page and the Greece.htm page have pens on them, unlike the other Web pages in the site. This indicates that both of these pages are open.

5. **Select File → Close from the menu to close the Italy page, without saving changes.**

   The Greece page appears in the window once again.

   That’s all there is to using the Folder List. As you develop your Web site, you’ll find that the Folder List is a tool you will use often.

---

**Quick Reference**

**To Hide or Display the Folder List:**

- Click the Folder List button on the Standard toolbar.

  Or...

- Click the Folders button in the View Pane.

  Or...

- Select View → Folders from the menu.
Lesson 3-4: Navigate Web Pages

Web pages generally shouldn’t be more than two or three page-lengths long, so it’s not that difficult to navigate through them. The simple use of the scroll bars will get you where you need to go in a page. The vertical scroll bar is located along the right side of the window and is used to move up and down in a document. The horizontal scroll bar is located along the bottom of the window, and is used to move from left to right when a document doesn’t fit entirely on the screen. Figure 3-7 shows both of these scroll bars.

1. **Click the down arrow on the bottom of the vertical scroll bar several times.**
   When you click the arrow, the screen scrolls down one line at a time.

2. **Click and hold the down arrow on the bottom of the vertical scroll bar.**
   This causes the screen to move downward more rapidly.

3. **Click and drag the vertical scroll box to the top of the scroll bar.**
   This takes you back to the beginning of the document.

4. **Press the `<End>` key.**
   The insertion point moves to the end of the current line.

5. **Press the `<Home>` key.**
   The insertion point moves to the beginning of the current line.

6. **Press `<Ctrl>` + `<End>` to move to the end of the document.**
   The insertion point moves to the end of the document. Notice that the vertical scroll box appears near the end of the scroll bar, indicating your position in the page. You can also find your position in a page by looking at the status bar at the bottom of the screen—it states the page you’re currently on.
7. Press <Page Up> to move up one screen.

8. Press <Page Down> to move down one screen.

9. Press <Ctrl> + <Home> to move to the beginning of the document.

Using the keystrokes is faster than sifting through menus, don’t you think?

<table>
<thead>
<tr>
<th>Press</th>
<th>To Move</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Start of line</td>
</tr>
<tr>
<td>End</td>
<td>End of line</td>
</tr>
<tr>
<td>Page Up</td>
<td>Up one screen</td>
</tr>
<tr>
<td>Page Down</td>
<td>Down one screen</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + Home</td>
<td>To the beginning of the page</td>
</tr>
<tr>
<td>&lt;Ctrl&gt; + End</td>
<td>To the end of the page</td>
</tr>
</tbody>
</table>

Quick Reference

To Move to the Beginning or Ending of a Line:
- Press <Home> to move to the beginning of a line.
- Press <End> to move to the end of a line.

To Move Up or Down One Screen:
- Press <Page Up> to move up one screen.
- Press <Page Down> to move down one screen.

To Move to the Beginning or End of a Page:
- Press <Ctrl> + <Home> to move to the beginning of the document.
- Press <Ctrl> + <End> to move to the end of the document.
Lesson 3-5: Printing a Web Page

Part of the appeal of Web pages is that they’re electronic, so you don’t have to waste a bunch of paper to use them. Over the course of time, however, you may find that you want to print a page. Seeing a page on paper is good for proofreading spelling and grammar, and as a preview of how the page will look on the Web.

1. **Select File → Print from the menu.**
   The Print dialog box appears on the screen. Here, you can specify which pages to print, how many copies, and which printer to use, as shown in Figure 3-9. See Table 3-4: Print Options for more information. Choose to see more options with the Properties button.

2. **Click Properties. Select the Flip on Long Edge option to print on both sides of the paper.**
   Since the Web page isn’t long enough to need two sides of paper, click Cancel to print on one side.
3. Click **Cancel** to return to the Print dialog box. Click **OK** to send the page to the printer.

### Table 3-4: Print Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Portrait</td>
<td>Orient the print vertically.</td>
</tr>
<tr>
<td>Landscape</td>
<td>Orient the print horizontally.</td>
</tr>
<tr>
<td>Rotated Landscape</td>
<td>Rotates the paper 90 degrees counterclockwise.</td>
</tr>
<tr>
<td>None</td>
<td>Prints on only one side of the paper.</td>
</tr>
<tr>
<td>Flip on Long Edge</td>
<td>Prints pages so that they read like a book.</td>
</tr>
<tr>
<td>Flip on Short Edge</td>
<td>Prints pages so that they read by flipping over, like a notepad.</td>
</tr>
</tbody>
</table>
Lesson 3-6: Displaying a Web Page in a Web Browser

An earlier lesson in this chapter explained how to use the Preview tab to view your pages as they would appear on the web. It is better to view the page in a Web browser, however, because users are going to be viewing the pages in a browser, not in FrontPage.

1. If necessary, navigate to your Practice Chapter 3 folder, open the North Shore Travel web, and open the Greece page.

2. Click the Preview in Browser button on the Standard toolbar.

The browser opens the Greece page.

**NOTE:** If you have more than one browser installed on your computer, a dialog box will appear asking which browser you would like to use to preview the page. Click on the browser and click Preview.
3. **The Web browser displays the page as it would appear on the Web, as shown in Figure 3-12.**

This is what your page will look like to anyone who views it using Microsoft Internet Explorer. However, Microsoft Internet Explorer is not the only web browser, so it would be wise to view your page with as many different browsers as possible. The most popular ones are Microsoft Internet Explorer and Netscape Navigator.

4. **Close the Web browser window to return to FrontPage.**

As with most areas of computer technology, Microsoft has managed to monopolize the Internet. Most computers have Microsoft Internet Explorer already installed on them, so most people use Explorer as their browser. Unfortunately, Microsoft has set up FrontPage so that only certain features can be used or viewed with Internet Explorer; hence, other browsers like Netscape Navigator can not view them properly.
Lesson 3-7: Changing the Title of a Web Page

To Change the Title of a Page:
1. Select the page, and click File → Properties from the menu.
2. Type the new title in the Title box.
Or...
Right-click on the page, and select Page Properties, and enter the new title.

Other Ways to Change the Title of a Web Page:
• Right-click on the page, and select Page Properties.

A Web page’s title is important. The Web page’s title appears at the top of a Web browser window when the page is open, so the title should describe its contents. Try using a brief, informative title that will lure readers into the page.

1. Click the Folders List button on the Standard toolbar to view the Folder List.
   All the folders and pages in your Web site are displayed in the Folder List.
2. In the Folders List, click Greece.htm to select it, and click File → Properties from the menu.
   The properties dialog box of the page appears, as shown in Figure 3-13.
3. Type Navel of the World in the Title box, and click OK.
   Now “Navel of the World” will appear at the top of the Web browser window and in Navigation view.
Lesson 3-8: Renaming a Web Page

You just changed the title, and now you’re renaming? You’re probably asking yourself, “What’s the big difference?” Well, the difference is subtle, but important to learn. Unlike the title, the name is mostly for your use; it could also be referred to as the file name. It’s a good idea to make the name of the page descriptive for your own use as well.

1. Click the Folders List button on the Standard toolbar to view the Folders List.
   All the folders and pages in your Web site are displayed in the Folder List.

2. Click Greece.htm to select it, then click it again.
   The name of the page appears surrounded by a box, as shown in Figure 3-15. The timing for this is a bit difficult, so it might take a few tries.

3. Type Navel in the box to rename the page, and press <Enter>.
   A dialog box appears, asking if you want to update the hyperlinks to reflect this change.

4. Click Yes.
   If you don’t answer “Yes” to this question, you may have some complications later on in your web’s development.

Figure 3-15
The changed page name

Figure 3-16
The Rename dialog box and the Rename progress dialog box

Shortcut button
Other Ways to Rename a Web Page:
• Click on the page name and type the new name in the box.

Quick Reference
To Rename a Page:
• Click on the page name, wait a moment, and type the new name.
Or...
• Right-click on the page name, select Rename from the shortcut menu, and type the new name.
Lesson 3-9: Deleting a Web Page

It’s rare that you’ll want to delete a page, but in case you want to, you’ve come to the right lesson. Make sure that you no longer need the information on the page you want to delete; after all, you’ve spent a lot of valuable time putting it together! Also, never delete the page named index.htm, because this is your home page. Without it, an error message will appear when readers visit your web site.

1. If necessary, navigate to the Practice Chapter 3 folder, open the North Shore Travel web, and open the Italy page. If necessary, click the Folders List button on the Standard toolbar to view the Folders List.

   All the folders and pages in your Web site are displayed in the Folder List.

2. Click Italy.htm in the Folder List to select it, and press the <Delete> key.

   The Confirm Delete dialog box appears, asking if you’re sure you want to delete the page. On second thought, that page took a while to complete, so let’s keep it in the Web site.
3. Click **No** in the Confirm Delete dialog box to cancel the page deletion.

The dialog box disappears, and you return to FrontPage.

**Quick Reference**

**To Delete a Page:**
- Select the page in the Folders List, and press the `<Delete>` key.

Or...
- Right-click on the page name and select **Delete** from the shortcut menu.
Chapter Three Review

Lesson Summary

Working with the Views Panel
- Click the button in the Views Panel of the view you want to see.

Working with Web Pages in Different Page Views
- Click the tab of the page view you want to work in.

Using the Folder List
- Click the Folder List button on the toolbar to display or hide the folder list.

Navigate Web Pages
- To Move to the Beginning or Ending of a Line: Press <Home> to move to the beginning of a line. Press <End> to move to the end of a line.
- To Move Up or Down One Screen: Press <Page Up> to move up one screen. Press <Page Down> to move down one screen.
- To Move to the Beginning or End of the Screen: Press <Ctrl> + <Home> to move to the beginning of the document. Press <Ctrl> + <End> to move to the end of the document.

Printing a Web Page
- To Print a Page: Click the Print button on the Standard toolbar. Or, select File → Print from the menu. Or press <Ctrl> + <P>.

Displaying a Web Page in a Web Browser
- Click the Preview in Browser button on the Standard toolbar. Or, click File → Preview in Browser.

Changing the Title of a Web Page
- Open the Folder List, select the page you want to change and click File → Properties under the menu. Type the new title in the Title box, and click OK.

Renaming a Web Page
- Open the Folder List. Click on the page name, wait a moment, and type the new name. Or, right-click on the page name, select Rename from the shortcut menu, and type the new name.

Deleting a Web Page
- In the Folder List, select the page and press the <Delete> key. Or, right-click on the page name and select Delete from the shortcut menu.
Quiz

1. **HTML view in FrontPage is different from Normal and Preview views because:**
   - A. HTML is more textual than Normal or Preview views.
   - B. The page has more graphics on it.
   - C. HTML shows the code that translates the Web page onto the Internet.
   - D. HTML is easier to read than Normal and Preview views.

2. **The title of a page is the same as the file name of a page.** (True or False?)

3. **You want to print four copies of a Web page you have created so that your co-workers can proofread it. How can you get four copies of a page?**
   - A. Click File → Print and enter the number of copies you want to print in the dialog box.
   - B. Print one copy of the page and take it to Kinko’s to make three more copies.
   - C. Click the Print Preview button on the Standard toolbar and enter the number of copies you want to email to your co-workers.
   - D. Press <Ctrl> + <V> and enter the number of copies you want to print.

4. **You designed a very important Web site for your company, and it will be published onto the Internet in two weeks. What are some important precautions you should take before uploading the site onto the Internet?** (Select all that apply.)
   - A. Preview the pages only in Microsoft Internet Explorer.
   - B. Preview the pages in different browsers.
   - C. Print the pages and edit them.
   - D. None of this is necessary.

5. **The Folder List is:**
   - A. A list of all the folders on your computer.
   - B. An ineffective feature of FrontPage that only takes up valuable screen space.
   - C. A feature that automatically maps out your Web site.
   - D. Easily accessible as a button on the Standard toolbar.

6. **Navigating Web pages is similar to browsing the Internet.** (True or False?)

7. **HTML is the easiest view from which to work when working with graphics.** (True or False?)

8. **The Title of a Web page appears:**
   - A. At the top of the browser when it is viewed by a reader.
   - B. As the name of the page in the Folders View.
   - C. At the very top of the page as the page’s first heading.
   - D. In the lower right corner of the window next to the Estimated Download time.

**Homework**

1. Start FrontPage, navigate to your Practice folder and open the Homework Web.
2. Click the View List button on the Standard toolbar, and select Homework 3.
3. Rename the page, Snow Club.htm.
4. Open the page you just renamed.
5. View the page in Normal, HTML, and Preview views, and return to Normal view.
6. Change the title of the page to “SnowFlakers”.
7. Navigate to the bottom of the page using the keyboard.
8. Preview the page in a Web browser.

Quiz Answers

1. A and C. HTML view is very textual and it shows the code that translates the page onto the Internet.
2. False. The title is different from the file name because it appears in the Title bar of the browser when viewed on the Internet.
3. A. The print dialog box allows you to customize your printing, including how many copies of a page you want.
4. B and C. You will want to view the page in different browsers to make sure it is able to be viewed by most people. It is also easier to edit on paper than on the screen.
5. D. The Folder List is a button on the Standard toolbar. This is convenient, because you will probably use the Folder List quite often in FrontPage.
6. False. Navigating Web pages is different from navigating through the Internet because you scroll up and down a Web page, while navigating through the Internet involves sifting through hundreds of pages.
7. False. HTML view is more difficult to work with graphics because the images do not actually appear as they will on the page. Normal view is more user-friendly when working with graphics.
8. A. The title gives the reader a better idea of what the content of the page is, and it appears at the top of the browser window.
Chapter Four: Formatting Web Pages

Chapter Objectives:

- Bold, italicize, underline or indent text
- Changing font type, size, and color
- Changing a paragraph’s alignment and spacing
- Using the Format Painter
- Creating bulleted and numbered lists
- Changing the background color
- Applying a Theme

Chapter Task: Format the text of a Web page

You’ve probably seen Web pages online and have noticed how their different fonts, italicized and boldfaced type, and fancy paragraph formatting catches your eye. This chapter explains how to format both text and paragraphs. You will learn how to change the appearance, size, and color of the characters in your web pages. You will also learn the ins and outs of formatting paragraphs: aligning text to the left, right, and center of the page; increasing a paragraph’s line spacing; and indenting paragraphs. This chapter also describes how to add borders to paragraphs and how to create bulleted and numbered lists.

Knowing how to format text and paragraphs gives your Web pages more impact and makes them easier to read. Let’s get started!
Lesson 4-1: Using Bold and Italics

You can emphasize text in a document by making the text darker and heavier (**bold**) or slanted (**italics**). Underlining text is discouraged in Web pages because this format is saved for hyperlinks. One of the easiest ways to apply character formatting is to use the Formatting toolbar. The Formatting toolbar includes buttons for applying the most common character and paragraph formatting options.

1. Navigate to your Chapter 4 Practice folder and open the Lesson 4A Web page.

Okay! Let’s start by applying bold formatting to some of the text in the Web page…
2. Press <Ctrl> + <Home> to move the insertion point to the top of the document. Click the **Bold button** on the Formatting toolbar.
   Whenever the Bold button on the Formatting toolbar is indented, the text will be in boldface.

3. **Type North Shore Travel.**
   Notice how the text “North Shore Travel” is in boldface? You don’t want to use bold character formatting anymore, so…

4. **Click the **Bold button** on the Formatting toolbar.**
   The Bold button on the Formatting toolbar is no longer indented. You can also change the formatting of existing text by simply selecting the text and then formatting it. Try selecting and then formatting some text.

5. **In the second line, select the text We have the tickets to your dreams.**
   You can format the text now that it is selected.

6. **Click the **Italics button** on the Formatting toolbar.**
   The selected text, “We have the tickets to your dreams.” appears in italics.
   That looks a little better, but we can probably do even more to make it look good. Go on to the next lessons to see what else you can do.

7. **Save your changes.**

---

**Quick Reference**

**To Bold Text:**
- Click the **Bold button** on the Formatting toolbar, or press <Ctrl> + <B>.

**To Italics Text:**
- Click the **Italics button** on the Formatting toolbar, or press <Ctrl> + <I>.
Lesson 4-2: Changing Font Type

Fonts must be used differently when creating pages for the Internet than when using a print program like Microsoft Word. When developing Web pages, you must be aware that people viewing your Web pages may not have a font you use installed on his or her computer. Fortunately, there are some fonts that are universal, which means they are Web-safe. This lesson will show you how to change font type, and list a few common fonts that are Web-safe.

1. Select the text North Shore Travel.

   Note that the text does not have a font selected in the Font list, it just says "(default font)". This is not your default font; this means that the text will appear in the font that the person viewing your page has assigned as the default font for his or her browser.

2. Click the Font list arrow on the formatting toolbar, then scroll to and click Arial from the list of fonts.

   The selected text “North Shore Travel” appears in Arial font. Arial and Times New Roman are two of the most commonly used fonts.

   NOTE: Using a common font type is important when creating Web pages. An obscure font may look great on your screen, but it may not be available on all computers that want to view your page.

<table>
<thead>
<tr>
<th>Table 4-1: Common Web-safe Font Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
</tr>
<tr>
<td>Courier</td>
</tr>
</tbody>
</table>

(default font) — the text will appear in the font that the user has assigned as the default font for his or her browser.
Lesson 4-3: Changing Font Size

Text can also be emphasized in a page by making the text larger.

1. **Select the text North Shore Travel.**
   
   Notice that there are numbers one through seven in the Font Size list, and that each number has a point size next to it. The point sizes are only there to help you understand how large the font will be, especially if you’re used to using print programs like Word. Font point sizes are not applicable to Web use.

2. **Click the Font Size list arrow on the Formatting toolbar.** Then select 5 (18 pt).
   
   The selected text “North Shore Travel” appears in a larger font size.

### Table 4-2: Common Font Sizes

<table>
<thead>
<tr>
<th>Font</th>
<th>Point Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
<td>8</td>
</tr>
<tr>
<td>Arial</td>
<td>10</td>
</tr>
<tr>
<td>Arial</td>
<td>12</td>
</tr>
<tr>
<td>Arial</td>
<td>14</td>
</tr>
<tr>
<td>Arial</td>
<td>18</td>
</tr>
</tbody>
</table>

### Figure 4-4

The procedure for changing font size.

Font Size List

Other Ways to Change Font Size:
- Select **Format → Font** from the menu and select the font size from the dialog box.

Quick Reference

To Change Font Size:
- Select the pt. size from the **Font Size list** on the Formatting toolbar.
  Or...
- Select **Format → Font** from the menu and select the font size from the dialog box.
Lesson 4-4: Changing Font Color

There probably won’t be many instances where you’ll want to change the font color, but in case the situation arises, here’s how to do it.

1. Select the North Shore Travel text at the top of the page.
   The text already stands out simply because it is at the top of the page, but changing its color will make it stand out even more.

2. Click the Font Color list arrow on the Formatting toolbar and select the blue color.
   The selected text “North Shore Travel” appears in the color blue. Colored text really catches your eye, doesn’t it?
   NOTE: The Font Color button only changes text to the color of the line under the “A”. Use the down arrow beside it to choose another color, as shown in Figure 4-5.
   If you choose to use colored text, choose your text wisely. An entire page of colored text is ineffective, because nothing will stand out.

3. Click the Undo button on the Standard toolbar to undo the change and return the text to its original color.
Lesson 4-5: Using the Font Dialog Box

1. **Select the heading We have the tickets to your dreams.**
   You will format this text a little differently than you did in the previous lesson. The Formatting toolbar is great for quick formatting, but the Font dialog box has additional, more advanced font formatting options than the Formatting toolbar.

2. **Select Format → Font from the menu.**
   The Font dialog box appears, as shown in Figure 4-6. The line of text you selected will be a minor heading, so you need to make it stand out from the document.

3. **Click the Font list arrow on the Formatting toolbar and select Comic Sans MS.**
   Look at the Preview area at the bottom of the Font dialog box to see a sample or preview of how the selected text will look once it has been formatted.

4. **Select Italic from the Font style list and select 4 (14 pt) from the Size list.**

5. **Click OK.**
Lesson 4-6: Changing Paragraph Alignment

This lesson moves on to paragraph formatting and how to align paragraphs to the left, right, or center on a page. Figure 4-8 gives a better idea of how these various alignments look.

1. If necessary, navigate to your Chapter 4 Practice folder and open the Lesson 4B Web page.

2. Place the insertion point anywhere in the first line, North Shore Travel, then click the Center button on the Formatting toolbar.

   The first line, the page’s title, is centered between the left and right margins. Notice that you don’t have to select the text to change the paragraph’s alignment.

   Now do the same thing with the second line.

3. Press <- to move the insertion point to the next line, and repeat Step 2.

   The second line is centered like the one above it.

   You can also center several lines at once by selecting them.
4. Place the mouse insertion point to the beginning of the sentence, *Call us 24 hours a day!* press the left mouse button and drag to select the rest of the text on the page (except the last paragraph). Press <Ctrl> + <E> to center the text.

That looks more organized, don’t you think?

5. Move the insertion point to the last line of the document, *Travel with a translation book.*

This line is going to be moved to the right side of the page.

6. Click the **Align Right** button on the Formatting toolbar.

The paragraph is lined up against the right margin.

You can also use the Format dialog box to change the alignment of your paragraphs.

7. Select **Format → Paragraph** from the menu.

The Paragraph dialog box appears, as shown in Figure 4-9. You can select paragraph alignment from the Alignment list. When aligning paragraphs, it’s easier and faster to use the Formatting toolbars. However, if you need to format another element of a paragraph, such as its spacing, the Paragraph dialog box is a good way to go about it. Since you have already aligned the paragraphs in your page, you can close the Paragraph dialog box.

8. Click **Cancel** to close the Paragraph dialog box.

---

**Quick Reference**

- **Align Left button**
  - Other Ways to Align Left:
    - Press <Ctrl> + <L>.

- **Align Right button**
  - Other Ways to Align Right:
    - Press <Ctrl> + <R>.

- **To Left-Align a Paragraph:**
  - Click the **Align Left button** on the Formatting toolbar or press <Ctrl> + <L>.

- **To Center a Paragraph:**
  - Click the **Center button** on the Formatting toolbar or press <Ctrl> + <E>.

- **To Right-Align a Paragraph:**
  - Click the **Align Right button** on the Formatting toolbar or press <Ctrl> + <R>.

- **To Align a Paragraph with the Paragraph dialog box:**
  - Select **Format → Paragraph** from the menu and select the paragraph alignment from the **Alignment** list.
Lesson 4-7: Using the Format Painter

If you find yourself applying the same formatting to characters and/or paragraphs again and again, then you need the Format Painter tool. The Format Painter allows you to copy the formatting of text and apply it elsewhere. Sound confusing? It won’t be after you walk through this lesson.

1. **Select the heading We have the tickets to your dreams.**
   
   You want to apply the font formatting in “We have the tickets to your dreams” to the other headings on the page.
2. While the text is selected, double-click the Format Painter button on the Standard toolbar.

Double-clicking the Format Painter button allows you to copy the same formatting several times. Clicking the Format Painter button once allows you to apply the copied formatting only one time. Notice that the pointer changes to a $\text{ parfait}$.

3. Move the $\text{ parfait}$ pointer to the very beginning of the heading, Call us 24 hours a day!. Click and hold the mouse button, and drag the pointer across the heading. Release the mouse button at the end of the heading.

The formatting from the first heading is applied to the selected heading. Because you double-clicked the Format Painter button, you can keep applying the formatting you copied to other paragraphs.

4. Drag the $\text{ parfait}$ pointer across the remaining heading, Contact our global offices in:

The formatting is applied to the last heading in the document.

5. Click the Format Painter button on the Standard toolbar to deactivate the Format Painter.

The Format Painter is a great tool. If you use it enough, you may find that you hardly ever need to use other buttons on the Formatting toolbar.

Quick Reference

To Copy Formatting with the Format Painter:

1. Select the text or paragraph with the formatting options you want to copy.

2. Click the Format Painter button on the Standard toolbar.

3. Drag the Format Painter pointer across the text or paragraph where you want to apply the copied formatting options.

To Copy Selected Formatting to Several Locations:

1. Select the text or paragraph with the formatting options you want to copy.

2. Double-click the Format Painter button.

3. Drag the Format Painter pointer across the text or paragraph where you want to apply the copied formatting options.

4. Click the Format Painter button when you're finished.
Lesson 4-8: Indenting Text

Indenting means to add blank space between the left and/or right margin and the paragraph text, as shown in Figure 4-13. Indenting paragraphs can emphasize the paragraphs and add organization to a document. Long quotations, numbered and bulleted lists, and bibliographies are a few examples of paragraphs that are often indented. You can indent paragraphs from the left and right margins.

1. Place the insertion point anywhere in the paragraph under the heading We have the tickets to your dreams and click the Increase Indent button on the formatting toolbar.

   The Increase Indent button indents the paragraph 40 pixels the right, as shown in Figure 4-13 (the top two lines are right-aligned for the sake of viewing an indent; do not make these changes to your own file). FrontPage measures the indentation in pixels. A pixel is a mere dot on the computer screen, so you probably won’t see much of a change if you enter a number less than 20.

2. Place the insertion point anywhere in the last paragraph (Our global agents) and select Format → Paragraph from the menu.

   The Paragraph dialog box appears, as shown in Figure 4-14. The Paragraph dialog box has an option you indent paragraphs with greater precision than the Formatting toolbar.
3. **Select the Before text box and type 20.**
   You can also click on the up and down arrows to increase and decrease paragraph indentation.

4. **Click OK.**
   FrontPage indents the selected paragraph 20 pixels to the right.

5. **Keeping the insertion point in the same paragraph, select Format → Paragraph from the menu.**
   The Paragraph dialog box appears.

6. **Select the After text box, type 30 and click OK.**
   The paragraph right indentation increases by 30 pixels to the left.

7. **Keeping the insertion point in the same sentence, select Format → Paragraph from the menu.**
   The Paragraph dialog box appears.

8. **Type 0 in the Right Indentation box and click OK.**
   The paragraph’s right edge is no longer indented. You could also click the Undo button to make this change.
   You can also indent, or hang indent, the first line in a paragraph.

9. **Keeping the insertion point in the same paragraph, select Format → Paragraph from the menu.**
   Once again, the paragraph dialog box appears. Let’s indent the first line a little more.

10. **Type 10 in the Indent first line box and click OK.**
    The first line indents the number of pixels relative to the rest of the paragraph. So, if the paragraph is already indented 20 pixels, the first line is indented a total of 30 pixels from the left margin.
    A hanging indent is another good way to layout a paragraph.

11. **Select the Indent first line box, click the down arrow to –10 and click OK.**
    The first line hangs past the edge of the rest of the paragraph, as shown in Figure 4-13. Again, the first line indents relative to the rest of the paragraph. So, if the paragraph was already indented 20 pixels, now the first line is indented a total of 10 pixels from the left margin.

This concludes the lesson on indenting paragraphs.

---

**Quick Reference**

**To Left Indent a Paragraph:**
- Click the **Increase Indent** button on the Formatting toolbar.
- Or...
  - Select **Format → Paragraph** from the menu and enter how many pixels you want the paragraph to be indented in the Indent section.

**To Decrease an Indent:**
- Click the **Decrease Indent** button on the Formatting toolbar.

**To Right Indent a Paragraph:**
- Select **Format → Paragraph** from the menu and enter how many pixels you want the paragraph to be indented in the Indent section.

**To Hanging Indent the First Line:**
- Select **Format → Paragraph** from the menu and enter how many pixels you want the first line to be indented, relative to the rest of the paragraph.
Lesson 4-9: Creating Bulleted and Numbered Lists

You can make lists more attractive and easier to read by using bulleted lists. In a bulleted list, each paragraph is preceded by a bullet, which is a (•) filled in circle or other character (not the type of bullet you load in a gun). Use bulleted lists when the order of the items does not matter.

When the order of the items in a list does matter, try using a numbered list. Numbered lists are great when you want to present step-by-step instructions (like in this book!). When you work with a numbered list, FrontPage takes care of the numbering for you—you can add or delete items in a list and they will always be numbered correctly.

Things to buy:
- Peas
- Corn
- Cod-liver Oil

How to turn on my computer:
2. Take a deep breath.
3. Press ON.

You can make lists more attractive and easier to read by using bulleted lists. In a bulleted list, each paragraph is preceded by a bullet, which is a (•) filled in circle or other character (not the type of bullet you load in a gun). Use bulleted lists when the order of the items does not matter.

When the order of the items in a list does matter, try using a numbered list. Numbered lists are great when you want to present step-by-step instructions (like in this book!). When you work with a numbered list, FrontPage takes care of the numbering for you—you can add or delete items in a list and they will always be numbered correctly.
Chapter Four: Formatting Web Pages

1. If necessary, navigate to your Chapter 4 Practice folder and open the Lesson 4C Web page.

2. Select the entire list of global offices, which begins with Luxor, Egypt and ending with Florence, Italy.
   With the current formatting, it’s difficult to distinguish this as a list. Add some bullets to make it look more like a list.

3. Click the Bullets button on the Formatting toolbar.
   Bullets appear in front of each listed item, and the extra space between each item is erased.
   Creating a numbered list is just as easy as creating a bulleted list.

4. With the same list still selected, click the Numbering button on the formatting toolbar.
   Voila! The bulleted list is changed to a numbered list.

5. Place the insertion point at the end of Florence, Italy.

6. Press <Enter> to start a new line.
   Notice how the new line starts with the next number on the list and “inherits” the same formatting as the line before it.

7. Type Rethymnon, Crete.

8. Press <Enter> to start a new line.
   The line starts with the next number on our list. That’s great, but what if you’ve finished your list and want to type something else?

9. Press the <Backspace> key to stop adding to the list.
   The paragraph no longer has a number in front of it and is not part of the list.
   You can also create a bulleted or numbered list using the Bullets and Numbering dialog box under the Formatting menu. The Bullets and Numbering dialog box gives you more formatting options than the simple buttons on the Formatting toolbar.

10. Select the entire list of global offices, beginning with Luxor, Egypt and ending with Rethymnon, Crete.

11. Select Format → Bullets and Numbering from the menu.
   The Bullets and Numbering dialog box appears with the Numbering tab selected, as shown in Figure 4-18. Here you can select which type of numbers or bullets you want to appear in your list.

12. If necessary, click the Numbered tab.

13. Click the Roman numeral numbering option (the third option in the first row) and click OK.
   The list is numbered with Roman numerals.

Quick Reference

To Create a Bulleted List:

- Click the Bullets button on the Formatting toolbar.

Or...
1. Select Format → Bullets and Numbering from the menu and click the Plain Bullets tab.

To Create a Numbered List:

- Click the Numbering button on the Formatting toolbar.

Or...
1. Select Format → Bullets and Numbering from the menu and click the Numbers tab.
Lesson 4-10: Changing the Background Color

If you want to add a little zing to your page, color the background. However, make sure your page is readable by using a dark background with a light text color, or a light background with a dark text color.

1. In the page where you want to change the background color, select Format → Background from the menu.
   
   The Background tab of the Page Properties dialog box appears.

2. Click the Background color list arrow to select a new background color for your Web page.

   “Automatic” should appear in the box with the color white, the default page color. We want the page to look sleeker, so let’s change the background to silver.

3. Select the Silver color and click OK to confirm your selection.

   The background of the page is now silver, with black text.
4. Click the **Undo button** on the Standard toolbar to return the background to its original white color.

The Silver background disappears, and the text is easy to read on the white background.

Backgrounds are great additions to pages, but you must choose them carefully. Not only must you make sure the text can still be read on top of the background, you must consider other colors in the page, such as colors in images, hyperlinks, etc.
Lesson 4-11: Applying a Theme

Themes are fast, easy ways to make your Web site look well-designed and polished. With a few clicks of the mouse, you can turn a black and white Web page into a colorful, coordinated page that complements the purpose of your Web site.

Before you decide to apply a theme to your Web site, consider, is that themes are exclusive to Microsoft FrontPage. Every other Web-development program uses cascading style sheets to cohesively format Web pages.

1. Navigate to your Chapter 4 Practice folder and open the Theme Web and open the Italy.htm page.
   Let’s try to apply a theme to this page.

2. Select Format → Theme from the menu.
   The Themes dialog box appears, as shown in Figure 4-21. The available themes appear listed on the left side, while a preview of the selected theme is shown on the right.
3. Click on a theme to see its preview on the right. Scroll down the list and select the Romanesque theme from the list.
   After deciding which theme you want to use, you must decide which pages you want to display it on.
4. Click the All Pages option in the dialog box to apply the theme to all of the pages in the Web site, and click OK.
   A dialog box appears, warning you that applying the theme will change the formatting of the Web site.
5. Click Yes in the dialog box to continue.
   FrontPage begins applying the theme to all the pages in the Theme Web site. This takes a while, so you will have to be patient while the theme is being applied.
   When FrontPage is finished, the Italy.htm page will appear in the window with the theme, as shown in Figure 4-22.
   Browse other pages to see how their formatting changes with the new theme.
6. Select Format → Theme from the menu, select the (No Theme) option from the Themes dialog box, click All Pages, click OK, and click Yes.
   The Romanesque theme is erased from the Web site.

### Table 4-3: Additional Theme Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vivid Colors</td>
<td>This option uses brighter colors in the theme. These options are sometimes harder to see than the regular colors however, and may cause problems for other computers downloading the site.</td>
</tr>
<tr>
<td>Active Graphics</td>
<td>This option adds some animated graphics to the theme. For example, buttons could change colors as a cursor is drawn over them with this option.</td>
</tr>
<tr>
<td>Background Picture</td>
<td>Each theme has a background built into it, but you can choose to omit a background from the theme if you uncheck this option.</td>
</tr>
<tr>
<td>Apply using CSS</td>
<td>Apply the theme using a Cascading Style Sheet you have already created.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Apply a Theme:
1. Click Format → Theme from the menu.
2. Select the theme you want to use in the Themes dialog box.
3. Click OK.
4. Click Yes to change the formatting previously applied to the page.
Chapter Four Review

Lesson Summary

**Bold, Italicize, or Underline Text**

- **To Bold Text:** Click the **Bold** button on the Formatting toolbar, or press `<Ctrl> + <B>`, or select `Format → Font` from the menu, select **Bold** from the Font Style box, then click **OK**.

- **To Italicize Text:** Click the **Italics** button on the Formatting toolbar, or press `<Ctrl> + <I>`, select `Format → Font` from the menu, select **Italic** from the Font Style box, then click **OK**.

**To Change Font Type**

- Select the font from the **Font** list on the Formatting toolbar, or click `Format → Font`, and select the font type from the dialog box.

**To Change Font Size**

- Select the size from the **Font Size** list on the Formatting toolbar, or click `Format → Font`, and select the font size from the dialog box.

**To Change Font Color**

- Select the color from the **font color list arrow** on the Standard toolbar, or click `Format → Font`, and select the font color from the dialog box.

**Using the Font Dialog Box**

- Formatting characters with the Font dialog box isn’t as fast or easy as using the Formatting toolbar, but it offers more formatting options.

- **To Open the Font Dialog Box:** Select `Format → Font` from the menu.

- **To Change a Font’s Color:** Click the **Font Color Button arrow** on the Formatting toolbar and select the color.

**Changing Paragraph Alignment**

- **To Left-Align a Paragraph:** Click the **Align Left** button on the Formatting toolbar or press `<Ctrl> + <L>`.

- **To Center a Paragraph:** Click the **Center** button on the Formatting toolbar or press `<Ctrl> + <E>`.

- **To Right-Align a Paragraph:** Click the **Align Right** button on the Formatting toolbar or press `<Ctrl> + <R>`.

- **To Align a Paragraph with the Paragraph dialog box:** Select `Format → Paragraph` from the menu and select the paragraph alignment from the **Alignment list**.
Using the Format Painter

- The Format Painter lets you copy character and paragraph formatting and apply or paste the formatting to other characters and paragraphs.

- **To Copy Formatting with the Format Painter:** Select the text, paragraph, or object with the formatting options you want to copy. Click the Format Painter button on the Standard toolbar and drag the Format Painter pointer across the text or paragraph where you want to apply the copied formatting options.

- Double-click the Format Painter button to apply formatting to several locations. Click the Format Painter button again when you’re finished.

Indenting Text

- **To Left Indent a Paragraph:** Click the Increase Indent button on the Formatting toolbar; or select Format → Paragraph from the menu and enter how many pixels you want to indent the paragraph in the Indentation section.

- **To Right Indent a Paragraph:** Click the Decrease Indent button on the Formatting toolbar; or select Format → Paragraph from the menu and enter how many pixels you want to indent the paragraph in the Indentation section.

- **To Hanging Indent the First Line:** Select Format → Paragraph from the menu and enter how many pixels you want the first line to be indented, relative to the rest of the paragraph.

Creating Bulleted and Numbered Lists

- **To Create a Bulleted List:** Click the Bullets button on the Formatting toolbar, or select Format → Bullets and Numbering from the menu, click the Bullets tab, and select the bulleted option you want to use.

- **To Create a Numbered List:** Click the Numbering button on the Formatting toolbar, or select Format → Bullets and Numbering from the menu, click the Numbering tab, and select the numbering option you want to use.

Changing the Background Color

- Select Format → Background from the menu, choose a background color, and click OK.

Applying a Theme

- Click Format → Theme from the menu. Select the theme you want to use in the Themes dialog box. Click OK. Click Yes to change the formatting previously applied to the page.
Quiz

1. Which of the following procedures can you use to change the size of a font?
   A. Select the text and select the font size from the Font Size list on the Formatting toolbar.
   B. Select the text, right-click it, choose Font from the shortcut menu, select the font size and click OK.
   C. Select the text, select Format → Font from the menu, select the font size and click OK.
   D. All of the above.

2. To copy character and paragraph formatting from one area on a page and apply it to another area, you would use:
   A. The Edit → Copy Format and Edit → Paste Format commands from the menu.
   B. The Format Painter button on the Standard toolbar.
   C. There isn’t a way to copy and apply formatting in Word.
   D. Open the Copy and Apply Formatting dialog box by selecting Format → Copy Formatting from the menu.

3. You want to use the Format Painter to apply formatting to multiple lines of a document that are not next to each other. How can you do this?
   A. Click the Format Painter button on the Standard toolbar.
   B. Double-click the Format Painter button on the Standard toolbar.
   C. This isn’t possible.
   D. Open the Copy and Apply Formatting dialog box by selecting Format → Copy Formatting from the menu.

4. Which statement is NOT true?
   A. Clicking the Center button on the Formatting toolbar centers the current or selected paragraph(s) on the page.
   B. Using the Formatting toolbar is the easiest way to format text.
   C. When you indent a first line, every first line after it is also indented.
   D. A special type of indent is First line.

5. Which of the following is NOT a method for indenting a paragraph?
   A. Move the pointer to the left or right edge of the paragraph and then drag the mouse to where you want the paragraph indented.
   B. Click the Increase Indent button on the Formatting toolbar.
   C. Click the Decrease Indent button on the Formatting toolbar.
   D. Select Format → Paragraph from the menu and specify how much you would like the paragraph indented in the Indentation section.

6. Which is NOT a method for applying boldface to a selected block of text?
   A. Select Format → Font from the menu and select Bold from the Font style list.
   B. Press <Ctrl> + <B>.
   C. Right-click the text and select Boldface from the shortcut menu.
   D. Click the Bold button on the Formatting toolbar.
7. When you press <Enter> to start a new paragraph, the new paragraph is formatted exactly like the paragraph before it. (True or False?)

8. How do you center a paragraph?
   A. Click the Center button on the Formatting toolbar.
   B. Click the Alignment arrow on the toolbar and select Center.
   C. Press <Ctrl> + <C>.
   D. Select Edit → Center from the menu.

9. How can you change the bullet character that is used in a bulleted list?
   A. Click the Bullets arrow on the Formatting toolbar and select the character.
   B. You can't change the bullet character.
   C. Select Edit → Bullet Symbol from the menu, select the bulleted list you want to use, click Customize, and select the character you want to use.
   D. Select Format → Bullets and Numbering from the menu, select the bulleted list you want to use, click Customize, and select the character you want to use.

10. You want to change the background color of your page to make it more interesting. Which of these methods will allow you to do this?
    A. Click the Background button on the Formatting toolbar and select a background color.
    B. Select the text and click the Underline button on the Formatting toolbars.
    C. Select Format → Background from the menu and select a background color.
    D. Right-click the page and select Page Properties → Background tab, and select a background color.

11. All Web development programs use themes. (True or False?)

12. What is the difference between themes and cascading style sheets? (Select all that apply.)
    A. There is no difference.
    B. The styles in themes are already created, whereas you create the styles in cascading style sheets on your own.
    C. Themes can only be applied to one page in a Web site, whereas cascading style sheets apply to every page in the Web site.
    D. Cascading style sheets change the style of a page’s specific HTML tags in HTML code, while themes are a collection of styles applied at one time.

Homework

2. Select the first line, “Snowflake Flakers.” Change the font type to Comic Sans MS, the font size to 5 (18 pt), and the font color to blue.
4. Select the third paragraph, “Peter Peterson is also famous for…” and center the paragraph.

5. Select the four outdoor camping activities, and click the Bullet button on the Standard toolbar.

6. Change the background color of the page to a light blue. (On the background tab, click the More Colors button, and select a light blue color from the hexagon.)

Extra Credit: Apply a theme to the Homework 4 page. Then create your own cascading style sheet for the body text, Heading 1, and the background.

Quiz Answers

1. D. All of these procedures change the font size.

2. B. The Format Painter tool can copy formatting from one area of a document and apply it somewhere else.

3. B. Double-click the Format Painter button to apply formatting to multiple areas of a document. Click the Format Painter button when you’re finished.

4. C. First line indents are only available in the paragraph in which you set the indent.

5. A. The other three methods are valid ways to indent a paragraph.

6. C. You can use the other three methods to apply bold to text.

7. True. Paragraphs ‘inherit’ the formatting from the paragraphs above them.

8. A. Click the Center button on the Formatting toolbar to center a paragraph.

9. D. To change the bullet character used in a bulleted list, select Format → Bullets and Numbering from the menu; select the bulleted list you want to use; click Customize; and select the character you want to use.

10. C and D. To change the background color, select Format → Background from the menu and select a background color. Or, right-click the page and select Page Properties → Background tab, and select a background color.

11. False. Themes are only available in Microsoft FrontPage. Every other program uses cascading style sheets for consistent formatting.
12. B and D. Cascading style sheets are easier to customize to your own needs than themes are. Also, cascading style sheets change the formatting in a page by applying its HTML code to the page.
Chapter Five:
Working with Images

Chapter Objectives:

• Adding a ClipArt Image, and an Image from File
• Moving, Copying, Resizing, and Cropping an Image
• Adding a Border to an Image
• Aligning Text with an Image
• Positioning an Image
• Adding a Background Image
• Creating a Thumbnail Image
• Adding a Hyperlink to an Image
• Working with Image Hotspots
• Changing Image Files Formats

Chapter Task: Add Images to a Web Page

The Internet is a visual medium, so generally speaking, more images equals a better page. The trick is to find the balance between designing a page that is visually pleasing, and one that is just cluttered.

Images are more than just eye candy; they can act as hyperlinks as well. In this chapter, you’ll learn how to place and organize images on your page; how to format an image; and how to coordinate text with images. You will need to use many of the lessons in this chapter as you design your Web site.
Lesson 5-1: Adding an Image from a File

When you are creating your Web site, you will probably have most of the images you want to include in your Web site already on file. This lesson will show you how to move them from their saved location to your Web page.

1. **Navigate to your Practice Chapter 5 folder and open Lesson 5A.**
   The text looks good on this page, but it needs some pictures to liven it up.

2. **Place the insertion point at the end of the line that begins with We specialize in Mediterranean travel, and press <Enter>.**
   Now the picture will have clean spacing between paragraphs.
3. **Click the Insert Picture From File button on the Standard toolbar.**

   The Picture dialog box appears, as shown in Figure 5-2.

   You have two choices:

   - ![Use your Web Browser to select a page or file](image)
     Click this button to browse the Web to find an image you want to insert into your Web page.

   - ![Select a file on your computer](image)
     Click this button to navigate to the location of a file on your computer.

4. **Click the Select a file on your computer button on the lower right side of the window.**

   The Select File dialog box appears. Here you can browse through your computer to the location of the file you want to add to the page.

5. **In the Look in: list, navigate to your Practice folder. Click on the map file to select it, and click OK.**

   The map of the Mediterranean is added to your Web page.

   **NOTE:** Try not to insert an image that needs further editing into FrontPage. FrontPage is not an image-editing program.

---

**Quick Reference**

To Add an Image from a File:

1. Click the Insert Picture From File button on the Standard toolbar.
2. Click the Select a file on your computer button on the lower right side of the window.
3. Locate and select the image you want to insert, and click OK.

   Or...

1. Select Insert → Picture → From File from the menu.
2. Locate and select the image you want to insert, and click OK.
Lesson 5-2: Adding a ClipArt Image

Sometimes you’ll want to add an image to your page that you don’t have on file. Clip Art has a lot of fun pictures, although you might not want to create an entire web site of Clip Art. Try looking through the Clip Art Gallery to find an image that’s a good match for your Web site.

1. Place the insertion point at the end of the sentence that begins If you’ve been waiting for the trip of a lifetime, and press <Enter> to move the insertion point down one line.

   The new line “inherits” the centered formatting of the previous paragraph.

2. Select Insert → Picture → Clip Art from the menu.

   The Clip Art Gallery appears. The art is organized by category, so click on the category that is closest to the kind of image you want. In this case, choose travel.
3. Scroll down the Clip Art window and select **Travel**.
   The travel category appears in the window. The very first picture in the window
   (airplane and globe) looks like a good option for a travel agency, so let’s put that on the
   page.

4. **Click on the first picture in the Travel category.**
   A menu appears, asking what you would like to do with the image.

5. **Click the Insert Clip button to add the image to your page.**
   Whoa! That’s a pretty large picture! Don’t worry; we’ll resize it in the next lesson.

   **NOTE:** If you don’t find the image you’re looking for in your computer’s Clip Art
   Gallery, there are other ways to get clip art. Click the Clips Online button to
   find additional images on the Internet at Microsoft’s Clip Gallery. Clip art
   images are also available for purchase at computer stores.

---

**Quick Reference**

**To Insert Clip Art:**

1. Place the insertion point
   where you want to insert
   the image.
2. Select **Insert → Picture
   → Clip Art** from the
   menu.
3. Click on the category of
   clip art images you want
   to insert.
4. Click on the image you
   want to insert, and click
   the **Insert Clip button**
   from the menu.
Lesson 5-3: Resize an Image

Sometimes an image will appear on your page much larger than you want it to be. Follow this lesson to resize the clip art image you just inserted.

**NOTE:** When possible, do not resize images in FrontPage. Doing so will cause images to be distorted. Instead use a graphics program such as PhotoShop or Fireworks to size the image, and then re-insert the image in the page.

1. **Click the clip art image to select it.**
   An image must be selected before it can be resized.

2. **Position the cursor over the lower right handle until it changes to a ▼.**
   Resizing the image from a corner handle keeps the image in proportion.

3. **Click and drag the handle until the image is about the size shown in Figure 5-1, and release the mouse button.**
   The image appears in a smaller size.
Lesson 5-4: Moving an Image

1. **Place the insertion point at the end of the sentence** *We have the tickets to your dreams* **and press <Enter> to begin a new line.**

   This is a better place for this image because it gives the reader an immediate idea of what the purpose of the page is.

2. **Click the airplane image to select it.**

3. **Drag the picture into the space you just entered below the sentence, *We have the tickets to your dreams.***

   The cursor changes to a light gray rectangle and arrow, as shown in Figure 5-8. This means that the image will be inserted wherever the gray insertion point is when the mouse button is released.

   Notice that the image is centered on the page. That is because it “inherits” the formatting from the line it was dropped on.

---

**Quick Reference**

To Move an Image:

1. Click the image to select it.

2. Drag the cursor to where you want to move the image.
Lesson 5-5: Copying an Image

Copying an image is very similar to copying text. In this lesson, we’ll copy the airplane image to the bottom of our Web page.

1. **Click the airplane image to select it.**
   Here’s how to copy an image…

2. **Click the Copy button on the Standard toolbar.**
   The image is placed on the clipboard, ready to be pasted elsewhere on the page.

3. **Press <Ctrl> + <End> to place the insertion point at the end of the page.**
   **Press <Ctrl> + <V> to paste the image onto the page.**
   Nothing to it! The copied image appears with the “inherited” formatting of the last line. The image doesn’t need to be at the bottom of the page though, and it adds download time to the page, so let’s just delete it.

4. **Select the image you just pasted at the bottom of the page, and press <Delete> to erase the image from the page.**

5. **Close the Web page without saving changes.**
Lesson 5-6: Cropping an Image

There are a few reasons you may want to crop an image on your page: (1) to bring the reader’s attention to an important part of the image, (2) to change the proportions so the image fits better on your page, and (3) to reduce the size of the image so it downloads faster onto the reader’s screen. In this lesson we’re going to crop the image for all of the above reasons.

NOTE: When possible, do not crop images in FrontPage. Instead use a graphics program such as PhotoShop or Fireworks to crop the image, and then re-insert the image in the page.

1. Navigate to your Practice Chapter 5 folder and open Lesson 5B.
2. Click on the map to select it, and click the Crop button on the Pictures toolbar at the bottom of the FrontPage window.

A dashed line appears inside the map, as shown in Figure 5-12.
3. Place the mouse over the upper right corner of the image, and click and drag over the part of the image you want to keep, as shown in Figure 5-13.

The area inside the dashed line is the part of the image that you will keep. If you make a mistake while drawing the dashed line, just click outside the image and start over.
4. Click the Crop button on the Pictures toolbar once again to delete the parts of the image outside the dashed line.

The image is smaller so that it focuses on a smaller area of the map, fits on the page better, and makes the size of the file much smaller and faster to download.
Lesson 5-7: Adding a Border to an Image

People put frames around art because it adds a finishing touch to the picture. You can do the same thing in a Web page; add a border to an image to make it stand out.

1. Click the map to select it.

2. Select Format → Properties from the menu and click the Appearance tab.

   The Picture Properties dialog box appears with the Appearance tab on top, as shown in Figure 5-14.

3. In the Border thickness box, click the up arrow to set it at 3, and click OK.

   The image appears with a black border around it, as shown in Figure 5-15.

   **NOTE:** The border of an image will always be black, unless the image is a link. If an image is a link, the border will be blue so that readers can easily identify it as a link.

---

**Quick Reference**

To Add a Border to an Image:

1. Select the image.
2. Select Format → Properties from the menu and click the Appearance tab.
3. Enter the thickness for the border, in the Border thickness box, and click OK.

---

**Other Ways to Access Picture Properties:**

- Right-click the picture and select Picture Properties from the shortcut menu.
- Press <Alt> + <Enter>.
Lesson 5-8: Aligning an Image with Text

Moving images within a web page is pretty easy; just click on the image and drag it to where you want it. You may have noticed though, that the text doesn’t wrap around the image, which wastes a lot of space and doesn’t always look very good. This lesson will teach you how to solve this problem.

1. **Click on the image you want to display with a border. Select Format → Properties from the menu and click the Appearance tab.**
   The Picture Properties dialog box appears with the Appearance tab on top, as shown in Figure 5-16.

2. **In the Alignment drop-down list, select Left, and click OK.**
   The image appears aligned with the text, as shown in Figure 5-18. This doesn’t look as good as it was when it was centered though, so let’s undo the alignment.

3. **Click the Undo button on the Standard toolbar to replace the image in its original location.**

Other Ways to Align Text:
- Click the right mouse button and select Picture Properties from the shortcut list.
  Or...
  - Press <Alt> + <Enter>.

Quick Reference

To Align an Image with Text:
1. Select the image you want to align.
2. Select Format → Properties → Appearance from the menu.
   Or...
   Click the right mouse button, select Picture Properties from the shortcut list and click the Appearance tab.
   Or...
   Press <Alt> + <Enter>.
3. Select the alignment for the picture, and click OK.
Lesson 5-9: Positioning an Image

Positioning an image allows you to place the image in an exact location on a Web page. The danger in positioning an image is that the image remains in the same location on the Web page, no matter what the size or resolution of the screen. Tables (a topic discussed later in the manual) are much easier to use than positioning, and the objects in the table are guaranteed to stay where they are.

1. If necessary, navigate to your Practice Chapter 5 folder, and open Lesson 5C.

2. Click on the bag image to select it and click the Position Absolutely button on the Pictures toolbar.
   The image covers up some text, as shown in Figure 5-19, but we can fix that by positioning the image. We also want to use the Positioning toolbar to perform this action.

3. Select View → Toolbars → Positioning from the menu.
   The Positioning toolbar appears, as shown in Figure 5-19. You can use this toolbar to exactly position the coordinates of the image on the page, but it is probably easier to just drag the image to a location on the page.
4. **Position the pointer over the image, drag the picture to the left corner of the page, and drop the picture.**
   
   Your page should reflect Figure 5-20.

Once again, the use of Position Absolutely is not the best way to place images in a Web page. Instead, use a table to lay out the Web page, and organize the text and images in the table’s cells.

---

**Quick Reference**

To Position an Image:

1. Click on the image to select it.
2. Click the **Position Absolutely** button on the Pictures toolbar.
3. Click and drag the image to where you want it to appear on the screen.
Lesson 5-10: Adding a Background Image

Adding a background image adds visual interest to a Web page. The danger of using background images is that different browsers might interpret them differently, or they might clutter or confuse the rest of the information on the page. For example, dark text on a dark background will be difficult to read. Background images also require more time for the page to download. The rule of consistency also says that you should probably include the background image in all of the pages on your Web site. This lesson will show you how to add a background image.
Chapter Five: Working with Images

1. **Select Format → Background from the menu.**
   The Background tab of the Page Properties dialog box appears, as shown in Figure 5-21.

2. **Check the Background pictures box and click the Browse button.**
   The “Select a background picture” dialog box appears, displaying the images that are already in your Web site.

   **NOTE:** If you want to use one of the images that is already displayed here, select it and click OK to confirm the selection.

3. **Click the Select a file on your computer button in the Select Background Picture dialog box.**
   Another dialog box appears where you can navigate to another file on your computer to set for the background.

4. **Navigate to your Practice folder, select background image and click OK to confirm your selection.**
   The location and name of the file appear on the Background tab of the Page Properties dialog box.

5. **Click OK in the Page Properties dialog box to add the background image to your Web page.**
   The page is displayed with the new background. Looks pretty good, don’t you think? Notice how the background of the airplane image is white, which makes it stick out from the rest of the page. There’s a way to make its background transparent so it blends into the page better.

6. **Click the airplane image to select it, and click the Set Transparent Color button on the Pictures toolbar.**
   The cursor changes to a _REGISTRY_PARENT, indicating that you can click on the part of an image you want to make transparent.

7. **Click the _REGISTRY_PARENT on the white area of the airplane picture.**
   The white area changes to match the rest of the background. That looks more finished, don’t you think? On second thought, we don’t want this background for the entire Web site, so let’s delete it from this page.

8. **Click Format → Background from the menu, uncheck the Background pictures box and click OK to remove the background from the page.**
   Ah, back to plain white. Don’t be afraid to experiment with using a background image. When used correctly, this feature really can add a lot to a page; just make sure you’re not sacrificing readability for impressive graphics, and that you are consistent with all pages on the Web site.

---

Quick Reference

**To Set the Background Image:**
1. Select Format → Background from the menu.
2. Check the Background pictures box and click the Browse button.
3. Click the Browse button to navigate to the image you want to use.
4. Click the Select a file on your computer button in the Select Background Picture dialog box.
5. Select the image you want to use and click OK.
6. Click OK in the Page Properties dialog box.

**To Set Transparent Color:**
1. Select the image.
2. Click the Set Transparent Color button on the Pictures toolbar.
3. Point to the part of the image you want to change with the _REGISTRY_PARENT, and click.
Lesson 5-11: Creating a Thumbnail Image

Thumbnails are small versions of an image linked to a larger version of the same image. They are valuable assets because thumbnails download much faster than large images, without losing the ability to include large pictures on a Web page. Thumbnail images are great to use, especially if you have a page with a lot of pictures on it, like a photo gallery.

1. **If necessary, navigate to your Chapter 5 Practice Folder and open Lesson 5D.**
   
   Whoa! The picture barely fits inside the window! Notice the Estimated Download Time in the lower right of the window: 13 seconds over 28. This is isn’t too long to wait for a page to download, but making the pictures into thumbnails will make the time even shorter.

2. **Click the large image on the page to select it, and click the Auto Thumbnails button on the Pictures toolbar.**
   
   The picture automatically shrinks and is surrounded by a blue border to indicate that it is a link. Notice that the Estimated Download Time has shrunk to a fraction of the original time: only 2 seconds over 28.8!
Lesson 5-12: Adding Alternative Text to an Image

A general courtesy when developing a Web page is to include alternative text for each image on the page. This allows users with special accessibility needs to get the full experience of the page. Also, sometimes users will turn off the images option on their browser so that pages will download faster. Adding alternative text is an easy task to accomplish, and this lesson will show you how to do it.

1. Right-click the Temple of Apollo in Delphi image and select Picture Properties from the shortcut menu.
   The Picture Properties dialog box appears, as shown in Figure 5-28.

2. Type Scenic overlook of the temple and valley below in the Alternative representations text box, and click OK.
   If the image does not appear on the page, the words you typed will appear describing the image.

Quick Reference
To Set Alternative Text to an Image:
1. Right-click on the image you want to change, and select Picture Properties from the shortcut menu.
2. In the Alternative representations Text box, type the text you want to appear.
3. Click OK.
Lesson 5-13: Adding a Hyperlink to an Image

Images are important in making your page visually pleasing, but they can also serve a more functional purpose; they can act as hyperlinks. This lesson will show you how to do this nifty trick.

1. **Click the Temple of Apollo in Delphi image to select it.**
   Let’s add a hyperlink to a page that includes more information about Greek temples and religion.

2. **Click the Insert Hyperlink button on the Standard toolbar.**
   The Create Hyperlink dialog box appears. The page we want to link the image to is not already in the Web site, so you will have to navigate to your Practice folder.

3. **Select the Lesson 5A.htm page and click OK to return to FrontPage.**
   The image is outlined in blue, indicating that it is a hyperlink. Let’s see if the link works.
4. **Click the Preview tab in FrontPage.**
   The Preview tab is a quick and easy way to check hyperlinks.

5. **Press <Ctrl> and click the Temple of Apollo in Delphi image.**
   The Lesson 5A page appears.

6. **Click the Normal tab to return to the original page.**
   Do not be afraid to use images as hyperlinks. Linking images and pages of related information is a great way to provide more information on a topic.

---

**Quick Reference**

**To Add a Hyperlink to an Image:**

1. Select the image, and click the Insert Hyperlink button on the Standard toolbar.
   Or…
   Select Insert → Hyperlink from the menu.
   Or…
   Press <Ctrl> + <K>.
   Or…
   Right-click the image and select Hyperlink from the shortcut menu.
2. Navigate to the file you want to link and click OK to confirm your selection.

**To Test a Link:**

1. Click the Preview tab.
2. Press the <Ctrl> key and click the left mouse button at the same time.
Lesson 5-14: Working with Image Hotspots

There are more advanced ways to make an image into a link; by breaking it into hotspots. Hotspots are areas of an image that are linked to a different Web page. This is also called an image map. In this lesson, we’ll create hotspots on a map out of the featured countries in North Shore Travel: Italy, Greece, and Egypt.

1. Navigate to your Practice Chapter 5 folder, open the Hotspot web and open the index.htm page.

   We’re going to link three countries on the map (Italy, Greece, and Egypt) to relative pages on the Web site.

2. Click the map to select it, and click the Rectangular Hotspot button on the Pictures toolbar. The cursor changes into a ✂ pencil.

   This is the shape we’re going to use for the first hotspot along the borders of Egypt.
3. **Click on the lower right corner of the picture, and drag the box until it is around the borders of Egypt, as shown in Figure 5-31. Then drop the cursor.**

   The Create Hyperlink dialog box appears after you drop the cursor, as shown in Figure 5-32.

4. **Click the Egypt.htm page and click OK to create a hyperlink to that page.**

   Now, whenever someone clicks on the Egypt area, they will be linked to that page.

5. **Click the map to select it, and click the Circular Hotspot button on the Pictures toolbar. The cursor changes into a pencil.**

   This time let’s make a circle-shaped link around Greece.

6. **Click in the middle of the country Greece and drag the circle around Greece’s border, as shown in Figure 5-31, and drop the cursor.**

   Again, the Create Hyperlink dialog box appears.

7. **Select the Navel.htm page in the Create Hyperlink dialog box, and click OK.**

   You can adjust the location and size of the circle by using the shape’s handles.

   Now comes the tricky hotspot, the polygonal hotspot, which we’ll use for Italy.

8. **Click the map to select it, and click the Polygonal Hotspot button on the Pictures toolbar.**

   The polygonal hotspot allows you to draw your hotspot, instead of just using one general shape.

   **NOTE:** Always establish the points of the polygon in order when using a polygonal hotspot. For example, if establishing a country as a hotspot, click around the border as though you were tracing the border with the mouse cursor.

9. **Click the pencil on the border of Italy, drag the line, and click once again.**

   See how you drew a line between the two points where you clicked? Just keep tracing around the border of Italy until the two ends meet, as shown in Figure 5-31.

10. **When the ends meet, the Create Hyperlink dialog box appears. Click the Italy.htm page and click OK to create a hyperlink to that page.**

    Well, we’ve created the hotspots, now all we have to do is see if they work!

11. **Click the Preview tab, and drag the cursor over the map.**

    See how the pointer switches from an arrow to a pointing hand? The hand indicates that there is a link you can click. Let’s see if the Egypt link works.

12. **Press the <Ctrl> key and click on the Egypt hotspot to see if it works.**

    The Egypt page appears in FrontPage. Pretty neat, huh?

    If you want to preview the other links, use the Folder List to return to the index.htm page.

---

**Quick Reference**

**To Create an Image Hotspot:**

1. Click on the image where you want to create hotspots.
2. Click the button for the shape of hotspot you want to create.
3. Click and drag the shape to the size you want it to be, and let go of the mouse button.
4. Select the item you want to link the hotspot to in the Create Hyperlink dialog box, and click OK.

**To Preview a Hotspot:**

1. Click the Preview tab.
2. Press the <Ctrl> and click on the image.
Lesson 5-15: Changing Image File Formats

Images are generally set in the format that is best for the type of image they are. Depending on what you do to the image and how you want your page to look, you may want to change the format of an image. This lesson will show you how to do this.

NOTE: When possible, do not change image file formats in FrontPage. Instead use a graphics program such as PhotoShop or Fireworks.

1. Navigate to your Practice Chapter 5 folder, open the Hotspot web and open the Italy.htm page.

2. Click on the David image. Click Format → Properties → General tab from the menu.

   The General tab of the Picture Properties dialog box appears. Currently, the type of file is JPEG at 75 quality, and the Estimated Download time is 9 seconds over 28.8. Let’s see what happens if it’s changed to a GIF type file.

3. Click the GIF option to change the type, and click OK to confirm the change.

   You are returned to FrontPage. It doesn’t really look different, but notice the Estimated Download time: 26 seconds over 28! Go back and change the image to a JPEG file.
4. Click on the david image. Click Format → Properties → General tab from the menu. Click the JPEG option to restore the image to its original file type.

<table>
<thead>
<tr>
<th>File Types</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GIF</td>
<td>The colors in the image are limited to 256. These types of images are faster to download, but are not good for photograph images.</td>
</tr>
<tr>
<td>Transparent</td>
<td>Check this box to apply transparent color to the picture. Uncheck this box to make the picture non-transparent and return the picture to its normal color.</td>
</tr>
<tr>
<td>Interlaced</td>
<td>Check this box to display the picture with increasing detail as it is downloaded.</td>
</tr>
<tr>
<td>JPEG</td>
<td>Pictures of this type are ideal for photographs, because they support thousands or millions of colors.</td>
</tr>
<tr>
<td>Quality</td>
<td>You can specify the picture quality from 1 to 99; the default setting is 75. As Quality is increased, the picture file size is larger and download time is longer, but picture quality is improved. As Quality is decreased, the picture file size is smaller and download time is shorter, but picture quality is degraded.</td>
</tr>
<tr>
<td>Progressive passes</td>
<td>You can specify the number of layers of the image will be shown on the screen before it is finished downloading in the Web browser. If it is set at 0, the JPEG will not be shown on the screen until it is entirely downloaded.</td>
</tr>
<tr>
<td>PNG</td>
<td>The PNG format is an alternative to GIF that supports transparency for pictures containing thousands or millions of colors. However, some Web browsers cannot display PNG pictures without a special plug-in.</td>
</tr>
</tbody>
</table>

Quick Reference

To Change an Image File Format:
1. Select Format → Properties → General from the menu.
2. Check the box of the file format you want the picture to be.
Chapter Five Review

Lesson Summary

Adding an Image from a File

- Place the insertion point where you want to insert the image. Click Insert → Picture → From File from the menu.

Adding a ClipArt Image

- Place the insertion point where you want to insert the image. Click Insert → Picture → Clip Art from the menu. Click on the category of clip art images you want to insert. Click on the image you want to insert, and click the Insert Clip button from the menu.

Resize an Image

- Place the cursor over one of the handles until the cursor changes to a \( \uparrow \). Click and drag the handle until the image is the right size.

Moving an Image

- Click on the image. Drag the \( \downarrow \) cursor to where you want to move the image.

Copying an Image

- **To Copy an Image**: Click the Copy button on the Standard toolbar, or select Edit → Copy from the menu, or click the right-mouse button and select Copy from the shortcut menu.

- **To Paste an Image**: Click the Paste button on the Standard toolbar, or press \( \text{Ctrl} + \text{V} \), or, click the right-mouse button and select Paste from the shortcut menu.

Cropping an Image

- Select the image. Click the Crop button on the Pictures toolbar. Drag the mouse \( \rightarrow \) cursor over the part of the image you want to keep. Click the Crop button on the Pictures toolbar to delete the parts of the image outside the dashed line.

Adding a Border to an Image

- Click on the image you want to display with a border. Click Format → Properties → Appearance tab, or click the right mouse button, select Picture Properties from the shortcut list and click the Appearance tab, or press \( \text{Alt} + \text{Enter} \).

Aligning an Image with Text

- Click on the image you want to align. Click Format → Properties → Appearance tab, or click the right mouse button, select Picture Properties from the shortcut list and click the Appearance tab, or press \( \text{Alt} + \text{Enter} \). Select the alignment for the picture, and click OK.
Chapter Five: Working with Images

Positioning an Image
- Click on the image to select it. Click the Position Absolutely button on the Pictures toolbar. Click the Send Backward button on the Pictures toolbar to allow text to flow over the object, or click the Send Forward button to make the image float on top of text. Drag the image to where you want it on the screen.

Adding a Background Image
- To Add a Background Image: Click Format → Background from the menu. Check the Background pictures box, and click the Browse button. Click the Browse button to navigate to the image you want to use. Click the Select a file on your computer button in the Select Background Picture dialog box. Select the image you want to use and click OK. Click OK in the Page Properties dialog box.
- To Set Transparent Color: Select the image. Click the Set Transparent Color button on the Pictures toolbar. Point to the part of the image you want to change with the \, and click.

Creating a Thumbnail Image
- Select the image and click the Auto Thumbnails button on the Pictures toolbar.

Adding Alternative Text to an Image
- Right-click on the image you want to change, and select Picture Properties from the shortcut menu. In the Alternative representations Text box, type the text you want to appear. Click OK.

Adding a Hyperlink to an Image
- To Add a Hyperlink to an Image: Select the image, and click the Insert Hyperlink button on the Standard toolbar, or click Insert → Hyperlink from the menu, or press <Ctrl> + <K>, or right-click the image and select Hyperlink from the shortcut menu. Navigate to the file you want to link and click OK to confirm your selection.
- To Test a Link: Click the Preview tab, and press the <Ctrl> key and click the left mouse button at the same time.

Working with Image Hotspots
- To Create an Image Hotspot: Click on the image where you want to create hotspots, and click the button for the shape of hotspot you want to create. Click and drag the shape to the size you want it to be, and let go of the mouse button. Then select the item you want to link the hotspot to in the Create Hyperlink dialog box, and click OK.
- To Preview a Hotspot: Click the Preview tab, press <Ctrl>, and click on the image.

Changing Image File Formats
- Click Format → Properties → General. Select the button of the file format you want the picture to be.
Quiz

1. Which of the following statements is true?
   A. Thumbnail images are linked to larger versions of the image.
   B. A page with large image files on it will take less time to download than a page with small image files.
   C. Cropping an image decreases the size and quality of an image file by causing it to appear grainy.
   D. Alternative text appears just below an image on the page.

2. You want to insert a picture of your pet dog, Sparky, onto your Web site, but the only picture you have of Sparky includes the rest of the family. What is the best method you can use to focus on Sparky?
   A. Resize the image.
   B. Create a thumbnail image.
   C. Realign the image.
   D. Crop the image.

3. Changing the file format of an image will always cause the file size to decrease. (True or False?)

4. ClipArt images are usually in GIF format. (True or False?)

5. A blue border around an image means that:
   A. The reader has already visited the web site.
   B. The image is a link.
   C. There is alternative text behind the image.
   D. It was imported from the Internet.

6. You have created a web page with lots of pictures, but without much information for each image. What can you do to give the reader easy access to more information on the topic?
   A. Add a hyperlink from the image to another page of the same topic.
   B. Add alternative text to the image.
   C. Provide an address so they can send for a pamphlet on the topic.
   D. Create an e-mail form so they can forward their questions to you.

7. A hotspot is:
   A. The page that is most popular in a Web site.
   B. A link that is consistently clicked on a Web page.
   C. The area of a stove where one can get burned.
   D. An area of an image that is linked to another Web page.

8. Which one of these statements is NOT true?
   A. Background images increase the download time on a page.
   B. Moving an image on a page is the same as positioning an image on a page.
   C. Alternative text only appears if the reader has disabled the graphics viewer on the browser they are using.
   D. A border around an image adds a finishing touch to an image.
9. **Aligning an image causes the text near it to:**
   A. Wrap around the image.
   B. Float on top of the image.
   C. Change its alignment to the image’s alignment.
   D. Be displayed in HTML format.

10. **Which of these image file formats is NOT used on the Internet?**
   A. JPEG
   B. GIF
   C. BIT
   D. PNG

**Homework**

1. Start Microsoft FrontPage. Navigate to your Chapter 5 Practice folder and open the “Rocks” web.
2. Place your insertion point behind the last word in the second line, “source”. Press <Enter>, and insert the agate.bmp image from your Practice file.
3. Place your insertion point beneath the paragraph that begins “The most active hobby that involves rocks is rock climbing.” Press the Center button on the Standard toolbar.
4. Click Insert \rightarrow Picture \rightarrow Clip Art from the menu. Type “rocks” in the “Search for clips:” area of the Clip Art box, and insert the image of the rock climber.
5. Add a 3-pixel border to the image.
6. Right-align the image with the text.
7. Set the background of the page to the rockback.jpeg from the Practice folder.

**Quiz Answers**

1. A. Thumbnails are really just links to larger versions of the same image. Thumbnails are advantageous because you can have a large, quality picture on your web site without using a lot of download time.
2. D. Cropping an image not only reduces the size of an image file, it also allows you to focus on a particular area of the image.
3. False. Changing a JPEG file with millions of colors to a GIF file with 256 colors might seem like a good idea, but sometimes it just makes the image more difficult to download.
4. True. ClipArt images don’t require many colors, so they’re usually in GIF format.
5. B. Just like blue text signifies a link, an image with a blue border is a link.
6. A. Add a hyperlink from the image to another page of the same topic.
7. D. You could get burned on the hotspot of a stove, but in FrontPage, a hotspot is an area of an image that is linked to another Web page.
8. B. Positioning an image is different from moving an image because positioning an image affixes the image in an exact spot on the page.
9. A. Text wraps around an aligned image.
10. D. PNG files are not often used because some Web browsers cannot display them without a special plug-in.
Chapter Six: Working with Links and Navigation View

Chapter Objectives:

- Plan a Web Site
- Create a Link to Another Web Page
- Create a Link Within a Web Page
- Create an E-mail Link
- Check and Remove Links
- Create and Preview Hover Buttons
- Use Hyperlinks and Navigation View
- Add and Remove a Page in a Web Site in Navigation view
- Add Shared Borders
- Set Navigation Bar Properties

Chapter Task: Create Links and Work with Navigation View

The Internet has grown to become one of the primary sources of information and communication in the world. No other medium provides users with instant access to thousands of other resources on a given topic with the click of a few keys and buttons. Linking pages together with hyperlinks is one of the most popular ways to navigate through the Internet’s Web sites.

In the last chapter you learned a bit about how to make hyperlinks with images. This chapter will teach you even more about how to use hyperlinks to make your Web site as flexible, interesting, and informative as possible.
Lesson 6-1: Planning a Web Site

Like building a house, building a Web site takes planning. Before you build, you must answer a multitude of questions, such as: What information and how many pages will you include? What colors and images will go well together? What kind of audience am I making this Web site for?

Follow this brief list of guidelines before you begin building your Web site:

- **Set goals for the Web site:** Why are you building a Web site in the first place? What do you hope to accomplish with the site?

- **Design before you build, not after:** Designing your web site beforehand will not only make your job easier, it will make for a more complete, coherent site.

- **Plan for expansion:** The beauty of Web sites is that they can be modified to reflect changes over time. Try to organize your Web folder hierarchy so there is room for future pages.

- **Talk to people:** Gather feedback from people who will use the site so that you can determine which methods will help you achieve your goals. Talk to people interested in the Web site as well, such as employees and managers.

- **Be consistent:** A Web site with inconsistent pages can be very confusing to a user. A consistent look on each page will allow the user to focus on each page’s information without being distracted by visual changes.

- **Find a color scheme and stick to it:** This falls under the consistency rule. Also, the colors you pick will effect the images you use, so try to use neutral colors.

- **Acknowledge the key elements:** Keep your background simple, and bring out important elements of your Web site by using formatting techniques and strategically placing them on the page.

---

**Figure 6-1**
A Web site planning map

![Web site planning map](image)
• **Don't make users read too much**: Make everything easily accessible to them. Remember that the Web is a visual-based medium, so try to make your site visually pleasing. From a user’s viewpoint, if a site looks good, then its content is probably worth reading.

• **Prioritize your layout**: Place your most important pages at the top of the navigation structure, and work your way down.

• **Use your instincts**: If you’re stuck on something, trust your own taste. Chances are other people will like it too.
Lesson 6-2: Create a Link to Another Page in the Web Site

One of the easiest ways to create links is between pages within a Web site. Let's link the pages in the North Shore Travel web site using this process.

1. Navigate to your Chapter 6 Practice folder, open the Links web, and open the index page.
   If you've been following along, this page isn't new to you.

2. Scroll down the page and select Greece from the sentence that begins We specialize in Mediterranean travel, as shown in Figure 6-2.
   This is the text we want to use to create the link.
Chapter Six: Working with Links and Navigation View

3. **Click the Hyperlink button on the Standard toolbar.**
   
The Create Hyperlink dialog box appears with all the files in the current Web.
   
   There are a few different types of links you can create:
   
   - **Use your Web Browser to select a page or file:** You can use a browser to find a page you want to link to on the Internet.
   
   - **Select a file on your computer:** Search for and create a link to a file on your computer.
   
   - **Make a hyperlink that sends e-mail:** When it is clicked, this type of hyperlink opens an e-mail message with the correct address already entered.
   
   - **Create a page and link to the new page:** You can create a link to an empty page, and then enter the contents of the page later.

   For this lesson however, we want to create a link to another page on the Web, the Greece page, so you don’t have to use any of these buttons.

4. **Click the Greece.htm page in the Create Hyperlink dialog box, and click OK.**
   
The word “Greece” appears blue and underlined, indicating that FrontPage has created the link. You can also create links to the other two countries with Web pages, Italy and Egypt.

5. **Select Italy from the sentence that begins We specialize in Mediterranean travel, click the Hyperlink button on the Standard toolbar, click on the Italy.htm page in the dialog box, and click OK.**
   
   A link is created to the Italy page. Now create one last link to the Egypt page.

6. **Select Egypt from the sentence that begins We specialize in Mediterranean travel, click the Hyperlink button on the Standard toolbar, click on the Egypt.htm page in the dialog box, and click OK.**
   
The names of all three countries are linked to their own pages. That’s how to link to Web pages within your own Web site.

7. **Close the Index page.**

---

**Quick Reference**

To Create a Link to Another Page in the Web Site:

1. Select the text to which you want to create the hyperlink.
2. Click the **Insert Hyperlink** button on the Standard toolbar.
3. Click on the Web page in the Insert Hyperlink dialog box, and click **OK.**

---

**Hyperlink button**

Other Ways to Create a Hyperlink:

- Select **Insert → Hyperlink** from the menu.
- Press `<Ctrl>` + `<K>`. 

---
Lesson 6-3: Create a Link to Another Page on the Internet

The ability to connect your Web site to remote Web sites on the Internet is one of the best ways to provide your users with more information on your own site’s topic. This lesson will show you how to do this task.

1. If necessary, navigate to your Chapter 6 Practice folder, open the Links Web site, and open the Egypt page.

   You have some information on your Web site about Egypt, but would like to provide your users with even more information. Setting up a hyperlink to another Web site about Egypt is a great way to do just that.

2. Place the insertion point below the Back to North Shore Travel hyperlink and type Click here to connect to Egypt.com, as shown in Figure 6-5. Then select Egypt.com from the text you just typed.

   This is the text that will be made into the hyperlink.

3. Click the Hyperlink button on the Standard toolbar.

   The Create Hyperlink dialog box appears.
4. Type `www.egypt.com` in the **URL:** box of the Create Hyperlink dialog box, and click **OK.**

The text becomes blue and underlined, indicating that this page is linked to your Web site. This link will allow readers to jump to the Egypt.com page on the Internet.

---

**Quick Reference**

To Create a Link to Another Page on the Internet:

1. Select the text with which you want to create the hyperlink.
2. Click the **Hyperlink** button on the Standard toolbar.
3. Type the Internet address in the **URL:** box, and click **OK.**
Lesson 6-4: Create a Link within a Web Page

Hyperlinks are not only useful for jumping from one Web page to another, they are also useful for quickly sending readers to another section of the same Web page. These sections are marked with bookmarks. This lesson will show you how to create bookmarks, and how to create hyperlinks within a page using bookmarks.

1. **Open the index page.**
   There is some important information at the end of the page, but you want to enable users to get that information without having to scroll all the way down to the bottom of the page.

2. **Scroll down the page. Select the Luxor, Egypt heading, as shown in Figure 6-7.**
   You’re going to make bookmarks out of all four countries shown in Figure 6-7, starting with Egypt.
3. Select **Insert → Bookmark** from the menu.
   The Bookmark dialog box appears, as shown in Figure 6-6. We don’t need to change the name of the bookmark, so go on to the next step.

4. Click **OK** in the Bookmark dialog box.
   You are returned to the index.htm page, where the Luxor, Egypt text is underlined by a dashed line. Now repeat this process to create bookmarks for the next three headings on the page.

5. Select **Athens, Greece**, select **Insert → Bookmark** from the menu, and click **OK** in the Bookmark dialog box. Repeat this process two more times, for **Florence, Italy** and **Rethymnon, Crete**.
   After the Rethymnon, Crete bookmark is created, the Bookmark dialog box should appear with all four options, as shown in Figure 6-6.

   Now that the bookmarks have been made, you can create links to them.

6. Scroll up the page to the numbered list of countries, and select **Luxor, Egypt**. Click the **Hyperlink button** on the Standard toolbar.
   The Create Hyperlink dialog box appears. You’ve been here before, but this time you’re going to use a part of the dialog box that you haven’t used.

7. Click the **Bookmark** drop-down list in the Create Hyperlink dialog box, as shown in Figure 6-8. Select **Luxor, Egypt**, and click **OK**.
   The link from Luxor, Egypt in the list, to Luxor, Egypt the bookmark is created.

   Now the other three bookmarks need to be linked to the list.

8. Select **Athens, Greece** from the list of countries, click the **Hyperlink button**, select **Athens, Greece** from the **Bookmark** drop-down list, and click **OK**. Repeat this step for **Florence, Italy** and **Rethymnon, Crete**.
   Now each country in the list is linked to its bookmark on the page.

---

### Quick Reference

**Hyperlink button**

Other Ways to Create a Hyperlink:
- Select **Insert → Hyperlink** from the menu.
- Or…
- Press `<Ctrl> + <K>`.

---

**To Create a Bookmark:**
- Select the text with which you want to create the bookmark.
- Select **Insert → Bookmark** from the menu.
- Enter the name of the bookmark in the **Bookmark** dialog box, and click **OK**.

**To Create a Link within a Web Page:**
1. Select the text to which you want to create the hyperlink.
2. Click the **Hyperlink** button on the Standard toolbar.
3. Click the **Bookmark** drop-down list in the Create Hyperlink dialog box, and select the bookmark to which you want to create the hyperlink, and click **OK**.
Lesson 6-5: Create an E-mail Link

An e-mail link allows users to interact with you, the Web site creator. This allows users to give feedback, ask questions, or simply begin a correspondence.

1. **Open the index page.** Press `<Ctrl> + <End>` to jump to the end of the page. Select the name **Sally Smith**.
   This is the text you want to use for the link. Usually the name of the site's webmaster is the text you will use for the e-mail link.

2. **Click the Hyperlink button** on the Standard toolbar.
   The Create Hyperlink dialog box appears.

3. **Click the Make a hyperlink that sends E-mail button** in the Create Hyperlink dialog box.
   The Create E-mail hyperlink dialog box appears, as shown in Figure 6-10.
4. **Type smith@customguide.com, the e-mail address that the message will be sent to, and click OK.**
   When the hyperlink is clicked, this address will automatically appear in the To: part of the e-mail.

5. **Click OK in the Create Hyperlink dialog box to create the e-mail link.**
The text appears underlined in blue, indicating that FrontPage has created the link.

---

**Quick Reference**

**To Create an E-mail Link:**

1. Select the text you want to use for the link.
2. Click the Hyperlink button on the Standard toolbar.
3. Click the Make a hyperlink that sends E-mail button in the Create Hyperlink dialog box.
4. Type the e-mail address that the message will be sent to in the Create E-mail Hyperlink dialog box, and click OK.
5. Click OK in the Create Hyperlink dialog box to create the e-mail link.
Lesson 6-6: Check a Link in Preview View

Once you’ve made a link, you want to make sure it actually works. One quick and easy way to check a hyperlink is with Preview view because it is a limited version of a Web browser. This lesson will show you how to preview your hyperlinks.

1. Open the Greece page.
   The first thing you need to do is change the view to Preview view.

2. Click the Preview tab at the bottom of the window.
   The page appears similar to how it would appear in a Web browser.
3. Scroll down to the bottom of the page. Place the cursor over the **North Shore Travel** link so the cursor changes to a 🖱️ pointing hand.
Whenever the cursor moves over a hyperlink in a Web browser or in Preview view, it changes into a pointing hand.

4. **Press and hold the <Ctrl> key as you click the mouse.**
The home page appears on the screen, which means the link works successfully.

---

**Quick Reference**

To Check a Hyperlink in Preview View:

1. Click the **Preview** tab.
2. Place the mouse cursor over the hyperlink, so the cursor changes to a 🖱️ pointing hand.
3. Hold down the <Ctrl> key as you click the hyperlink.
Lesson 6-7: Check a Link in Reports View

To Check a Link in Reports View:

1. Open the index page of the Links Web site. Click the Reports button on the Views bar.
   Reports view breaks down all the elements of your Web site so you can easily view its contents. Bring up the Reports toolbar so you can check your links.

2. If necessary, select View → Toolbars → Reporting from the menu.
   The Reporting toolbar appears in the window, as shown in Figure 6-14.

3. Click the Verify Hyperlinks button on the Reporting toolbar to check the links on your Web site.
   The Verify Hyperlinks dialog box appears, as shown in Figure 6-15.

4. Click the Verify all hyperlinks option and click Start.
   FrontPage prepares a Broken Hyperlinks report on the status of your Web site’s links, as shown in Figure 6-16. The report declares the status of the link, the name of the link, and the page it is on so it is easy to find and repair.

Of course, after you’ve made all your links, you will want to check to see if they actually work. You’ll also have to check your hyperlinks intermittently to make sure that the pages they are linked to still exist. This lesson will show you how to do this.

Figure 6-14
Reports view shown with the Reporting toolbar

Figure 6-15
The Verify Hyperlinks dialog box

Figure 6-16
The Broken Links Report

Quick Reference

To Check a Link in Reports View:

1. Click Reports button on the Views bar.
2. Select View → Toolbars → Reporting from the menu.
3. Click the Verify Hyperlinks button on the Reporting toolbar.
4. Click the Verify all hyperlinks option and click Start.
Lesson 6-8: Remove a Link

Fortunately, hyperlinks aren’t permanent. If you choose to delete a hyperlink, it is easily removed. You’ll find that in the fast-paced world of the Web, you have to update and remove hyperlinks to pages that don’t exist, or that no longer have relevant information.

1. Click the Page button in the Views bar.
   You are in the default Page view.
2. Place the insertion point in the Italy link, and click the Hyperlink button on the Standard toolbar.
   The Edit Hyperlink dialog box displays information for the link.
3. Select the Italy.htm text in the URL: box, press the <Delete> key, and click OK to confirm the deletion.
   That’s all there is to removing a hyperlink! The text on the Web page is no longer blue and underlined, indicating that it is no longer a link.
   This is a link we actually want to save though, so let’s restore the link.
4. Press <Ctrl> + <Z> to undo the deletion.
   The text is blue and underlined, indicating that it is a link once again.

Figure 6-17
The Edit Hyperlink dialog box

Hyperlink button
Other Ways to Remove a Link:
• Press <Alt> + <Enter>, and select the link you want to remove.
• Right-click the link and select the Hyperlink Properties option.

Quick Reference
To Remove a Link:
1. Place the insertion point in the link, and click the Hyperlink button on the Standard toolbar.
2. Select the text in the URL: box in the Edit Hyperlink dialog box.
3. Press the <Delete>, and click OK to confirm the deletion.
Lesson 6-9: Create a Link with a Hover Button

A hover button looks like a normal button, but it has animated qualities. Whenever a mouse cursor moves over a hover button, the button changes. For example, a yellow hover button could turn blue when a cursor points to it. Hover buttons are especially useful as hyperlinks, which is a refreshing change from the standard blue, underlined hyperlink text.

**NOTE:** Hover buttons are components that are exclusive to Microsoft. Therefore, you will have to view your Web pages in different browsers to make sure the component works with non-Microsoft software. To learn more about components, refer to Chapter 13 – FrontPage Components.

1. **Open the index page. Scroll to the bottom of the page.**
   You want to insert hover buttons to each of the three countries featured in the Web site: Egypt, Italy, and Greece.

2. **Select Insert → Component → Hover Button from the menu.**
   The Hover Button Properties dialog box appears. Notice that the hover button has been inserted into the Web page. All you need to do now is verify the button’s link, and how the button appears on the Web page.
   Create the first hover button for the Egypt page.

3. **Type Egypt in the Button text box.**
   Whatever is typed in the Button Text box will appear on the button.
   Now verify what the button is linked to.
4. Click the **Browse** button.
The Select Hover Button Hyperlink dialog box appears.

5. **Select Egypt.htm from the Links Web site folder. Click OK.**
If the Web site folder doesn’t appear in your window, use the Look in list to navigate to where the site is located.
You are back at the Hover Button Properties dialog box. Now just choose the colors you want for the button and the effect.

6. **Click the Button Color drop-down list. Select Red from the color list.**
The button will appear red with the Egypt text on it in the Web page.

7. **Click the Effect Color drop-down list. Select Black from the color list.**
That’s all for the Egypt button. If you want to check to make sure the button’s properties are correct, compare your dialog box to Figure 6-18.

8. **Click OK.**
The dialog box closes. Now create buttons for Greece and Italy.

9. **Press <Enter> to start a new paragraph. Select Insert → Component → Hover Button from the menu.**
The Hover Button Properties dialog box appears once again.

10. **Type Greece in the Button text box. Type Greece.htm in the Link to box.**
Instead of navigating to the Greece Web page with the Browse button, you can also enter the file name in the Link to box. This is the quickest method if you know the file name or URL of the page you want to link the button to.

11. **Click the Button Color drop-down list. Select Blue from the color list.**
**Click the Effect Color drop-down list. Select White from the color list.**
**Click OK.**
Just one button left: Italy.

12. **Press <Enter> to start a new paragraph. Select Insert → Component → Hover Button from the menu. Type Italy in the Button text box, and type Italy.htm in the Link to box.**
All that’s left is defining the colors for the button.

13. **Click the Button Color drop-down list. Select Green from the color list.**
**Click the Effect Color drop-down list. Select Red from the color list.**
**Click OK.**
What if you want to change how a button is formatted after it has been created?

14. **Right-click the Greece button. Select Hover Button Properties from the shortcut menu.**
The Hover Button Properties dialog box appears. The effect type for the Greece button is too bright. Change the type of effect to Light Glow.

15. **Click the Effect drop-down button. Select Light Glow from the list.**
The Greece text on the button will be easier to see with this effect.
If you’re ambitious, there are many other things you can do with hover buttons under the Customize button.

16. **Save your work.**
Lesson 6-10: Creating Image Hover Buttons

In the previous lesson you learned about how you can create a hyperlink using a hover button to add a little pizzazz to your Web page. You can make your hover buttons even more advanced by displaying the button as an image, and making its hover effect another image. The effect is kind of like flipping a coin; the coin has an image on one side, but when the coin is flipped, a different image is shown.

1. **Open the index page.**
   We’re going to add another hover button to this page, but this time, it will be an image hover button. The button will be the heads of a coin, and the hover effect will be the tails of a coin.

2. **Scroll to the bottom of the page. Type Spend pennies when you travel with North Shore!, and press <Shift> + <Enter>.**
   The hover button won’t have text on it to identify what it does since it’s an image, so the text will give the user a hint of what the button is linked to.

3. **Select Insert → Component → Hover Button from the menu.**
   The Hover Button Properties dialog box appears.
4. **Click the Custom button in the dialog box.**
The Custom dialog box appears. Here you can choose a sound or an image to go with the hover button. Let’s experiment with images for now.

5. **Click the top Browse button in the Custom section of the Custom dialog box.**
The Select Picture dialog box appears.

6. **Navigate to your Practice folder.**
The image you’re looking for is in the Practice folder. Ask your instructor for help if you don’t know where your practice folder is, or if you don’t know how to navigate to it.

7. **Select the CoinHead.jpg file. Click OK until you return to the Custom dialog box.**
The CoinHead file appears in the Button text box of the Custom dialog box. Now set the image that will appear for the hover effect.

8. **Click the bottom Browse button in the Custom section of the Custom dialog box. Navigate to your Practice folder.**
Ask your instructor for help if you don’t know where your practice folder is.

9. **Select the CoinTails.jpg file. Click OK until you return to the Custom dialog box.**
The CoinTails file appears in the On hover text box of the Custom dialog box. Now that you have defined the location of the images you want to use for the hover button, you can finish the process.

10. **Click OK to close the Custom dialog box.**
You are returned to the Hover Button Properties dialog box.
You are not sure how large the images are going to be, and you are not going to have any text on the hover button, so clear these text boxes in the dialog box.

11. **Delete the contents of the Button text box, and the Width and Height boxes.**
When these boxes are empty, the image has the freedom to appear in the correct size.

12. **Click OK.**
The Hover Button Properties dialog box closes, and the CoinHead image appears on the screen.

13. **Save your work.**

---

Quick Reference

To Create an Image Hover Button:

1. Select **Insert → Component → Hover Button** from the menu.
2. Click the **Custom** button.
3. Click the Button image **Browse** button.
4. Navigate to and select the image you want to use for the button.
5. Click **OK** until you return to the Custom dialog box.
6. Click the On hover **Browse** button.
7. Navigate to and select the image you want to use for the hover effect.
8. Click **OK** until you return to the Custom dialog box.
9. Click **OK** to close the Custom dialog box and return to the Hover Button Properties dialog box.
10. Delete all text in the **Button Text** box, and the **Width** and **Height** boxes.
11. Click **OK.**
12. Save your work.
Lesson 6-11: Previewing Hover Buttons

Once you have created your hover buttons, no doubt you want to see how the cool effects work for yourself. You will need to preview your hover buttons differently depending on what type of hover button you have created. Regular hover buttons can be viewed in the Preview tab of Page view. However, image hover buttons must be viewed in a browser so the Java script can be applied to the button.

1. Click the Save button on the Standard toolbar.
   Before hover buttons can be viewed, they must be saved to the Web site folder. Otherwise, they won’t work at all, no matter where you view them.

2. Click the Preview tab.
   Scroll down to the hover buttons.

You must have Java installed on your computer to preview the hover effect.
3. **Place your mouse cursor over the Egypt, Greece, and Italy buttons.**
   You can see how the hover effect changes the button.
   Notice that there is a gray box where the image hover button is supposed to be. Doesn’t it work? Actually, the image hover button needs to be viewed in a browser for it to work. Why? Because of the Java script is in the browser, but not the FrontPage program.

4. **Click the Preview in Browser button on the Standard toolbar.**
   The Web page appears in the browser. Now you can see if the image hover button works.

5. **Place your mouse cursor over the coin image.**
   The image flips to show the other side of the coin. Pretty neat, eh?

6. **Close the browser and return to the FrontPage window.**
   Previewing your hover buttons is an important step. Make sure you take the time to preview them not only in FrontPage and your own browser, but in other browsers like Netscape Navigator as well.

---

### Quick Reference

**To Preview a Hover Button Effect:**
1. Save the Web page.
2. Click the **Preview** tab in Page view.
3. Place your mouse cursor over the hover button to see the effect.

**To Preview an Image Hover Button Effect:**
1. Save the Web page.
2. Click the **Preview in Browser** button on the Standard toolbar.
3. Place your mouse cursor over the hover button to see the effect.
Lesson 6-12: Using Hyperlinks View

Hyperlinks view provides information on each link to and from every page in your Web site. All you have to do is click on a page in the Folder List while in Hyperlinks view, and FrontPage will display the links to and from the Web page.

1. Open the index page of the Links Web site. Click the Hyperlinks button in the Views bar.
   FrontPage displays all the hyperlinks to the index.htm page. Notice that there are links both to and from the index.htm page. Try to connect all the pages on your Web site back to the home page. That way, you will have no dead ends on your Web site. If you want to see the links to one of the other pages, just click on the page in the Folder List.

2. Click the Greece.htm page in the Folder List.
   FrontPage displays the Greece page in hyperlinks view, as shown in Figure 6-25.

Quick Reference

To Use Hyperlinks View:
- Click Hyperlinks button in the Views bar.

To View Links of an Individual Page:
1. Click Hyperlinks button in the Views bar.
2. Click the page in the Folder List.
Lesson 6-13: Using Navigation View

Navigation view allows you to insert navigational features on your Web pages, such as navigation bars. Each page included in the navigational structure in Navigation view is included in these navigational features.

1. **Open the index page of the Links Web site. Click the Folder List button on the Standard toolbar.**
   All the pages and images in the Web site appear in the Folders list.

2. **Click the Navigation button on the Views bar.**
   The Web site is displayed in Navigation view, as shown in Figure 6-26.

   **NOTE:** If you scroll down the Folder list, you will notice that some pages are not shown in the Navigation View. This is because FrontPage doesn’t automatically set up the Navigation view when you create a Web site. So, if you open Navigation view and the window is blank, or it shows just one page, you have to add Web pages to Navigation view on your own.
Lesson 6-14: Add a Page to a Web Site in Navigation View

Adding a Web page to your site isn’t very difficult in Navigation view. In fact, it is similar to clicking and dragging text to a new location. Adding pages to Navigation view is important because Navigation view determines which pages are included as navigation buttons in shared borders.

1. **Click the Navigation button in the Views panel, and click the Folder List button to display the pages in the site.**

   Navigation view shows four pages. As you can see in the Folder List, there are a few more pages we can add to the site.

2. **Click the religion.htm page in the Folder List and drag and drop it under the Greece page.**

   A gray outline shows where the page will be added, as shown in Figure 6-28.

3. **Click the Site Gallery.htm page, and drag and drop it on the middle level.**

   Click the SnowFlakers.htm page, and drag and drop it under the Egypt.htm page.

   The site appears with all the pages in the site, as shown in Figure 6-28.
Lesson 6-15: Remove a Page from a Web Site in Navigation view

Removing a Web page from a Web site is just as easy as adding one.

1. **Click the Navigation button in the Views bar.**
   The site’s structure is displayed. The Snowflakers page doesn’t really belong though, so let’s remove it from the structure.

2. **Click on the Snowflakers page and press the <Delete> key.**
   The Delete Page dialog box appears. You can do two different things with the page when you delete it:
   - **Remove this page from all navigation bars:** FrontPage removes the page from the Web site structure, but not from the Web site.
   - **Delete this page from the Web:** FrontPage deletes the page from the structure and the Web site.

3. **Select the Delete this page from the Web option and click OK.**
   The page has no relevance to the rest of the site, so we can erase it from the site. You probably will want to keep the page in the Web site most of the time in case you find that you need it later.

---

**Quick Reference**

To Remove a Page from a Web Site:
1. Click on the page you want to delete in Navigation view.
2. Press the <Delete> key.
3. Select Remove this page from all navigation bars or Delete this page from the Web from the dialog box, and click OK.
Lesson 6-16: Add Shared Borders

Shared borders can be useful features to add to your Web site. They can make navigating your Web site easier, and they provide a uniform structure for each of the site’s pages. You can also use shared borders to provide information on each page in your Web site. For example, you can put copyright information in a shared border at the bottom of a page, and automatically apply that same border to each page in the Web site. Before you decide that shared borders are the greatest things since penicillin, however, find out how they work in this lesson.

1. If necessary, navigate to your Chapter 6 Practice folder and open the Navigation web. Open the index page.
   We’ll work on the shared borders from the home page of the Web site.

2. Select Format → Shared Borders from the menu.
   The shared borders dialog box appears, as shown in Figure 6-31. For this Web site we want to apply the borders to all of the pages, appearing on the left side of the page.

3. Click the All pages option, check the Left option, and click OK to confirm your selection.
   FrontPage automatically applies the border to all of the pages. (It may take a few seconds for FrontPage to apply the borders, so be patient.) Currently, the border doesn’t have anything in it.

   **NOTE:** If you apply themes to your site, FrontPage will automatically change the text hyperlinks in the borders, into the navigation buttons of the theme you choose.
**Quick Reference**

**To Insert a Shared Border:**

1. Select Format → **Shared Borders** from the menu.
2. Check the **All Pages** option to apply the shared border to every page in the Web site.

Or...

    Check the **Current Page** option to apply the shared border only to the current page.

3. Select the check box where you want to enable a shared border on the page(s).
4. Click **OK**.

---

*How do shared borders work?* Shared borders are actually a Microsoft meta tag. Meta tags tell browsers how to set up the Web page in the browser window. The tag tells the browser to leave some space on the edge of a page for the shared border. The problem is that you don’t have total control over the shared border space, and browsers may interpret the meta tag differently.

This use of tags and allocation of space is generally not an accepted practice in Web design. Web designers generally will use tables to designate space on a page because it is more reliable and precise.

Therefore, try not to use shared borders. Instead, use frames or tables to create a similar effect.
Lesson 6-17: Add Navigation Bars and Change Properties

Navigation bars are not optional in the construction of Web sites; they are necessary. Without them, users would be left disoriented and frustrated with the Web site, never to return again. Navigation bars make return visits more likely; they provide a consistent, easy-to-use means of moving around the Web site.

What features make navigation bars helpful tools for navigation in a Web site?

- **A navigation bar includes links to pages in the Navigation view structure:** This can be tricky, because if a page is not in the Navigation view structure, it won’t appear on the navigation bar.
- **Navigation bars can appear on each page of the Web site:** The continuity of this feature makes navigation through the Web site intuitive and easy to follow.

If these features are applied to your Web site, it will be more consistent, user-friendly, and organized.
1. **Open the Navigation web index.htm page.**
   If you did not follow the previous lesson on shared borders, do the following: Click Format → Shared Borders from the menu. In the Shared Borders dialog box, click the “All pages” option, check the “Left” option, and click OK to confirm your selection. Now go on to the next step.

2. **Select Format → Shared Borders from the menu.**
   The Shared Borders dialog box appears, as shown in Figure 6-33.

3. **Check the Include navigation buttons option be the Left option in the dialog box, and click OK.**
   The shared border on the left side of the index page appears with hyperlinks. Once navigation bars are added in a shared border, you can change their properties.

4. **If necessary, click the Folder List button to open the Folder List and open the Egypt.htm page.**
   The page appears with a left-shared border, but without a navigation bar. Why? The Navigation bar properties are not set for this page.

5. **Right-click on the text in the shared border, and select Navigation Bar Properties from the shortcut menu.**
   The Navigation Bar Properties dialog box appears, as shown in Figure 6-34. There are many options from which to choose, as far as which hyperlinks you want to be shown in the navigation bar. Refer to Table 6-1: Navigation Bar Properties for more information.

6. **Select the Same level option and check the Home page option.**
   Your dialog box should reflect Figure 6-34.

7. **Click OK.**
   The page appears with a navigation bar in the left-shared border.

### Table 6-1: Navigation Bar Properties

<table>
<thead>
<tr>
<th>Hyperlinks to add to page options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent Level</td>
<td>The Parent level is one level above the active page, as shown in the blue boxes of this diagram.</td>
</tr>
<tr>
<td>Same Level</td>
<td>Choose this option to include hyperlinks to the other page(s) on the same level as the active page.</td>
</tr>
<tr>
<td>Back and Next</td>
<td>Choose this option to include hyperlinks to page(s) on the same level as the active page.</td>
</tr>
<tr>
<td>Child Level</td>
<td>Choose this option to include hyperlinks to the page(s) below the level of the active page.</td>
</tr>
<tr>
<td>Top Level</td>
<td>Choose this option to include hyperlinks to the page(s) on the same level as the home page.</td>
</tr>
<tr>
<td>Child Pages under Home</td>
<td>Choose this option to include hyperlinks to child pages under the Home page. This is useful if your web is divided into main sections under the home page</td>
</tr>
<tr>
<td>Home page</td>
<td>Check this option to include a hyperlink to the home page</td>
</tr>
<tr>
<td>Parent page</td>
<td>Check this option to include a hyperlink to the parent page</td>
</tr>
</tbody>
</table>

### Other Ways to Access Navigation Bar Properties:
- Press `<Alt> + <Enter>`

---

**Quick Reference**

To Add a Navigation Bar:
1. Select Format → Shared Borders from the menu.
2. Check Include navigation buttons in the dialog box.
3. Click OK.

To Change Navigation Bar Properties:
1. Right-click on the Navigation bar.
2. Select Navigation Bar Properties from the shortcut menu.
3. Check any additional options for hyperlinks.
4. Click OK.
Chapter Six Review

Lesson Summary

Planning a Web Site

- Consider the purpose of your Web site, the topics you want to cover in its Web pages, and plot out a map of how it will be organized.

Create a Link to Another Web Page in the Web Site

- Select the text to which you want to create the hyperlink. Click the Hyperlink button on the Standard toolbar. Click on the Web page in the Create Hyperlink dialog box, and click OK.

Create a Link to Another Page on the Internet

- Type the Internet address of the page you want to link to. FrontPage identifies the address, and creates the link for you. Select the text you want to link, and click the Hyperlink button on the Standard toolbar. Type the Internet address in the URL: box, and click OK.

Create a Link within a Web Page

- To Create a Bookmark: Select the text to which you want to create the bookmark. Select Insert → Bookmark from the menu. Enter the name of the bookmark in the Bookmark dialog box, and click OK.

- To Create a Link within a Web Page: Select the text to which you want to create the hyperlink. Click the Hyperlink button on the Standard toolbar. Click the Bookmark drop-down list in the Create Hyperlink dialog box, select the bookmark to which you want to create the hyperlink, and click OK.

Create an E-mail Link

- To Create an E-mail Link: Select the text to which you want to create the bookmark. Click the Hyperlink button on the Standard toolbar. Click the Make a hyperlink that sends E-mail button in the Create Hyperlink dialog box.

- To Create a Link to Another Page in the Web Site: Select the text to which you want to create the hyperlink. Click the Hyperlink button on the Standard toolbar. Click on the Web page in the Create Hyperlink dialog box, and click OK. Type the e-mail address that the message will be sent to in the Create E-mail Hyperlink dialog box, and click OK. Click OK in the Create Hyperlink dialog box to create the e-mail link.

Check a Link in Preview View

- Click the Preview tab. Place the mouse cursor over the hyperlink, so the cursor changes to a pointing hand. Press <Ctrl> + Click the mouse.
Check a Link in Reports View

- Click **Reports** on the Views bar. Select **View** → **Toolbars** → **Reporting** from the menu. Click the **Verify Hyperlinks** button on the Reporting toolbar. Click the **Verify all hyperlinks** option and click **Start**.

Remove a Link

- Place the insertion point in the link, and click the **Hyperlink** button on the Standard toolbar. Select the text in the URL: box in the Edit Hyperlink dialog box. Press the **<Delete>** , and click **OK** to confirm the deletion.

Create a Link with a Hover Button

- **To Create a Hover Button:** Select **Insert** → **Web Component** from the menu and select **Dynamic Effects** in the left column and **Hover Button** in the right column. Click the **Finish button** and type the name of the button in the Button text box. Type the filename or URL of the Web page you want to link the button to or click the **Browse** button to navigate to the Web page you want to link the button to. Then, click the **Button Color** drop-down list arrow to select the button’s color, click the **Effect Color** drop-down list arrow to select the button’s color, and click the **Effect** drop-down list and select the effect you want. Click **OK**.

- **To Change Hover Button Properties:** Right-click the button and select **Hover Button Properties** from the shortcut menu or select the button and press **<Alt>** + **<Enter>**.

Creating Image Hover Buttons

- Select **Insert** → **Web Component** from the menu, select **Dynamic Effects** in the left column and **Hover Button** in the right column and click the **Finish button**. Click the **Custom** button and click the Button image **Browse** button. Navigate to and select the image you want to use for the button. Click **OK** until you return to the Custom dialog box. Click the On hover **Browse** button and navigate to and select the image you want to use for the hover effect. Click **OK** until you return to the Custom dialog box. Click **OK** to close the Custom dialog box and return to the Hover Button Properties dialog box. Delete all text in the **Button Text** box and the **Width** and **Height** boxes, and click **OK**.

Previewing Hover Buttons

- **To Preview a Hover Button Effect:** Save the Web page and click the **Preview** tab in Page view. Place your mouse cursor over the hover button to see the effect.

- **To Preview an Image Hover Button Effect:** Save the Web page and click the **Preview in Browser** button on the Standard toolbar. Place your mouse cursor over the hover button to see the effect.

Using Hyperlinks View

- **To Use Hyperlinks View:** Click **Hyperlinks** in the Views bar.

- **To View Links of an Individual Page:** Click **Hyperlinks** in the Views bar. Click the page in the **Folder List**.

Using Navigation View

- Click the **Navigation** button on the Views bar.
Add a Page to a Web Site in Navigation View

- Click the page you want to add in the Folder List. Click and drag the page to the location in the Navigation page where you want to add the page.

Remove a Page from a Web Site in Navigation View

- Click on the page you want to delete in Navigation view. Press the <Delete> key. Select Remove this page from all navigation bars or Delete this page from the Web from the dialog box, and click OK.

Add Shared Borders

- Click Format → Shared Borders from the menu. Check the All Pages option to apply the shared border to every page in the Web site, or check the Current Page option to apply the shared border only to the current page. Select the check box where you want to enable a shared border on the page(s). Click OK.

Add Navigation Bars and Change Properties

- To Add a Navigation Bar: Click Format → Shared Borders from the menu. Check Include navigation buttons in the dialog box.
- To Change Navigation Bar Properties: Click OK. Right-click on the Navigation bar. Select the Hyperlinks to add to page option that you want to use. Check any additional options for hyperlinks. Click OK.
Quiz

1. Shared borders can be displayed on what part of a Web page? (Select all that apply.)
   A. Bottom
   B. Right
   C. Left
   D. Top

2. Which of the following statements is NOT true?
   A. Hyperlinks can exist within a Web page.
   B. Hyperlinks can be added in Navigation view.
   C. Hyperlinks within a Web site are displayed in Hyperlinks view.
   D. Hyperlinks can appear in any color on a page.

3. Preview view is a way to check a hyperlink. (True or False?)

4. You can add a page to a Web site in Normal view. (True or False?)

5. What are some reasons you would create a hyperlink? (Select all that apply.)
   A. To provide the reader with more information on the topic.
   B. Without hyperlinks, your page is boring.
   C. To add variety to the Web page.
   D. To get feedback about the site.

6. What are bookmarks used for in FrontPage?
   A. Keeping track of favorite Web sites.
   B. Marking tasks that still need to be finished.
   C. Editing spelling or grammar errors.
   D. Marking hyperlinks within a Web page.

7. Hyperlinks can be linked to any of the following: (Select all that apply.)
   A. An e-mail
   B. A sound byte
   C. A video clip
   D. A bookmark on a page

8. A navigation bar is a tool used to help:
   A. Sailors at sea.
   B. Drivers of luxury cars.
   C. Users navigate FrontPage Web sites.
   D. Shared borders locate where to go in a Web site.

9. Which of the following statements is true?
   A. Shared borders automatically apply navigation buttons.
   B. Removing a link also removes the file it is linked to.
   C. Navigation view allows you to navigate faster through an individual page.
   D. You can add a page to a Web site in Navigation View.
Homework

1. Start FrontPage. Navigate to your Chapter 6 Practice folder, and open the Wedding Web site. Open the index.htm page.
2. Create links to the reception.htm, caterers.htm, and bands.htm pages on the index.htm page.
3. Add each page to Navigation view.
4. Add a left shared border with a navigation bar that has links to each page in the Web site.
5. Preview each hyperlink, and Verify Hyperlinks in Reports view.

Quiz Answers

1. A, B, C and D. A shared border can be applied on all four margins in a page.
2. B. Hyperlinks can not be added in Navigation view.
3. True. Preview view is a good way to check it. You could also check it by verifying links in Reports view.
4. False. You can create a page in Normal view, but you can’t add it to a Web site unless you are in Navigation view.
5. A, C and D. It’s true that hyperlinks add a lot to Web pages, although they aren’t necessarily there just to provide entertainment.
6. D. Bookmarks are generally used to create hyperlinks within a page in FrontPage.
7. A, B, C and D. Hyperlinks can be linked to any of those options.
8. C. The navigation bar is a tool that helps Web users navigate a Web site.
9. D. You can add a page to a Web site in Navigation view.
Chapter Seven: Working with Tables

Chapter Objectives:

- Use Tables for Page Layout
- Add a Table
- Add a Row or Column
- Change Row Height or Column Width
- Combine and Split Cells
- Change Alignment of Text
- Add an Image to a Table
- Change Table Border
- Format Cell Padding and Cell Spacing
- Nest Tables
- Display Tables in Pixels or Percents

Prerequisites

- How to open and save a page
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes
- How to select text

Chapter Task: Use tables to organize Web pages

Every professional-looking page on the Web uses tables to help organize and position the elements in a page. In fact, a World Wide Web without tables would be an ugly, messy, and confusing sight.

Tables are valuable because they firmly position text and images on the page from computer to computer. Without tables, elements in the page change their position on each individual’s screen. The use of tables on the Web is so advanced, that tables can even be used to organize other tables, a method called nesting.

This chapter will show how to use tables so your Web page’s content is displayed in an organized, attractive manner on the World Wide Web.
Lesson 7-1: Using Tables for Page Layout

You have probably already used tables in other Microsoft programs for many different functions, such as to show data, solve formulas, sort information, or use complex formatting. In FrontPage, tables have an entirely new purpose; tables are used in the layout of the page to organize text and images.

Nearly every page that you see when surfing the Internet is designed with tables. There are many benefits to using tables for page layout on the Internet. Here are two of the most important ones:

- **Tables are compatible with many browsers:** One consideration when inserting items into a Web page is whether users with different technology will be able to view it. This is not a concern when using tables; they are universal and they rarely cause problems for browsers.

- **Tables give the page designer total control:** Because browsers and settings vary from computer to computer, it is important that a Web page has something to keep its contents in place. Tables provide the structure that a Web page needs to “anchor” things in place.
Look at Figure 7-1 in the diagram above. Notice that all the text and images are neatly aligned and spaced, making it very easy to read and follow. Specific cells in the table are also shaded to highlight different areas on the page. Most importantly, when the window is re-sized the images and text will keep their places in the table.

**NOTE:** When tables are used in the layout of pages, the borders are set to zero so the borders are invisible.

Now look at Figure 7-2. This is the same Web page as Figure 7-1, but it does not have a table layout. Notice that the text and images are not cleanly spaced, text and images jump all over the page and it is very confusing to read. Most importantly, since a table isn’t holding everything in place, once the window is resized the text and images will be even more garbled than they are now. No one would want to visit this page.

Therefore, it is important that you understand how tables work, and how you should use them when designing your Web page.
Lesson 7-2: Inserting a Table

To create a table, you must specify how many columns (which run up and down) and rows (which run left to right) you want to appear in your table. Cells are small, rectangular-shaped boxes where the rows and columns of a table intersect. If you’re not certain how many columns and rows you want in your table, take an educated guess—you can always add or delete columns and rows from a table later.

In this lesson, you will learn how to create a table and enter information into it.

1. **Navigate to your Chapter 7 Practice folder and open Lesson 7A.**
   You’ll add a table for each country’s tour rates in this lesson.

2. **Press <Ctrl> + <End> to place the insertion point at the end of the page.**
   The Insert Table button is the quickest and easiest way to insert a table.
3. **Click the Insert Table button** on the Standard toolbar and drag inside the grid to select **3 rows** and **4 columns**, as shown in Figure 7-4. Release the mouse button when you are finished.

A blank table appears with three rows and four columns, but without any information in it; that’s what you’ll do next.

You can also insert a table with the Insert Table dialog box, shown in Figure 7-4. Just select Table → Insert Table from the menu to open it.

4. **Place the insertion point in the first cell** (the one in the upper left-hand corner of the table) by clicking the cell.

5. **Type Egypt**, then press `<Tab>` to move to the next cell.

The `<Tab>` moves the insertion point to the next cell in the row. Finish adding the column headings for your table. Make sure you press `<Tab>` to move to the next cell.

6. **Type Italy, press `<Tab>`, type Greece, press `<Tab>`, and type Israel.**

7. **Press `<Tab>` to move the insertion point to the first cell in the second row.**

8. **Type the following text in the table. Press `<Tab>` after entering the text in each cell. Don’t press `<Tab>` at the end of the last row.**

   | 5-7 day tour | 3-4 day art tour | 4-6 day archaeology tour | 3 day Jerusalem tour |
   | $900–1500   | $400–500        | $700–900                  | $500–600               |

When you’re finished, your table should look like the one in Figure 7-5.

---

### Table 7-1: The Table Toolbar

<table>
<thead>
<tr>
<th><strong>Button</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw Table</td>
<td>Uses a freehand pencil to draw a table and add cells, columns, or rows.</td>
</tr>
<tr>
<td>Eraser</td>
<td>Erases borders in a table.</td>
</tr>
<tr>
<td>Insert Rows or Columns</td>
<td>Inserts columns or rows depending on the insertion point’s location</td>
</tr>
<tr>
<td>Delete Cells</td>
<td>Deletes the selected cells.</td>
</tr>
<tr>
<td>Merge Cells</td>
<td>Combines two or more selected cells into a single larger cell.</td>
</tr>
<tr>
<td>Split Cells</td>
<td>Splits the selected cells into a specified number of rows and columns.</td>
</tr>
<tr>
<td>Align Top</td>
<td>Aligns text at the top of the cell.</td>
</tr>
<tr>
<td>Center Vertically</td>
<td>Aligns the text so there is equal space above and below the text.</td>
</tr>
<tr>
<td>Align Bottom</td>
<td>Aligns text at the bottom of the cell.</td>
</tr>
<tr>
<td>Distribute Rows Evenly</td>
<td>Changes the selected rows or cells to equal row height.</td>
</tr>
<tr>
<td>Distribute Columns Evenly</td>
<td>Changes the selected columns or cells to equal column width.</td>
</tr>
<tr>
<td>AutoFit</td>
<td>Adjusts the cells to automatically fit around the table’s contents.</td>
</tr>
</tbody>
</table>
Lesson 7-3: Modifying Table Properties

A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, a car’s properties would include its color, make, model, and shape. A property for a table might be the table’s height, width, and color.

Every table in a Web page has its own set of properties that you can view and change. This property concept might seem a little confusing at first but it’s something you have to learn if you want to become proficient at working with tables.

Much of this chapter is devoted to working with a table’s properties in one way or another, so consider this your introduction to table properties, and to properties in general.

Here’s how to view a table’s properties…

1. Right-click the table you created in the previous lesson and select **Table Properties** from the shortcut menu.
   
   The Table Properties dialog box appears, as shown in Figure 7-8.

2. Peruse the following table so that you're more familiar with the various table properties. Close the Table Properties dialog box when you're finished.

Table 7-2: Table Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>HTML Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alignment</td>
<td>Aligns the table to the left, center, or right of the window.</td>
<td>`&lt;table align=&quot;left</td>
</tr>
<tr>
<td>Float</td>
<td>Specifies if text can flow to the left or right of the table or not at all.</td>
<td>`&lt;div align=&quot;left</td>
</tr>
<tr>
<td>Cell padding</td>
<td>Specifies the distance between the cell's contents and its inside border.</td>
<td><code>&lt;table cellpadding=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Cell spacing</td>
<td>Specifies the distance or space between the cells in a table.</td>
<td><code>&lt;table cellspacing=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Table Width</td>
<td>Determines the width of the table. Measured as a number of pixels or as a percentage of the table width.</td>
<td><code>&lt;table width=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Table Height</td>
<td>Determines the height of the table. Measured as a number of pixels or as a percentage of the table height.</td>
<td><code>&lt;table height=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Border width</td>
<td>Specifies the width of the table’s border in pixels. Enter 0 for no border.</td>
<td><code>&lt;table border=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Background color</td>
<td>Specifies a color for the table’s background.</td>
<td><code>&lt;table bgcolor=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
<tr>
<td>Background image</td>
<td>Displays a background picture in the table.</td>
<td><code>&lt;table background=&quot;filename&quot;&gt;</code></td>
</tr>
<tr>
<td>Border color</td>
<td>Specifies a color for the table’s border.</td>
<td><code>&lt;table bordercolor=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 7-4: Modifying Cell Properties

Modifying cell properties is similar to modifying table properties, it's just in smaller increments. There are three main things you can modify in a cell's properties; the layout, border, and background. Refer to the table below for a description of all the cell properties.

1. Right-click the cell you want to modify and select Cell Properties from the shortcut menu.

   The Cell Properties dialog box appears, as shown in Figure 7-9.

Other Ways to View a Cell's Properties:

- Click anywhere in the table and select Table ➔ Properties ➔ Cell from the menu.
2. Peruse the following table so that you’re more familiar with the various cell properties. Close the Cell Properties dialog box when you’re finished.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>HTML Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal alignment</td>
<td>Aligns the contents of a cell to the left, right, or center.</td>
<td>`&lt;td align=&quot;left</td>
</tr>
<tr>
<td>Vertical alignment</td>
<td>Aligns the contents of a cell to the top, middle, or bottom.</td>
<td>`&lt;td align=&quot;top</td>
</tr>
<tr>
<td>Header cell</td>
<td>Displays the cell contents in bold.</td>
<td><code>&lt;th&gt;</code></td>
</tr>
<tr>
<td>No wrap</td>
<td>Prevents text from wrapping inside the cell.</td>
<td><code>&lt;td nowrap&gt;</code></td>
</tr>
<tr>
<td>Specify width</td>
<td>Determines the width of the cell. Measured as a number of pixels or as a percentage of the table.</td>
<td><code>&lt;td width=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Specify height</td>
<td>Determines the height of the cell. Measured as a number of pixels or as a percentage of the table.</td>
<td><code>&lt;td height=&quot;n&quot;&gt;</code></td>
</tr>
<tr>
<td>Background color</td>
<td>Specifies a color for the cell’s background.</td>
<td><code>&lt;td bgcolor=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
<tr>
<td>Background image</td>
<td>Displays a background picture in the cell.</td>
<td><code>&lt;td background=&quot;filename&quot;&gt;</code></td>
</tr>
<tr>
<td>Border color</td>
<td>Specifies a color for the cell’s border.</td>
<td><code>&lt;td bordercolor=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
<tr>
<td>Number of rows spanned</td>
<td>Allows a single cell to extend over multiple rows.</td>
<td><code>&lt;td colspan=&quot;num&quot;&gt;</code></td>
</tr>
<tr>
<td>Number of columns spanned</td>
<td>Allows a single cell to extend over multiple columns.</td>
<td><code>&lt;td rowspan=&quot;num&quot;&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 7-5: Adding or Deleting Rows and Columns

In this lesson, you will learn how to insert new columns and rows into a table, and how to delete entire columns and rows.

1. **Place the insertion point in the first column.**
   Now you can insert a column to the left or right of the current column.

2. **Select Table → Insert → Rows or Columns from the menu.**
   The Insert Rows or Columns dialog box appears, as shown in Figure 7-12. This dialog box is used for inserting both rows and columns, so you need to specify what and where you want to insert.

3. **Click the Columns option, click Left of selection for the location and click OK.**
   A new column is inserted to the left of the Egypt column.
4. Place the insertion point in the top cell of the new column, press <Ctrl> + <B> and type Destination.

5. Press the Down Arrow Key <↓> to move down to the next empty cell in the column.

Go on to the next step to complete the rest of the column.

6. Press <Ctrl> + <B> and type Tour Options, move down to the next empty cell in the column, and type Estimated Cost.

Now try inserting a new row.

7. Select Table → Insert → Rows or Columns from the menu. Click the Rows option, and click Below selection for the location. Click OK to verify your selection.

A new row appears at the bottom of the table.

8. Place the insertion point in the first cell of the new row and type Waiting List. Press <Tab>, then type the following:

   Yes <Tab> No <Tab> Yes <Tab> Yes.

Let’s add one more row to the table.

9. In the bottom right cell of the table, press <Tab> to add a new row. Type First Tour Year <Tab> 1980 <Tab> 1988 <Tab> 1975 <Tab> 2000.

Now you’ve added two rows and a column. What if you want to delete a row or column? Fortunately, there are a few ways you can do this from the table.

10. Place the cursor just to the left of the row and click to select the First Tour Year row.

   Just like selecting a line in Microsoft Word, click in the margin to the left of the table row to select it.

11. Select Table → Delete cells from the menu.

   The First Tour Year row is deleted. Now let’s delete the Israel column.

12. Select the Israel column. Select Table → Delete cells from the menu.

   The Israel column is deleted.

   Compare your table to Figure 7-13.

Other Ways to Delete a Column or Row:

- Select the column or row you want to delete. Then click the right mouse button and select Delete Cells from the shortcut menu.
Lesson 7-6: Changing Row Height or Column Width

When you create a table, all of the rows and columns normally appear the same size. As you enter information in a table, you will quickly discover that some of the columns are not wide enough to properly display the information they contain. This lesson explains how to change the width of a column.

1. **Position the pointer over the border between Italy and Greece, until it changes to a ↔.**
   The arrow indicates that the border can be moved.

2. **Click and hold the mouse button, drag the pointer to the left and release the mouse button.**
   The width of the “Italy” column is now smaller.

   **NOTE:** If you attempt to drag the outside border of the table (the border farthest to the right), the width of the entire table changes.
You can change the height of rows using the same process. You will seldom need to change a row’s height, however. Generally, all the cells in a row will automatically expand to the tallest cell in the table—the one that contains the most lines of text.

3. Position the pointer over the border between the Destination and Tour Options rows, until it changes to a \( \text{I} \).
   Now you can change the row’s height.

4. Click and hold the mouse button, drag the pointer down and release the mouse button.
   The “Destination” row is now taller than the other rows.

   Another fast and easy way to adjust a column’s width or row’s height is to use FrontPage’s AutoFit feature.

5. Select the Italy column, and select Table \( \rightarrow \) AutoFit from the menu.
   FrontPage automatically adjusts the column for the text fits, and so spacing is even.

   Use the same process for a row: select the row, and select Table \( \rightarrow \) AutoFit from the menu.

   Another neat trick you should know is that you can distribute columns and rows evenly, which changes the selected cells to equal column width or row height.

6. Select the Egypt, Italy, and Greece columns, right-click and select Distribute Columns Evenly from the shortcut menu.
   FrontPage adjusts the columns so they are of equal width. Notice that the “Destination” column stands out because of its different width.

7. Select the all of the rows, right-click on the table, and select Distribute Rows Evenly from the shortcut menu.
   Now the rows are evenly spaced, bringing out the “Destination” column even more.

   Though a perfectly symmetrical table may seem like the best option, you can use different heights and widths of rows and columns to your advantage. Use these differences as you would use text formatting: a wider column or row causes its contents to stand out from the rest of the table.

8. Close the page without saving changes.
Lesson 7-7: Merging and Splitting Cells

You may find times when you wish you could have a single, large cell that spanned across several smaller columns. The *Merge Cells* command combines several smaller cells into a single larger cell that spans the space the previous cells occupied. The *Split Cells* command breaks cells into several smaller cells. You will execute both of these commands in this lesson.

1. If necessary, navigate to your Chapter 7 Practice folder and open the Lesson 7B page.

   We’re going to merge a few cells, but first we need to select the cells we want to merge.
2. Select all the cells in the bottom row.
Once you select several cells, you can merge them or combine them into a single, larger cell.

3. If necessary, select View → Toolbars → Tables from the menu.
The Tables toolbar appears.

4. Click the Merge Cells button on the Tables toolbar to merge the selected cells.
The selected cells are merged into a single cell that spans the entire table, as shown in Figure 7-16.
The procedure for splitting a single cell into several smaller cells is almost as easy as merging cells.

5. With the merged cell still selected, click the Split Cells button on the Tables toolbar.
The Split Cells dialog box appears, as shown in Figure 7-17.

6. Verify that the number 2 appears in the Number of Columns box.
The selected cell will be split into two columns. You may notice that there is a “Number of Rows” text box in the dialog box. If you wanted to split a cell into multiple rows, you would enter the number of rows here.

7. Click OK. Compare your table to the one in Figure 7-18.
The dialog box closes and the selected cell is split into two smaller cells, as shown in Figure 7-18.
The row looked better as one cell though, so go ahead and merge the last row’s cells once again.

8. Select the last row’s two cells and click the Merge Cells button on the Tables toolbar.
Knowing how to merge and split cells is valuable when using tables in a Web page, especially when using elements of different sizes, like images and text.
Lesson 7-8: Changing Alignment of Text in a Cell

In this lesson, you will learn how to align text horizontally and vertically in a cell. Like other table operations, aligning a cell’s contents is easiest if you use the Tables toolbar.

1. **Select the bottom cell in the table, Last updated May 31, 2001.**
   The text doesn’t stand out much where it is, so let’s center it. Also, align the text in a cell vertically so it sits on the bottom border of the cell.

2. **Select Table → Properties → Cell from the menu.**
   The Cell Properties dialog box appears.

3. **Select Center from the Horizontal Alignment drop-down list, select Bottom from the Vertical Alignment drop-down list, and click OK.**
   The text is now aligned to the center and the bottom of the cell. Compare your table to the one in Figure 7-22.

4. **Close the page without saving changes.**
Lesson 7-9: Adding an Image to a Table

Tables are necessary for controlling the placement of images on a Web page. Without a table, there is no way to control where images and text appear on a page. Fortunately, inserting a picture into a table really isn’t any different from inserting an image as you normally would on a page, so this lesson shouldn’t be too difficult.

1. Navigate to your Chapter 7 Practice folder, open Lesson 7C.
   Tables are especially good for laying out images with text.

2. Click the bottom left cell of the table, and click the Insert Picture from File button on the Standard toolbar.
   The Picture dialog box appears as shown in Figure 7-23, displaying images you have already added to your Web site. Or, FrontPage might skip the Picture dialog box and go directly to the Select File dialog box.

3. Click the Select a file on your computer button to open the Select File dialog box, and navigate to your root Practice folder in the Look in: list. Select the olivetree file, and click OK to confirm your selection.
   The image is inserted into the table, and the cell adjusts to the size of the image.

4. Save the page.

Quick Reference

To Add an Image to a Table:
1. Click in the cell where you want to insert the image.
2. Click the Insert Picture from File button on the Standard toolbar.

Or...
1. Select Insert → Picture From File from the menu.
2. If the image is not already in your Web site, click the Select a file on your computer button to open the Select File dialog box.
3. Select the image you want to insert, and click OK.
Lesson 7-10: Formatting Cell Spacing

Instead of trying to use the space bar or <Enter> key to control the spacing of text within a cell, format the cell spacing in the table. Cell spacing determines the thickness of the borders between cells, so that the content in the cells is easier to read.

1. **Click anywhere in the table.**
   To adjust the cell spacing, go to the Table Properties dialog box.

2. **Right-click in the table, and select Table Properties from the menu.**
   The Table Properties dialog box appears, as shown in Figure 7-26.

3. **Type 10 in the Cell spacing box, and click OK.**
   The table appears with the new cell spacing, as shown in Figure 7-27.

4. **Press <Ctrl> + <Z> to restore the table’s original format.**
   The cell spacing is returned to the original format.
Lesson 7-11: Formatting Cell Padding

Cell padding allows you to put a “padding” of space between the text and the borders. Cell spacing and cell padding do essentially the same thing, but cell spacing is a little easier to understand and use.

1. **Place your insertion point anywhere in the table.**
   The cell spacing is adjusted in the Table Properties dialog box.

2. **Right-click in the table, and select Table Properties from the menu.**
   The Table Properties dialog box appears, as shown in Figure 7-26.

3. **Type 10 in the Cell spacing box, and click OK.**
   The table appears with the changed cell spacing, as shown in Figure 7-27. As you can see, cell padding is difficult to understand because the spacing boundaries are not clear.

4. **Press <Ctrl> + <Z> to restore the table to its original format.**
   The cell padding is returned to the original format.

---

**Quick Reference**

**To Format Cell Padding:**
1. Right-click in the table, and select Table Properties from the shortcut menu.
2. Enter the number of pixels you want between the text and the cell border in the Cell padding box.
3. Click OK.
Lesson 7-12: Changing a Table’s Borders

Most of the time, you will want to make the borders of the tables in your Web pages invisible, since tables are mostly used for organizational purposes in Web pages. Invisible borders are almost always used to format images with text on a Web page. If you want to make the borders of a table visible to highlight a certain point, however, change the size or color of a table’s border.

This lesson will show you how to make a table visible or invisible.

1. **Click anywhere in the table.**
   If the cursor is placed in the table, you can change the table’s properties.

2. **Select Table → Properties → Table from the menu.**
   The Table Properties dialog box appears. Let’s color the border and make it larger.

3. **In the Borders area, click the up arrow to change the size to 7, or type 7.**
   The border will appear seven pixels wide. Now add some color to the border.

4. **Select the color yellow from the Color drop-down list. Click OK to confirm your selection.**
   The border appears in the color yellow.
Most of the time, however, you will want to use the table without the border so that it can be used to layout the page without distracting from the page’s content. Try it with this page’s table.

5. **Repeat Step 2. In the Borders area, change the size to 0, and click OK to confirm your selection.**
   The table’s border appears as a light, dashed line that’s easy to work with, but it will be invisible to users on the Web.

6. **Save your changes.**
Lesson 7-13: Displaying Tables in Pixels or Percent

The final step in setting your table’s properties is deciding whether to display the table in pixels or percent. Since every user’s computer will have different settings, it’s almost impossible to predict how your Web page is going to look on all of them. Therefore, you have to do what you can to format your Web page so it is user-friendly. The best way to do this is to set the table to be displayed in pixels or percent. This lesson will show you the differences in both of these options so you can choose what you need.

1. **If necessary, navigate to your Practice Chapter 7 Folder and open Lesson 7C.**
   Ask your instructor for help if you don’t know where your practice files are located.

2. **Place the insertion point in the table, right-click and select Table Properties from the shortcut menu.**
   The Table Properties dialog box appears.
   Notice that in the upper right corner there are the “Specify width” and “Specify height” options. This is what we’ll be exploring in this lesson.
3. **Check the Specify width checkbox.**

   Setting the width of a table is important to making the table consistent in different browsers and computer settings.

   **NOTE:** It’s a good idea to leave the specify height checkbox unchecked if you specify the width of the table. Then the table can expand to adjust for its contents.

When you are deciding whether to display the table in pixels or percent, use the following information to help guide your decision:

- **Pixels:** If your table is set to a certain number of pixels, it will appear in the same number of pixels on the screen no matter what the size of the browser window is. This option is usually best because the contents of the table appear consistently on different pages.

- **Percent:** If your table is set to percent, it will take up the set percent of the browser window. This means that the table’s appearance will change according to the size of a user’s browser window. The problem with this option is that as the user resizes the window, the contents of the table will change and may not appear the way you intended.

First, let’s see what happens if you specify the width of the table in percent.

4. **Click the In percent option for width in the Table Properties dialog box.**

   The width of the table will span a percent of the window’s width.

5. **Type 100 in the Specify width box and click OK.**

   The width will span 100 percent of the browser’s window, and each cell will be spaced evenly horizontally.

   See what happens if you resize the table.

6. **Save the page and click the Preview in Browser button on the Standard toolbar.**

   Resize the window.

7. **Drag the right side of the window to the left to resize the window as shown in Figure 7-34.**

   The table is resized and adjusts to the contents of the table.

   A table set in pixels does not adjust to the size of a resized window. Try setting the width of the table in pixels.

8. **Close the browser window. Place the insertion point in the table, right-click and select Table Properties from the shortcut menu.**

   The Table Properties dialog box appears.

9. **Click the In pixels option for width in the Table Properties dialog box.**

   The width of the table will remain at the number of pixels you specify.

10. **Type 740 in the Specify width box and click OK.**

    This width is a standard width for tables used in Web page layout because it is compatible with the most popular screen resolution, 800 x 600 pixels.

11. **Save the page and click the Preview in Browser button on the Standard toolbar.**

    Resize the window.

12. **Drag the right side of the window to the left to resize the window as shown in Figure 7-36.**

    The window is smaller but the table remains the same size.

13. **Close the browser window and close the page without saving changes.**

---

### Quick Reference

**To Display a Table in Percent:**

1. Right-click and select **Table Properties** from the shortcut menu.
2. Check the **Specify height** or **Specify width** options, and click the **In percent** option.
3. Enter the percent at which you want to display the table in the specified box.

**To Display a Table in Pixels:**

1. Right-click and select **Table Properties** from the shortcut menu.
2. Check the **Specify height** or **Specify width** option, and click the **In pixels** option.
3. Enter the number of pixels at which you want to set the table’s display in the specified box.
Lesson 7-14: Nesting Tables

Nesting tables isn’t for the birds; in fact nesting tables is very important in Web development. The process of placing layers of tables within tables is called nesting. Nesting tables is a process that most Web pages on the Internet use. In nesting, the page is formed from one large table, but other elements within the page are made within their own table. If you nest tables in your Web site, you will have total control over how elements appear in your Web pages. This lesson will show you a basic way to use this process effectively in a Web page.

1. Navigate to your Chapter 7 Practice folder and open Lesson 7D.
   There is some text and an image outside the table on the page. You’re going to nest a table for the image and text in the lower left cell of the table.

2. Place your insertion point in the lower left cell of the table (the empty one).
   This is where you’re going to nest another table.
3. Click the **Insert Table** button on the Standard toolbar. Drag your cursor to select 1 column and 2 rows.
   Compare your work to Figure 7-37. The new table should adjust to fit within the new cell.

4. Right-click in the nested table and select **Table Properties** from the shortcut menu. Decrease the Border size to 0 (zero) and click **OK**.
   Now the border of the nested table will be invisible, just like the table in which it is nested, and you have more control over how the content of the Web page appears on every user’s screen.

5. **Cut and paste the statue image** into the top cell of the nested table.
   The cell expands to fit the size of the image. Now insert the caption text of the image in the nested table cell below the image.

6. **Cut and paste the Michelangelo’s “David” text** into the bottom cell of the nested table.
   The table adjusts to the size of each item, as shown in Figure 7-38. Using nested tables is a relatively simple process, and they greatly enhance your Web page’s appearance.

---

**Quick Reference**

To Nest a Table:

1. Select a cell in which to nest the table.
2. Click the **Insert Table** button on the Standard toolbar and drag the cursor to select the number of columns and rows you want in the table.
3. Right-click in the nested table and select **Table Properties** from the shortcut menu. Decrease the Border size to 0 (zero) and click **OK**.
Lesson 7-15: Adding a Background Color to a Table

If changing the color of a table’s border doesn’t do enough to make your table stand out, or if you just want to do something different, you might want to try adding a background color to a table.

One important thing to watch out for when picking out a background color is the contrast between the font and the background. Nobody wants to try and read white text on a light yellow background!

1. Right-click the table and select **Table Properties** from the shortcut menu.
   
The background of the table is a property that can be changed in the Table Properties dialog box.

2. Click the **Color drop-down list arrow** in the **Background** area of the Table Properties dialog box.
   
   A list of available colors appears, as shown in Figure 7-39. To select a color from the list, just click it.

3. **Select Olive** from the drop-down list.
   
   Perhaps Olive isn’t the most becoming shade, but you don’t have to look at it for very long.

4. Click **OK** to close the dialog box.
   
The olive color is applied to the table.

Remember to ensure that the text is still visible once the background color has been applied. You can always change the font color to make it more readable as well.

---

**Quick Reference**

To Add a Background Color to a Table:

1. Right-click the table and select **Table Properties** from the shortcut menu.

   Or...

   Select **Table** → **Properties** → **Table** from the menu.

2. Click the **Color drop-down list arrow**.

3. Select a color from the list.

4. Click **OK**.
Lesson 7-16: Adding a Background Image to a Table

Take adding a background color to a table one step further and add an image to the background of a table. The principles for adding background color also apply for adding a background image: make sure the text in the table is still legible.

1. **Right-click the table and select Table Properties from the shortcut menu.**
   Select the image you want to set as your background here.

2. **Check the Use background picture checkbox.**
   Identify the file you want to use for the background picture.

3. **Click the Browse button.**
   The Select Background Picture dialog box appears.

4. **Click the Select file from computer button.**
   The Select File dialog box appears. Navigate to the file you want to use.

5. **Navigate to the practice folder and select the background image file. Click OK.**
   The Select File and Select Background Image dialog boxes close.

6. **Click OK.**
   The Table Properties dialog box closes and the background image is applied to the table.
Chapter Seven Review

Lesson Summary

Using Tables for Page Layout

- Tables are important in the layout and development of Web pages. Without them, Web pages would look messy, disorganized, and haphazardly thrown together. Remember; laying out a page with a table is not rocket science. It just takes smart use of table and cell properties to lay out a professional, readable page.

Inserting a Table

- To Insert a Table (Using the Toolbar): Click the Insert Table button on the Standard toolbar and drag your cursor inside the grid to select the number of columns and rows you want.
- To Insert a Table (Using the Menu): Select Table → Insert Table from the menu, specify the number of rows and columns you want, and click OK.
- Move between cells by pressing <Tab> to move forward one field or cell, and <Shift> + <Tab> to move back one field or cell.
- Delete the contents of a cell by selecting the cell(s), and pressing the <Delete> key.

Modifying Table Properties

- A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, a car’s properties would include its color, make, and model, and shape. A property for a table might be the table’s height, width, and color.
- Every table in a Web page has its own set of properties that you can view and change.
- To View Table Properties: Right-click the table and select Table Properties from the shortcut menu, or, click anywhere in the table and select Table → Properties → Table from the menu.

Modifying Cell Properties

- Modifying cell properties is similar to modifying table properties, it’s just in smaller increments.
- There are three main things you can modify in a cell’s properties; the layout, border, and background.
- To View Cell Properties: Right-click the table and select Cell Properties from the shortcut menu, or, click anywhere in the table and select Table → Properties → Cell from the menu.

Adding or Delete Rows and Columns

- To Insert a Column or Row: Select the column to the right of, or the row below, where the new column or row will be inserted. Right-click and select Insert Columns or Insert Rows from the shortcut menu, or select Table → Insert → Rows or Columns from the menu, or click the Insert Columns or Insert Rows buttons on the Tables toolbar.
• **To Delete a Column or Row:** Select the column or row you want to delete. Then right-click and select **Delete Cells** from the shortcut menu. Or, select the column or row you want to delete, and select **Table → Delete Cells** from the menu.

**Changing Row Height or Column Width**

• **To Adjust the Width of a Column:** Click and drag the column’s right border to the left or right.

• **To Adjust the Height of a Row:** Click and drag the row’s bottom border up or down.

• **AutoFit:** You can use AutoFit to adjust a column’s width or a row’s height to fit the entry. To use AutoFit, select the column, select **Table → AutoFit** from the menu.

• **To Distribute Columns or Rows Evenly in a Table:** Select the column or row, right-click and select **Distribute Columns Evenly** or **Distribute Rows Evenly** from the shortcut menu. Or, select the column or row and click the **Distribute Columns Evenly**, or **Distribute Rows Evenly** button on the Tables toolbar.

**Merging and Splitting Cells**

• **Merge cells:** You can merge multiple cells into a single, larger cell by selecting the cells you want to merge, and selecting **Table → Merge cells** from the menu, or by clicking the **Merge Cells** button on the Tables toolbar. You can also use the **Eraser** button on the Tables toolbar to split cells by erasing the lines between them.

• **Split cells:** You can split a cell into several smaller, multiple cells by selecting the cell you want to split and selecting **Table → Split Cells** from the menu, or by clicking the **Split Cells** button on the Tables and Borders toolbar. You can also use the **Draw Table** button on the Tables toolbar to merge cells by drawing lines between them.

**Changing Alignment of Text in a Cell**

• **To Horizontally Align a Cell’s Contents:** Right-click in the cell and select **Cell Properties** from the shortcut menu, or select the cell(s) and select **Table → Properties → Cell**. Click anywhere in the cell and click the **Align Left, Center, or Align Right** button on the Formatting toolbar.

• **To Vertically Align a Cell’s Contents:** Right-click in the cell and select **Cell Properties** from the shortcut menu, or select the cell(s) and select **Table → Properties → Cell** and change the alignment. Or, select the cell(s) and click the **Align Top, Center, Vertically, or Align Bottom** button on the Tables toolbar.

**Adding an Image to a Table**

• **To Add an Image to a Table:** Click in the cell where you want to insert the image and click the **Insert Picture from File** button on the Standard toolbar or select **Insert → Picture → From File** from the menu. If the image is not already in your Web site, click the **Select a file on your computer** button to open the Select File dialog box. Select the image you want to insert, and click **OK**.

**Formatting Cell Spacing**

• Right-click in the table, and select **Table Properties** from the shortcut menu. Enter the number of pixels you want between cells in the **Cell spacing** box and click **OK**.

**Formatting Cell Padding**

• Right-click in the table, and select **Table Properties** from the shortcut menu. Enter the number of pixels you want between the text and the cell border in the **Cell padding** box, and click **OK**.
Changing a Table’s Borders

- **Change a Border’s Size:** Click anywhere in the table, and select Table → Properties → Table from the menu. In the Borders area, change the Size in pixels, and click OK to confirm your selection.

- **Change a Border’s Color:** Click anywhere in the table, and select Table → Properties → Table from the menu. In the Borders area, select a Color, and click OK to confirm your selection.

- **Invisible Border:** Click anywhere in the table, and select Table → Properties → Table from the menu. In the Borders area, change the Size to zero, and click OK to confirm your selection.

Displaying Tables in Pixels or Percent

- **To Display a Table in Percent:** Right-click and select Table Properties from the shortcut menu. Check the Specify height or Specify width options, and click the In percent option. Enter the percent at which you want to display the table in the specified box.

- **To Display a Table in Pixels:** Right-click and select Table Properties from the shortcut menu. Check the Specify height or Specify width options, and click the In pixels option. Enter the number of pixels at which you want to set the table’s display in the specified box.

Nesting Tables

- Select a cell in which to nest the table. Click the Insert Table button on the Standard toolbar and drag the cursor to select the number of columns and rows you want in the table. Right-click in the nested table and select Table Properties from the shortcut menu. Decrease the Border size to 0 (zero) and click OK.

Adding a Background Color to a Table

- Be careful to leave enough contrast between the font and the table’s background image.

- **To Add a Background Color to a Table:** Right-click the table and select Table Properties from the shortcut menu, or, select Table → Properties → Table from the menu. Click the Color drop-down list arrow, select a color from the list and click OK.

Add a Background Image to a Table

- Be careful to leave enough contrast between the font and the table’s background.

- **To Add a Background Image to a Table:** Right-click the table and select Table Properties from the shortcut menu, or select Table → Properties → Table from the menu. Check the Use background image checkbox and click the Browse button. Click the Select file from computer button and navigate to the location of the image you want to use for the background. Click OK, OK.

Quiz

1. Which of the following is NOT a way to create a table?
   A. Select Table → Insert → Table from the menu.
   B. Click the Insert Table button on the Standard toolbar.
   C. Select Insert → Table from the menu.
   D. Select View → Toolbars → Tables to view the Tables toolbar and click the Draw Table button on the Tables menu.
2. Which of the following statements about tables is NOT true?
   A. You can format the characters and paragraphs in a table.
   B. You can automatically sort information in a table alphabetically, numerically, or chronologically, by clicking the column button.
   C. You can split a cell into several smaller cells, or merge several smaller cells into a single, larger cell.
   D. FrontPage’s tables cannot perform calculations.

3. Which keys can you use to navigate in a table?
   A. <Tab> to move to the next cell, <Shift> + <Tab> to move to the previous cell.
   B. <Enter> to move to the next cell, <Shift> + <Enter> to move to the previous cell.
   C. <→> to move to the next cell, <←> to move to the previous cell.
   D. All of the above.

4. It is not possible to insert images in a table. (True or False?)

5. Which of the following statements is NOT true?
   A. The AutoFit feature automatically adjusts the width of a column or row so that it fits its longest entry.
   B. You can change the width of a column or the height of a row by clicking and dragging it with the cursor.
   C. A table’s borders must always appear on the Web.
   D. You can merge several cells into a single cell and split a single cell into several smaller cells.

6. You can use the Draw Table tool to draw doodles and pictures in a table. (True or False?)

7. Which of the following procedures can you use to change a table’s borders?
   A. Select the cells where you want to apply the different borders and select the desired border from the Borders button on the Formatting toolbar, or on the Tables toolbar.
   B. Select Tables → Table Border Wizard from the menu and follow the onscreen instructions.
   C. Click the Draw Table button on the Tables toolbar and then draw the border.
   D. Place the insertion point in the table, select Tables → Properties → Table from the menu, and change the information in the Border area of the dialog box.

8. The only possible way to align text in the cells of a table is horizontally. (True or False?)

9. You have four cells that you would like to combine into one. Which of the following methods can you use to combine the cells? (Select all that apply.)
   A. Select the four cells and click the Merge Cells button on the Tables toolbar.
   B. Select the four cells and select Table → Merge Cells from the menu.
   C. Select the four cells, click the right mouse button and select Merge Cells from the menu.
   D. Select the four cells and press <Ctrl> + <M>.
10. The only difference between cell padding and cell spacing, is that cell padding changes the width of the borders between cells. (True or False?)

11. It is necessary to display tables in pixels or percent, because Web pages do not appear the same on every screen. (True or False?)

12. Nested tables refers to:
   A. A dining room table setting that allows for more intimate conversation.
   B. Pieces of furniture from which birds eat.
   C. Tables that consist of hundreds of sticks and mud.
   D. Tables within tables on a Web page.

**Homework**

   
2. Click the Insert Table button on the Standard toolbar and click and drag until you have created a table with five rows and five columns.
   
   **NOTE:** If this is not the default setting, insert the table through the Insert menu.
   
3. Enter the following information into the table:

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Q1</th>
<th>Q2</th>
<th>Q3</th>
<th>Q4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flights</td>
<td>15,000</td>
<td>15,000</td>
<td>15,000</td>
<td>15,000</td>
</tr>
<tr>
<td>Tours</td>
<td>25,000</td>
<td>25,000</td>
<td>25,000</td>
<td>25,000</td>
</tr>
<tr>
<td>Cruises</td>
<td>5,000</td>
<td>5,000</td>
<td>5,000</td>
<td>5,000</td>
</tr>
<tr>
<td>Scams</td>
<td>1,500</td>
<td>1,500</td>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>

   Remember to use the arrow keys, <Tab>, <Shift> + <Tab> and <Enter> to move from cell to cell.
   
4. Display the Tables toolbar by selecting View → Toolbars → Tables from the menu.
   
5. Click and drag the first column’s right border to the left about a half-inch.
   
6. Format the table headings: Select the table’s top row and click the Center button and the Bold button on the Formatting toolbar.
   
7. Save the page as “Table Homework” and exit Microsoft FrontPage.

**Quiz Answers**

1. C. You would think selecting Insert → Table would be the way to insert a table using the menu, but the actual command is Table → Insert Table.
   
2. B. FrontPage’s tables can format the information you put in the cells, but it cannot compute or organize any of the information.
   
3. A and C. Pressing <Enter> only makes the row bigger.
   
4. False. Tables are almost necessary for images on Web pages.
   
5. C. In fact, tables are in almost every page on the Web, but they’re invisible.
6. False. The Draw Table tool is used to add columns and rows to a table.

7. C and D. The Draw Table tool is useful when creating advanced tables. You can use either of these methods to add borders to a table.

8. False. Cells can also be aligned vertically.

9. A, B and C. Any of these methods will combine or merge several cells into a single cell.

10. False. Cell padding changes the space between the cell’s contents and the border. Cell spacing changes the width of the borders between cells.

11. True. Setting the table to be displayed in pixels or percent gives the table a better chance of appearing how you want it to appear on most screens.

12. D. Nested tables are often used in Web sites to allow for more control over images and text on a Web page.
Chapter Eight: Working with Frames

Chapter Objectives:
• Create Frames
• Add Pages to Frames
• Create Frame Targets
• Change Frame Properties
• Save Frames
• Create a Link to a Frame

Chapter Task: Create a Frame page

You’ve heard of picture frames and house frames; but frames on the Web? Web frames are kind of like their picture frame cousins, except instead of pictures, Web frames hold a Web page. Each Web frame takes up a portion of the browser window, allowing you to interact with the pages separately.

Why would you use frames in the first place? One of the most common uses for frames is as navigation tools for your Web site. For example, one frame would hold a page of hyperlinks, and another frame would show the link’s page, kind of like a table of contents for the Web site. Therefore, frames allow you to keep information on the screen while the rest of the Web site is being browsed. Another reason to use frames is for continuity in the Web site. A frame can be used to display a common header that will remain open, even when the user changes pages.

But before you decide that frames are the answer to all your problems, think about the number of times you’ve encountered a Web site that uses frames, and you can probably count them on both hands. Web designers don’t use frames very often because they sometimes don’t work very well, and because they’re difficult to set up. Instead, Web designers use table templates that provide a common header and navigation tool for Web pages, instead of frames.

Whatever you decide to do, this chapter will show you how to use frames.
Lesson 8-1: Create Frames

Figure 8-1
The Frames Pages tab of the New page dialog box

Figure 8-2
A new page in frame format

Quick Reference
To Create Frames:
1. Click File → New → Page from the menu.
2. Click on the Frames Pages tab in the New dialog box.
3. Select the frame you want to use, and click OK.

One of the most common uses for frames is to create a Table of Contents to the left side of the window to easily access other Web pages or sections of the current Web page.

1. Open FrontPage. Click File → New → Page from the menu.
   The New dialog box appears, as shown in Figure 8-1.

2. Click the Frames Page tab in the New dialog box.
   Select a page template to see how the frames will break up the window in the preview area of the dialog box.

3. Select the Contents template, and click OK to confirm your selection.
   The page appears in FrontPage, as shown in Figure 8-2. The window is broken up into two parts; a narrower left side, and a larger right side. There are also two buttons that give you the choice of either importing a page that already exists into the frame area, or creating a blank new page in the frame.

4. Save the page under the filename language frame.
Lesson 8-2: Add Pages to Frames

You can add pages that already exist to frames with the click of a button, or you can create a new page in the frame. This lesson will show you how to create frame pages using both methods. First, let’s set up the left, smaller frame.

1. Click the New Page button in the left frame.
   The frame appears as a blank new page.
2. Type Italian, press <Enter>, type Greek, press <Enter>, and type Arabic.
   The words appear on separate lines in the frame, almost like a navigation bar. Now add a page that is already created in the right frame.
3. Click the Set Initial Page button in the right frame.
   The Select File dialog box appears. If the Create Hyperlink dialog box appears instead, click the Select a file on your computer button in the Create Hyperlinks dialog box.
4. Navigate to your root Practice Folder. Select the right frame page file, and click OK.
   The page appears in the right frame. Compare your screen to Figure 8-4.
   Go on to the next lesson to add links to the words in the left frame.
Lesson 8-3: Create Frame Targets

Once the frames are set up, you have to create something for the hyperlinks to link to; a frame target. In this lesson, you are going to create targets for the links in the left frame of the window.

You are going to create hyperlinks in the left frame, and the pages they are linked to will appear in the right frame.

1. Select the Italian text in the left frame, and click the Hyperlink button on the Standard toolbar.

The Create Hyperlink dialog box appears.

2. Click the Change Target Frame button, click the right frame (the one on the right) in the Current frames page area of the Target Frame dialog box, and click OK.

The right frame turns blue when it is selected, as shown in Figure 8-5. This indicates that the link’s page will appear in the right-hand frame.
3. **Select Italy.htm from the Create Hyperlink dialog box, and click OK.**
   The text is now in hyperlink format; blue and underlined.
   There are two other language links that need corresponding pages.

4. **Select Greek in the left frame and click the Hyperlink button on the Standard toolbar.**
   Use the same process you just used to link the Italy.htm page, to link the Greece.htm page.

5. **Click the Change Target Frame button, click the right frame in the Current frames page area of the Target Frame dialog box, and click OK.**
   When the Greek hyperlink is clicked, the page to which it is linked will show up in the right frame of the page.
   Now verify the link’s destination.

6. **Select Greece.htm from the Create Hyperlink dialog box, and click OK.**
   The Greece page will appear in the right-side frame when the Greek hyperlink is clicked.
   Now only Arabic is left.

7. **Select Arabic in the left frame and click the Hyperlink button on the Standard toolbar.**
   Select the page to which you want to make the link.

8. **Click the Change Target Frame button, click the right frame in the Current frames page area of the Target Frame dialog box, and click OK.**
   The Egypt page will appear in the right-side frame when the Arabic link is clicked.

9. **Select Egypt.htm from the Create Hyperlink dialog box, and click OK.**
   The Egypt page will appear in the right-side frame when the Arabic hyperlink is clicked.

---

**Quick Reference**

To Set a Frame Target:

1. Select the text to be hyperlinked, and click the Hyperlink button on the Standard toolbar.

2. Click the Change Target Frame button in the Create Hyperlink dialog box.

3. Select the frame in which you want the page to appear in the Target Frame dialog box, and click OK.

4. Navigate to the location of the page, and click OK.

Or...

Click the Create a page and link to the new page button in the Create Hyperlink dialog box, select the type of page in the New dialog box, and click OK.
Lesson 8-4: Change Frame Properties

After you have created a frame, you must set its properties, according to how you want it to be displayed on the Web. For example, you could set the properties so that a scroll bar appears, or so a user can resize a frame. Changing frame properties is not nearly as complicated as setting the frames in place. In this lesson we will resize the left frame.

1. Move the cursor between the two frames, until it changes to a ←→, then click and drag the border to the left.
   The left frame becomes narrower, and the right frame becomes wider.

2. Right-click anywhere in the right frame, and select Frame Properties from the shortcut menu.
   The Frame Properties dialog box appears, as shown in Figure 8-7.
   Take a moment to look at the different options available in the Frame Properties dialog box. It might be a good idea to employ your knowledge of table properties to frame properties.

3. Click the Show Scrollbars drop-down list, select If Needed from the list, and click OK.
   If the user’s browser window does not show all of the content in the right frame, a scroll bar will appear. If the content does appear in the user’s browser window, a scroll bar will not appear.

Other Ways to Access Frame Properties:
- Click Frames → Frame Properties from the menu.

Quick Reference

To Change Frame Properties:
1. Right-click anywhere in the frame, and select Frame Properties from the shortcut menu.
2. Modify the options to how you want the frame to be displayed.

To Resize a Frame:
1. Move the cursor to the edge of the frame until it changes to a ←→, then click and drag the frame border.
Lesson 8-5: Save Frames

1. Click in the frame on the left side of the page.
   Let’s start with saving this frame.

2. Click the Save button on the Standard toolbar.
   The Save As dialog box appears.

3. Type languages in the File name box, and click Save.
   The left frame is saved as its own file. The right frame page has already been saved, so FrontPage is ready to save the master page.

4. Select File → Save As from the menu.
   The Save As dialog box appears with the entire page highlighted as shown in Figure 8-8. This time you are saving the master page.

5. Type Frame page in the File name text box, and click Save.
   The master page is saved, so that whenever it is opened it will put the languages file in the left frame, and the right frame page in the right frame.

6. Close the page.

Saving frames is a bit more complicated than saving unframed Web pages because there is more than one page in a frame page. For example, there are three parts to save the page you have been working on so far: the left frame page, the right frame page, and the master frame page (the page that holds both frames). This lesson will walk you through the process.
Lesson 8-6: Exit Frames

What happens when you want to go back to displaying only one frame in the browser window? All it really takes is another hyperlink that resets the screen to a whole page. It’s a simple process, but if you don’t do it, the pages will continue to be shown on only part of the screen.

1. If necessary, navigate to your Practice Chapter 8 folder, and open Lesson 8.

2. Type North Shore Home Page under the last hyperlink (Arabic) in the left frame. Select the North Shore Home Page text, and click the Hyperlink button on the Standard toolbar.

The Create Hyperlink dialog box appears.

3. Click the Change Target Frame button.

The Target Frame dialog box appears, as shown in Figure 8-9.

4. Click Whole Page, as shown in Figure 8-9 and click OK.

The Target Frame dialog box disappears, and the Create Hyperlink dialog is active once again. By changing the target frame to whole page, the linked page will fill the entire browser window, rather than just a frame.
5. Click `index.htm` in the Create Hyperlink dialog box, and click OK. The dialog box closes, and the hyperlink is created. Let’s see if the hyperlink works the way it should.

6. Press the `<Ctrl>` key and click the North Shore Home Page hyperlink. The index.htm page appears in the program window, as shown in Error! Reference source not found..

7. Close the Web page without saving changes.

<table>
<thead>
<tr>
<th>Target</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Default (main)</td>
<td>Set a frame target default to display frame targets the same way each time.</td>
</tr>
<tr>
<td>Same Frame</td>
<td>The page will appear in the same frame as the hyperlink.</td>
</tr>
<tr>
<td>Whole Page</td>
<td>The page will fill the browser window.</td>
</tr>
<tr>
<td>New Window</td>
<td>The page will appear in a new browser window.</td>
</tr>
<tr>
<td>Parent Frame</td>
<td>The page will appear in the parent frame of the page.</td>
</tr>
</tbody>
</table>

Quick Reference

To Exit Frames:

1. Select the hyperlink text, and click the Hyperlink button on the Standard toolbar.

2. Click the Change Target Frame button in the Create Hyperlink dialog box.

3. Click Whole Page in the Target Frame dialog box, and click OK.

4. Select the page to which to link in the Create Hyperlink dialog box, and click OK.
Chapter Eight Review

Lesson Summary

Create a Frame
- Click **File → New → Page** from the menu. Click on the **Frames Pages** tab in the New dialog box. Select the frame you want to use and click **OK**.

Add Pages to Frames
- **To Add a New Page to a Frame:** Click the **New Page** button in the frame. Select the page, and click **OK**.
- **To Add an Existing Page to a Frame:** Click the **Set Initial Page** button in the frame. Navigate to the location of the page in the Insert Hyperlink dialog box. Select the page, and click **OK**. Select File dialog box.

Create Frame Targets
- Select the text to be hyperlinked, and click the **Hyperlink** button on the Standard toolbar. Click the **Change Target Frame** button in the Create Hyperlink dialog box. Select the frame in which you want the page to appear in the Target Frame dialog box, and click **OK**. Navigate to the location of the page, and click **OK**. Or, click the **Create a page and link to the new page** button in the Create Hyperlink dialog box, select the type of page in the New dialog box, and click **OK**.

Change Frame Properties
- **To Change Frame Properties:** Right-click anywhere in the frame, and select **Frame Properties** from the shortcut menu. Modify the options to how you want the frame to be displayed.
- **To Resize a Frame:** Move the cursor to the edge of the frame until it changes to a ‹›, then click and drag the frame border.

Save Frames
- **To Save a Frame:** Click the frame to select it. Click the **Save** button on the Standard toolbar. Type its name in the File name box, and click the **Save** button.
- **To Save a Master Frame Page:** Move the cursor over the border between frames until it is a ‹›, then right-click. The entire page should be outlined in blue. Click the **Save** button on the Standard toolbar. Make sure the entire frame is selected in the Save As dialog box. Type the master page’s name in the File name box, and click **OK**.

Exit Frames
- Select the hyperlink text, and click the **Hyperlink** button on the Standard toolbar. Click the **Change Target Frame** button in the Create Hyperlink dialog box. Click **Whole Page** in the Target Frame dialog box, and click **OK**. Select the page to which to link in the Create Hyperlink dialog box, and click **OK**.
Chapter Eight: Working with Frames

Quiz

1. Which of the following is a way to create a frame? (Select all that apply.)
   A. Select New → Insert → Frame from the menu.
   B. Click the Insert Frame button on the Standard toolbar.
   C. Select File → Page, click the Frames Pages tab, select a type of frame, and click OK.
   D. Click the New Page button arrow , select Page → Frame.

2. Which of the following statements is NOT true?
   A. You can resize frames, and you can allow users to adjust the size of frames in the browser window.
   B. Frames allow users to view different pages in a Web site at the same time.
   C. You can split a frame into several smaller frames, like splitting a table cell.
   D. Once you create a frame page in a Web site, all the pages in the Web site are frame pages.

3. Which of the following can be changed in the Frame Properties dialog box?
   A. The page displayed in the frame.
   B. The option for users to resize the frame in the Web browser.
   C. The option to display a scroll bar in the frame.
   D. All of the above.

4. There are three parts to save in a two-frame page. (True or False?)

5. Which of the following is true?
   A. A frame target is the page that will appear in the frame when a hyperlink is clicked.
   B. A frame target is an element of a Web site.
   C. A frame target appears when a frame is split.
   D. None of the above.

6. You can create a new page in a frame, or set a page that’s already created in a frame. (True or False?)

Homework

1. Start Microsoft FrontPage.

2. Create a new empty Web site named “Action Heroes”. Then create three Web pages as follows:
   a. A Web page with the names of two main comic book producers, DC and Marvel, aligned on the left side of the page. Save the page as “actionheroes.htm”.
   b. A Web page with the following text: D.C. produced some of America’s favorite action heroes, such as: Superman, Batman, and Wonder Woman. Save the page as “DC.htm”.
   c. A Web page with the following text: Marvel produced most of America’s most popular super heroes, including Spiderman and the Incredible Hulk. Marvel also produced memorable super hero groups, like the X-men and the Fantastic Four. Save the page as “Marvel.htm”.

3. Create a new Contents template frames page.
4. Place the actionheroes.htm page on the left side.
5. Place the DC.htm page on the right side.
6. Create a hyperlink so that when the users click DC in the left frame, the DC.htm page appears in the right frame.
7. Create a hyperlink so that when the users click Marvel in the left frame, the Marvel.htm page appears in the right frame.

Quiz Answers

1. C. This is the only one way to create a frames page.
2. D. You can reset the frame targets to be shown in the whole window so they aren't in frames.
3. D. All of these options can be changed in the Frame Properties dialog box.
4. True. You must save a page in each frame, and save the master frame page.
5. A. You can set frame targets so the target appears when its hyperlink is clicked.
6. True. You can create a new page to appear in the frame, or set a page that has already been created to appear in the frame.
Chapter Nine: Creating Forms

Chapter Objectives:
- Set up a Form
- Add a Text Box
- Add Check Boxes
- Add Radio Buttons
- Add a Drop-Down Menu
- Access Form Results

Chapter Task: Create a form in a Web page

Most basic Web pages are like a large class lecture; users can glean information from the monotone lecturer, but they usually don’t interact and give their own input. Forms in Web pages are more like group discussions; they are open to two-way communication, and input is welcome.

Forms can be useful information-gathering tools on any page in your Web site. You can use forms to get to know who is visiting your Web pages, or visitors can use forms to order something from your company online.

Once you have decided to make a Web form, contact a database specialist to set up the structure necessary to support the form. This chapter will take you through the basics of setting up a form on your Web page.

Prerequisites
- Be able to use menus, toolbars, dialog boxes, and shortcut keystrokes
- Know how to select text
Lesson 9-1: Set Up a Form

Forms work because of HTML programs on Web servers that translate the forms to and from the Web. This lesson will show you the first step in putting together a form.

1. **Navigate to your Chapter 9 Practice folder, and open Lesson 9A.**
2. **Click below the text on the page, and select Insert → Form → Form from the menu.**
   
The form appears on your page, as shown in Figure 9-2.
3. **Place your insertion point to the left of the Submit button. Press <Enter> two times.**

Now you have space to insert more form elements.

There are a few different types of forms you can use to field information from users that are already in FrontPage. Figure 9-1 displays the options you can use to answer questions in a form.
There’s more to inserting a form than meets the eye, however. Forms require certain FrontPage Server Extensions on your Web server. To make sure these are available, call your Web server provider and ask if they use FrontPage Extensions.

Listed in the table below are a number of form template options you can use on a page, instead of creating your own form. To use these templates, click File → New → Page and select one of the form templates from the dialog box.

**Table 9-1: Form Templates**

<table>
<thead>
<tr>
<th>Template</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confirmation</td>
<td>A confirmation form is usually a page that acknowledges the server received a Web page. The confirmation form usually includes a short message and a hyperlink back to the home page.</td>
</tr>
<tr>
<td>Feedback</td>
<td>You can customize a feedback form to ask a user specific questions about the site.</td>
</tr>
<tr>
<td>Guest Book</td>
<td>Users can sign in and offer a comment about the site.</td>
</tr>
<tr>
<td>Search</td>
<td>Users can type a topic into the search box, the form will send a query to the server, and the server returns a list of hits related to the topic.</td>
</tr>
<tr>
<td>User Registration</td>
<td>Users can supply information about his or her self to register for a service or product provided by the Web site.</td>
</tr>
</tbody>
</table>

The table below describes the form fields available, and each field’s function.

**Table 9-2: Form Fields**

<table>
<thead>
<tr>
<th>Form Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One-Line Text Box</td>
<td>Allow users to type a line of feedback</td>
</tr>
<tr>
<td>Scrolling Text Box</td>
<td>Allow users to type multiple lines of feedback</td>
</tr>
<tr>
<td>Check Box</td>
<td>Allows users to choose one or more options in a group</td>
</tr>
<tr>
<td>Radio Button</td>
<td>Allows users to choose one option in a group</td>
</tr>
<tr>
<td>Drop-Down Menu</td>
<td>Allows users to choose one option from a list. This field can hold more options and is more space efficient than the option button.</td>
</tr>
<tr>
<td>Push Button</td>
<td>Use this button to insert a generic button and label it, or set the field properties to make it a Submit or Reset button.</td>
</tr>
<tr>
<td>Picture</td>
<td>Insert a picture into the form. This is not so much a field as it is a standard picture.</td>
</tr>
<tr>
<td>Label</td>
<td>Use this option to group a form field and its descriptive text</td>
</tr>
</tbody>
</table>

Quick Reference

To Set Up a Form:

1. Click on the page, and select **Insert → Form → Form** from the menu.
2. Place the cursor inside the form and press **<Enter>** the number of times necessary to expand the form to its desired size.
Lesson 9-2: Add a Text Box

There are two basic types of text boxes you can insert into a form: one-line, and scrolling. Use a one-line text box for information such as a name, or phone number. Use a scrolling text box for more information that requires several lines or paragraphs.

1. Click on the first line of the form and click the **Align Left button** on the **Formatting toolbar**.
   Depending on how FrontPage is set up on your computer, the default formatting for forms may be centered alignment. Make sure this form is aligned left.

2. Type **Name:** and press **<Shift> + <Enter>** to move the cursor down one line.
   This is the text that will appear next to the text box.

3. Click **Insert → Form → One-Line Text Box** from the menu.
   A text box appears below the text. You can change how the width of a text box appears by changing its properties.

4. **Right-click the text box, and select Form Field Properties from the shortcut menu.**
   The Text Box Properties dialog box appears.

---

**Right-click shortcut menu**

Other Ways to Change Form Field Properties:
- Press **<Alt> + <Enter>**.
- Double-click the form field.
5. **Type name in the Name field, and type 40 in the Width in characters field, as shown in Figure 9-3.**

The text box appears wider than before, as shown in Figure 9-4.

Remember: the width of the box determines how the box will appear on the Internet, not how much information can be entered into it. If users have more than forty characters to enter, the box will scroll to the left until the user is done entering information.

**NOTE:** Hide a user’s information as they enter it by selecting Yes in the Password field.

You can also insert scrolling text boxes that allow users to enter information in several lines or paragraphs.

6. **Place the insertion point on the line below the Name: text box. Type Tour Wish List:, and press <Shift> + <Enter> to move the cursor down one line.**

Now insert the text area.

7. **Select Insert → Form → Scrolling Text Box from the menu.**

A large text box with scroll bars appears in the form. Let’s set the properties for the scrolling text box as well.

8. **Type wishlist in the Name field, type 35 in the Width in characters field, and type 3 in the Number of lines field, as shown in Figure 9-4.**

The text box appears wider than before.

---

**Quick Reference**

**To Add a Text Boxes:**
- Click Insert → Form → One-Line Text Box or Scrolling Text Box from the menu.

**To Change Text Box Properties:**
- Right-click the text box, and select Form Field Properties from the shortcut menu.
Lesson 9-3: Add Check Boxes

Check boxes are great for selecting one or more options in a form. You will insert check boxes into the form in this lesson.

1. Click below the scrolling box on the form, type Which of the following countries would you like to include in your tour? and press <Enter>. Insert group boxes for three countries: Egypt, Italy, and Greece.

2. Click Insert → Form → Check Box from the menu. A check box appears on the page.

3. Type Egypt to right of the check box. Now you’re going to have to change the properties of the check box for when you receive the form results.

4. Right-click the check box, and select Form Field Properties from the shortcut menu. The Check Box Properties dialog box appears.

5. Type Egypt in the Name field, type yes in the Value field, and type 1 in the Tab order field. Click OK. When the form results are sent you will be able to identify that the user wants to go to Egypt. The Tab field allows the user to tab from one field to the next, just like you move from cell to cell in a table. The number you enter in this field specifies the position of the field in the tab order.
6. Repeat steps 2-5 to create two more check boxes, one for Italy and one for Greece. When changing the Tab order field in the Form Field Properties, enter 2 for Italy, and 3 for Greece.

That’s all there is to entering check boxes in a form.

Quick Reference

To Add Check Boxes:
1. Click Insert → Form → Check Box from the menu.
2. Type descriptive text next to the check box.

To Change Check Box Properties:
1. Right-click the check box, and select Form Field Properties from the shortcut menu.
2. Enter information into the dialog according to how you want it to be returned in the form results.
Lesson 9-4: Add Radio Buttons

Radio buttons are similar to check boxes, except you use radio buttons when you want readers to select only one of several options.

1. If necessary, navigate to your Chapter 9 Practice folder, and open Lesson 9B.

2. Place your insertion point below the check box row, type What is your trip’s budget?, and press <Shift> + <Enter> to move the cursor down one line.

Users will answer this question with the radio buttons you are about to insert.

3. Click Insert → Form → Radio Button from the menu.

A radio button appears in the form.

4. Type $1500–2500 to the right of the radio button.

Now you’re going to have to change the properties of the radio button for when you receive the form results.

5. Right-click the radio button, and select Form Field Properties from the shortcut menu.

The Radio Button Properties dialog box appears, as shown in Figure 9-8.

6. Type tourbudget in the Name field, type $1500–2500 in the Value field, and type 1 in the Tab order field.

When the form results come back to you, you will be able to identify what the user’s budget is for the tour.
**NOTE:** You might remember that the Egypt check box already has one for the tab order. Fortunately, FrontPage adjusts so that if a Tab order number has already been entered, the number entered earlier will come first.

7. Repeat steps 2-5 to create two more check boxes, one for $2500–3500 and one for $3500 and up. When changing the Tab order field in the Form Field Properties, enter 2 for $2500–3500, and 3 for $3500 and up.

That's all there is to entering radio buttons in a form!
Lesson 9-5: Add a Drop-Down Menu

Drop-down menus are useful in situations where you have a list of options for users to choose from. Like check boxes, one or more options can be selected from a drop-down menu.

1. **Place the insertion point below the radio buttons row, type How many days would you like to spend on your tour?, and press <Shift> + <Enter> to move the cursor down one line.**

Users will answer this question with the drop-down menu you are about to insert.
2. **Select Insert → Form → Drop-Down Menu from the menu.**
   An empty drop-down menu appears on the form. Next, you need to enter the options that will appear in the drop-down menu.

3. **Right-click the drop-down menu, and select Form Field Properties from the shortcut menu.**
   The Drop-Down Menu Properties dialog box appears, as shown in Figure 9-9.

4. **In the Name: field, type tourdays.**

5. **Click the Add button in the dialog box.**
   The Add Choice dialog box appears, as shown in Figure 9-10.

6. **In the Choice: field, type 3–5 days, and click OK.**
   The Drop-Down Menu Properties dialog box reappears, with the new information in the window. This is the first item that will appear in the menu.

7. **Click the Add button in the dialog box, and type 5–10 days in the Choice: field.**
   This is the same basic process as we just did, but this time we’re going to add a few differences.

8. **Check the Specify Value box, and type 5–10 in the text box.**
   If you check the Specify Value box, the value you type in the text box is what will appear on your form report.
   This is a good option to use if you want to use shorter text for the form report. For example, if you have a list of states in the drop-down menu, you might want “North Dakota” to appear as “ND” in your form report. In this case, this is the most common request at North Shore Travel.

9. **Click the Selected option in the Initial state field, and click OK.**
   Now, instead of the first option listed, 3-5 days, the 5-10 days option will already appear selected when users download the page. Only one item in your drop-down menu can be selected in the initial state.
   Just two final items to add to the menu…

10. **Click the Add button in the dialog box, and type 10–20 days in the Choice: field. Click OK.**
    This time, you didn’t click the “Specified Value” option. This means that the information you already entered will automatically appear as the value in your form report.

11. **Click the Add button in the dialog box, and type 20 days or more in the Choice: field. Check the Specify Value box, and type 20+ in the text box. Click OK.**
    Now 20+ will appear in your form report, which takes less space in your report.

---

**Quick Reference**

**To Add a Drop-Down Menu:**
1. **Click Insert → Form → Drop-Down Menu from the menu.**
2. **Type descriptive text (i.e. a question) next to the drop-down menu.**

**To Change Form Field Properties:**
1. **Right-click the menu, and select Form Field Properties from the shortcut menu.**
2. **Enter information as you want it to be returned in the form results.**
Lesson 9-6: Access Form Results

Now that you've done all that work setting up the form, you need to know how to access the form's results. There are a few different ways you can view a form's results, depending on the type of form you use, and what you are using the results for. For example, a simple feedback form with a few fields could be sent to the Webmaster in an e-mail. On the other hand, if the form includes information you will need to organize or use for future reference (i.e. addresses), send the form results to a database.

1. Click anywhere inside the form (defined by dashed lines), and select **Insert → Form → Form Properties** from the menu.

   The Form Properties dialog box appears, as shown in Figure 9-12. The first thing you have to do is clarify where you want the results of the forms to be sent. For this form, let's send the results to the default file name, and send the e-mail to a CustomGuide address. The following tells you how each of these options work.

   - **File Name:** This option will send the form results to a file you specify. By default, this file is located in the _private folder of the current web.
   - **E-mail address:** This option will send the form results to the e-mail address you specify. For this feature to work, your Web server must have the FrontPage Server Extensions installed, and the e-mail options must be correctly configured.
• **Database:** This option will send the form results to a new or existing Microsoft Access database. Click the Options button in the Form Properties dialog box to configure the database. For this feature to work, your Web server must have the FrontPage Server Extensions installed.

• **Other:** Sends form results to a custom form handler, or to the Registration or Discussion form handler.

2. **In the E-mail address option under the Where to store results area, type smith@customguide.com.** In the Form name option under the Form Properties area, type **Custom Tour Form.**

   Now, each time someone fills out a form and clicks the Submit button, a copy of the results will be sent to smith@customguide.com. Compare your form to Figure 9-12. You can further customize how you view your form results; just continue to the next lesson.

3. **Click the Options button in the dialog box, and click the File Results tab.**

   The Options for Saving Results of Form dialog box appears, as shown in Figure 9-13. You can change the file format or add another file to store the form results.

4. **In the File Format drop-down list, select Text database using comma as separator.**

   This format is good if you want to convert the files to a database or spreadsheet. Refer to **NOTE:** If your system is not set up correctly, you will get an error message. Ask your system administrator for help when setting up the form results.

7. **Close the Lesson 9B file without saving your changes.**

   **Table 9-3: Options for File Formatting** for more information on choosing a file format that is right for your form results.

5. **Click the E-mail Results tab in the Options for Saving Results of Form dialog box.**

   The tab appears, as shown in Figure 9-14.

6. **Type Custom Tour Queries in the Subject line text box, and click OK to close the click Options for Saving Results of Form dialog box.** Click **OK** to close the Form Properties dialog box.

   Now the e-mailed Form Results will have Custom Tour Queries in the Subject line.

   **NOTE:** If your system is not set up correctly, you will get an error message. Ask your system administrator for help when setting up the form results.

7. **Close the Lesson 9B file without saving your changes.**

   **Table 9-3: Options for File Formatting**

<table>
<thead>
<tr>
<th><strong>File Format</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML</td>
<td>Saves the file in standard Web page format.</td>
</tr>
<tr>
<td>HTML definition list</td>
<td>Saves the file in a Web page that’s formatted like a dictionary (name and definition)</td>
</tr>
<tr>
<td>HTML bulleted list</td>
<td>Saves the file in a Web page that’s formatted as a bulleted list</td>
</tr>
<tr>
<td>Formatted text with HTML</td>
<td>Saves the file so it is easily read in a Web browser</td>
</tr>
<tr>
<td>Formatted text</td>
<td>Saves the file so it is easily read in a text editor (i.e., Microsoft Word)</td>
</tr>
<tr>
<td><strong>File Format</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>Text database using comma, tab,</td>
<td>Saves the file so it is easy to use in a spreadsheet or database</td>
</tr>
<tr>
<td>or space as a separator</td>
<td></td>
</tr>
</tbody>
</table>
Chapter Nine Review

Lesson Summary

Set up a Form
- To Set Up a Form: Click on the page, and select Insert → Form → Form from the menu. Place the cursor inside the form and press <Enter> the number of times necessary to expand the form to its desired size.

Add a Text Box
- To Add a Text Box: Click Insert → Form → One-Line Text Box or Scrolling Text Box from the menu.
- To Change Text Box Properties: Right-click the text box, and select Form Field Properties from the shortcut menu.

Add Check Boxes
- To Add Check Boxes: Click Insert → Form → Check Box from the menu. Type descriptive text next to the check box.
- To Change Check Box Properties: Right-click the check box, and select Form Field Properties from the shortcut menu. Enter information in the dialog box as you want it to be returned in the form results.

Add a Radio Button
- To Add a Radio Button: Click Insert → Form → Radio Button from the menu. Type descriptive text next to the radio button.
- To Change Radio Button Properties: Right-click the radio button, and select Form Field Properties from the shortcut menu. Enter information as you want it to be returned in the form results.

Add a Drop-Down Menu
- To Add a Drop-Down Menu: Click Insert → Form → Drop-Down Menu from the menu. Type descriptive text (i.e. a question) next to the drop-down menu.
- To Change Form Field Properties: Right-click the menu, and select Form Field Properties from the shortcut menu. Enter information as you want it to be returned in the form results.

Access Form Results
- To Access Form Properties: Click anywhere inside the form (and select Insert → Form → Form Properties from the menu. Or, right-click anywhere within form and select Form Properties from the shortcut menu.
• To Send the Form Results to an E-mail Address: Type the e-mail address in the E-mail address option in the Form Properties dialog box.

Quiz

1. Which of the following is a way to create a form?
   A. Select Form → Insert → Form from the menu.
   B. Click the Insert Form button on the Standard toolbar.
   C. Select Insert → Form → Form from the menu.
   D. Select View → Toolbars → Forms to view the Forms toolbar, and click the Draw Form button.

2. Which of the following statements about forms is NOT true?
   A. You can change the properties of the form, but not the fields inside it.
   B. You can send form results to an e-mail address.
   C. You cannot insert a form field (i.e. a check box) onto a Web page without inserting it into a form.
   D. FrontPage’s forms cannot perform calculations.

3. Which fields can you insert into a form?
   A. Scrolling text box
   B. Radio button
   C. Drop-down menu
   D. All of the above.

4. You can change the height or width of a form by clicking and dragging the dashed lines. (True or False?)

5. Which of the following statements is true?
   A. The AutoFit feature automatically adjusts the width of a column or row so that it fits its longest entry.
   B. You can change the width of a text box by clicking and dragging the edges.
   C. The form’s dashed outline appears on the Web.
   D. You can send form results to a database or spreadsheet.

6. If the form results are going to be used in a database, it is best to save the file in HTML format. (True or False?)

7. It is possible to insert an image into a form. (True or False?)

Homework

1. Start Microsoft FrontPage, navigate to your Practice folder and open Homework 9.
2. Set up a form in the page.
3. Enter the following information into the form:
   Name: (one-line text box)       Address: (scrolling text box)       Age: (drop-down menu)
4. Set the drop-down menu properties so that it has the options: 15-25; 26-40; 40-60; 61 and above.

5. Set the form field properties to reflect each field’s information in the form results.

6. Send the form results to yogaworld@customguide.com.

7. Save the page as “Form Homework” and exit Microsoft FrontPage.

**Quiz Answers**

1. C. All the answers seem possible, but there is really only one way to insert a form; Insert → Form → Form.

2. A. FrontPage’s forms allow you to change the properties of the form, and the fields within it separately.

3. D. You can also insert a one-line text box and a check box.

4. False. You can change the height of a form by pressing the <Enter> key.

5. D. Sending form results to a database or spreadsheet is a good idea if you will be using the information later. For example, if you are compiling addresses for a mailing list, send the form results to a database or spreadsheet.

6. False. Actually, it is better to save it in text database format, with something to separate the information (i.e. comma, tab, space).

7. True. An image can easily be inserted into a form by selecting Insert → Form → Picture.
Chapter Ten: Formatting with Cascading Style Sheets

Chapter Objectives:

- Understand Styles and Cascading Style Sheets (CSS)
- Modify, Create, and Apply a Style
- Create a Cascading Style Sheet
- Apply a Cascading Style Sheet

Chapter Task: Create a Cascading Style Sheet

This short chapter is dedicated to helping make your job as Web designer easier. There are two basic features that can help you: styles and cascading style sheets (CSS). Basically, a bunch of styles put together in a single Web page create a cascading style sheet.

You have already been using styles. For example, anything you type in a Web page before it is formatted is in the default style (which is Times New Roman 12 pt in FrontPage). This chapter teaches you how to define your own styles.

Cascading Style Sheets (CSS) are kind of like uniforms for your Web site. Create the CSS, then link it to, or “put it on,” the Web pages in the site. Then, when all the pages are linked to the CSS, they will have the same font types, colors, and sizes, along with any other specifications you have created in the CSS.

As you become more proficient at creating Web sites, you will find that cascading style sheets are not just a nifty feature; they are essential to creating a Web site that looks professional, and conforms to formatting rules.
Lesson 10-1: Creating and Applying a Custom Style

Styles save a lot of time and ensure that your Web pages are formatted in a consistent manner. A style is a group of formatting settings that are stored under a single name. When you format something with a style you are actually applying several formatting settings in a single step. For example, imagine you want to format all the subheadings in a Web page using a blue Arial boldfaced font. Instead of having to select each of these formatting options separately, you could apply them all at once using a style. If you make changes to a style, everything formatted with that style is automatically updated to reflect the style changes. For example, if the subheadings in your Web page use Arial font and you later decide that you want Times New Roman, you don't have to reformat every subheading; just change the subheading style.
Here’s how to create a custom style…

1. Open the **Chapter 10** Web site located in your Practice folder.

2. Open the **Folder List** and open the eastmeeting.htm file.

   This Web page contains several different types of headings. You could format each heading individually, but we’ll save the time and effort by creating several custom styles to apply to the various headings and paragraphs. Here’s how to create a custom style…

3. **Select Format → Style** from the menu.

   The Style dialog box appears, as shown in Figure 10-1.

4. **Click the New button to create a new style.**

   The New Style dialog box appears, as shown in Figure 10-2. You need to give your new style a name.

5. **Type seminar in the Name box.**

   Now you need to specify the formatting characteristics of the style.

6. **Click Format.**

   A list of formatting attributes appears under the Format button. A style may contain one or more of the following characteristics:

   - **Font:** Applies formatting to text or characters. Includes such settings as font color, font size, and font type.
   - **Paragraph:** Applies formatting to a paragraph. Includes such settings as paragraph alignment, paragraph indentation, and paragraph spacing.
   - **Border:** Adds borders and/or shading to a paragraph. Includes such settings as the border’s style and width.
   - **Numbering:** Applies numbering or bullets to several paragraphs. Includes such settings as the number format or the character used as a bullet.
   - **Position:** Applies position formatting to a selected picture so that text wraps around the object. Includes such settings as the wrapping style and the location of the object.

   We want our style to contain font formatting.

7. **Select Font from the Format list.**

   The Font dialog box appears, as shown in Figure 10-3.

8. **In the Font Style list select Bold Italic.**

   Next let’s change the text color…

9. **Click the Color list arrow and select a dark blue color, then click OK to close the Font dialog box.**

   The Font dialog box closes. Next we need to modify the paragraph formatting in our new style.

10. **Click Format → Paragraph.**

    The Paragraph dialog box appears, as shown in Figure 10-4. We want to specify that we don’t want any space to appear above the paragraph.

11. **Click the After box under the Spacing heading and type 0.**

    We’re finished adding the formatting we want to the seminar style.

12. **Click OK, OK, OK.**

    You’ve just created a new style named “seminar”. Move on to the next lesson to learn how to apply the seminar style to your text.
Lesson 10-2: Applying a Style

Applying a custom style is incredibly easy—so easy that this is one of the shortest lessons in the book. Here’s how to apply a custom style...

1. **Place the insertion point anywhere in the Natasha Bryant, Ceridix Systems line of the eastmeeting.htm file.**
   
   Now let’s apply the “seminar” style we created in the previous lesson to the selected paragraph.

2. **Click the Style list arrow on the Formatting toolbar and scroll down to the very bottom of the list.**
   
   Our “seminar” style can be found at the very bottom of the Style list. If a period (.) appears in front of the seminar style, it means that it is a custom style and not a predefined HTML tag, such as a heading tag.

3. **Select the seminar style from the Style list.**
   
   FrontPage applies the formatting characteristics of the seminar style—blue, bold and italics font formatting and paragraph spacing—to the selected paragraph. Wasn’t that a lot faster and easier than applying all that formatting yourself?

4. **Apply the seminar style to the remaining seminar headings: Brian Nordet North Shore Travel and Susan Flint, Synergy Inc.**

   You might be wondering why you would want to use styles when you can use FrontPage’s much more user-friendly themes instead. Themes are specific to Microsoft FrontPage—so if you try editing a Web page formatted with a theme in another program, such as Macromedia Dreamweaver, you’ll run into some problems. While they may seem more complicated, styles are universal and can be understood by any high-end Web design program. Once you understand how to use them, styles are also much more powerful and flexible than themes.
Chapter Ten: Formatting with Cascading Style Sheets

Lesson 10-3: Modifying a Style

Now that you know how to create and apply styles, you can move on to what’s really cool about styles—modifying them. You can modify the formatting options for a style the same way that you can modify the formatting options for a paragraph. However, when you modify the formatting options for a style, every character and paragraph based on that style is updated to reflect the formatting changes. So if your boss tells you to change the font in the 20+ headings of your Web page before lunch, you won’t have to frantically go through the entire document, fixing each heading. Just modify the style the heading is based on and… Viola! All the headings are reformatted with only a few clicks of the mouse.

1. **Select Format → Style** from the menu.  
The Style dialog box appears.
2. **Select Seminar from the Style list, then click Modify.**  
The Modify Style dialog box appears. Now you need to specify the formatting characteristic(s) that you want to modify.
3. **Click Format and select Font.**  
The Font dialog box appears.
4. **Click the Color list arrow and select a dark red color.**  
Move on to the next step and save your changes to the style.
5. **Click OK, OK, OK.**  
Every paragraph based on the seminar style is automatically updated to reflect the change in color. Look how much time you just saved by modifying the seminar style! If you hadn’t used a style, you would have had to reformat each heading manually—plus there’s always the chance that you might miss reformatting one of the headings.
Lesson 10-4: Creating and Linking a Cascading Style Sheet

In the previous lessons you have been working with styles for a single Web page to ensure that various elements of the Web page are formatted in a consistent manner. The real power of styles is to apply consistent formatting across all the pages in a Web site. To apply styles to several Web pages you need to create a cascading style sheet (CSS) that contains the HTML definitions for the styles. Once you have created a cascading style sheet you can link it to every page in a Web site and utilize its styles.

Here’s how to create a cascading style sheet…

1. **Click the New button on the Standard toolbar.**
   A new, blank page appears—this will be our cascading style sheet. Next we have to add our custom styles to the cascading style sheet.

2. **Select Format → Style from the menu.**
   The Style dialog box appears. We’ll add the seminar style we’ve been using to the cascading style sheet.
3. Click New to create a new style.
The New Style dialog box appears.
4. In the Name box type seminar.
Now you need to specify the formatting characteristics of the style.
5. Select Format → Font from the menu.
The Font dialog box appears.
6. Specify that you want text to be formatted with Dark Blue, Bold Italic font formatting, then click OK.
Next we have to define the style’s paragraph formatting.
7. Select Format → Paragraph from the menu.
The Paragraph dialog box appears.
8. Click the After box under the Spacing heading and type 0, then click OK.
That’s it! We can save our seminar style.
9. Click OK, OK to save the seminar style.
The Style dialog box closes. The Web page still seems blank, but it actually contains HTML code that defines our seminar style. Let’s take a look…
10. Click the HTML tab at the bottom of the window.
FrontPage displays the HTML code for the cascading style sheet, as shown in Figure 10-7. Move on to the next step to save the cascading style sheet.
11. Select File → Save As from the menu.
The Save As dialog box appears. First we need to give our style sheet a name…
12. Type style in the File name box.
Now you need to tell FrontPage that you want to save the Web page as style sheet.
13. Click the Save as type arrow, select HyperText Style Sheet and click Save.
FrontPage saves the cascading style sheet under the name “style.css”. We need to open a Web page to see how our new cascading style sheet works.
FrontPage opens the westmeeting.htm page.
After you create a cascading style sheet you can apply its styles to Web pages in your site by linking the cascading style sheet to them. If you modify your cascading style sheet it will automatically update the related formatting in all the linked Web pages. Here’s how to link a cascading style sheet…
15. Select Format → Style Sheet Links from the menu.
The Link Style Sheet dialog box appears, as shown in Figure 10-8.
16. Click Add.
The Select Hyperlink dialog box appears. You need to specify the cascading style sheet that you want to attach to the Web page.
17. Double-click the style.css file and click OK.
FrontPage links the style.css cascading style sheet to the Web page. Notice the paragraphs in the westmeeting page that are based on the seminar style are updated to reflect the formatting of the seminar style in the linked cascading style sheet.

It is possible to apply a cascading style sheet to only a few of the pages in a Web site. In Folders view, press the <Ctrl> key and select the pages you want to apply the cascading style sheet to with the right mouse button, and select the Selected page(s) option in the Link Style Sheet dialog box.

Quick Reference
To Create a Cascading Style Sheet:
1. Create a New Web page.
2. Select Format → Style from the menu.
3. Select the style you want to modify from the Style list.
Or…
4. Click New to create a new style.
5. Click Format and modify the characteristic(s) you want to change.
6. Type a name for the CSS, and select HyperText Style Sheet from the Save as type drop-down list.
To Link a Cascading Style Sheet to a Web Page:
1. Select Format → Style Sheet Links from the menu.
2. Click Add in the Link Style Sheet dialog box.
3. Click the cascading style sheet and click OK.
Lesson 10-5: Redefining HTML Tags Using Styles

Modifying a style is similar to redefining the HTML tags for that Web page. For example, the default formatting for the Heading 3 tag is modified, the modifications appear in the head tags at the top of the Web page, not in the <h3> tag itself.

This lesson gives a behind the scenes understanding of how styles are similar to HTML tags.

1. Open the eastmeeting.htm page. Click the HTML tab in Page view.
   The page appears in HTML code, as shown in Figure 10-10. Notice that there is no formatting, just a bunch of text and tags. The tags tell the text how to appear on the Web, and that’s how styles and tags work together.

2. Click the Normal tab. Select Format → Style from the menu.
   The Style dialog box appears. Since we’re going to redefine HTML tags, make sure that the HTML tag list is shown.

3. If necessary, select All HTML tags from the List arrow.
   Let’s redefine the Heading 3 style.
4. **Scroll down and select h3 from the Style list, then click Modify.**
The Modify Style dialog box appears. Now you need to specify the formatting characteristic(s) that you want to modify.

5. **Click Format and select Font.**
The Font dialog box appears.

6. **Click the Color list arrow and select the teal color.**
Let’s make one more change to the font.

7. **Select Bold from the Font style list.**
Move on to the next step and save your changes to the style.

8. **Click OK, OK, OK.**
Every paragraph based on the heading 3 style is automatically updated to reflect the change in color and the font weight, as shown in Figure 10-11.

Now let’s look at how the style modification changed the HTML code of the Web page.

9. **Click the HTML tab.**
Find the gray text near the top of the page, as shown in Figure 10-12. This is where the <h3> tag is redefined for the rest of the Web page.

10. **Close all open pages without saving your changes.**

### Table 10-1: Common HTML Tags

<table>
<thead>
<tr>
<th>Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>H1…H6</td>
<td>Headings of different sizes, from largest to smallest</td>
</tr>
<tr>
<td>OL</td>
<td>Formatting that appears in a numbered list</td>
</tr>
<tr>
<td>UL</td>
<td>Formatting that appears in a bulleted list</td>
</tr>
<tr>
<td>LI</td>
<td>Formatting of a single item in a list</td>
</tr>
<tr>
<td>A</td>
<td>Formatting that appears for a hyperlink</td>
</tr>
<tr>
<td>Body</td>
<td>Formatting of all the text that appears in the main part of the Web page</td>
</tr>
<tr>
<td>P</td>
<td>Dictates how much spacing will appear between paragraphs in the body</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Redefine an HTML tag:

1. Select **Format → Style** from the menu.
2. Select the tag you want to redefine from the Styles list, and click **Modify**.
3. Click **Format** and select the characteristic(s) you want to modify.
4. Specify the changes in the dialog box, and click **OK** until you return to the Web page.
Chapter Ten Review

Lesson Summary

Creating a Custom Style

1. Select Format → Style from the menu, click New and enter a name for your new style, click the Format button and select the formatting characteristics you want to change. Change the formatting options for the selected element. Click OK, OK, OK to close the various dialog boxes.

Applying a Style

2. Place the insertion point in the paragraph to which you want to apply the style. Select the style you want to apply from the Style list arrow on the Formatting toolbar.

Modifying a Style

3. Select Format → Style from the menu. Select the style you want to modify from the Style list, and click Modify. Click Format and select the characteristic(s) you want to modify. Specify the changes in the dialog box, and click OK until you return to the Web page.

Creating and Linking Cascading Style Sheet

4. To Create a Cascading Style Sheet: Create a new, blank Web page. Click Format → Style from the menu. Select the HTML tag style you want to change from the Styles list, or click New to create a new style. Click Modify, click Format and select the part of the style you want to change from the drop-down list. Make changes in the dialog box, and click OK, OK, OK. Repeat steps 1-5 to set any other styles in the style sheet.

To Link a Cascading Style Sheet: Open the Web in Folders view. Click Format → Style Sheet Links from the menu. Select the All pages or Selected page(s) option. Select the cascading style sheet you want to apply to the page(s) from the URL list, and click OK and wait for the styles to be re-formatted. Or, if the cascading style sheet doesn’t appear in the URL, click Add, select the cascading style sheet you want to link to the pages, and click OK. Click OK and wait for the styles to be re-formatted.

Redefining HTML Tags Using Styles

- Select Format → Style from the menu. Select the tag you want to redefine from the Styles list, and click Modify. Click Format and select the characteristic(s) you want to modify, specify the changes in the dialog box, and click OK until you return to the Web page.
Quiz

1. What is the difference between themes and cascading style sheets? (Select all that apply.)
   A. There is no difference.
   B. The styles in themes are already created, whereas you create the styles in cascading style sheets on your own.
   C. Themes can only be applied to one page in a Web site, whereas cascading style sheets apply to every page in the Web site.
   D. Cascading style sheets change the style of a page’s specific HTML tags in HTML code, while themes are a collection of styles applied at one time.

2. Cascading Style Sheets are really just a collection of styles linked to a Web page. (True or False?)

3. Which of the following are formatting characteristics that you can define in a style?
   A. Paragraph
   B. Font
   C. Numbering
   D. Border
   E. All of the above

4. Creating a style is the same as redefining an HTML tag. (True or False?)

Homework

1. Start FrontPage, create a new Web, and create a new cascading style sheet.
2. Create the following styles: Heading 1 (Arial, 5 (18 pt.), Dark Blue); Body text (Arial, 3 (12 pt.)); Background (yellow).
3. Link the cascading style sheet you just created to a Web page you have already created.

Quiz Answers

1. B and D. Cascading style sheets are easier to customize to your own needs than themes are. Also, cascading style sheets change the formatting in a page by applying its HTML code to the page.
2. True. The benefit of grouping a bunch of styles together in a cascading style sheet is that you can apply those styles to as many Web pages as you want.
3. E. All of the answers are characteristics that can be defined in a style. Numbering and Position are the other two characteristics that can be defined in a style.
4. False. The processes are similar, but HTML tags and styles are not the same thing. HTML tags are the default formatting for the Web page. Styles are defined by the user and do not appear as their own tags in HTML.
Chapter Eleven:
Manage Web Pages

Chapter Objectives:
- Add a Task
- View Tasks
- Start a Task
- Delete a Task
- Using Reports View

Chapter Task: Add a Task to a Web site

If you’re someone who likes to move around from page to page while building a Web site, you might want to track the tasks you still have to complete before moving on to the next page. In FrontPage, making sure you get every I dotted, every T crossed, and every loose end tied is easy with the Folders, Tasks, and Reports views. Just like your filing-cabinet, Folders view allows you to find the page you still need to tweak, or the file that needs to be added to the Web site. Tasks view keeps track of all the to-do items you still have to complete on your Web site. The final view we’ll be looking at in this chapter is Reports view, which allows you to see the status of the entire Web at one time.

If you have ever used Microsoft Project, you will realize that the Tasks view in FrontPage works similarly. You can record the status of the task, prioritize it, see when it was last updated, specify what type of task it is, and view to whom the task is assigned. Beware of becoming too involved in tasks, however: keeping track of a bunch of little tasks can take more time than actually finishing the task.

Prerequisites
- Know how to use menus, toolbars, dialog boxes, and shortcut keystrokes
- Know how to select text
Lesson 11-1: Add a Task

Recording tasks that need to be finished in a Web site seems like a waste of time; why not just go ahead and finish a page altogether? This is a good work ethic, but it’s not practical for a project as time-consuming and involved as building a Web site. Building Web sites takes a lot of time, and there are many things to consider, so keeping track of things you have left to do is important. You wouldn’t want to publish your Web site having forgotten to add a few pictures, would you?

1. Navigate to your Chapter 11 Practice folder, open the Tasks web, and open the Site Gallery.htm page.
   The Site Gallery.htm page appears on your screen.
   By now, most of the pages in the Web site are finished, but the Site Gallery doesn’t have any pictures of Egypt or Italy. Since it is a gallery representing the entire Web site, we had better give an equal advertising opportunity to all three countries. Go to the next step to add this task.

2. Select Edit → Task → Add Task from the menu.
   The New Task dialog box appears.
   **NOTE:** If the task you want to add is on a specific page in the Web site, add the task while the page is open. Or, if you are in a different view when you add the task, select the page with which the task is associated beforehand. Otherwise, if you want to assign a task that applies to the entire Web site, go to Tasks view, right-click in the window and select Add Task from the shortcut menu.

3. Type Insert Photos in the Task name: field.
   This is what will appear in Tasks view for the name of the task.

4. Click High in the Priority list.
   This information will also appear in the Tasks view.
5. **Type** Insert photos of Egypt and Italy to the site gallery in the **Description** area of the dialog box, and click **OK**.

The Description area allows you to detail what the task involves, which is especially useful if more than one person is working on the site. Compare your dialog box with Figure 11-1.
Lesson 11-2: View and Edit Tasks

Once you have entered a task on a page or Web site, it is added to the list in Tasks view. To view this list, just click the Tasks button in the Views bar.

1. Scroll down the Views bar and click Tasks.
   All the tasks that have been added to the Web site appear in the window. Changing a task is very simple as well.

2. Right-click the Table makeover task, and select Edit Task from the shortcut menu.
   The Task Details dialog box appears. Not all the information is completely filled out in this task so complete it in the next step.

3. Change the Priority to High, type Cut and copy pictures and text into a table in the Description area, and click OK.
   The task appears with these changes in Tasks view.

4. Click the Priority column heading button.
   The list is re-sorted to list High priority tasks first. Each heading organizes the list differently. Go ahead and experiment by clicking the heading buttons to see how each heading organizes the list.

---

Quick Reference

To View Tasks:
- Click the Tasks button on the Views bar

To Edit a Task:
- In Tasks view, right-click the task and select Edit Task from the menu.

To Re-sort the Tasks List:
- Click the heading button by which you want to re-sort the list.
Lesson 11-3: Start or Delete a Task

The hardest part about working with tasks is starting them. Fortunately, once you’ve started a task in FrontPage, you can always stop and complete it later. When you are finished, just like crossing an item off a list, you can easily delete the task from the Tasks list.

1. In Tasks view, right-click the Insert Photos task, and select Start Task from the shortcut menu.
   FrontPage sends you to the Site Gallery page, ready for you to work on it.
   Once you complete a task, you can either mark it as completed, or delete it altogether.

2. Go back to Tasks view. Select the lighthouse and press the <Delete> key.
   The Confirmation Delete dialog box appears. To mark a task as completed, just right-click on the task and select Mark as Completed.

3. Click Yes to delete the task.
   The task disappears from the list.

   **NOTE:** If you delete a task but end up wanting to view it later, you can do so by right-clicking in the Tasks window (not on a task), and selecting Show Task History from the shortcut menu.
Lesson 11-4: Using Reports View

If you are wondering about any statistics in your Web site, Reports view is the place to go. Reports view can tell you many things, including the number of files in the site, the number of hyperlinks, and the number of incomplete hyperlinks. You can also view a customized report of the site. This lesson will show you how to use Reports view.

1. If necessary, navigate to your Chapter 11 Practice folder and open the Tasks web. Click the Reports button in the Views bar.

The Site Summary report appears on your screen, which provides a general overview of everything in your Web site.

FrontPage can prepare reports that are more specific as well.

2. Select View → Toolbars → Reporting from the menu.

The Reporting toolbar appears.

3. Click the drop-down menu in the Reporting toolbar, and select Slow Pages from the menu.

The window is blank. A more specific report appears in the window. If the report does not show any pages, just change the number of seconds in the Reporting toolbar.

4. Click the seconds drop-down menu, and select 10 seconds.

The report should show any pages that take over 10 seconds to download.

Refer to

Table 11-1: Types of FrontPage Reports for more information on the reports available.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Summary</td>
<td>Displays a general overview of the site's elements</td>
</tr>
<tr>
<td>All Files</td>
<td>Provides information on each file in the Web site</td>
</tr>
<tr>
<td>Recently Added Files</td>
<td>Reports files created in the last 30 days</td>
</tr>
<tr>
<td>Recently Changed Files</td>
<td>Reports files changed in the last 30 days</td>
</tr>
<tr>
<td>Older Files</td>
<td>Displays files that have not been changed in the last 72 days</td>
</tr>
<tr>
<td>Unlinked Files</td>
<td>Lists files that cannot be accessed from the site's home page</td>
</tr>
<tr>
<td>Slow Pages</td>
<td>Lists pages that take at least 1 second to download on a 28.8 Kb/s modem</td>
</tr>
<tr>
<td>Broken Hyperlinks</td>
<td>Displays the status of all the hyperlinks in the site</td>
</tr>
</tbody>
</table>

Quick Reference

To View Reports:
- Click the Reports button in the Views panel.

To View Specific Reports:
1. Click View → Toolbars → Reporting from the menu.
2. Click the drop-down list to select a different type of report.
Chapter Eleven Review

Lesson Summary

Add a Task

- To Add a Task: Select Edit → Task → Add Task from the menu. Or, click the drop-down arrow to the right of the New Page button, and select Task from the menu. In any view, right-click on the page with the task you want to add and select Add Task from the shortcut menu.

View and Edit Tasks

- To View Tasks: Click the Tasks button on the Views bar
- To Edit a Task: In Tasks view, right-click the task and select Edit Task from the menu.
- To Re-sort the Tasks List: Click the heading button by which you want to re-sort the list.

Start or Delete a Task

- To Start a Task: Right-click the task you want to start, and select Start Task from the shortcut menu. Or, in Tasks view, select the task, then select Edit → Task → Start from the menu.

Using Reports View

- To View Reports: Click the Reports button in the Views panel.
- To View Specific Reports: Click View → Toolbars → Reporting from the menu. Or, click the drop-down list to select a different type of report.

Quiz

1. Which of the following is NOT a way to add a task?
   A. Select Edit → Task → Add Task from the menu.
   B. Click the Add Task button on the Standard toolbar.
   C. Right-click on a page in Folders view, and select Add Task from the shortcut menu.
   D. Right-click in the Tasks view window, and select New Task from the shortcut menu.

2. Which of the following statements about tasks is NOT true?
   A. You must associate a task with a specific page.
   B. You can automatically sort information in Tasks view by priority, status, or chronological order, by clicking the column heading button.
   C. FrontPage can recall all the tasks added since a Web site was created in the Show Task History option.
   D. Tasks can be assigned to specific individuals working on the Web site.
3. Which of the following reports are NOT available in Reports view?
   A. Publish Status, Older Files, Component Errors, and Categories
   B. Site Summary, Unlinked Files, Recently Changed Files, and Assigned To
   C. Review Status, Broken Hyperlinks, All Files, and Slow Pages
   D. Valid Hyperlinks, Finished Tasks, Unused Themes, and Internal Hyperlinks

4. You cannot edit a task after it has been added to the Web site. (True or False?)

Homework

1. Start Microsoft FrontPage. Navigate to your Chapter 11 Practice folder, and open the Wedding Web site. Open the index.htm page.

2. Click the Tasks button in the Views bar, and add a High Priority Task to include a DJ hyperlink.

3. Click the Folders button in the Views bar, and add a task to create the DJ Web page.


Quiz Answers

1. B. There is no Add Task button on the Standard toolbar.

2. A. Tasks don’t have to be assigned to a particular Web page; they can be assigned to the Web site in general.

3. D. Unused Themes and Internal Hyperlinks are items that are reported, but they are not in the Reporting drop-down menu.

4. False. You can edit tasks by right clicking on the task and selecting Edit Task from the shortcut menu.
Chapter Twelve: Publishing Web Pages

Chapter Objectives:

• Choose a Web Presence Provider
• Assess a Pre-publish Checklist for your Web Site
• Change a Web Site’s Page Options
• Specify Keywords for Web Pages
• Transfer Web Pages to a Web Server
• Publicize Web Pages

Chapter Task: Publish a Web site to the Internet

The final step in building a Web site is actually publishing it to the Internet. This step requires more research than most of the other steps in the Web-building process, but the overall success of your Web site depends on it. Even a beautifully designed Web site with nice graphics and good use of tables can fail if the Web Presence Provider doesn’t give the site very much flexibility.

This chapter will show you how to begin publishing your Web site onto the Internet. However, the initiative to contact Web service providers and related tasks is up to you.

Also, remember that publishing your site on the Internet is not the last thing you’ll ever have to do with the Web site. Constant checking of links and updating changes is required. Congratulations on getting this far, however, and good luck.
Lesson 12-1: Choose a Web Presence Provider

The main thing you need to publish a Web site onto the Internet is a server, a computer that stores, monitors, and controls access to your Web pages. Usually you won’t have the funds to buy a server just to put your pages on the Internet, so you can choose someone else to provide the service: Web Presence Provider (WPP). There are many different types of WPPs available, so be sure you make an informed decision and find a WPP that’s suited for your Web site. This lesson will show you the types of WPPs are available, and what to look for when you’re researching.

<table>
<thead>
<tr>
<th>WPPs</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your Own Web Server</td>
<td>This is the most expensive and difficult option, but if you want to have complete control over your Web pages, purchase your own server. This option also requires a full-time connection to the Internet.</td>
</tr>
<tr>
<td>Internet Service Providers</td>
<td>These companies provide Internet access to their customers. Internet Service Providers often reserve space on their Web servers where their customers can publish their own Web sites free of charge.</td>
</tr>
<tr>
<td>Commercial Online Services</td>
<td>Commercial Online Services, such as America Online, publish customer Web pages for free.</td>
</tr>
<tr>
<td>Free Web Presence Providers</td>
<td>These companies on the Web will publish your Web site for free. However, the amount of storage space is limited, and they will probably place advertisements on the pages.</td>
</tr>
</tbody>
</table>
Now that you know what kinds of WPPs are out there, how do you find them? The Internet is a good resource for researching these options. You could start with the Microsoft page (www.microsoftwpp.com), as shown in Figure 12-1. All of the WPPs listed on the site host FrontPage server extensions.

What should you look for when comparing WPPs? Use the following table to guide your selection process.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>FrontPage Server Extensions</strong></td>
<td>This is an important question because some WPPs do not support FrontPage Server Extensions. These extensions allow advanced features of FrontPage to work, such as hit counters and other components.</td>
</tr>
<tr>
<td>Security</td>
<td>A secure server encrypts data so unauthorized parties cannot read the information. This is especially important if Web users will be providing personal information to your Web site.</td>
</tr>
<tr>
<td>Storage Space</td>
<td>WPPs will usually limit the amount of storage space you can use for your Web site. Choose a WPP that allows the storage of at least 5 MB of information.</td>
</tr>
<tr>
<td>Technical Support</td>
<td>A WPP should provide technical support in case you have problems with your Web pages. Try to get a sense of how good the service is, however. Will the technical support get back to your question in a day or a week? When you call, will technical support answer the phone immediately, or will you be on hold for 15 minutes?</td>
</tr>
<tr>
<td>Traffic Limit</td>
<td>Most WPPs limit the amount of information that is transferred from your Web site. You may even have to pay extra if the transfer amount goes over the limit. Choose a WPP that allows the transfer of at least 50 MB of information in a day.</td>
</tr>
<tr>
<td>Domain Name Registration</td>
<td>Your domain name is what users will type in the browser to access your Web pages. Most WPPs will register your domain name for a fee. Personalized domain names are especially good because they are easy to remember.</td>
</tr>
</tbody>
</table>
Lesson 12-2: Pre-publish Task List

Before you publish your Web on the Internet, make sure it is free of mistakes like misspelled words, broken hyperlinks, and incomplete pages. Though not exhaustive, this lesson provides a general list of tasks to address before publishing the Web.

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit and finalize the textual and visual content in each page</td>
</tr>
<tr>
<td>Check links to make sure they are linked to the correct page, image, email address, etc.</td>
</tr>
<tr>
<td>Look over appearance of Web pages. If necessary, enhance Web page appearance by</td>
</tr>
<tr>
<td>adding a Web theme to the site, or format the pages so their appearance is cohesive.</td>
</tr>
<tr>
<td>Run the spell check over the entire site. You can check the whole site at once by clicking Folders View, clicking the Spelling button on the Standard toolbar, and selecting the Entire web option button.</td>
</tr>
<tr>
<td>Complete any unfinished tasks in Tasks view</td>
</tr>
<tr>
<td>Verify the Web site’s hyperlinks in Reports view</td>
</tr>
<tr>
<td>Verify that none of the pages are “dead-ends”; make sure that there are navigation options to other pages on the Web</td>
</tr>
<tr>
<td>Add any missing pages or page content as necessary</td>
</tr>
<tr>
<td>Run a Site Summary in Reports view</td>
</tr>
<tr>
<td>Update shared borders and navigation bars</td>
</tr>
<tr>
<td>Update the Navigation and Hyperlinks views</td>
</tr>
<tr>
<td>Update FrontPage components</td>
</tr>
<tr>
<td>Delete any unused or outdated files</td>
</tr>
<tr>
<td>Verify that your pages are organized by tables, and are displayed in pixels or percent</td>
</tr>
</tbody>
</table>
### Tasks

| Preview the site on different computers and browsers as much as possible | Set the Web site’s page options so it is viewable by the largest audience possible |

You will also have to gather the following information from your Web Presence Provider. You will be prompted to provide this information to complete the Web publishing process:

- **User Name**: The user name is assigned by your Web Presence Provider.
- **Server Address**: The server address is the URL of the computer that stores your Web site.
- **Password**: The password is necessary so you can access your Web site and make changes to it after it is published.
- **Server type**: Servers have different settings that will affect certain aspects of your Web site. For example, the server hosting your Web site may only allow 100 hits on your Web site each day.
Lesson 12-3: Change a Web Site’s Page Options

Microsoft FrontPage is probably the easiest Web-design program to use, but like most programs, it has a downside. One of the most controversial things about Microsoft FrontPage is that it uses specific server extensions. This means that servers without FrontPage Server Extensions have to use special codes to view FrontPage Web sites. Some components in FrontPage absolutely require that the server have FrontPage Server Extensions installed.

This has caused controversy because it seems that Microsoft is forcing its monopoly onto the Web; if you use Microsoft’s Web developing program, you and anyone that wants to view the site has to use Microsoft’s server programs and Web browser. This takes opportunities away from competing companies like Netscape, which makes another Web browser called Netscape Navigator.

Don’t let this deter you from using FrontPage. It is possible to make your FrontPage Web site compatible to almost all servers on the Internet. If you want to do this however, don’t expect to use advanced components like the hit counter or scrolling marquee.

This lesson will show you how to change the page settings of your Web site so that it is available to the largest audience possible.

1. Navigate to your Chapter 12 Practice folder, open the Publish web, and open the index page.
2. Click Tools → Page Options and click the Compatibility tab in the Page Options dialog box.
   The Compatibility tab of the Page Options dialog box appears, as shown in Figure 12-3.
3. **Click the Browsers: drop-down list, and select Both Internet Explorer and Navigator.**
   This setting enables the Web features supported by both Internet Explorer and Netscape Navigator browsers.

4. **Click the Browser versions: drop-down list, and select 4.0 browsers and later.**
   The browser versions drop-down list decides which Internet technologies will be enabled. For example, when the 4.0 browsers and later option is selected, the ActiveX and VBScript controls are de-selected in the technologies area of the dialog box. Refer to Table 12-4: Internet Technologies for more information.

5. **Click the Servers: drop-down list, and select the option that matches the type of server your WPP will be using.**
   You should acquire this information from your Web Presence Provider.

6. **If your WPP will support FrontPage Server Extensions, click the Enabled with Microsoft FrontPage Server Extensions option.**
   Again, you will need to acquire this information from your WPP.

7. **Click all the Technologies options (except ActiveX and VBScript) to select them, and click OK.**
   It’s a good idea to check all of the options, because it doesn’t hurt anything to make them available.

---

**Table 12-4: Internet Technologies**

<table>
<thead>
<tr>
<th>Technology</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActiveX</td>
<td>This application allows multimedia affects to occur in a Web page (animation, interactive objects, etc.) This technology is not available with the “Browser versions above 3.0” option.</td>
</tr>
<tr>
<td>VBScript</td>
<td>This is a Microsoft scripting language that is used to imbed interactive elements in a Web page. This technology is not available with Browser versions above 3.0.</td>
</tr>
<tr>
<td>JavaScript</td>
<td>This is a Netscape scripting language that is used to create dynamic content in Web pages</td>
</tr>
<tr>
<td>Java applet</td>
<td>This program is written in the Java programming language. It adds multimedia and interactive affects to a Web page.</td>
</tr>
<tr>
<td>Dynamic HTML</td>
<td>This is a code that allows you to create animated effects for text or other object. You can also use it to respond to input from users</td>
</tr>
<tr>
<td>Frames</td>
<td>This control enables frames, which allow multiple Web pages to appear simultaneously in one browser window.</td>
</tr>
<tr>
<td>CSS 1.0 (formatting)</td>
<td>This is an HTML variable that allows you to apply text formatting in a Web page (color, font size, font type, etc.)</td>
</tr>
<tr>
<td>CSS 2.0 (positioning)</td>
<td>This is an HTML variable that allows you to position objects on a Web page</td>
</tr>
<tr>
<td>Active Server pages</td>
<td>These pages are located on the server. They enable scripts that process the page</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Change a Web Site’s Page Options:**

1. **Click Tools → Page Options from the menu.**
2. **Click the Compatibility tab.**
3. **Change the options according to the type of Web site you created, and the type of server that will host your Web site.**
Lesson 12-4: Specify Keywords for a Web Page

Once you have chosen a Web Presence Provider, you can finalize details in the Web site, such as the keywords for Web pages. Search engines try to match the keywords of Web pages with words that the user entered in the search. This lesson will show you how to specify keywords for the Web pages in your site.

1. If necessary, navigate to the Chapter 12 Practice folder, open the Publish Web, and open the index page.

   Because this is the home page, there are more keywords we can enter for the page.

2. Click File \(\rightarrow\) Properties from the menu, and click the Custom tab in the Page Properties dialog box.

   The Custom tab of the Page Properties dialog box appears, as shown in Figure 12-4.

3. Click the Add button in the Page Properties dialog box.

   The User Meta Variable dialog box appears. This will categorize the keywords in the variables list.

4. Type keywords in the Name: box of the User Meta Variable dialog box.

   Type Egypt, Italy, Greece, travel, North Shore Travel in the Value: box of the dialog box, and click OK.

   Compare your dialog box to Figure 12-5. The keywords appear on the Custom tab of the Page Properties, as shown in Figure 12-4.

5. Click OK.

Quick Reference

To Open the Properties Dialog Box:
- Click File \(\rightarrow\) Properties from the menu
- Or...
- Right-click on the page and select Page Properties from the shortcut menu.

To Specify Keywords for a Web Page:
1. Click the Custom tab in the Page Properties dialog box.
2. Click the Add button.
3. Type keywords in the Name: box, and enter the page’s keywords in the Value: box.
4. Click OK.
Lesson 12-5: Transfer Web Pages to the Web Server

Once you have chosen a Web Presence Provider (WPP), previewed your Web, and gone through a final check-up on your Web site, you are ready to send your pages to the Web server. This lesson will give you an idea of how to go about this procedure; however, the steps will differ depending on your WPP and individual settings.

1. **Connect to the Internet.** Navigate to your Chapter 12 Practice folder and open the Publish Web folder.
   
   Your web has gone through the pre-publishing checklists, and is ready to be published.  
   
   **NOTE:** You will need to have the following information ready to provide: your User Name, Password, and Web server address.

2. **Click the Publish Web button on the Standard toolbar.**
   
   The Publish Web dialog box appears, as shown in Figure 12-6.

3. **Type the address of the Web server that will host your Web pages in the Publish Web dialog box, and click the Publish button.**
   
   Your server’s address will be different from Figure 12-6. Notice that another dialog box appears, which requires your user name and password from the WPP.

4. **Enter your User Name and Password into the Name and Password dialog box, and click OK.**

   FrontPage copies your pages onto the Web, and a confirmation dialog box appears.

5. **Click the Click here to view your published web site hyperlink to view the site on the Web.**

   Your Web site appears on the Internet.

---

**Figure 12-6**

The Publish Web dialog box

When possible, have your system administrator manage and upload a Web site.

---

入库 Quick Reference

To Transfer Web Pages to the Web Server:

1. Connect to the Internet. Open the Web site you want to publish in FrontPage.

2. Click the Publish Web button on the Standard toolbar.

3. Type the address of the Web server that will host your Web pages in the Publish Web dialog box, and click the Publish button.

4. Enter your User Name and Password into the Name and Password dialog box, and click OK.

5. Click the Click here to view your published web site hyperlink to view the site on the Web.
Lesson 12-6: Promote Your Web Site

Now that you've created and published a Web site on the Internet, how are you going to get people to find it among the millions of other Web pages on the World Wide Web? Here are some ideas on how to promote your Web site:

- **Use the Mail:** Send mail through mailboxes or inboxes to let people know about your Web site. Be sure to include the topic of the Web site so they know what to expect before visiting it.

**Figure 12-7**
The Overture Web site is a great tool for advertising on the Internet.

**Figure 12-8**
Google is a popular search engine, and is a good advertising tool on the Internet.
• **Exchange Hyperlinks:** Find another Web site that is related to your Web site’s topic. Ask the author to include a link to your Web site on his or her Web site, and tell the author that you will do the same. This gives users greater accessibility to sites of similar topics.

• **Announce your site to Newsgroups:** Go to newsgroups that discuss the topic related to your Web site, and post an announcement about your Web site.

• **Sign onto Search Engines:** People often use search engines such as Google and Yahoo! to find what they’re looking for on the Web. Add your Web site to the search engine list to generate more hits. A good place to start researching how to do this is www.submit-it.com.

• **Advertise on the Internet:** Companies will sometimes set aside a portion of their Web site where Web sites can be advertised, often for a fee. This is an expensive but effective way to publicize your Web site.

• **Use your Imagination:** These are a few common ways to get the word out, but remember to use your own creativity and ingenuity to get people to visit your Web site.
Chapter Twelve Review

Lesson Summary

Choose a Web Presence Provider

- Research Web Presence Providers (WPPs), and select a WPP that matches the needs of your Web site.

Pre-publish Task List

- Follow a task list to ensure that your Web site is ready to be published. Also, you will need specific information from your Web Presence Provider in order to publish your Web site.

Change a Web Site’s Page Options

- Click Tools → Page Options from the menu, and click the Compatibility tab. Change the options according to the type of Web site you created and the type of server that will host your Web site.

Specify Keywords for a Web Page

- To Access Page Properties: Click File → Properties from the menu, or right-click on the page and select Page Properties from the shortcut menu.

- To Change Keywords in a Web page: Click the Custom tab in the Page Properties dialog box, and click the Add button. Type keywords in the Name: box, and enter the page’s keywords in the Value: box, and click OK.

Transfer Web Pages to the Web Server

- Connect to the Internet. Open the Web site you want to publish in FrontPage. Click the Publish Web button on the Standard toolbar. Type the address of the Web server that will host your Web pages in the Publish Web dialog box, and click the Publish button. Enter your User Name and Password into the Name and Password dialog box, and click OK. Finally, click the Click here to view your published web site hyperlink to view the site on the Web.

Publicize Web Pages

- Use the Internet to publicize your Web site by adding your Web site to search engine lists, or by advertising.
Quiz

1. Which of the following statements about WPPs is NOT true?
   A. Usually there is a limited number of transmissions WPPs will allow each day for your Web site.
   B. Using your own server is expensive, but it allows the most control over your Web site.
   C. Some WPPs publish Web sites for free.
   D. All WPPs provide an unlimited amount of storage space to its clients.

2. FrontPage Server Extensions are installed on each server on the Internet. (True or False?)

3. Which page option is most compatible for all Internet users?
   A. Both Internet Explorer and Navigator
   B. Microsoft WebTV
   C. Custom
   D. None of the above

4. Why is it important to set keywords for Web pages?
   A. Keywords are not important.
   B. Search engines search a page’s keywords to find pages related to a user’s search topic.
   C. Keywords allow hyperlinks to work from one page to another.
   D. None of the above.

5. What information is important to know before transferring Web pages to the WPP server?
   A. Your user name
   B. Your password
   C. The server’s address
   D. All of the above.

6. You can publish a Web site onto the Internet using a domain name that already exists. (True or False?)

7. Which of the following procedures can you use to change a Web site’s page options?
   A. Click Format → Options → Page Options, and select the options you want to change.
   B. Click Format → Page Options → Compatibility, and select the options you want to change.
   C. Navigate to the WPP server’s settings, and adjust them to accommodate your Web site.
   D. Click Tools → Page Options → Compatibility tab, and select the options you want to change.
8. After publishing your Web site on the Internet, it is a good idea to publicize your Web site. (True or False?)

**Homework**

1. Start Microsoft FrontPage. Navigate to the Chapter 12 Practice folder, open the Homework web, and open the index page.
2. Set the following keywords for the index.htm page: climbing, rockclimbing, rocks, fitness.
3. Set the Web site page options to allow both Internet Explorer and Netscape Navigator.

**Quiz Answers**

1. D. Most WPPs limit the amount of storage space you can use for your Web site.
2. False. FrontPage Server Extensions are not installed on all servers. The extensions are mostly used for advanced components however, such as hit counter and scrolling marquee.
3. A. Internet Explorer and Netscape Navigator are the two primary browsers that are used on the Internet.
4. B. Search engines find pages that are related to a user’s search topic by sifting through keywords.
5. D. You must know your user name, password, and the address of the server which will host your Web site.
6. False. You must acquire your own domain name for the Web site.
7. D. The only way to change your Web site’s page options is under Tools → Page Options → Compatibility tab.
8. True. No one will visit your Web site if no one is aware it exists.
Chapter Thirteen:
Using FrontPage Components

Chapter Objectives:
• Insert FrontPage Components
• Understand Office Web Components
• Insert a Spreadsheet and Chart Component
• Use a Component Property Toolbox
• Import Data into a Spreadsheet Component
• Create and Use an Interactive PivotTable

Chapter Task: Insert FrontPage Components into a Web site

Prerequisites
• Understand Windows basic functions
• Understand how to create Web sites and Web pages

Before you finish this book, you ought to know about one of the neater features in FrontPage: components. Some components are more sophisticated and complex than others, like Office Web Components. There are also some components that are very easy to use, but they add a lot to your Web page.

This chapter will concentrate on how to use components to enhance your Web page.
Lesson 13-1: Inserting FrontPage Components

Components are great additions to your Web page, because they add interactive, animated effects that stand out from the sterile images and hyperlinks of normal Web page. Microsoft has already done all the hard work for you. All you need to do is take advantage of the component options they have already programmed in FrontPage. Sound too easy? In a way, it is. Once again, Microsoft has worked its own restrictions into the programming so that any non-Microsoft program that tries to read the component may not work. You can solve this problem by diligent previewing in many different types of browsers and computer settings.

1. If necessary, navigate to your Chapter 13 Practice folder and open the index page in the Components web. If necessary, click the Page button in the Views bar.

You’re going to try adding a hit counter to the index page so you can see how many people visit your Web site.

![Figure 13-1](image1.png)

The Hit Counter Properties dialog box

![Figure 13-2](image2.png)

A Web page with a Hit Counter component
2. Place your insertion point at the bottom of the page. Click the Center button on the Formatting toolbar.
   The hit counter will appear in the middle of the page.

3. Select Insert → Component → Hit Counter from the menu.
   The Hit Counter dialog box appears. You can select from a number of counter styles, or you can use a customized counter style.

4. Select a style from the dialog box and click OK.
   The Hit Counter dialog box closes.
   Look at the Web page in the FrontPage window. All that appears is [Hit Counter]. Where is the hit counter image you picked out? Unfortunately, the hit counter image doesn’t actually appear on your page until the Web site is published on the Internet.

Refer to the tables below for additional types of components you can add to your Web page.

**Table 13-1: FrontPage Components**

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Banner Ad Manager</td>
<td>Automatically switches the advertisement banners on your Web site.</td>
</tr>
<tr>
<td>Hit Counter</td>
<td>Counts the number of times the Web page is downloaded to another computer.</td>
</tr>
<tr>
<td>Hover Button</td>
<td>Hyperlink alternative that changes its appearance when a mouse cursor is placed on it.</td>
</tr>
<tr>
<td>Marquee</td>
<td>Animated banner that scrolls text across the Web page.</td>
</tr>
<tr>
<td>Confirmation Field</td>
<td>Confirms that the form's information has been sent successfully.</td>
</tr>
<tr>
<td>Include Page</td>
<td>Pastes another page from the Web site into the current page.</td>
</tr>
<tr>
<td>Scheduled Picture</td>
<td>Inserts or removes a picture on a Web page at an appointed time and date.</td>
</tr>
<tr>
<td>Scheduled Include Page</td>
<td>Pastes another page from the Web site into the current page at an appointed time and date.</td>
</tr>
<tr>
<td>Substitution</td>
<td>Changes the value of a variable defined in the Web site.</td>
</tr>
<tr>
<td>Categories</td>
<td>Creates hyperlinks to all the pages in the defined category</td>
</tr>
<tr>
<td>Search Form</td>
<td>Creates a page with a search form to search for words or topics in the Web site</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>Creates a table of contents for the pages in the Web site.</td>
</tr>
</tbody>
</table>

**Quick Reference**

To Insert a FrontPage Component:

1. Select Insert → Component from the menu.
2. Select the component you want to insert from the list.
3. Enter the information required to finish inserting the component.
Lesson 13-2: Understanding Office Web Components

Interactive Web site features have never been so easy to use! Components are interactive objects that stand out from the sterile images and hyperlinks of normal Web page. Microsoft has already done all the hard work for you. All you need to do is take advantage of the component options they have already programmed in FrontPage.

The appeal of using Office Components is that you can insert a spreadsheet, chart or pivot table into your Web page without using Excel. The user can also view and interact with the

Components work best with Microsoft Internet Explorer 4.01 or later.
component when it is published on the Internet, without using Excel. Also, when Excel publishes a Web page, you cannot enter additional text outside the Excel data. In FrontPage, however, you can enter text in the Web page outside the Office Components.

Sound too easy? In a way, it is. The Office components use Microsoft’s ActiveX programming language. However, ActiveX language is only readable in browsers that use Microsoft Windows. So, if anyone that wants to read your Web page is using a Macintosh operating system, they are out of luck. This in mind, the most useful place for Office Components is probably within an office Intranet. That way you can be sure that everyone accessing the page has the software required to view the component.

If you’re publishing your Web page on the Internet and you feel that inserting an office component into your Web page is necessary, and you don’t mind taking a risk, go ahead with the rest of the chapter. Otherwise, it might be in your best interest to ignore office components altogether.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office Spreadsheet</td>
<td>Add an interactive spreadsheet to the Web page. You enter the formulas, column and row headings, and the user provides the information needed to work out an individualized result. For example, you could insert the information to calculate mortgage rates into the spreadsheet, publish it, and people could then enter their own information into the spreadsheet to calculate their own mortgage rate.</td>
</tr>
<tr>
<td>Office Chart</td>
<td>Usually Office Component Charts are used to chart the information provided in a spreadsheet that has already been inserted in the Web page. You can, however, use a chart to illustrate information from a different data source.</td>
</tr>
<tr>
<td>Office PivotTable</td>
<td>PivotTables list information from a spreadsheet or database. The user can choose how they want to view that information by selecting different criteria from each category in the list.</td>
</tr>
</tbody>
</table>
Lesson 13-3: Inserting a Spreadsheet Component

Spreadsheet components are like mini-Excel programs. They can do many of the things Excel can do, such as formulas, formatting, and basic editing commands, but it is not as advanced as the full Excel program.

More than likely, you will not want to insert a spreadsheet component into a Web page unless it is published in an intranet where you know that everyone has similar computer environments. Otherwise, if you insert a spreadsheet component into a Web page that will be viewed by many different browsers, chances are many people will not have the software needed to view the component.

1. Create a new Web page. Place your insertion point where you want to insert the spreadsheet on the page.

Components are just like any other kind of object you might insert into a Web page. Wherever the insertion point is located, that is where the component will be inserted.
2. **Select Insert → Component → Office Spreadsheet from the menu.**

   FrontPage inserts the spreadsheet on the Web page.

   The spreadsheet component works like a simple Excel program. Once you enter data, you can perform and calculate formulas, format the font of the data in the spreadsheet, and set parameters for visitor use on the Web.

   To understand more functions you can use with a spreadsheet component, refer to the table below.

   **Table 13-3: Spreadsheet Component Toolbar**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Click to undo the last action performed in the spreadsheet.</td>
</tr>
<tr>
<td>Cut</td>
<td>Select the text you want to cut, then click this button to remove the text from the spreadsheet onto the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Select the text you want to copy, then click this button to copy the text onto the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Place the insertion point where you want to paste the copied or cut text, then click this button to move the text from the clipboard to the spreadsheet.</td>
</tr>
<tr>
<td>AutoSum</td>
<td>Click this button to add all the cells in a column or row.</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Click this button to sort the cells in the spreadsheet in ascending order.</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Click this button to sort the cells in the spreadsheet in descending order.</td>
</tr>
<tr>
<td>AutoFilter</td>
<td>Click this button to view the spreadsheet using criteria based on the information in the spreadsheet.</td>
</tr>
<tr>
<td>Export to Excel</td>
<td>Click this button to export the information in the spreadsheet component to the Excel program.</td>
</tr>
<tr>
<td>Property Toolbox button</td>
<td>Click this button to view more menus of controls you can apply to the spreadsheet component.</td>
</tr>
<tr>
<td>Help</td>
<td>Click to view help about the spreadsheet component.</td>
</tr>
</tbody>
</table>

   **Quick Reference**

   **To Insert a Component:**

   1. Place the insertion point where you want to insert the component on the page.
   2. Select Insert → Component from the menu.
   Or...
   Click the Insert Component button on the Standard toolbar.
   3. Select the component you want to insert from the list.
   4. Provide any information required to complete the insertion.
Lesson 13-4: Using a Component Property Toolbox

Once you have inserted your spreadsheet and entered data, there are a number of things you can do with the spreadsheet that aren’t included on the component toolbar. These more advanced options are found in the Property Toolbox.

Property toolboxes work like menus. The toolbox has a number of categories that expand to show more options within the category. All three of the Office Web Components—spreadsheet, chart, and PivotTable—have a property toolbox. They differ, however, in the menus included, and the items included in the menus. This lesson will show you how to display the toolbox, along with a table that displays expanded menus in a toolbox.

1. **Click the Property Toolbox button on the Spreadsheet component toolbar.**
   The Spreadsheet Property Toolbox appears, as shown in Figure 13-8.

2. **Click the General bar in the toolbox.**
   The General menu expands, as shown in Figure 13-8. Once a menu is expanded, you can click any of the buttons in the menu to perform an action to the spreadsheet. When you are finished with a menu you can collapse it so that it doesn’t take up valuable screen space.

3. **Click the General bar in the toolbox.**
   The General menu collapses.

Refer to the table below for examples of expanded toolbox menus and their descriptions.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Perform basic functions, like undo and help in the General menu.</td>
</tr>
<tr>
<td>Show/Hide</td>
<td>Click the buttons of the spreadsheet component features you want to display in the window. In this image, all the component features are being shown.</td>
</tr>
</tbody>
</table>
### Quick Reference

To Use an Office Component Property Toolbox:

1. **Click the Property Toolbox button** in the component toolbar.
2. **Click the menu bar**, and **select the action you want to perform in the component from the menu.**

### Menu

<table>
<thead>
<tr>
<th>Calculations</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View a cell’s formula and the resulting calculation.</td>
<td></td>
</tr>
</tbody>
</table>

| Find | Enter the text you want to find in the spreadsheet, then click the Find Next button to find it. |

| Import Data | Import existing spreadsheet data into the component. |

| Protection | Specify what Web visitors can do when they use the spreadsheet. |

| Title Bar | Assign and format the title of the spreadsheet component. |

| Advanced | Assign advanced features to the spreadsheet. |

| Format | Format fonts, cells, paragraphs and numbers in the Format menu. |

---

**Menu**

<table>
<thead>
<tr>
<th>Calculations</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View a cell’s formula and the resulting calculation.</td>
<td></td>
</tr>
</tbody>
</table>

| Find | Enter the text you want to find in the spreadsheet, then click the Find Next button to find it. |

| Import Data | Import existing spreadsheet data in to the component. |

| Protection | Specify what Web visitors can do when they use the spreadsheet. |

| Title Bar | Assign and format the title of the spreadsheet component. |

| Advanced | Assign advanced features to the spreadsheet. |

| Format | Format fonts, cells, paragraphs and numbers in the Format menu. |
Lesson 13-5: Importing Data into a Spreadsheet Component

Instead of entering all the data into the spreadsheet component cell by cell, you can import data from a spreadsheet that has already been completed in another program. Importing data is kind of like copying and pasting; all the information from the original spreadsheet is inserted in the spreadsheet component, but if the original spreadsheet changes, the component’s data does not.

1. **Place the insertion point in cell A1 of the spreadsheet component.**  
The imported data will begin filling here, at the beginning of the spreadsheet.

2. **If necessary, click the Property Toolbox button on the Spreadsheet Component toolbar.**  
The Spreadsheet Property Toolbox appears. To import data, you need to expand the Import Data menu.

3. **Click the Import Data bar in the Spreadsheet Property Toolbox.**  
Here, you must enter the location of the file you want to import.  
Remember, the file must be saved in Web format before it can be imported.
4. **Enter the location of the Spreadsheetdata.htm practice file in the URL text box.**
   Your instructor should provide the exact location of the file.

5. **Click the Import Now button.**
   The data from the Spreadsheetdata.htm file is entered in the spreadsheet component.
   That sure beats entering all those formulas and numbers, don’t you think? Now, once the data has been imported, you can resize the spreadsheet to fit the data range.

6. **Place your cursor in the lower right corner of the spreadsheet window.**

7. **Click and drag the corner up and to the left to resize the spreadsheet window.**
   Compare the image to Figure 13-10.

---

Quick Reference

**To Import Data:**

1. Place the insertion point where you want the imported data to begin.
2. If necessary, open the Spreadsheet Property Toolbox.
3. Click the **Import Data** bar in the Spreadsheet Property Toolbox.
4. Enter the location of the .htm file you want to import.
5. Click the **Import Now** button to import the data.
Lesson 13-6: Inserting an Office Chart

Chart components illustrate information from a spreadsheet, usually a spreadsheet on the same page as the chart. Pairing the spreadsheet and chart components on the same Web page is an excellent scheme, because once the Web page has been published, the chart automatically updates to reflect any changes you make to the spreadsheet.

1. **Place the insertion point below the spreadsheet component on the Web page.**
   The chart will illustrate the information in the spreadsheet component that is already inserted and has data in the Web page.

---

**Figure 13-11**
Step 1 of the Office Chart Wizard

**Figure 13-12**
Step 2 of the Office Chart Wizard

**Figure 13-13**
Data Range dialog box

**Figure 13-14**
Step 3 of the Office Chart Wizard
2. **Select Insert → Component → Office Chart from the menu.**
   The skeleton of the first dialog box of the Office Chart Wizard appears. The first step is to decide which type of chart you want to use. For this chart, let’s just use the default Clustered Column type.

3. **Click Next.**
   The second dialog box asks you to specify which data source you want the chart to illustrate. Generally, you will chart either an office spreadsheet or an office PivotTable, as shown in the dialog box. The spreadsheet for the Web page is already selected, so all you need to do is go on to the next step.

4. **Make sure that the data source you want to use is selected. Click Next.**
   The third dialog box is where you specify the data range, and preview the chart.

5. **Click the Set this chart’s data in one step button at the top of the third dialog box.**
   A smaller dialog box appears, as shown in Figure 13-13. This is where you define how the information will be shown, and the data range that will be illustrated from the selected data source.

6. **Type =A5:F7 in the Data Range text box.**
   The data from these cells will be illustrated in the chart.

7. **Select the Rows option and click OK.**
   The preview of the chart appears in the dialog box, as shown in Figure 13-14.

8. **Click Finish.**
   The dialog box closes and the completed chart appears in the Web page.

---

### Quick Reference

**To Insert an Office Chart:**

1. Place your insertion point where you want to insert the chart on the page.
2. Select Insert → Component → Office Chart from the menu.
   Or...
   - Click the Insert Component button on the Standard toolbar, and select Office Chart from the list.
3. Select the type of chart you want to use from the dialog box. Click Next.
4. Choose the data source (spreadsheet or PivotTable) you want to chart from the Web page.
5. Enter the data range you want to illustrate from the data source.
6. Select how you want the data to be displayed in the chart.
7. Preview the chart, and click Finish.
Lesson 13-7: Inserting a PivotTable

PivotTables are the most difficult Office Components to insert in a Web page because they cannot use a spreadsheet component as the data source. Instead, you must connect the PivotTable to a data source already published on the Web, which is no easy task. In fact, you will probably want to ask your network administrator for help when setting up a PivotTable. Instead of trying to use a PivotTable component, you may want to create a list of data in Excel, and then publish the data as a Web page with PivotTable interactivity. This lesson shows you how to do both.

1. If necessary, create a new page. Select Insert → Component → Office PivotTable from the menu.
   The skeleton of a PivotTable appears on the Web page, as shown in Figure 13-15.
Chapter Thirteen: Using FrontPage Components

To Insert a PivotTable in FrontPage:
1. Place your cursor where you want to insert the PivotTable on the page.
2. Select Insert → Component → Office PivotTable from the menu.
3. Click the Property Toolbox button on the Component toolbar.
4. Click the Data Source list arrow.
5. Select the Connection option and click the Connection Editor button.
6. Connect the PivotTable to a data source.

To Create a Web PivotTable with Excel:
1. Select File → Save as Web Page from the menu.
2. Click Publish.
3. Specify what you want to publish on your Web page from the Choose list and type a name for your Web page file in the File name box.
4. Check the Add interactivity with box.
5. Click Publish.

PivotTables use spreadsheets as sources for their information, so have a spreadsheet of the information you want to use ready.

Quick Reference

To Insert a PivotTable in FrontPage:
1. Place your cursor where you want to insert the PivotTable on the page.
2. Select Insert → Component → Office PivotTable from the menu.
3. Click the Property Toolbox button on the Component toolbar.
4. Click the Data Source list arrow.
5. Select the Connection option and click the Connection Editor button.
6. Connect the PivotTable to a data source.

To Create a Web PivotTable with Excel:
1. Select File → Save as Web Page from the menu.
2. Click Publish.
3. Specify what you want to publish on your Web page from the Choose list and type a name for your Web page file in the File name box.
4. Check the Add interactivity with box.
5. Click Publish.
Chapter Thirteen Review

Lesson Summary

Inserting FrontPage Components

- Select Insert → Component from the menu, or click the Insert Component button on the Standard toolbar. Select the component you want to insert from the list, and enter the information required to finish inserting the component.

Understanding Office Web Components

- There are three types of Office Web Components: spreadsheet, chart, and PivotTable.

Inserting a Spreadsheet Component

- Place the insertion point where you want to insert the component on the page. Select Insert → Component from the menu, or click the Insert Component button on the Standard toolbar. Select the component you want to insert from the list, and provide any information required to complete the insertion.

Using a Component Property Toolbox

- Click the Property Toolbox button in the component toolbar. Click the menu bar, and select the action you want to perform in the component from the menu.

Import Data into a Spreadsheet Component

- Place the insertion point where you want the imported data to begin. Click the Import Data bar in the Spreadsheet Property Toolbox, enter the location of the .htm file you want to import, and click the Import Now button to import the data.

Insert an Office Chart

- Select Insert → Component → Office Chart from the menu, or click the Insert Component button on the Standard toolbar, and select Office Chart from the list. Select the type of chart you want to use from the dialog box. Click Next. Choose the data source (spreadsheet or PivotTable) you want to chart from the Web page. Enter the data range you want to illustrate from the data source. Select how you want the data to be displayed in the chart. Preview the chart, and click Finish.

Insert a PivotTable

- To Insert a PivotTable in FrontPage: Place your cursor where you want to insert the PivotTable on the page. Select Insert → Component → Office PivotTable from the menu. Click the Property Toolbox button on the Component toolbar. Click the Data Source list arrow. Select the Connection option and click the Connection Editor button. Connect the PivotTable to a data source.
• To Create a Web PivotTable with Excel: Open the Excel spreadsheet and select the cells you want to use to create the PivotTable. Select File → Save as Web Page from the menu. Click Publish. Specify what you want to publish on your Web page from the Choose list and type a name for your Web page file in the File name box. Check the Add interactivity with box and click Publish.

Quiz

1. All of the following statements are true except…
   A. Hover buttons are the most complex components.
   B. You can change the title of a spreadsheet component.
   C. A Chart Component will update itself to reflect any changes made in the spreadsheet component it illustrates.
   D. Office Web Components require ActiveX in order to be used.

2. Which of the following is NOT a component you can insert in FrontPage?
   A. Table of Contents.
   B. Substitute Picture.
   C. Scheduled Hyperlink.
   D. Scheduled Include Page.

3. All FrontPage Components require ActiveX in order to be used. (True or False?)

4. Which of the following statements is true?
   A. Chart components must use a data source outside the Web page.
   B. Once a spreadsheet component is published, it cannot be changed.
   C. The easiest way to insert an interactive PivotTable is in Excel.
   D. A spreadsheet component can only support 8 rows.

5. Which statement best describes a properties toolbox?
   A. A properties toolbox is used to define the properties of a Web site.
   B. A properties toolbox holds menus of actions you can perform in a component, like the menu bar of a full program.
   C. A properties toolbox is used to hammer out the mistakes in a Web page.
   D. A properties toolbox contains all the images inserted in a Web site.

6. ActiveX is only available on computers with Microsoft Windows. (True or False?)

7. Which of the following statements is NOT true?
   A. You can change which parts of a spreadsheet component appear on the screen.
   B. You can lock or unlock a cell or cell range by clicking the Lock button on the Standard toolbar.
   C. You can switch between open workbooks by selecting Window from the menu and selecting the name of the workbook from the Window menu.
   D. A spreadsheet component can perform all the same actions as Microsoft Excel.
8. Which of the following options is NOT located in the Component toolbar?
   A. Undo.
   B. Repeat.
   C. AutoSum.
   D. Export to Excel.

**Homework**

1. Create a new Web page.
2. Insert a spreadsheet component into the Web page, and import the data from the homework file found in the Chapter 13 Practice folder.
3. Insert a chart that illustrates the data in the spreadsheet component.
4. Insert a marquee component that says “Travel with us!”
5. Format the text in the spreadsheet so that the row and column headings are bold.
6. Insert a hit counter in the Web page.

**Quiz Answers**

1. A. Office Web components are more complex than hover buttons.
2. C. You cannot schedule a Web page to include a hyperlink.
3. False. Only Office Web Components need ActiveX. The other components use different languages.
4. C. The PivotTable Component isn’t very easy to use in FrontPage.
5. B. The properties toolbox is like a mini-menu bar.
6. True. The fact that only computers using Microsoft Windows have ActiveX is a big pitfall when using Office Web Components.
7. D. A spreadsheet component is only a shadow of all the things Microsoft Excel can do.
8. B. There is an Undo button, but not a Repeat button.
Chapter Fourteen: Understanding HTML

Chapter Objectives:

• Understand Programming Languages
• Learn Basic HTML Code

Chapter Task: Use HTML to format a Web page

Hypertext Markup Language (HTML) is the foundation of the Internet. All the text, images, tables, hyperlinks and formatting you find on pages on the Web are made possible by HTML. In fact, there was a time when HTML code was the only way to create a Web document. Fortunately, programs like FrontPage have been created so that you can use a What You See Is What You Get (WYSIWYG) editor, which automatically translates what you put in a Web page into HTML.

So why get into HTML since we have WYSIWYG editors? You don’t have to use HTML to design a good Web page. However, knowing the code of the Web separates the “enlightened” Web designers and users from those who take the nicely formatted text and images for granted.

In this chapter, we’re pulling back the curtains to reveal the nuts and bolts of the Internet. In reality, the hardest part about using HTML is knowing which codes to use to perform a certain function. Now that you have this chapter to reference, you won’t need to create a page in FrontPage’s Normal Page View again!
Lesson 14-1: Introduction to HTML

Imagine that you are representing your country at a United Nations convention. You are only fluent in your native language, so what are you going to do when a foreign-speaking representative takes the floor? Fortunately, you have a machine that translates all the different languages into a language you can understand. This machine can do this for all the other representatives at the convention as well, enabling conversations to take place between all the different countries of the world.

The Internet works somewhat like the translating machines at the UN. There are many different programming languages that are being sent through the Internet, but your computer is able to translate these different programs into text and images that you can understand; a Web page.

As you probably know, the main Web language is HTML. Other languages work with HTML to create advanced effects. JavaScript is a language that is often used to enable animated effects on the Web. Another commonly used language is ActiveX, a language exclusive to Microsoft.

- **How does Hypertext Markup Language work?** HTML code appears in tags around any formatting that is applied to a Web page’s content. These tags tell your browser how the Web page’s content is supposed to appear on your screen. In fact, certain HTML codes are required on every Web page, simply to identify it as a Web page.
• **Most tags require an opening and closing tag (two-sided tags), but some only require an opening tag (one-sided tag):** Tags indicate when to start and end formatting. In two-sided tags, if you enter an opening tag but don’t apply a closing tag, the formatting will either continue for the rest of the page, or it won’t be applied at all. An example of a two-sided tag is bold text. One-sided tags do not require a closing tag, however. An example of a one-sided tag is a Web page background, which is applied to the entire page.

• **Some HTML tags allow defining properties:** Some tags allow you to enter a property to further describe how the tagged item will appear on the Web page. For example, to center a paragraph on a page, you would type `<p align = center>` in the opening tag of the paragraph.

• **Specific HTML tags are required on each Web page:** In order for a Web browser to recognize a Web page and begin translating its code, it must first identify the document as a Web page. For example, each page opens `<html>` and closes `</html>` with a tag to identify the page as an HTML document.

• **You can nest HTML tags to apply several formats to an item:** Nested tags are tags that appear within each other. For example, you could bold and italicize text, or you could nest a numbered list within a bulleted list.

• **Images are not part of an HTML document:** When you insert an image in a Web page, the image is not actually saved within the Web page. The picture is really saved somewhere else on the Web, but you still need to enter HTML code for the image so the browser knows where to find the image, and how to display it on the screen.
Lesson 14-2: Using HTML

Creating web pages in HTML is not as common as it was in the past. Most people choose to create their pages in a WYSIWIG (What You See Is What You Get) editor which translates the page into HTML for you. But even if you use WYSIWYG to create your page, it’s a good idea to understand the basics of HTML. Format some text in this page with HTML in this lesson.

1. Navigate to your Chapter 14 Practice folder and open the layoffs page.
   We will format the text on this page using HTML code.

2. Click the HTML tab at the bottom of the page.
   The page appears in HTML code. FrontPage’s HTML code is easy to use because all the HTML tags appear in blue.
   First apply some bold formatting to text.

3. Place your cursor after the colon in the first sentence and type <b>.
   The tag turns blue, just like the other HTML tags on the page.
   For most HTML tags you must apply an opening and closing tag, which enclose the formatting. The bold tag is one of them, so apply the closing tag at the end of the text you want to format.
4. **Place your cursor at the end of the first sentence and type** `<b>`.
   The backslash indicates that it is a closing tag and all the text between the opening and closing tag will be bold.
   Now try applying a different font type to some text.

5. **Place your cursor before the P.S. and type** `<font face="arial">`.
   Though you can’t see it right now, the text between these HTML tags will appear in a font that is different from the rest of the text on the page.

6. **Place your cursor at the end of the sentence, before the `<p>` tag, and type** `</font>`.
   Ready to see if this will work? Let’s look at the page in the WYSIWYG editor.

7. **Click the Normal tab at the bottom of the page.**
   The text is formatting according to the HTML tags you applied to the text.
   Now try applying formatting in Normal view and see how the WYSIWYG editor translates the formatting into HTML.

8. **Select the text** **Who will go? Will it be me?** **and click the Italic button on the Formatting toolbar.**
   See how the HTML code looks for the formatting.

9. **Click the HTML tab at the bottom of the page.**
   Look for text you just formatted. The actual text does not appear in italics, but the `<i>` tags around the text show that the formatting will appear in a browser.
   Can you imagine creating an entire Web page using only HTML code? The process would probably take much longer if you don’t know HTML very well. But having used HTML a little bit, at least you can appreciate how WYSIWYG editors and HTML code work together.
Lesson 14-3: Working with Text

Text tags are probably the most common types of HTML code used in Web pages. HTML text tags allow you to apply any of the effects listed in a typical Font dialog box. But instead of selecting the text and applying the formatting, put tags around the text you want to format.

### Table 14-1: Text HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Font Size</td>
<td>Changes default font size from 1 to 7</td>
<td><code>&lt;BASEFONT SIZE=num&gt;</code></td>
</tr>
<tr>
<td></td>
<td>(3 is the default setting)</td>
<td></td>
</tr>
<tr>
<td>Bigger</td>
<td>Increase font size by one</td>
<td><code>&lt;BIG&gt;&lt;/BIG&gt;</code></td>
</tr>
<tr>
<td>Blinking</td>
<td>Makes text blink on and off</td>
<td><code>&lt;BLINK&gt;&lt;/BLINK&gt;</code></td>
</tr>
<tr>
<td>Bold</td>
<td>Boldfaces text</td>
<td><code>&lt;B&gt;&lt;/B&gt;</code></td>
</tr>
<tr>
<td>Citation</td>
<td>Indicates a work cited</td>
<td><code>&lt;CITE&gt;&lt;/CITE&gt;</code></td>
</tr>
<tr>
<td>Font Color</td>
<td>Font color in hexadecimal number</td>
<td><code>FONT COLOR=&quot;#rrggbb&quot;&gt;&lt;/FONT&gt;</code></td>
</tr>
<tr>
<td>Font Face</td>
<td>Font type, such as Arial</td>
<td><code>FONT FACE=&quot;face&quot;&gt;&lt;/FONT&gt;</code></td>
</tr>
<tr>
<td>Font Size</td>
<td>Font size from 1 to 7</td>
<td><code>FONT SIZE=&quot;n&quot;&gt;&lt;/FONT&gt;</code></td>
</tr>
<tr>
<td>Font Size (Points)</td>
<td>Font size in points</td>
<td><code>&lt;FONT POINT-SIZE=?&gt;&lt;/FONT&gt;</code></td>
</tr>
<tr>
<td>Font Weight</td>
<td>Font weight or boldness</td>
<td><code>&lt;FONT WEIGHT=?&gt;&lt;/FONT&gt;</code></td>
</tr>
<tr>
<td>Italic</td>
<td>Italicizes text</td>
<td><code>&lt;I&gt;&lt;/I&gt;</code></td>
</tr>
</tbody>
</table>

It's no secret: huge layoffs are coming! You're probably already asking yourself Who will go? Will it be me? Maybe... Keep watching this site and find out - we will post a list of the unfortunate details right here on December 24. P.S. Merry Christmas!

P.S. Merry Christmas!
<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non-Breaking Space</td>
<td>Non-Breaking Space Character</td>
<td>&amp;NBSP;</td>
</tr>
<tr>
<td>Overstrike</td>
<td>Strike through text</td>
<td>&lt;S&gt;&lt;/S&gt;</td>
</tr>
<tr>
<td>Plain Text</td>
<td>Disables tag processing</td>
<td>&lt;PLAINTEXT&gt;&lt;/PLAINTEXT&gt;</td>
</tr>
<tr>
<td>Preformatted Text</td>
<td>Displays text exactly as is</td>
<td>&lt;PRE&gt;&lt;/PRE&gt;</td>
</tr>
<tr>
<td>Quote</td>
<td>Quotation marks</td>
<td>&quot;</td>
</tr>
<tr>
<td>Regular Emphasis</td>
<td>Usually italicizes text</td>
<td>&lt;EM&gt;&lt;/EM&gt;</td>
</tr>
<tr>
<td>Sample Output</td>
<td>For literal characters</td>
<td>&lt;SAMP&gt;&lt;/SAMP&gt;</td>
</tr>
<tr>
<td>Smaller</td>
<td>Decrease in font size</td>
<td>&lt;SMALL&gt;&lt;/SMALL&gt;</td>
</tr>
<tr>
<td>Source Code</td>
<td>For computer source code listings</td>
<td>&lt;CODE&gt;&lt;/CODE&gt;</td>
</tr>
<tr>
<td>Strong Emphasis</td>
<td>Usually bolds text</td>
<td>&lt;STRONG&gt;&lt;/STRONG&gt;</td>
</tr>
<tr>
<td>Subscript</td>
<td>Subscripts text</td>
<td>&lt;SUB&gt;&lt;/SUB&gt;</td>
</tr>
<tr>
<td>Superscript</td>
<td>Superscripts text</td>
<td>&lt;SUP&gt;&lt;/SUP&gt;</td>
</tr>
<tr>
<td>Typewriter Style</td>
<td>Fixed width font</td>
<td>&lt;TT&gt;&lt;/TT&gt;</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines text</td>
<td>&lt;U&gt;&lt;/U&gt;</td>
</tr>
</tbody>
</table>
Lesson 14-4: Working with Paragraphs

Paragraphs are another group of HTML codes that you will use fairly often. Whether you are aligning a paragraph, making a line break, or inserting a horizontal line, the HTML code can do it all.

### Table 14-2: Paragraph HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Text</td>
<td>Aligns paragraphs</td>
<td>`&lt;P ALIGN = LEFT</td>
</tr>
<tr>
<td>Division</td>
<td>Defines the beginning and end of a division of the page</td>
<td><code>&lt;DIV&gt;&lt;/DIV&gt;</code></td>
</tr>
<tr>
<td>Blockquote</td>
<td>Sets quoted text apart from the rest of the text</td>
<td><code>&lt;blockquote&gt;&lt;/blockquote&gt;</code></td>
</tr>
<tr>
<td>Headings</td>
<td>Displays the specified hierarchical heading level (1-6)</td>
<td><code>&lt;H1&gt;&lt;/H1&gt;…&lt;H6&gt;&lt;/H6&gt;</code></td>
</tr>
<tr>
<td>Horizontal Rule</td>
<td>Draws a line across the screen</td>
<td><code>&lt;HR&gt;</code></td>
</tr>
<tr>
<td>HR Rule Alignment</td>
<td>Defines a horizontal rule's alignment</td>
<td>`&lt;HR ALIGN = LEFT</td>
</tr>
<tr>
<td>HR Thickness</td>
<td>Defines the line thickness of a horizontal rule</td>
<td><code>&lt;HR SIZE=n&gt;</code> (in pixels)</td>
</tr>
</tbody>
</table>

### Example

```html
<p align = center><h1>Why the layoffs?</h1></p>
<p>In most companies, employees are laid off because profits have fallen.&lt;br&gt;
We're just trying to get rid of all the people who wear bad clothes.&lt;/p&gt;
<blockquote>&quot;We need to dress for the future.&quot;&lt;/blockquote&gt;
<p>So if you have worn a leisure suit in the past year, you may want to budget your Christmas gifts.&lt;/p&gt;
```

Why the layoffs?

In most companies, employees are laid off because profits have fallen.
We're just trying to get rid of all the people who wear bad clothes.

“We need to dress for the future”

So if you have worn a leisure suit in the past year, you may want to budget your Christmas gifts.
<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>HR Width</td>
<td>Defines the length of a horizontal rule</td>
<td><code>&lt;HR WIDTH=n&gt;</code> (in pixels or %)</td>
</tr>
<tr>
<td>Line Break</td>
<td>Starts a new line without starting a new paragraph</td>
<td><code>&lt;BR&gt;</code></td>
</tr>
<tr>
<td>No Break</td>
<td>Prevents line breaks</td>
<td><code>&lt;NOBR&gt;&lt;/NOBR&gt;</code></td>
</tr>
<tr>
<td>Paragraph</td>
<td>Starts and ends a paragraph</td>
<td><code>&lt;P&gt;&lt;/P&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 14-5: Working with Lists

Lists are a bit more difficult to work with than paragraphs and text in HTML, because there are more tags involved. For example, look at the figures above. The type of list is defined with tags, and then each list item within those tags must be identified.

### Table 14-3: List HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compact</td>
<td>Compacted list</td>
<td>COMPACT</td>
</tr>
<tr>
<td>Definition List</td>
<td>List of terms and definitions</td>
<td>&lt;DL&gt;&lt;/DL&gt;</td>
</tr>
<tr>
<td>Definition List Item</td>
<td>Item to be defined</td>
<td>&lt;DT&gt;</td>
</tr>
<tr>
<td>Definition Text</td>
<td>Definition for the previous item</td>
<td>&lt;DD&gt;</td>
</tr>
<tr>
<td>Directory List</td>
<td>List of short items</td>
<td>&lt;DIR&gt;&lt;/DIR&gt;</td>
</tr>
<tr>
<td>List Items</td>
<td>A single item on a list</td>
<td>&lt;LI&gt;&lt;/LI&gt;</td>
</tr>
<tr>
<td>Menu</td>
<td>Displays a menu list, similar to an unordered list</td>
<td>&lt;MENU&gt;&lt;/MENU&gt;</td>
</tr>
<tr>
<td>Ordered List</td>
<td>Numbered list</td>
<td>&lt;OL&gt;&lt;/OL&gt;</td>
</tr>
<tr>
<td>Numbering Type (list)</td>
<td>Specifies the numbering type for the entire list</td>
<td>&lt;OL TYPE=A</td>
</tr>
<tr>
<td>Numbering Type (list items)</td>
<td>Specifies the numbering type for this and subsequent items</td>
<td>&lt;LI TYPE=A</td>
</tr>
<tr>
<td>Starting Number (list)</td>
<td>Specifies at which point the list numbering begins</td>
<td>&lt;OL START=?&gt;</td>
</tr>
</tbody>
</table>

Anyone who is fired should not be surprised, because the following warnings have been issued:

1. Verbal warning
2. E-mail warning
3. Written warning and clothing gift certificate
4. You’re fired!

These are some articles of clothing for which you could be warned:

- Brown polyester pants
- Leisure suits
- Fringed leather pants

Anyone who is fired should not be surprised, because the following warnings have been issued:

- Verbal warning
- E-mail warning
- Written warning and clothing gift certificate
- You’re fired!

These are some articles of clothing you could be warned:

- Brown polyester pants
- Leisure suits
- Fringed leather pants
<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting Number (list items)</td>
<td>Specifies at which point the numbering begins for this and subsequent items</td>
<td><code>&lt;LI START=?&gt;</code></td>
</tr>
<tr>
<td>Unordered List</td>
<td>Bulleted list</td>
<td><code>&lt;UL&gt;&lt;/UL&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 14-6: Working with Images

Images are a major component of Web pages since the Internet is such a visual medium. Inserting images into a Web page is kind of like inserting hyperlinks. Since the image is not actually saved in the Web page, you have to specify the URL where the browser can find an image. You must also specify how you want the image to appear on the screen in HTML.

For future reference, we will draw up a dress code so that you don’t have to be caught in one of these sticky situations.

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>Inserts a graphic on the page</td>
<td><code>&lt;IMG&gt;</code></td>
</tr>
<tr>
<td>Border</td>
<td>Specify how wide you want the image’s border to be. If you don’t want a border, enter a zero.</td>
<td><code>&lt;IMG BORDER=n&gt;</code></td>
</tr>
<tr>
<td>Align</td>
<td>Aligns the image on the page (see Table 14-5: Align Types)</td>
<td><code>&lt;IMG ALIGN=type&gt;</code></td>
</tr>
<tr>
<td>Alternative text</td>
<td>Displays alternative text if the image does not appear</td>
<td><code>&lt;IMG ALT=text&gt;</code></td>
</tr>
<tr>
<td>Height</td>
<td>Specifies the height of the image in pixels. Not necessary, but helps speed up the download process.</td>
<td><code>&lt;IMG HEIGHT=n&gt;</code></td>
</tr>
<tr>
<td>Ismap</td>
<td>Tells the browser that the image is used as an image map (a hotspot image)</td>
<td><code>&lt;IMG ISMAP&gt;</code></td>
</tr>
<tr>
<td>Src</td>
<td>Tells the browser the URL of the image file that is to be displayed</td>
<td><code>&lt;IMG SRC&gt;</code></td>
</tr>
</tbody>
</table>

For future reference, we will draw up a dress code so that you don’t have to be caught in one of these sticky situations.
There are a few different ways you can align the image on the page, as shown in the table below.

### Table 14-5: Align Types

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absbottom</td>
<td>Aligns the bottom of the image with the bottom of the current line</td>
</tr>
<tr>
<td>Absmiddle</td>
<td>Aligns the middle of the image with the middle of the current line</td>
</tr>
<tr>
<td>Baseline</td>
<td>Aligns the bottom of the image with the baseline of the current line</td>
</tr>
<tr>
<td>Bottom</td>
<td>Aligns the bottom of the image with the text baseline (default)</td>
</tr>
<tr>
<td>Center</td>
<td>Centers the image horizontally on the page (browsers treat it the same as align=middle, however)</td>
</tr>
<tr>
<td>Left</td>
<td>Aligns image on the left margin and allows text to wrap around it</td>
</tr>
<tr>
<td>Middle</td>
<td>Aligns the text baseline with the middle of the image</td>
</tr>
<tr>
<td>Right</td>
<td>Aligns the image on the right margin and allows text to wrap around it</td>
</tr>
<tr>
<td>Top</td>
<td>Aligns the top of the image with the tallest object in the line</td>
</tr>
</tbody>
</table>
Lesson 14-7: Working with Pages

Some HTML codes must appear on every Web page. Otherwise, browsers won’t be able to read or recognize the Web page. There are also some one-sided tags you can use that are applied to the entire page, such as the page background.

Table 14-6: Page HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base</td>
<td>Defines the base URL for the document</td>
<td>&lt;BASE&gt;&lt;/BASE&gt;</td>
</tr>
<tr>
<td>Body</td>
<td>Appears at the opening and closing of the page’s content that appears in the Web browser (see Table 14-7: Body Tag Attributes)</td>
<td>&lt;BODY&gt; &lt;/BODY&gt;</td>
</tr>
<tr>
<td>Head</td>
<td>Defines the ‘header’ of the Web page that contains information about the page</td>
<td>&lt;HEAD&gt; &lt;/HEAD&gt;</td>
</tr>
<tr>
<td>HTML</td>
<td>Tells the browser that the document is in HTML, and appears at the beginning and end of each document</td>
<td>&lt;HTML&gt; &lt;/HTML&gt;</td>
</tr>
<tr>
<td>Meta</td>
<td>Placed within the &lt;HEAD&gt; tags, they give the browser information about the document, like keywords for searches</td>
<td>&lt;META&gt; &lt;/META&gt;</td>
</tr>
<tr>
<td>Title</td>
<td>Appears in the title bar of the browser window. Enter this information in the header (head tags) of the Web page</td>
<td>&lt;TITLE&gt; &lt;/TITLE&gt;</td>
</tr>
</tbody>
</table>

Welcome to the Unemployment Pages Web site! Unfortunately, there are no job listings at this time, but if you visit in another month, there is sure to be a part-time box folder position available.
<table>
<thead>
<tr>
<th>Body Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Image</td>
<td>Specify an image to use as the background for a web page</td>
<td><code>&lt;BODY BACKGROUND=&quot;image&quot;&gt;</code></td>
</tr>
<tr>
<td>Background Color</td>
<td>The background’s color</td>
<td><code>&lt;BODY BGCOLOR=#rrggb&gt;</code></td>
</tr>
<tr>
<td>Text Color</td>
<td>The default text color</td>
<td><code>&lt;BODY TEXT=&quot;#rrggb&quot;&gt;</code></td>
</tr>
<tr>
<td>Link Color</td>
<td>Color of unvisited links</td>
<td><code>&lt;BODY LINK=&quot;#rrggb&quot;&gt;</code></td>
</tr>
<tr>
<td>Visited Links</td>
<td>Color of visited links</td>
<td><code>&lt;BODY VLINK=&quot;#rrggb&quot;&gt;</code></td>
</tr>
<tr>
<td>Active Link</td>
<td>Color of the currently active link</td>
<td><code>&lt;BODY ALINK=&quot;#rrggb&quot;&gt;</code></td>
</tr>
<tr>
<td>Watermarked Background</td>
<td>Specifies that the background image scrolls with the web page</td>
<td><code>&lt;BODY BGPREFERENCES=&quot;FIXED&quot;&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 14-8: Working with Tables

There are a few things you need to remember when you leave the office for the last time:

- Leave all pens, pencils, markers and paperclips.
- Do not take any paper with you.
- Clean your desk and vacuum the carpet beneath your desk and chair.
- Leave all job account information with your supervisor.

```
<table border="1" width="100%">
  <tr width=50%>Leave all pens, pencils, markers and paperclips</tr>
  <tr width=50%>Do not take any paper with you</tr>
  <tr width=50%>Clean your desk and vacuum the carpet beneath your desk and chair</tr>
  <tr width=50%>Leave all job account information with your supervisor</tr>
</table>
```

Tables are the best way to organize information on your Web page, because they keep things where you put them. Think of them as a kind of fence; they keep all the text and images “fenced in” where you put them.

### Table 14-8: Table HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define Table</td>
<td>Indicates that there is a table</td>
<td><code>&lt;TABLE&gt;&lt;/TABLE&gt;</code></td>
</tr>
<tr>
<td>Table Alignment</td>
<td>Alignment of the table on the page</td>
<td>`&lt;TABLE ALIGN=LEFT</td>
</tr>
<tr>
<td>Border</td>
<td>The table’s border width in pixels</td>
<td><code>&lt;TABLE BORDER=n&gt;</code></td>
</tr>
<tr>
<td>Border Color</td>
<td>The border color</td>
<td><code>&lt;TABLE BORDERCOLOR=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
<tr>
<td>Table Width</td>
<td>Table width in pixels or percent of the window width</td>
<td><code>&lt;TABLE WIDTH=n&gt;</code></td>
</tr>
<tr>
<td>Row</td>
<td>Items in a table row</td>
<td><code>&lt;TR&gt;&lt;/TR&gt;</code></td>
</tr>
<tr>
<td>Cell Alignment</td>
<td>The alignment of text in a cell</td>
<td>`&lt;TR ALIGN=LEFT</td>
</tr>
<tr>
<td>Cell Color</td>
<td>The cell’s background color</td>
<td><code>&lt;TD BGColor=&quot;#rrggbb&quot;&gt;</code></td>
</tr>
<tr>
<td>Cell Padding</td>
<td>Space between cell and text</td>
<td><code>&lt;TABLE CELLPADDING=n&gt;</code></td>
</tr>
<tr>
<td>Tag/Attribute</td>
<td>Description</td>
<td>Syntax</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Cell Spacing</td>
<td>Amount of space between cells</td>
<td><code>&lt;TABLE CELLSPACING=n&gt;</code></td>
</tr>
<tr>
<td>Cell Width</td>
<td>Desired cell width in pixels or percent of the window width</td>
<td><code>&lt;TD WIDTH=n&gt;</code></td>
</tr>
<tr>
<td>Cell No Linebreaks</td>
<td>Specify if text can wrap in a cell</td>
<td><code>&lt;TD NOWRAP&gt;</code></td>
</tr>
<tr>
<td>Columns to Span</td>
<td>Number of columns a cell spans</td>
<td><code>&lt;TD ROWSPAN=?&gt;</code></td>
</tr>
<tr>
<td>Rows to Span</td>
<td>Number of rows a cell spans</td>
<td><code>&lt;TD COLSPAN=?&gt;</code></td>
</tr>
<tr>
<td>Title</td>
<td>The table’s caption or title</td>
<td><code>&lt;CAPTION&gt;&lt;/CAPTION&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 14-9: Working with Hyperlinks and Bookmarks

You will probably insert at least one hyperlink in every Web page you create. Fortunately, this is easy to do when in Normal view of FrontPage, but it is also very easy to do in HTML view. Just type the text you want to use for the link, and enclose it with hyperlink tags, and the link’s destination.

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bookmark (or Anchor)</td>
<td>Marks a section of the HTML document</td>
<td>&lt;A NAME=&quot;text&quot;&gt;</td>
</tr>
<tr>
<td>E-mail</td>
<td>Where to send e-mail</td>
<td><a href="MAILTO:email@domain.com">MAILTO:email@domain.com</a></td>
</tr>
<tr>
<td>Link to Location</td>
<td>(In the same document)</td>
<td>&lt;A HREF=&quot;#link&quot;&gt;&lt;/A&gt;</td>
</tr>
<tr>
<td>Link to Location</td>
<td>(In another document)</td>
<td>&lt;A HREF=&quot;url#link&quot;&gt;&lt;/A&gt;</td>
</tr>
<tr>
<td>Target Window</td>
<td>Where a new document or web page appear, i.e. in</td>
<td>&lt;A HREF=&quot;url&quot; TARGET=&quot;_blank</td>
</tr>
</tbody>
</table>
Lesson 14-10: Working with Forms

Forms are a good way to interact with site visitors and let your users give feedback on your Web site. They can also be used to enable visitors to order a product from your Web site.

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checked</td>
<td>Use with check boxes or radio buttons</td>
<td>&lt;INPUT CHECKED&gt;</td>
</tr>
<tr>
<td>Define Form</td>
<td>Defines the area of the web page used as a form</td>
<td>&lt;FORM ACTION=&quot;url&quot; METHOD=GET</td>
</tr>
<tr>
<td>Field Name</td>
<td>The field name (required)</td>
<td>&lt;INPUT NAME=&quot;name&quot;&gt;</td>
</tr>
<tr>
<td>Field Size</td>
<td>Field size in characters</td>
<td>&lt;INPUT SIZE=&quot;n&quot;&gt;</td>
</tr>
<tr>
<td>Field Value</td>
<td>The field value</td>
<td>&lt;INPUT VALUE=&quot;value&quot;&gt;</td>
</tr>
<tr>
<td>Input Field</td>
<td>Inserts a certain type of input field such as a text box, check box, or button</td>
<td>&lt;INPUT TYPE=&quot;TEXT</td>
</tr>
<tr>
<td>List Items</td>
<td>Items in a list or combo box</td>
<td>&lt;SELECT&gt;&lt;/SELECT&gt;</td>
</tr>
<tr>
<td>Max Length</td>
<td>Maximum length in characters</td>
<td>&lt;INPUT MAXLENGTH=?&gt;</td>
</tr>
<tr>
<td>Option List</td>
<td>Creates an option list</td>
<td>&lt;OPTION&gt;&lt;/OPTION&gt;</td>
</tr>
<tr>
<td>Prompt</td>
<td>Message in input field</td>
<td>&lt;INPUT PROMPT=&quot;text&quot;&gt;</td>
</tr>
</tbody>
</table>

Forms are a good way to interact with site visitors and let your users give feedback on your Web site. They can also be used to enable visitors to order a product from your Web site.
Lesson 14-11: Working with Frames

Frames enable you to split up the Web browser window and display two Web pages at the same time. This feature is useful for displaying Web site contents as a navigation bar, or page banners. The images above display a contents frame page and its HTML code. Notice that the HTML code does not display the text within the frame pages. Instead, it defines the frameset, the frames within the frameset, the pages in each frame, and an alternative page in case the browser does not support frames.

Table 14-11: Frameset HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frameset</td>
<td>Defines a collection of frames in a frame Web page</td>
<td><code>&lt;FRAMESET&gt;&lt;/FRAMESET&gt;</code></td>
</tr>
<tr>
<td>Cols</td>
<td>Defines the number and size of columns in the frameset. The number of columns is determined by the number of values in the list</td>
<td><code>&lt;FRAMESET COLS=value&gt;</code></td>
</tr>
</tbody>
</table>

Within the frameset tag, use the HTML code from the table below to define the frames in the page.

Table 14-12: Frames HTML

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame</td>
<td>Defines a single frame within the frameset</td>
<td><code>&lt;FRAME&gt;&lt;/FRAME&gt;</code></td>
</tr>
<tr>
<td>Tag/Attribute</td>
<td>Description</td>
<td>Syntax</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Name</td>
<td>Gives the frame a name</td>
<td><code>&lt;FRAME NAME=text&gt;</code></td>
</tr>
<tr>
<td>Noresize</td>
<td>Prevents the user from resizing the frame</td>
<td><code>&lt;FRAME NORESIZE&gt;</code></td>
</tr>
<tr>
<td>Scrolling</td>
<td>Specifies whether a scrollbar will appear in the frame. Auto, the default setting, automatically displays scrollbars if the frame’s contents do not fit</td>
<td>`&lt;FRAME SCROLLING=yes</td>
</tr>
<tr>
<td>SRC</td>
<td>Defines the location of the HTML file to be displayed in the frame</td>
<td><code>&lt;FRAME SRC=url&gt;</code></td>
</tr>
</tbody>
</table>
Lesson 14-12: Working with Cascading Style Sheets (CSS)

Cascading style sheets can be fairly intimidating if you don’t know how to use them. However, they are actually quite easy to use once you understand how they are applied to a page. Once you have created a style sheet, all you have to do is link it to the page you want the style to be applied to.

Notice that in the HTML code above, there is no background color tag, font color or hyperlink tag. This is because of the style sheet. Once a style sheet is linked to a Web page, all the formatting in the style sheet is applied to the page. In this example, the style sheet adds a black background, white verdana text, red verdana hyperlinks and red verdana headings.

<table>
<thead>
<tr>
<th>Tag/Attribute</th>
<th>Description</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link</td>
<td>Creates a relationship between one document to another document</td>
<td>&lt;LINK&gt;&lt;/LINK&gt;</td>
</tr>
<tr>
<td>Rel=stylesheet</td>
<td>Defines that the &lt;LINK&gt; tag is related to an external stylesheet</td>
<td>&lt;LINK REL=stylesheet&gt;</td>
</tr>
<tr>
<td>Type=text/css</td>
<td>Defines that the linked document is an external stylesheet</td>
<td>&lt;LINK TYPE=TEXT/CSS&gt;</td>
</tr>
<tr>
<td>Href=url</td>
<td>Identifies the location of the target document</td>
<td>&lt;LINK HREF=URL&gt;</td>
</tr>
</tbody>
</table>

Table 14-13: Style Sheet HTML
## Index

### A
- adding
  - clip art..............................................130
  - hyperlinks, external ..........................160
  - hyperlinks, internal ..........................158
  - image from file .................................128
  - navigation bars ................................176
  - shared borders ..................................174
  - tables .............................................184
  - tasks ..............................................236
- Web page in Navigation view .............172
- Web pages to frames ..............................209
- adjusting
  - column width ...................................188
  - row height ......................................188
- alignment
  - cell, table ......................................192
  - image with text ................................137
  - paragraph ......................................104
- Alt key, using .....................................20
- alternative image text ............................143

### B
- background
  - color ..............................................112
  - image ..............................................140
- backspace key, using .............................47
- blank Web page, creating .......................44
- borders
  - image, adding to ...............................136
  - shared .............................................174
  - table .............................................194
- browser
  - description of ..................................14
  - previewing Web page .........................88
- bulleted lists ....................................110

### C
- cascading style sheet
  - applying .........................................118
  - creating .........................................116
  - description of ..................................51
- cells
  - alignment ........................................192
  - merging ...........................................190
  - padding ..........................................197
  - spacing .........................................196
  - splitting ........................................190
- center, paragraph ...............................104
- changing
  - column width ...................................188
  - row height ......................................188
- check boxes, forms ..............................224
- clip art
  - inserting ........................................130
- closing
  - Web pages .......................................48
- color
  - background ......................................112
  - font, changing ..................................102
- columns
  - table, deleting ................................186
  - table, inserting ................................186
  - table, width adjusting .......................188
- compatibility, Web site ........................250
- copying
  - formatting .....................................106
  - image ..............................................134
  - text ...............................................54
  - text with drag and drop .......................56
  - Web page from the Internet .................42
  - Web site to server ............................253
- creating
  - cascading style sheet .........................116
  - forms .............................................220
  - frames ............................................208
hyperlinks, external ......................... 160
hyperlinks, internal ......................... 158
tables ........................................... 184
tasks ............................................. 236
Web page from a template ................. 36
Web page using a Wizard ................. 38
Web page, blank ............................. 44
cropping ....................................... 135
CSS
applying ....................................... 118
creating ....................................... 116
description of .............................. 51
Ctrl key, using ............................... 24
cutting
text ........................................... 54
D
delete key, using ............................. 47
deleting
columns, table ............................... 186
hyperlinks .................................... 169
rows, table .................................... 186
tasks ........................................... 239
text ........................................... 46
Web pages ..................................... 92
drop-down menus, forms ................. 228
E
e-mail
hyperlink to ................................... 164
Embedded files ............................ 51
exiting
frames ......................................... 214
F
files
importing .................................... 40
finding ....................................... 58
Web host ...................................... 246
folder
importing .................................... 40
folders
displaying with the Folders list ...... 82
Folders list
displaying ................................... 82
font
color, changing ............................. 102
font type, changing ....................... 100
size, changing .............................. 101
Format Painter ............................... 106
formatting
alignment, paragraph .................... 104
background color .......................... 112
bold ........................................... 98
bulleted lists ................................. 110
cascading style sheet, applying ...... 118
cascading style sheet, creating ...... 116
color, font .................................... 102
copying ....................................... 106
font size ....................................... 101
font type ....................................... 100
frames ......................................... 212
italics .......................................... 98
numbered lists .............................. 110
paragraphs, indenting ................... 108
table borders ................................. 194
table cell alignment ....................... 192
table cell padding ......................... 197
themes, applying ......................... 114
underline ..................................... 98
formatting toolbar ......................... 19
forms
check boxes ................................. 224
creating ....................................... 220
drop-down menus .......................... 228
options ....................................... 226
radio buttons ............................... 226
results ....................................... 230
text box, adding ......................... 222
frames
creating ....................................... 208
exiting ........................................ 214
formatting ................................. 212
properties ................................... 212
saving ......................................... 213
targets, creating ......................... 210
Web pages, adding to ................... 209
FrontPage
introduction to ............................ 12
server extensions ......................... 14
starting ....................................... 16
terms ........................................... 12
G
GIF ................................................ 148
description of ............................. 51
H
help ............................................. 28
host
finding ....................................... 246
transferring Web site to ................. 253
hotspots, images ......................... 146
HTML
description of ............................. 14
HTML view .................................. 81
HTTP........................................ 14
hyperlink
deleting ............................................ 169
e-mail ............................................... 164
external ............................................ 160
image, adding to .............................. 144
internal............................................. 158
on same page ................................... 162
previewing ....................................... 166
reports view ..................................... 168
Hyperlinks view................................ 79, 170

I
image
aligning with text............................. 137
borders, adding to ...................... 136
copying ............................................ 134
cropping ........................................... 135
file formats....................................... 148
GIF ................................................... 148
hotspots ......................................... 146
hyperlink, adding to ....................... 144
inserting from clip art .............. 130
inserting, from file ....................... 128
JPEG................................................ 148
moving............................................. 133
PNG ................................................. 148
positioning ...................................... 138
resizing ............................................ 132
table, adding to ............................ 193
text alternative ............................... 143
thumbnails ....................................... 142
Web page background ...................... 140
image map ........................................... 146
importing
existing local Web page ............. 40
existing Web page from the Internet 42
text ..................................................... 62
indenting, paragraphs............... 108
inserting
clip art........................................... 130
columns, table ................................. 186
hyperlinks, external ..................... 160
hyperlinks, internal .................. 158
image from a file ......................... 128
rows, table .......................... 186
tables.............................................. 184
text .................................................. 46
Web page in Navigation view ...... 172
Internet Explorer, Microsoft ....... 250
italics ................................................. 98

K
keyboard shortcuts............................ 24
keystroke shortcuts.......................... 24
keywords ............................................. 252

L
left-align, paragraph ..................... 104
link breaks
inserting ......................................... 60
vs. paragraphs .............................. 60
list
bulleted ................................................. 110
numbered .......................................... 110

M
menus .................................................. 20
drop-down, form ......................... 228
merge, table cells .......................... 190
metatags ............................................ 252
Microsoft Internet Explorer ............ 250
moving
around a Web page ....................... 84
image ............................................... 133

N
navigation
bars, adding ..................................... 176
shared borders, adding .............. 174
Navigation view ............................. 79
switching to .................................... 171
nesting, tables ............................... 198
Netscape Navigator .......................... 250
new
Web page, blank .......................... 44
Normal view .................................... 81
numbered lists ............................... 110

O
opening
Web page ........................................ 26
Web pages ........................................ 48
options, forms.............................. 226

P
padding, cells ............................... 197
Page view ......................................... 79
paragraph
alignment ...................................... 104
indenting ........................................ 108
paragraphs
vs. line breaks ............................... 60
password ........................................... 248
pasting
  text ........................................... 54
percent, table width ........................ 200
pixels, table width ........................... 200
planning, Web site ............................ 156
PNG .............................................. 148
description of ................................ 51
points, font size ............................... 101
positioning
  image .......................................... 138
Preview view .................................. 81
previewing
  hyperlinks .................................... 166
    Web page in a browser ................... 88
printing ......................................... 86
promoting Web sites
  general tips .................................. 254
  keywords, using .............................. 252
  search engines, submitting to ........... 256
properties
  frames ......................................... 212
publicizing, Web sites ...................... 254
publishing, Web sites ....................... 253
R
radio buttons, forms ......................... 226
redo .............................................. 68
removing
  hyperlinks ................................... 169
renaming, Web pages .......................... 91
replacing ........................................ 58
reports view
  hyperlinks, checking ...................... 168
Reports view .................................. 79, 240
resizing
  image .......................................... 132
results, form ................................... 230
right-align, paragraph .................... 104
rows
  table, deleting .............................. 186
  table, height adjusting ................... 188
  table, inserting ............................ 186
S
saving
  frames ........................................ 213
  Web pages .................................... 52
scroll bars ..................................... 84
search engine
  description of ................................ 15
search engines
  submitting to .............................. 256
server address ............................... 248
server, Web, finding ........................ 246
shared borders ................................ 174
size
  font .......................................... 101
  font, changing ................................ 101
  image ......................................... 132
sorting, tasks ................................ 239
spacing
  cell, table ................................... 196
  spelling, correcting ....................... 66
split, table cells ............................. 190
standard toolbar ................................ 19
starting, FrontPage .......................... 16
T			
tables
  borders, adding ............................ 194
  cell alignment ................................ 192
  cell padding ................................ 197
  cell spacing ................................ 196
  column width, adjusting ................. 188
  deleting, columns and rows ............. 186
  image, adding to ........................... 193
  inserting .................................... 184
  inserting, columns and rows ............ 186
  merging cells ............................... 190
  nesting ...................................... 198
  row height, adjusting .................... 188
  splitting cells ............................ 190
  width, changing ........................... 200
target, frame .................................. 210
tasks
  deleting ...................................... 239
  sorting ....................................... 239
  viewing ...................................... 238
Tasks view .................................... 79
taskmaking ..................................... 236
templates ...................................... 36
text
  copying ...................................... 54
  copying with drag and drop .............. 56
  cutting ....................................... 54
  deleting ...................................... 46
  finding ....................................... 58
  formatting, bold ........................... 98
  formatting, color .......................... 102
  formatting, font size ..................... 101
  formatting, font type ..................... 100
  formatting, italics ....................... 98
  formatting, underline .................... 98
  image, aligning with ..................... 137
importing .................................... 62
indenting ..................................... 108
inserting ...................................... 46
pasting ....................................... 54
replacing ............................................58

text box, forms .....................................222

themes
applying ...........................................114
themes

thumbnails ...........................................142

Title, Web page .......................................90

tools
hiding and displaying .........................22
moving ..................................................22
using ..................................................22
typeface, changing ......................100

U
underline ................................................98
undo .......................................................68
URL .......................................................15
user name .............................................248

V
verify, hyperlinks ..................................168
viewing
Hyperlinks view ..............................170
tasks ....................................................238
views
Hyperlinks view .........................170
Navigation view ............................171
Page ....................................................80
Reports view .................................240
Tasks view ...........................................238
Views panel ...........................................78

W
Web host
finding .............................................246

Web page
background, image .........................140
closing .............................................48
color, background .........................112
creating using a Wizard ..................38
creating, using templates ................36
deleting .............................................92
frames, adding to ...........................209
how they are saved .......................50
importing existing .........................40
importing from the Internet .............42
navigating .........................................84
opening .............................................26, 48
previewing in a browser .................88
printing .............................................86
renaming ..........................................91
saving ...............................................52
title, changing ...............................90

Web server
finding .............................................246
required information ......................248
transferring Web site to ..................253

Web site
external hyperlink, creating ..............160
internal hyperlink, creating ..............158
navigation bars ..............................176
options .............................................250
planning .........................................156
width

table .................................................200

Wizard
to create a new Web page .................38
World Wide Web, description of ..........14